Database: SAMPLE

Properties

Name: SAMPLE

Tables

Name | Tablespace | Description | Index tablespace | Long tablespace
USER.ACT | USERSPACE1 | This is the ACT table |  |
USER.CDSTAFF | TSCDSTAFF |  |  |
USER.CL_SCHED | USERSPACE1 | cl_sched comment |  |
USER.CONNHEADER_XXXXX | USERSPACE1 |  |  |
USER.CONTROL_XXXXX | USERSPACE1 |  |  |
USER.DB_XXXXX | USERSPACE1 |  |  |
USER.DBMEMUSE_XXXXX | USERSPACE1 |  |  |
USER.DEADLOCK_XXXXX | USERSPACE1 |  |  |
USER.DEPARTMENT | USERSPACE1 |  |  |
USER.DLCONN_XXXXX | USERSPACE1 |  |  |
USER.EMP_ACT | USERSPACE1 |  |  |
USER.EMP_PHOTO | USERSPACE1 |  |  |
USER.EMP_RESUME | USERSPACE1 |  |  |
USER.EMPLOYEE | USERSPACE1 |  |  |
ASN.IBMSNAP_APPENQ | TSASNAA |  |  |
ASN.IBMSNAP_APPLYTRACE | TSASNAA |  |  |
ASN.IBMSNAP_APPLYTRAIL | TSASNAA |  |  |
ASN.IBMSNAP_APPPARMS | TSASNAA |  |  |
ASN.IBMSNAP_CAPENQ | TSASNCA |  |  |
ASN.IBMSNAP_CAPMON | TSASNCA |  |  |
ASN.IBMSNAP_CAPPARMS | TSASNCA |  |  |
ASN.IBMSNAP_CAPSCHEMAS | TSASNCA |  |  |
ASN.IBMSNAP_CAPTRACE | TSASNCA |  |  |
ASN.IBMSNAP_COMPENSATE | TSASNAA |  |  |
ASN.IBMSNAP_PRUNCNTL | TSASNCA |  |  |
ASN.IBMSNAP_PRUNE_LOCK | TSASNCA |  |  |
ASN.IBMSNAP_PRUNE_SET | TSASNCA |  |  |
ASN.IBMSNAP_REGISTER | TSASNCA |  |  |
ASN.IBMSNAP_RESTART | TSASNCA |  |  |
ASN.IBMSNAP_SIGNAL | TSASNCA |  |  |
ASN.IBMSNAP_SUBS_COLS | TSASNAA |  |  |
ASN.IBMSNAP_SUBS_EVENT | TSASNAA |  |  |
ASN.IBMSNAP_SUBS_MEMBR | TSASNAA |  |  |
ASN.IBMSNAP_SUBS_SET | TSASNAA |  |  |
ASN.IBMSNAP_SUBS_STMTS | TSASNAA |  |  |
ASN.IBMSNAP_UOW | TSASNUOW |  |  |
USER.IN_TRAY | USERSPACE1 |  |  |
USER.ORG | USERSPACE1 |  |  |
USER.PROJECT | USERSPACE1 |  |  |
USER.SALES | USERSPACE1 |  |  |
USER.STAFF | USERSPACE1 |  |  |
Total: 41 table(s)

Indexes

Name | TABLE | Unique rule | Type | Description
USER.CC1151754616344 | USER.NICK_COLUMNS | PRIMARY | REGULAR |
USER.CC1151754705266 | USER.NICK_CHECK_CONSTRAINTS | PRIMARY | REGULAR |
USER.CC1151755626422 | USER.STAFF | PRIMARY | REGULAR |
USER.CC11517556264220 | USER.NICK_STAFF | PRIMARY | REGULAR |
USER.CC11517556264221 | USER.QQQ_STAFF | PRIMARY | REGULAR |
USER.CC1151755924953 | USER.ORG | PRIMARY | REGULAR |
USER.CC1151778928062 | USER.EMPLOYEE | PRIMARY | REGULAR |
ASN.IBMSNAP_APPENQX | ASN.IBMSNAP_APPENQ | UNIQUE | REGULAR |
ASN.IBMSNAP_APPLYTRACX | ASN.IBMSNAP_APPLYTRACE | DUBLICATE | REGULAR |
ASN.IBMSNAP_APPLYTRLX | ASN.IBMSNAP_APPLYTRAIL | DUBLICATE | REGULAR |
ASN.IBMSNAP_APPPARMSX | ASN.IBMSNAP_APPPARMS | UNIQUE | REGULAR |
ASN.IBMSNAP_CAPMONX | ASN.IBMSNAP_CAPMON | UNIQUE | REGULAR |
ASN.IBMSNAP_CAPSCHEMAX | ASN.IBMSNAP_CAPSCHEMAS | UNIQUE | REGULAR |
ASN.IBMSNAP_CAPTRACEX | ASN.IBMSNAP_CAPTRACE | DUBLICATE | REGULAR |
ASN.IBMSNAP_COMPENSATX | ASN.IBMSNAP_COMPENSATE | UNIQUE | REGULAR |
ASN.IBMSNAP_PRUNCNTLX | ASN.IBMSNAP_PRUNCNTL | UNIQUE | REGULAR |
ASN.IBMSNAP_PRUNCNTLX1 | ASN.IBMSNAP_PRUNCNTL | UNIQUE | REGULAR |
ASN.IBMSNAP_PRUNCNTLX2 | ASN.IBMSNAP_PRUNCNTL | DUBLICATE | REGULAR |
ASN.IBMSNAP_PRUNCNTLX3 | ASN.IBMSNAP_PRUNCNTL | DUBLICATE | REGULAR |
ASN.IBMSNAP_PRUNE_SETX | ASN.IBMSNAP_PRUNE_SET | UNIQUE | REGULAR |
ASN.IBMSNAP_REGISTERX | ASN.IBMSNAP_REGISTER | UNIQUE | REGULAR |
ASN.IBMSNAP_REGISTERX1 | ASN.IBMSNAP_REGISTER | DUBLICATE | REGULAR |
ASN.IBMSNAP_REGISTERX2 | ASN.IBMSNAP_REGISTER | DUBLICATE | REGULAR |
ASN.IBMSNAP_SIGNALX | ASN.IBMSNAP_SIGNAL | UNIQUE | REGULAR |
ASN.IBMSNAP_SUBS_COLSX | ASN.IBMSNAP_SUBS_COLS | UNIQUE | REGULAR |
ASN.IBMSNAP_SUBS_EVENX | ASN.IBMSNAP_SUBS_EVENT | UNIQUE | REGULAR |
ASN.IBMSNAP_SUBS_MEMBX | ASN.IBMSNAP_SUBS_MEMBR | UNIQUE | REGULAR |
ASN.IBMSNAP_SUBS_SETX | ASN.IBMSNAP_SUBS_SET | UNIQUE | REGULAR |
ASN.IBMSNAP_SUBS_STMTX | ASN.IBMSNAP_SUBS_STMTS | UNIQUE | REGULAR |
ASN.IBMSNAP_UOWX | ASN.IBMSNAP_UOW | UNIQUE | REGULAR |
USER.IXCDSTAFF | USER.CDSTAFF | UNIQUE | REGULAR |
USER.IXNICK_STAFF_MQT | USER.NICK_STAFF_MQT | UNIQUE | REGULAR |
USER.IXQQQ_STAFF_MQT | USER.QQQ_STAFF_MQT | UNIQUE | REGULAR |
USER.PK_ACT | USER.ACT | PRIMARY | REGULAR |
SYSIBM.SQL060616220800090 | USER.EMP_PHOTO | PRIMARY | REGULAR |
SYSIBM.SQL060616220803090 | USER.EMP_RESUME | PRIMARY | REGULAR |
USER.XACT2 | USER.ACT | UNIQUE | REGULAR |
USER.XACT3 | USER.ACT | DUBLICATE | REGULAR |
Total: 38 index(s)

Constraints

Name | Valid | TABLE
CC1151413049172 |  | USER.ACT
CC1151754626766 |  | USER.NICK_COLUMNS
CC1151754741688 |  | USER.NICK_CHECK_CONSTRAINTS
Total: 3 constraint(s)

Views

Name | Readonly | Valid | Description
USER.AAAAAAAAAAAA |  |  |
USER.VDEPT |  |  |
USER.VHDEPT |  |  |
Total: 3 view(s)

Aliases

Name | Parent | Description
USER.DEPT | USER.DEPARTMENT | sddddddddd
USER.EMP | USER.EMPLOYEE |
Total: 2 alias(es)

Nicknames

NAME | Cached | Remote server | Remote schema | Remote table
USER.NICK_CHECK_CONSTRAINTS |  | TEST | SYSIBM | CHECK_CONSTRAINTS
USER.NICK_COLUMNS |  | TEST | SYSIBM | COLUMNS
USER.NICK_COLUMNS_S |  | TEST | SYSIBM | COLUMNS_S
USER.NICK_REF_CONSTRAINTS |  | TEST | SYSIBM | REF_CONSTRAINTS
USER.NICK_REFERENTIAL_CONSTRAINTS |  | TEST | SYSIBM | REFERENTIAL_CONSTRAINTS
USER.NICK_SALES |  | TEST | USER | SALES
USER.NICK_STAFF |  | TEST | USER | STAFF
USER.QQQ_STAFF |  | TEST | USER | STAFF
Total: 8 nickname(s)

Materialised views

Name | Readonly | Valid | Cached table | Description
USER.NICK_STAFF_MQT |  |  | USER.NICK_STAFF |
USER.QQQ_STAFF_MQT |  |  | USER.QQQ_STAFF |
Total: 2 materialised view(s)

Procedures

Name | Specific name | Description
USER.BONUS_INCREASE | BONUS_INCREASE |
Total: 1 procedure(s)

Functions

Name | Specific name | Description
USER.RESIGN_EMPLOYEE | SQL060624144124500 |
Total: 1 function(s)

Triggers

Name | Table | Valid | Time | Event | Description
USER.TR_STAFF_BEFORE | USER.STAFF |  | BEFORE | DELETE |
Total: 1 trigger(s)

Packages

Name | Description
USER.P4434996 |
Total: 1 package(s)

Sequences

Name | Start | Increment | Min | Max | Cycle | Ordered | Cache | Description
USER.SAMPSEQUENCE | 1 | 1 | 1 | 9223372036854775807 |  |  | 20 |
Total: 1 sequence(s)

Datatypes

Name | Definer | Description
USER.NEW_TYPE2 | USER |
USER.PERSON_T | USER |
Total: 2 datatype(s)

Schemas

Name | Owner | Definer | Description
ASN | SYSIBM | USER |
NULLID | SYSIBM | USER |
SQLJ | SYSIBM | USER |
SYSCAT | SYSIBM | SYSIBM |
SYSFUN | SYSIBM | SYSIBM |
SYSIBM | SYSIBM | SYSIBM |
SYSPROC | SYSIBM | SYSIBM |
SYSSTAT | SYSIBM | SYSIBM |
SYSTOOLS | SYSIBM | DB2ADMIN |
USER | SYSIBM | USER |
Total: 10 schema(s)

Tablespaces

Tbspace | Definer | Description
NICK_STAFF_MQT_TS | USER |
QQQ_STAFF_MQT_TS | USER |
SYSCATSPACE | SYSIBM |
SYSTOOLSPACE | DB2ADMIN |
TEMPSPACE1 | SYSIBM |
TSASNAA | USER |
TSASNCA | USER |
TSASNUOW | USER |
TSCDSTAFF | USER |
USERSPACE1 | SYSIBM |
Total: 10 tablespace(s)

Bufferpools

Name | Size | Use extended memory
IBMDEFAULTBP | 250 |
Total: 1 bufferpool(s)

Eventmonitors

Name | Definer | Description
DB2DETAILDEADLOCK | USER |
XXXXX | USER |
Total: 2 eventmonitor(s)

Wrappers

Name | Library | Wraptype | Description
CONNECT | db2drda.dll | RELATIONAL |
Total: 1 wrapper(s)

Users

Name
DB2ADMIN
USER
Total: 2 user(s)

Groups

Name
PUBLIC
Total: 1 group(s)

See Also

Instance overview


List of tables

Tables

Name | Tablespace | Description | Index tablespace | Long tablespace
USER.ACT | USERSPACE1 | This is the ACT table |  |
USER.CDSTAFF | TSCDSTAFF |  |  |
USER.CL_SCHED | USERSPACE1 | cl_sched comment |  |
USER.CONNHEADER_XXXXX | USERSPACE1 |  |  |
USER.CONTROL_XXXXX | USERSPACE1 |  |  |
USER.DB_XXXXX | USERSPACE1 |  |  |
USER.DBMEMUSE_XXXXX | USERSPACE1 |  |  |
USER.DEADLOCK_XXXXX | USERSPACE1 |  |  |
USER.DEPARTMENT | USERSPACE1 |  |  |
USER.DLCONN_XXXXX | USERSPACE1 |  |  |
USER.EMP_ACT | USERSPACE1 |  |  |
USER.EMP_PHOTO | USERSPACE1 |  |  |
USER.EMP_RESUME | USERSPACE1 |  |  |
USER.EMPLOYEE | USERSPACE1 |  |  |
ASN.IBMSNAP_APPENQ | TSASNAA |  |  |
ASN.IBMSNAP_APPLYTRACE | TSASNAA |  |  |
ASN.IBMSNAP_APPLYTRAIL | TSASNAA |  |  |
ASN.IBMSNAP_APPPARMS | TSASNAA |  |  |
ASN.IBMSNAP_CAPENQ | TSASNCA |  |  |
ASN.IBMSNAP_CAPMON | TSASNCA |  |  |
ASN.IBMSNAP_CAPPARMS | TSASNCA |  |  |
ASN.IBMSNAP_CAPSCHEMAS | TSASNCA |  |  |
ASN.IBMSNAP_CAPTRACE | TSASNCA |  |  |
ASN.IBMSNAP_COMPENSATE | TSASNAA |  |  |
ASN.IBMSNAP_PRUNCNTL | TSASNCA |  |  |
ASN.IBMSNAP_PRUNE_LOCK | TSASNCA |  |  |
ASN.IBMSNAP_PRUNE_SET | TSASNCA |  |  |
ASN.IBMSNAP_REGISTER | TSASNCA |  |  |
ASN.IBMSNAP_RESTART | TSASNCA |  |  |
ASN.IBMSNAP_SIGNAL | TSASNCA |  |  |
ASN.IBMSNAP_SUBS_COLS | TSASNAA |  |  |
ASN.IBMSNAP_SUBS_EVENT | TSASNAA |  |  |
ASN.IBMSNAP_SUBS_MEMBR | TSASNAA |  |  |
ASN.IBMSNAP_SUBS_SET | TSASNAA |  |  |
ASN.IBMSNAP_SUBS_STMTS | TSASNAA |  |  |
ASN.IBMSNAP_UOW | TSASNUOW |  |  |
USER.IN_TRAY | USERSPACE1 |  |  |
USER.ORG | USERSPACE1 |  |  |
USER.PROJECT | USERSPACE1 |  |  |
USER.SALES | USERSPACE1 |  |  |
USER.STAFF | USERSPACE1 |  |  |
Total: 41 table(s)

See Also

Database overview


Table: USER.ACT

Properties

Name: | ACT
Schema: | USER
Status: | NORMAL
Create time: | 27.06.2006
Tablespace: | USERSPACE1
Index tablespace: |
Long tablespace: |
Base table schema: |
Base table: |
Rowtype schema: |
Rowtype name: |
Description: | This is the ACT table

Columns

Name | Type | Length | Scale | Codepage | Identity | Nulls | Default | Description
ACTNO | SMALLINT | 2 | 0 | 0 |  |  |  |
ACTKWD | CHARACTER | 6 | 0 | 1251 |  |  |  |
ACTDESC | VARCHAR | 20 | 0 | 1251 |  |  |  |
Total: 3 column(s)

Indexes

Name | Unique rule | Type | Colnames | Description
USER.PK_ACT | PRIMARY | REGULAR | ACTNO |
USER.XACT2 | UNIQUE | REGULAR | ACTNO, ACTKWD |
USER.XACT3 | DUBLICATE | REGULAR | ACTNO, ACTKWD, ACTDESC |
Total: 3 index(s)

Constraints

Name | Valid | Text
CC1151413049172 |  | ACTNO >1000
Total: 1 constraint(s)

Referencing tables

Table | Foreign key | Primary key
USER.QQQ_STAFF | CC1152703301094 | PK_ACT
Total: 1 referencing table(s)

Autherisations

Grantor | Grantee | Authorities
SYSIBM | USER | CONTROL=HELD, ALTER=HELD_GRANTABLE, DELETE=HELD_GRANTABLE, INDEX=HELD_GRANTABLE, INSERT=HELD_GRANTABLE, SELECT=HELD_GRANTABLE, REFERENCE=HELD_GRANTABLE, UPDATE=HELD_GRANTABLE
Total: 1 autherisation(s)

SQL

CREATE TABLE "USER "."ACT" (
"ACTNO" SMALLINT NOT NULL ,
"ACTKWD" CHAR(6) NOT NULL ,
"ACTDESC" VARCHAR(20) NOT NULL )
IN "USERSPACE1" ;

COMMENT ON TABLE "USER "."ACT" IS 'This is the ACT table';

CREATE UNIQUE INDEX "USER "."XACT2" ON "USER "."ACT"
("ACTNO" ASC,
"ACTKWD" ASC) ALLOW REVERSE SCANS;

CREATE INDEX "USER "."XACT3" ON "USER "."ACT"
("ACTNO" ASC,
"ACTKWD" ASC,
"ACTDESC" ASC) ALLOW REVERSE SCANS;

ALTER TABLE "USER "."ACT"
ADD CONSTRAINT "PK_ACT" PRIMARY KEY
("ACTNO");

ALTER TABLE "USER "."ACT"
ADD CONSTRAINT "CC1151413049172" CHECK
(ACTNO >1000)
ENFORCED
ENABLE QUERY OPTIMIZATION;

See Also

List of tables


Table: USER.CDSTAFF

Properties

Name: | CDSTAFF
Schema: | USER
Status: | NORMAL
Create time: | 01.07.2006
Tablespace: | TSCDSTAFF
Index tablespace: |
Long tablespace: |
Base table schema: |
Base table: |
Rowtype schema: |
Rowtype name: |
Description: |

Columns

Name | Type | Length | Scale | Codepage | Identity | Nulls | Default | Description
IBMSNAP_COMMITSEQ | CHARACTER | 10 | 0 | 0 |  |  |  |
IBMSNAP_INTENTSEQ | CHARACTER | 10 | 0 | 0 |  |  |  |
IBMSNAP_OPERATION | CHARACTER | 1 | 0 | 1251 |  |  |  |
ID | SMALLINT | 2 | 0 | 0 |  |  |  |
NAME | VARCHAR | 9 | 0 | 1251 |  |  |  |
DEPT | SMALLINT | 2 | 0 | 0 |  |  |  |
JOB | CHARACTER | 5 | 0 | 1251 |  |  |  |
YEARS | SMALLINT | 2 | 0 | 0 |  |  |  |
SALARY | DECIMAL | 7 | 2 | 0 |  |  |  |
COMM | DECIMAL | 7 | 2 | 0 |  |  |  |
Total: 10 column(s)

Indexes

Name | Unique rule | Type | Colnames | Description
USER.IXCDSTAFF | UNIQUE | REGULAR | IBMSNAP_COMMITSEQ, IBMSNAP_INTENTSEQ |
Total: 1 index(s)

Autherisations

Grantor | Grantee | Authorities
SYSIBM | USER | CONTROL=HELD, ALTER=HELD_GRANTABLE, DELETE=HELD_GRANTABLE, INDEX=HELD_GRANTABLE, INSERT=HELD_GRANTABLE, SELECT=HELD_GRANTABLE, REFERENCE=HELD_GRANTABLE, UPDATE=HELD_GRANTABLE
Total: 1 autherisation(s)

SQL

CREATE TABLE "USER "."CDSTAFF" (
"IBMSNAP_COMMITSEQ" CHAR(10) FOR BIT DATA NOT NULL ,
"IBMSNAP_INTENTSEQ" CHAR(10) FOR BIT DATA NOT NULL ,
"IBMSNAP_OPERATION" CHAR(1) NOT NULL ,
"ID" SMALLINT NOT NULL ,
"NAME" VARCHAR(9) ,
"DEPT" SMALLINT ,
"JOB" CHAR(5) ,
"YEARS" SMALLINT ,
"SALARY" DECIMAL(7,2) ,
"COMM" DECIMAL(7,2) )
IN "TSCDSTAFF" ;

ALTER TABLE "USER "."CDSTAFF" VOLATILE CARDINALITY;

CREATE UNIQUE INDEX "USER "."IXCDSTAFF" ON "USER "."CDSTAFF"
("IBMSNAP_COMMITSEQ" ASC,
"IBMSNAP_INTENTSEQ" ASC)
PCTFREE 0 ;

See Also

List of tables


Table: USER.CL_SCHED

Properties

Name: | CL_SCHED
Schema: | USER
Status: | NORMAL
Create time: | 16.06.2006
Tablespace: | USERSPACE1
Index tablespace: |
Long tablespace: |
Base table schema: |
Base table: |
Rowtype schema: |
Rowtype name: |
Description: | cl_sched comment

Columns

Name | Type | Length | Scale | Codepage | Identity | Nulls | Default | Description
CLASS_CODE | CHARACTER | 7 | 0 | 1251 |  |  |  |
DAY | SMALLINT | 2 | 0 | 0 |  |  |  |
STARTING | TIME | 3 | 0 | 0 |  |  |  |
ENDING | TIME | 3 | 0 | 0 |  |  |  |
Total: 4 column(s)

Autherisations

Grantor | Grantee | Authorities
SYSIBM | USER | CONTROL=HELD, ALTER=HELD_GRANTABLE, DELETE=HELD_GRANTABLE, INDEX=HELD_GRANTABLE, INSERT=HELD_GRANTABLE, SELECT=HELD_GRANTABLE, REFERENCE=HELD_GRANTABLE, UPDATE=HELD_GRANTABLE
Total: 1 autherisation(s)

SQL

CREATE TABLE "USER "."CL_SCHED" (
"CLASS_CODE" CHAR(7) ,
"DAY" SMALLINT ,
"STARTING" TIME ,
"ENDING" TIME )
IN "USERSPACE1" ;

COMMENT ON TABLE "USER "."CL_SCHED" IS 'cl_sched comment';

See Also

List of tables


Table: USER.CONNHEADER_XXXXX

Properties

Name: | CONNHEADER_XXXXX
Schema: | USER
Status: | NORMAL
Create time: | 01.07.2006
Tablespace: | USERSPACE1
Index tablespace: |
Long tablespace: |
Base table schema: |
Base table: |
Rowtype schema: |
Rowtype name: |
Description: |

Columns

Name | Type | Length | Scale | Codepage | Identity | Nulls | Default | Description
AGENT_ID | BIGINT | 8 | 0 | 0 |  |  |  |
APPL_ID | CHARACTER | 32 | 0 | 1251 |  |  |  |
APPL_NAME | VARCHAR | 255 | 0 | 1251 |  |  |  |
AUTH_ID | VARCHAR | 30 | 0 | 1251 |  |  |  |
CLIENT_DB_ALIAS | CHARACTER | 8 | 0 | 1251 |  |  |  |
CLIENT_NNAME | VARCHAR | 20 | 0 | 1251 |  |  |  |
CLIENT_PID | BIGINT | 8 | 0 | 0 |  |  |  |
CLIENT_PLATFORM | INTEGER | 4 | 0 | 0 |  |  |  |
CLIENT_PRDID | VARCHAR | 20 | 0 | 1251 |  |  |  |
CLIENT_PROTOCOL | INTEGER | 4 | 0 | 0 |  |  |  |
CODEPAGE_ID | INTEGER | 4 | 0 | 0 |  |  |  |
CONN_TIME | TIMESTAMP | 10 | 0 | 0 |  |  |  |
CORR_TOKEN | CHARACTER | 32 | 0 | 1251 |  |  |  |
EXECUTION_ID | VARCHAR | 30 | 0 | 1251 |  |  |  |
SEQUENCE_NO | CHARACTER | 4 | 0 | 1251 |  |  |  |
TERRITORY_CODE | INTEGER | 4 | 0 | 0 |  |  |  |
Total: 16 column(s)

Autherisations

Grantor | Grantee | Authorities
SYSIBM | USER | CONTROL=HELD, ALTER=HELD_GRANTABLE, DELETE=HELD_GRANTABLE, INDEX=HELD_GRANTABLE, INSERT=HELD_GRANTABLE, SELECT=HELD_GRANTABLE, REFERENCE=HELD_GRANTABLE, UPDATE=HELD_GRANTABLE
Total: 1 autherisation(s)

SQL

CREATE TABLE "USER "."CONNHEADER_XXXXX" (
"AGENT_ID" BIGINT NOT NULL ,
"APPL_ID" CHAR(32) NOT NULL ,
"APPL_NAME" VARCHAR(255) NOT NULL ,
"AUTH_ID" VARCHAR(30) NOT NULL ,
"CLIENT_DB_ALIAS" CHAR(8) NOT NULL ,
"CLIENT_NNAME" VARCHAR(20) NOT NULL ,
"CLIENT_PID" BIGINT NOT NULL ,
"CLIENT_PLATFORM" INTEGER NOT NULL ,
"CLIENT_PRDID" VARCHAR(20) NOT NULL ,
"CLIENT_PROTOCOL" INTEGER NOT NULL ,
"CODEPAGE_ID" INTEGER NOT NULL ,
"CONN_TIME" TIMESTAMP NOT NULL ,
"CORR_TOKEN" CHAR(32) NOT NULL ,
"EXECUTION_ID" VARCHAR(30) NOT NULL ,
"SEQUENCE_NO" CHAR(4) NOT NULL ,
"TERRITORY_CODE" INTEGER NOT NULL )
IN "USERSPACE1" ;

See Also

List of tables


Table: USER.CONTROL_XXXXX

Properties

Name: | CONTROL_XXXXX
Schema: | USER
Status: | NORMAL
Create time: | 01.07.2006
Tablespace: | USERSPACE1
Index tablespace: |
Long tablespace: |
Base table schema: |
Base table: |
Rowtype schema: |
Rowtype name: |
Description: |

Columns

Name | Type | Length | Scale | Codepage | Identity | Nulls | Default | Description
EVENT_MONITOR_NAME | VARCHAR | 128 | 0 | 1251 |  |  |  |
MESSAGE | VARCHAR | 128 | 0 | 1251 |  |  |  |
MESSAGE_TIME | TIMESTAMP | 10 | 0 | 0 |  |  |  |
Total: 3 column(s)

Autherisations

Grantor | Grantee | Authorities
SYSIBM | USER | CONTROL=HELD, ALTER=HELD_GRANTABLE, DELETE=HELD_GRANTABLE, INDEX=HELD_GRANTABLE, INSERT=HELD_GRANTABLE, SELECT=HELD_GRANTABLE, REFERENCE=HELD_GRANTABLE, UPDATE=HELD_GRANTABLE
Total: 1 autherisation(s)

SQL

CREATE TABLE "USER "."CONTROL_XXXXX" (
"EVENT_MONITOR_NAME" VARCHAR(128) NOT NULL ,
"MESSAGE" VARCHAR(128) NOT NULL ,
"MESSAGE_TIME" TIMESTAMP NOT NULL )
IN "USERSPACE1" ;

See Also

List of tables


Table: USER.DB_XXXXX

Properties

Name: | DB_XXXXX
Schema: | USER
Status: | NORMAL
Create time: | 01.07.2006
Tablespace: | USERSPACE1
Index tablespace: |
Long tablespace: |
Base table schema: |
Base table: |
Rowtype schema: |
Rowtype name: |
Description: |

Columns

Name | Type | Length | Scale | Codepage | Identity | Nulls | Default | Description
APPL_SECTION_INSERTS | BIGINT | 8 | 0 | 0 |  |  |  |
APPL_SECTION_LOOKUPS | BIGINT | 8 | 0 | 0 |  |  |  |
BINDS_PRECOMPILES | BIGINT | 8 | 0 | 0 |  |  |  |
CAT_CACHE_HEAP_FULL | BIGINT | 8 | 0 | 0 |  |  |  |
CAT_CACHE_INSERTS | BIGINT | 8 | 0 | 0 |  |  |  |
CAT_CACHE_LOOKUPS | BIGINT | 8 | 0 | 0 |  |  |  |
CAT_CACHE_OVERFLOWS | BIGINT | 8 | 0 | 0 |  |  |  |
CAT_CACHE_SIZE_TOP | BIGINT | 8 | 0 | 0 |  |  |  |
CATALOG_NODE | BIGINT | 8 | 0 | 0 |  |  |  |
CATALOG_NODE_NAME | VARCHAR | 32 | 0 | 1251 |  |  |  |
COMMIT_SQL_STMTS | BIGINT | 8 | 0 | 0 |  |  |  |
CONNECTIONS_TOP | BIGINT | 8 | 0 | 0 |  |  |  |
DB_HEAP_TOP | BIGINT | 8 | 0 | 0 |  |  |  |
DDL_SQL_STMTS | BIGINT | 8 | 0 | 0 |  |  |  |
DEADLOCKS | BIGINT | 8 | 0 | 0 |  |  |  |
DIRECT_READ_REQS | BIGINT | 8 | 0 | 0 |  |  |  |
DIRECT_READ_TIME | BIGINT | 8 | 0 | 0 |  |  |  |
DIRECT_READS | BIGINT | 8 | 0 | 0 |  |  |  |
DIRECT_WRITE_REQS | BIGINT | 8 | 0 | 0 |  |  |  |
DIRECT_WRITE_TIME | BIGINT | 8 | 0 | 0 |  |  |  |
DIRECT_WRITES | BIGINT | 8 | 0 | 0 |  |  |  |
DISCONN_TIME | TIMESTAMP | 10 | 0 | 0 |  |  |  |
DYNAMIC_SQL_STMTS | BIGINT | 8 | 0 | 0 |  |  |  |
ELAPSED_EXEC_TIME | BIGINT | 8 | 0 | 0 |  |  |  |
EVMON_ACTIVATES | BIGINT | 8 | 0 | 0 |  |  |  |
EVMON_FLUSHES | BIGINT | 8 | 0 | 0 |  |  |  |
FAILED_SQL_STMTS | BIGINT | 8 | 0 | 0 |  |  |  |
FILES_CLOSED | BIGINT | 8 | 0 | 0 |  |  |  |
HASH_JOIN_OVERFLOWS | BIGINT | 8 | 0 | 0 |  |  |  |
HASH_JOIN_SMALL_OVERFLOWS | BIGINT | 8 | 0 | 0 |  |  |  |
INT_AUTO_REBINDS | BIGINT | 8 | 0 | 0 |  |  |  |
INT_COMMITS | BIGINT | 8 | 0 | 0 |  |  |  |
INT_ROLLBACKS | BIGINT | 8 | 0 | 0 |  |  |  |
INT_ROWS_DELETED | BIGINT | 8 | 0 | 0 |  |  |  |
INT_ROWS_INSERTED | BIGINT | 8 | 0 | 0 |  |  |  |
INT_ROWS_UPDATED | BIGINT | 8 | 0 | 0 |  |  |  |
LOCK_ESCALS | BIGINT | 8 | 0 | 0 |  |  |  |
LOCK_TIMEOUTS | BIGINT | 8 | 0 | 0 |  |  |  |
LOCK_WAIT_TIME | BIGINT | 8 | 0 | 0 |  |  |  |
LOCK_WAITS | BIGINT | 8 | 0 | 0 |  |  |  |
LOG_FILE_ARCHIVE | BIGINT | 8 | 0 | 0 |  |  |  |
LOG_FILE_NUM_CURR | BIGINT | 8 | 0 | 0 |  |  |  |
LOG_FILE_NUM_FIRST | BIGINT | 8 | 0 | 0 |  |  |  |
LOG_FILE_NUM_LAST | BIGINT | 8 | 0 | 0 |  |  |  |
LOG_HELD_BY_DIRTY_PAGES | BIGINT | 8 | 0 | 0 |  |  |  |
LOG_READ_TIME | BIGINT | 8 | 0 | 0 |  |  |  |
LOG_READS | BIGINT | 8 | 0 | 0 |  |  |  |
LOG_TO_REDO_FOR_RECOVERY | BIGINT | 8 | 0 | 0 |  |  |  |
LOG_WRITE_TIME | BIGINT | 8 | 0 | 0 |  |  |  |
LOG_WRITES | BIGINT | 8 | 0 | 0 |  |  |  |
NUM_LOG_BUFF_FULL | BIGINT | 8 | 0 | 0 |  |  |  |
NUM_LOG_DATA_IN_BUFF | BIGINT | 8 | 0 | 0 |  |  |  |
NUM_LOG_PART_PAGE_IO | BIGINT | 8 | 0 | 0 |  |  |  |
NUM_LOG_READ_IO | BIGINT | 8 | 0 | 0 |  |  |  |
NUM_LOG_WRITE_IO | BIGINT | 8 | 0 | 0 |  |  |  |
PARTIAL_RECORD | SMALLINT | 2 | 0 | 0 |  |  |  |
PKG_CACHE_INSERTS | BIGINT | 8 | 0 | 0 |  |  |  |
PKG_CACHE_LOOKUPS | BIGINT | 8 | 0 | 0 |  |  |  |
PKG_CACHE_NUM_OVERFLOWS | BIGINT | 8 | 0 | 0 |  |  |  |
PKG_CACHE_SIZE_TOP | BIGINT | 8 | 0 | 0 |  |  |  |
POOL_ASYNC_DATA_READ_REQS | BIGINT | 8 | 0 | 0 |  |  |  |
POOL_ASYNC_DATA_READS | BIGINT | 8 | 0 | 0 |  |  |  |
POOL_ASYNC_DATA_WRITES | BIGINT | 8 | 0 | 0 |  |  |  |
POOL_ASYNC_INDEX_READ_REQS | BIGINT | 8 | 0 | 0 |  |  |  |
POOL_ASYNC_INDEX_READS | BIGINT | 8 | 0 | 0 |  |  |  |
POOL_ASYNC_INDEX_WRITES | BIGINT | 8 | 0 | 0 |  |  |  |
POOL_ASYNC_READ_TIME | BIGINT | 8 | 0 | 0 |  |  |  |
POOL_ASYNC_WRITE_TIME | BIGINT | 8 | 0 | 0 |  |  |  |
POOL_DATA_FROM_ESTORE | BIGINT | 8 | 0 | 0 |  |  |  |
POOL_DATA_L_READS | BIGINT | 8 | 0 | 0 |  |  |  |
POOL_DATA_P_READS | BIGINT | 8 | 0 | 0 |  |  |  |
POOL_DATA_TO_ESTORE | BIGINT | 8 | 0 | 0 |  |  |  |
POOL_DATA_WRITES | BIGINT | 8 | 0 | 0 |  |  |  |
POOL_DRTY_PG_STEAL_CLNS | BIGINT | 8 | 0 | 0 |  |  |  |
POOL_DRTY_PG_THRSH_CLNS | BIGINT | 8 | 0 | 0 |  |  |  |
POOL_INDEX_FROM_ESTORE | BIGINT | 8 | 0 | 0 |  |  |  |
POOL_INDEX_L_READS | BIGINT | 8 | 0 | 0 |  |  |  |
POOL_INDEX_P_READS | BIGINT | 8 | 0 | 0 |  |  |  |
POOL_INDEX_TO_ESTORE | BIGINT | 8 | 0 | 0 |  |  |  |
POOL_INDEX_WRITES | BIGINT | 8 | 0 | 0 |  |  |  |
POOL_LSN_GAP_CLNS | BIGINT | 8 | 0 | 0 |  |  |  |
POOL_NO_VICTIM_BUFFER | BIGINT | 8 | 0 | 0 |  |  |  |
POOL_READ_TIME | BIGINT | 8 | 0 | 0 |  |  |  |
POOL_TEMP_DATA_L_READS | BIGINT | 8 | 0 | 0 |  |  |  |
POOL_TEMP_DATA_P_READS | BIGINT | 8 | 0 | 0 |  |  |  |
POOL_TEMP_INDEX_L_READS | BIGINT | 8 | 0 | 0 |  |  |  |
POOL_TEMP_INDEX_P_READS | BIGINT | 8 | 0 | 0 |  |  |  |
POOL_WRITE_TIME | BIGINT | 8 | 0 | 0 |  |  |  |
PREFETCH_WAIT_TIME | BIGINT | 8 | 0 | 0 |  |  |  |
PRIV_WORKSPACE_NUM_OVERFLOWS | BIGINT | 8 | 0 | 0 |  |  |  |
PRIV_WORKSPACE_SECTION_INSERTS | BIGINT | 8 | 0 | 0 |  |  |  |
PRIV_WORKSPACE_SECTION_LOOKUPS | BIGINT | 8 | 0 | 0 |  |  |  |
PRIV_WORKSPACE_SIZE_TOP | BIGINT | 8 | 0 | 0 |  |  |  |
ROLLBACK_SQL_STMTS | BIGINT | 8 | 0 | 0 |  |  |  |
ROWS_DELETED | BIGINT | 8 | 0 | 0 |  |  |  |
ROWS_INSERTED | BIGINT | 8 | 0 | 0 |  |  |  |
ROWS_READ | BIGINT | 8 | 0 | 0 |  |  |  |
ROWS_SELECTED | BIGINT | 8 | 0 | 0 |  |  |  |
ROWS_UPDATED | BIGINT | 8 | 0 | 0 |  |  |  |
SEC_LOG_USED_TOP | BIGINT | 8 | 0 | 0 |  |  |  |
SELECT_SQL_STMTS | BIGINT | 8 | 0 | 0 |  |  |  |
SERVER_PLATFORM | INTEGER | 4 | 0 | 0 |  |  |  |
SHR_WORKSPACE_NUM_OVERFLOWS | BIGINT | 8 | 0 | 0 |  |  |  |
SHR_WORKSPACE_SECTION_INSERTS | BIGINT | 8 | 0 | 0 |  |  |  |
SHR_WORKSPACE_SECTION_LOOKUPS | BIGINT | 8 | 0 | 0 |  |  |  |
SHR_WORKSPACE_SIZE_TOP | BIGINT | 8 | 0 | 0 |  |  |  |
SORT_OVERFLOWS | BIGINT | 8 | 0 | 0 |  |  |  |
SORT_SHRHEAP_TOP | BIGINT | 8 | 0 | 0 |  |  |  |
STATIC_SQL_STMTS | BIGINT | 8 | 0 | 0 |  |  |  |
TOT_LOG_USED_TOP | BIGINT | 8 | 0 | 0 |  |  |  |
TOTAL_CONS | BIGINT | 8 | 0 | 0 |  |  |  |
TOTAL_HASH_JOINS | BIGINT | 8 | 0 | 0 |  |  |  |
TOTAL_HASH_LOOPS | BIGINT | 8 | 0 | 0 |  |  |  |
TOTAL_SORT_TIME | BIGINT | 8 | 0 | 0 |  |  |  |
TOTAL_SORTS | BIGINT | 8 | 0 | 0 |  |  |  |
UID_SQL_STMTS | BIGINT | 8 | 0 | 0 |  |  |  |
UNREAD_PREFETCH_PAGES | BIGINT | 8 | 0 | 0 |  |  |  |
X_LOCK_ESCALS | BIGINT | 8 | 0 | 0 |  |  |  |
Total: 118 column(s)

Autherisations

Grantor | Grantee | Authorities
SYSIBM | USER | CONTROL=HELD, ALTER=HELD_GRANTABLE, DELETE=HELD_GRANTABLE, INDEX=HELD_GRANTABLE, INSERT=HELD_GRANTABLE, SELECT=HELD_GRANTABLE, REFERENCE=HELD_GRANTABLE, UPDATE=HELD_GRANTABLE
Total: 1 autherisation(s)

SQL

CREATE TABLE "USER "."DB_XXXXX" (
"APPL_SECTION_INSERTS" BIGINT NOT NULL ,
"APPL_SECTION_LOOKUPS" BIGINT NOT NULL ,
"BINDS_PRECOMPILES" BIGINT NOT NULL ,
"CAT_CACHE_HEAP_FULL" BIGINT NOT NULL ,
"CAT_CACHE_INSERTS" BIGINT NOT NULL ,
"CAT_CACHE_LOOKUPS" BIGINT NOT NULL ,
"CAT_CACHE_OVERFLOWS" BIGINT NOT NULL ,
"CAT_CACHE_SIZE_TOP" BIGINT NOT NULL ,
"CATALOG_NODE" BIGINT NOT NULL ,
"CATALOG_NODE_NAME" VARCHAR(32) NOT NULL ,
"COMMIT_SQL_STMTS" BIGINT NOT NULL ,
"CONNECTIONS_TOP" BIGINT NOT NULL ,
"DB_HEAP_TOP" BIGINT NOT NULL ,
"DDL_SQL_STMTS" BIGINT NOT NULL ,
"DEADLOCKS" BIGINT NOT NULL ,
"DIRECT_READ_REQS" BIGINT NOT NULL ,
"DIRECT_READ_TIME" BIGINT NOT NULL ,
"DIRECT_READS" BIGINT NOT NULL ,
"DIRECT_WRITE_REQS" BIGINT NOT NULL ,
"DIRECT_WRITE_TIME" BIGINT NOT NULL ,
"DIRECT_WRITES" BIGINT NOT NULL ,
"DISCONN_TIME" TIMESTAMP NOT NULL ,
"DYNAMIC_SQL_STMTS" BIGINT NOT NULL ,
"ELAPSED_EXEC_TIME" BIGINT NOT NULL ,
"EVMON_ACTIVATES" BIGINT NOT NULL ,
"EVMON_FLUSHES" BIGINT NOT NULL ,
"FAILED_SQL_STMTS" BIGINT NOT NULL ,
"FILES_CLOSED" BIGINT NOT NULL ,
"HASH_JOIN_OVERFLOWS" BIGINT NOT NULL ,
"HASH_JOIN_SMALL_OVERFLOWS" BIGINT NOT NULL ,
"INT_AUTO_REBINDS" BIGINT NOT NULL ,
"INT_COMMITS" BIGINT NOT NULL ,
"INT_ROLLBACKS" BIGINT NOT NULL ,
"INT_ROWS_DELETED" BIGINT NOT NULL ,
"INT_ROWS_INSERTED" BIGINT NOT NULL ,
"INT_ROWS_UPDATED" BIGINT NOT NULL ,
"LOCK_ESCALS" BIGINT NOT NULL ,
"LOCK_TIMEOUTS" BIGINT NOT NULL ,
"LOCK_WAIT_TIME" BIGINT NOT NULL ,
"LOCK_WAITS" BIGINT NOT NULL ,
"LOG_FILE_ARCHIVE" BIGINT NOT NULL ,
"LOG_FILE_NUM_CURR" BIGINT NOT NULL ,
"LOG_FILE_NUM_FIRST" BIGINT NOT NULL ,
"LOG_FILE_NUM_LAST" BIGINT NOT NULL ,
"LOG_HELD_BY_DIRTY_PAGES" BIGINT NOT NULL ,
"LOG_READ_TIME" BIGINT NOT NULL ,
"LOG_READS" BIGINT NOT NULL ,
"LOG_TO_REDO_FOR_RECOVERY" BIGINT NOT NULL ,
"LOG_WRITE_TIME" BIGINT NOT NULL ,
"LOG_WRITES" BIGINT NOT NULL ,
"NUM_LOG_BUFF_FULL" BIGINT NOT NULL ,
"NUM_LOG_DATA_IN_BUFF" BIGINT NOT NULL ,
"NUM_LOG_PART_PAGE_IO" BIGINT NOT NULL ,
"NUM_LOG_READ_IO" BIGINT NOT NULL ,
"NUM_LOG_WRITE_IO" BIGINT NOT NULL ,
"PARTIAL_RECORD" SMALLINT NOT NULL ,
"PKG_CACHE_INSERTS" BIGINT NOT NULL ,
"PKG_CACHE_LOOKUPS" BIGINT NOT NULL ,
"PKG_CACHE_NUM_OVERFLOWS" BIGINT NOT NULL ,
"PKG_CACHE_SIZE_TOP" BIGINT NOT NULL ,
"POOL_ASYNC_DATA_READ_REQS" BIGINT NOT NULL ,
"POOL_ASYNC_DATA_READS" BIGINT NOT NULL ,
"POOL_ASYNC_DATA_WRITES" BIGINT NOT NULL ,
"POOL_ASYNC_INDEX_READ_REQS" BIGINT NOT NULL ,
"POOL_ASYNC_INDEX_READS" BIGINT NOT NULL ,
"POOL_ASYNC_INDEX_WRITES" BIGINT NOT NULL ,
"POOL_ASYNC_READ_TIME" BIGINT NOT NULL ,
"POOL_ASYNC_WRITE_TIME" BIGINT NOT NULL ,
"POOL_DATA_FROM_ESTORE" BIGINT NOT NULL ,
"POOL_DATA_L_READS" BIGINT NOT NULL ,
"POOL_DATA_P_READS" BIGINT NOT NULL ,
"POOL_DATA_TO_ESTORE" BIGINT NOT NULL ,
"POOL_DATA_WRITES" BIGINT NOT NULL ,
"POOL_DRTY_PG_STEAL_CLNS" BIGINT NOT NULL ,
"POOL_DRTY_PG_THRSH_CLNS" BIGINT NOT NULL ,
"POOL_INDEX_FROM_ESTORE" BIGINT NOT NULL ,
"POOL_INDEX_L_READS" BIGINT NOT NULL ,
"POOL_INDEX_P_READS" BIGINT NOT NULL ,
"POOL_INDEX_TO_ESTORE" BIGINT NOT NULL ,
"POOL_INDEX_WRITES" BIGINT NOT NULL ,
"POOL_LSN_GAP_CLNS" BIGINT NOT NULL ,
"POOL_NO_VICTIM_BUFFER" BIGINT NOT NULL ,
"POOL_READ_TIME" BIGINT NOT NULL ,
"POOL_TEMP_DATA_L_READS" BIGINT NOT NULL ,
"POOL_TEMP_DATA_P_READS" BIGINT NOT NULL ,
"POOL_TEMP_INDEX_L_READS" BIGINT NOT NULL ,
"POOL_TEMP_INDEX_P_READS" BIGINT NOT NULL ,
"POOL_WRITE_TIME" BIGINT NOT NULL ,
"PREFETCH_WAIT_TIME" BIGINT NOT NULL ,
"PRIV_WORKSPACE_NUM_OVERFLOWS" BIGINT NOT NULL ,
"PRIV_WORKSPACE_SECTION_INSERTS" BIGINT NOT NULL ,
"PRIV_WORKSPACE_SECTION_LOOKUPS" BIGINT NOT NULL ,
"PRIV_WORKSPACE_SIZE_TOP" BIGINT NOT NULL ,
"ROLLBACK_SQL_STMTS" BIGINT NOT NULL ,
"ROWS_DELETED" BIGINT NOT NULL ,
"ROWS_INSERTED" BIGINT NOT NULL ,
"ROWS_READ" BIGINT NOT NULL ,
"ROWS_SELECTED" BIGINT NOT NULL ,
"ROWS_UPDATED" BIGINT NOT NULL ,
"SEC_LOG_USED_TOP" BIGINT NOT NULL ,
"SELECT_SQL_STMTS" BIGINT NOT NULL ,
"SERVER_PLATFORM" INTEGER NOT NULL ,
"SHR_WORKSPACE_NUM_OVERFLOWS" BIGINT NOT NULL ,
"SHR_WORKSPACE_SECTION_INSERTS" BIGINT NOT NULL ,
"SHR_WORKSPACE_SECTION_LOOKUPS" BIGINT NOT NULL ,
"SHR_WORKSPACE_SIZE_TOP" BIGINT NOT NULL ,
"SORT_OVERFLOWS" BIGINT NOT NULL ,
"SORT_SHRHEAP_TOP" BIGINT NOT NULL ,
"STATIC_SQL_STMTS" BIGINT NOT NULL ,
"TOT_LOG_USED_TOP" BIGINT NOT NULL ,
"TOTAL_CONS" BIGINT NOT NULL ,
"TOTAL_HASH_JOINS" BIGINT NOT NULL ,
"TOTAL_HASH_LOOPS" BIGINT NOT NULL ,
"TOTAL_SORT_TIME" BIGINT NOT NULL ,
"TOTAL_SORTS" BIGINT NOT NULL ,
"UID_SQL_STMTS" BIGINT NOT NULL ,
"UNREAD_PREFETCH_PAGES" BIGINT NOT NULL ,
"X_LOCK_ESCALS" BIGINT NOT NULL )
IN "USERSPACE1" ;

See Also

List of tables


Table: USER.DBMEMUSE_XXXXX

Properties

Name: | DBMEMUSE_XXXXX
Schema: | USER
Status: | NORMAL
Create time: | 01.07.2006
Tablespace: | USERSPACE1
Index tablespace: |
Long tablespace: |
Base table schema: |
Base table: |
Rowtype schema: |
Rowtype name: |
Description: |

Columns

Name | Type | Length | Scale | Codepage | Identity | Nulls | Default | Description
EVMON_ACTIVATES | BIGINT | 8 | 0 | 0 |  |  |  |
EVMON_FLUSHES | BIGINT | 8 | 0 | 0 |  |  |  |
POOL_CUR_SIZE | BIGINT | 8 | 0 | 0 |  |  |  |
POOL_ID | BIGINT | 8 | 0 | 0 |  |  |  |
POOL_MAX_SIZE | BIGINT | 8 | 0 | 0 |  |  |  |
POOL_WATERMARK | BIGINT | 8 | 0 | 0 |  |  |  |
Total: 6 column(s)

Autherisations

Grantor | Grantee | Authorities
SYSIBM | USER | CONTROL=HELD, ALTER=HELD_GRANTABLE, DELETE=HELD_GRANTABLE, INDEX=HELD_GRANTABLE, INSERT=HELD_GRANTABLE, SELECT=HELD_GRANTABLE, REFERENCE=HELD_GRANTABLE, UPDATE=HELD_GRANTABLE
Total: 1 autherisation(s)

SQL

CREATE TABLE "USER "."DBMEMUSE_XXXXX" (
"EVMON_ACTIVATES" BIGINT NOT NULL ,
"EVMON_FLUSHES" BIGINT NOT NULL ,
"POOL_CUR_SIZE" BIGINT NOT NULL ,
"POOL_ID" BIGINT NOT NULL ,
"POOL_MAX_SIZE" BIGINT NOT NULL ,
"POOL_WATERMARK" BIGINT NOT NULL )
IN "USERSPACE1" ;

See Also

List of tables


Table: USER.DEADLOCK_XXXXX

Properties

Name: | DEADLOCK_XXXXX
Schema: | USER
Status: | NORMAL
Create time: | 01.07.2006
Tablespace: | USERSPACE1
Index tablespace: |
Long tablespace: |
Base table schema: |
Base table: |
Rowtype schema: |
Rowtype name: |
Description: |

Columns

Name | Type | Length | Scale | Codepage | Identity | Nulls | Default | Description
DEADLOCK_ID | BIGINT | 8 | 0 | 0 |  |  |  |
DL_CONNS | BIGINT | 8 | 0 | 0 |  |  |  |
EVMON_ACTIVATES | BIGINT | 8 | 0 | 0 |  |  |  |
ROLLED_BACK_AGENT_ID | BIGINT | 8 | 0 | 0 |  |  |  |
ROLLED_BACK_APPL_ID | CHARACTER | 32 | 0 | 1251 |  |  |  |
ROLLED_BACK_PARTICIPANT_NO | SMALLINT | 2 | 0 | 0 |  |  |  |
ROLLED_BACK_SEQUENCE_NO | CHARACTER | 4 | 0 | 1251 |  |  |  |
START_TIME | TIMESTAMP | 10 | 0 | 0 |  |  |  |
Total: 8 column(s)

Autherisations

Grantor | Grantee | Authorities
SYSIBM | USER | CONTROL=HELD, ALTER=HELD_GRANTABLE, DELETE=HELD_GRANTABLE, INDEX=HELD_GRANTABLE, INSERT=HELD_GRANTABLE, SELECT=HELD_GRANTABLE, REFERENCE=HELD_GRANTABLE, UPDATE=HELD_GRANTABLE
Total: 1 autherisation(s)

SQL

CREATE TABLE "USER "."DEADLOCK_XXXXX" (
"DEADLOCK_ID" BIGINT NOT NULL ,
"DL_CONNS" BIGINT NOT NULL ,
"EVMON_ACTIVATES" BIGINT NOT NULL ,
"ROLLED_BACK_AGENT_ID" BIGINT NOT NULL ,
"ROLLED_BACK_APPL_ID" CHAR(32) NOT NULL ,
"ROLLED_BACK_PARTICIPANT_NO" SMALLINT NOT NULL ,
"ROLLED_BACK_SEQUENCE_NO" CHAR(4) NOT NULL ,
"START_TIME" TIMESTAMP NOT NULL )
IN "USERSPACE1" ;

See Also

List of tables


Table: USER.DEPARTMENT

Properties

Name: | DEPARTMENT
Schema: | USER
Status: | NORMAL
Create time: | 16.06.2006
Tablespace: | USERSPACE1
Index tablespace: |
Long tablespace: |
Base table schema: |
Base table: |
Rowtype schema: |
Rowtype name: |
Description: |

Columns

Name | Type | Length | Scale | Codepage | Identity | Nulls | Default | Description
DEPTNO | CHARACTER | 3 | 0 | 1251 |  |  |  |
DEPTNAME | VARCHAR | 29 | 0 | 1251 |  |  |  |
MGRNO | CHARACTER | 6 | 0 | 1251 |  |  |  |
ADMRDEPT | CHARACTER | 3 | 0 | 1251 |  |  |  |
LOCATION | CHARACTER | 16 | 0 | 1251 |  |  |  |
Total: 5 column(s)

Dipendent objects

Name
USER.VDEPT
USER.VHDEPT
Total: 2 dipendent object(s)

Autherisations

Grantor | Grantee | Authorities
SYSIBM | USER | CONTROL=HELD, ALTER=HELD_GRANTABLE, DELETE=HELD_GRANTABLE, INDEX=HELD_GRANTABLE, INSERT=HELD_GRANTABLE, SELECT=HELD_GRANTABLE, REFERENCE=HELD_GRANTABLE, UPDATE=HELD_GRANTABLE
Total: 1 autherisation(s)

SQL

CREATE TABLE "USER "."DEPARTMENT" (
"DEPTNO" CHAR(3) NOT NULL ,
"DEPTNAME" VARCHAR(29) NOT NULL ,
"MGRNO" CHAR(6) ,
"ADMRDEPT" CHAR(3) NOT NULL ,
"LOCATION" CHAR(16) )
IN "USERSPACE1" ;

See Also

List of tables


Table: USER.DLCONN_XXXXX

Properties

Name: | DLCONN_XXXXX
Schema: | USER
Status: | NORMAL
Create time: | 01.07.2006
Tablespace: | USERSPACE1
Index tablespace: |
Long tablespace: |
Base table schema: |
Base table: |
Rowtype schema: |
Rowtype name: |
Description: |

Columns

Name | Type | Length | Scale | Codepage | Identity | Nulls | Default | Description
AGENT_ID | BIGINT | 8 | 0 | 0 |  |  |  |
APPL_ID | CHARACTER | 32 | 0 | 1251 |  |  |  |
APPL_ID_HOLDING_LK | CHARACTER | 32 | 0 | 1251 |  |  |  |
DEADLOCK_ID | BIGINT | 8 | 0 | 0 |  |  |  |
EVMON_ACTIVATES | BIGINT | 8 | 0 | 0 |  |  |  |
LOCK_ATTRIBUTES | BIGINT | 8 | 0 | 0 |  |  |  |
LOCK_COUNT | BIGINT | 8 | 0 | 0 |  |  |  |
LOCK_CURRENT_MODE | BIGINT | 8 | 0 | 0 |  |  |  |
LOCK_ESCALATION | SMALLINT | 2 | 0 | 0 |  |  |  |
LOCK_HOLD_COUNT | BIGINT | 8 | 0 | 0 |  |  |  |
LOCK_MODE | BIGINT | 8 | 0 | 0 |  |  |  |
LOCK_MODE_REQUESTED | BIGINT | 8 | 0 | 0 |  |  |  |
LOCK_NAME | CHARACTER | 13 | 0 | 1251 |  |  |  |
LOCK_NODE | BIGINT | 8 | 0 | 0 |  |  |  |
LOCK_OBJECT_NAME | BIGINT | 8 | 0 | 0 |  |  |  |
LOCK_OBJECT_TYPE | BIGINT | 8 | 0 | 0 |  |  |  |
LOCK_RELEASE_FLAGS | BIGINT | 8 | 0 | 0 |  |  |  |
LOCK_WAIT_START_TIME | TIMESTAMP | 10 | 0 | 0 |  |  |  |
PARTICIPANT_NO | SMALLINT | 2 | 0 | 0 |  |  |  |
PARTICIPANT_NO_HOLDING_LK | SMALLINT | 2 | 0 | 0 |  |  |  |
SEQUENCE_NO | CHARACTER | 4 | 0 | 1251 |  |  |  |
SEQUENCE_NO_HOLDING_LK | CHARACTER | 4 | 0 | 1251 |  |  |  |
START_TIME | TIMESTAMP | 10 | 0 | 0 |  |  |  |
TABLE_NAME | VARCHAR | 128 | 0 | 1251 |  |  |  |
TABLE_SCHEMA | VARCHAR | 30 | 0 | 1251 |  |  |  |
TABLESPACE_NAME | VARCHAR | 18 | 0 | 1251 |  |  |  |
Total: 26 column(s)

Autherisations

Grantor | Grantee | Authorities
SYSIBM | USER | CONTROL=HELD, ALTER=HELD_GRANTABLE, DELETE=HELD_GRANTABLE, INDEX=HELD_GRANTABLE, INSERT=HELD_GRANTABLE, SELECT=HELD_GRANTABLE, REFERENCE=HELD_GRANTABLE, UPDATE=HELD_GRANTABLE
Total: 1 autherisation(s)

SQL

CREATE TABLE "USER "."DLCONN_XXXXX" (
"AGENT_ID" BIGINT NOT NULL ,
"APPL_ID" CHAR(32) NOT NULL ,
"APPL_ID_HOLDING_LK" CHAR(32) NOT NULL ,
"DEADLOCK_ID" BIGINT NOT NULL ,
"EVMON_ACTIVATES" BIGINT NOT NULL ,
"LOCK_ATTRIBUTES" BIGINT NOT NULL ,
"LOCK_COUNT" BIGINT NOT NULL ,
"LOCK_CURRENT_MODE" BIGINT NOT NULL ,
"LOCK_ESCALATION" SMALLINT NOT NULL ,
"LOCK_HOLD_COUNT" BIGINT NOT NULL ,
"LOCK_MODE" BIGINT NOT NULL ,
"LOCK_MODE_REQUESTED" BIGINT NOT NULL ,
"LOCK_NAME" CHAR(13) NOT NULL ,
"LOCK_NODE" BIGINT NOT NULL ,
"LOCK_OBJECT_NAME" BIGINT NOT NULL ,
"LOCK_OBJECT_TYPE" BIGINT NOT NULL ,
"LOCK_RELEASE_FLAGS" BIGINT NOT NULL ,
"LOCK_WAIT_START_TIME" TIMESTAMP NOT NULL ,
"PARTICIPANT_NO" SMALLINT NOT NULL ,
"PARTICIPANT_NO_HOLDING_LK" SMALLINT NOT NULL ,
"SEQUENCE_NO" CHAR(4) NOT NULL ,
"SEQUENCE_NO_HOLDING_LK" CHAR(4) NOT NULL ,
"START_TIME" TIMESTAMP NOT NULL ,
"TABLE_NAME" VARCHAR(128) NOT NULL ,
"TABLE_SCHEMA" VARCHAR(30) NOT NULL ,
"TABLESPACE_NAME" VARCHAR(18) NOT NULL )
IN "USERSPACE1" ;

See Also

List of tables


Table: USER.EMP_ACT

Properties

Name: | EMP_ACT
Schema: | USER
Status: | NORMAL
Create time: | 16.06.2006
Tablespace: | USERSPACE1
Index tablespace: |
Long tablespace: |
Base table schema: |
Base table: |
Rowtype schema: |
Rowtype name: |
Description: |

Columns

Name | Type | Length | Scale | Codepage | Identity | Nulls | Default | Description
EMPNO | CHARACTER | 6 | 0 | 1251 |  |  |  |
PROJNO | CHARACTER | 6 | 0 | 1251 |  |  |  |
ACTNO | SMALLINT | 2 | 0 | 0 |  |  |  |
EMPTIME | DECIMAL | 5 | 2 | 0 |  |  |  |
EMSTDATE | DATE | 4 | 0 | 0 |  |  |  |
EMENDATE | DATE | 4 | 0 | 0 |  |  |  |
Total: 6 column(s)

Referenced tables

Table | Foreign key | Primary key
USER.EMPLOYEE | NOACTIONNOACTION | CC1151778928062
Total: 1 referenced table(s)

Autherisations

Grantor | Grantee | Authorities
SYSIBM | USER | CONTROL=HELD, ALTER=HELD_GRANTABLE, DELETE=HELD_GRANTABLE, INDEX=HELD_GRANTABLE, INSERT=HELD_GRANTABLE, SELECT=HELD_GRANTABLE, REFERENCE=HELD_GRANTABLE, UPDATE=HELD_GRANTABLE
Total: 1 autherisation(s)

SQL

CREATE TABLE "USER "."EMP_ACT" (
"EMPNO" CHAR(6) NOT NULL ,
"PROJNO" CHAR(6) NOT NULL ,
"ACTNO" SMALLINT NOT NULL ,
"EMPTIME" DECIMAL(5,2) ,
"EMSTDATE" DATE ,
"EMENDATE" DATE )
IN "USERSPACE1" ;

ALTER TABLE "USER "."EMP_ACT"
ADD CONSTRAINT "NOACTIONNOACTION" FOREIGN KEY
("EMPNO")
REFERENCES "USER "."EMPLOYEE"
("EMPNO")
ON DELETE NO ACTION
ON UPDATE NO ACTION
ENFORCED
ENABLE QUERY OPTIMIZATION;

See Also

List of tables


List of foreign keys

Foreign keys

Table | Foreign key | Primary key
USER.EMPLOYEE | NOACTIONNOACTION | CC1151778928062
Total: 1 foreign key(s)

See Also

Table [USER.EMP_ACT]


Foreign key: NOACTIONNOACTION

Properties

Name: | NOACTIONNOACTION
Table schema: | USER
Table: | USER.EMP_ACT
Definer: | USER
Reference key: | CC1151778928062
Reference schema: | USER
Reference table: | EMPLOYEE
Delete rule: | NO ACTION
Update rule: | NO ACTION
Create time: | 02.07.2006
Foreign key colnames: | EMPNO
Primary key colnames: | EMPNO

SQL

ALTER TABLE "USER "."EMP_ACT"
ADD CONSTRAINT "NOACTIONNOACTION" FOREIGN KEY
("EMPNO")
REFERENCES "USER "."EMPLOYEE"
("EMPNO")
ON DELETE NO ACTION
ON UPDATE NO ACTION
ENFORCED
ENABLE QUERY OPTIMIZATION;

See Also

List of foreign keys


Table: USER.EMP_PHOTO

Properties

Name: | EMP_PHOTO
Schema: | USER
Status: | NORMAL
Create time: | 16.06.2006
Tablespace: | USERSPACE1
Index tablespace: |
Long tablespace: |
Base table schema: |
Base table: |
Rowtype schema: |
Rowtype name: |
Description: |

Columns

Name | Type | Length | Scale | Codepage | Identity | Nulls | Default | Description
EMPNO | CHARACTER | 6 | 0 | 1251 |  |  |  |
PHOTO_FORMAT | VARCHAR | 10 | 0 | 1251 |  |  |  |
PICTURE | BLOB | 102400 | 0 | 0 |  |  |  |
Total: 3 column(s)

Indexes

Name | Unique rule | Type | Colnames | Description
SYSIBM.SQL060616220800090 | PRIMARY | REGULAR | EMPNO, PHOTO_FORMAT |
Total: 1 index(s)

Autherisations

Grantor | Grantee | Authorities
SYSIBM | USER | CONTROL=HELD, ALTER=HELD_GRANTABLE, DELETE=HELD_GRANTABLE, INDEX=HELD_GRANTABLE, INSERT=HELD_GRANTABLE, SELECT=HELD_GRANTABLE, REFERENCE=HELD_GRANTABLE, UPDATE=HELD_GRANTABLE
Total: 1 autherisation(s)

SQL

CREATE TABLE "USER "."EMP_PHOTO" (
"EMPNO" CHAR(6) NOT NULL ,
"PHOTO_FORMAT" VARCHAR(10) NOT NULL ,
"PICTURE" BLOB(102400) LOGGED NOT COMPACT )
IN "USERSPACE1" ;

ALTER TABLE "USER "."EMP_PHOTO"
ADD PRIMARY KEY
("EMPNO",
"PHOTO_FORMAT");

See Also

List of tables


Table: USER.EMP_RESUME

Properties

Name: | EMP_RESUME
Schema: | USER
Status: | NORMAL
Create time: | 16.06.2006
Tablespace: | USERSPACE1
Index tablespace: |
Long tablespace: |
Base table schema: |
Base table: |
Rowtype schema: |
Rowtype name: |
Description: |

Columns

Name | Type | Length | Scale | Codepage | Identity | Nulls | Default | Description
EMPNO | CHARACTER | 6 | 0 | 1251 |  |  |  |
RESUME_FORMAT | VARCHAR | 10 | 0 | 1251 |  |  |  |
RESUME | CLOB | 5120 | 0 | 1251 |  |  |  |
Total: 3 column(s)

Indexes

Name | Unique rule | Type | Colnames | Description
SYSIBM.SQL060616220803090 | PRIMARY | REGULAR | EMPNO, RESUME_FORMAT |
Total: 1 index(s)

Referenced tables

Table | Foreign key | Primary key
USER.EMPLOYEE | CC1151778995891 | CC1151778928062
Total: 1 referenced table(s)

Autherisations

Grantor | Grantee | Authorities
SYSIBM | USER | CONTROL=HELD, ALTER=HELD_GRANTABLE, DELETE=HELD_GRANTABLE, INDEX=HELD_GRANTABLE, INSERT=HELD_GRANTABLE, SELECT=HELD_GRANTABLE, REFERENCE=HELD_GRANTABLE, UPDATE=HELD_GRANTABLE
Total: 1 autherisation(s)

SQL

CREATE TABLE "USER "."EMP_RESUME" (
"EMPNO" CHAR(6) NOT NULL ,
"RESUME_FORMAT" VARCHAR(10) NOT NULL ,
"RESUME" CLOB(5120) LOGGED NOT COMPACT )
IN "USERSPACE1" ;

ALTER TABLE "USER "."EMP_RESUME"
ADD PRIMARY KEY
("EMPNO",
"RESUME_FORMAT");

ALTER TABLE "USER "."EMP_RESUME"
ADD CONSTRAINT "CC1151778995891" FOREIGN KEY
("EMPNO")
REFERENCES "USER "."EMPLOYEE"
("EMPNO")
ON DELETE RESTRICT
ON UPDATE RESTRICT
ENFORCED
ENABLE QUERY OPTIMIZATION;

See Also

List of tables


List of foreign keys

Foreign keys

Table | Foreign key | Primary key
USER.EMPLOYEE | CC1151778995891 | CC1151778928062
Total: 1 foreign key(s)

See Also

Table [USER.EMP_RESUME]


Foreign key: CC1151778995891

Properties

Name: | CC1151778995891
Table schema: | USER
Table: | USER.EMP_RESUME
Definer: | USER
Reference key: | CC1151778928062
Reference schema: | USER
Reference table: | EMPLOYEE
Delete rule: | RESTRICT
Update rule: | RESTRICT
Create time: | 01.07.2006
Foreign key colnames: | EMPNO
Primary key colnames: | EMPNO

SQL

ALTER TABLE "USER "."EMP_RESUME"
ADD CONSTRAINT "CC1151778995891" FOREIGN KEY
("EMPNO")
REFERENCES "USER "."EMPLOYEE"
("EMPNO")
ON DELETE RESTRICT
ON UPDATE RESTRICT
ENFORCED
ENABLE QUERY OPTIMIZATION;

See Also

List of foreign keys


Table: USER.EMPLOYEE

Properties

Name: | EMPLOYEE
Schema: | USER
Status: | NORMAL
Create time: | 16.06.2006
Tablespace: | USERSPACE1
Index tablespace: |
Long tablespace: |
Base table schema: |
Base table: |
Rowtype schema: |
Rowtype name: |
Description: |

Columns

Name | Type | Length | Scale | Codepage | Identity | Nulls | Default | Description
EMPNO | CHARACTER | 6 | 0 | 1251 |  |  |  |
FIRSTNME | VARCHAR | 12 | 0 | 1251 |  |  |  |
MIDINIT | CHARACTER | 1 | 0 | 1251 |  |  |  |
LASTNAME | VARCHAR | 15 | 0 | 1251 |  |  |  |
WORKDEPT | CHARACTER | 3 | 0 | 1251 |  |  |  |
PHONENO | CHARACTER | 4 | 0 | 1251 |  |  |  |
HIREDATE | DATE | 4 | 0 | 0 |  |  |  |
JOB | CHARACTER | 8 | 0 | 1251 |  |  |  |
EDLEVEL | SMALLINT | 2 | 0 | 0 |  |  |  |
SEX | CHARACTER | 1 | 0 | 1251 |  |  |  |
BIRTHDATE | DATE | 4 | 0 | 0 |  |  |  |
SALARY | DECIMAL | 9 | 2 | 0 |  |  |  |
BONUS | DECIMAL | 9 | 2 | 0 |  |  |  |
COMM | DECIMAL | 9 | 2 | 0 |  |  |  |
Total: 14 column(s)

Indexes

Name | Unique rule | Type | Colnames | Description
USER.CC1151778928062 | PRIMARY | REGULAR | EMPNO |
Total: 1 index(s)

Referencing tables

Table | Foreign key | Primary key
USER.EMP_RESUME | CC1151778995891 | CC1151778928062
USER.EMP_ACT | NOACTIONNOACTION | CC1151778928062
Total: 2 referencing table(s)

Autherisations

Grantor | Grantee | Authorities
SYSIBM | USER | CONTROL=HELD, ALTER=HELD_GRANTABLE, DELETE=HELD_GRANTABLE, INDEX=HELD_GRANTABLE, INSERT=HELD_GRANTABLE, SELECT=HELD_GRANTABLE, REFERENCE=HELD_GRANTABLE, UPDATE=HELD_GRANTABLE
Total: 1 autherisation(s)

SQL

CREATE TABLE "USER "."EMPLOYEE" (
"EMPNO" CHAR(6) NOT NULL ,
"FIRSTNME" VARCHAR(12) NOT NULL ,
"MIDINIT" CHAR(1) NOT NULL ,
"LASTNAME" VARCHAR(15) NOT NULL ,
"WORKDEPT" CHAR(3) ,
"PHONENO" CHAR(4) ,
"HIREDATE" DATE ,
"JOB" CHAR(8) ,
"EDLEVEL" SMALLINT NOT NULL ,
"SEX" CHAR(1) ,
"BIRTHDATE" DATE ,
"SALARY" DECIMAL(9,2) ,
"BONUS" DECIMAL(9,2) ,
"COMM" DECIMAL(9,2) )
IN "USERSPACE1" ;

ALTER TABLE "USER "."EMPLOYEE"
ADD CONSTRAINT "CC1151778928062" PRIMARY KEY
("EMPNO");

See Also

List of tables


Table: ASN.IBMSNAP_APPENQ

Properties

Name: | IBMSNAP_APPENQ
Schema: | ASN
Status: | NORMAL
Create time: | 01.07.2006
Tablespace: | TSASNAA
Index tablespace: |
Long tablespace: |
Base table schema: |
Base table: |
Rowtype schema: |
Rowtype name: |
Description: |

Columns

Name | Type | Length | Scale | Codepage | Identity | Nulls | Default | Description
APPLY_QUAL | CHARACTER | 18 | 0 | 1251 |  |  |  |
Total: 1 column(s)

Indexes

Name | Unique rule | Type | Colnames | Description
ASN.IBMSNAP_APPENQX | UNIQUE | REGULAR | APPLY_QUAL |
Total: 1 index(s)

Autherisations

Grantor | Grantee | Authorities
SYSIBM | USER | CONTROL=HELD, ALTER=HELD_GRANTABLE, DELETE=HELD_GRANTABLE, INDEX=HELD_GRANTABLE, INSERT=HELD_GRANTABLE, SELECT=HELD_GRANTABLE, REFERENCE=HELD_GRANTABLE, UPDATE=HELD_GRANTABLE
Total: 1 autherisation(s)

SQL

CREATE TABLE "ASN "."IBMSNAP_APPENQ" (
"APPLY_QUAL" CHAR(18) )
IN "TSASNAA" ;

CREATE UNIQUE INDEX "ASN "."IBMSNAP_APPENQX" ON "ASN "."IBMSNAP_APPENQ"
("APPLY_QUAL" ASC);

See Also

List of tables


Table: ASN.IBMSNAP_APPLYTRACE

Properties

Name: | IBMSNAP_APPLYTRACE
Schema: | ASN
Status: | NORMAL
Create time: | 01.07.2006
Tablespace: | TSASNAA
Index tablespace: |
Long tablespace: |
Base table schema: |
Base table: |
Rowtype schema: |
Rowtype name: |
Description: |

Columns

Name | Type | Length | Scale | Codepage | Identity | Nulls | Default | Description
APPLY_QUAL | CHARACTER | 18 | 0 | 1251 |  |  |  |
TRACE_TIME | TIMESTAMP | 10 | 0 | 0 |  |  |  |
OPERATION | CHARACTER | 8 | 0 | 1251 |  |  |  |
DESCRIPTION | VARCHAR | 1024 | 0 | 1251 |  |  |  |
Total: 4 column(s)

Indexes

Name | Unique rule | Type | Colnames | Description
ASN.IBMSNAP_APPLYTRACX | DUBLICATE | REGULAR | APPLY_QUAL, TRACE_TIME |
Total: 1 index(s)

Autherisations

Grantor | Grantee | Authorities
SYSIBM | USER | CONTROL=HELD, ALTER=HELD_GRANTABLE, DELETE=HELD_GRANTABLE, INDEX=HELD_GRANTABLE, INSERT=HELD_GRANTABLE, SELECT=HELD_GRANTABLE, REFERENCE=HELD_GRANTABLE, UPDATE=HELD_GRANTABLE
Total: 1 autherisation(s)

SQL

CREATE TABLE "ASN "."IBMSNAP_APPLYTRACE" (
"APPLY_QUAL" CHAR(18) NOT NULL ,
"TRACE_TIME" TIMESTAMP NOT NULL ,
"OPERATION" CHAR(8) NOT NULL ,
"DESCRIPTION" VARCHAR(1024) NOT NULL )
IN "TSASNAA" ;

CREATE INDEX "ASN "."IBMSNAP_APPLYTRACX" ON "ASN "."IBMSNAP_APPLYTRACE"
("APPLY_QUAL" ASC,
"TRACE_TIME" ASC);

See Also

List of tables


Table: ASN.IBMSNAP_APPLYTRAIL

Properties

Name: | IBMSNAP_APPLYTRAIL
Schema: | ASN
Status: | NORMAL
Create time: | 01.07.2006
Tablespace: | TSASNAA
Index tablespace: |
Long tablespace: |
Base table schema: |
Base table: |
Rowtype schema: |
Rowtype name: |
Description: |

Columns

Name | Type | Length | Scale | Codepage | Identity | Nulls | Default | Description
APPLY_QUAL | CHARACTER | 18 | 0 | 1251 |  |  |  |
SET_NAME | CHARACTER | 18 | 0 | 1251 |  |  |  |
SET_TYPE | CHARACTER | 1 | 0 | 1251 |  |  |  |
WHOS_ON_FIRST | CHARACTER | 1 | 0 | 1251 |  |  |  |
ASNLOAD | CHARACTER | 1 | 0 | 1251 |  |  |  |
FULL_REFRESH | CHARACTER | 1 | 0 | 1251 |  |  |  |
EFFECTIVE_MEMBERS | INTEGER | 4 | 0 | 0 |  |  |  |
SET_INSERTED | INTEGER | 4 | 0 | 0 |  |  |  |
SET_DELETED | INTEGER | 4 | 0 | 0 |  |  |  |
SET_UPDATED | INTEGER | 4 | 0 | 0 |  |  |  |
SET_REWORKED | INTEGER | 4 | 0 | 0 |  |  |  |
SET_REJECTED_TRXS | INTEGER | 4 | 0 | 0 |  |  |  |
STATUS | SMALLINT | 2 | 0 | 0 |  |  |  |
LASTRUN | TIMESTAMP | 10 | 0 | 0 |  |  |  |
LASTSUCCESS | TIMESTAMP | 10 | 0 | 0 |  |  |  |
SYNCHPOINT | CHARACTER | 10 | 0 | 0 |  |  |  |
SYNCHTIME | TIMESTAMP | 10 | 0 | 0 |  |  |  |
SOURCE_SERVER | CHARACTER | 18 | 0 | 1251 |  |  |  |
SOURCE_ALIAS | CHARACTER | 8 | 0 | 1251 |  |  |  |
SOURCE_OWNER | VARCHAR | 30 | 0 | 1251 |  |  |  |
SOURCE_TABLE | VARCHAR | 128 | 0 | 1251 |  |  |  |
SOURCE_VIEW_QUAL | SMALLINT | 2 | 0 | 0 |  |  |  |
TARGET_SERVER | CHARACTER | 18 | 0 | 1251 |  |  |  |
TARGET_ALIAS | CHARACTER | 8 | 0 | 1251 |  |  |  |
TARGET_OWNER | VARCHAR | 30 | 0 | 1251 |  |  |  |
TARGET_TABLE | VARCHAR | 128 | 0 | 1251 |  |  |  |
CAPTURE_SCHEMA | VARCHAR | 30 | 0 | 1251 |  |  |  |
TGT_CAPTURE_SCHEMA | VARCHAR | 30 | 0 | 1251 |  |  |  |
FEDERATED_SRC_SRVR | VARCHAR | 18 | 0 | 1251 |  |  |  |
FEDERATED_TGT_SRVR | VARCHAR | 18 | 0 | 1251 |  |  |  |
JRN_LIB | CHARACTER | 10 | 0 | 1251 |  |  |  |
JRN_NAME | CHARACTER | 10 | 0 | 1251 |  |  |  |
COMMIT_COUNT | SMALLINT | 2 | 0 | 0 |  |  |  |
OPTION_FLAGS | CHARACTER | 4 | 0 | 1251 |  |  |  |
EVENT_NAME | CHARACTER | 18 | 0 | 1251 |  |  |  |
ENDTIME | TIMESTAMP | 10 | 0 | 0 |  |  | CURRENT TIMESTAMP |
SOURCE_CONN_TIME | TIMESTAMP | 10 | 0 | 0 |  |  |  |
SQLSTATE | CHARACTER | 5 | 0 | 1251 |  |  |  |
SQLCODE | INTEGER | 4 | 0 | 0 |  |  |  |
SQLERRP | CHARACTER | 8 | 0 | 1251 |  |  |  |
SQLERRM | VARCHAR | 70 | 0 | 1251 |  |  |  |
APPERRM | VARCHAR | 760 | 0 | 1251 |  |  |  |
Total: 42 column(s)

Indexes

Name | Unique rule | Type | Colnames | Description
ASN.IBMSNAP_APPLYTRLX | DUBLICATE | REGULAR | LASTRUN, APPLY_QUAL |
Total: 1 index(s)

Autherisations

Grantor | Grantee | Authorities
SYSIBM | USER | CONTROL=HELD, ALTER=HELD_GRANTABLE, DELETE=HELD_GRANTABLE, INDEX=HELD_GRANTABLE, INSERT=HELD_GRANTABLE, SELECT=HELD_GRANTABLE, REFERENCE=HELD_GRANTABLE, UPDATE=HELD_GRANTABLE
Total: 1 autherisation(s)

SQL

CREATE TABLE "ASN "."IBMSNAP_APPLYTRAIL" (
"APPLY_QUAL" CHAR(18) NOT NULL ,
"SET_NAME" CHAR(18) NOT NULL ,
"SET_TYPE" CHAR(1) NOT NULL ,
"WHOS_ON_FIRST" CHAR(1) NOT NULL ,
"ASNLOAD" CHAR(1) ,
"FULL_REFRESH" CHAR(1) ,
"EFFECTIVE_MEMBERS" INTEGER ,
"SET_INSERTED" INTEGER NOT NULL ,
"SET_DELETED" INTEGER NOT NULL ,
"SET_UPDATED" INTEGER NOT NULL ,
"SET_REWORKED" INTEGER NOT NULL ,
"SET_REJECTED_TRXS" INTEGER NOT NULL ,
"STATUS" SMALLINT NOT NULL ,
"LASTRUN" TIMESTAMP NOT NULL ,
"LASTSUCCESS" TIMESTAMP ,
"SYNCHPOINT" CHAR(10) FOR BIT DATA ,
"SYNCHTIME" TIMESTAMP ,
"SOURCE_SERVER" CHAR(18) NOT NULL ,
"SOURCE_ALIAS" CHAR(8) ,
"SOURCE_OWNER" VARCHAR(30) ,
"SOURCE_TABLE" VARCHAR(128) ,
"SOURCE_VIEW_QUAL" SMALLINT ,
"TARGET_SERVER" CHAR(18) NOT NULL ,
"TARGET_ALIAS" CHAR(8) ,
"TARGET_OWNER" VARCHAR(30) NOT NULL ,
"TARGET_TABLE" VARCHAR(128) NOT NULL ,
"CAPTURE_SCHEMA" VARCHAR(30) NOT NULL ,
"TGT_CAPTURE_SCHEMA" VARCHAR(30) ,
"FEDERATED_SRC_SRVR" VARCHAR(18) ,
"FEDERATED_TGT_SRVR" VARCHAR(18) ,
"JRN_LIB" CHAR(10) ,
"JRN_NAME" CHAR(10) ,
"COMMIT_COUNT" SMALLINT ,
"OPTION_FLAGS" CHAR(4) NOT NULL ,
"EVENT_NAME" CHAR(18) ,
"ENDTIME" TIMESTAMP NOT NULL WITH DEFAULT ,
"SOURCE_CONN_TIME" TIMESTAMP ,
"SQLSTATE" CHAR(5) ,
"SQLCODE" INTEGER ,
"SQLERRP" CHAR(8) ,
"SQLERRM" VARCHAR(70) ,
"APPERRM" VARCHAR(760) )
IN "TSASNAA" ;

CREATE INDEX "ASN "."IBMSNAP_APPLYTRLX" ON "ASN "."IBMSNAP_APPLYTRAIL"
("LASTRUN" DESC,
"APPLY_QUAL" ASC);

See Also

List of tables


Table: ASN.IBMSNAP_APPPARMS

Properties

Name: | IBMSNAP_APPPARMS
Schema: | ASN
Status: | NORMAL
Create time: | 01.07.2006
Tablespace: | TSASNAA
Index tablespace: |
Long tablespace: |
Base table schema: |
Base table: |
Rowtype schema: |
Rowtype name: |
Description: |

Columns

Name | Type | Length | Scale | Codepage | Identity | Nulls | Default | Description
APPLY_QUAL | CHARACTER | 18 | 0 | 1251 |  |  |  |
APPLY_PATH | VARCHAR | 1040 | 0 | 1251 |  |  |  |
COPYONCE | CHARACTER | 1 | 0 | 1251 |  |  | 'N' |
DELAY | INTEGER | 4 | 0 | 0 |  |  | 6 |
ERRWAIT | INTEGER | 4 | 0 | 0 |  |  | 300 |
INAMSG | CHARACTER | 1 | 0 | 1251 |  |  | 'Y' |
LOADXIT | CHARACTER | 1 | 0 | 1251 |  |  | 'N' |
LOGREUSE | CHARACTER | 1 | 0 | 1251 |  |  | 'N' |
LOGSTDOUT | CHARACTER | 1 | 0 | 1251 |  |  | 'N' |
NOTIFY | CHARACTER | 1 | 0 | 1251 |  |  | 'N' |
OPT4ONE | CHARACTER | 1 | 0 | 1251 |  |  | 'N' |
SLEEP | CHARACTER | 1 | 0 | 1251 |  |  | 'Y' |
SQLERRCONTINUE | CHARACTER | 1 | 0 | 1251 |  |  | 'N' |
SPILLFILE | VARCHAR | 10 | 0 | 1251 |  |  | 'DISK' |
TERM | CHARACTER | 1 | 0 | 1251 |  |  | 'Y' |
TRLREUSE | CHARACTER | 1 | 0 | 1251 |  |  | 'N' |
Total: 16 column(s)

Indexes

Name | Unique rule | Type | Colnames | Description
ASN.IBMSNAP_APPPARMSX | UNIQUE | REGULAR | APPLY_QUAL |
Total: 1 index(s)

Autherisations

Grantor | Grantee | Authorities
SYSIBM | USER | CONTROL=HELD, ALTER=HELD_GRANTABLE, DELETE=HELD_GRANTABLE, INDEX=HELD_GRANTABLE, INSERT=HELD_GRANTABLE, SELECT=HELD_GRANTABLE, REFERENCE=HELD_GRANTABLE, UPDATE=HELD_GRANTABLE
Total: 1 autherisation(s)

SQL

CREATE TABLE "ASN "."IBMSNAP_APPPARMS" (
"APPLY_QUAL" CHAR(18) NOT NULL ,
"APPLY_PATH" VARCHAR(1040) ,
"COPYONCE" CHAR(1) WITH DEFAULT 'N' ,
"DELAY" INTEGER WITH DEFAULT 6 ,
"ERRWAIT" INTEGER WITH DEFAULT 300 ,
"INAMSG" CHAR(1) WITH DEFAULT 'Y' ,
"LOADXIT" CHAR(1) WITH DEFAULT 'N' ,
"LOGREUSE" CHAR(1) WITH DEFAULT 'N' ,
"LOGSTDOUT" CHAR(1) WITH DEFAULT 'N' ,
"NOTIFY" CHAR(1) WITH DEFAULT 'N' ,
"OPT4ONE" CHAR(1) WITH DEFAULT 'N' ,
"SLEEP" CHAR(1) WITH DEFAULT 'Y' ,
"SQLERRCONTINUE" CHAR(1) WITH DEFAULT 'N' ,
"SPILLFILE" VARCHAR(10) WITH DEFAULT 'DISK' ,
"TERM" CHAR(1) WITH DEFAULT 'Y' ,
"TRLREUSE" CHAR(1) WITH DEFAULT 'N' )
IN "TSASNAA" ;

CREATE UNIQUE INDEX "ASN "."IBMSNAP_APPPARMSX" ON "ASN "."IBMSNAP_APPPARMS"
("APPLY_QUAL" ASC);

See Also

List of tables


Table: ASN.IBMSNAP_CAPENQ

Properties

Name: | IBMSNAP_CAPENQ
Schema: | ASN
Status: | NORMAL
Create time: | 01.07.2006
Tablespace: | TSASNCA
Index tablespace: |
Long tablespace: |
Base table schema: |
Base table: |
Rowtype schema: |
Rowtype name: |
Description: |

Columns

Name | Type | Length | Scale | Codepage | Identity | Nulls | Default | Description
LOCK_NAME | CHARACTER | 9 | 0 | 1251 |  |  |  |
Total: 1 column(s)

Autherisations

Grantor | Grantee | Authorities
SYSIBM | USER | CONTROL=HELD, ALTER=HELD_GRANTABLE, DELETE=HELD_GRANTABLE, INDEX=HELD_GRANTABLE, INSERT=HELD_GRANTABLE, SELECT=HELD_GRANTABLE, REFERENCE=HELD_GRANTABLE, UPDATE=HELD_GRANTABLE
Total: 1 autherisation(s)

SQL

CREATE TABLE "ASN "."IBMSNAP_CAPENQ" (
"LOCK_NAME" CHAR(9) )
IN "TSASNCA" ;

See Also

List of tables


Table: ASN.IBMSNAP_CAPMON

Properties

Name: | IBMSNAP_CAPMON
Schema: | ASN
Status: | NORMAL
Create time: | 01.07.2006
Tablespace: | TSASNCA
Index tablespace: |
Long tablespace: |
Base table schema: |
Base table: |
Rowtype schema: |
Rowtype name: |
Description: |

Columns

Name | Type | Length | Scale | Codepage | Identity | Nulls | Default | Description
MONITOR_TIME | TIMESTAMP | 10 | 0 | 0 |  |  |  |
RESTART_TIME | TIMESTAMP | 10 | 0 | 0 |  |  |  |
CURRENT_MEMORY | INTEGER | 4 | 0 | 0 |  |  |  |
CD_ROWS_INSERTED | INTEGER | 4 | 0 | 0 |  |  |  |
RECAP_ROWS_SKIPPED | INTEGER | 4 | 0 | 0 |  |  |  |
TRIGR_ROWS_SKIPPED | INTEGER | 4 | 0 | 0 |  |  |  |
CHG_ROWS_SKIPPED | INTEGER | 4 | 0 | 0 |  |  |  |
TRANS_PROCESSED | INTEGER | 4 | 0 | 0 |  |  |  |
TRANS_SPILLED | INTEGER | 4 | 0 | 0 |  |  |  |
MAX_TRANS_SIZE | INTEGER | 4 | 0 | 0 |  |  |  |
LOCKING_RETRIES | INTEGER | 4 | 0 | 0 |  |  |  |
JRN_LIB | CHARACTER | 10 | 0 | 1251 |  |  |  |
JRN_NAME | CHARACTER | 10 | 0 | 1251 |  |  |  |
LOGREADLIMIT | INTEGER | 4 | 0 | 0 |  |  |  |
CAPTURE_IDLE | INTEGER | 4 | 0 | 0 |  |  |  |
SYNCHTIME | TIMESTAMP | 10 | 0 | 0 |  |  |  |
Total: 16 column(s)

Indexes

Name | Unique rule | Type | Colnames | Description
ASN.IBMSNAP_CAPMONX | UNIQUE | REGULAR | MONITOR_TIME |
Total: 1 index(s)

Autherisations

Grantor | Grantee | Authorities
SYSIBM | USER | CONTROL=HELD, ALTER=HELD_GRANTABLE, DELETE=HELD_GRANTABLE, INDEX=HELD_GRANTABLE, INSERT=HELD_GRANTABLE, SELECT=HELD_GRANTABLE, REFERENCE=HELD_GRANTABLE, UPDATE=HELD_GRANTABLE
Total: 1 autherisation(s)

SQL

CREATE TABLE "ASN "."IBMSNAP_CAPMON" (
"MONITOR_TIME" TIMESTAMP NOT NULL ,
"RESTART_TIME" TIMESTAMP NOT NULL ,
"CURRENT_MEMORY" INTEGER NOT NULL ,
"CD_ROWS_INSERTED" INTEGER NOT NULL ,
"RECAP_ROWS_SKIPPED" INTEGER NOT NULL ,
"TRIGR_ROWS_SKIPPED" INTEGER NOT NULL ,
"CHG_ROWS_SKIPPED" INTEGER NOT NULL ,
"TRANS_PROCESSED" INTEGER NOT NULL ,
"TRANS_SPILLED" INTEGER NOT NULL ,
"MAX_TRANS_SIZE" INTEGER NOT NULL ,
"LOCKING_RETRIES" INTEGER NOT NULL ,
"JRN_LIB" CHAR(10) ,
"JRN_NAME" CHAR(10) ,
"LOGREADLIMIT" INTEGER NOT NULL ,
"CAPTURE_IDLE" INTEGER NOT NULL ,
"SYNCHTIME" TIMESTAMP NOT NULL )
IN "TSASNCA" ;

CREATE UNIQUE INDEX "ASN "."IBMSNAP_CAPMONX" ON "ASN "."IBMSNAP_CAPMON"
("MONITOR_TIME" ASC);

See Also

List of tables


Table: ASN.IBMSNAP_CAPPARMS

Properties

Name: | IBMSNAP_CAPPARMS
Schema: | ASN
Status: | NORMAL
Create time: | 01.07.2006
Tablespace: | TSASNCA
Index tablespace: |
Long tablespace: |
Base table schema: |
Base table: |
Rowtype schema: |
Rowtype name: |
Description: |

Columns

Name | Type | Length | Scale | Codepage | Identity | Nulls | Default | Description
RETENTION_LIMIT | INTEGER | 4 | 0 | 0 |  |  |  |
LAG_LIMIT | INTEGER | 4 | 0 | 0 |  |  |  |
COMMIT_INTERVAL | INTEGER | 4 | 0 | 0 |  |  |  |
PRUNE_INTERVAL | INTEGER | 4 | 0 | 0 |  |  |  |
TRACE_LIMIT | INTEGER | 4 | 0 | 0 |  |  |  |
MONITOR_LIMIT | INTEGER | 4 | 0 | 0 |  |  |  |
MONITOR_INTERVAL | INTEGER | 4 | 0 | 0 |  |  |  |
MEMORY_LIMIT | SMALLINT | 2 | 0 | 0 |  |  |  |
REMOTE_SRC_SERVER | CHARACTER | 18 | 0 | 1251 |  |  |  |
AUTOPRUNE | CHARACTER | 1 | 0 | 1251 |  |  |  |
TERM | CHARACTER | 1 | 0 | 1251 |  |  |  |
AUTOSTOP | CHARACTER | 1 | 0 | 1251 |  |  |  |
LOGREUSE | CHARACTER | 1 | 0 | 1251 |  |  |  |
LOGSTDOUT | CHARACTER | 1 | 0 | 1251 |  |  |  |
SLEEP_INTERVAL | SMALLINT | 2 | 0 | 0 |  |  |  |
CAPTURE_PATH | VARCHAR | 1040 | 0 | 1251 |  |  |  |
STARTMODE | VARCHAR | 10 | 0 | 1251 |  |  |  |
Total: 17 column(s)

Autherisations

Grantor | Grantee | Authorities
SYSIBM | USER | CONTROL=HELD, ALTER=HELD_GRANTABLE, DELETE=HELD_GRANTABLE, INDEX=HELD_GRANTABLE, INSERT=HELD_GRANTABLE, SELECT=HELD_GRANTABLE, REFERENCE=HELD_GRANTABLE, UPDATE=HELD_GRANTABLE
Total: 1 autherisation(s)

SQL

CREATE TABLE "ASN "."IBMSNAP_CAPPARMS" (
"RETENTION_LIMIT" INTEGER ,
"LAG_LIMIT" INTEGER ,
"COMMIT_INTERVAL" INTEGER ,
"PRUNE_INTERVAL" INTEGER ,
"TRACE_LIMIT" INTEGER ,
"MONITOR_LIMIT" INTEGER ,
"MONITOR_INTERVAL" INTEGER ,
"MEMORY_LIMIT" SMALLINT ,
"REMOTE_SRC_SERVER" CHAR(18) ,
"AUTOPRUNE" CHAR(1) ,
"TERM" CHAR(1) ,
"AUTOSTOP" CHAR(1) ,
"LOGREUSE" CHAR(1) ,
"LOGSTDOUT" CHAR(1) ,
"SLEEP_INTERVAL" SMALLINT ,
"CAPTURE_PATH" VARCHAR(1040) ,
"STARTMODE" VARCHAR(10) )
IN "TSASNCA" ;

See Also

List of tables


Table: ASN.IBMSNAP_CAPSCHEMAS

Properties

Name: | IBMSNAP_CAPSCHEMAS
Schema: | ASN
Status: | NORMAL
Create time: | 01.07.2006
Tablespace: | TSASNCA
Index tablespace: |
Long tablespace: |
Base table schema: |
Base table: |
Rowtype schema: |
Rowtype name: |
Description: |

Columns

Name | Type | Length | Scale | Codepage | Identity | Nulls | Default | Description
CAP_SCHEMA_NAME | VARCHAR | 30 | 0 | 1251 |  |  |  |
Total: 1 column(s)

Indexes

Name | Unique rule | Type | Colnames | Description
ASN.IBMSNAP_CAPSCHEMAX | UNIQUE | REGULAR | CAP_SCHEMA_NAME |
Total: 1 index(s)

Autherisations

Grantor | Grantee | Authorities
SYSIBM | USER | CONTROL=HELD, ALTER=HELD_GRANTABLE, DELETE=HELD_GRANTABLE, INDEX=HELD_GRANTABLE, INSERT=HELD_GRANTABLE, SELECT=HELD_GRANTABLE, REFERENCE=HELD_GRANTABLE, UPDATE=HELD_GRANTABLE
Total: 1 autherisation(s)

SQL

CREATE TABLE "ASN "."IBMSNAP_CAPSCHEMAS" (
"CAP_SCHEMA_NAME" VARCHAR(30) )
IN "TSASNCA" ;

CREATE UNIQUE INDEX "ASN "."IBMSNAP_CAPSCHEMAX" ON "ASN "."IBMSNAP_CAPSCHEMAS"
("CAP_SCHEMA_NAME" ASC);

See Also

List of tables


Table: ASN.IBMSNAP_CAPTRACE

Properties

Name: | IBMSNAP_CAPTRACE
Schema: | ASN
Status: | NORMAL
Create time: | 01.07.2006
Tablespace: | TSASNCA
Index tablespace: |
Long tablespace: |
Base table schema: |
Base table: |
Rowtype schema: |
Rowtype name: |
Description: |

Columns

Name | Type | Length | Scale | Codepage | Identity | Nulls | Default | Description
OPERATION | CHARACTER | 8 | 0 | 1251 |  |  |  |
TRACE_TIME | TIMESTAMP | 10 | 0 | 0 |  |  |  |
DESCRIPTION | VARCHAR | 1024 | 0 | 1251 |  |  |  |
Total: 3 column(s)

Indexes

Name | Unique rule | Type | Colnames | Description
ASN.IBMSNAP_CAPTRACEX | DUBLICATE | REGULAR | TRACE_TIME |
Total: 1 index(s)

Autherisations

Grantor | Grantee | Authorities
SYSIBM | USER | CONTROL=HELD, ALTER=HELD_GRANTABLE, DELETE=HELD_GRANTABLE, INDEX=HELD_GRANTABLE, INSERT=HELD_GRANTABLE, SELECT=HELD_GRANTABLE, REFERENCE=HELD_GRANTABLE, UPDATE=HELD_GRANTABLE
Total: 1 autherisation(s)

SQL

CREATE TABLE "ASN "."IBMSNAP_CAPTRACE" (
"OPERATION" CHAR(8) NOT NULL ,
"TRACE_TIME" TIMESTAMP NOT NULL ,
"DESCRIPTION" VARCHAR(1024) NOT NULL )
IN "TSASNCA" ;

CREATE INDEX "ASN "."IBMSNAP_CAPTRACEX" ON "ASN "."IBMSNAP_CAPTRACE"
("TRACE_TIME" ASC);

See Also

List of tables


Table: ASN.IBMSNAP_COMPENSATE

Properties

Name: | IBMSNAP_COMPENSATE
Schema: | ASN
Status: | NORMAL
Create time: | 01.07.2006
Tablespace: | TSASNAA
Index tablespace: |
Long tablespace: |
Base table schema: |
Base table: |
Rowtype schema: |
Rowtype name: |
Description: |

Columns

Name | Type | Length | Scale | Codepage | Identity | Nulls | Default | Description
APPLY_QUAL | CHARACTER | 18 | 0 | 1251 |  |  |  |
MEMBER | SMALLINT | 2 | 0 | 0 |  |  |  |
INTENTSEQ | CHARACTER | 10 | 0 | 0 |  |  |  |
OPERATION | CHARACTER | 1 | 0 | 1251 |  |  |  |
Total: 4 column(s)

Indexes

Name | Unique rule | Type | Colnames | Description
ASN.IBMSNAP_COMPENSATX | UNIQUE | REGULAR | APPLY_QUAL, MEMBER |
Total: 1 index(s)

Autherisations

Grantor | Grantee | Authorities
SYSIBM | USER | CONTROL=HELD, ALTER=HELD_GRANTABLE, DELETE=HELD_GRANTABLE, INDEX=HELD_GRANTABLE, INSERT=HELD_GRANTABLE, SELECT=HELD_GRANTABLE, REFERENCE=HELD_GRANTABLE, UPDATE=HELD_GRANTABLE
Total: 1 autherisation(s)

SQL

CREATE TABLE "ASN "."IBMSNAP_COMPENSATE" (
"APPLY_QUAL" CHAR(18) NOT NULL ,
"MEMBER" SMALLINT NOT NULL ,
"INTENTSEQ" CHAR(10) FOR BIT DATA NOT NULL ,
"OPERATION" CHAR(1) NOT NULL )
IN "TSASNAA" ;

CREATE UNIQUE INDEX "ASN "."IBMSNAP_COMPENSATX" ON "ASN "."IBMSNAP_COMPENSATE"
("APPLY_QUAL" ASC,
"MEMBER" ASC);

See Also

List of tables


Table: ASN.IBMSNAP_PRUNCNTL

Properties

Name: | IBMSNAP_PRUNCNTL
Schema: | ASN
Status: | NORMAL
Create time: | 01.07.2006
Tablespace: | TSASNCA
Index tablespace: |
Long tablespace: |
Base table schema: |
Base table: |
Rowtype schema: |
Rowtype name: |
Description: |

Columns

Name | Type | Length | Scale | Codepage | Identity | Nulls | Default | Description
TARGET_SERVER | CHARACTER | 18 | 0 | 1251 |  |  |  |
TARGET_OWNER | VARCHAR | 30 | 0 | 1251 |  |  |  |
TARGET_TABLE | VARCHAR | 128 | 0 | 1251 |  |  |  |
SYNCHTIME | TIMESTAMP | 10 | 0 | 0 |  |  |  |
SYNCHPOINT | CHARACTER | 10 | 0 | 0 |  |  |  |
SOURCE_OWNER | VARCHAR | 30 | 0 | 1251 |  |  |  |
SOURCE_TABLE | VARCHAR | 128 | 0 | 1251 |  |  |  |
SOURCE_VIEW_QUAL | SMALLINT | 2 | 0 | 0 |  |  |  |
APPLY_QUAL | CHARACTER | 18 | 0 | 1251 |  |  |  |
SET_NAME | CHARACTER | 18 | 0 | 1251 |  |  |  |
CNTL_SERVER | CHARACTER | 18 | 0 | 1251 |  |  |  |
TARGET_STRUCTURE | SMALLINT | 2 | 0 | 0 |  |  |  |
CNTL_ALIAS | CHARACTER | 8 | 0 | 1251 |  |  |  |
PHYS_CHANGE_OWNER | VARCHAR | 30 | 0 | 1251 |  |  |  |
PHYS_CHANGE_TABLE | VARCHAR | 128 | 0 | 1251 |  |  |  |
MAP_ID | VARCHAR | 10 | 0 | 1251 |  |  |  |
Total: 16 column(s)

Indexes

Name | Unique rule | Type | Colnames | Description
ASN.IBMSNAP_PRUNCNTLX | UNIQUE | REGULAR | SOURCE_OWNER, SOURCE_TABLE, SOURCE_VIEW_QUAL, APPLY_QUAL, SET_NAME, TARGET_SERVER, TARGET_TABLE, TARGET_OWNER |
ASN.IBMSNAP_PRUNCNTLX1 | UNIQUE | REGULAR | MAP_ID |
ASN.IBMSNAP_PRUNCNTLX2 | DUBLICATE | REGULAR | PHYS_CHANGE_OWNER, PHYS_CHANGE_TABLE |
ASN.IBMSNAP_PRUNCNTLX3 | DUBLICATE | REGULAR | APPLY_QUAL, SET_NAME, TARGET_SERVER |
Total: 4 index(s)

Autherisations

Grantor | Grantee | Authorities
SYSIBM | USER | CONTROL=HELD, ALTER=HELD_GRANTABLE, DELETE=HELD_GRANTABLE, INDEX=HELD_GRANTABLE, INSERT=HELD_GRANTABLE, SELECT=HELD_GRANTABLE, REFERENCE=HELD_GRANTABLE, UPDATE=HELD_GRANTABLE
Total: 1 autherisation(s)

SQL

CREATE TABLE "ASN "."IBMSNAP_PRUNCNTL" (
"TARGET_SERVER" CHAR(18) NOT NULL ,
"TARGET_OWNER" VARCHAR(30) NOT NULL ,
"TARGET_TABLE" VARCHAR(128) NOT NULL ,
"SYNCHTIME" TIMESTAMP ,
"SYNCHPOINT" CHAR(10) FOR BIT DATA ,
"SOURCE_OWNER" VARCHAR(30) NOT NULL ,
"SOURCE_TABLE" VARCHAR(128) NOT NULL ,
"SOURCE_VIEW_QUAL" SMALLINT NOT NULL ,
"APPLY_QUAL" CHAR(18) NOT NULL ,
"SET_NAME" CHAR(18) NOT NULL ,
"CNTL_SERVER" CHAR(18) NOT NULL ,
"TARGET_STRUCTURE" SMALLINT NOT NULL ,
"CNTL_ALIAS" CHAR(8) ,
"PHYS_CHANGE_OWNER" VARCHAR(30) ,
"PHYS_CHANGE_TABLE" VARCHAR(128) ,
"MAP_ID" VARCHAR(10) NOT NULL )
IN "TSASNCA" ;

CREATE UNIQUE INDEX "ASN "."IBMSNAP_PRUNCNTLX" ON "ASN "."IBMSNAP_PRUNCNTL"
("SOURCE_OWNER" ASC,
"SOURCE_TABLE" ASC,
"SOURCE_VIEW_QUAL" ASC,
"APPLY_QUAL" ASC,
"SET_NAME" ASC,
"TARGET_SERVER" ASC,
"TARGET_TABLE" ASC,
"TARGET_OWNER" ASC);

CREATE UNIQUE INDEX "ASN "."IBMSNAP_PRUNCNTLX1" ON "ASN "."IBMSNAP_PRUNCNTL"
("MAP_ID" ASC);

CREATE INDEX "ASN "."IBMSNAP_PRUNCNTLX2" ON "ASN "."IBMSNAP_PRUNCNTL"
("PHYS_CHANGE_OWNER" ASC,
"PHYS_CHANGE_TABLE" ASC);

CREATE INDEX "ASN "."IBMSNAP_PRUNCNTLX3" ON "ASN "."IBMSNAP_PRUNCNTL"
("APPLY_QUAL" ASC,
"SET_NAME" ASC,
"TARGET_SERVER" ASC);

See Also

List of tables


Table: ASN.IBMSNAP_PRUNE_LOCK

Properties

Name: | IBMSNAP_PRUNE_LOCK
Schema: | ASN
Status: | NORMAL
Create time: | 01.07.2006
Tablespace: | TSASNCA
Index tablespace: |
Long tablespace: |
Base table schema: |
Base table: |
Rowtype schema: |
Rowtype name: |
Description: |

Columns

Name | Type | Length | Scale | Codepage | Identity | Nulls | Default | Description
DUMMY | CHARACTER | 1 | 0 | 1251 |  |  |  |
Total: 1 column(s)

Autherisations

Grantor | Grantee | Authorities
SYSIBM | USER | CONTROL=HELD, ALTER=HELD_GRANTABLE, DELETE=HELD_GRANTABLE, INDEX=HELD_GRANTABLE, INSERT=HELD_GRANTABLE, SELECT=HELD_GRANTABLE, REFERENCE=HELD_GRANTABLE, UPDATE=HELD_GRANTABLE
Total: 1 autherisation(s)

SQL

CREATE TABLE "ASN "."IBMSNAP_PRUNE_LOCK" (
"DUMMY" CHAR(1) )
IN "TSASNCA" ;

See Also

List of tables


Table: ASN.IBMSNAP_PRUNE_SET

Properties

Name: | IBMSNAP_PRUNE_SET
Schema: | ASN
Status: | NORMAL
Create time: | 01.07.2006
Tablespace: | TSASNCA
Index tablespace: |
Long tablespace: |
Base table schema: |
Base table: |
Rowtype schema: |
Rowtype name: |
Description: |

Columns

Name | Type | Length | Scale | Codepage | Identity | Nulls | Default | Description
TARGET_SERVER | CHARACTER | 18 | 0 | 1251 |  |  |  |
APPLY_QUAL | CHARACTER | 18 | 0 | 1251 |  |  |  |
SET_NAME | CHARACTER | 18 | 0 | 1251 |  |  |  |
SYNCHTIME | TIMESTAMP | 10 | 0 | 0 |  |  |  |
SYNCHPOINT | CHARACTER | 10 | 0 | 0 |  |  |  |
Total: 5 column(s)

Indexes

Name | Unique rule | Type | Colnames | Description
ASN.IBMSNAP_PRUNE_SETX | UNIQUE | REGULAR | TARGET_SERVER, APPLY_QUAL, SET_NAME |
Total: 1 index(s)

Autherisations

Grantor | Grantee | Authorities
SYSIBM | USER | CONTROL=HELD, ALTER=HELD_GRANTABLE, DELETE=HELD_GRANTABLE, INDEX=HELD_GRANTABLE, INSERT=HELD_GRANTABLE, SELECT=HELD_GRANTABLE, REFERENCE=HELD_GRANTABLE, UPDATE=HELD_GRANTABLE
Total: 1 autherisation(s)

SQL

CREATE TABLE "ASN "."IBMSNAP_PRUNE_SET" (
"TARGET_SERVER" CHAR(18) NOT NULL ,
"APPLY_QUAL" CHAR(18) NOT NULL ,
"SET_NAME" CHAR(18) NOT NULL ,
"SYNCHTIME" TIMESTAMP ,
"SYNCHPOINT" CHAR(10) FOR BIT DATA NOT NULL )
IN "TSASNCA" ;

CREATE UNIQUE INDEX "ASN "."IBMSNAP_PRUNE_SETX" ON "ASN "."IBMSNAP_PRUNE_SET"
("TARGET_SERVER" ASC,
"APPLY_QUAL" ASC,
"SET_NAME" ASC);

See Also

List of tables


Table: ASN.IBMSNAP_REGISTER

Properties

Name: | IBMSNAP_REGISTER
Schema: | ASN
Status: | NORMAL
Create time: | 01.07.2006
Tablespace: | TSASNCA
Index tablespace: |
Long tablespace: |
Base table schema: |
Base table: |
Rowtype schema: |
Rowtype name: |
Description: |

Columns

Name | Type | Length | Scale | Codepage | Identity | Nulls | Default | Description
SOURCE_OWNER | VARCHAR | 30 | 0 | 1251 |  |  |  |
SOURCE_TABLE | VARCHAR | 128 | 0 | 1251 |  |  |  |
SOURCE_VIEW_QUAL | SMALLINT | 2 | 0 | 0 |  |  |  |
GLOBAL_RECORD | CHARACTER | 1 | 0 | 1251 |  |  |  |
SOURCE_STRUCTURE | SMALLINT | 2 | 0 | 0 |  |  |  |
SOURCE_CONDENSED | CHARACTER | 1 | 0 | 1251 |  |  |  |
SOURCE_COMPLETE | CHARACTER | 1 | 0 | 1251 |  |  |  |
CD_OWNER | VARCHAR | 30 | 0 | 1251 |  |  |  |
CD_TABLE | VARCHAR | 128 | 0 | 1251 |  |  |  |
PHYS_CHANGE_OWNER | VARCHAR | 30 | 0 | 1251 |  |  |  |
PHYS_CHANGE_TABLE | VARCHAR | 128 | 0 | 1251 |  |  |  |
CD_OLD_SYNCHPOINT | CHARACTER | 10 | 0 | 0 |  |  |  |
CD_NEW_SYNCHPOINT | CHARACTER | 10 | 0 | 0 |  |  |  |
DISABLE_REFRESH | SMALLINT | 2 | 0 | 0 |  |  |  |
CCD_OWNER | VARCHAR | 30 | 0 | 1251 |  |  |  |
CCD_TABLE | VARCHAR | 128 | 0 | 1251 |  |  |  |
CCD_OLD_SYNCHPOINT | CHARACTER | 10 | 0 | 0 |  |  |  |
SYNCHPOINT | CHARACTER | 10 | 0 | 0 |  |  |  |
SYNCHTIME | TIMESTAMP | 10 | 0 | 0 |  |  |  |
CCD_CONDENSED | CHARACTER | 1 | 0 | 1251 |  |  |  |
CCD_COMPLETE | CHARACTER | 1 | 0 | 1251 |  |  |  |
ARCH_LEVEL | CHARACTER | 4 | 0 | 1251 |  |  |  |
DESCRIPTION | CHARACTER | 254 | 0 | 1251 |  |  |  |
BEFORE_IMG_PREFIX | VARCHAR | 4 | 0 | 1251 |  |  |  |
CONFLICT_LEVEL | CHARACTER | 1 | 0 | 1251 |  |  |  |
CHG_UPD_TO_DEL_INS | CHARACTER | 1 | 0 | 1251 |  |  |  |
CHGONLY | CHARACTER | 1 | 0 | 1251 |  |  |  |
RECAPTURE | CHARACTER | 1 | 0 | 1251 |  |  |  |
OPTION_FLAGS | CHARACTER | 4 | 0 | 1251 |  |  |  |
STOP_ON_ERROR | CHARACTER | 1 | 0 | 1251 |  |  | 'Y' |
STATE | CHARACTER | 1 | 0 | 1251 |  |  | 'I' |
STATE_INFO | CHARACTER | 8 | 0 | 1251 |  |  |  |
Total: 32 column(s)

Indexes

Name | Unique rule | Type | Colnames | Description
ASN.IBMSNAP_REGISTERX | UNIQUE | REGULAR | SOURCE_OWNER, SOURCE_TABLE, SOURCE_VIEW_QUAL |
ASN.IBMSNAP_REGISTERX1 | DUBLICATE | REGULAR | PHYS_CHANGE_OWNER, PHYS_CHANGE_TABLE |
ASN.IBMSNAP_REGISTERX2 | DUBLICATE | REGULAR | GLOBAL_RECORD |
Total: 3 index(s)

Autherisations

Grantor | Grantee | Authorities
SYSIBM | USER | CONTROL=HELD, ALTER=HELD_GRANTABLE, DELETE=HELD_GRANTABLE, INDEX=HELD_GRANTABLE, INSERT=HELD_GRANTABLE, SELECT=HELD_GRANTABLE, REFERENCE=HELD_GRANTABLE, UPDATE=HELD_GRANTABLE
Total: 1 autherisation(s)

SQL

CREATE TABLE "ASN "."IBMSNAP_REGISTER" (
"SOURCE_OWNER" VARCHAR(30) NOT NULL ,
"SOURCE_TABLE" VARCHAR(128) NOT NULL ,
"SOURCE_VIEW_QUAL" SMALLINT NOT NULL ,
"GLOBAL_RECORD" CHAR(1) NOT NULL ,
"SOURCE_STRUCTURE" SMALLINT NOT NULL ,
"SOURCE_CONDENSED" CHAR(1) NOT NULL ,
"SOURCE_COMPLETE" CHAR(1) NOT NULL ,
"CD_OWNER" VARCHAR(30) ,
"CD_TABLE" VARCHAR(128) ,
"PHYS_CHANGE_OWNER" VARCHAR(30) ,
"PHYS_CHANGE_TABLE" VARCHAR(128) ,
"CD_OLD_SYNCHPOINT" CHAR(10) FOR BIT DATA ,
"CD_NEW_SYNCHPOINT" CHAR(10) FOR BIT DATA ,
"DISABLE_REFRESH" SMALLINT NOT NULL ,
"CCD_OWNER" VARCHAR(30) ,
"CCD_TABLE" VARCHAR(128) ,
"CCD_OLD_SYNCHPOINT" CHAR(10) FOR BIT DATA ,
"SYNCHPOINT" CHAR(10) FOR BIT DATA ,
"SYNCHTIME" TIMESTAMP ,
"CCD_CONDENSED" CHAR(1) ,
"CCD_COMPLETE" CHAR(1) ,
"ARCH_LEVEL" CHAR(4) NOT NULL ,
"DESCRIPTION" CHAR(254) ,
"BEFORE_IMG_PREFIX" VARCHAR(4) ,
"CONFLICT_LEVEL" CHAR(1) ,
"CHG_UPD_TO_DEL_INS" CHAR(1) ,
"CHGONLY" CHAR(1) ,
"RECAPTURE" CHAR(1) ,
"OPTION_FLAGS" CHAR(4) NOT NULL ,
"STOP_ON_ERROR" CHAR(1) WITH DEFAULT 'Y' ,
"STATE" CHAR(1) WITH DEFAULT 'I' ,
"STATE_INFO" CHAR(8) )
IN "TSASNCA" ;

CREATE UNIQUE INDEX "ASN "."IBMSNAP_REGISTERX" ON "ASN "."IBMSNAP_REGISTER"
("SOURCE_OWNER" ASC,
"SOURCE_TABLE" ASC,
"SOURCE_VIEW_QUAL" ASC);

CREATE INDEX "ASN "."IBMSNAP_REGISTERX1" ON "ASN "."IBMSNAP_REGISTER"
("PHYS_CHANGE_OWNER" ASC,
"PHYS_CHANGE_TABLE" ASC);

CREATE INDEX "ASN "."IBMSNAP_REGISTERX2" ON "ASN "."IBMSNAP_REGISTER"
("GLOBAL_RECORD" ASC);

See Also

List of tables


Table: ASN.IBMSNAP_RESTART

Properties

Name: | IBMSNAP_RESTART
Schema: | ASN
Status: | NORMAL
Create time: | 01.07.2006
Tablespace: | TSASNCA
Index tablespace: |
Long tablespace: |
Base table schema: |
Base table: |
Rowtype schema: |
Rowtype name: |
Description: |

Columns

Name | Type | Length | Scale | Codepage | Identity | Nulls | Default | Description
MAX_COMMITSEQ | CHARACTER | 10 | 0 | 0 |  |  |  |
MAX_COMMIT_TIME | TIMESTAMP | 10 | 0 | 0 |  |  |  |
MIN_INFLIGHTSEQ | CHARACTER | 10 | 0 | 0 |  |  |  |
CURR_COMMIT_TIME | TIMESTAMP | 10 | 0 | 0 |  |  |  |
CAPTURE_FIRST_SEQ | CHARACTER | 10 | 0 | 0 |  |  |  |
Total: 5 column(s)

Autherisations

Grantor | Grantee | Authorities
SYSIBM | USER | CONTROL=HELD, ALTER=HELD_GRANTABLE, DELETE=HELD_GRANTABLE, INDEX=HELD_GRANTABLE, INSERT=HELD_GRANTABLE, SELECT=HELD_GRANTABLE, REFERENCE=HELD_GRANTABLE, UPDATE=HELD_GRANTABLE
Total: 1 autherisation(s)

SQL

CREATE TABLE "ASN "."IBMSNAP_RESTART" (
"MAX_COMMITSEQ" CHAR(10) FOR BIT DATA NOT NULL ,
"MAX_COMMIT_TIME" TIMESTAMP NOT NULL ,
"MIN_INFLIGHTSEQ" CHAR(10) FOR BIT DATA NOT NULL ,
"CURR_COMMIT_TIME" TIMESTAMP NOT NULL ,
"CAPTURE_FIRST_SEQ" CHAR(10) FOR BIT DATA NOT NULL )
IN "TSASNCA" ;

See Also

List of tables


Table: ASN.IBMSNAP_SIGNAL

Properties

Name: | IBMSNAP_SIGNAL
Schema: | ASN
Status: | NORMAL
Create time: | 01.07.2006
Tablespace: | TSASNCA
Index tablespace: |
Long tablespace: |
Base table schema: |
Base table: |
Rowtype schema: |
Rowtype name: |
Description: |

Columns

Name | Type | Length | Scale | Codepage | Identity | Nulls | Default | Description
SIGNAL_TIME | TIMESTAMP | 10 | 0 | 0 |  |  | CURRENT TIMESTAMP |
SIGNAL_TYPE | VARCHAR | 30 | 0 | 1251 |  |  |  |
SIGNAL_SUBTYPE | VARCHAR | 30 | 0 | 1251 |  |  |  |
SIGNAL_INPUT_IN | VARCHAR | 500 | 0 | 1251 |  |  |  |
SIGNAL_STATE | CHARACTER | 1 | 0 | 1251 |  |  |  |
SIGNAL_LSN | CHARACTER | 10 | 0 | 0 |  |  |  |
Total: 6 column(s)

Indexes

Name | Unique rule | Type | Colnames | Description
ASN.IBMSNAP_SIGNALX | UNIQUE | REGULAR | SIGNAL_TIME |
Total: 1 index(s)

Autherisations

Grantor | Grantee | Authorities
SYSIBM | USER | CONTROL=HELD, ALTER=HELD_GRANTABLE, DELETE=HELD_GRANTABLE, INDEX=HELD_GRANTABLE, INSERT=HELD_GRANTABLE, SELECT=HELD_GRANTABLE, REFERENCE=HELD_GRANTABLE, UPDATE=HELD_GRANTABLE
Total: 1 autherisation(s)

SQL

CREATE TABLE "ASN "."IBMSNAP_SIGNAL" (
"SIGNAL_TIME" TIMESTAMP NOT NULL WITH DEFAULT ,
"SIGNAL_TYPE" VARCHAR(30) NOT NULL ,
"SIGNAL_SUBTYPE" VARCHAR(30) ,
"SIGNAL_INPUT_IN" VARCHAR(500) ,
"SIGNAL_STATE" CHAR(1) NOT NULL ,
"SIGNAL_LSN" CHAR(10) FOR BIT DATA )
DATA CAPTURE CHANGES
IN "TSASNCA" ;

CREATE UNIQUE INDEX "ASN "."IBMSNAP_SIGNALX" ON "ASN "."IBMSNAP_SIGNAL"
("SIGNAL_TIME" ASC);

See Also

List of tables


Table: ASN.IBMSNAP_SUBS_COLS

Properties

Name: | IBMSNAP_SUBS_COLS
Schema: | ASN
Status: | NORMAL
Create time: | 01.07.2006
Tablespace: | TSASNAA
Index tablespace: |
Long tablespace: |
Base table schema: |
Base table: |
Rowtype schema: |
Rowtype name: |
Description: |

Columns

Name | Type | Length | Scale | Codepage | Identity | Nulls | Default | Description
APPLY_QUAL | CHARACTER | 18 | 0 | 1251 |  |  |  |
SET_NAME | CHARACTER | 18 | 0 | 1251 |  |  |  |
WHOS_ON_FIRST | CHARACTER | 1 | 0 | 1251 |  |  |  |
TARGET_OWNER | VARCHAR | 30 | 0 | 1251 |  |  |  |
TARGET_TABLE | VARCHAR | 128 | 0 | 1251 |  |  |  |
COL_TYPE | CHARACTER | 1 | 0 | 1251 |  |  |  |
TARGET_NAME | VARCHAR | 30 | 0 | 1251 |  |  |  |
IS_KEY | CHARACTER | 1 | 0 | 1251 |  |  |  |
COLNO | SMALLINT | 2 | 0 | 0 |  |  |  |
EXPRESSION | VARCHAR | 254 | 0 | 1251 |  |  |  |
Total: 10 column(s)

Indexes

Name | Unique rule | Type | Colnames | Description
ASN.IBMSNAP_SUBS_COLSX | UNIQUE | REGULAR | APPLY_QUAL, SET_NAME, WHOS_ON_FIRST, TARGET_OWNER, TARGET_TABLE, TARGET_NAME |
Total: 1 index(s)

Autherisations

Grantor | Grantee | Authorities
SYSIBM | USER | CONTROL=HELD, ALTER=HELD_GRANTABLE, DELETE=HELD_GRANTABLE, INDEX=HELD_GRANTABLE, INSERT=HELD_GRANTABLE, SELECT=HELD_GRANTABLE, REFERENCE=HELD_GRANTABLE, UPDATE=HELD_GRANTABLE
Total: 1 autherisation(s)

SQL

CREATE TABLE "ASN "."IBMSNAP_SUBS_COLS" (
"APPLY_QUAL" CHAR(18) NOT NULL ,
"SET_NAME" CHAR(18) NOT NULL ,
"WHOS_ON_FIRST" CHAR(1) NOT NULL ,
"TARGET_OWNER" VARCHAR(30) NOT NULL ,
"TARGET_TABLE" VARCHAR(128) NOT NULL ,
"COL_TYPE" CHAR(1) NOT NULL ,
"TARGET_NAME" VARCHAR(30) NOT NULL ,
"IS_KEY" CHAR(1) NOT NULL ,
"COLNO" SMALLINT NOT NULL ,
"EXPRESSION" VARCHAR(254) NOT NULL )
IN "TSASNAA" ;

CREATE UNIQUE INDEX "ASN "."IBMSNAP_SUBS_COLSX" ON "ASN "."IBMSNAP_SUBS_COLS"
("APPLY_QUAL" ASC,
"SET_NAME" ASC,
"WHOS_ON_FIRST" ASC,
"TARGET_OWNER" ASC,
"TARGET_TABLE" ASC,
"TARGET_NAME" ASC);

See Also

List of tables


Table: ASN.IBMSNAP_SUBS_EVENT

Properties

Name: | IBMSNAP_SUBS_EVENT
Schema: | ASN
Status: | NORMAL
Create time: | 01.07.2006
Tablespace: | TSASNAA
Index tablespace: |
Long tablespace: |
Base table schema: |
Base table: |
Rowtype schema: |
Rowtype name: |
Description: |

Columns

Name | Type | Length | Scale | Codepage | Identity | Nulls | Default | Description
EVENT_NAME | CHARACTER | 18 | 0 | 1251 |  |  |  |
EVENT_TIME | TIMESTAMP | 10 | 0 | 0 |  |  |  |
END_SYNCHPOINT | CHARACTER | 10 | 0 | 0 |  |  |  |
END_OF_PERIOD | TIMESTAMP | 10 | 0 | 0 |  |  |  |
Total: 4 column(s)

Indexes

Name | Unique rule | Type | Colnames | Description
ASN.IBMSNAP_SUBS_EVENX | UNIQUE | REGULAR | EVENT_NAME, EVENT_TIME |
Total: 1 index(s)

Autherisations

Grantor | Grantee | Authorities
SYSIBM | USER | CONTROL=HELD, ALTER=HELD_GRANTABLE, DELETE=HELD_GRANTABLE, INDEX=HELD_GRANTABLE, INSERT=HELD_GRANTABLE, SELECT=HELD_GRANTABLE, REFERENCE=HELD_GRANTABLE, UPDATE=HELD_GRANTABLE
Total: 1 autherisation(s)

SQL

CREATE TABLE "ASN "."IBMSNAP_SUBS_EVENT" (
"EVENT_NAME" CHAR(18) NOT NULL ,
"EVENT_TIME" TIMESTAMP NOT NULL ,
"END_SYNCHPOINT" CHAR(10) FOR BIT DATA ,
"END_OF_PERIOD" TIMESTAMP )
IN "TSASNAA" ;

CREATE UNIQUE INDEX "ASN "."IBMSNAP_SUBS_EVENX" ON "ASN "."IBMSNAP_SUBS_EVENT"
("EVENT_NAME" ASC,
"EVENT_TIME" ASC);

See Also

List of tables


Table: ASN.IBMSNAP_SUBS_MEMBR

Properties

Name: | IBMSNAP_SUBS_MEMBR
Schema: | ASN
Status: | NORMAL
Create time: | 01.07.2006
Tablespace: | TSASNAA
Index tablespace: |
Long tablespace: |
Base table schema: |
Base table: |
Rowtype schema: |
Rowtype name: |
Description: |

Columns

Name | Type | Length | Scale | Codepage | Identity | Nulls | Default | Description
APPLY_QUAL | CHARACTER | 18 | 0 | 1251 |  |  |  |
SET_NAME | CHARACTER | 18 | 0 | 1251 |  |  |  |
WHOS_ON_FIRST | CHARACTER | 1 | 0 | 1251 |  |  |  |
SOURCE_OWNER | VARCHAR | 30 | 0 | 1251 |  |  |  |
SOURCE_TABLE | VARCHAR | 128 | 0 | 1251 |  |  |  |
SOURCE_VIEW_QUAL | SMALLINT | 2 | 0 | 0 |  |  |  |
TARGET_OWNER | VARCHAR | 30 | 0 | 1251 |  |  |  |
TARGET_TABLE | VARCHAR | 128 | 0 | 1251 |  |  |  |
TARGET_CONDENSED | CHARACTER | 1 | 0 | 1251 |  |  |  |
TARGET_COMPLETE | CHARACTER | 1 | 0 | 1251 |  |  |  |
TARGET_STRUCTURE | SMALLINT | 2 | 0 | 0 |  |  |  |
PREDICATES | VARCHAR | 1024 | 0 | 1251 |  |  |  |
MEMBER_STATE | CHARACTER | 1 | 0 | 1251 |  |  |  |
TARGET_KEY_CHG | CHARACTER | 1 | 0 | 1251 |  |  |  |
UOW_CD_PREDICATES | VARCHAR | 1024 | 0 | 1251 |  |  |  |
JOIN_UOW_CD | CHARACTER | 1 | 0 | 1251 |  |  |  |
LOADX_TYPE | SMALLINT | 2 | 0 | 0 |  |  |  |
LOADX_SRC_N_OWNER | VARCHAR | 30 | 0 | 1251 |  |  |  |
LOADX_SRC_N_TABLE | VARCHAR | 128 | 0 | 1251 |  |  |  |
Total: 19 column(s)

Indexes

Name | Unique rule | Type | Colnames | Description
ASN.IBMSNAP_SUBS_MEMBX | UNIQUE | REGULAR | APPLY_QUAL, SET_NAME, WHOS_ON_FIRST, SOURCE_OWNER, SOURCE_TABLE, SOURCE_VIEW_QUAL, TARGET_OWNER, TARGET_TABLE |
Total: 1 index(s)

Autherisations

Grantor | Grantee | Authorities
SYSIBM | USER | CONTROL=HELD, ALTER=HELD_GRANTABLE, DELETE=HELD_GRANTABLE, INDEX=HELD_GRANTABLE, INSERT=HELD_GRANTABLE, SELECT=HELD_GRANTABLE, REFERENCE=HELD_GRANTABLE, UPDATE=HELD_GRANTABLE
Total: 1 autherisation(s)

SQL

CREATE TABLE "ASN "."IBMSNAP_SUBS_MEMBR" (
"APPLY_QUAL" CHAR(18) NOT NULL ,
"SET_NAME" CHAR(18) NOT NULL ,
"WHOS_ON_FIRST" CHAR(1) NOT NULL ,
"SOURCE_OWNER" VARCHAR(30) NOT NULL ,
"SOURCE_TABLE" VARCHAR(128) NOT NULL ,
"SOURCE_VIEW_QUAL" SMALLINT NOT NULL ,
"TARGET_OWNER" VARCHAR(30) NOT NULL ,
"TARGET_TABLE" VARCHAR(128) NOT NULL ,
"TARGET_CONDENSED" CHAR(1) NOT NULL ,
"TARGET_COMPLETE" CHAR(1) NOT NULL ,
"TARGET_STRUCTURE" SMALLINT NOT NULL ,
"PREDICATES" VARCHAR(1024) ,
"MEMBER_STATE" CHAR(1) ,
"TARGET_KEY_CHG" CHAR(1) NOT NULL ,
"UOW_CD_PREDICATES" VARCHAR(1024) ,
"JOIN_UOW_CD" CHAR(1) ,
"LOADX_TYPE" SMALLINT ,
"LOADX_SRC_N_OWNER" VARCHAR(30) ,
"LOADX_SRC_N_TABLE" VARCHAR(128) )
IN "TSASNAA" ;

CREATE UNIQUE INDEX "ASN "."IBMSNAP_SUBS_MEMBX" ON "ASN "."IBMSNAP_SUBS_MEMBR"
("APPLY_QUAL" ASC,
"SET_NAME" ASC,
"WHOS_ON_FIRST" ASC,
"SOURCE_OWNER" ASC,
"SOURCE_TABLE" ASC,
"SOURCE_VIEW_QUAL" ASC,
"TARGET_OWNER" ASC,
"TARGET_TABLE" ASC);

See Also

List of tables


Table: ASN.IBMSNAP_SUBS_SET

Properties

Name: | IBMSNAP_SUBS_SET
Schema: | ASN
Status: | NORMAL
Create time: | 01.07.2006
Tablespace: | TSASNAA
Index tablespace: |
Long tablespace: |
Base table schema: |
Base table: |
Rowtype schema: |
Rowtype name: |
Description: |

Columns

Name | Type | Length | Scale | Codepage | Identity | Nulls | Default | Description
APPLY_QUAL | CHARACTER | 18 | 0 | 1251 |  |  |  |
SET_NAME | CHARACTER | 18 | 0 | 1251 |  |  |  |
SET_TYPE | CHARACTER | 1 | 0 | 1251 |  |  |  |
WHOS_ON_FIRST | CHARACTER | 1 | 0 | 1251 |  |  |  |
ACTIVATE | SMALLINT | 2 | 0 | 0 |  |  |  |
SOURCE_SERVER | CHARACTER | 18 | 0 | 1251 |  |  |  |
SOURCE_ALIAS | CHARACTER | 8 | 0 | 1251 |  |  |  |
TARGET_SERVER | CHARACTER | 18 | 0 | 1251 |  |  |  |
TARGET_ALIAS | CHARACTER | 8 | 0 | 1251 |  |  |  |
STATUS | SMALLINT | 2 | 0 | 0 |  |  |  |
LASTRUN | TIMESTAMP | 10 | 0 | 0 |  |  |  |
REFRESH_TYPE | CHARACTER | 1 | 0 | 1251 |  |  |  |
SLEEP_MINUTES | INTEGER | 4 | 0 | 0 |  |  |  |
EVENT_NAME | CHARACTER | 18 | 0 | 1251 |  |  |  |
LASTSUCCESS | TIMESTAMP | 10 | 0 | 0 |  |  |  |
SYNCHPOINT | CHARACTER | 10 | 0 | 0 |  |  |  |
SYNCHTIME | TIMESTAMP | 10 | 0 | 0 |  |  |  |
CAPTURE_SCHEMA | VARCHAR | 30 | 0 | 1251 |  |  |  |
TGT_CAPTURE_SCHEMA | VARCHAR | 30 | 0 | 1251 |  |  |  |
FEDERATED_SRC_SRVR | VARCHAR | 18 | 0 | 1251 |  |  |  |
FEDERATED_TGT_SRVR | VARCHAR | 18 | 0 | 1251 |  |  |  |
JRN_LIB | CHARACTER | 10 | 0 | 1251 |  |  |  |
JRN_NAME | CHARACTER | 10 | 0 | 1251 |  |  |  |
OPTION_FLAGS | CHARACTER | 4 | 0 | 1251 |  |  |  |
COMMIT_COUNT | SMALLINT | 2 | 0 | 0 |  |  |  |
MAX_SYNCH_MINUTES | SMALLINT | 2 | 0 | 0 |  |  |  |
AUX_STMTS | SMALLINT | 2 | 0 | 0 |  |  |  |
ARCH_LEVEL | CHARACTER | 4 | 0 | 1251 |  |  |  |
Total: 28 column(s)

Indexes

Name | Unique rule | Type | Colnames | Description
ASN.IBMSNAP_SUBS_SETX | UNIQUE | REGULAR | APPLY_QUAL, SET_NAME, WHOS_ON_FIRST |
Total: 1 index(s)

Autherisations

Grantor | Grantee | Authorities
SYSIBM | USER | CONTROL=HELD, ALTER=HELD_GRANTABLE, DELETE=HELD_GRANTABLE, INDEX=HELD_GRANTABLE, INSERT=HELD_GRANTABLE, SELECT=HELD_GRANTABLE, REFERENCE=HELD_GRANTABLE, UPDATE=HELD_GRANTABLE
Total: 1 autherisation(s)

SQL

CREATE TABLE "ASN "."IBMSNAP_SUBS_SET" (
"APPLY_QUAL" CHAR(18) NOT NULL ,
"SET_NAME" CHAR(18) NOT NULL ,
"SET_TYPE" CHAR(1) NOT NULL ,
"WHOS_ON_FIRST" CHAR(1) NOT NULL ,
"ACTIVATE" SMALLINT NOT NULL ,
"SOURCE_SERVER" CHAR(18) NOT NULL ,
"SOURCE_ALIAS" CHAR(8) ,
"TARGET_SERVER" CHAR(18) NOT NULL ,
"TARGET_ALIAS" CHAR(8) ,
"STATUS" SMALLINT NOT NULL ,
"LASTRUN" TIMESTAMP NOT NULL ,
"REFRESH_TYPE" CHAR(1) NOT NULL ,
"SLEEP_MINUTES" INTEGER ,
"EVENT_NAME" CHAR(18) ,
"LASTSUCCESS" TIMESTAMP ,
"SYNCHPOINT" CHAR(10) FOR BIT DATA ,
"SYNCHTIME" TIMESTAMP ,
"CAPTURE_SCHEMA" VARCHAR(30) NOT NULL ,
"TGT_CAPTURE_SCHEMA" VARCHAR(30) ,
"FEDERATED_SRC_SRVR" VARCHAR(18) ,
"FEDERATED_TGT_SRVR" VARCHAR(18) ,
"JRN_LIB" CHAR(10) ,
"JRN_NAME" CHAR(10) ,
"OPTION_FLAGS" CHAR(4) NOT NULL ,
"COMMIT_COUNT" SMALLINT ,
"MAX_SYNCH_MINUTES" SMALLINT ,
"AUX_STMTS" SMALLINT NOT NULL ,
"ARCH_LEVEL" CHAR(4) NOT NULL )
IN "TSASNAA" ;

CREATE UNIQUE INDEX "ASN "."IBMSNAP_SUBS_SETX" ON "ASN "."IBMSNAP_SUBS_SET"
("APPLY_QUAL" ASC,
"SET_NAME" ASC,
"WHOS_ON_FIRST" ASC);

See Also

List of tables


Table: ASN.IBMSNAP_SUBS_STMTS

Properties

Name: | IBMSNAP_SUBS_STMTS
Schema: | ASN
Status: | NORMAL
Create time: | 01.07.2006
Tablespace: | TSASNAA
Index tablespace: |
Long tablespace: |
Base table schema: |
Base table: |
Rowtype schema: |
Rowtype name: |
Description: |

Columns

Name | Type | Length | Scale | Codepage | Identity | Nulls | Default | Description
APPLY_QUAL | CHARACTER | 18 | 0 | 1251 |  |  |  |
SET_NAME | CHARACTER | 18 | 0 | 1251 |  |  |  |
WHOS_ON_FIRST | CHARACTER | 1 | 0 | 1251 |  |  |  |
BEFORE_OR_AFTER | CHARACTER | 1 | 0 | 1251 |  |  |  |
STMT_NUMBER | SMALLINT | 2 | 0 | 0 |  |  |  |
EI_OR_CALL | CHARACTER | 1 | 0 | 1251 |  |  |  |
SQL_STMT | VARCHAR | 1024 | 0 | 1251 |  |  |  |
ACCEPT_SQLSTATES | VARCHAR | 50 | 0 | 1251 |  |  |  |
Total: 8 column(s)

Indexes

Name | Unique rule | Type | Colnames | Description
ASN.IBMSNAP_SUBS_STMTX | UNIQUE | REGULAR | APPLY_QUAL, SET_NAME, WHOS_ON_FIRST, BEFORE_OR_AFTER, STMT_NUMBER |
Total: 1 index(s)

Autherisations

Grantor | Grantee | Authorities
SYSIBM | USER | CONTROL=HELD, ALTER=HELD_GRANTABLE, DELETE=HELD_GRANTABLE, INDEX=HELD_GRANTABLE, INSERT=HELD_GRANTABLE, SELECT=HELD_GRANTABLE, REFERENCE=HELD_GRANTABLE, UPDATE=HELD_GRANTABLE
Total: 1 autherisation(s)

SQL

CREATE TABLE "ASN "."IBMSNAP_SUBS_STMTS" (
"APPLY_QUAL" CHAR(18) NOT NULL ,
"SET_NAME" CHAR(18) NOT NULL ,
"WHOS_ON_FIRST" CHAR(1) NOT NULL ,
"BEFORE_OR_AFTER" CHAR(1) NOT NULL ,
"STMT_NUMBER" SMALLINT NOT NULL ,
"EI_OR_CALL" CHAR(1) NOT NULL ,
"SQL_STMT" VARCHAR(1024) ,
"ACCEPT_SQLSTATES" VARCHAR(50) )
IN "TSASNAA" ;

CREATE UNIQUE INDEX "ASN "."IBMSNAP_SUBS_STMTX" ON "ASN "."IBMSNAP_SUBS_STMTS"
("APPLY_QUAL" ASC,
"SET_NAME" ASC,
"WHOS_ON_FIRST" ASC,
"BEFORE_OR_AFTER" ASC,
"STMT_NUMBER" ASC);

See Also

List of tables


Table: ASN.IBMSNAP_UOW

Properties

Name: | IBMSNAP_UOW
Schema: | ASN
Status: | NORMAL
Create time: | 01.07.2006
Tablespace: | TSASNUOW
Index tablespace: |
Long tablespace: |
Base table schema: |
Base table: |
Rowtype schema: |
Rowtype name: |
Description: |

Columns

Name | Type | Length | Scale | Codepage | Identity | Nulls | Default | Description
IBMSNAP_UOWID | CHARACTER | 10 | 0 | 0 |  |  |  |
IBMSNAP_COMMITSEQ | CHARACTER | 10 | 0 | 0 |  |  |  |
IBMSNAP_LOGMARKER | TIMESTAMP | 10 | 0 | 0 |  |  |  |
IBMSNAP_AUTHTKN | VARCHAR | 30 | 0 | 1251 |  |  |  |
IBMSNAP_AUTHID | VARCHAR | 30 | 0 | 1251 |  |  |  |
IBMSNAP_REJ_CODE | CHARACTER | 1 | 0 | 1251 |  |  | ' ' |
IBMSNAP_APPLY_QUAL | CHARACTER | 18 | 0 | 1251 |  |  | ' ' |
Total: 7 column(s)

Indexes

Name | Unique rule | Type | Colnames | Description
ASN.IBMSNAP_UOWX | UNIQUE | REGULAR | IBMSNAP_COMMITSEQ, IBMSNAP_LOGMARKER |
Total: 1 index(s)

Autherisations

Grantor | Grantee | Authorities
SYSIBM | USER | CONTROL=HELD, ALTER=HELD_GRANTABLE, DELETE=HELD_GRANTABLE, INDEX=HELD_GRANTABLE, INSERT=HELD_GRANTABLE, SELECT=HELD_GRANTABLE, REFERENCE=HELD_GRANTABLE, UPDATE=HELD_GRANTABLE
Total: 1 autherisation(s)

SQL

CREATE TABLE "ASN "."IBMSNAP_UOW" (
"IBMSNAP_UOWID" CHAR(10) FOR BIT DATA NOT NULL ,
"IBMSNAP_COMMITSEQ" CHAR(10) FOR BIT DATA NOT NULL ,
"IBMSNAP_LOGMARKER" TIMESTAMP NOT NULL ,
"IBMSNAP_AUTHTKN" VARCHAR(30) NOT NULL ,
"IBMSNAP_AUTHID" VARCHAR(30) NOT NULL ,
"IBMSNAP_REJ_CODE" CHAR(1) NOT NULL WITH DEFAULT ,
"IBMSNAP_APPLY_QUAL" CHAR(18) NOT NULL WITH DEFAULT )
IN "TSASNUOW" ;

ALTER TABLE "ASN "."IBMSNAP_UOW" VOLATILE CARDINALITY;

CREATE UNIQUE INDEX "ASN "."IBMSNAP_UOWX" ON "ASN "."IBMSNAP_UOW"
("IBMSNAP_COMMITSEQ" ASC,
"IBMSNAP_LOGMARKER" ASC);

See Also

List of tables


Table: USER.IN_TRAY

Properties

Name: | IN_TRAY
Schema: | USER
Status: | NORMAL
Create time: | 16.06.2006
Tablespace: | USERSPACE1
Index tablespace: |
Long tablespace: |
Base table schema: |
Base table: |
Rowtype schema: |
Rowtype name: |
Description: |

Columns

Name | Type | Length | Scale | Codepage | Identity | Nulls | Default | Description
RECEIVED | TIMESTAMP | 10 | 0 | 0 |  |  |  |
SOURCE | CHARACTER | 8 | 0 | 1251 |  |  |  |
SUBJECT | CHARACTER | 64 | 0 | 1251 |  |  |  |
NOTE_TEXT | VARCHAR | 3000 | 0 | 1251 |  |  |  |
Total: 4 column(s)

Autherisations

Grantor | Grantee | Authorities
SYSIBM | USER | CONTROL=HELD, ALTER=HELD_GRANTABLE, DELETE=HELD_GRANTABLE, INDEX=HELD_GRANTABLE, INSERT=HELD_GRANTABLE, SELECT=HELD_GRANTABLE, REFERENCE=HELD_GRANTABLE, UPDATE=HELD_GRANTABLE
Total: 1 autherisation(s)

SQL

CREATE TABLE "USER "."IN_TRAY" (
"RECEIVED" TIMESTAMP ,
"SOURCE" CHAR(8) ,
"SUBJECT" CHAR(64) ,
"NOTE_TEXT" VARCHAR(3000) )
IN "USERSPACE1" ;

See Also

List of tables


Table: USER.ORG

Properties

Name: | ORG
Schema: | USER
Status: | NORMAL
Create time: | 16.06.2006
Tablespace: | USERSPACE1
Index tablespace: |
Long tablespace: |
Base table schema: |
Base table: |
Rowtype schema: |
Rowtype name: |
Description: |

Columns

Name | Type | Length | Scale | Codepage | Identity | Nulls | Default | Description
DEPTNUMB | SMALLINT | 2 | 0 | 0 |  |  |  |
DEPTNAME | VARCHAR | 14 | 0 | 1251 |  |  |  |
MANAGER | SMALLINT | 2 | 0 | 0 |  |  |  |
DIVISION | VARCHAR | 10 | 0 | 1251 |  |  |  |
LOCATION | VARCHAR | 13 | 0 | 1251 |  |  |  |
Total: 5 column(s)

Indexes

Name | Unique rule | Type | Colnames | Description
USER.CC1151755924953 | PRIMARY | REGULAR | DEPTNUMB |
Total: 1 index(s)

Autherisations

Grantor | Grantee | Authorities
SYSIBM | USER | CONTROL=HELD, ALTER=HELD_GRANTABLE, DELETE=HELD_GRANTABLE, INDEX=HELD_GRANTABLE, INSERT=HELD_GRANTABLE, SELECT=HELD_GRANTABLE, REFERENCE=HELD_GRANTABLE, UPDATE=HELD_GRANTABLE
Total: 1 autherisation(s)

SQL

CREATE TABLE "USER "."ORG" (
"DEPTNUMB" SMALLINT NOT NULL ,
"DEPTNAME" VARCHAR(14) ,
"MANAGER" SMALLINT ,
"DIVISION" VARCHAR(10) ,
"LOCATION" VARCHAR(13) )
IN "USERSPACE1" ;

ALTER TABLE "USER "."ORG"
ADD CONSTRAINT "CC1151755924953" PRIMARY KEY
("DEPTNUMB");

See Also

List of tables


Table: USER.PROJECT

Properties

Name: | PROJECT
Schema: | USER
Status: | NORMAL
Create time: | 16.06.2006
Tablespace: | USERSPACE1
Index tablespace: |
Long tablespace: |
Base table schema: |
Base table: |
Rowtype schema: |
Rowtype name: |
Description: |

Columns

Name | Type | Length | Scale | Codepage | Identity | Nulls | Default | Description
PROJNO | CHARACTER | 6 | 0 | 1251 |  |  |  |
PROJNAME | VARCHAR | 24 | 0 | 1251 |  |  |  |
DEPTNO | CHARACTER | 3 | 0 | 1251 |  |  |  |
RESPEMP | CHARACTER | 6 | 0 | 1251 |  |  |  |
PRSTAFF | DECIMAL | 5 | 2 | 0 |  |  |  |
PRSTDATE | DATE | 4 | 0 | 0 |  |  |  |
PRENDATE | DATE | 4 | 0 | 0 |  |  |  |
MAJPROJ | CHARACTER | 6 | 0 | 1251 |  |  |  |
Total: 8 column(s)

Autherisations

Grantor | Grantee | Authorities
SYSIBM | USER | CONTROL=HELD, ALTER=HELD_GRANTABLE, DELETE=HELD_GRANTABLE, INDEX=HELD_GRANTABLE, INSERT=HELD_GRANTABLE, SELECT=HELD_GRANTABLE, REFERENCE=HELD_GRANTABLE, UPDATE=HELD_GRANTABLE
Total: 1 autherisation(s)

SQL

CREATE TABLE "USER "."PROJECT" (
"PROJNO" CHAR(6) NOT NULL ,
"PROJNAME" VARCHAR(24) NOT NULL ,
"DEPTNO" CHAR(3) NOT NULL ,
"RESPEMP" CHAR(6) NOT NULL ,
"PRSTAFF" DECIMAL(5,2) ,
"PRSTDATE" DATE ,
"PRENDATE" DATE ,
"MAJPROJ" CHAR(6) )
IN "USERSPACE1" ;

See Also

List of tables


Table: USER.SALES

Properties

Name: | SALES
Schema: | USER
Status: | NORMAL
Create time: | 16.06.2006
Tablespace: | USERSPACE1
Index tablespace: |
Long tablespace: |
Base table schema: |
Base table: |
Rowtype schema: |
Rowtype name: |
Description: |

Columns

Name | Type | Length | Scale | Codepage | Identity | Nulls | Default | Description
SALES_DATE | DATE | 4 | 0 | 0 |  |  |  |
SALES_PERSON | VARCHAR | 15 | 0 | 1251 |  |  |  |
REGION | VARCHAR | 15 | 0 | 1251 |  |  |  |
SALES | INTEGER | 4 | 0 | 0 |  |  |  |
Total: 4 column(s)

Autherisations

Grantor | Grantee | Authorities
SYSIBM | USER | CONTROL=HELD, ALTER=HELD_GRANTABLE, DELETE=HELD_GRANTABLE, INDEX=HELD_GRANTABLE, INSERT=HELD_GRANTABLE, SELECT=HELD_GRANTABLE, REFERENCE=HELD_GRANTABLE, UPDATE=HELD_GRANTABLE
Total: 1 autherisation(s)

SQL

CREATE TABLE "USER "."SALES" (
"SALES_DATE" DATE ,
"SALES_PERSON" VARCHAR(15) ,
"REGION" VARCHAR(15) ,
"SALES" INTEGER )
DATA CAPTURE CHANGES
IN "USERSPACE1" ;

See Also

List of tables


Table: USER.STAFF

Properties

Name: | STAFF
Schema: | USER
Status: | NORMAL
Create time: | 16.06.2006
Tablespace: | USERSPACE1
Index tablespace: |
Long tablespace: |
Base table schema: |
Base table: |
Rowtype schema: |
Rowtype name: |
Description: |

Columns

Name | Type | Length | Scale | Codepage | Identity | Nulls | Default | Description
ID | SMALLINT | 2 | 0 | 0 |  |  |  |
NAME | VARCHAR | 9 | 0 | 1251 |  |  |  |
DEPT | SMALLINT | 2 | 0 | 0 |  |  |  |
JOB | CHARACTER | 5 | 0 | 1251 |  |  |  |
YEARS | SMALLINT | 2 | 0 | 0 |  |  |  |
SALARY | DECIMAL | 7 | 2 | 0 |  |  |  |
COMM | DECIMAL | 7 | 2 | 0 |  |  |  |
Total: 7 column(s)

Indexes

Name | Unique rule | Type | Colnames | Description
USER.CC1151755626422 | PRIMARY | REGULAR | ID |
Total: 1 index(s)

Triggers

Name | Valid | Time | Event | Description
USER.TR_STAFF_BEFORE |  | BEFORE | DELETE |
Total: 1 trigger(s)

Dipendent objects

Name
USER.TR_STAFF_BEFORE
Total: 1 dipendent object(s)

Autherisations

Grantor | Grantee | Authorities
SYSIBM | USER | CONTROL=HELD, ALTER=HELD_GRANTABLE, DELETE=HELD_GRANTABLE, INDEX=HELD_GRANTABLE, INSERT=HELD_GRANTABLE, SELECT=HELD_GRANTABLE, REFERENCE=HELD_GRANTABLE, UPDATE=HELD_GRANTABLE
Total: 1 autherisation(s)

SQL

CREATE TABLE "USER "."STAFF" (
"ID" SMALLINT NOT NULL ,
"NAME" VARCHAR(9) ,
"DEPT" SMALLINT ,
"JOB" CHAR(5) ,
"YEARS" SMALLINT ,
"SALARY" DECIMAL(7,2) ,
"COMM" DECIMAL(7,2) )
DATA CAPTURE CHANGES
IN "USERSPACE1" ;

ALTER TABLE "USER "."STAFF"
ADD CONSTRAINT "CC1151755626422" PRIMARY KEY
("ID");

See Also

List of tables


List of indexes

Indexes

Name | TABLE | Unique rule | Type | Description
USER.CC1151754616344 | USER.NICK_COLUMNS | PRIMARY | REGULAR |
USER.CC1151754705266 | USER.NICK_CHECK_CONSTRAINTS | PRIMARY | REGULAR |
USER.CC1151755626422 | USER.STAFF | PRIMARY | REGULAR |
USER.CC11517556264220 | USER.NICK_STAFF | PRIMARY | REGULAR |
USER.CC11517556264221 | USER.QQQ_STAFF | PRIMARY | REGULAR |
USER.CC1151755924953 | USER.ORG | PRIMARY | REGULAR |
USER.CC1151778928062 | USER.EMPLOYEE | PRIMARY | REGULAR |
ASN.IBMSNAP_APPENQX | ASN.IBMSNAP_APPENQ | UNIQUE | REGULAR |
ASN.IBMSNAP_APPLYTRACX | ASN.IBMSNAP_APPLYTRACE | DUBLICATE | REGULAR |
ASN.IBMSNAP_APPLYTRLX | ASN.IBMSNAP_APPLYTRAIL | DUBLICATE | REGULAR |
ASN.IBMSNAP_APPPARMSX | ASN.IBMSNAP_APPPARMS | UNIQUE | REGULAR |
ASN.IBMSNAP_CAPMONX | ASN.IBMSNAP_CAPMON | UNIQUE | REGULAR |
ASN.IBMSNAP_CAPSCHEMAX | ASN.IBMSNAP_CAPSCHEMAS | UNIQUE | REGULAR |
ASN.IBMSNAP_CAPTRACEX | ASN.IBMSNAP_CAPTRACE | DUBLICATE | REGULAR |
ASN.IBMSNAP_COMPENSATX | ASN.IBMSNAP_COMPENSATE | UNIQUE | REGULAR |
ASN.IBMSNAP_PRUNCNTLX | ASN.IBMSNAP_PRUNCNTL | UNIQUE | REGULAR |
ASN.IBMSNAP_PRUNCNTLX1 | ASN.IBMSNAP_PRUNCNTL | UNIQUE | REGULAR |
ASN.IBMSNAP_PRUNCNTLX2 | ASN.IBMSNAP_PRUNCNTL | DUBLICATE | REGULAR |
ASN.IBMSNAP_PRUNCNTLX3 | ASN.IBMSNAP_PRUNCNTL | DUBLICATE | REGULAR |
ASN.IBMSNAP_PRUNE_SETX | ASN.IBMSNAP_PRUNE_SET | UNIQUE | REGULAR |
ASN.IBMSNAP_REGISTERX | ASN.IBMSNAP_REGISTER | UNIQUE | REGULAR |
ASN.IBMSNAP_REGISTERX1 | ASN.IBMSNAP_REGISTER | DUBLICATE | REGULAR |
ASN.IBMSNAP_REGISTERX2 | ASN.IBMSNAP_REGISTER | DUBLICATE | REGULAR |
ASN.IBMSNAP_SIGNALX | ASN.IBMSNAP_SIGNAL | UNIQUE | REGULAR |
ASN.IBMSNAP_SUBS_COLSX | ASN.IBMSNAP_SUBS_COLS | UNIQUE | REGULAR |
ASN.IBMSNAP_SUBS_EVENX | ASN.IBMSNAP_SUBS_EVENT | UNIQUE | REGULAR |
ASN.IBMSNAP_SUBS_MEMBX | ASN.IBMSNAP_SUBS_MEMBR | UNIQUE | REGULAR |
ASN.IBMSNAP_SUBS_SETX | ASN.IBMSNAP_SUBS_SET | UNIQUE | REGULAR |
ASN.IBMSNAP_SUBS_STMTX | ASN.IBMSNAP_SUBS_STMTS | UNIQUE | REGULAR |
ASN.IBMSNAP_UOWX | ASN.IBMSNAP_UOW | UNIQUE | REGULAR |
USER.IXCDSTAFF | USER.CDSTAFF | UNIQUE | REGULAR |
USER.IXNICK_STAFF_MQT | USER.NICK_STAFF_MQT | UNIQUE | REGULAR |
USER.IXQQQ_STAFF_MQT | USER.QQQ_STAFF_MQT | UNIQUE | REGULAR |
USER.PK_ACT | USER.ACT | PRIMARY | REGULAR |
SYSIBM.SQL060616220800090 | USER.EMP_PHOTO | PRIMARY | REGULAR |
SYSIBM.SQL060616220803090 | USER.EMP_RESUME | PRIMARY | REGULAR |
USER.XACT2 | USER.ACT | UNIQUE | REGULAR |
USER.XACT3 | USER.ACT | DUBLICATE | REGULAR |
Total: 38 index(s)

See Also

Database overview


Index: USER.CC1151754616344

Properties

Name: | CC1151754616344
Schema: | USER
Table schema: | USER
Table: | NICK_COLUMNS
Unique rule: | PRIMARY
Type: | REGULAR
Create time: | 01.07.2006
Tablespace: | SYSCATSPACE
Description: |

Columns

Colname | Order
TABLE_CATALOG | ASCENDING
TABLE_SCHEMA | ASCENDING
TABLE_NAME | ASCENDING
COLUMN_NAME | ASCENDING
Total: 4 column(s)

Autherisations

Grantor | Grantee | Authorities
SYSIBM | USER | CONTROL=HELD
Total: 1 autherisation(s)

SQL

See Also

List of indexes


Index: USER.CC1151754705266

Properties

Name: | CC1151754705266
Schema: | USER
Table schema: | USER
Table: | NICK_CHECK_CONSTRAINTS
Unique rule: | PRIMARY
Type: | REGULAR
Create time: | 01.07.2006
Tablespace: | SYSCATSPACE
Description: |

Columns

Colname | Order
CONSTRAINT_CATALOG | ASCENDING
CONSTRAINT_SCHEMA | ASCENDING
CONSTRAINT_NAME | ASCENDING
Total: 3 column(s)

Autherisations

Grantor | Grantee | Authorities
SYSIBM | USER | CONTROL=HELD
Total: 1 autherisation(s)

SQL

See Also

List of indexes


Index: USER.CC1151755626422

Properties

Name: | CC1151755626422
Schema: | USER
Table schema: | USER
Table: | STAFF
Unique rule: | PRIMARY
Type: | REGULAR
Create time: | 01.07.2006
Tablespace: | USERSPACE1
Description: |

Columns

Colname | Order
ID | ASCENDING
Total: 1 column(s)

Autherisations

Grantor | Grantee | Authorities
SYSIBM | USER | CONTROL=HELD
Total: 1 autherisation(s)

SQL

ALTER TABLE "USER "."STAFF"
ADD CONSTRAINT "CC1151755626422" PRIMARY KEY
("ID");

See Also

List of indexes


Index: USER.CC11517556264220

Properties

Name: | CC11517556264220
Schema: | USER
Table schema: | USER
Table: | NICK_STAFF
Unique rule: | PRIMARY
Type: | REGULAR
Create time: | 01.07.2006
Tablespace: | SYSCATSPACE
Description: |

Columns

Colname | Order
ID | ASCENDING
Total: 1 column(s)

Autherisations

Grantor | Grantee | Authorities
SYSIBM | USER | CONTROL=HELD
Total: 1 autherisation(s)

SQL

See Also

List of indexes


Index: USER.CC11517556264221

Properties

Name: | CC11517556264221
Schema: | USER
Table schema: | USER
Table: | QQQ_STAFF
Unique rule: | PRIMARY
Type: | REGULAR
Create time: | 01.07.2006
Tablespace: | SYSCATSPACE
Description: |

Columns

Colname | Order
ID | ASCENDING
Total: 1 column(s)

Autherisations

Grantor | Grantee | Authorities
SYSIBM | USER | CONTROL=HELD
Total: 1 autherisation(s)

SQL

See Also

List of indexes


Index: USER.CC1151755924953

Properties

Name: | CC1151755924953
Schema: | USER
Table schema: | USER
Table: | ORG
Unique rule: | PRIMARY
Type: | REGULAR
Create time: | 01.07.2006
Tablespace: | USERSPACE1
Description: |

Columns

Colname | Order
DEPTNUMB | ASCENDING
Total: 1 column(s)

Autherisations

Grantor | Grantee | Authorities
SYSIBM | USER | CONTROL=HELD
Total: 1 autherisation(s)

SQL

ALTER TABLE "USER "."ORG"
ADD CONSTRAINT "CC1151755924953" PRIMARY KEY
("DEPTNUMB");

See Also

List of indexes


Index: USER.CC1151778928062

Properties

Name: | CC1151778928062
Schema: | USER
Table schema: | USER
Table: | EMPLOYEE
Unique rule: | PRIMARY
Type: | REGULAR
Create time: | 01.07.2006
Tablespace: | USERSPACE1
Description: |

Columns

Colname | Order
EMPNO | ASCENDING
Total: 1 column(s)

Autherisations

Grantor | Grantee | Authorities
SYSIBM | USER | CONTROL=HELD
Total: 1 autherisation(s)

SQL

ALTER TABLE "USER "."EMPLOYEE"
ADD CONSTRAINT "CC1151778928062" PRIMARY KEY
("EMPNO");

See Also

List of indexes


Index: ASN.IBMSNAP_APPENQX

Properties

Name: | IBMSNAP_APPENQX
Schema: | ASN
Table schema: | ASN
Table: | IBMSNAP_APPENQ
Unique rule: | UNIQUE
Type: | REGULAR
Create time: | 01.07.2006
Tablespace: | TSASNAA
Description: |

Columns

Colname | Order
APPLY_QUAL | ASCENDING
Total: 1 column(s)

Autherisations

Grantor | Grantee | Authorities
SYSIBM | USER | CONTROL=HELD
Total: 1 autherisation(s)

SQL

CREATE UNIQUE INDEX "ASN "."IBMSNAP_APPENQX" ON "ASN "."IBMSNAP_APPENQ"
("APPLY_QUAL" ASC);

See Also

List of indexes


Index: ASN.IBMSNAP_APPLYTRACX

Properties

Name: | IBMSNAP_APPLYTRACX
Schema: | ASN
Table schema: | ASN
Table: | IBMSNAP_APPLYTRACE
Unique rule: | DUBLICATE
Type: | REGULAR
Create time: | 01.07.2006
Tablespace: | TSASNAA
Description: |

Columns

Colname | Order
APPLY_QUAL | ASCENDING
TRACE_TIME | ASCENDING
Total: 2 column(s)

Autherisations

Grantor | Grantee | Authorities
SYSIBM | USER | CONTROL=HELD
Total: 1 autherisation(s)

SQL

CREATE INDEX "ASN "."IBMSNAP_APPLYTRACX" ON "ASN "."IBMSNAP_APPLYTRACE"
("APPLY_QUAL" ASC,
"TRACE_TIME" ASC);

See Also

List of indexes


Index: ASN.IBMSNAP_APPLYTRLX

Properties

Name: | IBMSNAP_APPLYTRLX
Schema: | ASN
Table schema: | ASN
Table: | IBMSNAP_APPLYTRAIL
Unique rule: | DUBLICATE
Type: | REGULAR
Create time: | 01.07.2006
Tablespace: | TSASNAA
Description: |

Columns

Colname | Order
LASTRUN | DESCENDING
APPLY_QUAL | ASCENDING
Total: 2 column(s)

Autherisations

Grantor | Grantee | Authorities
SYSIBM | USER | CONTROL=HELD
Total: 1 autherisation(s)

SQL

CREATE INDEX "ASN "."IBMSNAP_APPLYTRLX" ON "ASN "."IBMSNAP_APPLYTRAIL"
("LASTRUN" DESC,
"APPLY_QUAL" ASC);

See Also

List of indexes


Index: ASN.IBMSNAP_APPPARMSX

Properties

Name: | IBMSNAP_APPPARMSX
Schema: | ASN
Table schema: | ASN
Table: | IBMSNAP_APPPARMS
Unique rule: | UNIQUE
Type: | REGULAR
Create time: | 01.07.2006
Tablespace: | TSASNAA
Description: |

Columns

Colname | Order
APPLY_QUAL | ASCENDING
Total: 1 column(s)

Autherisations

Grantor | Grantee | Authorities
SYSIBM | USER | CONTROL=HELD
Total: 1 autherisation(s)

SQL

CREATE UNIQUE INDEX "ASN "."IBMSNAP_APPPARMSX" ON "ASN "."IBMSNAP_APPPARMS"
("APPLY_QUAL" ASC);

See Also

List of indexes


Index: ASN.IBMSNAP_CAPMONX

Properties

Name: | IBMSNAP_CAPMONX
Schema: | ASN
Table schema: | ASN
Table: | IBMSNAP_CAPMON
Unique rule: | UNIQUE
Type: | REGULAR
Create time: | 01.07.2006
Tablespace: | TSASNCA
Description: |

Columns

Colname | Order
MONITOR_TIME | ASCENDING
Total: 1 column(s)

Autherisations

Grantor | Grantee | Authorities
SYSIBM | USER | CONTROL=HELD
Total: 1 autherisation(s)

SQL

CREATE UNIQUE INDEX "ASN "."IBMSNAP_CAPMONX" ON "ASN "."IBMSNAP_CAPMON"
("MONITOR_TIME" ASC);

See Also

List of indexes


Index: ASN.IBMSNAP_CAPSCHEMAX

Properties

Name: | IBMSNAP_CAPSCHEMAX
Schema: | ASN
Table schema: | ASN
Table: | IBMSNAP_CAPSCHEMAS
Unique rule: | UNIQUE
Type: | REGULAR
Create time: | 01.07.2006
Tablespace: | TSASNCA
Description: |

Columns

Colname | Order
CAP_SCHEMA_NAME | ASCENDING
Total: 1 column(s)

Autherisations

Grantor | Grantee | Authorities
SYSIBM | USER | CONTROL=HELD
Total: 1 autherisation(s)

SQL

CREATE UNIQUE INDEX "ASN "."IBMSNAP_CAPSCHEMAX" ON "ASN "."IBMSNAP_CAPSCHEMAS"
("CAP_SCHEMA_NAME" ASC);

See Also

List of indexes


Index: ASN.IBMSNAP_CAPTRACEX

Properties

Name: | IBMSNAP_CAPTRACEX
Schema: | ASN
Table schema: | ASN
Table: | IBMSNAP_CAPTRACE
Unique rule: | DUBLICATE
Type: | REGULAR
Create time: | 01.07.2006
Tablespace: | TSASNCA
Description: |

Columns

Colname | Order
TRACE_TIME | ASCENDING
Total: 1 column(s)

Autherisations

Grantor | Grantee | Authorities
SYSIBM | USER | CONTROL=HELD
Total: 1 autherisation(s)

SQL

CREATE INDEX "ASN "."IBMSNAP_CAPTRACEX" ON "ASN "."IBMSNAP_CAPTRACE"
("TRACE_TIME" ASC);

See Also

List of indexes


Index: ASN.IBMSNAP_COMPENSATX

Properties

Name: | IBMSNAP_COMPENSATX
Schema: | ASN
Table schema: | ASN
Table: | IBMSNAP_COMPENSATE
Unique rule: | UNIQUE
Type: | REGULAR
Create time: | 01.07.2006
Tablespace: | TSASNAA
Description: |

Columns

Colname | Order
APPLY_QUAL | ASCENDING
MEMBER | ASCENDING
Total: 2 column(s)

Autherisations

Grantor | Grantee | Authorities
SYSIBM | USER | CONTROL=HELD
Total: 1 autherisation(s)

SQL

CREATE UNIQUE INDEX "ASN "."IBMSNAP_COMPENSATX" ON "ASN "."IBMSNAP_COMPENSATE"
("APPLY_QUAL" ASC,
"MEMBER" ASC);

See Also

List of indexes


Index: ASN.IBMSNAP_PRUNCNTLX

Properties

Name: | IBMSNAP_PRUNCNTLX
Schema: | ASN
Table schema: | ASN
Table: | IBMSNAP_PRUNCNTL
Unique rule: | UNIQUE
Type: | REGULAR
Create time: | 01.07.2006
Tablespace: | TSASNCA
Description: |

Columns

Colname | Order
SOURCE_OWNER | ASCENDING
SOURCE_TABLE | ASCENDING
SOURCE_VIEW_QUAL | ASCENDING
APPLY_QUAL | ASCENDING
SET_NAME | ASCENDING
TARGET_SERVER | ASCENDING
TARGET_TABLE | ASCENDING
TARGET_OWNER | ASCENDING
Total: 8 column(s)

Autherisations

Grantor | Grantee | Authorities
SYSIBM | USER | CONTROL=HELD
Total: 1 autherisation(s)

SQL

CREATE UNIQUE INDEX "ASN "."IBMSNAP_PRUNCNTLX" ON "ASN "."IBMSNAP_PRUNCNTL"
("SOURCE_OWNER" ASC,
"SOURCE_TABLE" ASC,
"SOURCE_VIEW_QUAL" ASC,
"APPLY_QUAL" ASC,
"SET_NAME" ASC,
"TARGET_SERVER" ASC,
"TARGET_TABLE" ASC,
"TARGET_OWNER" ASC);

See Also

List of indexes


Index: ASN.IBMSNAP_PRUNCNTLX1

Properties

Name: | IBMSNAP_PRUNCNTLX1
Schema: | ASN
Table schema: | ASN
Table: | IBMSNAP_PRUNCNTL
Unique rule: | UNIQUE
Type: | REGULAR
Create time: | 01.07.2006
Tablespace: | TSASNCA
Description: |

Columns

Colname | Order
MAP_ID | ASCENDING
Total: 1 column(s)

Autherisations

Grantor | Grantee | Authorities
SYSIBM | USER | CONTROL=HELD
Total: 1 autherisation(s)

SQL

CREATE UNIQUE INDEX "ASN "."IBMSNAP_PRUNCNTLX1" ON "ASN "."IBMSNAP_PRUNCNTL"
("MAP_ID" ASC);

See Also

List of indexes


Index: ASN.IBMSNAP_PRUNCNTLX2

Properties

Name: | IBMSNAP_PRUNCNTLX2
Schema: | ASN
Table schema: | ASN
Table: | IBMSNAP_PRUNCNTL
Unique rule: | DUBLICATE
Type: | REGULAR
Create time: | 01.07.2006
Tablespace: | TSASNCA
Description: |

Columns

Colname | Order
PHYS_CHANGE_OWNER | ASCENDING
PHYS_CHANGE_TABLE | ASCENDING
Total: 2 column(s)

Autherisations

Grantor | Grantee | Authorities
SYSIBM | USER | CONTROL=HELD
Total: 1 autherisation(s)

SQL

CREATE INDEX "ASN "."IBMSNAP_PRUNCNTLX2" ON "ASN "."IBMSNAP_PRUNCNTL"
("PHYS_CHANGE_OWNER" ASC,
"PHYS_CHANGE_TABLE" ASC);

See Also

List of indexes


Index: ASN.IBMSNAP_PRUNCNTLX3

Properties

Name: | IBMSNAP_PRUNCNTLX3
Schema: | ASN
Table schema: | ASN
Table: | IBMSNAP_PRUNCNTL
Unique rule: | DUBLICATE
Type: | REGULAR
Create time: | 01.07.2006
Tablespace: | TSASNCA
Description: |

Columns

Colname | Order
APPLY_QUAL | ASCENDING
SET_NAME | ASCENDING
TARGET_SERVER | ASCENDING
Total: 3 column(s)

Autherisations

Grantor | Grantee | Authorities
SYSIBM | USER | CONTROL=HELD
Total: 1 autherisation(s)

SQL

CREATE INDEX "ASN "."IBMSNAP_PRUNCNTLX3" ON "ASN "."IBMSNAP_PRUNCNTL"
("APPLY_QUAL" ASC,
"SET_NAME" ASC,
"TARGET_SERVER" ASC);

See Also

List of indexes


Index: ASN.IBMSNAP_PRUNE_SETX

Properties

Name: | IBMSNAP_PRUNE_SETX
Schema: | ASN
Table schema: | ASN
Table: | IBMSNAP_PRUNE_SET
Unique rule: | UNIQUE
Type: | REGULAR
Create time: | 01.07.2006
Tablespace: | TSASNCA
Description: |

Columns

Colname | Order
TARGET_SERVER | ASCENDING
APPLY_QUAL | ASCENDING
SET_NAME | ASCENDING
Total: 3 column(s)

Autherisations

Grantor | Grantee | Authorities
SYSIBM | USER | CONTROL=HELD
Total: 1 autherisation(s)

SQL

CREATE UNIQUE INDEX "ASN "."IBMSNAP_PRUNE_SETX" ON "ASN "."IBMSNAP_PRUNE_SET"
("TARGET_SERVER" ASC,
"APPLY_QUAL" ASC,
"SET_NAME" ASC);

See Also

List of indexes


Index: ASN.IBMSNAP_REGISTERX

Properties

Name: | IBMSNAP_REGISTERX
Schema: | ASN
Table schema: | ASN
Table: | IBMSNAP_REGISTER
Unique rule: | UNIQUE
Type: | REGULAR
Create time: | 01.07.2006
Tablespace: | TSASNCA
Description: |

Columns

Colname | Order
SOURCE_OWNER | ASCENDING
SOURCE_TABLE | ASCENDING
SOURCE_VIEW_QUAL | ASCENDING
Total: 3 column(s)

Autherisations

Grantor | Grantee | Authorities
SYSIBM | USER | CONTROL=HELD
Total: 1 autherisation(s)

SQL

CREATE UNIQUE INDEX "ASN "."IBMSNAP_REGISTERX" ON "ASN "."IBMSNAP_REGISTER"
("SOURCE_OWNER" ASC,
"SOURCE_TABLE" ASC,
"SOURCE_VIEW_QUAL" ASC);

See Also

List of indexes


Index: ASN.IBMSNAP_REGISTERX1

Properties

Name: | IBMSNAP_REGISTERX1
Schema: | ASN
Table schema: | ASN
Table: | IBMSNAP_REGISTER
Unique rule: | DUBLICATE
Type: | REGULAR
Create time: | 01.07.2006
Tablespace: | TSASNCA
Description: |

Columns

Colname | Order
PHYS_CHANGE_OWNER | ASCENDING
PHYS_CHANGE_TABLE | ASCENDING
Total: 2 column(s)

Autherisations

Grantor | Grantee | Authorities
SYSIBM | USER | CONTROL=HELD
Total: 1 autherisation(s)

SQL

CREATE INDEX "ASN "."IBMSNAP_REGISTERX1" ON "ASN "."IBMSNAP_REGISTER"
("PHYS_CHANGE_OWNER" ASC,
"PHYS_CHANGE_TABLE" ASC);

See Also

List of indexes


Index: ASN.IBMSNAP_REGISTERX2

Properties

Name: | IBMSNAP_REGISTERX2
Schema: | ASN
Table schema: | ASN
Table: | IBMSNAP_REGISTER
Unique rule: | DUBLICATE
Type: | REGULAR
Create time: | 01.07.2006
Tablespace: | TSASNCA
Description: |

Columns

Colname | Order
GLOBAL_RECORD | ASCENDING
Total: 1 column(s)

Autherisations

Grantor | Grantee | Authorities
SYSIBM | USER | CONTROL=HELD
Total: 1 autherisation(s)

SQL

CREATE INDEX "ASN "."IBMSNAP_REGISTERX2" ON "ASN "."IBMSNAP_REGISTER"
("GLOBAL_RECORD" ASC);

See Also

List of indexes


Index: ASN.IBMSNAP_SIGNALX

Properties

Name: | IBMSNAP_SIGNALX
Schema: | ASN
Table schema: | ASN
Table: | IBMSNAP_SIGNAL
Unique rule: | UNIQUE
Type: | REGULAR
Create time: | 01.07.2006
Tablespace: | TSASNCA
Description: |

Columns

Colname | Order
SIGNAL_TIME | ASCENDING
Total: 1 column(s)

Autherisations

Grantor | Grantee | Authorities
SYSIBM | USER | CONTROL=HELD
Total: 1 autherisation(s)

SQL

CREATE UNIQUE INDEX "ASN "."IBMSNAP_SIGNALX" ON "ASN "."IBMSNAP_SIGNAL"
("SIGNAL_TIME" ASC);

See Also

List of indexes


Index: ASN.IBMSNAP_SUBS_COLSX

Properties

Name: | IBMSNAP_SUBS_COLSX
Schema: | ASN
Table schema: | ASN
Table: | IBMSNAP_SUBS_COLS
Unique rule: | UNIQUE
Type: | REGULAR
Create time: | 01.07.2006
Tablespace: | TSASNAA
Description: |

Columns

Colname | Order
APPLY_QUAL | ASCENDING
SET_NAME | ASCENDING
WHOS_ON_FIRST | ASCENDING
TARGET_OWNER | ASCENDING
TARGET_TABLE | ASCENDING
TARGET_NAME | ASCENDING
Total: 6 column(s)

Autherisations

Grantor | Grantee | Authorities
SYSIBM | USER | CONTROL=HELD
Total: 1 autherisation(s)

SQL

CREATE UNIQUE INDEX "ASN "."IBMSNAP_SUBS_COLSX" ON "ASN "."IBMSNAP_SUBS_COLS"
("APPLY_QUAL" ASC,
"SET_NAME" ASC,
"WHOS_ON_FIRST" ASC,
"TARGET_OWNER" ASC,
"TARGET_TABLE" ASC,
"TARGET_NAME" ASC);

See Also

List of indexes


Index: ASN.IBMSNAP_SUBS_EVENX

Properties

Name: | IBMSNAP_SUBS_EVENX
Schema: | ASN
Table schema: | ASN
Table: | IBMSNAP_SUBS_EVENT
Unique rule: | UNIQUE
Type: | REGULAR
Create time: | 01.07.2006
Tablespace: | TSASNAA
Description: |

Columns

Colname | Order
EVENT_NAME | ASCENDING
EVENT_TIME | ASCENDING
Total: 2 column(s)

Autherisations

Grantor | Grantee | Authorities
SYSIBM | USER | CONTROL=HELD
Total: 1 autherisation(s)

SQL

CREATE UNIQUE INDEX "ASN "."IBMSNAP_SUBS_EVENX" ON "ASN "."IBMSNAP_SUBS_EVENT"
("EVENT_NAME" ASC,
"EVENT_TIME" ASC);

See Also

List of indexes


Index: ASN.IBMSNAP_SUBS_MEMBX

Properties

Name: | IBMSNAP_SUBS_MEMBX
Schema: | ASN
Table schema: | ASN
Table: | IBMSNAP_SUBS_MEMBR
Unique rule: | UNIQUE
Type: | REGULAR
Create time: | 01.07.2006
Tablespace: | TSASNAA
Description: |

Columns

Colname | Order
APPLY_QUAL | ASCENDING
SET_NAME | ASCENDING
WHOS_ON_FIRST | ASCENDING
SOURCE_OWNER | ASCENDING
SOURCE_TABLE | ASCENDING
SOURCE_VIEW_QUAL | ASCENDING
TARGET_OWNER | ASCENDING
TARGET_TABLE | ASCENDING
Total: 8 column(s)

Autherisations

Grantor | Grantee | Authorities
SYSIBM | USER | CONTROL=HELD
Total: 1 autherisation(s)

SQL

CREATE UNIQUE INDEX "ASN "."IBMSNAP_SUBS_MEMBX" ON "ASN "."IBMSNAP_SUBS_MEMBR"
("APPLY_QUAL" ASC,
"SET_NAME" ASC,
"WHOS_ON_FIRST" ASC,
"SOURCE_OWNER" ASC,
"SOURCE_TABLE" ASC,
"SOURCE_VIEW_QUAL" ASC,
"TARGET_OWNER" ASC,
"TARGET_TABLE" ASC);

See Also

List of indexes


Index: ASN.IBMSNAP_SUBS_SETX

Properties

Name: | IBMSNAP_SUBS_SETX
Schema: | ASN
Table schema: | ASN
Table: | IBMSNAP_SUBS_SET
Unique rule: | UNIQUE
Type: | REGULAR
Create time: | 01.07.2006
Tablespace: | TSASNAA
Description: |

Columns

Colname | Order
APPLY_QUAL | ASCENDING
SET_NAME | ASCENDING
WHOS_ON_FIRST | ASCENDING
Total: 3 column(s)

Autherisations

Grantor | Grantee | Authorities
SYSIBM | USER | CONTROL=HELD
Total: 1 autherisation(s)

SQL

CREATE UNIQUE INDEX "ASN "."IBMSNAP_SUBS_SETX" ON "ASN "."IBMSNAP_SUBS_SET"
("APPLY_QUAL" ASC,
"SET_NAME" ASC,
"WHOS_ON_FIRST" ASC);

See Also

List of indexes


Index: ASN.IBMSNAP_SUBS_STMTX

Properties

Name: | IBMSNAP_SUBS_STMTX
Schema: | ASN
Table schema: | ASN
Table: | IBMSNAP_SUBS_STMTS
Unique rule: | UNIQUE
Type: | REGULAR
Create time: | 01.07.2006
Tablespace: | TSASNAA
Description: |

Columns

Colname | Order
APPLY_QUAL | ASCENDING
SET_NAME | ASCENDING
WHOS_ON_FIRST | ASCENDING
BEFORE_OR_AFTER | ASCENDING
STMT_NUMBER | ASCENDING
Total: 5 column(s)

Autherisations

Grantor | Grantee | Authorities
SYSIBM | USER | CONTROL=HELD
Total: 1 autherisation(s)

SQL

CREATE UNIQUE INDEX "ASN "."IBMSNAP_SUBS_STMTX" ON "ASN "."IBMSNAP_SUBS_STMTS"
("APPLY_QUAL" ASC,
"SET_NAME" ASC,
"WHOS_ON_FIRST" ASC,
"BEFORE_OR_AFTER" ASC,
"STMT_NUMBER" ASC);

See Also

List of indexes


Index: ASN.IBMSNAP_UOWX

Properties

Name: | IBMSNAP_UOWX
Schema: | ASN
Table schema: | ASN
Table: | IBMSNAP_UOW
Unique rule: | UNIQUE
Type: | REGULAR
Create time: | 01.07.2006
Tablespace: | TSASNUOW
Description: |

Columns

Colname | Order
IBMSNAP_COMMITSEQ | ASCENDING
IBMSNAP_LOGMARKER | ASCENDING
Total: 2 column(s)

Autherisations

Grantor | Grantee | Authorities
SYSIBM | USER | CONTROL=HELD
Total: 1 autherisation(s)

SQL

CREATE UNIQUE INDEX "ASN "."IBMSNAP_UOWX" ON "ASN "."IBMSNAP_UOW"
("IBMSNAP_COMMITSEQ" ASC,
"IBMSNAP_LOGMARKER" ASC);

See Also

List of indexes


Index: USER.IXCDSTAFF

Properties

Name: | IXCDSTAFF
Schema: | USER
Table schema: | USER
Table: | CDSTAFF
Unique rule: | UNIQUE
Type: | REGULAR
Create time: | 01.07.2006
Tablespace: | TSCDSTAFF
Description: |

Columns

Colname | Order
IBMSNAP_COMMITSEQ | ASCENDING
IBMSNAP_INTENTSEQ | ASCENDING
Total: 2 column(s)

Autherisations

Grantor | Grantee | Authorities
SYSIBM | USER | CONTROL=HELD
Total: 1 autherisation(s)

SQL

CREATE UNIQUE INDEX "USER "."IXCDSTAFF" ON "USER "."CDSTAFF"
("IBMSNAP_COMMITSEQ" ASC,
"IBMSNAP_INTENTSEQ" ASC)
PCTFREE 0 ;

See Also

List of indexes


Index: USER.IXNICK_STAFF_MQT

Properties

Name: | IXNICK_STAFF_MQT
Schema: | USER
Table schema: | USER
Table: | NICK_STAFF_MQT
Unique rule: | UNIQUE
Type: | REGULAR
Create time: | 01.07.2006
Tablespace: | NICK_STAFF_MQT_TS
Description: |

Columns

Colname | Order
ID | ASCENDING
Total: 1 column(s)

Autherisations

Grantor | Grantee | Authorities
SYSIBM | USER | CONTROL=HELD
Total: 1 autherisation(s)

SQL

See Also

List of indexes


Index: USER.IXQQQ_STAFF_MQT

Properties

Name: | IXQQQ_STAFF_MQT
Schema: | USER
Table schema: | USER
Table: | QQQ_STAFF_MQT
Unique rule: | UNIQUE
Type: | REGULAR
Create time: | 01.07.2006
Tablespace: | QQQ_STAFF_MQT_TS
Description: |

Columns

Colname | Order
ID | ASCENDING
Total: 1 column(s)

Autherisations

Grantor | Grantee | Authorities
SYSIBM | USER | CONTROL=HELD
Total: 1 autherisation(s)

SQL

See Also

List of indexes


Index: USER.PK_ACT

Properties

Name: | PK_ACT
Schema: | USER
Table schema: | USER
Table: | ACT
Unique rule: | PRIMARY
Type: | REGULAR
Create time: | 27.06.2006
Tablespace: | USERSPACE1
Description: |

Columns

Colname | Order
ACTNO | ASCENDING
Total: 1 column(s)

Autherisations

Grantor | Grantee | Authorities
SYSIBM | USER | CONTROL=HELD
Total: 1 autherisation(s)

SQL

ALTER TABLE "USER "."ACT"
ADD CONSTRAINT "PK_ACT" PRIMARY KEY
("ACTNO");

See Also

List of indexes


Index: SYSIBM.SQL060616220800090

Properties

Name: | SQL060616220800090
Schema: | SYSIBM
Table schema: | USER
Table: | EMP_PHOTO
Unique rule: | PRIMARY
Type: | REGULAR
Create time: | 16.06.2006
Tablespace: | USERSPACE1
Description: |

Columns

Colname | Order
EMPNO | ASCENDING
PHOTO_FORMAT | ASCENDING
Total: 2 column(s)

SQL

See Also

List of indexes


Index: SYSIBM.SQL060616220803090

Properties

Name: | SQL060616220803090
Schema: | SYSIBM
Table schema: | USER
Table: | EMP_RESUME
Unique rule: | PRIMARY
Type: | REGULAR
Create time: | 16.06.2006
Tablespace: | USERSPACE1
Description: |

Columns

Colname | Order
EMPNO | ASCENDING
RESUME_FORMAT | ASCENDING
Total: 2 column(s)

SQL

See Also

List of indexes


Index: USER.XACT2

Properties

Name: | XACT2
Schema: | USER
Table schema: | USER
Table: | ACT
Unique rule: | UNIQUE
Type: | REGULAR
Create time: | 27.06.2006
Tablespace: | USERSPACE1
Description: |

Columns

Colname | Order
ACTNO | ASCENDING
ACTKWD | ASCENDING
Total: 2 column(s)

Autherisations

Grantor | Grantee | Authorities
SYSIBM | USER | CONTROL=HELD
Total: 1 autherisation(s)

SQL

CREATE UNIQUE INDEX "USER "."XACT2" ON "USER "."ACT"
("ACTNO" ASC,
"ACTKWD" ASC) ALLOW REVERSE SCANS;

See Also

List of indexes


Index: USER.XACT3

Properties

Name: | XACT3
Schema: | USER
Table schema: | USER
Table: | ACT
Unique rule: | DUBLICATE
Type: | REGULAR
Create time: | 05.07.2006
Tablespace: | USERSPACE1
Description: |

Columns

Colname | Order
ACTNO | ASCENDING
ACTKWD | ASCENDING
ACTDESC | ASCENDING
Total: 3 column(s)

Autherisations

Grantor | Grantee | Authorities
SYSIBM | USER | CONTROL=HELD
Total: 1 autherisation(s)

SQL

CREATE INDEX "USER "."XACT3" ON "USER "."ACT"
("ACTNO" ASC,
"ACTKWD" ASC,
"ACTDESC" ASC) ALLOW REVERSE SCANS;

See Also

List of indexes


List of constraints

Constraints

Name | Valid | TABLE
CC1151413049172 |  | USER.ACT
CC1151754626766 |  | USER.NICK_COLUMNS
CC1151754741688 |  | USER.NICK_CHECK_CONSTRAINTS
Total: 3 constraint(s)

See Also

Database overview


Constraint: CC1151413049172

Properties

Name: | CC1151413049172
Definer: | USER
Parent: | USER.ACT
Create time: | 27.06.2006
Qualifier: | USER
Valid: |
Text: | ACTNO >1000

Columns

Colname
ACTNO
Total: 1 column(s)

SQL

ACTNO >1000

See Also

List of constraints


Constraint: CC1151754626766

Properties

Name: | CC1151754626766
Definer: | USER
Parent: | USER.NICK_COLUMNS
Create time: | 01.07.2006
Qualifier: | USER
Valid: |
Text: | TABLE_SCHEMA is not null

Columns

Colname
TABLE_SCHEMA
Total: 1 column(s)

SQL

TABLE_SCHEMA is not null

See Also

List of constraints


Constraint: CC1151754741688

Properties

Name: | CC1151754741688
Definer: | USER
Parent: | USER.NICK_CHECK_CONSTRAINTS
Create time: | 01.07.2006
Qualifier: | USER
Valid: |
Text: | CONSTRAINT_NAME is not null

Columns

Colname
CONSTRAINT_NAME
Total: 1 column(s)

SQL

CONSTRAINT_NAME is not null

See Also

List of constraints


List of views

Views

Name | Readonly | Valid | Description
USER.AAAAAAAAAAAA |  |  |
USER.VDEPT |  |  |
USER.VHDEPT |  |  |
Total: 3 view(s)

See Also

Database overview


View: USER.AAAAAAAAAAAA

Properties

Name: | AAAAAAAAAAAA
Schema: | USER
Definer: | USER
Readonly: |
Valid: |
Qualifier: | USER
Description: |

Columns

Name | Type | Length | Scale | Codepage | Nulls | Description
CONSTRAINT_CATALOG | VARCHAR | 128 | 0 | 1251 |  |
CONSTRAINT_SCHEMA | VARCHAR | 128 | 0 | 1251 |  |
CONSTRAINT_NAME | VARCHAR | 128 | 0 | 1251 |  |
CHECK_CLAUSE | CLOB | 2097152 | 0 | 1251 |  |
Total: 4 column(s)

Dipend on objects

Name
USER.NICK_CHECK_CONSTRAINTS
Total: 1 object(s)

Autherisations

Grantor | Grantee | Authorities
SYSIBM | USER | CONTROL=HELD, ALTER=NOT_HELD, DELETE=NOT_HELD, INDEX=NOT_HELD, INSERT=NOT_HELD, SELECT=HELD_GRANTABLE, REFERENCE=NOT_HELD, UPDATE=NOT_HELD
Total: 1 autherisation(s)

SQL

CREATE view "USER".AAAAAAAAAAAA as SELECT * FROM NICK_CHECK_CONSTRAINTS

See Also

List of views


View: USER.VDEPT

Properties

Name: | VDEPT
Schema: | USER
Definer: | USER
Readonly: |
Valid: |
Qualifier: | USER
Description: |

Columns

Name | Type | Length | Scale | Codepage | Nulls | Description
DEPTNO | CHARACTER | 3 | 0 | 1251 |  |
DEPTNAME | VARCHAR | 29 | 0 | 1251 |  |
MGRNO | CHARACTER | 6 | 0 | 1251 |  |
ADMRDEPT | CHARACTER | 3 | 0 | 1251 |  |
Total: 4 column(s)

Dipend on objects

Name
USER.DEPARTMENT
USER.DEPT
Total: 2 object(s)

Autherisations

Grantor | Grantee | Authorities
SYSIBM | USER | CONTROL=HELD, ALTER=NOT_HELD, DELETE=HELD_GRANTABLE, INDEX=NOT_HELD, INSERT=HELD_GRANTABLE, SELECT=HELD_GRANTABLE, REFERENCE=NOT_HELD, UPDATE=HELD_GRANTABLE
Total: 1 autherisation(s)

SQL

CREATE VIEW VDEPT AS SELECT ALL DEPTNO, DEPTNAME, MGRNO, ADMRDEPT FROM DEPT

See Also

List of views


View: USER.VHDEPT

Properties

Name: | VHDEPT
Schema: | USER
Definer: | USER
Readonly: |
Valid: |
Qualifier: | USER
Description: |

Columns

Name | Type | Length | Scale | Codepage | Nulls | Description
DEPTNO | CHARACTER | 3 | 0 | 1251 |  |
DEPTNAME | VARCHAR | 29 | 0 | 1251 |  |
MGRNO | CHARACTER | 6 | 0 | 1251 |  |
ADMRDEPT | CHARACTER | 3 | 0 | 1251 |  |
LOCATION | CHARACTER | 16 | 0 | 1251 |  |
Total: 5 column(s)

Dipend on objects

Name
USER.DEPARTMENT
USER.DEPT
Total: 2 object(s)

Autherisations

Grantor | Grantee | Authorities
SYSIBM | USER | CONTROL=HELD, ALTER=NOT_HELD, DELETE=HELD_GRANTABLE, INDEX=NOT_HELD, INSERT=HELD_GRANTABLE, SELECT=HELD_GRANTABLE, REFERENCE=NOT_HELD, UPDATE=HELD_GRANTABLE
Total: 1 autherisation(s)

SQL

CREATE VIEW VHDEPT AS SELECT ALL DEPTNO , DEPTNAME, MGRNO , ADMRDEPT, LOCATION FROM DEPT

See Also

List of views


List of aliases

Aliases

Name | Parent | Description
USER.DEPT | USER.DEPARTMENT | sddddddddd
USER.EMP | USER.EMPLOYEE |
Total: 2 alias(es)

See Also

Database overview


Alias: USER.DEPT

Properties

Name: | DEPT
Schema: | USER
Definer: | USER
Parent schema: | USER
Parent: | USER.DEPARTMENT
Description: | sddddddddd

Dipendent objects

Name
USER.VDEPT
USER.VHDEPT
Total: 2 dipendent object(s)

SQL

CREATE ALIAS "USER "."DEPT" FOR "USER "."DEPARTMENT";

COMMENT ON ALIAS "USER "."DEPT" IS 'sddddddddd';

See Also

List of aliases


Alias: USER.EMP

Properties

Name: | EMP
Schema: | USER
Definer: | USER
Parent schema: | USER
Parent: | USER.EMPLOYEE
Description: |

SQL

CREATE ALIAS "USER "."EMP" FOR "USER "."EMPLOYEE";

See Also

List of aliases


List of nicknames

Nicknames

NAME | Cached | Remote server | Remote schema | Remote table
USER.NICK_CHECK_CONSTRAINTS |  | TEST | SYSIBM | CHECK_CONSTRAINTS
USER.NICK_COLUMNS |  | TEST | SYSIBM | COLUMNS
USER.NICK_COLUMNS_S |  | TEST | SYSIBM | COLUMNS_S
USER.NICK_REF_CONSTRAINTS |  | TEST | SYSIBM | REF_CONSTRAINTS
USER.NICK_REFERENTIAL_CONSTRAINTS |  | TEST | SYSIBM | REFERENTIAL_CONSTRAINTS
USER.NICK_SALES |  | TEST | USER | SALES
USER.NICK_STAFF |  | TEST | USER | STAFF
USER.QQQ_STAFF |  | TEST | USER | STAFF
Total: 8 nickname(s)

See Also

Database overview


Nickname: USER.NICK_CHECK_CONSTRAINTS

Properties

Name: | NICK_CHECK_CONSTRAINTS
Schema: | USER
Wrapper: | CONNECT
Remote server: | TEST
Remote schema: | SYSIBM
Remote table: | CHECK_CONSTRAINTS
Readonly: |
Cached: |
Materialised view: |
Status: | NORMAL
Create time: | 01.07.2006
Description: |

Columns

Name | Type | Length | Scale | Codepage | Identity | Nulls | Default | Description
CONSTRAINT_CATALOG | VARCHAR | 128 | 0 | 1251 |  |  |  |
CONSTRAINT_SCHEMA | VARCHAR | 128 | 0 | 1251 |  |  |  |
CONSTRAINT_NAME | VARCHAR | 128 | 0 | 1251 |  |  |  |
CHECK_CLAUSE | CLOB | 2097152 | 0 | 1251 |  |  |  |
Total: 4 column(s)

Indexes

Name | Unique rule | Type | Colnames | Description
USER.CC1151754705266 | PRIMARY | REGULAR | CONSTRAINT_CATALOG, CONSTRAINT_SCHEMA, CONSTRAINT_NAME |
Total: 1 index(s)

Constraints

Name | Valid | Text
CC1151754741688 |  | CONSTRAINT_NAME is not null
Total: 1 constraint(s)

Dipendent objects

Name
USER.AAAAAAAAAAAA
Total: 1 dipendent object(s)

Autherisations

Grantor | Grantee | Authorities
SYSIBM | USER | CONTROL=HELD, ALTER=HELD_GRANTABLE, DELETE=HELD_GRANTABLE, INDEX=HELD_GRANTABLE, INSERT=HELD_GRANTABLE, SELECT=HELD_GRANTABLE, REFERENCE=HELD_GRANTABLE, UPDATE=HELD_GRANTABLE
Total: 1 autherisation(s)

See Also

List of nicknames


Nickname: USER.NICK_COLUMNS

Properties

Name: | NICK_COLUMNS
Schema: | USER
Wrapper: | CONNECT
Remote server: | TEST
Remote schema: | SYSIBM
Remote table: | COLUMNS
Readonly: |
Cached: |
Materialised view: |
Status: | NORMAL
Create time: | 01.07.2006
Description: |

Columns

Name | Type | Length | Scale | Codepage | Identity | Nulls | Default | Description
TABLE_CATALOG | VARCHAR | 128 | 0 | 1251 |  |  |  |
TABLE_SCHEMA | VARCHAR | 128 | 0 | 1251 |  |  |  |
TABLE_NAME | VARCHAR | 128 | 0 | 1251 |  |  |  |
COLUMN_NAME | VARCHAR | 128 | 0 | 1251 |  |  |  |
ORDINAL_POSITION | INTEGER | 4 | 0 | 0 |  |  |  |
COLUMN_DEFAULT | VARCHAR | 2000 | 0 | 1251 |  |  |  |
IS_NULLABLE | VARCHAR | 3 | 0 | 1251 |  |  |  |
DATA_TYPE | VARCHAR | 128 | 0 | 1251 |  |  |  |
CHARACTER_MAXIMUM_LENGTH | INTEGER | 4 | 0 | 0 |  |  |  |
CHARACTER_OCTET_LENGTH | INTEGER | 4 | 0 | 0 |  |  |  |
NUMERIC_PRECISION | INTEGER | 4 | 0 | 0 |  |  |  |
NUMERIC_PRECISION_RADIX | INTEGER | 4 | 0 | 0 |  |  |  |
NUMERIC_SCALE | INTEGER | 4 | 0 | 0 |  |  |  |
DATETIME_PRECISION | INTEGER | 4 | 0 | 0 |  |  |  |
INTERVAL_TYPE | VARCHAR | 128 | 0 | 1251 |  |  |  |
INTERVAL_PRECISION | INTEGER | 4 | 0 | 0 |  |  |  |
CHARACTER_SET_CATALOG | VARCHAR | 128 | 0 | 1251 |  |  |  |
CHARACTER_SET_SCHEMA | VARCHAR | 128 | 0 | 1251 |  |  |  |
CHARACTER_SET_NAME | VARCHAR | 128 | 0 | 1251 |  |  |  |
COLLATION_CATALOG | VARCHAR | 128 | 0 | 1251 |  |  |  |
COLLATION_SCHEMA | VARCHAR | 128 | 0 | 1251 |  |  |  |
COLLATION_NAME | VARCHAR | 128 | 0 | 1251 |  |  |  |
DOMAIN_CATALOG | VARCHAR | 128 | 0 | 1251 |  |  |  |
DOMAIN_SCHEMA | VARCHAR | 128 | 0 | 1251 |  |  |  |
DOMAIN_NAME | VARCHAR | 128 | 0 | 1251 |  |  |  |
UDT_CATALOG | VARCHAR | 128 | 0 | 1251 |  |  |  |
UDT_SCHEMA | VARCHAR | 128 | 0 | 1251 |  |  |  |
UDT_NAME | VARCHAR | 128 | 0 | 1251 |  |  |  |
SCOPE_CATALOG | VARCHAR | 128 | 0 | 1251 |  |  |  |
SCOPE_SCHEMA | VARCHAR | 128 | 0 | 1251 |  |  |  |
SCOPE_NAME | VARCHAR | 128 | 0 | 1251 |  |  |  |
MAXIMUM_CARDINALITY | INTEGER | 4 | 0 | 0 |  |  |  |
DTD_IDENTIFIER | VARCHAR | 128 | 0 | 1251 |  |  |  |
IS_SELF_REFERENCING | VARCHAR | 3 | 0 | 1251 |  |  |  |
Total: 34 column(s)

Indexes

Name | Unique rule | Type | Colnames | Description
USER.CC1151754616344 | PRIMARY | REGULAR | TABLE_CATALOG, TABLE_SCHEMA, TABLE_NAME, COLUMN_NAME |
Total: 1 index(s)

Constraints

Name | Valid | Text
CC1151754626766 |  | TABLE_SCHEMA is not null
Total: 1 constraint(s)

Autherisations

Grantor | Grantee | Authorities
SYSIBM | USER | CONTROL=HELD, ALTER=HELD_GRANTABLE, DELETE=HELD_GRANTABLE, INDEX=HELD_GRANTABLE, INSERT=HELD_GRANTABLE, SELECT=HELD_GRANTABLE, REFERENCE=HELD_GRANTABLE, UPDATE=HELD_GRANTABLE
Total: 1 autherisation(s)

See Also

List of nicknames


Nickname: USER.NICK_COLUMNS_S

Properties

Name: | NICK_COLUMNS_S
Schema: | USER
Wrapper: | CONNECT
Remote server: | TEST
Remote schema: | SYSIBM
Remote table: | COLUMNS_S
Readonly: |
Cached: |
Materialised view: |
Status: | NORMAL
Create time: | 01.07.2006
Description: |

Columns

Name | Type | Length | Scale | Codepage | Identity | Nulls | Default | Description
TABLE_CATALOG | VARCHAR | 128 | 0 | 1251 |  |  |  |
TABLE_SCHEMA | VARCHAR | 128 | 0 | 1251 |  |  |  |
TABLE_NAME | VARCHAR | 128 | 0 | 1251 |  |  |  |
COLUMN_NAME | VARCHAR | 128 | 0 | 1251 |  |  |  |
ORDINAL_POSITION | INTEGER | 4 | 0 | 0 |  |  |  |
COLUMN_DEFAULT | VARCHAR | 2000 | 0 | 1251 |  |  |  |
IS_NULLABLE | VARCHAR | 3 | 0 | 1251 |  |  |  |
DATA_TYPE | VARCHAR | 128 | 0 | 1251 |  |  |  |
CHAR_MAX_LENGTH | INTEGER | 4 | 0 | 0 |  |  |  |
CHAR_OCTET_LENGTH | INTEGER | 4 | 0 | 0 |  |  |  |
NUMERIC_PRECISION | INTEGER | 4 | 0 | 0 |  |  |  |
NUMERIC_PREC_RADIX | INTEGER | 4 | 0 | 0 |  |  |  |
NUMERIC_SCALE | INTEGER | 4 | 0 | 0 |  |  |  |
DATETIME_PRECISION | INTEGER | 4 | 0 | 0 |  |  |  |
INTERVAL_TYPE | VARCHAR | 128 | 0 | 1251 |  |  |  |
INTERVAL_PRECISION | INTEGER | 4 | 0 | 0 |  |  |  |
CHAR_SET_CATALOG | VARCHAR | 128 | 0 | 1251 |  |  |  |
CHAR_SET_SCHEMA | VARCHAR | 128 | 0 | 1251 |  |  |  |
CHARACTER_SET_NAME | VARCHAR | 128 | 0 | 1251 |  |  |  |
COLLATION_CATALOG | VARCHAR | 128 | 0 | 1251 |  |  |  |
COLLATION_SCHEMA | VARCHAR | 128 | 0 | 1251 |  |  |  |
COLLATION_NAME | VARCHAR | 128 | 0 | 1251 |  |  |  |
DOMAIN_CATALOG | VARCHAR | 128 | 0 | 1251 |  |  |  |
DOMAIN_SCHEMA | VARCHAR | 128 | 0 | 1251 |  |  |  |
DOMAIN_NAME | VARCHAR | 128 | 0 | 1251 |  |  |  |
UDT_CATALOG | VARCHAR | 128 | 0 | 1251 |  |  |  |
UDT_SCHEMA | VARCHAR | 128 | 0 | 1251 |  |  |  |
UDT_NAME | VARCHAR | 128 | 0 | 1251 |  |  |  |
SCOPE_CATALOG | VARCHAR | 128 | 0 | 1251 |  |  |  |
SCOPE_SCHEMA | VARCHAR | 128 | 0 | 1251 |  |  |  |
SCOPE_NAME | VARCHAR | 128 | 0 | 1251 |  |  |  |
MAX_CARDINALITY | INTEGER | 4 | 0 | 0 |  |  |  |
DTD_IDENTIFIER | VARCHAR | 128 | 0 | 1251 |  |  |  |
IS_SELF_REF | VARCHAR | 3 | 0 | 1251 |  |  |  |
Total: 34 column(s)

Autherisations

Grantor | Grantee | Authorities
SYSIBM | USER | CONTROL=HELD, ALTER=HELD_GRANTABLE, DELETE=HELD_GRANTABLE, INDEX=HELD_GRANTABLE, INSERT=HELD_GRANTABLE, SELECT=HELD_GRANTABLE, REFERENCE=HELD_GRANTABLE, UPDATE=HELD_GRANTABLE
Total: 1 autherisation(s)

See Also

List of nicknames


Nickname: USER.NICK_REF_CONSTRAINTS

Properties

Name: | NICK_REF_CONSTRAINTS
Schema: | USER
Wrapper: | CONNECT
Remote server: | TEST
Remote schema: | SYSIBM
Remote table: | REF_CONSTRAINTS
Readonly: |
Cached: |
Materialised view: |
Status: | NORMAL
Create time: | 01.07.2006
Description: |

Columns

Name | Type | Length | Scale | Codepage | Identity | Nulls | Default | Description
CONSTRAINT_CATALOG | VARCHAR | 128 | 0 | 1251 |  |  |  |
CONSTRAINT_SCHEMA | VARCHAR | 128 | 0 | 1251 |  |  |  |
CONSTRAINT_NAME | VARCHAR | 128 | 0 | 1251 |  |  |  |
UNIQUE_CONSTR_CAT | VARCHAR | 128 | 0 | 1251 |  |  |  |
UNIQUE_CONSTR_SCH | VARCHAR | 128 | 0 | 1251 |  |  |  |
UNIQUE_CONSTR_NAME | VARCHAR | 128 | 0 | 1251 |  |  |  |
MATCH_OPTION | VARCHAR | 4 | 0 | 1251 |  |  |  |
UPDATE_RULE | VARCHAR | 9 | 0 | 1251 |  |  |  |
DELETE_RULE | VARCHAR | 9 | 0 | 1251 |  |  |  |
Total: 9 column(s)

Autherisations

Grantor | Grantee | Authorities
SYSIBM | USER | CONTROL=HELD, ALTER=HELD_GRANTABLE, DELETE=HELD_GRANTABLE, INDEX=HELD_GRANTABLE, INSERT=HELD_GRANTABLE, SELECT=HELD_GRANTABLE, REFERENCE=HELD_GRANTABLE, UPDATE=HELD_GRANTABLE
Total: 1 autherisation(s)

See Also

List of nicknames


Nickname: USER.NICK_REFERENTIAL_CONSTRAINTS

Properties

Name: | NICK_REFERENTIAL_CONSTRAINTS
Schema: | USER
Wrapper: | CONNECT
Remote server: | TEST
Remote schema: | SYSIBM
Remote table: | REFERENTIAL_CONSTRAINTS
Readonly: |
Cached: |
Materialised view: |
Status: | NORMAL
Create time: | 01.07.2006
Description: |

Columns

Name | Type | Length | Scale | Codepage | Identity | Nulls | Default | Description
CONSTRAINT_CATALOG | VARCHAR | 128 | 0 | 1251 |  |  |  |
CONSTRAINT_SCHEMA | VARCHAR | 128 | 0 | 1251 |  |  |  |
CONSTRAINT_NAME | VARCHAR | 128 | 0 | 1251 |  |  |  |
UNIQUE_CONSTRAINT_CATALOG | VARCHAR | 128 | 0 | 1251 |  |  |  |
UNIQUE_CONSTRAINT_SCHEMA | VARCHAR | 128 | 0 | 1251 |  |  |  |
UNIQUE_CONSTRAINT_NAME | VARCHAR | 128 | 0 | 1251 |  |  |  |
MATCH_OPTION | VARCHAR | 4 | 0 | 1251 |  |  |  |
UPDATE_RULE | VARCHAR | 9 | 0 | 1251 |  |  |  |
DELETE_RULE | VARCHAR | 9 | 0 | 1251 |  |  |  |
Total: 9 column(s)

Autherisations

Grantor | Grantee | Authorities
SYSIBM | USER | CONTROL=HELD, ALTER=HELD_GRANTABLE, DELETE=HELD_GRANTABLE, INDEX=HELD_GRANTABLE, INSERT=HELD_GRANTABLE, SELECT=HELD_GRANTABLE, REFERENCE=HELD_GRANTABLE, UPDATE=HELD_GRANTABLE
Total: 1 autherisation(s)

See Also

List of nicknames


Nickname: USER.NICK_SALES

Properties

Name: | NICK_SALES
Schema: | USER
Wrapper: | CONNECT
Remote server: | TEST
Remote schema: | USER
Remote table: | SALES
Readonly: |
Cached: |
Materialised view: |
Status: | NORMAL
Create time: | 01.07.2006
Description: |

Columns

Name | Type | Length | Scale | Codepage | Identity | Nulls | Default | Description
SALES_DATE | DATE | 4 | 0 | 0 |  |  |  |
SALES_PERSON | VARCHAR | 15 | 0 | 1251 |  |  |  |
REGION | VARCHAR | 15 | 0 | 1251 |  |  |  |
SALES | INTEGER | 4 | 0 | 0 |  |  |  |
Total: 4 column(s)

Autherisations

Grantor | Grantee | Authorities
SYSIBM | USER | CONTROL=HELD, ALTER=HELD_GRANTABLE, DELETE=HELD_GRANTABLE, INDEX=HELD_GRANTABLE, INSERT=HELD_GRANTABLE, SELECT=HELD_GRANTABLE, REFERENCE=HELD_GRANTABLE, UPDATE=HELD_GRANTABLE
Total: 1 autherisation(s)

See Also

List of nicknames


Nickname: USER.NICK_STAFF

Properties

Name: | NICK_STAFF
Schema: | USER
Wrapper: | CONNECT
Remote server: | TEST
Remote schema: | USER
Remote table: | STAFF
Readonly: |
Cached: |
Materialised view: | USER.NICK_STAFF_MQT
Status: | NORMAL
Create time: | 01.07.2006
Description: |

Columns

Name | Type | Length | Scale | Codepage | Identity | Nulls | Default | Description
ID | SMALLINT | 2 | 0 | 0 |  |  |  |
NAME | VARCHAR | 9 | 0 | 1251 |  |  |  |
DEPT | SMALLINT | 2 | 0 | 0 |  |  |  |
JOB | CHARACTER | 5 | 0 | 1251 |  |  |  |
YEARS | SMALLINT | 2 | 0 | 0 |  |  |  |
SALARY | DECIMAL | 7 | 2 | 0 |  |  |  |
COMM | DECIMAL | 7 | 2 | 0 |  |  |  |
Total: 7 column(s)

Indexes

Name | Unique rule | Type | Colnames | Description
USER.CC11517556264220 | PRIMARY | REGULAR | ID |
Total: 1 index(s)

Dipendent objects

Name
USER.NICK_STAFF_MQT
Total: 1 dipendent object(s)

Autherisations

Grantor | Grantee | Authorities
SYSIBM | USER | CONTROL=HELD, ALTER=HELD_GRANTABLE, DELETE=HELD_GRANTABLE, INDEX=HELD_GRANTABLE, INSERT=HELD_GRANTABLE, SELECT=HELD_GRANTABLE, REFERENCE=HELD_GRANTABLE, UPDATE=HELD_GRANTABLE
Total: 1 autherisation(s)

See Also

List of nicknames


Nickname: USER.QQQ_STAFF

Properties

Name: | QQQ_STAFF
Schema: | USER
Wrapper: | CONNECT
Remote server: | TEST
Remote schema: | USER
Remote table: | STAFF
Readonly: |
Cached: |
Materialised view: | USER.QQQ_STAFF_MQT
Status: | NORMAL
Create time: | 01.07.2006
Description: |

Columns

Name | Type | Length | Scale | Codepage | Identity | Nulls | Default | Description
ID | SMALLINT | 2 | 0 | 0 |  |  |  |
NAME | VARCHAR | 9 | 0 | 1251 |  |  |  |
DEPT | SMALLINT | 2 | 0 | 0 |  |  |  |
JOB | CHARACTER | 5 | 0 | 1251 |  |  |  |
YEARS | SMALLINT | 2 | 0 | 0 |  |  |  |
SALARY | DECIMAL | 7 | 2 | 0 |  |  |  |
COMM | DECIMAL | 7 | 2 | 0 |  |  |  |
Total: 7 column(s)

Indexes

Name | Unique rule | Type | Colnames | Description
USER.CC11517556264221 | PRIMARY | REGULAR | ID |
Total: 1 index(s)

Referenced tables

Table | Foreign key | Primary key
USER.ACT | CC1152703301094 | PK_ACT
Total: 1 referenced table(s)

Dipendent objects

Name
USER.QQQ_STAFF_MQT
Total: 1 dipendent object(s)

Autherisations

Grantor | Grantee | Authorities
SYSIBM | USER | CONTROL=HELD, ALTER=HELD_GRANTABLE, DELETE=HELD_GRANTABLE, INDEX=HELD_GRANTABLE, INSERT=HELD_GRANTABLE, SELECT=HELD_GRANTABLE, REFERENCE=HELD_GRANTABLE, UPDATE=HELD_GRANTABLE
Total: 1 autherisation(s)

See Also

List of nicknames


List of foreign keys

Foreign keys

Table | Foreign key | Primary key
USER.ACT | CC1152703301094 | PK_ACT
Total: 1 foreign key(s)

See Also

Nickname [USER.QQQ_STAFF]


Foreign key: CC1152703301094

Properties

Name: | CC1152703301094
Table schema: | USER
Table: | USER.QQQ_STAFF
Definer: | USER
Reference key: | PK_ACT
Reference schema: | USER
Reference table: | ACT
Delete rule: | NO ACTION
Update rule: | NO ACTION
Create time: | 12.07.2006
Foreign key colnames: | ID
Primary key colnames: | ACTNO

SQL

See Also

List of foreign keys


List of materialised views

Materialised views

Name | Readonly | Valid | Cached table | Description
USER.NICK_STAFF_MQT |  |  | USER.NICK_STAFF |
USER.QQQ_STAFF_MQT |  |  | USER.QQQ_STAFF |
Total: 2 materialised view(s)

See Also

Database overview


Materialised view: USER.NICK_STAFF_MQT

Properties

Name: | NICK_STAFF_MQT
Schema: | USER
Cached schema: | USER
Cached table: | USER.NICK_STAFF
Tablespace: | NICK_STAFF_MQT_TS
Definer: | USER
Readonly: |
Valid: |
Qualifier: | USER
Description: |

Columns

Name | Type | Length | Scale | Codepage | Nulls | Description
ID | SMALLINT | 2 | 0 | 0 |  |
NAME | VARCHAR | 9 | 0 | 1251 |  |
DEPT | SMALLINT | 2 | 0 | 0 |  |
JOB | CHARACTER | 5 | 0 | 1251 |  |
YEARS | SMALLINT | 2 | 0 | 0 |  |
SALARY | DECIMAL | 7 | 2 | 0 |  |
COMM | DECIMAL | 7 | 2 | 0 |  |
Total: 7 column(s)

Dipend on objects

Name
USER.NICK_STAFF
Total: 1 object(s)

Autherisations

Grantor | Grantee | Authorities
SYSIBM | USER | CONTROL=HELD, ALTER=HELD_GRANTABLE, DELETE=HELD_GRANTABLE, INDEX=HELD_GRANTABLE, INSERT=HELD_GRANTABLE, SELECT=HELD_GRANTABLE, REFERENCE=HELD_GRANTABLE, UPDATE=HELD_GRANTABLE
Total: 1 autherisation(s)

SQL

CREATE TABLE USER.NICK_STAFF_MQT AS (SELECT * FROM "USER".NICK_STAFF) DATA INITIALLY DEFERRED REFRESH DEFERRED MAINTAINED BY FEDERATED_TOOL IN NICK_STAFF_MQT_TS

See Also

List of materialised views


Materialised view: USER.QQQ_STAFF_MQT

Properties

Name: | QQQ_STAFF_MQT
Schema: | USER
Cached schema: | USER
Cached table: | USER.QQQ_STAFF
Tablespace: | QQQ_STAFF_MQT_TS
Definer: | USER
Readonly: |
Valid: |
Qualifier: | USER
Description: |

Columns

Name | Type | Length | Scale | Codepage | Nulls | Description
ID | SMALLINT | 2 | 0 | 0 |  |
NAME | VARCHAR | 9 | 0 | 1251 |  |
DEPT | SMALLINT | 2 | 0 | 0 |  |
JOB | CHARACTER | 5 | 0 | 1251 |  |
YEARS | SMALLINT | 2 | 0 | 0 |  |
SALARY | DECIMAL | 7 | 2 | 0 |  |
COMM | DECIMAL | 7 | 2 | 0 |  |
Total: 7 column(s)

Dipend on objects

Name
USER.QQQ_STAFF
Total: 1 object(s)

Autherisations

Grantor | Grantee | Authorities
SYSIBM | USER | CONTROL=HELD, ALTER=HELD_GRANTABLE, DELETE=HELD_GRANTABLE, INDEX=HELD_GRANTABLE, INSERT=HELD_GRANTABLE, SELECT=HELD_GRANTABLE, REFERENCE=HELD_GRANTABLE, UPDATE=HELD_GRANTABLE
Total: 1 autherisation(s)

SQL

CREATE TABLE USER.QQQ_STAFF_MQT AS (SELECT * FROM "USER".QQQ_STAFF) DATA INITIALLY DEFERRED REFRESH DEFERRED MAINTAINED BY FEDERATED_TOOL IN QQQ_STAFF_MQT_TS

See Also

List of materialised views


List of triggers

Triggers

Name | Table | Valid | Time | Event | Description
USER.TR_STAFF_BEFORE | USER.STAFF |  | BEFORE | DELETE |
Total: 1 trigger(s)

See Also

Database overview


Trigger: USER.TR_STAFF_BEFORE

Properties

Name: | TR_STAFF_BEFORE
Schema: | USER
Definer: | USER
Table schema: | USER
Table: | STAFF
Valid: |
Trigtime: | BEFORE
Trigevent: | DELETE
Granularity: | ROW
Create time: | 24.06.2006
Qualifier: | USER
Description: |

SQL

CREATE TRIGGER "USER".TR_STAFF_BEFORE NO CASCADE BEFORE DELETE ON "USER".STAFF REFERENCING OLD AS OLDSTAFF FOR EACH ROW MODE DB2SQL
WHEN(oldstaff.job = 'Sales') BEGIN
ATOMIC SIGNAL SQLSTATE '75000' ('Sales staff cannot be deleted... see the DO_NOT_DEL_SALES trigger.');
END

See Also

List of triggers


List of procedures

Procedures

Name | Specific name | Description
USER.BONUS_INCREASE | BONUS_INCREASE |
Total: 1 procedure(s)

See Also

Database overview


Procedure: USER.BONUS_INCREASE

Properties

Name: | BONUS_INCREASE
Schema: | USER
Definer: | USER
Specific name: | BONUS_INCREASE
Valid: |
Create time: | 24.06.2006
Alter time: | 24.06.2006
Determenistic: |
Language: | SQL
Qualifier: | USER
Description: |

Parameters

Name | Direction | Type | Length | Scale | Codepage | Description
P_BONUSFACTOR | IN | DECIMAL | 3 | 2 | 0 |
P_BONUSMAXSUMFORDEPT | IN | DECIMAL | 9 | 2 | 0 |
P_DEPTSWITHOUTNEWBONUSES | OUT | VARCHAR | 255 | 0 | 1251 |
P_COUNTDEPTSVIEWED | OUT | INTEGER | 4 | 0 | 0 |
P_COUNTDEPTSBONUSCHANGED | OUT | INTEGER | 4 | 0 | 0 |
P_ERRORMSG | OUT | VARCHAR | 255 | 0 | 1251 |
Total: 6 parameter(s)

Dipend on objects

Name
USER.P4434996
Total: 1 object(s)

Autherisations

Grantor | Grantee | Authorities
SYSIBM | USER | EXECUTE=HELD_GRANTABLE
Total: 1 autherisation(s)

SQL

CREATE PROCEDURE bonus_increase (IN p_bonusFactor
DECIMAL (3,2), IN p_bonusMaxSumForDept DECIMAL
(9,2), OUT p_deptsWithoutNewBonuses VARCHAR(255),
OUT p_countDeptsViewed INTEGER,
OUT p_countDeptsBonusChanged INTEGER,
OUT p_errorMsg VARCHAR(255)) SPECIFIC BONUS_INCREASE
LANGUAGE SQL
DYNAMIC RESULT SETS 1

BEGIN
DECLARE v_dept, v_actdept CHAR(3);--
DECLARE v_bonus, v_deptbonus, v_newbonus DECIMAL(9,2);--
DECLARE v_empno CHAR(6);--
DECLARE v_atend SMALLINT DEFAULT 0;--

RETURN -1;--

END

See Also

List of procedures


List of functions

Functions

Name | Specific name | Description
USER.RESIGN_EMPLOYEE | SQL060624144124500 |
Total: 1 function(s)

See Also

Database overview


Function: USER.RESIGN_EMPLOYEE

Properties

Name: | RESIGN_EMPLOYEE
Schema: | USER
Definer: | USER
Specific name: | SQL060624144124500
Valid: |
Create time: | 24.06.2006
Alter time: | 24.06.2006
Qualifier: | USER
Determenistic: |
Language: | SQL
Description: |

Parameters

Name | Direction | Type | Length | Scale | Codepage | Description
EMPNO | BEFORE CASTING | CHARACTER | 6 | 0 | 1251 |
NUMBER | IN | CHARACTER | 6 | 0 | 1251 |
SALARY | BEFORE CASTING | DOUBLE | 8 | 0 | 0 |
DEPT | BEFORE CASTING | CHARACTER | 3 | 0 | 1251 |
Total: 4 parameter(s)

SQL

CREATE FUNCTION resign_employee (number CHAR(6))
RETURNS TABLE (empno CHAR(6),
salary DOUBLE,
dept CHAR(3))
MODIFIES SQL DATA
LANGUAGE SQL
BEGIN ATOMIC
DECLARE l_salary DOUBLE;--
DECLARE l_job CHAR(3);--

RETURN VALUES (number,l_salary, l_job);--

END

See Also

List of functions


List of packages

Packages

Name | Description
USER.P4434996 |
Total: 1 package(s)

See Also

Database overview


Package: USER.P4434996

Properties

Name: | P4434996
Schema: | USER
Boundby: | USER
Definer: | USER
Default schema: | USER
Valid: |
Version: |
Create time: | 24.06.2006
Description: |

Dipendent objects

Name
USER.BONUS_INCREASE
Total: 1 dipendent object(s)

Autherisations

Grantor | Grantee | Authorities
SYSIBM | USER | CONTROL=HELD, BIND=HELD_GRANTABLE, EXECUTE=HELD_GRANTABLE
Total: 1 autherisation(s)

See Also

List of packages


List of datatypes

Datatypes

Name | Definer | Description
USER.NEW_TYPE2 | USER |
USER.PERSON_T | USER |
Total: 2 datatype(s)

See Also

Database overview


Datatype: USER.NEW_TYPE2

Properties

Name: | NEW_TYPE2
Schema: | USER
Definer: | USER
Source schema: | SYSIBM
Source name: | SMALLINT
Length: | 2
Scale: | 0
Codepage: | 0
Final: |
Inline length: | 0
Natural inline length: |
Create time: | 24.06.2006
Alter time: |
Description: |

SQL

CREATE DISTINCT TYPE "USER "."NEW_TYPE2" AS "SYSIBM ".SMALLINT
WITH COMPARISONS;

See Also

List of datatypes


Datatype: USER.PERSON_T

Properties

Name: | PERSON_T
Schema: | USER
Definer: | USER
Source schema: | SYSIBM
Source name: | VARCHAR
Length: | 13
Scale: | 0
Codepage: | 0
Final: |
Inline length: | 74
Natural inline length: | 74
Create time: | 24.06.2006
Alter time: |
Description: |

SQL

CREATE TYPE "USER "."PERSON_T" AS
("NAME" VARCHAR(20),
"AGE" INTEGER)
INSTANTIABLE
INLINE LENGTH 74
WITHOUT COMPARISONS
NOT FINAL
REF USING VARCHAR(13) FOR BIT DATA
MODE DB2SQL;

See Also

List of datatypes


List of sequences

Sequences

Name | Start | Increment | Min | Max | Cycle | Ordered | Cache | Description
USER.SAMPSEQUENCE | 1 | 1 | 1 | 9223372036854775807 |  |  | 20 |
Total: 1 sequence(s)

See Also

Database overview


Sequence: USER.SAMPSEQUENCE

Properties

Name: | SAMPSEQUENCE
Schema: | USER
Definer: | USER
Owner: | USER
Start: | 1
Min: | 1
Max: | 9223372036854775807
Increment: | 1
Cycle: |
Order: |
Cache: | 20
Create time: | 24.06.2006
Alter time: | 24.06.2006
Description: |

Autherisations

Grantor | Grantee | Authorities
SYSIBM | USER | USAGE=HELD_GRANTABLE, ALTER=HELD_GRANTABLE
Total: 1 autherisation(s)

SQL

CREATE SEQUENCE "USER "."SAMPSEQUENCE" AS BIGINT
MINVALUE 1 MAXVALUE 9223372036854775807
START WITH 1 INCREMENT BY 1
CACHE 20 NO CYCLE NO ORDER;

See Also

List of sequences


List of tablespaces

Tablespaces

Tbspace | Definer | Description
NICK_STAFF_MQT_TS | USER |
QQQ_STAFF_MQT_TS | USER |
SYSCATSPACE | SYSIBM |
SYSTOOLSPACE | DB2ADMIN |
TEMPSPACE1 | SYSIBM |
TSASNAA | USER |
TSASNCA | USER |
TSASNUOW | USER |
TSCDSTAFF | USER |
USERSPACE1 | SYSIBM |
Total: 10 tablespace(s)

See Also

Database overview


Tablespace: NICK_STAFF_MQT_TS

Properties

Name: | NICK_STAFF_MQT_TS
Definer: | USER
Create time: | 01.07.2006
Extent size: | 8
Prefetch size: | 8
Overhead: | 12,67
Transfer rate: | 0,18
Page size: | 4096
Default partition group: | IBMDEFAULTGROUP
Bufferpool: | IBMDEFAULTBP
Drop recovery: |
Description: |

Autherisations

Grantor | Grantee | Authorities
SYSIBM | USER | USE=HELD_GRANTABLE
Total: 1 autherisation(s)

SQL

CREATE REGULAR TABLESPACE NICK_STAFF_MQT_TS IN DATABASE PARTITION GROUP IBMDEFAULTGROUP PAGESIZE 4096 MANAGED BY SYSTEM
USING ('C:\DB2\NODE0000\SQL00001\NICK_STAFF_MQT_TS')
EXTENTSIZE 8
PREFETCHSIZE 8
BUFFERPOOL IBMDEFAULTBP
OVERHEAD 12.670000
TRANSFERRATE 0.180000
DROPPED TABLE RECOVERY ON;

See Also

List of tablespaces


Tablespace: QQQ_STAFF_MQT_TS

Properties

Name: | QQQ_STAFF_MQT_TS
Definer: | USER
Create time: | 01.07.2006
Extent size: | 8
Prefetch size: | 8
Overhead: | 12,67
Transfer rate: | 0,18
Page size: | 4096
Default partition group: | IBMDEFAULTGROUP
Bufferpool: | IBMDEFAULTBP
Drop recovery: |
Description: |

Autherisations

Grantor | Grantee | Authorities
SYSIBM | USER | USE=HELD_GRANTABLE
Total: 1 autherisation(s)

SQL

CREATE REGULAR TABLESPACE QQQ_STAFF_MQT_TS IN DATABASE PARTITION GROUP IBMDEFAULTGROUP PAGESIZE 4096 MANAGED BY SYSTEM
USING ('C:\DB2\NODE0000\SQL00001\QQQ_STAFF_MQT_TS')
EXTENTSIZE 8
PREFETCHSIZE 8
BUFFERPOOL IBMDEFAULTBP
OVERHEAD 12.670000
TRANSFERRATE 0.180000
DROPPED TABLE RECOVERY ON;
ALTER TABLESPACE SYSCATSPACE
PREFETCHSIZE AUTOMATIC
OVERHEAD 12.670000
TRANSFERRATE 0.180000;
ALTER TABLESPACE TEMPSPACE1
PREFETCHSIZE AUTOMATIC
OVERHEAD 12.670000
TRANSFERRATE 0.180000;
ALTER TABLESPACE USERSPACE1
PREFETCHSIZE AUTOMATIC
OVERHEAD 12.670000
TRANSFERRATE 0.180000;

See Also

List of tablespaces


Tablespace: SYSCATSPACE

Properties

Name: | SYSCATSPACE
Definer: | SYSIBM
Create time: | 16.06.2006
Extent size: | 32
Prefetch size: | -1
Overhead: | 12,67
Transfer rate: | 0,18
Page size: | 4096
Default partition group: | IBMCATGROUP
Bufferpool: | IBMDEFAULTBP
Drop recovery: |
Description: |

SQL

See Also

List of tablespaces


Tablespace: SYSTOOLSPACE

Properties

Name: | SYSTOOLSPACE
Definer: | DB2ADMIN
Create time: | 24.06.2006
Extent size: | 32
Prefetch size: | -1
Overhead: | 12,67
Transfer rate: | 0,18
Page size: | 4096
Default partition group: | IBMCATGROUP
Bufferpool: | IBMDEFAULTBP
Drop recovery: |
Description: |

Autherisations

Grantor | Grantee | Authorities
SYSIBM | DB2ADMIN | USE=HELD_GRANTABLE
Total: 1 autherisation(s)

SQL

CREATE REGULAR TABLESPACE SYSTOOLSPACE IN DATABASE PARTITION GROUP IBMCATGROUP PAGESIZE 4096 MANAGED BY SYSTEM
USING ('C:\DB2\NODE0000\SQL00001\SYSTOOLSPACE')
EXTENTSIZE 32
PREFETCHSIZE AUTOMATIC
BUFFERPOOL IBMDEFAULTBP
OVERHEAD 12.670000
TRANSFERRATE 0.180000
DROPPED TABLE RECOVERY ON;

See Also

List of tablespaces


Tablespace: TEMPSPACE1

Properties

Name: | TEMPSPACE1
Definer: | SYSIBM
Create time: | 16.06.2006
Extent size: | 32
Prefetch size: | -1
Overhead: | 12,67
Transfer rate: | 0,18
Page size: | 4096
Default partition group: | IBMTEMPGROUP
Bufferpool: | IBMDEFAULTBP
Drop recovery: |
Description: |

SQL

See Also

List of tablespaces


Tablespace: TSASNAA

Properties

Name: | TSASNAA
Definer: | USER
Create time: | 01.07.2006
Extent size: | 32
Prefetch size: | -1
Overhead: | 12,67
Transfer rate: | 0,18
Page size: | 4096
Default partition group: | IBMDEFAULTGROUP
Bufferpool: | IBMDEFAULTBP
Drop recovery: |
Description: |

Autherisations

Grantor | Grantee | Authorities
SYSIBM | USER | USE=HELD_GRANTABLE
Total: 1 autherisation(s)

SQL

CREATE REGULAR TABLESPACE TSASNAA IN DATABASE PARTITION GROUP IBMDEFAULTGROUP PAGESIZE 4096 MANAGED BY DATABASE
USING (FILE 'C:\DB2\NODE0000\SQL00001\TSASNAA'2560)
EXTENTSIZE 32
PREFETCHSIZE AUTOMATIC
BUFFERPOOL IBMDEFAULTBP
OVERHEAD 12.670000
TRANSFERRATE 0.180000
DROPPED TABLE RECOVERY ON;

See Also

List of tablespaces


Tablespace: TSASNCA

Properties

Name: | TSASNCA
Definer: | USER
Create time: | 01.07.2006
Extent size: | 32
Prefetch size: | -1
Overhead: | 12,67
Transfer rate: | 0,18
Page size: | 4096
Default partition group: | IBMDEFAULTGROUP
Bufferpool: | IBMDEFAULTBP
Drop recovery: |
Description: |

Autherisations

Grantor | Grantee | Authorities
SYSIBM | USER | USE=HELD_GRANTABLE
Total: 1 autherisation(s)

SQL

CREATE REGULAR TABLESPACE TSASNCA IN DATABASE PARTITION GROUP IBMDEFAULTGROUP PAGESIZE 4096 MANAGED BY DATABASE
USING (FILE 'C:\DB2\NODE0000\SQL00001\TSASNCA'2560)
EXTENTSIZE 32
PREFETCHSIZE AUTOMATIC
BUFFERPOOL IBMDEFAULTBP
OVERHEAD 12.670000
TRANSFERRATE 0.180000
DROPPED TABLE RECOVERY ON;

See Also

List of tablespaces


Tablespace: TSASNUOW

Properties

Name: | TSASNUOW
Definer: | USER
Create time: | 01.07.2006
Extent size: | 32
Prefetch size: | -1
Overhead: | 12,67
Transfer rate: | 0,18
Page size: | 4096
Default partition group: | IBMDEFAULTGROUP
Bufferpool: | IBMDEFAULTBP
Drop recovery: |
Description: |

Autherisations

Grantor | Grantee | Authorities
SYSIBM | USER | USE=HELD_GRANTABLE
Total: 1 autherisation(s)

SQL

CREATE REGULAR TABLESPACE TSASNUOW IN DATABASE PARTITION GROUP IBMDEFAULTGROUP PAGESIZE 4096 MANAGED BY DATABASE
USING (FILE 'C:\DB2\NODE0000\SQL00001\TSASNUOW'2560)
EXTENTSIZE 32
PREFETCHSIZE AUTOMATIC
BUFFERPOOL IBMDEFAULTBP
OVERHEAD 12.670000
TRANSFERRATE 0.180000
DROPPED TABLE RECOVERY ON;

See Also

List of tablespaces


Tablespace: TSCDSTAFF

Properties

Name: | TSCDSTAFF
Definer: | USER
Create time: | 01.07.2006
Extent size: | 32
Prefetch size: | -1
Overhead: | 12,67
Transfer rate: | 0,18
Page size: | 4096
Default partition group: | IBMDEFAULTGROUP
Bufferpool: | IBMDEFAULTBP
Drop recovery: |
Description: |

Autherisations

Grantor | Grantee | Authorities
SYSIBM | USER | USE=HELD_GRANTABLE
Total: 1 autherisation(s)

SQL

CREATE REGULAR TABLESPACE TSCDSTAFF IN DATABASE PARTITION GROUP IBMDEFAULTGROUP PAGESIZE 4096 MANAGED BY DATABASE
USING (FILE 'C:\DB2\NODE0000\SQL00001\CDSTAFF'512)
EXTENTSIZE 32
PREFETCHSIZE AUTOMATIC
BUFFERPOOL IBMDEFAULTBP
OVERHEAD 12.670000
TRANSFERRATE 0.180000
DROPPED TABLE RECOVERY ON;

See Also

List of tablespaces


Tablespace: USERSPACE1

Properties

Name: | USERSPACE1
Definer: | SYSIBM
Create time: | 16.06.2006
Extent size: | 32
Prefetch size: | -1
Overhead: | 12,67
Transfer rate: | 0,18
Page size: | 4096
Default partition group: | IBMDEFAULTGROUP
Bufferpool: | IBMDEFAULTBP
Drop recovery: |
Description: |

Autherisations

Grantor | Grantee | Authorities
SYSIBM | PUBLIC | USE=HELD
Total: 1 autherisation(s)

SQL

See Also

List of tablespaces


List of schemas

Schemas

Name | Owner | Definer | Description
ASN | SYSIBM | USER |
NULLID | SYSIBM | USER |
SQLJ | SYSIBM | USER |
SYSCAT | SYSIBM | SYSIBM |
SYSFUN | SYSIBM | SYSIBM |
SYSIBM | SYSIBM | SYSIBM |
SYSPROC | SYSIBM | SYSIBM |
SYSSTAT | SYSIBM | SYSIBM |
SYSTOOLS | SYSIBM | DB2ADMIN |
USER | SYSIBM | USER |
Total: 10 schema(s)

See Also

Database overview


Schema: ASN

Properties

Name: | ASN
Owner: | SYSIBM
Definer: | USER
Create time: | 01.07.2006
Description: |

Autherisations

Grantor | Grantee | Authorities
SYSIBM | PUBLIC | ALTER=NOT_HELD, CREATE=HELD, DROP=NOT_HELD
Total: 1 autherisation(s)

See Also

List of schemas


Schema: NULLID

Properties

Name: | NULLID
Owner: | SYSIBM
Definer: | USER
Create time: | 16.06.2006
Description: |

See Also

List of schemas


Schema: SQLJ

Properties

Name: | SQLJ
Owner: | SYSIBM
Definer: | USER
Create time: | 16.06.2006
Description: |

See Also

List of schemas


Schema: SYSCAT

Properties

Name: | SYSCAT
Owner: | SYSIBM
Definer: | SYSIBM
Create time: | 16.06.2006
Description: |

See Also

List of schemas


Schema: SYSFUN

Properties

Name: | SYSFUN
Owner: | SYSIBM
Definer: | SYSIBM
Create time: | 16.06.2006
Description: |

See Also

List of schemas


Schema: SYSIBM

Properties

Name: | SYSIBM
Owner: | SYSIBM
Definer: | SYSIBM
Create time: | 16.06.2006
Description: |

See Also

List of schemas


Schema: SYSPROC

Properties

Name: | SYSPROC
Owner: | SYSIBM
Definer: | SYSIBM
Create time: | 16.06.2006
Description: |

See Also

List of schemas


Schema: SYSSTAT

Properties

Name: | SYSSTAT
Owner: | SYSIBM
Definer: | SYSIBM
Create time: | 16.06.2006
Description: |

See Also

List of schemas


Schema: SYSTOOLS

Properties

Name: | SYSTOOLS
Owner: | SYSIBM
Definer: | DB2ADMIN
Create time: | 24.06.2006
Description: |

See Also

List of schemas


Schema: USER

Properties

Name: | USER
Owner: | SYSIBM
Definer: | USER
Create time: | 16.06.2006
Description: |

Autherisations

Grantor | Grantee | Authorities
SYSIBM | PUBLIC | ALTER=NOT_HELD, CREATE=HELD, DROP=NOT_HELD
Total: 1 autherisation(s)

See Also

List of schemas


List of bufferpools

Bufferpools

Name | Size | Use extended memory
IBMDEFAULTBP | 250 |
Total: 1 bufferpool(s)

See Also

Database overview


Bufferpool: IBMDEFAULTBP

Properties

Name: | IBMDEFAULTBP
Default partition group: |
Pages: | 250
Page size: | 4096
Extended memory: |
Block pages: | 0
Block size: | 0

See Also

List of bufferpools


List of eventmonitors

Eventmonitors

Name | Definer | Description
DB2DETAILDEADLOCK | USER |
XXXXX | USER |
Total: 2 eventmonitor(s)

See Also

Database overview


Eventmonitor: DB2DETAILDEADLOCK

Properties

Name: | DB2DETAILDEADLOCK
Definer: | USER
Target type: | FILE
Target: | db2detaildeadlock
Max files: | 20
Max file size: | 512
Buffer size: | 17
Io mode: | BLOCKED
Write mode: | APPEND
Autostart: |
Nodes: | 0
Scope: | L
Activates: | 0
Description: |

Events

Name | Filter
DETAILDEADLOCKS |
Total: 1 event(s)

See Also

List of eventmonitors


Eventmonitor: XXXXX

Properties

Name: | XXXXX
Definer: | USER
Target type: | TABLE
Target: |
Max files: |
Max file size: |
Buffer size: | 4
Io mode: | NOT BLOCKED
Write mode: |
Autostart: |
Nodes: | 0
Scope: | T
Activates: | 1
Description: |

Events

Name | Filter
DATABASE |
DEADLOCKS |
Total: 2 event(s)

See Also

List of eventmonitors


List of wrappers

Wrappers

Name | Library | Wraptype | Description
CONNECT | db2drda.dll | RELATIONAL |
Total: 1 wrapper(s)

See Also

Database overview


Wrapper: CONNECT

Properties

Name: | CONNECT
Type: | RELATIONAL
Version: | 0
Library: | db2drda.dll
Description: |

Servers

Name | Type | Version | Description
TEST | DB2/UDB | 8.2 |
TEST222 | DB2/UDB | 8.1 |
XXXXX | DB2/UDB | 8.1 |
Total: 3 server(s)

Options

Option | Setting
DB2_FENCED | N
Total: 1 option(s)

See Also

List of wrappers


List of servers

Servers

Name | Type | Version | Description
TEST | DB2/UDB | 8.2 |
TEST222 | DB2/UDB | 8.1 |
XXXXX | DB2/UDB | 8.1 |
Total: 3 wrapper_server(s)

See Also

Wrapper [SAMPLE]


Wrapper server: TEST

Properties

Name: | TEST
Type: | DB2/UDB
Version: | 8.2
Description: |

Options

Option | Setting
DBNAME | SAMPLE
PASSWORD | Y
Total: 2 option(s)

User mappings

AuthId | Option | Setting
DB2ADMIN | REMOTE_AUTHID | db2admin
USER | REMOTE_AUTHID | db2admin
Total: 2 user mapping(s)

Nicknames

NAME | Cached | Remote schema | Remote table
USER.NICK_CHECK_CONSTRAINTS |  | SYSIBM | CHECK_CONSTRAINTS
USER.NICK_COLUMNS |  | SYSIBM | COLUMNS
USER.NICK_COLUMNS_S |  | SYSIBM | COLUMNS_S
USER.NICK_REF_CONSTRAINTS |  | SYSIBM | REF_CONSTRAINTS
USER.NICK_REFERENTIAL_CONSTRAINTS |  | SYSIBM | REFERENTIAL_CONSTRAINTS
USER.NICK_SALES |  | USER | SALES
USER.NICK_STAFF |  | USER | STAFF
USER.QQQ_STAFF |  | USER | STAFF
Total: 8 nickname(s)

See Also

List of servers


Wrapper server: TEST222

Properties

Name: | TEST222
Type: | DB2/UDB
Version: | 8.1
Description: |

Options

Option | Setting
DBNAME | TEST
PASSWORD | Y
Total: 2 option(s)

User mappings

AuthId | Option | Setting
DB2ADMIN | REMOTE_AUTHID | db2admin
Total: 1 user mapping(s)

See Also

List of servers


Wrapper server: XXXXX

Properties

Name: | XXXXX
Type: | DB2/UDB
Version: | 8.1
Description: |

Options

Option | Setting
DBNAME | TEST
PASSWORD | Y
Total: 2 option(s)

See Also

List of servers


List of users

Users

Name
DB2ADMIN
USER
Total: 2 user(s)

See Also

Database overview


User: DB2ADMIN

Properties

Name: DB2ADMIN

Autherisations

Grantor | Object | Authorities
SYSIBM | SYSTOOLSPACE | USE=HELD_GRANTABLE
Total: 1 autherisation(s)

See Also

List of users


User: USER

Properties

Name: USER

Autherisations

Grantor | Object | Authorities
SYSIBM | SAMPLE | DBA=HELD, CREATETABLE=HELD, BIND=HELD, CONNECT=HELD, NOFENCE=HELD, IMPLICIT_SCHEMA=HELD, LOAD=HELD, CREATE_EXTERNAL_ROUTINE=HELD, QUIESCE_CONNECT=HELD, LIBRARY_ADMIN=NOT_HELD, SECURITY_ADMIN=NOT_HELD
SYSIBM | USER.AAAAAAAAAAAA | CONTROL=HELD, ALTER=NOT_HELD, DELETE=NOT_HELD, INDEX=NOT_HELD, INSERT=NOT_HELD, SELECT=HELD_GRANTABLE, REFERENCE=NOT_HELD, UPDATE=NOT_HELD
SYSIBM | USER.ACT | CONTROL=HELD, ALTER=HELD_GRANTABLE, DELETE=HELD_GRANTABLE, INDEX=HELD_GRANTABLE, INSERT=HELD_GRANTABLE, SELECT=HELD_GRANTABLE, REFERENCE=HELD_GRANTABLE, UPDATE=HELD_GRANTABLE
SYSIBM | USER.BONUS_INCREASE | EXECUTE=HELD_GRANTABLE
SYSIBM | USER.CC1151754616344 | CONTROL=HELD
SYSIBM | USER.CC1151754705266 | CONTROL=HELD
SYSIBM | USER.CC1151755626422 | CONTROL=HELD
SYSIBM | USER.CC11517556264220 | CONTROL=HELD
SYSIBM | USER.CC11517556264221 | CONTROL=HELD
SYSIBM | USER.CC1151755924953 | CONTROL=HELD
SYSIBM | USER.CC1151778928062 | CONTROL=HELD
SYSIBM | USER.CDSTAFF | CONTROL=HELD, ALTER=HELD_GRANTABLE, DELETE=HELD_GRANTABLE, INDEX=HELD_GRANTABLE, INSERT=HELD_GRANTABLE, SELECT=HELD_GRANTABLE, REFERENCE=HELD_GRANTABLE, UPDATE=HELD_GRANTABLE
SYSIBM | USER.CL_SCHED | CONTROL=HELD, ALTER=HELD_GRANTABLE, DELETE=HELD_GRANTABLE, INDEX=HELD_GRANTABLE, INSERT=HELD_GRANTABLE, SELECT=HELD_GRANTABLE, REFERENCE=HELD_GRANTABLE, UPDATE=HELD_GRANTABLE
SYSIBM | USER.CONNHEADER_XXXXX | CONTROL=HELD, ALTER=HELD_GRANTABLE, DELETE=HELD_GRANTABLE, INDEX=HELD_GRANTABLE, INSERT=HELD_GRANTABLE, SELECT=HELD_GRANTABLE, REFERENCE=HELD_GRANTABLE, UPDATE=HELD_GRANTABLE
SYSIBM | USER.CONTROL_XXXXX | CONTROL=HELD, ALTER=HELD_GRANTABLE, DELETE=HELD_GRANTABLE, INDEX=HELD_GRANTABLE, INSERT=HELD_GRANTABLE, SELECT=HELD_GRANTABLE, REFERENCE=HELD_GRANTABLE, UPDATE=HELD_GRANTABLE
SYSIBM | USER.DB_XXXXX | CONTROL=HELD, ALTER=HELD_GRANTABLE, DELETE=HELD_GRANTABLE, INDEX=HELD_GRANTABLE, INSERT=HELD_GRANTABLE, SELECT=HELD_GRANTABLE, REFERENCE=HELD_GRANTABLE, UPDATE=HELD_GRANTABLE
SYSIBM | USER.DBMEMUSE_XXXXX | CONTROL=HELD, ALTER=HELD_GRANTABLE, DELETE=HELD_GRANTABLE, INDEX=HELD_GRANTABLE, INSERT=HELD_GRANTABLE, SELECT=HELD_GRANTABLE, REFERENCE=HELD_GRANTABLE, UPDATE=HELD_GRANTABLE
SYSIBM | USER.DEADLOCK_XXXXX | CONTROL=HELD, ALTER=HELD_GRANTABLE, DELETE=HELD_GRANTABLE, INDEX=HELD_GRANTABLE, INSERT=HELD_GRANTABLE, SELECT=HELD_GRANTABLE, REFERENCE=HELD_GRANTABLE, UPDATE=HELD_GRANTABLE
SYSIBM | USER.DEPARTMENT | CONTROL=HELD, ALTER=HELD_GRANTABLE, DELETE=HELD_GRANTABLE, INDEX=HELD_GRANTABLE, INSERT=HELD_GRANTABLE, SELECT=HELD_GRANTABLE, REFERENCE=HELD_GRANTABLE, UPDATE=HELD_GRANTABLE
SYSIBM | USER.DLCONN_XXXXX | CONTROL=HELD, ALTER=HELD_GRANTABLE, DELETE=HELD_GRANTABLE, INDEX=HELD_GRANTABLE, INSERT=HELD_GRANTABLE, SELECT=HELD_GRANTABLE, REFERENCE=HELD_GRANTABLE, UPDATE=HELD_GRANTABLE
SYSIBM | USER.EMP_ACT | CONTROL=HELD, ALTER=HELD_GRANTABLE, DELETE=HELD_GRANTABLE, INDEX=HELD_GRANTABLE, INSERT=HELD_GRANTABLE, SELECT=HELD_GRANTABLE, REFERENCE=HELD_GRANTABLE, UPDATE=HELD_GRANTABLE
SYSIBM | USER.EMP_PHOTO | CONTROL=HELD, ALTER=HELD_GRANTABLE, DELETE=HELD_GRANTABLE, INDEX=HELD_GRANTABLE, INSERT=HELD_GRANTABLE, SELECT=HELD_GRANTABLE, REFERENCE=HELD_GRANTABLE, UPDATE=HELD_GRANTABLE
SYSIBM | USER.EMP_RESUME | CONTROL=HELD, ALTER=HELD_GRANTABLE, DELETE=HELD_GRANTABLE, INDEX=HELD_GRANTABLE, INSERT=HELD_GRANTABLE, SELECT=HELD_GRANTABLE, REFERENCE=HELD_GRANTABLE, UPDATE=HELD_GRANTABLE
SYSIBM | USER.EMPLOYEE | CONTROL=HELD, ALTER=HELD_GRANTABLE, DELETE=HELD_GRANTABLE, INDEX=HELD_GRANTABLE, INSERT=HELD_GRANTABLE, SELECT=HELD_GRANTABLE, REFERENCE=HELD_GRANTABLE, UPDATE=HELD_GRANTABLE
SYSIBM | ASN.IBMSNAP_APPENQ | CONTROL=HELD, ALTER=HELD_GRANTABLE, DELETE=HELD_GRANTABLE, INDEX=HELD_GRANTABLE, INSERT=HELD_GRANTABLE, SELECT=HELD_GRANTABLE, REFERENCE=HELD_GRANTABLE, UPDATE=HELD_GRANTABLE
SYSIBM | ASN.IBMSNAP_APPENQX | CONTROL=HELD
SYSIBM | ASN.IBMSNAP_APPLYTRACE | CONTROL=HELD, ALTER=HELD_GRANTABLE, DELETE=HELD_GRANTABLE, INDEX=HELD_GRANTABLE, INSERT=HELD_GRANTABLE, SELECT=HELD_GRANTABLE, REFERENCE=HELD_GRANTABLE, UPDATE=HELD_GRANTABLE
SYSIBM | ASN.IBMSNAP_APPLYTRACX | CONTROL=HELD
SYSIBM | ASN.IBMSNAP_APPLYTRAIL | CONTROL=HELD, ALTER=HELD_GRANTABLE, DELETE=HELD_GRANTABLE, INDEX=HELD_GRANTABLE, INSERT=HELD_GRANTABLE, SELECT=HELD_GRANTABLE, REFERENCE=HELD_GRANTABLE, UPDATE=HELD_GRANTABLE
SYSIBM | ASN.IBMSNAP_APPLYTRLX | CONTROL=HELD
SYSIBM | ASN.IBMSNAP_APPPARMS | CONTROL=HELD, ALTER=HELD_GRANTABLE, DELETE=HELD_GRANTABLE, INDEX=HELD_GRANTABLE, INSERT=HELD_GRANTABLE, SELECT=HELD_GRANTABLE, REFERENCE=HELD_GRANTABLE, UPDATE=HELD_GRANTABLE
SYSIBM | ASN.IBMSNAP_APPPARMSX | CONTROL=HELD
SYSIBM | ASN.IBMSNAP_CAPENQ | CONTROL=HELD, ALTER=HELD_GRANTABLE, DELETE=HELD_GRANTABLE, INDEX=HELD_GRANTABLE, INSERT=HELD_GRANTABLE, SELECT=HELD_GRANTABLE, REFERENCE=HELD_GRANTABLE, UPDATE=HELD_GRANTABLE
SYSIBM | ASN.IBMSNAP_CAPMON | CONTROL=HELD, ALTER=HELD_GRANTABLE, DELETE=HELD_GRANTABLE, INDEX=HELD_GRANTABLE, INSERT=HELD_GRANTABLE, SELECT=HELD_GRANTABLE, REFERENCE=HELD_GRANTABLE, UPDATE=HELD_GRANTABLE
SYSIBM | ASN.IBMSNAP_CAPMONX | CONTROL=HELD
SYSIBM | ASN.IBMSNAP_CAPPARMS | CONTROL=HELD, ALTER=HELD_GRANTABLE, DELETE=HELD_GRANTABLE, INDEX=HELD_GRANTABLE, INSERT=HELD_GRANTABLE, SELECT=HELD_GRANTABLE, REFERENCE=HELD_GRANTABLE, UPDATE=HELD_GRANTABLE
SYSIBM | ASN.IBMSNAP_CAPSCHEMAS | CONTROL=HELD, ALTER=HELD_GRANTABLE, DELETE=HELD_GRANTABLE, INDEX=HELD_GRANTABLE, INSERT=HELD_GRANTABLE, SELECT=HELD_GRANTABLE, REFERENCE=HELD_GRANTABLE, UPDATE=HELD_GRANTABLE
SYSIBM | ASN.IBMSNAP_CAPSCHEMAX | CONTROL=HELD
SYSIBM | ASN.IBMSNAP_CAPTRACE | CONTROL=HELD, ALTER=HELD_GRANTABLE, DELETE=HELD_GRANTABLE, INDEX=HELD_GRANTABLE, INSERT=HELD_GRANTABLE, SELECT=HELD_GRANTABLE, REFERENCE=HELD_GRANTABLE, UPDATE=HELD_GRANTABLE
SYSIBM | ASN.IBMSNAP_CAPTRACEX | CONTROL=HELD
SYSIBM | ASN.IBMSNAP_COMPENSATE | CONTROL=HELD, ALTER=HELD_GRANTABLE, DELETE=HELD_GRANTABLE, INDEX=HELD_GRANTABLE, INSERT=HELD_GRANTABLE, SELECT=HELD_GRANTABLE, REFERENCE=HELD_GRANTABLE, UPDATE=HELD_GRANTABLE
SYSIBM | ASN.IBMSNAP_COMPENSATX | CONTROL=HELD
SYSIBM | ASN.IBMSNAP_PRUNCNTL | CONTROL=HELD, ALTER=HELD_GRANTABLE, DELETE=HELD_GRANTABLE, INDEX=HELD_GRANTABLE, INSERT=HELD_GRANTABLE, SELECT=HELD_GRANTABLE, REFERENCE=HELD_GRANTABLE, UPDATE=HELD_GRANTABLE
SYSIBM | ASN.IBMSNAP_PRUNCNTLX | CONTROL=HELD
SYSIBM | ASN.IBMSNAP_PRUNCNTLX1 | CONTROL=HELD
SYSIBM | ASN.IBMSNAP_PRUNCNTLX2 | CONTROL=HELD
SYSIBM | ASN.IBMSNAP_PRUNCNTLX3 | CONTROL=HELD
SYSIBM | ASN.IBMSNAP_PRUNE_LOCK | CONTROL=HELD, ALTER=HELD_GRANTABLE, DELETE=HELD_GRANTABLE, INDEX=HELD_GRANTABLE, INSERT=HELD_GRANTABLE, SELECT=HELD_GRANTABLE, REFERENCE=HELD_GRANTABLE, UPDATE=HELD_GRANTABLE
SYSIBM | ASN.IBMSNAP_PRUNE_SET | CONTROL=HELD, ALTER=HELD_GRANTABLE, DELETE=HELD_GRANTABLE, INDEX=HELD_GRANTABLE, INSERT=HELD_GRANTABLE, SELECT=HELD_GRANTABLE, REFERENCE=HELD_GRANTABLE, UPDATE=HELD_GRANTABLE
SYSIBM | ASN.IBMSNAP_PRUNE_SETX | CONTROL=HELD
SYSIBM | ASN.IBMSNAP_REGISTER | CONTROL=HELD, ALTER=HELD_GRANTABLE, DELETE=HELD_GRANTABLE, INDEX=HELD_GRANTABLE, INSERT=HELD_GRANTABLE, SELECT=HELD_GRANTABLE, REFERENCE=HELD_GRANTABLE, UPDATE=HELD_GRANTABLE
SYSIBM | ASN.IBMSNAP_REGISTERX | CONTROL=HELD
SYSIBM | ASN.IBMSNAP_REGISTERX1 | CONTROL=HELD
SYSIBM | ASN.IBMSNAP_REGISTERX2 | CONTROL=HELD
SYSIBM | ASN.IBMSNAP_RESTART | CONTROL=HELD, ALTER=HELD_GRANTABLE, DELETE=HELD_GRANTABLE, INDEX=HELD_GRANTABLE, INSERT=HELD_GRANTABLE, SELECT=HELD_GRANTABLE, REFERENCE=HELD_GRANTABLE, UPDATE=HELD_GRANTABLE
SYSIBM | ASN.IBMSNAP_SIGNAL | CONTROL=HELD, ALTER=HELD_GRANTABLE, DELETE=HELD_GRANTABLE, INDEX=HELD_GRANTABLE, INSERT=HELD_GRANTABLE, SELECT=HELD_GRANTABLE, REFERENCE=HELD_GRANTABLE, UPDATE=HELD_GRANTABLE
SYSIBM | ASN.IBMSNAP_SIGNALX | CONTROL=HELD
SYSIBM | ASN.IBMSNAP_SUBS_COLS | CONTROL=HELD, ALTER=HELD_GRANTABLE, DELETE=HELD_GRANTABLE, INDEX=HELD_GRANTABLE, INSERT=HELD_GRANTABLE, SELECT=HELD_GRANTABLE, REFERENCE=HELD_GRANTABLE, UPDATE=HELD_GRANTABLE
SYSIBM | ASN.IBMSNAP_SUBS_COLSX | CONTROL=HELD
SYSIBM | ASN.IBMSNAP_SUBS_EVENT | CONTROL=HELD, ALTER=HELD_GRANTABLE, DELETE=HELD_GRANTABLE, INDEX=HELD_GRANTABLE, INSERT=HELD_GRANTABLE, SELECT=HELD_GRANTABLE, REFERENCE=HELD_GRANTABLE, UPDATE=HELD_GRANTABLE
SYSIBM | ASN.IBMSNAP_SUBS_EVENX | CONTROL=HELD
SYSIBM | ASN.IBMSNAP_SUBS_MEMBR | CONTROL=HELD, ALTER=HELD_GRANTABLE, DELETE=HELD_GRANTABLE, INDEX=HELD_GRANTABLE, INSERT=HELD_GRANTABLE, SELECT=HELD_GRANTABLE, REFERENCE=HELD_GRANTABLE, UPDATE=HELD_GRANTABLE
SYSIBM | ASN.IBMSNAP_SUBS_MEMBX | CONTROL=HELD
SYSIBM | ASN.IBMSNAP_SUBS_SET | CONTROL=HELD, ALTER=HELD_GRANTABLE, DELETE=HELD_GRANTABLE, INDEX=HELD_GRANTABLE, INSERT=HELD_GRANTABLE, SELECT=HELD_GRANTABLE, REFERENCE=HELD_GRANTABLE, UPDATE=HELD_GRANTABLE
SYSIBM | ASN.IBMSNAP_SUBS_SETX | CONTROL=HELD
SYSIBM | ASN.IBMSNAP_SUBS_STMTS | CONTROL=HELD, ALTER=HELD_GRANTABLE, DELETE=HELD_GRANTABLE, INDEX=HELD_GRANTABLE, INSERT=HELD_GRANTABLE, SELECT=HELD_GRANTABLE, REFERENCE=HELD_GRANTABLE, UPDATE=HELD_GRANTABLE
SYSIBM | ASN.IBMSNAP_SUBS_STMTX | CONTROL=HELD
SYSIBM | ASN.IBMSNAP_UOW | CONTROL=HELD, ALTER=HELD_GRANTABLE, DELETE=HELD_GRANTABLE, INDEX=HELD_GRANTABLE, INSERT=HELD_GRANTABLE, SELECT=HELD_GRANTABLE, REFERENCE=HELD_GRANTABLE, UPDATE=HELD_GRANTABLE
SYSIBM | ASN.IBMSNAP_UOWX | CONTROL=HELD
SYSIBM | USER.IN_TRAY | CONTROL=HELD, ALTER=HELD_GRANTABLE, DELETE=HELD_GRANTABLE, INDEX=HELD_GRANTABLE, INSERT=HELD_GRANTABLE, SELECT=HELD_GRANTABLE, REFERENCE=HELD_GRANTABLE, UPDATE=HELD_GRANTABLE
SYSIBM | USER.IXCDSTAFF | CONTROL=HELD
SYSIBM | USER.IXNICK_STAFF_MQT | CONTROL=HELD
SYSIBM | USER.IXQQQ_STAFF_MQT | CONTROL=HELD
SYSIBM | USER.NICK_CHECK_CONSTRAINTS | CONTROL=HELD, ALTER=HELD_GRANTABLE, DELETE=HELD_GRANTABLE, INDEX=HELD_GRANTABLE, INSERT=HELD_GRANTABLE, SELECT=HELD_GRANTABLE, REFERENCE=HELD_GRANTABLE, UPDATE=HELD_GRANTABLE
SYSIBM | USER.NICK_COLUMNS | CONTROL=HELD, ALTER=HELD_GRANTABLE, DELETE=HELD_GRANTABLE, INDEX=HELD_GRANTABLE, INSERT=HELD_GRANTABLE, SELECT=HELD_GRANTABLE, REFERENCE=HELD_GRANTABLE, UPDATE=HELD_GRANTABLE
SYSIBM | USER.NICK_COLUMNS_S | CONTROL=HELD, ALTER=HELD_GRANTABLE, DELETE=HELD_GRANTABLE, INDEX=HELD_GRANTABLE, INSERT=HELD_GRANTABLE, SELECT=HELD_GRANTABLE, REFERENCE=HELD_GRANTABLE, UPDATE=HELD_GRANTABLE
SYSIBM | USER.NICK_REF_CONSTRAINTS | CONTROL=HELD, ALTER=HELD_GRANTABLE, DELETE=HELD_GRANTABLE, INDEX=HELD_GRANTABLE, INSERT=HELD_GRANTABLE, SELECT=HELD_GRANTABLE, REFERENCE=HELD_GRANTABLE, UPDATE=HELD_GRANTABLE
SYSIBM | USER.NICK_REFERENTIAL_CONSTRAINTS | CONTROL=HELD, ALTER=HELD_GRANTABLE, DELETE=HELD_GRANTABLE, INDEX=HELD_GRANTABLE, INSERT=HELD_GRANTABLE, SELECT=HELD_GRANTABLE, REFERENCE=HELD_GRANTABLE, UPDATE=HELD_GRANTABLE
SYSIBM | USER.NICK_SALES | CONTROL=HELD, ALTER=HELD_GRANTABLE, DELETE=HELD_GRANTABLE, INDEX=HELD_GRANTABLE, INSERT=HELD_GRANTABLE, SELECT=HELD_GRANTABLE, REFERENCE=HELD_GRANTABLE, UPDATE=HELD_GRANTABLE
SYSIBM | USER.NICK_STAFF | CONTROL=HELD, ALTER=HELD_GRANTABLE, DELETE=HELD_GRANTABLE, INDEX=HELD_GRANTABLE, INSERT=HELD_GRANTABLE, SELECT=HELD_GRANTABLE, REFERENCE=HELD_GRANTABLE, UPDATE=HELD_GRANTABLE
SYSIBM | USER.NICK_STAFF_MQT | CONTROL=HELD, ALTER=HELD_GRANTABLE, DELETE=HELD_GRANTABLE, INDEX=HELD_GRANTABLE, INSERT=HELD_GRANTABLE, SELECT=HELD_GRANTABLE, REFERENCE=HELD_GRANTABLE, UPDATE=HELD_GRANTABLE
SYSIBM | NICK_STAFF_MQT_TS | USE=HELD_GRANTABLE
SYSIBM | USER.ORG | CONTROL=HELD, ALTER=HELD_GRANTABLE, DELETE=HELD_GRANTABLE, INDEX=HELD_GRANTABLE, INSERT=HELD_GRANTABLE, SELECT=HELD_GRANTABLE, REFERENCE=HELD_GRANTABLE, UPDATE=HELD_GRANTABLE
SYSIBM | USER.P4434996 | CONTROL=HELD, BIND=HELD_GRANTABLE, EXECUTE=HELD_GRANTABLE
SYSIBM | USER.PK_ACT | CONTROL=HELD
SYSIBM | USER.PROJECT | CONTROL=HELD, ALTER=HELD_GRANTABLE, DELETE=HELD_GRANTABLE, INDEX=HELD_GRANTABLE, INSERT=HELD_GRANTABLE, SELECT=HELD_GRANTABLE, REFERENCE=HELD_GRANTABLE, UPDATE=HELD_GRANTABLE
SYSIBM | USER.QQQ_STAFF | CONTROL=HELD, ALTER=HELD_GRANTABLE, DELETE=HELD_GRANTABLE, INDEX=HELD_GRANTABLE, INSERT=HELD_GRANTABLE, SELECT=HELD_GRANTABLE, REFERENCE=HELD_GRANTABLE, UPDATE=HELD_GRANTABLE
SYSIBM | USER.QQQ_STAFF_MQT | CONTROL=HELD, ALTER=HELD_GRANTABLE, DELETE=HELD_GRANTABLE, INDEX=HELD_GRANTABLE, INSERT=HELD_GRANTABLE, SELECT=HELD_GRANTABLE, REFERENCE=HELD_GRANTABLE, UPDATE=HELD_GRANTABLE
SYSIBM | QQQ_STAFF_MQT_TS | USE=HELD_GRANTABLE
SYSIBM | USER.SALES | CONTROL=HELD, ALTER=HELD_GRANTABLE, DELETE=HELD_GRANTABLE, INDEX=HELD_GRANTABLE, INSERT=HELD_GRANTABLE, SELECT=HELD_GRANTABLE, REFERENCE=HELD_GRANTABLE, UPDATE=HELD_GRANTABLE
SYSIBM | USER.SAMPSEQUENCE | USAGE=HELD_GRANTABLE, ALTER=HELD_GRANTABLE
SYSIBM | USER.SQL060624144124500 | EXECUTE=HELD_GRANTABLE
SYSIBM | USER.STAFF | CONTROL=HELD, ALTER=HELD_GRANTABLE, DELETE=HELD_GRANTABLE, INDEX=HELD_GRANTABLE, INSERT=HELD_GRANTABLE, SELECT=HELD_GRANTABLE, REFERENCE=HELD_GRANTABLE, UPDATE=HELD_GRANTABLE
SYSIBM | TSASNAA | USE=HELD_GRANTABLE
SYSIBM | TSASNCA | USE=HELD_GRANTABLE
SYSIBM | TSASNUOW | USE=HELD_GRANTABLE
SYSIBM | TSCDSTAFF | USE=HELD_GRANTABLE
SYSIBM | USER.VDEPT | CONTROL=HELD, ALTER=NOT_HELD, DELETE=HELD_GRANTABLE, INDEX=NOT_HELD, INSERT=HELD_GRANTABLE, SELECT=HELD_GRANTABLE, REFERENCE=NOT_HELD, UPDATE=HELD_GRANTABLE
SYSIBM | USER.VHDEPT | CONTROL=HELD, ALTER=NOT_HELD, DELETE=HELD_GRANTABLE, INDEX=NOT_HELD, INSERT=HELD_GRANTABLE, SELECT=HELD_GRANTABLE, REFERENCE=NOT_HELD, UPDATE=HELD_GRANTABLE
SYSIBM | USER.XACT2 | CONTROL=HELD
SYSIBM | USER.XACT3 | CONTROL=HELD
Total: 101 autherisation(s)

See Also

List of users


List of groups

groups

Name
PUBLIC
Total: 1 group(s)

See Also

Database overview


Group: PUBLIC

Properties

Name: PUBLIC

Autherisations

Grantor | Object | Authorities
USER | SAMPLE | DBA=NOT_HELD, CREATETABLE=HELD, BIND=HELD, CONNECT=HELD, NOFENCE=NOT_HELD, IMPLICIT_SCHEMA=NOT_HELD, LOAD=NOT_HELD, CREATE_EXTERNAL_ROUTINE=NOT_HELD, QUIESCE_CONNECT=NOT_HELD, LIBRARY_ADMIN=NOT_HELD, SECURITY_ADMIN=NOT_HELD
SYSIBM | SAMPLE | DBA=NOT_HELD, CREATETABLE=HELD, BIND=HELD, CONNECT=HELD, NOFENCE=NOT_HELD, IMPLICIT_SCHEMA=HELD, LOAD=NOT_HELD, CREATE_EXTERNAL_ROUTINE=NOT_HELD, QUIESCE_CONNECT=NOT_HELD, LIBRARY_ADMIN=NOT_HELD, SECURITY_ADMIN=NOT_HELD
SYSIBM | ASN | ALTER=NOT_HELD, CREATE=HELD, DROP=NOT_HELD
SYSIBM | USER | ALTER=NOT_HELD, CREATE=HELD, DROP=NOT_HELD
SYSIBM | USERSPACE1 | USE=HELD
Total: 5 autherisation(s)

See Also

List of groups


Instance Info

Instance information

Name:
Partitionable:
Partions:
Architecture:
Release number:
Service level:
Build level:
Program temporary fix:
Fixpack number:

System information

OS:
OS Version:
OS Release:
Host name:
Total CPUs:
Configured CPUs:
Total memory:

Configuration

Name | Value in memory | Value on disk
AGENT_STACK_SZ | 16 | 16
AGENTPRI | -1 | -1
ASLHEAPSZ | 15 | 15
AUDIT_BUF_SZ | 0 | 0
AUTHENTICATION | 0 | 0
BACKBUFSZ | 1024 | 1024
CATALOG_NOAUTH | 0 | 0
CLNT_KRB_PLUGIN | IBMkrb5 | IBMkrb5
CLNT_PW_PLUGIN |  |
COMM_BANDWIDTH | 0 | 0
CONN_ELAPSE | 0 | 0
CPUSPEED | 3,936202E-07 | 3,936202E-07
DATALINKS | 0 | 0
DBMCONFIG_TYPE | 0 | 1
DFT_ACCOUNT_STR |  |
DFT_CLIENT_ADPT | 0 | 0
DFT_CLIENT_COMM |  |
DFT_MON_BUFPOOL | 0 | 0
DFT_MON_LOCK | 0 | 0
DFT_MON_SORT | 0 | 0
DFT_MON_STMT | 0 | 0
DFT_MON_TABLE | 0 | 0
DFT_MON_UOW | 0 | 0
DFT_MONSWITCHES | 64 | 64
DFTDBPATH | C: | C:
DIAGLEVEL | 3 | 3
DIAGPATH |  |
DIR_CACHE | 1 | 1
DIR_OBJ_NAME |  |
DIR_PATH_NAME | /.:/subsys/database/ | /.:/subsys/database/
DIR_TYPEC | 0 | 0
DISCOVER_COMM |  |
DISCOVER_INST | 1 | 1
DISCOVERD | 2 | 2
DOS_RQRIOBLK | 4096 | 4096
DRDA_HEAP_SZ | 128 | 128
FCM_NUM_ANCHORS | -1 | -1
FCM_NUM_BUFFERS | 1024 | 0
FCM_NUM_CONNECT | -1 | -1
FCM_NUM_RQB | 512 | 0
FEDERATED | 0 | 0
FILESERVER |  |
GROUP_PLUGIN |  |
INDEXRECE | 2 | 2
INITDARI_JVM | 0 | 0
INTRA_PARALLEL | 0 | 0
IPX_SOCKET | 879E | 879E
JAVA_HEAP_SZ | 512 | 512
JDK11_PATH | C:\Program Files\IBM\SQLLIB\java\jdk | C:\Program Files\IBM\SQLLIB\java\jdk
KEEPDARI | 1 | 1
LOCAL_GSSPLUGIN |  |
MAX_CONNRETRIES | 0 | 0
MAX_COORDAGENTS | -1 | 200
MAX_LOGICAGENTS | 1 | 0
MAX_QUERYDEGREE | -1 | -1
MAX_TIME_DIFF | 0 | 0
MAXAGENTS | 200 | 200
MAXCAGENTS | -1 | 200
MAXDARI | -1 | -1
MAXTOTFILOP | 16000 | 16000
MIN_PRIV_MEM | 32 | 32
MON_HEAP_SZ | 66 | 66
NNAME |  |
NODETYPE | 1 | 1
NOTIFYLEVEL | 3 | 3
NUM_INITAGENTS | 0 | 0
NUM_INITDARIS | 0 | 0
NUM_POOLAGENTS | -1 | 100
NUMDB | 8 | 8
OBJECTNAME |  |
PLUGIN_MODE | 1 | 1
PRIV_MEM_THRESH | 20000 | 20000
QUERY_HEAP_SZ | 1000 | 1000
RELEASE | 2560 | 2560
RESTBUFSZ | 1024 | 1024
RESYNC_INTERVAL | 180 | 180
ROUTE_OBJ_NAME |  |
RQRIOBLK | 32767 | 32767
SHEAPTHRES | 10000 | 10000
SPM_LOG_FILE_SZ | 256 | 256
SPM_MAX_RESYNC | 20 | 20
SPM_NAME | TEZORRO | TEZORRO
SPM_PATH_NAME |  |
SRVCON_AUTH | 255 | 255
SRVCON_GSSPLUGIN_LIST |  |
SRVCON_PW_PLUGIN |  |
SS_LOGON | 1 | 1
START_STOP_TIME | 0 | 0
SVCENAME | db2c_DB2 | db2c_DB2
SYSADM_GROUP |  |
SYSCTRL_GROUP |  |
SYSMAINT_GROUP |  |
TM_DATABASE | 1ST_CONN | 1ST_CONN
TP_MON_NAME |  |
TPNAME |  |
TRUST_ALLCLNTSF | 1 | 1
TRUST_CLNTAUTH | 0 | 0
UDF_MEM_SZ | 256 | 256


About

Documentation details

Customer: |
Project: |
Created: | 30.07.2006