List of databases

Databases

Database | CharacterSet | Collation
mysql | latin1 | latin1_swedish_ci
test | latin1 | latin1_swedish_ci
Total: 2 database(s)

See Also

Server overview


List of databases

Databases

Database | Default Character Set | Default Character Collation
mysql | latin1 | latin1_swedish_ci
test | latin1 | latin1_swedish_ci
Total: 2 database(s)

See Also

Server overview


Database: mysql

Properties

Name: | mysql
Default Character Set: | latin1
Default Character Collation: | latin1_swedish_ci

Tables

Name | Engine | Comment
columns_priv | MyISAM | Column privileges1
db | MyISAM | Database privileges
func | MyISAM | User defined functions
help_keyword | MyISAM | help keywords
help_relation | MyISAM | keyword-topic relation
help_topic | MyISAM | help topics
host | MyISAM | Host privileges1; Merged with database privileges
proc | MyISAM | Stored Procedures
procs_priv | MyISAM | Procedure privileges
tables_priv | MyISAM | Table privileges
test1 | InnoDB | test1 table description; InnoDB free: 4096 kB; (`a1`) REFER `mysql/test3`(`a3`)
test2 | InnoDB | InnoDB free: 4096 kB; (`a2`) REFER `mysql/test3`(`a3`)
test3 | InnoDB | InnoDB free: 4096 kB
test4 | InnoDB | InnoDB free: 4096 kB
time_zone | MyISAM | Time zones
time_zone_leap_second | MyISAM | Leap seconds information for time zones
time_zone_name | MyISAM | Time zone names
time_zone_transition | MyISAM | Time zone transitions
time_zone_transition_type | MyISAM | Time zone transition types
user | MyISAM | Users and global privileges
Total: 20 table(s)

Views

Name | Check Option | Updatable | Definer | Security Type
newview | NONE |  | root@localhost | DEFINER
Total: 1 view(s)

Procedures

Name | Language | Security Type | Definer | Comment
simpleproc | SQL | DEFINER | root@localhost | The following is an example of a simple stored procedure that us
simpleproc1 | SQL | DEFINER | root@localhost | The following is an example of a simple stored procedure that us
Total: 2 procedure(s)

Functions

Name | Language | Security Type | Definer | Comment
fun1 | SQL | DEFINER | root@localhost | helllo world function
Total: 1 function(s)

SQL

CREATE DATABASE `mysql` /*!40100 DEFAULT CHARACTER SET latin1 */

See Also

Server overview


List of tables

Tables

Name | Engine | Comment
columns_priv | MyISAM | Column privileges1
db | MyISAM | Database privileges
func | MyISAM | User defined functions
help_keyword | MyISAM | help keywords
help_relation | MyISAM | keyword-topic relation
help_topic | MyISAM | help topics
host | MyISAM | Host privileges1; Merged with database privileges
proc | MyISAM | Stored Procedures
procs_priv | MyISAM | Procedure privileges
tables_priv | MyISAM | Table privileges
test1 | InnoDB | test1 table description; InnoDB free: 4096 kB; (`a1`) REFER `mysql/test3`(`a3`)
test2 | InnoDB | InnoDB free: 4096 kB; (`a2`) REFER `mysql/test3`(`a3`)
test3 | InnoDB | InnoDB free: 4096 kB
test4 | InnoDB | InnoDB free: 4096 kB
time_zone | MyISAM | Time zones
time_zone_leap_second | MyISAM | Leap seconds information for time zones
time_zone_name | MyISAM | Time zone names
time_zone_transition | MyISAM | Time zone transitions
time_zone_transition_type | MyISAM | Time zone transition types
user | MyISAM | Users and global privileges
Total: 20 table(s)

See Also

Database overview


Table: columns_priv

Properties

Engine: | MyISAM
Version: | 10
Row format: | Fixed
Rows: | 0
Avg row length: | 0
Data length: | 0
Max data length: | 227994731135631359
Index length: | 1024
Data free: | 0
Auto increment: |
Create time: | 10.10.2006
Update time: | 10.10.2006
Check time: |
Collation: | utf8_bin
Checksum: |
Create options: |
Comment: | Column privileges1

Columns

Name | Data Type | NULL | Identity | Default | Comment
Host | char(60) |  |  |  | Host
Db | char(64) |  |  |  | DB
User | char(16) |  |  |  |
Table_name | char(64) |  |  |  |
Column_name | char(64) |  |  |  |
Timestamp | timestamp |  |  | CURRENT_TIMESTAMP |
Column_priv | set('Select', 'Insert', 'Update', 'References') |  |  |  |
Total: 7 column(s)

Indexes

Name | Primary | Unique
PRIMARY |  |
Total: 1 indexes(s)

SQL

CREATE TABLE `columns_priv` (
`Host` char(60) collate utf8_bin NOT NULL COMMENT 'Host',
`Db` char(64) collate utf8_bin NOT NULL COMMENT 'DB',
`User` char(16) collate utf8_bin NOT NULL default '',
`Table_name` char(64) collate utf8_bin NOT NULL default '',
`Column_name` char(64) collate utf8_bin NOT NULL default '',
`Timestamp` timestamp NOT NULL default CURRENT_TIMESTAMP on update CURRENT_TIMESTAMP,
`Column_priv` set('Select','Insert','Update','References') character set utf8 NOT NULL default '',
PRIMARY KEY (`Host`,`Db`,`User`,`Table_name`,`Column_name`)
) ENGINE=MyISAM DEFAULT CHARSET=utf8 COLLATE=utf8_bin COMMENT='Column privileges1'

See Also

List of tables


List of indexes

Indexes

Name | Primary | Unique
PRIMARY |  |
Total: 1 index(s)

See Also

Table [columns_priv]


Index: PRIMARY on table columns_priv

Properties

Primary: |
Unique: |
Collation: | A
Type: | BTREE
Comment: |

Index Columns

Name | Collation
Host | A
Db | A
User | A
Table_name | A
Column_name | A
Total: 5 column(s)

See Also

List of indexes


Table: db

Properties

Engine: | MyISAM
Version: | 10
Row format: | Fixed
Rows: | 0
Avg row length: | 0
Data length: | 876
Max data length: | 123286039799267327
Index length: | 4096
Data free: | 876
Auto increment: |
Create time: | 07.04.2007
Update time: | 08.07.2004
Check time: | 07.04.2007
Collation: | utf8_bin
Checksum: |
Create options: |
Comment: | Database privileges

Columns

Name | Data Type | NULL | Identity | Default | Comment
Host | char(60) |  |  |  |
Db | char(64) |  |  |  |
User | char(16) |  |  |  |
Select_priv | enum('N', 'Y') |  |  | N |
Insert_priv | enum('N', 'Y') |  |  | N |
Update_priv | enum('N', 'Y') |  |  | N |
Delete_priv | enum('N', 'Y') |  |  | N |
Create_priv | enum('N', 'Y') |  |  | N |
Drop_priv | enum('N', 'Y') |  |  | N |
Grant_priv | enum('N', 'Y') |  |  | N |
References_priv | enum('N', 'Y') |  |  | N |
Index_priv | enum('N', 'Y') |  |  | N |
Alter_priv | enum('N', 'Y') |  |  | N |
Create_tmp_table_priv | enum('N', 'Y') |  |  | N |
Lock_tables_priv | enum('N', 'Y') |  |  | N |
Create_view_priv | enum('N', 'Y') |  |  | N |
Show_view_priv | enum('N', 'Y') |  |  | N |
Create_routine_priv | enum('N', 'Y') |  |  | N |
Alter_routine_priv | enum('N', 'Y') |  |  | N |
Execute_priv | enum('N', 'Y') |  |  | N |
Total: 20 column(s)

Indexes

Name | Primary | Unique
PRIMARY |  |
User |  |
Total: 2 indexes(s)

SQL

CREATE TABLE `db` (
`Host` char(60) collate utf8_bin NOT NULL default '',
`Db` char(64) collate utf8_bin NOT NULL default '',
`User` char(16) collate utf8_bin NOT NULL default '',
`Select_priv` enum('N','Y') character set utf8 NOT NULL default 'N',
`Insert_priv` enum('N','Y') character set utf8 NOT NULL default 'N',
`Update_priv` enum('N','Y') character set utf8 NOT NULL default 'N',
`Delete_priv` enum('N','Y') character set utf8 NOT NULL default 'N',
`Create_priv` enum('N','Y') character set utf8 NOT NULL default 'N',
`Drop_priv` enum('N','Y') character set utf8 NOT NULL default 'N',
`Grant_priv` enum('N','Y') character set utf8 NOT NULL default 'N',
`References_priv` enum('N','Y') character set utf8 NOT NULL default 'N',
`Index_priv` enum('N','Y') character set utf8 NOT NULL default 'N',
`Alter_priv` enum('N','Y') character set utf8 NOT NULL default 'N',
`Create_tmp_table_priv` enum('N','Y') character set utf8 NOT NULL default 'N',
`Lock_tables_priv` enum('N','Y') character set utf8 NOT NULL default 'N',
`Create_view_priv` enum('N','Y') character set utf8 NOT NULL default 'N',
`Show_view_priv` enum('N','Y') character set utf8 NOT NULL default 'N',
`Create_routine_priv` enum('N','Y') character set utf8 NOT NULL default 'N',
`Alter_routine_priv` enum('N','Y') character set utf8 NOT NULL default 'N',
`Execute_priv` enum('N','Y') character set utf8 NOT NULL default 'N',
PRIMARY KEY (`Host`,`Db`,`User`),
KEY `User` (`User`)
) ENGINE=MyISAM DEFAULT CHARSET=utf8 COLLATE=utf8_bin COMMENT='Database privileges'

See Also

List of tables


List of indexes

Indexes

Name | Primary | Unique
PRIMARY |  |
User |  |
Total: 2 index(s)

See Also

Table [db]


Index: PRIMARY on table db

Properties

Primary: |
Unique: |
Collation: | A
Type: | BTREE
Comment: |

Index Columns

Name | Collation
Host | A
Db | A
User | A
Total: 3 column(s)

See Also

List of indexes


Index: User on table db

Properties

Primary: |
Unique: |
Collation: | A
Type: | BTREE
Comment: |

Index Columns

Name | Collation
User | A
Total: 1 column(s)

See Also

List of indexes


Table: func

Properties

Engine: | MyISAM
Version: | 10
Row format: | Fixed
Rows: | 0
Avg row length: | 0
Data length: | 0
Max data length: | 162974011515469823
Index length: | 1024
Data free: | 0
Auto increment: |
Create time: | 07.04.2007
Update time: | 07.04.2007
Check time: |
Collation: | utf8_bin
Checksum: |
Create options: |
Comment: | User defined functions

Columns

Name | Data Type | NULL | Identity | Default | Comment
name | char(64) |  |  |  |
ret | tinyint(1) |  |  | 0 |
dl | char(128) |  |  |  |
type | enum('function', 'aggregate') |  |  |  |
Total: 4 column(s)

Indexes

Name | Primary | Unique
PRIMARY |  |
Total: 1 indexes(s)

SQL

CREATE TABLE `func` (
`name` char(64) collate utf8_bin NOT NULL default '',
`ret` tinyint(1) NOT NULL default '0',
`dl` char(128) collate utf8_bin NOT NULL default '',
`type` enum('function','aggregate') character set utf8 NOT NULL,
PRIMARY KEY (`name`)
) ENGINE=MyISAM DEFAULT CHARSET=utf8 COLLATE=utf8_bin COMMENT='User defined functions'

See Also

List of tables


List of indexes

Indexes

Name | Primary | Unique
PRIMARY |  |
Total: 1 index(s)

See Also

Table [func]


Index: PRIMARY on table func

Properties

Primary: |
Unique: |
Collation: | A
Type: | BTREE
Comment: |

Index Columns

Name | Collation
name | A
Total: 1 column(s)

See Also

List of indexes


Table: help_keyword

Properties

Engine: | MyISAM
Version: | 10
Row format: | Fixed
Rows: | 395
Avg row length: | 197
Data length: | 77815
Max data length: | 55450570411999231
Index length: | 14336
Data free: | 0
Auto increment: |
Create time: | 07.04.2007
Update time: | 07.04.2007
Check time: |
Collation: | utf8_general_ci
Checksum: |
Create options: |
Comment: | help keywords

Columns

Name | Data Type | NULL | Identity | Default | Comment
help_keyword_id | int(10) unsigned |  |  |  |
name | char(64) |  |  |  |
Total: 2 column(s)

Indexes

Name | Primary | Unique
name |  |
PRIMARY |  |
Total: 2 indexes(s)

SQL

CREATE TABLE `help_keyword` (
`help_keyword_id` int(10) unsigned NOT NULL,
`name` char(64) NOT NULL,
PRIMARY KEY (`help_keyword_id`),
UNIQUE KEY `name` (`name`)
) ENGINE=MyISAM DEFAULT CHARSET=utf8 COMMENT='help keywords'

See Also

List of tables


List of indexes

Indexes

Name | Primary | Unique
name |  |
PRIMARY |  |
Total: 2 index(s)

See Also

Table [help_keyword]


Index: name on table help_keyword

Properties

Primary: |
Unique: |
Collation: | A
Type: | BTREE
Comment: |

Index Columns

Name | Collation
name | A
Total: 1 column(s)

See Also

List of indexes


Index: PRIMARY on table help_keyword

Properties

Primary: |
Unique: |
Collation: | A
Type: | BTREE
Comment: |

Index Columns

Name | Collation
help_keyword_id | A
Total: 1 column(s)

See Also

List of indexes


Table: help_relation

Properties

Engine: | MyISAM
Version: | 10
Row format: | Fixed
Rows: | 809
Avg row length: | 9
Data length: | 7281
Max data length: | 2533274790395903
Index length: | 15360
Data free: | 0
Auto increment: |
Create time: | 07.04.2007
Update time: | 07.04.2007
Check time: |
Collation: | utf8_general_ci
Checksum: |
Create options: |
Comment: | keyword-topic relation

Columns

Name | Data Type | NULL | Identity | Default | Comment
help_topic_id | int(10) unsigned |  |  |  |
help_keyword_id | int(10) unsigned |  |  |  |
Total: 2 column(s)

Indexes

Name | Primary | Unique
PRIMARY |  |
Total: 1 indexes(s)

SQL

CREATE TABLE `help_relation` (
`help_topic_id` int(10) unsigned NOT NULL,
`help_keyword_id` int(10) unsigned NOT NULL,
PRIMARY KEY (`help_keyword_id`,`help_topic_id`)
) ENGINE=MyISAM DEFAULT CHARSET=utf8 COMMENT='keyword-topic relation'

See Also

List of tables


List of indexes

Indexes

Name | Primary | Unique
PRIMARY |  |
Total: 1 index(s)

See Also

Table [help_relation]


Index: PRIMARY on table help_relation

Properties

Primary: |
Unique: |
Collation: | A
Type: | BTREE
Comment: |

Index Columns

Name | Collation
help_keyword_id | A
help_topic_id | A
Total: 2 column(s)

See Also

List of indexes


Table: help_topic

Properties

Engine: | MyISAM
Version: | 10
Row format: | Dynamic
Rows: | 466
Avg row length: | 715
Data length: | 333276
Max data length: | 281474976710655
Index length: | 17408
Data free: | 0
Auto increment: |
Create time: | 07.04.2007
Update time: | 07.04.2007
Check time: |
Collation: | utf8_general_ci
Checksum: |
Create options: |
Comment: | help topics

Columns

Name | Data Type | NULL | Identity | Default | Comment
help_topic_id | int(10) unsigned |  |  |  |
name | char(64) |  |  |  |
help_category_id | smallint(5) unsigned |  |  |  |
description | text |  |  |  |
example | text |  |  |  |
url | char(128) |  |  |  |
Total: 6 column(s)

Indexes

Name | Primary | Unique
name |  |
PRIMARY |  |
Total: 2 indexes(s)

SQL

CREATE TABLE `help_topic` (
`help_topic_id` int(10) unsigned NOT NULL,
`name` char(64) NOT NULL,
`help_category_id` smallint(5) unsigned NOT NULL,
`description` text NOT NULL,
`example` text NOT NULL,
`url` char(128) NOT NULL,
PRIMARY KEY (`help_topic_id`),
UNIQUE KEY `name` (`name`)
) ENGINE=MyISAM DEFAULT CHARSET=utf8 COMMENT='help topics'

See Also

List of tables


List of indexes

Indexes

Name | Primary | Unique
name |  |
PRIMARY |  |
Total: 2 index(s)

See Also

Table [help_topic]


Index: name on table help_topic

Properties

Primary: |
Unique: |
Collation: | A
Type: | BTREE
Comment: |

Index Columns

Name | Collation
name | A
Total: 1 column(s)

See Also

List of indexes


Index: PRIMARY on table help_topic

Properties

Primary: |
Unique: |
Collation: | A
Type: | BTREE
Comment: |

Index Columns

Name | Collation
help_topic_id | A
Total: 1 column(s)

See Also

List of indexes


Table: host

Properties

Engine: | MyISAM
Version: | 10
Row format: | Fixed
Rows: | 0
Avg row length: | 0
Data length: | 0
Max data length: | 109775240917155839
Index length: | 1024
Data free: | 0
Auto increment: |
Create time: | 07.04.2007
Update time: | 07.04.2007
Check time: |
Collation: | utf8_bin
Checksum: |
Create options: |
Comment: | Host privileges1; Merged with database privileges

Columns

Name | Data Type | NULL | Identity | Default | Comment
Host | char(60) |  |  |  |
Db | char(64) |  |  |  |
Select_priv | enum('N', 'Y') |  |  | N |
Insert_priv | enum('N', 'Y') |  |  | N |
Update_priv | enum('N', 'Y') |  |  | N |
Delete_priv | enum('N', 'Y') |  |  | N |
Create_priv | enum('N', 'Y') |  |  | N |
Drop_priv | enum('N', 'Y') |  |  | N |
Grant_priv | enum('N', 'Y') |  |  | N |
References_priv | enum('N', 'Y') |  |  | N |
Index_priv | enum('N', 'Y') |  |  | N |
Alter_priv | enum('N', 'Y') |  |  | N |
Create_tmp_table_priv | enum('N', 'Y') |  |  | N |
Lock_tables_priv | enum('N', 'Y') |  |  | N |
Create_view_priv | enum('N', 'Y') |  |  | N |
Show_view_priv | enum('N', 'Y') |  |  | N |
Create_routine_priv | enum('N', 'Y') |  |  | N |
Alter_routine_priv | enum('N', 'Y') |  |  | N |
Execute_priv | enum('N', 'Y') |  |  | N |
Total: 19 column(s)

Indexes

Name | Primary | Unique
PRIMARY |  |
Total: 1 indexes(s)

SQL

CREATE TABLE `host` (
`Host` char(60) collate utf8_bin NOT NULL default '',
`Db` char(64) collate utf8_bin NOT NULL default '',
`Select_priv` enum('N','Y') character set utf8 NOT NULL default 'N',
`Insert_priv` enum('N','Y') character set utf8 NOT NULL default 'N',
`Update_priv` enum('N','Y') character set utf8 NOT NULL default 'N',
`Delete_priv` enum('N','Y') character set utf8 NOT NULL default 'N',
`Create_priv` enum('N','Y') character set utf8 NOT NULL default 'N',
`Drop_priv` enum('N','Y') character set utf8 NOT NULL default 'N',
`Grant_priv` enum('N','Y') character set utf8 NOT NULL default 'N',
`References_priv` enum('N','Y') character set utf8 NOT NULL default 'N',
`Index_priv` enum('N','Y') character set utf8 NOT NULL default 'N',
`Alter_priv` enum('N','Y') character set utf8 NOT NULL default 'N',
`Create_tmp_table_priv` enum('N','Y') character set utf8 NOT NULL default 'N',
`Lock_tables_priv` enum('N','Y') character set utf8 NOT NULL default 'N',
`Create_view_priv` enum('N','Y') character set utf8 NOT NULL default 'N',
`Show_view_priv` enum('N','Y') character set utf8 NOT NULL default 'N',
`Create_routine_priv` enum('N','Y') character set utf8 NOT NULL default 'N',
`Alter_routine_priv` enum('N','Y') character set utf8 NOT NULL default 'N',
`Execute_priv` enum('N','Y') character set utf8 NOT NULL default 'N',
PRIMARY KEY (`Host`,`Db`)
) ENGINE=MyISAM DEFAULT CHARSET=utf8 COLLATE=utf8_bin COMMENT='Host privileges1; Merged with database privileges'

See Also

List of tables


List of indexes

Indexes

Name | Primary | Unique
PRIMARY |  |
Total: 1 index(s)

See Also

Table [host]


Index: PRIMARY on table host

Properties

Primary: |
Unique: |
Collation: | A
Type: | BTREE
Comment: |

Index Columns

Name | Collation
Host | A
Db | A
Total: 2 column(s)

See Also

List of indexes


Table: proc

Properties

Engine: | MyISAM
Version: | 10
Row format: | Dynamic
Rows: | 5
Avg row length: | 195
Data length: | 976
Max data length: | 281474976710655
Index length: | 3072
Data free: | 0
Auto increment: |
Create time: | 07.04.2007
Update time: | 10.10.2006
Check time: |
Collation: | utf8_general_ci
Checksum: |
Create options: |
Comment: | Stored Procedures

Columns

Name | Data Type | NULL | Identity | Default | Comment
db | char(64) |  |  |  |
name | char(64) |  |  |  |
type | enum('FUNCTION', 'PROCEDURE') |  |  |  |
specific_name | char(64) |  |  |  |
language | enum('SQL') |  |  | SQL |
sql_data_access | enum('CONTAINS_SQL', 'NO_SQL', 'READS_SQL_DATA', 'MODIFIES_SQL_DATA') |  |  | CONTAINS_SQL |
is_deterministic | enum('YES', 'NO') |  |  | NO |
security_type | enum('INVOKER', 'DEFINER') |  |  | DEFINER |
param_list | blob |  |  |  |
returns | char(64) |  |  |  |
body | longblob |  |  |  |
definer | char(77) |  |  |  |
created | timestamp |  |  | CURRENT_TIMESTAMP |
modified | timestamp |  |  | 0000-00-00 00:00:00 |
sql_mode | set('REAL_AS_FLOAT', 'PIPES_AS_CONCAT', 'ANSI_QUOTES', 'IGNORE_SPACE', 'NOT_USED', 'ONLY_FULL_GROUP_BY', 'NO_UNSIGNED_SUBTRACTION', 'NO_DIR_IN_CREATE', 'POSTGRESQL', 'ORACLE', 'MSSQL', 'DB2', 'MAXDB', 'NO_KEY_OPTIONS', 'NO_TABLE_OPTIONS', 'NO_FIELD_OPTIONS', 'MYSQL323', 'MYSQL40', 'ANSI', 'NO_AUTO_VALUE_ON_ZERO', 'NO_BACKSLASH_ESCAPES', 'STRICT_TRANS_TABLES', 'STRICT_ALL_TABLES', 'NO_ZERO_IN_DATE', 'NO_ZERO_DATE', 'INVALID_DATES', 'ERROR_FOR_DIVISION_BY_ZERO', 'TRADITIONAL', 'NO_AUTO_CREATE_USER', 'HIGH_NOT_PRECEDENCE') |  |  |  |
comment | char(64) |  |  |  |
Total: 16 column(s)

Indexes

Name | Primary | Unique
PRIMARY |  |
Total: 1 indexes(s)

SQL

CREATE TABLE `proc` (
`db` char(64) character set utf8 collate utf8_bin NOT NULL default '',
`name` char(64) NOT NULL default '',
`type` enum('FUNCTION','PROCEDURE') NOT NULL,
`specific_name` char(64) NOT NULL default '',
`language` enum('SQL') NOT NULL default 'SQL',
`sql_data_access` enum('CONTAINS_SQL','NO_SQL','READS_SQL_DATA','MODIFIES_SQL_DATA') NOT NULL default 'CONTAINS_SQL',
`is_deterministic` enum('YES','NO') NOT NULL default 'NO',
`security_type` enum('INVOKER','DEFINER') NOT NULL default 'DEFINER',
`param_list` blob NOT NULL,
`returns` char(64) NOT NULL default '',
`body` longblob NOT NULL,
`definer` char(77) character set utf8 collate utf8_bin NOT NULL default '',
`created` timestamp NOT NULL default CURRENT_TIMESTAMP on update CURRENT_TIMESTAMP,
`modified` timestamp NOT NULL default '0000-00-00 00:00:00',
`sql_mode` set('REAL_AS_FLOAT','PIPES_AS_CONCAT','ANSI_QUOTES','IGNORE_SPACE','NOT_USED','ONLY_FULL_GROUP_BY','NO_UNSIGNED_SUBTRACTION','NO_DIR_IN_CREATE','POSTGRESQL','ORACLE','MSSQL','DB2','MAXDB','NO_KEY_OPTIONS','NO_TABLE_OPTIONS','NO_FIELD_OPTIONS','MYSQL323','MYSQL40','ANSI','NO_AUTO_VALUE_ON_ZERO','NO_BACKSLASH_ESCAPES','STRICT_TRANS_TABLES','STRICT_ALL_TABLES','NO_ZERO_IN_DATE','NO_ZERO_DATE','INVALID_DATES','ERROR_FOR_DIVISION_BY_ZERO','TRADITIONAL','NO_AUTO_CREATE_USER','HIGH_NOT_PRECEDENCE') NOT NULL default '',
`comment` char(64) character set utf8 collate utf8_bin NOT NULL default '',
PRIMARY KEY (`db`,`name`,`type`)
) ENGINE=MyISAM DEFAULT CHARSET=utf8 COMMENT='Stored Procedures'

See Also

List of tables


List of indexes

Indexes

Name | Primary | Unique
PRIMARY |  |
Total: 1 index(s)

See Also

Table [proc]


Index: PRIMARY on table proc

Properties

Primary: |
Unique: |
Collation: | A
Type: | BTREE
Comment: |

Index Columns

Name | Collation
db | A
name | A
type | A
Total: 3 column(s)

See Also

List of indexes


Table: procs_priv

Properties

Engine: | MyISAM
Version: | 10
Row format: | Fixed
Rows: | 0
Avg row length: | 0
Data length: | 0
Max data length: | 239253730204057599
Index length: | 1024
Data free: | 0
Auto increment: |
Create time: | 07.04.2007
Update time: | 07.04.2007
Check time: |
Collation: | utf8_bin
Checksum: |
Create options: |
Comment: | Procedure privileges

Columns

Name | Data Type | NULL | Identity | Default | Comment
Host | char(60) |  |  |  |
Db | char(64) |  |  |  |
User | char(16) |  |  |  |
Routine_name | char(64) |  |  |  |
Routine_type | enum('FUNCTION', 'PROCEDURE') |  |  |  |
Grantor | char(77) |  |  |  |
Proc_priv | set('Execute', 'Alter Routine', 'Grant') |  |  |  |
Timestamp | timestamp |  |  | CURRENT_TIMESTAMP |
Total: 8 column(s)

Indexes

Name | Primary | Unique
Grantor |  |
PRIMARY |  |
Total: 2 indexes(s)

SQL

CREATE TABLE `procs_priv` (
`Host` char(60) collate utf8_bin NOT NULL default '',
`Db` char(64) collate utf8_bin NOT NULL default '',
`User` char(16) collate utf8_bin NOT NULL default '',
`Routine_name` char(64) collate utf8_bin NOT NULL default '',
`Routine_type` enum('FUNCTION','PROCEDURE') collate utf8_bin NOT NULL,
`Grantor` char(77) collate utf8_bin NOT NULL default '',
`Proc_priv` set('Execute','Alter Routine','Grant') character set utf8 NOT NULL default '',
`Timestamp` timestamp NOT NULL default CURRENT_TIMESTAMP on update CURRENT_TIMESTAMP,
PRIMARY KEY (`Host`,`Db`,`User`,`Routine_name`,`Routine_type`),
KEY `Grantor` (`Grantor`)
) ENGINE=MyISAM DEFAULT CHARSET=utf8 COLLATE=utf8_bin COMMENT='Procedure privileges'

See Also

List of tables


List of indexes

Indexes

Name | Primary | Unique
Grantor |  |
PRIMARY |  |
Total: 2 index(s)

See Also

Table [procs_priv]


Index: Grantor on table procs_priv

Properties

Primary: |
Unique: |
Collation: | A
Type: | BTREE
Comment: |

Index Columns

Name | Collation
Grantor | A
Total: 1 column(s)

See Also

List of indexes


Index: PRIMARY on table procs_priv

Properties

Primary: |
Unique: |
Collation: | A
Type: | BTREE
Comment: |

Index Columns

Name | Collation
Host | A
Db | A
User | A
Routine_name | A
Routine_type | A
Total: 5 column(s)

See Also

List of indexes


Table: tables_priv

Properties

Engine: | MyISAM
Version: | 10
Row format: | Fixed
Rows: | 0
Avg row length: | 0
Data length: | 0
Max data length: | 239535205180768255
Index length: | 1024
Data free: | 0
Auto increment: |
Create time: | 07.04.2007
Update time: | 07.04.2007
Check time: |
Collation: | utf8_bin
Checksum: |
Create options: |
Comment: | Table privileges

Columns

Name | Data Type | NULL | Identity | Default | Comment
Host | char(60) |  |  |  |
Db | char(64) |  |  |  |
User | char(16) |  |  |  |
Table_name | char(64) |  |  |  |
Grantor | char(77) |  |  |  |
Timestamp | timestamp |  |  | CURRENT_TIMESTAMP |
Table_priv | set('Select', 'Insert', 'Update', 'Delete', 'Create', 'Drop', 'Grant', 'References', 'Index', 'Alter', 'Create View', 'Show view') |  |  |  |
Column_priv | set('Select', 'Insert', 'Update', 'References') |  |  |  |
Total: 8 column(s)

Indexes

Name | Primary | Unique
Grantor |  |
PRIMARY |  |
Total: 2 indexes(s)

SQL

CREATE TABLE `tables_priv` (
`Host` char(60) collate utf8_bin NOT NULL default '',
`Db` char(64) collate utf8_bin NOT NULL default '',
`User` char(16) collate utf8_bin NOT NULL default '',
`Table_name` char(64) collate utf8_bin NOT NULL default '',
`Grantor` char(77) collate utf8_bin NOT NULL default '',
`Timestamp` timestamp NOT NULL default CURRENT_TIMESTAMP on update CURRENT_TIMESTAMP,
`Table_priv` set('Select','Insert','Update','Delete','Create','Drop','Grant','References','Index','Alter','Create View','Show view') character set utf8 NOT NULL default '',
`Column_priv` set('Select','Insert','Update','References') character set utf8 NOT NULL default '',
PRIMARY KEY (`Host`,`Db`,`User`,`Table_name`),
KEY `Grantor` (`Grantor`)
) ENGINE=MyISAM DEFAULT CHARSET=utf8 COLLATE=utf8_bin COMMENT='Table privileges'

See Also

List of tables


List of indexes

Indexes

Name | Primary | Unique
Grantor |  |
PRIMARY |  |
Total: 2 index(s)

See Also

Table [tables_priv]


Index: Grantor on table tables_priv

Properties

Primary: |
Unique: |
Collation: | A
Type: | BTREE
Comment: |

Index Columns

Name | Collation
Grantor | A
Total: 1 column(s)

See Also

List of indexes


Index: PRIMARY on table tables_priv

Properties

Primary: |
Unique: |
Collation: | A
Type: | BTREE
Comment: |

Index Columns

Name | Collation
Host | A
Db | A
User | A
Table_name | A
Total: 4 column(s)

See Also

List of indexes


Table: test1

Properties

Engine: | InnoDB
Version: | 10
Row format: | Compact
Rows: | 0
Avg row length: | 0
Data length: | 16384
Max data length: | 0
Index length: | 16384
Data free: | 0
Auto increment: |
Create time: | 08.07.2004
Update time: |
Check time: |
Collation: | latin1_swedish_ci
Checksum: |
Create options: |
Comment: | test1 table description; InnoDB free: 4096 kB; (`a1`) REFER `mysql/test3`(`a3`)

Columns

Name | Data Type | NULL | Identity | Default | Comment
a1 | int(11) |  |  |  | a1 super column
Total: 1 column(s)

Indexes

Name | Primary | Unique
fk1 |  |
Total: 1 indexes(s)

Referenced tables

Foreign Key | Columns | Table | Referenced Columns
fk1 | `a1` | test3 | `a3`
Total: 1 referenced table(s)

SQL

CREATE TABLE `test1` (
`a1` int(11) default NULL COMMENT 'a1 super column',
KEY `fk1` (`a1`),
CONSTRAINT `fk1` FOREIGN KEY (`a1`) REFERENCES `test3` (`a3`)
) ENGINE=InnoDB DEFAULT CHARSET=latin1 COMMENT='test1 table description'

See Also

List of tables


List of indexes

Indexes

Name | Primary | Unique
fk1 |  |
Total: 1 index(s)

See Also

Table [test1]


Index: fk1 on table test1

Properties

Primary: |
Unique: |
Collation: | A
Type: | BTREE
Comment: |

Index Columns

Name | Collation
a1 | A
Total: 1 column(s)

See Also

List of indexes


List of Relationships on mysql

Relationships

Foreign Key | Columns | Table | Referenced Columns
fk1 | `a1` | test3 | `a3`
Total: 1 relationship(s)

See Also

Table [test1]


Relationship: fk1 on table test1

Properties

Foreign Key: | fk1
Columns: | `a1`
Table: | test3
Referenced Columns: | `a3`
ON DELETE: |
ON UPDATE: |

SQL

ALTER TABLE `mysql`.`test1`
ADD CONSTRAINT `fk1` FOREIGN KEY (`a1`) REFERENCES `test3` (`a3`);

See Also

Table [test1]
Table [test3]


Table: test2

Properties

Engine: | InnoDB
Version: | 10
Row format: | Compact
Rows: | 0
Avg row length: | 0
Data length: | 16384
Max data length: | 0
Index length: | 16384
Data free: | 0
Auto increment: |
Create time: | 08.07.2004
Update time: |
Check time: |
Collation: | latin1_swedish_ci
Checksum: |
Create options: |
Comment: | InnoDB free: 4096 kB; (`a2`) REFER `mysql/test3`(`a3`)

Columns

Name | Data Type | NULL | Identity | Default | Comment
a2 | int(11) |  |  |  |
Total: 1 column(s)

Indexes

Name | Primary | Unique
fktest2 |  |
Total: 1 indexes(s)

Referenced tables

Foreign Key | Columns | Table | Referenced Columns
fktest2 | `a2` | test3 | `a3`
Total: 1 referenced table(s)

SQL

CREATE TABLE `test2` (
`a2` int(11) default NULL,
KEY `fktest2` (`a2`),
CONSTRAINT `fktest2` FOREIGN KEY (`a2`) REFERENCES `test3` (`a3`)
) ENGINE=InnoDB DEFAULT CHARSET=latin1

See Also

List of tables


List of indexes

Indexes

Name | Primary | Unique
fktest2 |  |
Total: 1 index(s)

See Also

Table [test2]


Index: fktest2 on table test2

Properties

Primary: |
Unique: |
Collation: | A
Type: | BTREE
Comment: |

Index Columns

Name | Collation
a2 | A
Total: 1 column(s)

See Also

List of indexes


List of Relationships on mysql

Relationships

Foreign Key | Columns | Table | Referenced Columns
fktest2 | `a2` | test3 | `a3`
Total: 1 relationship(s)

See Also

Table [test2]


Relationship: fktest2 on table test2

Properties

Foreign Key: | fktest2
Columns: | `a2`
Table: | test3
Referenced Columns: | `a3`
ON DELETE: |
ON UPDATE: |

SQL

ALTER TABLE `mysql`.`test2`
ADD CONSTRAINT `fktest2` FOREIGN KEY (`a2`) REFERENCES `test3` (`a3`);

See Also

Table [test2]
Table [test3]


Table: test3

Properties

Engine: | InnoDB
Version: | 10
Row format: | Compact
Rows: | 0
Avg row length: | 0
Data length: | 16384
Max data length: | 0
Index length: | 0
Data free: | 0
Auto increment: | 1
Create time: | 08.07.2004
Update time: |
Check time: |
Collation: | latin1_swedish_ci
Checksum: |
Create options: |
Comment: | InnoDB free: 4096 kB

Columns

Name | Data Type | NULL | Identity | Default | Comment
a3 | int(11) |  |  |  |
Total: 1 column(s)

Indexes

Name | Primary | Unique
PRIMARY |  |
Total: 1 indexes(s)

Referencing tables

Foreign Key | Table | Columns | Referencing Columns
fk1 | test1 | `a1` | `a3`
fktest2 | test2 | `a2` | `a3`
Total: 2 referencing table(s)

SQL

CREATE TABLE `test3` (
`a3` int(11) NOT NULL auto_increment,
PRIMARY KEY (`a3`)
) ENGINE=InnoDB DEFAULT CHARSET=latin1

See Also

List of tables


List of indexes

Indexes

Name | Primary | Unique
PRIMARY |  |
Total: 1 index(s)

See Also

Table [test3]


Index: PRIMARY on table test3

Properties

Primary: |
Unique: |
Collation: | A
Type: | BTREE
Comment: |

Index Columns

Name | Collation
a3 | A
Total: 1 column(s)

See Also

List of indexes


Table: test4

Properties

Engine: | InnoDB
Version: | 10
Row format: | Compact
Rows: | 0
Avg row length: | 0
Data length: | 16384
Max data length: | 0
Index length: | 0
Data free: | 0
Auto increment: | 1
Create time: | 08.07.2004
Update time: |
Check time: |
Collation: | latin1_swedish_ci
Checksum: |
Create options: |
Comment: | InnoDB free: 4096 kB

Columns

Name | Data Type | NULL | Identity | Default | Comment
a4 | int(11) |  |  |  |
b4 | int(11) |  |  | 0 |
Total: 2 column(s)

Indexes

Name | Primary | Unique
PRIMARY |  |
Total: 1 indexes(s)

SQL

CREATE TABLE `test4` (
`a4` int(11) NOT NULL auto_increment,
`b4` int(11) default '0',
PRIMARY KEY (`a4`)
) ENGINE=InnoDB DEFAULT CHARSET=latin1

See Also

List of tables


List of indexes

Indexes

Name | Primary | Unique
PRIMARY |  |
Total: 1 index(s)

See Also

Table [test4]


Index: PRIMARY on table test4

Properties

Primary: |
Unique: |
Collation: | A
Type: | BTREE
Comment: |

Index Columns

Name | Collation
a4 | A
Total: 1 column(s)

See Also

List of indexes


Table: time_zone

Properties

Engine: | MyISAM
Version: | 10
Row format: | Fixed
Rows: | 0
Avg row length: | 0
Data length: | 0
Max data length: | 1970324836974591
Index length: | 1024
Data free: | 0
Auto increment: | 1
Create time: | 07.04.2007
Update time: | 07.04.2007
Check time: |
Collation: | utf8_general_ci
Checksum: |
Create options: |
Comment: | Time zones

Columns

Name | Data Type | NULL | Identity | Default | Comment
Time_zone_id | int(10) unsigned |  |  |  |
Use_leap_seconds | enum('Y', 'N') |  |  | N |
Total: 2 column(s)

Indexes

Name | Primary | Unique
PRIMARY |  |
Total: 1 indexes(s)

SQL

CREATE TABLE `time_zone` (
`Time_zone_id` int(10) unsigned NOT NULL auto_increment,
`Use_leap_seconds` enum('Y','N') NOT NULL default 'N',
PRIMARY KEY (`Time_zone_id`)
) ENGINE=MyISAM DEFAULT CHARSET=utf8 COMMENT='Time zones'

See Also

List of tables


List of indexes

Indexes

Name | Primary | Unique
PRIMARY |  |
Total: 1 index(s)

See Also

Table [time_zone]


Index: PRIMARY on table time_zone

Properties

Primary: |
Unique: |
Collation: | A
Type: | BTREE
Comment: |

Index Columns

Name | Collation
Time_zone_id | A
Total: 1 column(s)

See Also

List of indexes


Table: time_zone_leap_second

Properties

Engine: | MyISAM
Version: | 10
Row format: | Fixed
Rows: | 0
Avg row length: | 0
Data length: | 0
Max data length: | 3659174697238527
Index length: | 1024
Data free: | 0
Auto increment: |
Create time: | 07.04.2007
Update time: | 07.04.2007
Check time: |
Collation: | utf8_general_ci
Checksum: |
Create options: |
Comment: | Leap seconds information for time zones

Columns

Name | Data Type | NULL | Identity | Default | Comment
Transition_time | bigint(20) |  |  |  |
Correction | int(11) |  |  |  |
Total: 2 column(s)

Indexes

Name | Primary | Unique
PRIMARY |  |
Total: 1 indexes(s)

SQL

CREATE TABLE `time_zone_leap_second` (
`Transition_time` bigint(20) NOT NULL,
`Correction` int(11) NOT NULL,
PRIMARY KEY (`Transition_time`)
) ENGINE=MyISAM DEFAULT CHARSET=utf8 COMMENT='Leap seconds information for time zones'

See Also

List of tables


List of indexes

Indexes

Name | Primary | Unique
PRIMARY |  |
Total: 1 index(s)

See Also

Table [time_zone_leap_second]


Index: PRIMARY on table time_zone_leap_second

Properties

Primary: |
Unique: |
Collation: | A
Type: | BTREE
Comment: |

Index Columns

Name | Collation
Transition_time | A
Total: 1 column(s)

See Also

List of indexes


Table: time_zone_name

Properties

Engine: | MyISAM
Version: | 10
Row format: | Fixed
Rows: | 0
Avg row length: | 0
Data length: | 0
Max data length: | 55450570411999231
Index length: | 1024
Data free: | 0
Auto increment: |
Create time: | 07.04.2007
Update time: | 07.04.2007
Check time: |
Collation: | utf8_general_ci
Checksum: |
Create options: |
Comment: | Time zone names

Columns

Name | Data Type | NULL | Identity | Default | Comment
Name | char(64) |  |  |  |
Time_zone_id | int(10) unsigned |  |  |  |
Total: 2 column(s)

Indexes

Name | Primary | Unique
PRIMARY |  |
Total: 1 indexes(s)

SQL

CREATE TABLE `time_zone_name` (
`Name` char(64) NOT NULL,
`Time_zone_id` int(10) unsigned NOT NULL,
PRIMARY KEY (`Name`)
) ENGINE=MyISAM DEFAULT CHARSET=utf8 COMMENT='Time zone names'

See Also

List of tables


List of indexes

Indexes

Name | Primary | Unique
PRIMARY |  |
Total: 1 index(s)

See Also

Table [time_zone_name]


Index: PRIMARY on table time_zone_name

Properties

Primary: |
Unique: |
Collation: | A
Type: | BTREE
Comment: |

Index Columns

Name | Collation
Name | A
Total: 1 column(s)

See Also

List of indexes


Table: time_zone_transition

Properties

Engine: | MyISAM
Version: | 10
Row format: | Fixed
Rows: | 0
Avg row length: | 0
Data length: | 0
Max data length: | 4785074604081151
Index length: | 1024
Data free: | 0
Auto increment: |
Create time: | 07.04.2007
Update time: | 07.04.2007
Check time: |
Collation: | utf8_general_ci
Checksum: |
Create options: |
Comment: | Time zone transitions

Columns

Name | Data Type | NULL | Identity | Default | Comment
Time_zone_id | int(10) unsigned |  |  |  |
Transition_time | bigint(20) |  |  |  |
Transition_type_id | int(10) unsigned |  |  |  |
Total: 3 column(s)

Indexes

Name | Primary | Unique
PRIMARY |  |
Total: 1 indexes(s)

SQL

CREATE TABLE `time_zone_transition` (
`Time_zone_id` int(10) unsigned NOT NULL,
`Transition_time` bigint(20) NOT NULL,
`Transition_type_id` int(10) unsigned NOT NULL,
PRIMARY KEY (`Time_zone_id`,`Transition_time`)
) ENGINE=MyISAM DEFAULT CHARSET=utf8 COMMENT='Time zone transitions'

See Also

List of tables


List of indexes

Indexes

Name | Primary | Unique
PRIMARY |  |
Total: 1 index(s)

See Also

Table [time_zone_transition]


Index: PRIMARY on table time_zone_transition

Properties

Primary: |
Unique: |
Collation: | A
Type: | BTREE
Comment: |

Index Columns

Name | Collation
Time_zone_id | A
Transition_time | A
Total: 2 column(s)

See Also

List of indexes


Table: time_zone_transition_type

Properties

Engine: | MyISAM
Version: | 10
Row format: | Fixed
Rows: | 0
Avg row length: | 0
Data length: | 0
Max data length: | 10696049115004927
Index length: | 1024
Data free: | 0
Auto increment: |
Create time: | 07.04.2007
Update time: | 07.04.2007
Check time: |
Collation: | utf8_general_ci
Checksum: |
Create options: |
Comment: | Time zone transition types

Columns

Name | Data Type | NULL | Identity | Default | Comment
Time_zone_id | int(10) unsigned |  |  |  |
Transition_type_id | int(10) unsigned |  |  |  |
Offset | int(11) |  |  | 0 |
Is_DST | tinyint(3) unsigned |  |  | 0 |
Abbreviation | char(8) |  |  |  |
Total: 5 column(s)

Indexes

Name | Primary | Unique
PRIMARY |  |
Total: 1 indexes(s)

SQL

CREATE TABLE `time_zone_transition_type` (
`Time_zone_id` int(10) unsigned NOT NULL,
`Transition_type_id` int(10) unsigned NOT NULL,
`Offset` int(11) NOT NULL default '0',
`Is_DST` tinyint(3) unsigned NOT NULL default '0',
`Abbreviation` char(8) NOT NULL default '',
PRIMARY KEY (`Time_zone_id`,`Transition_type_id`)
) ENGINE=MyISAM DEFAULT CHARSET=utf8 COMMENT='Time zone transition types'

See Also

List of tables


List of indexes

Indexes

Name | Primary | Unique
PRIMARY |  |
Total: 1 index(s)

See Also

Table [time_zone_transition_type]


Index: PRIMARY on table time_zone_transition_type

Properties

Primary: |
Unique: |
Collation: | A
Type: | BTREE
Comment: |

Index Columns

Name | Collation
Time_zone_id | A
Transition_type_id | A
Total: 2 column(s)

See Also

List of indexes


Table: user

Properties

Engine: | MyISAM
Version: | 10
Row format: | Dynamic
Rows: | 2
Avg row length: | 104
Data length: | 312
Max data length: | 281474976710655
Index length: | 2048
Data free: | 104
Auto increment: |
Create time: | 07.04.2007
Update time: | 08.07.2004
Check time: |
Collation: | utf8_bin
Checksum: |
Create options: |
Comment: | Users and global privileges

Columns

Name | Data Type | NULL | Identity | Default | Comment
Host | char(60) |  |  |  |
User | char(16) |  |  |  |
Password | char(41) |  |  |  |
Select_priv | enum('N', 'Y') |  |  | N |
Insert_priv | enum('N', 'Y') |  |  | N |
Update_priv | enum('N', 'Y') |  |  | N |
Delete_priv | enum('N', 'Y') |  |  | N |
Create_priv | enum('N', 'Y') |  |  | N |
Drop_priv | enum('N', 'Y') |  |  | N |
Reload_priv | enum('N', 'Y') |  |  | N |
Shutdown_priv | enum('N', 'Y') |  |  | N |
Process_priv | enum('N', 'Y') |  |  | N |
File_priv | enum('N', 'Y') |  |  | N |
Grant_priv | enum('N', 'Y') |  |  | N |
References_priv | enum('N', 'Y') |  |  | N |
Index_priv | enum('N', 'Y') |  |  | N |
Alter_priv | enum('N', 'Y') |  |  | N |
Show_db_priv | enum('N', 'Y') |  |  | N |
Super_priv | enum('N', 'Y') |  |  | N |
Create_tmp_table_priv | enum('N', 'Y') |  |  | N |
Lock_tables_priv | enum('N', 'Y') |  |  | N |
Execute_priv | enum('N', 'Y') |  |  | N |
Repl_slave_priv | enum('N', 'Y') |  |  | N |
Repl_client_priv | enum('N', 'Y') |  |  | N |
Create_view_priv | enum('N', 'Y') |  |  | N |
Show_view_priv | enum('N', 'Y') |  |  | N |
Create_routine_priv | enum('N', 'Y') |  |  | N |
Alter_routine_priv | enum('N', 'Y') |  |  | N |
Create_user_priv | enum('N', 'Y') |  |  | N |
ssl_type | enum('', 'ANY', 'X509', 'SPECIFIED') |  |  |  |
ssl_cipher | blob |  |  |  |
x509_issuer | blob |  |  |  |
x509_subject | blob |  |  |  |
max_questions | int(11) unsigned |  |  | 0 |
max_updates | int(11) unsigned |  |  | 0 |
max_connections | int(11) unsigned |  |  | 0 |
max_user_connections | int(11) unsigned |  |  | 0 |
Total: 37 column(s)

Indexes

Name | Primary | Unique
PRIMARY |  |
Total: 1 indexes(s)

SQL

CREATE TABLE `user` (
`Host` char(60) collate utf8_bin NOT NULL default '',
`User` char(16) collate utf8_bin NOT NULL default '',
`Password` char(41) character set latin1 collate latin1_bin NOT NULL default '',
`Select_priv` enum('N','Y') character set utf8 NOT NULL default 'N',
`Insert_priv` enum('N','Y') character set utf8 NOT NULL default 'N',
`Update_priv` enum('N','Y') character set utf8 NOT NULL default 'N',
`Delete_priv` enum('N','Y') character set utf8 NOT NULL default 'N',
`Create_priv` enum('N','Y') character set utf8 NOT NULL default 'N',
`Drop_priv` enum('N','Y') character set utf8 NOT NULL default 'N',
`Reload_priv` enum('N','Y') character set utf8 NOT NULL default 'N',
`Shutdown_priv` enum('N','Y') character set utf8 NOT NULL default 'N',
`Process_priv` enum('N','Y') character set utf8 NOT NULL default 'N',
`File_priv` enum('N','Y') character set utf8 NOT NULL default 'N',
`Grant_priv` enum('N','Y') character set utf8 NOT NULL default 'N',
`References_priv` enum('N','Y') character set utf8 NOT NULL default 'N',
`Index_priv` enum('N','Y') character set utf8 NOT NULL default 'N',
`Alter_priv` enum('N','Y') character set utf8 NOT NULL default 'N',
`Show_db_priv` enum('N','Y') character set utf8 NOT NULL default 'N',
`Super_priv` enum('N','Y') character set utf8 NOT NULL default 'N',
`Create_tmp_table_priv` enum('N','Y') character set utf8 NOT NULL default 'N',
`Lock_tables_priv` enum('N','Y') character set utf8 NOT NULL default 'N',
`Execute_priv` enum('N','Y') character set utf8 NOT NULL default 'N',
`Repl_slave_priv` enum('N','Y') character set utf8 NOT NULL default 'N',
`Repl_client_priv` enum('N','Y') character set utf8 NOT NULL default 'N',
`Create_view_priv` enum('N','Y') character set utf8 NOT NULL default 'N',
`Show_view_priv` enum('N','Y') character set utf8 NOT NULL default 'N',
`Create_routine_priv` enum('N','Y') character set utf8 NOT NULL default 'N',
`Alter_routine_priv` enum('N','Y') character set utf8 NOT NULL default 'N',
`Create_user_priv` enum('N','Y') character set utf8 NOT NULL default 'N',
`ssl_type` enum('','ANY','X509','SPECIFIED') character set utf8 NOT NULL default '',
`ssl_cipher` blob NOT NULL,
`x509_issuer` blob NOT NULL,
`x509_subject` blob NOT NULL,
`max_questions` int(11) unsigned NOT NULL default '0',
`max_updates` int(11) unsigned NOT NULL default '0',
`max_connections` int(11) unsigned NOT NULL default '0',
`max_user_connections` int(11) unsigned NOT NULL default '0',
PRIMARY KEY (`Host`,`User`)
) ENGINE=MyISAM DEFAULT CHARSET=utf8 COLLATE=utf8_bin COMMENT='Users and global privileges'

See Also

List of tables


List of indexes

Indexes

Name | Primary | Unique
PRIMARY |  |
Total: 1 index(s)

See Also

Table [user]


Index: PRIMARY on table user

Properties

Primary: |
Unique: |
Collation: | A
Type: | BTREE
Comment: |

Index Columns

Name | Collation
Host | A
User | A
Total: 2 column(s)

See Also

List of indexes


List of views

views

Name | Check Option | Updatable | Definer | Security Type
newview | NONE |  | root@localhost | DEFINER
Total: 1 view(s)

See Also

Database overview


View: newview

Properties

Check Option: | NONE
Updatable: |
Definer: | root@localhost
Security Type: | DEFINER

Columns

Name | Data Type
1 | int(1)
Total: 1 column(s)

SQL

CREATE ALGORITHM=UNDEFINED DEFINER=`root`@`localhost` SQL SECURITY DEFINER VIEW `mysql`.`newview` AS select 1 AS `1`

See Also

List of views


List of procedures

Procedure

Name | Language | Security Type | Definer | Comment
simpleproc | SQL | DEFINER | root@localhost | The following is an example of a simple stored procedure that us
simpleproc1 | SQL | DEFINER | root@localhost | The following is an example of a simple stored procedure that us
Total: 2 procedures(s)

See Also

Database overview


Procedure: simpleproc

Properties

Name: | simpleproc
Language: | SQL
Security Type: | DEFINER
Definer: | root@localhost
Created: | 08.07.2004
Modified: | 08.07.2004
DTD Identifier: |
External Name: |
External Language: |
Parameter Style: | SQL
Is Deterministric: | NO
SQL Data Access: | CONTAINS SQL
SQL Path: |
SQL Mode: | STRICT_TRANS_TABLES,NO_AUTO_CREATE_USER
Comment: | The following is an example of a simple stored procedure that us

SQL

CREATE DEFINER=`root`@`localhost` PROCEDURE `simpleproc`(OUT param1 INT)
COMMENT 'The following is an example of a simple stored procedure that us'
BEGIN
SELECT COUNT(*) INTO param1 FROM t;
END

See Also

List of procedures


Procedure: simpleproc1

Properties

Name: | simpleproc1
Language: | SQL
Security Type: | DEFINER
Definer: | root@localhost
Created: | 08.07.2004
Modified: | 08.07.2004
DTD Identifier: |
External Name: |
External Language: |
Parameter Style: | SQL
Is Deterministric: | NO
SQL Data Access: | CONTAINS SQL
SQL Path: |
SQL Mode: | STRICT_TRANS_TABLES,NO_AUTO_CREATE_USER
Comment: | The following is an example of a simple stored procedure that us

SQL

CREATE DEFINER=`root`@`localhost` PROCEDURE `simpleproc1`(OUT param1 INT)
COMMENT 'The following is an example of a simple stored procedure that us'
BEGIN
SELECT COUNT(*) INTO param1 FROM t;
END

See Also

List of procedures


List of functions

Functions

Name | Language | Security Type | Definer | Comment
fun1 | SQL | DEFINER | root@localhost | helllo world function
Total: 1 functions(s)

See Also

Database overview


Function: fun1

Properties

Name: | fun1
Language: | SQL
Security Type: | DEFINER
Definer: | root@localhost
Created: | 08.07.2004
Modified: | 08.07.2004
DTD Identifier: | char(50) CHARSET latin1
External Name: |
External Language: |
Parameter Style: | SQL
Is Deterministric: | NO
SQL Data Access: | CONTAINS SQL
SQL Path: |
SQL Mode: | STRICT_TRANS_TABLES,NO_AUTO_CREATE_USER
Comment: | helllo world function

SQL

CREATE DEFINER=`root`@`localhost` FUNCTION `fun1`(s CHAR(20)) RETURNS char(50) CHARSET latin1
COMMENT 'helllo world function'
RETURN CONCAT('Hello, ',s,'!')

See Also

List of functions


Database: test

Properties

Name: | test
Default Character Set: | latin1
Default Character Collation: | latin1_swedish_ci

Tables

Name | Engine | Comment
test1 | InnoDB | test1 table description; InnoDB free: 4096 kB; (`a1`) REFER `test/test3`(`a3`)
test2 | InnoDB | test 2 table; InnoDB free: 4096 kB
test3 | InnoDB | test3 table; InnoDB free: 4096 kB
test4 | InnoDB | test 4 table; InnoDB free: 4096 kB
Total: 4 table(s)

Views

Name | Check Option | Updatable | Definer | Security Type
newview | NONE |  | root@localhost | DEFINER
newview1 | NONE |  | root@localhost@% | DEFINER
Total: 2 view(s)

Procedures

Name | Language | Security Type | Definer | Comment
simpleproc | SQL | DEFINER | root@localhost | The following is an example of a simple stored procedure
Total: 1 procedure(s)

Functions

Name | Language | Security Type | Definer | Comment
fun1 | SQL | DEFINER | root@localhost | simple function
Total: 1 function(s)

SQL

CREATE DATABASE `test` /*!40100 DEFAULT CHARACTER SET latin1 */

See Also

Server overview


List of tables

Tables

Name | Engine | Comment
test1 | InnoDB | test1 table description; InnoDB free: 4096 kB; (`a1`) REFER `test/test3`(`a3`)
test2 | InnoDB | test 2 table; InnoDB free: 4096 kB
test3 | InnoDB | test3 table; InnoDB free: 4096 kB
test4 | InnoDB | test 4 table; InnoDB free: 4096 kB
Total: 4 table(s)

See Also

Database overview


Table: test1

Properties

Engine: | InnoDB
Version: | 10
Row format: | Compact
Rows: | 0
Avg row length: | 0
Data length: | 16384
Max data length: | 0
Index length: | 16384
Data free: | 0
Auto increment: |
Create time: | 08.07.2004
Update time: |
Check time: |
Collation: | latin1_swedish_ci
Checksum: |
Create options: |
Comment: | test1 table description; InnoDB free: 4096 kB; (`a1`) REFER `test/test3`(`a3`)

Columns

Name | Data Type | NULL | Identity | Default | Comment
a1 | int(11) |  |  |  | a1 super column
Total: 1 column(s)

Indexes

Name | Primary | Unique
fk1 |  |
Total: 1 indexes(s)

Triggers

Name | Action Timing | Event Manipulation
testref1 | BEFORE | INSERT
Total: 1 triggers(s)

Referenced tables

Foreign Key | Columns | Table | Referenced Columns
fk1 | `a1` | test3 | `a3`
Total: 1 referenced table(s)

SQL

CREATE TABLE `test1` (
`a1` int(11) default NULL COMMENT 'a1 super column',
KEY `fk1` (`a1`),
CONSTRAINT `fk1` FOREIGN KEY (`a1`) REFERENCES `test3` (`a3`)
) ENGINE=InnoDB DEFAULT CHARSET=latin1 COMMENT='test1 table description'

See Also

List of tables


List of triggers

Triggers

Name | Action Timing | Event Manipulation
testref1 | BEFORE | INSERT
Total: 1 trigger(s)

See Also

Table [test1]


Trigger: testref1 on table test1

Properties

Action Timing: | BEFORE
Event Manipulation: | INSERT
Action Orientation: | ROW
Action Reference Old Row: | OLD
Action Reference New Row: | NEW
SQL Mode: | STRICT_TRANS_TABLES,NO_AUTO_CREATE_USER,NO_ENGINE_SUBSTITUTION
Definer: | root@localhost

SQL

CREATE DEFINER = root@localhost
TRIGGER testref1 BEFORE INSERT
ON test1 FOR EACH ROW
BEGIN
INSERT INTO test2 SET a2 = NEW.a1;
DELETE FROM test3 WHERE a3 = NEW.a1;
UPDATE test4 SET b4 = b4 + 1 WHERE a4 = NEW.a1;
END

See Also

List of triggers


List of Relationships on test

Relationships

Foreign Key | Columns | Table | Referenced Columns
fk1 | `a1` | test3 | `a3`
Total: 1 relationship(s)

See Also

Table [test1]


Relationship: fk1 on table test1

Properties

Foreign Key: | fk1
Columns: | `a1`
Table: | test3
Referenced Columns: | `a3`
ON DELETE: |
ON UPDATE: |

SQL

ALTER TABLE `test`.`test1`
ADD CONSTRAINT `fk1` FOREIGN KEY (`a1`) REFERENCES `test3` (`a3`);

See Also

Table [test1]
Table [test3]


Table: test2

Properties

Engine: | InnoDB
Version: | 10
Row format: | Compact
Rows: | 0
Avg row length: | 0
Data length: | 16384
Max data length: | 0
Index length: | 0
Data free: | 0
Auto increment: |
Create time: | 08.07.2004
Update time: |
Check time: |
Collation: | latin1_swedish_ci
Checksum: |
Create options: |
Comment: | test 2 table; InnoDB free: 4096 kB

Columns

Name | Data Type | NULL | Identity | Default | Comment
a2 | int(11) |  |  |  | a2 column
Total: 1 column(s)

SQL

CREATE TABLE `test2` (
`a2` int(11) default NULL COMMENT 'a2 column'
) ENGINE=InnoDB DEFAULT CHARSET=latin1 COMMENT='test 2 table'

See Also

List of tables


Table: test3

Properties

Engine: | InnoDB
Version: | 10
Row format: | Compact
Rows: | 0
Avg row length: | 0
Data length: | 16384
Max data length: | 0
Index length: | 0
Data free: | 0
Auto increment: | 1
Create time: | 08.07.2004
Update time: |
Check time: |
Collation: | latin1_swedish_ci
Checksum: |
Create options: |
Comment: | test3 table; InnoDB free: 4096 kB

Columns

Name | Data Type | NULL | Identity | Default | Comment
a3 | int(11) |  |  |  | column 3 description
Total: 1 column(s)

Indexes

Name | Primary | Unique
PRIMARY |  |
Total: 1 indexes(s)

Referencing tables

Foreign Key | Table | Columns | Referencing Columns
fk1 | test1 | `a1` | `a3`
Total: 1 referencing table(s)

SQL

CREATE TABLE `test3` (
`a3` int(11) NOT NULL auto_increment COMMENT 'column 3 description',
PRIMARY KEY (`a3`)
) ENGINE=InnoDB DEFAULT CHARSET=latin1 COMMENT='test3 table'

See Also

List of tables


Table: test4

Properties

Engine: | InnoDB
Version: | 10
Row format: | Compact
Rows: | 0
Avg row length: | 0
Data length: | 16384
Max data length: | 0
Index length: | 0
Data free: | 0
Auto increment: | 1
Create time: | 08.07.2004
Update time: |
Check time: |
Collation: | latin1_swedish_ci
Checksum: |
Create options: |
Comment: | test 4 table; InnoDB free: 4096 kB

Columns

Name | Data Type | NULL | Identity | Default | Comment
a4 | int(11) |  |  |  | column a4
b4 | int(11) |  |  | 0 | column b4 with default value
textfield | varchar(11) |  |  | 'Hello' | textfield description
Total: 3 column(s)

Indexes

Name | Primary | Unique
PRIMARY |  |
Total: 1 indexes(s)

SQL

CREATE TABLE `test4` (
`a4` int(11) NOT NULL auto_increment COMMENT 'column a4',
`b4` int(11) default '0' COMMENT 'column b4 with default value',
`textfield` varchar(11) default '''Hello''' COMMENT 'textfield description',
PRIMARY KEY (`a4`)
) ENGINE=InnoDB DEFAULT CHARSET=latin1 COMMENT='test 4 table'

See Also

List of tables


List of views

views

Name | Check Option | Updatable | Definer | Security Type
newview | NONE |  | root@localhost | DEFINER
newview1 | NONE |  | root@localhost@% | DEFINER
Total: 2 view(s)

See Also

Database overview


View: newview

Properties

Check Option: | NONE
Updatable: |
Definer: | root@localhost
Security Type: | DEFINER

Columns

Name | Data Type
1 | int(1)
Total: 1 column(s)

SQL

CREATE ALGORITHM=UNDEFINED DEFINER=`root`@`localhost` SQL SECURITY DEFINER VIEW `test`.`newview` AS select 1 AS `1`

See Also

List of views


View: newview1

Properties

Check Option: | NONE
Updatable: |
Definer: | root@localhost@%
Security Type: | DEFINER

Columns

Name | Data Type
1 | int(1)
Total: 1 column(s)

SQL

CREATE ALGORITHM=UNDEFINED DEFINER=`root@localhost`@`%` SQL SECURITY DEFINER VIEW `test`.`newview1` AS select 1 AS `1`

See Also

List of views


List of procedures

Procedure

Name | Language | Security Type | Definer | Comment
simpleproc | SQL | DEFINER | root@localhost | The following is an example of a simple stored procedure
Total: 1 procedures(s)

See Also

Database overview


Procedure: simpleproc

Properties

Name: | simpleproc
Language: | SQL
Security Type: | DEFINER
Definer: | root@localhost
Created: | 08.07.2004
Modified: | 10.10.2006
DTD Identifier: |
External Name: |
External Language: |
Parameter Style: | SQL
Is Deterministric: | NO
SQL Data Access: | CONTAINS SQL
SQL Path: |
SQL Mode: | STRICT_TRANS_TABLES,NO_AUTO_CREATE_USER
Comment: | The following is an example of a simple stored procedure

SQL

CREATE DEFINER=`root`@`localhost` PROCEDURE `simpleproc`(OUT param1 INT)
COMMENT 'The following is an example of a simple stored procedure'
BEGIN
SELECT COUNT(*) INTO param1 FROM t;
END

See Also

List of procedures


List of functions

Functions

Name | Language | Security Type | Definer | Comment
fun1 | SQL | DEFINER | root@localhost | simple function
Total: 1 functions(s)

See Also

Database overview


Function: fun1

Properties

Name: | fun1
Language: | SQL
Security Type: | DEFINER
Definer: | root@localhost
Created: | 08.07.2004
Modified: | 10.10.2006
DTD Identifier: | char(50) CHARSET latin1
External Name: |
External Language: |
Parameter Style: | SQL
Is Deterministric: | NO
SQL Data Access: | CONTAINS SQL
SQL Path: |
SQL Mode: | STRICT_TRANS_TABLES,NO_AUTO_CREATE_USER
Comment: | simple function

SQL

CREATE DEFINER=`root`@`localhost` FUNCTION `fun1`(s CHAR(20)) RETURNS char(50) CHARSET latin1
COMMENT 'simple function'
RETURN CONCAT('Hello, ',s,'!')

See Also

List of functions


Server Info

Properties

Version: 5.0.45-community-nt

Databases

Database | Default Character Set | Default Character Collation
mysql | latin1 | latin1_swedish_ci
test | latin1 | latin1_swedish_ci
Total: 2 database(s)

Server Configuration

Name | Value
auto_increment_increment | 1
auto_increment_offset | 1
automatic_sp_privileges | ON
back_log | 50
basedir | C:\Program Files\MySQL\MySQL Server 5.0\
binlog_cache_size | 32768
bulk_insert_buffer_size | 8388608
character_set_client | latin1
character_set_connection | latin1
character_set_database | latin1
character_set_filesystem | binary
character_set_results | latin1
character_set_server | latin1
character_set_system | utf8
character_sets_dir | C:\Program Files\MySQL\MySQL Server 5.0\share\charsets\
collation_connection | latin1_swedish_ci
collation_database | latin1_swedish_ci
collation_server | latin1_swedish_ci
completion_type | 0
concurrent_insert | 1
connect_timeout | 5
datadir | C:\Program Files\MySQL\MySQL Server 5.0\Data\
date_format | %Y-%m-%d
datetime_format | %Y-%m-%d %H:%i:%s
default_week_format | 0
delay_key_write | ON
delayed_insert_limit | 100
delayed_insert_timeout | 300
delayed_queue_size | 1000
div_precision_increment | 4
engine_condition_pushdown | OFF
expire_logs_days | 0
flush | OFF
flush_time | 1800
ft_boolean_syntax | + -><()~*:""&|
ft_max_word_len | 84
ft_min_word_len | 4
ft_query_expansion_limit | 20
ft_stopword_file | (built-in)
group_concat_max_len | 1024
have_archive | YES
have_bdb | NO
have_blackhole_engine | YES
have_compress | YES
have_crypt | NO
have_csv | NO
have_dynamic_loading | YES
have_example_engine | NO
have_federated_engine | YES
have_geometry | YES
have_innodb | YES
have_isam | NO
have_merge_engine | YES
have_ndbcluster | NO
have_openssl | DISABLED
have_ssl | DISABLED
have_query_cache | YES
have_raid | NO
have_rtree_keys | YES
have_symlink | YES
hostname | tezorro
init_connect |
init_file |
init_slave |
innodb_additional_mem_pool_size | 2097152
innodb_autoextend_increment | 8
innodb_buffer_pool_awe_mem_mb | 0
innodb_buffer_pool_size | 8388608
innodb_checksums | ON
innodb_commit_concurrency | 0
innodb_concurrency_tickets | 500
innodb_data_file_path | ibdata1:10M:autoextend
innodb_data_home_dir |
innodb_doublewrite | ON
innodb_fast_shutdown | 1
innodb_file_io_threads | 4
innodb_file_per_table | OFF
innodb_flush_log_at_trx_commit | 1
innodb_flush_method |
innodb_force_recovery | 0
innodb_lock_wait_timeout | 50
innodb_locks_unsafe_for_binlog | OFF
innodb_log_arch_dir |
innodb_log_archive | OFF
innodb_log_buffer_size | 1048576
innodb_log_file_size | 10485760
innodb_log_files_in_group | 2
innodb_log_group_home_dir | .\
innodb_max_dirty_pages_pct | 90
innodb_max_purge_lag | 0
innodb_mirrored_log_groups | 1
innodb_open_files | 300
innodb_rollback_on_timeout | OFF
innodb_support_xa | ON
innodb_sync_spin_loops | 20
innodb_table_locks | ON
innodb_thread_concurrency | 8
innodb_thread_sleep_delay | 10000
interactive_timeout | 28800
join_buffer_size | 131072
key_buffer_size | 8388608
key_cache_age_threshold | 300
key_cache_block_size | 1024
key_cache_division_limit | 100
language | C:\Program Files\MySQL\MySQL Server 5.0\share\english\
large_files_support | ON
large_page_size | 0
large_pages | OFF
lc_time_names | en_US
license | GPL
local_infile | ON
log | OFF
log_bin | OFF
log_bin_trust_function_creators | OFF
log_error | C:\Program Files\MySQL\MySQL Server 5.0\Data\tezorro.err
log_queries_not_using_indexes | OFF
log_slave_updates | OFF
log_slow_queries | OFF
log_warnings | 1
long_query_time | 10
low_priority_updates | OFF
lower_case_file_system | ON
lower_case_table_names | 1
max_allowed_packet | 1048576
max_binlog_cache_size | 4294967295
max_binlog_size | 1073741824
max_connect_errors | 10
max_connections | 100
max_delayed_threads | 20
max_error_count | 64
max_heap_table_size | 16777216
max_insert_delayed_threads | 20
max_join_size | 4294967295
max_length_for_sort_data | 1024
max_prepared_stmt_count | 16382
max_relay_log_size | 0
max_seeks_for_key | 4294967295
max_sort_length | 1024
max_sp_recursion_depth | 0
max_tmp_tables | 32
max_user_connections | 0
max_write_lock_count | 4294967295
multi_range_count | 256
myisam_data_pointer_size | 6
myisam_max_sort_file_size | 107374182400
myisam_recover_options | OFF
myisam_repair_threads | 1
myisam_sort_buffer_size | 8388608
myisam_stats_method | nulls_unequal
named_pipe | OFF
net_buffer_length | 16384
net_read_timeout | 30
net_retry_count | 10
net_write_timeout | 60
new | OFF
old_passwords | OFF
open_files_limit | 622
optimizer_prune_level | 1
optimizer_search_depth | 62
pid_file | C:\Program Files\MySQL\MySQL Server 5.0\Data\tezorro.pid
port | 3307
preload_buffer_size | 32768
profiling | OFF
profiling_history_size | 15
protocol_version | 10
query_alloc_block_size | 8192
query_cache_limit | 1048576
query_cache_min_res_unit | 4096
query_cache_size | 0
query_cache_type | ON
query_cache_wlock_invalidate | OFF
query_prealloc_size | 8192
range_alloc_block_size | 2048
read_buffer_size | 61440
read_only | OFF
read_rnd_buffer_size | 258048
relay_log_purge | ON
relay_log_space_limit | 0
rpl_recovery_rank | 0
secure_auth | OFF
secure_file_priv |
shared_memory | OFF
shared_memory_base_name | MYSQL
server_id | 0
skip_external_locking | ON
skip_networking | OFF
skip_show_database | OFF
slave_compressed_protocol | OFF
slave_load_tmpdir | C:\WINDOWS\TEMP\
slave_net_timeout | 3600
slave_skip_errors | OFF
slave_transaction_retries | 10
slow_launch_time | 2
sort_buffer_size | 217080
sql_big_selects | ON
sql_mode | STRICT_TRANS_TABLES,NO_AUTO_CREATE_USER,NO_ENGINE_SUBSTITUTION
sql_notes | ON
sql_warnings | OFF
ssl_ca |
ssl_capath |
ssl_cert |
ssl_cipher |
ssl_key |
storage_engine | InnoDB
sync_binlog | 0
sync_frm | ON
system_time_zone | FLE Daylight Time
table_cache | 256
table_lock_wait_timeout | 50
table_type | InnoDB
thread_cache_size | 8
thread_stack | 196608
time_format | %H:%i:%s
time_zone | SYSTEM
timed_mutexes | OFF
tmp_table_size | 5242880
tmpdir | C:\WINDOWS\TEMP\
transaction_alloc_block_size | 8192
transaction_prealloc_size | 4096
tx_isolation | REPEATABLE-READ
updatable_views_with_limit | YES
version | 5.0.45-community-nt
version_comment | MySQL Community Edition (GPL)
version_compile_machine | ia32
version_compile_os | Win32
wait_timeout | 28800

See Also

Users
Hosts


List of users

Users

User
'root'@'%'
'root'@'localhost'
Total: 2 login(s)

See Also

Server overview


User: 'root'@'%'

Properties

User: | root
Host: | %

User Privileges

Select: |
Insert: |
Update: |
Delete: |
Create: |
Drop: |
Reload: |
Shutdown: |
Process: |
File: |
Grant: |
Referencies: |
Index: |
Alter: |
Show DB: |
Super: |
Create temp table: |
Lock tables: |
Execute: |
Repl. slave: |
Repl. client: |
Create view: |
Show view: |
Create routine: |
Alter routine: |
Create user: |
Max questions: | 0
Max updates: | 0
Max connections: | 0
Max user connections: | 0

SQL

CREATE USER 'root'@'%' IDENTIFIED BY PASSWORD '*81F5E21E35407D884A6CD4A731AEBFB6AF209E1B'

Grants

GRANT SELECT, INSERT, UPDATE, DELETE, CREATE, DROP, RELOAD, SHUTDOWN, PROCESS, FILE, REFERENCES, INDEX, ALTER, SHOW DATABASES, SUPER, CREATE TEMPORARY TABLES, LOCK TABLES, EXECUTE, REPLICATION SLAVE, REPLICATION CLIENT ON *.* TO 'root'@'%' IDENTIFIED BY PASSWORD '*81F5E21E35407D884A6CD4A731AEBFB6AF209E1B' WITH GRANT OPTION;

See Also

Server overview
User list


User: 'root'@'localhost'

Properties

User: | root
Host: | localhost

User Privileges

Select: |
Insert: |
Update: |
Delete: |
Create: |
Drop: |
Reload: |
Shutdown: |
Process: |
File: |
Grant: |
Referencies: |
Index: |
Alter: |
Show DB: |
Super: |
Create temp table: |
Lock tables: |
Execute: |
Repl. slave: |
Repl. client: |
Create view: |
Show view: |
Create routine: |
Alter routine: |
Create user: |
Max questions: | 0
Max updates: | 0
Max connections: | 0
Max user connections: | 0

SQL

CREATE USER 'root'@'localhost' IDENTIFIED BY PASSWORD '*81F5E21E35407D884A6CD4A731AEBFB6AF209E1B'

Grants

GRANT ALL PRIVILEGES ON *.* TO 'root'@'localhost' IDENTIFIED BY PASSWORD '*81F5E21E35407D884A6CD4A731AEBFB6AF209E1B' WITH GRANT OPTION;

See Also

Server overview
User list


About

Documentation details

Customer: |
Project: |
Created: | 10.11.2006
Generator: | DBScribe 1.2 for MySQL