Schema: GLOBAL

Properties

Name: | GLOBAL
Created: | 4/16/2007 12:06:32 PM

Views

Name | Status | Last modify | Created | Description
CHANNEL_DIMVIEW | INVALID | 4/16/2007 12:27:11 PM | 4/16/2007 12:27:11 PM |
CHANNEL_VIEW | VALID | 4/16/2007 12:27:08 PM | 4/16/2007 12:14:54 PM |
CUSTOMER_DIMVIEW | INVALID | 4/16/2007 12:27:11 PM | 4/16/2007 12:27:11 PM |
CUSTOMER_VIEW | VALID | 4/16/2007 12:27:08 PM | 4/16/2007 12:14:54 PM |
PRODUCT_DIMVIEW | INVALID | 4/16/2007 12:27:12 PM | 4/16/2007 12:27:12 PM |
PRODUCT_VIEW | VALID | 4/16/2007 12:27:09 PM | 4/16/2007 12:14:54 PM |
SALES_FACT | VALID | 4/16/2007 12:27:08 PM | 4/16/2007 12:14:52 PM |
TIME_DIMVIEW | INVALID | 4/16/2007 12:27:12 PM | 4/16/2007 12:27:12 PM |
TIME_VIEW | VALID | 4/16/2007 12:27:13 PM | 4/16/2007 12:14:54 PM |
UNITS_CUBE_CUBEVIEW | INVALID | 4/16/2007 12:27:12 PM | 4/16/2007 12:27:12 PM |
Total: 10 view(s)

Analytical workspaces

Name | Default Language
GLOBAL | AMERICAN
Total: 1 analytical workspace(s)

See Also

Server overview


List of views

Views

Name | Status | Last modify | Created | Description
CHANNEL_DIMVIEW | INVALID | 4/16/2007 12:27:11 PM | 4/16/2007 12:27:11 PM |
CHANNEL_VIEW | VALID | 4/16/2007 12:27:08 PM | 4/16/2007 12:14:54 PM |
CUSTOMER_DIMVIEW | INVALID | 4/16/2007 12:27:11 PM | 4/16/2007 12:27:11 PM |
CUSTOMER_VIEW | VALID | 4/16/2007 12:27:08 PM | 4/16/2007 12:14:54 PM |
PRODUCT_DIMVIEW | INVALID | 4/16/2007 12:27:12 PM | 4/16/2007 12:27:12 PM |
PRODUCT_VIEW | VALID | 4/16/2007 12:27:09 PM | 4/16/2007 12:14:54 PM |
SALES_FACT | VALID | 4/16/2007 12:27:08 PM | 4/16/2007 12:14:52 PM |
TIME_DIMVIEW | INVALID | 4/16/2007 12:27:12 PM | 4/16/2007 12:27:12 PM |
TIME_VIEW | VALID | 4/16/2007 12:27:13 PM | 4/16/2007 12:14:54 PM |
UNITS_CUBE_CUBEVIEW | INVALID | 4/16/2007 12:27:12 PM | 4/16/2007 12:27:12 PM |
Total: 10 view(s)

See Also

Schema overview


View: CHANNEL_DIMVIEW

Properties

Name: | CHANNEL_DIMVIEW
Status: | INVALID
Last modify: | 4/16/2007 12:27:11 PM
Created: | 4/16/2007 12:27:11 PM
Description: |

Columns

Name | Type | Length | Nchar Length | Precision | Scale | NULL | Default | Comment | Updatable | Deletable | Insertable
CHANNEL_ID | UNDEFINED | 0 |  |  |  | Y |  |  | YES | YES | YES
CHANNEL_PRIMARY_PARENT | UNDEFINED | 0 |  |  |  | Y |  |  | YES | YES | YES
CHANNEL_TOTAL_CHANNEL_ID | UNDEFINED | 0 |  |  |  | Y |  |  | YES | YES | YES
CHANNEL_TOTAL_CHANNEL_DESC | UNDEFINED | 0 |  |  |  | Y |  |  | YES | YES | YES
CHANNEL_CHANNEL_ID | UNDEFINED | 0 |  |  |  | Y |  |  | YES | YES | YES
CHANNEL_CHANNEL_DESC | UNDEFINED | 0 |  |  |  | Y |  |  | YES | YES | YES
CHANNEL_LEVEL | UNDEFINED | 0 |  |  |  | Y |  |  | YES | YES | YES
CHANNEL_LONG_DESCRIPTION | UNDEFINED | 0 |  |  |  | Y |  |  | YES | YES | YES
CHANNEL_SHORT_DESCRIPTION | UNDEFINED | 0 |  |  |  | Y |  |  | YES | YES | YES
Total: 9 column(s)

Uses

Owner | Name | Type
PUBLIC | OLAP_TABLE | SYNONYM
Total: 1 use reference(s)

DDL

CREATE OR REPLACE FORCE VIEW "GLOBAL"."CHANNEL_DIMVIEW" ("CHANNEL_ID", "CHANNEL_PRIMARY_PARENT", "CHANNEL_TOTAL_CHANNEL_ID", "CHANNEL_TOTAL_CHANNEL_DESC", "CHANNEL_CHANNEL_ID", "CHANNEL_CHANNEL_DESC", "CHANNEL_LEVEL", "CHANNEL_LONG_DESCRIPTION", "CHANNEL_SHORT_DESCRIPTION") AS
SELECT "CHANNEL_ID","CHANNEL_PRIMARY_PARENT","CHANNEL_TOTAL_CHANNEL_ID","CHANNEL_TOTAL_CHANNEL_DESC","CHANNEL_CHANNEL_ID","CHANNEL_CHANNEL_DESC","CHANNEL_LEVEL","CHANNEL_LONG_DESCRIPTION","CHANNEL_SHORT_DESCRIPTION"
FROM table(OLAP_TABLE('GLOBAL duration session',
'',
'',
'&(CHANNEL_LIMITMAP)' ))
MODEL
DIMENSION BY(
channel_id
)
MEASURES(
channel_primary_parent,
channel_total_channel_id,
channel_total_channel_desc,
channel_channel_id,
channel_channel_desc,
channel_level,
channel_long_description,
channel_short_description
)
RULES UPDATE SEQUENTIAL ORDER()

See Also

List of views


View: CHANNEL_VIEW

Properties

Name: | CHANNEL_VIEW
Status: | VALID
Last modify: | 4/16/2007 12:27:08 PM
Created: | 4/16/2007 12:14:54 PM
Description: |

Columns

Name | Type | Length | Nchar Length | Precision | Scale | NULL | Default | Comment | Updatable | Deletable | Insertable
CHANNEL_ID | NUMBER | 5 |  | 5 | 0 | N |  |  | YES | YES | YES
CHANNEL_DSC | VARCHAR2 | 15 |  |  |  | N |  |  | YES | YES | YES
TOTAL_CHANNEL_ID | NUMBER | 5 |  | 5 | 0 | N |  |  | YES | YES | YES
TOTAL_CHANNEL_DSC | VARCHAR2 | 15 |  |  |  | N |  |  | YES | YES | YES
Total: 4 column(s)

Grants

Privilage | Grantee | Grantable | Grantor
SELECT | GLOBAL_AW | NO | GLOBAL
Total: 1 grants

Uses

Owner | Name | Type
GLOBAL | CHANNEL_DIM | TABLE
Total: 1 use reference(s)

DDL

CREATE OR REPLACE FORCE VIEW "GLOBAL"."CHANNEL_VIEW" ("CHANNEL_ID", "CHANNEL_DSC", "TOTAL_CHANNEL_ID", "TOTAL_CHANNEL_DSC") AS
SELECT
CHANNEL_ID,
CHANNEL_DSC,
TOTAL_CHANNEL_ID,
TOTAL_CHANNEL_DSC
FROM
CHANNEL_DIM

See Also

List of views


View: CUSTOMER_DIMVIEW

Properties

Name: | CUSTOMER_DIMVIEW
Status: | INVALID
Last modify: | 4/16/2007 12:27:11 PM
Created: | 4/16/2007 12:27:11 PM
Description: |

Columns

Name | Type | Length | Nchar Length | Precision | Scale | NULL | Default | Comment | Updatable | Deletable | Insertable
CUSTOMER_ID | UNDEFINED | 0 |  |  |  | Y |  |  | YES | YES | YES
CUSTOMER_SHIPMENTS_PARENT | UNDEFINED | 0 |  |  |  | Y |  |  | YES | YES | YES
CUSTOMER_TOTAL_CUSTOMER_ID | UNDEFINED | 0 |  |  |  | Y |  |  | YES | YES | YES
CUSTOMER_TOTAL_CUSTOMER_DESC | UNDEFINED | 0 |  |  |  | Y |  |  | YES | YES | YES
CUSTOMER_REGION_ID | UNDEFINED | 0 |  |  |  | Y |  |  | YES | YES | YES
CUSTOMER_REGION_DESC | UNDEFINED | 0 |  |  |  | Y |  |  | YES | YES | YES
CUSTOMER_WAREHOUSE_ID | UNDEFINED | 0 |  |  |  | Y |  |  | YES | YES | YES
CUSTOMER_WAREHOUSE_DESC | UNDEFINED | 0 |  |  |  | Y |  |  | YES | YES | YES
CUSTOMER_SHIP_TO_ID | UNDEFINED | 0 |  |  |  | Y |  |  | YES | YES | YES
CUSTOMER_SHIP_TO_DESC | UNDEFINED | 0 |  |  |  | Y |  |  | YES | YES | YES
CUSTOMER_MARKET_SEGME_PARENT | UNDEFINED | 0 |  |  |  | Y |  |  | YES | YES | YES
CUSTOMER_TOTAL_MARKET_ID | UNDEFINED | 0 |  |  |  | Y |  |  | YES | YES | YES
CUSTOMER_TOTAL_MARKET_DESC | UNDEFINED | 0 |  |  |  | Y |  |  | YES | YES | YES
CUSTOMER_MARKET_SEGMENT_ID | UNDEFINED | 0 |  |  |  | Y |  |  | YES | YES | YES
CUSTOMER_MARKET_SEGMENT_DESC | UNDEFINED | 0 |  |  |  | Y |  |  | YES | YES | YES
CUSTOMER_ACCOUNT_ID | UNDEFINED | 0 |  |  |  | Y |  |  | YES | YES | YES
CUSTOMER_ACCOUNT_DESC | UNDEFINED | 0 |  |  |  | Y |  |  | YES | YES | YES
CUSTOMER_LEVEL | UNDEFINED | 0 |  |  |  | Y |  |  | YES | YES | YES
CUSTOMER_LONG_DESCRIPTION | UNDEFINED | 0 |  |  |  | Y |  |  | YES | YES | YES
CUSTOMER_SHORT_DESCRIPTION | UNDEFINED | 0 |  |  |  | Y |  |  | YES | YES | YES
Total: 20 column(s)

Uses

Owner | Name | Type
PUBLIC | OLAP_TABLE | SYNONYM
Total: 1 use reference(s)

DDL

CREATE OR REPLACE FORCE VIEW "GLOBAL"."CUSTOMER_DIMVIEW" ("CUSTOMER_ID", "CUSTOMER_SHIPMENTS_PARENT", "CUSTOMER_TOTAL_CUSTOMER_ID", "CUSTOMER_TOTAL_CUSTOMER_DESC", "CUSTOMER_REGION_ID", "CUSTOMER_REGION_DESC", "CUSTOMER_WAREHOUSE_ID", "CUSTOMER_WAREHOUSE_DESC", "CUSTOMER_SHIP_TO_ID", "CUSTOMER_SHIP_TO_DESC", "CUSTOMER_MARKET_SEGME_PARENT", "CUSTOMER_TOTAL_MARKET_ID", "CUSTOMER_TOTAL_MARKET_DESC", "CUSTOMER_MARKET_SEGMENT_ID", "CUSTOMER_MARKET_SEGMENT_DESC", "CUSTOMER_ACCOUNT_ID", "CUSTOMER_ACCOUNT_DESC", "CUSTOMER_LEVEL", "CUSTOMER_LONG_DESCRIPTION", "CUSTOMER_SHORT_DESCRIPTION") AS
SELECT "CUSTOMER_ID","CUSTOMER_SHIPMENTS_PARENT","CUSTOMER_TOTAL_CUSTOMER_ID","CUSTOMER_TOTAL_CUSTOMER_DESC","CUSTOMER_REGION_ID","CUSTOMER_REGION_DESC","CUSTOMER_WAREHOUSE_ID","CUSTOMER_WAREHOUSE_DESC","CUSTOMER_SHIP_TO_ID","CUSTOMER_SHIP_TO_DESC","CUSTOMER_MARKET_SEGME_PARENT","CUSTOMER_TOTAL_MARKET_ID","CUSTOMER_TOTAL_MARKET_DESC","CUSTOMER_MARKET_SEGMENT_ID","CUSTOMER_MARKET_SEGMENT_DESC","CUSTOMER_ACCOUNT_ID","CUSTOMER_ACCOUNT_DESC","CUSTOMER_LEVEL","CUSTOMER_LONG_DESCRIPTION","CUSTOMER_SHORT_DESCRIPTION"
FROM table(OLAP_TABLE('GLOBAL duration session',
'',
'',
'&(CUSTOMER_LIMITMAP)' ))
MODEL
DIMENSION BY(
customer_id
)
MEASURES(
customer_shipments_parent,
customer_total_customer_id,
customer_total_customer_desc,
customer_region_id,
customer_region_desc,
customer_warehouse_id,
customer_warehouse_desc,
customer_ship_to_id,
customer_ship_to_desc,
customer_market_segme_parent,
customer_total_market_id,
customer_total_market_desc,
customer_market_segment_id,
customer_market_segment_desc,
customer_account_id,
customer_account_desc,
customer_level,
customer_long_description,
customer_short_description
)
RULES UPDATE SEQUENTIAL ORDER()

See Also

List of views


View: CUSTOMER_VIEW

Properties

Name: | CUSTOMER_VIEW
Status: | VALID
Last modify: | 4/16/2007 12:27:08 PM
Created: | 4/16/2007 12:14:54 PM
Description: |

Columns

Name | Type | Length | Nchar Length | Precision | Scale | NULL | Default | Comment | Updatable | Deletable | Insertable
SHIP_TO_ID | NUMBER | 5 |  | 5 | 0 | N |  |  | YES | YES | YES
SHIP_TO_DSC | VARCHAR2 | 30 |  |  |  | N |  |  | YES | YES | YES
ACCOUNT_ID | NUMBER | 5 |  | 5 | 0 | N |  |  | YES | YES | YES
ACCOUNT_DSC | VARCHAR2 | 30 |  |  |  | N |  |  | YES | YES | YES
MARKET_SEGMENT_ID | NUMBER | 5 |  | 5 | 0 | N |  |  | YES | YES | YES
MARKET_SEGMENT_DSC | VARCHAR2 | 15 |  |  |  | N |  |  | YES | YES | YES
TOTAL_MARKET_ID | NUMBER | 5 |  | 5 | 0 | N |  |  | YES | YES | YES
TOTAL_MARKET_DSC | VARCHAR2 | 15 |  |  |  | N |  |  | YES | YES | YES
WAREHOUSE_ID | NUMBER | 5 |  | 5 | 0 | N |  |  | YES | YES | YES
WAREHOUSE_DSC | VARCHAR2 | 15 |  |  |  | N |  |  | YES | YES | YES
REGION_ID | NUMBER | 5 |  | 5 | 0 | N |  |  | YES | YES | YES
REGION_DSC | VARCHAR2 | 15 |  |  |  | N |  |  | YES | YES | YES
TOTAL_CUSTOMER_ID | NUMBER | 5 |  | 5 | 0 | N |  |  | YES | YES | YES
TOTAL_CUSTOMER_DSC | VARCHAR2 | 15 |  |  |  | N |  |  | YES | YES | YES
Total: 14 column(s)

Grants

Privilage | Grantee | Grantable | Grantor
SELECT | GLOBAL_AW | NO | GLOBAL
Total: 1 grants

Uses

Owner | Name | Type
GLOBAL | CUSTOMER_DIM | TABLE
Total: 1 use reference(s)

DDL

CREATE OR REPLACE FORCE VIEW "GLOBAL"."CUSTOMER_VIEW" ("SHIP_TO_ID", "SHIP_TO_DSC", "ACCOUNT_ID", "ACCOUNT_DSC", "MARKET_SEGMENT_ID", "MARKET_SEGMENT_DSC", "TOTAL_MARKET_ID", "TOTAL_MARKET_DSC", "WAREHOUSE_ID", "WAREHOUSE_DSC", "REGION_ID", "REGION_DSC", "TOTAL_CUSTOMER_ID", "TOTAL_CUSTOMER_DSC") AS
SELECT
SHIP_TO_ID,
SHIP_TO_DSC,
ACCOUNT_ID,
ACCOUNT_DSC,
MARKET_SEGMENT_ID,
MARKET_SEGMENT_DSC,
TOTAL_MARKET_ID,
TOTAL_MARKET_DSC,
WAREHOUSE_ID,
WAREHOUSE_DSC,
REGION_ID,
REGION_DSC,
TOTAL_CUSTOMER_ID,
TOTAL_CUSTOMER_DSC
FROM
CUSTOMER_DIM

See Also

List of views


View: PRODUCT_DIMVIEW

Properties

Name: | PRODUCT_DIMVIEW
Status: | INVALID
Last modify: | 4/16/2007 12:27:12 PM
Created: | 4/16/2007 12:27:12 PM
Description: |

Columns

Name | Type | Length | Nchar Length | Precision | Scale | NULL | Default | Comment | Updatable | Deletable | Insertable
PRODUCT_ID | UNDEFINED | 0 |  |  |  | Y |  |  | YES | YES | YES
PRODUCT_PRIMARY_PARENT | UNDEFINED | 0 |  |  |  | Y |  |  | YES | YES | YES
PRODUCT_TOTAL_PRODUCT_ID | UNDEFINED | 0 |  |  |  | Y |  |  | YES | YES | YES
PRODUCT_TOTAL_PRODUCT_DESC | UNDEFINED | 0 |  |  |  | Y |  |  | YES | YES | YES
PRODUCT_CLASS_ID | UNDEFINED | 0 |  |  |  | Y |  |  | YES | YES | YES
PRODUCT_CLASS_DESC | UNDEFINED | 0 |  |  |  | Y |  |  | YES | YES | YES
PRODUCT_FAMILY_ID | UNDEFINED | 0 |  |  |  | Y |  |  | YES | YES | YES
PRODUCT_FAMILY_DESC | UNDEFINED | 0 |  |  |  | Y |  |  | YES | YES | YES
PRODUCT_ITEM_ID | UNDEFINED | 0 |  |  |  | Y |  |  | YES | YES | YES
PRODUCT_ITEM_DESC | UNDEFINED | 0 |  |  |  | Y |  |  | YES | YES | YES
PRODUCT_LEVEL | UNDEFINED | 0 |  |  |  | Y |  |  | YES | YES | YES
PRODUCT_LONG_DESCRIPTION | UNDEFINED | 0 |  |  |  | Y |  |  | YES | YES | YES
PRODUCT_SHORT_DESCRIPTION | UNDEFINED | 0 |  |  |  | Y |  |  | YES | YES | YES
PRODUCT_ISVISIBLE | UNDEFINED | 0 |  |  |  | Y |  |  | YES | YES | YES
PRODUCT_PACKAGE | UNDEFINED | 0 |  |  |  | Y |  |  | YES | YES | YES
PRODUCT_BUYER | UNDEFINED | 0 |  |  |  | Y |  |  | YES | YES | YES
PRODUCT_MARKETING_MANAGER | UNDEFINED | 0 |  |  |  | Y |  |  | YES | YES | YES
Total: 17 column(s)

Uses

Owner | Name | Type
PUBLIC | OLAP_TABLE | SYNONYM
Total: 1 use reference(s)

DDL

CREATE OR REPLACE FORCE VIEW "GLOBAL"."PRODUCT_DIMVIEW" ("PRODUCT_ID", "PRODUCT_PRIMARY_PARENT", "PRODUCT_TOTAL_PRODUCT_ID", "PRODUCT_TOTAL_PRODUCT_DESC", "PRODUCT_CLASS_ID", "PRODUCT_CLASS_DESC", "PRODUCT_FAMILY_ID", "PRODUCT_FAMILY_DESC", "PRODUCT_ITEM_ID", "PRODUCT_ITEM_DESC", "PRODUCT_LEVEL", "PRODUCT_LONG_DESCRIPTION", "PRODUCT_SHORT_DESCRIPTION", "PRODUCT_ISVISIBLE", "PRODUCT_PACKAGE", "PRODUCT_BUYER", "PRODUCT_MARKETING_MANAGER") AS
SELECT "PRODUCT_ID","PRODUCT_PRIMARY_PARENT","PRODUCT_TOTAL_PRODUCT_ID","PRODUCT_TOTAL_PRODUCT_DESC","PRODUCT_CLASS_ID","PRODUCT_CLASS_DESC","PRODUCT_FAMILY_ID","PRODUCT_FAMILY_DESC","PRODUCT_ITEM_ID","PRODUCT_ITEM_DESC","PRODUCT_LEVEL","PRODUCT_LONG_DESCRIPTION","PRODUCT_SHORT_DESCRIPTION","PRODUCT_ISVISIBLE","PRODUCT_PACKAGE","PRODUCT_BUYER","PRODUCT_MARKETING_MANAGER"
FROM table(OLAP_TABLE('GLOBAL duration session',
'',
'',
'&(PRODUCT_LIMITMAP)' ))
MODEL
DIMENSION BY(
product_id
)
MEASURES(
product_primary_parent,
product_total_product_id,
product_total_product_desc,
product_class_id,
product_class_desc,
product_family_id,
product_family_desc,
product_item_id,
product_item_desc,
product_level,
product_long_description,
product_short_description,
product_isvisible,
product_package,
product_buyer,
product_marketing_manager
)
RULES UPDATE SEQUENTIAL ORDER()

See Also

List of views


View: PRODUCT_VIEW

Properties

Name: | PRODUCT_VIEW
Status: | VALID
Last modify: | 4/16/2007 12:27:09 PM
Created: | 4/16/2007 12:14:54 PM
Description: |

Columns

Name | Type | Length | Nchar Length | Precision | Scale | NULL | Default | Comment | Updatable | Deletable | Insertable
ITEM_ID | NUMBER | 5 |  | 5 | 0 | N |  |  | YES | YES | YES
ITEM_DSC | VARCHAR2 | 31 |  |  |  | N |  |  | YES | YES | YES
ITEM_PACKAGE | VARCHAR2 | 20 |  |  |  | Y |  |  | YES | YES | YES
ITEM_MARKETING_MANAGER | VARCHAR2 | 20 |  |  |  | Y |  |  | YES | YES | YES
ITEM_BUYER | VARCHAR2 | 20 |  |  |  | Y |  |  | YES | YES | YES
FAMILY_ID | NUMBER | 5 |  | 5 | 0 | N |  |  | YES | YES | YES
FAMILY_DSC | VARCHAR2 | 20 |  |  |  | N |  |  | YES | YES | YES
CLASS_ID | NUMBER | 5 |  | 5 | 0 | N |  |  | YES | YES | YES
CLASS_DSC | VARCHAR2 | 15 |  |  |  | N |  |  | YES | YES | YES
TOTAL_PRODUCT_ID | NUMBER | 5 |  | 5 | 0 | N |  |  | YES | YES | YES
TOTAL_PRODUCT_DSC | VARCHAR2 | 15 |  |  |  | N |  |  | YES | YES | YES
Total: 11 column(s)

Grants

Privilage | Grantee | Grantable | Grantor
SELECT | GLOBAL_AW | NO | GLOBAL
Total: 1 grants

Uses

Owner | Name | Type
GLOBAL | PRODUCT_DIM | TABLE
Total: 1 use reference(s)

DDL

CREATE OR REPLACE FORCE VIEW "GLOBAL"."PRODUCT_VIEW" ("ITEM_ID", "ITEM_DSC", "ITEM_PACKAGE", "ITEM_MARKETING_MANAGER", "ITEM_BUYER", "FAMILY_ID", "FAMILY_DSC", "CLASS_ID", "CLASS_DSC", "TOTAL_PRODUCT_ID", "TOTAL_PRODUCT_DSC") AS
SELECT ITEM_ID, ITEM_DSC, ITEM_PACKAGE_ID ITEM_PACKAGE, ITEM_MARKETING_MANAGER, ITEM_BUYER, FAMILY_ID, FAMILY_DSC, CLASS_ID, CLASS_DSC, TOTAL_PRODUCT_ID, TOTAL_PRODUCT_DSC
FROM PRODUCT_DIM

See Also

List of views


View: SALES_FACT

Properties

Name: | SALES_FACT
Status: | VALID
Last modify: | 4/16/2007 12:27:08 PM
Created: | 4/16/2007 12:14:52 PM
Description: |

Columns

Name | Type | Length | Nchar Length | Precision | Scale | NULL | Default | Comment | Updatable | Deletable | Insertable
MONTH_ID | NUMBER | 5 |  | 5 | 0 | Y |  |  | NO | NO | NO
ITEM_ID | NUMBER | 5 |  | 5 | 0 | Y |  |  | NO | NO | NO
SHIP_TO_ID | NUMBER | 5 |  | 5 | 0 | Y |  |  | NO | NO | NO
CHANNEL_ID | NUMBER | 5 |  | 5 | 0 | Y |  |  | NO | NO | NO
UNITS | NUMBER |  |  |  |  | Y |  |  | NO | NO | NO
SALES | NUMBER |  |  |  |  | Y |  |  | NO | NO | NO
COST | NUMBER |  |  |  |  | Y |  |  | NO | NO | NO
Total: 7 column(s)

Grants

Privilage | Grantee | Grantable | Grantor
SELECT | GLOBAL_AW | NO | GLOBAL
Total: 1 grants

Used by

Owner | Name | Type
GLOBAL | TIME_VIEW | VIEW
Total: 1 used by reference(s)

Uses

Owner | Name | Type
GLOBAL | PRICE_AND_COST_FACT | TABLE
GLOBAL | UNITS_FACT | TABLE
Total: 2 use reference(s)

DDL

CREATE OR REPLACE FORCE VIEW "GLOBAL"."SALES_FACT" ("MONTH_ID", "ITEM_ID", "SHIP_TO_ID", "CHANNEL_ID", "UNITS", "SALES", "COST") AS
SELECT distinct
u.MONTH_ID,
u.ITEM_ID,
u.SHIP_TO_ID,
u.CHANNEL_ID,
u.UNITS,
u.UNITS * pc.UNIT_PRICE sales,
u.UNITS * pc.UNIT_COST cost
FROM
UNITS_FACT u,
PRICE_AND_COST_FACT pc
WHERE
pc.ITEM_ID = u.ITEM_ID AND pc.MONTH_ID = u.MONTH_ID

See Also

List of views


View: TIME_DIMVIEW

Properties

Name: | TIME_DIMVIEW
Status: | INVALID
Last modify: | 4/16/2007 12:27:12 PM
Created: | 4/16/2007 12:27:12 PM
Description: |

Columns

Name | Type | Length | Nchar Length | Precision | Scale | NULL | Default | Comment | Updatable | Deletable | Insertable
TIME_ID | UNDEFINED | 0 |  |  |  | Y |  |  | YES | YES | YES
TIME_CALENDAR_YEA_PARENT | UNDEFINED | 0 |  |  |  | Y |  |  | YES | YES | YES
TIME_YEAR_ID | UNDEFINED | 0 |  |  |  | Y |  |  | YES | YES | YES
TIME_YEAR_DESC | UNDEFINED | 0 |  |  |  | Y |  |  | YES | YES | YES
TIME_QUARTER_ID | UNDEFINED | 0 |  |  |  | Y |  |  | YES | YES | YES
TIME_QUARTER_DESC | UNDEFINED | 0 |  |  |  | Y |  |  | YES | YES | YES
TIME_MONTH_ID | UNDEFINED | 0 |  |  |  | Y |  |  | YES | YES | YES
TIME_MONTH_DESC | UNDEFINED | 0 |  |  |  | Y |  |  | YES | YES | YES
TIME_ALL_YEARS_ID | UNDEFINED | 0 |  |  |  | Y |  |  | YES | YES | YES
TIME_ALL_YEARS_DESC | UNDEFINED | 0 |  |  |  | Y |  |  | YES | YES | YES
TIME_LEVEL | UNDEFINED | 0 |  |  |  | Y |  |  | YES | YES | YES
TIME_END_DATE | UNDEFINED | 0 |  |  |  | Y |  |  | YES | YES | YES
TIME_TIME_SPAN | UNDEFINED | 0 |  |  |  | Y |  |  | YES | YES | YES
TIME_LONG_DESCRIPTION | UNDEFINED | 0 |  |  |  | Y |  |  | YES | YES | YES
TIME_SHORT_DESCRIPTION | UNDEFINED | 0 |  |  |  | Y |  |  | YES | YES | YES
TIME_QUARTER | UNDEFINED | 0 |  |  |  | Y |  |  | YES | YES | YES
TIME_MONTH | UNDEFINED | 0 |  |  |  | Y |  |  | YES | YES | YES
TIME_TIME_DSO_1 | UNDEFINED | 0 |  |  |  | Y |  |  | YES | YES | YES
Total: 18 column(s)

Uses

Owner | Name | Type
PUBLIC | OLAP_TABLE | SYNONYM
Total: 1 use reference(s)

DDL

CREATE OR REPLACE FORCE VIEW "GLOBAL"."TIME_DIMVIEW" ("TIME_ID", "TIME_CALENDAR_YEA_PARENT", "TIME_YEAR_ID", "TIME_YEAR_DESC", "TIME_QUARTER_ID", "TIME_QUARTER_DESC", "TIME_MONTH_ID", "TIME_MONTH_DESC", "TIME_ALL_YEARS_ID", "TIME_ALL_YEARS_DESC", "TIME_LEVEL", "TIME_END_DATE", "TIME_TIME_SPAN", "TIME_LONG_DESCRIPTION", "TIME_SHORT_DESCRIPTION", "TIME_QUARTER", "TIME_MONTH", "TIME_TIME_DSO_1") AS
SELECT "TIME_ID","TIME_CALENDAR_YEA_PARENT","TIME_YEAR_ID","TIME_YEAR_DESC","TIME_QUARTER_ID","TIME_QUARTER_DESC","TIME_MONTH_ID","TIME_MONTH_DESC","TIME_ALL_YEARS_ID","TIME_ALL_YEARS_DESC","TIME_LEVEL","TIME_END_DATE","TIME_TIME_SPAN","TIME_LONG_DESCRIPTION","TIME_SHORT_DESCRIPTION","TIME_QUARTER","TIME_MONTH","TIME_TIME_DSO_1"
FROM table(OLAP_TABLE('GLOBAL duration session',
'',
'',
'&(TIME_LIMITMAP)' ))
MODEL
DIMENSION BY(
time_id
)
MEASURES(
time_calendar_yea_parent,
time_year_id,
time_year_desc,
time_quarter_id,
time_quarter_desc,
time_month_id,
time_month_desc,
time_all_years_id,
time_all_years_desc,
time_level,
time_end_date,
time_time_span,
time_long_description,
time_short_description,
time_quarter,
time_month,
time_time_dso_1
)
RULES UPDATE SEQUENTIAL ORDER()

See Also

List of views


View: TIME_VIEW

Properties

Name: | TIME_VIEW
Status: | VALID
Last modify: | 4/16/2007 12:27:13 PM
Created: | 4/16/2007 12:14:54 PM
Description: |

Columns

Name | Type | Length | Nchar Length | Precision | Scale | NULL | Default | Comment | Updatable | Deletable | Insertable
ALL_YEARS | CHAR | 9 |  |  |  | Y |  |  | NO | NO | NO
MONTH_ID | NUMBER | 5 |  | 5 | 0 | Y |  |  | NO | NO | NO
MONTH_DSC | VARCHAR2 | 10 |  |  |  | Y |  |  | NO | NO | NO
MONTH_END_DATE | DATE | 7 |  |  |  | Y |  |  | NO | NO | NO
MONTH_TIMESPAN | NUMBER | 5 |  | 5 | 0 | Y |  |  | NO | NO | NO
MONTH | VARCHAR2 | 3 |  |  |  | Y |  |  | NO | NO | NO
QUARTER_ID | NUMBER | 5 |  | 5 | 0 | Y |  |  | NO | NO | NO
QUARTER_DSC | VARCHAR2 | 5 |  |  |  | Y |  |  | NO | NO | NO
QUARTER_END_DATE | DATE | 7 |  |  |  | Y |  |  | NO | NO | NO
QUARTER_TIMESPAN | NUMBER | 5 |  | 5 | 0 | Y |  |  | NO | NO | NO
QUARTER | VARCHAR2 | 2 |  |  |  | Y |  |  | NO | NO | NO
YEAR_ID | NUMBER | 5 |  | 5 | 0 | Y |  |  | NO | NO | NO
YEAR_DSC | VARCHAR2 | 5 |  |  |  | Y |  |  | NO | NO | NO
YEAR_TIMESPAN | NUMBER | 5 |  | 5 | 0 | Y |  |  | NO | NO | NO
YEAR_END_DATE | DATE | 7 |  |  |  | Y |  |  | NO | NO | NO
FISCAL_QUARTER_ID | NUMBER | 5 |  | 5 | 0 | Y |  |  | NO | NO | NO
FISCAL_QUARTER_DSC | VARCHAR2 | 10 |  |  |  | Y |  |  | NO | NO | NO
FISCAL_QUARTER_END_DATE | DATE | 7 |  |  |  | Y |  |  | NO | NO | NO
FISCAL_QUARTER_TIMESPAN | NUMBER | 5 |  | 5 | 0 | Y |  |  | NO | NO | NO
FISCAL_YEAR_ID | NUMBER | 5 |  | 5 | 0 | Y |  |  | NO | NO | NO
FISCAL_YEAR_DSC | VARCHAR2 | 5 |  |  |  | Y |  |  | NO | NO | NO
FISCAL_YEAR_END_DATE | DATE | 7 |  |  |  | Y |  |  | NO | NO | NO
FISCAL_YEAR_TIMESPAN | NUMBER | 5 |  | 5 | 0 | Y |  |  | NO | NO | NO
Total: 23 column(s)

Grants

Privilage | Grantee | Grantable | Grantor
SELECT | GLOBAL_AW | NO | GLOBAL
Total: 1 grants

Uses

Owner | Name | Type
GLOBAL | SALES_FACT | VIEW
GLOBAL | TIME_DIM | TABLE
Total: 2 use reference(s)

DDL

CREATE OR REPLACE FORCE VIEW "GLOBAL"."TIME_VIEW" ("ALL_YEARS", "MONTH_ID", "MONTH_DSC", "MONTH_END_DATE", "MONTH_TIMESPAN", "MONTH", "QUARTER_ID", "QUARTER_DSC", "QUARTER_END_DATE", "QUARTER_TIMESPAN", "QUARTER", "YEAR_ID", "YEAR_DSC", "YEAR_TIMESPAN", "YEAR_END_DATE", "FISCAL_QUARTER_ID", "FISCAL_QUARTER_DSC", "FISCAL_QUARTER_END_DATE", "FISCAL_QUARTER_TIMESPAN", "FISCAL_YEAR_ID", "FISCAL_YEAR_DSC", "FISCAL_YEAR_END_DATE", "FISCAL_YEAR_TIMESPAN") AS
SELECT
'All Years' ALL_YEARS,
MONTH_ID,
MONTH_DSC,
MONTH_END_DATE,
MONTH_TIMESPAN,
TO_CHAR(MONTH_END_DATE, 'Mon') as MONTH,
QUARTER_ID,
QUARTER_DSC,
QUARTER_END_DATE,
QUARTER_TIMESPAN,
SUBSTR(QUARTER_DSC, 1, 2) as QUARTER,
YEAR_ID,
YEAR_DSC,
YEAR_TIMESPAN,
YEAR_END_DATE,
FISCAL_QUARTER_ID,
FISCAL_QUARTER_DSC,
FISCAL_QUARTER_END_DATE,
FISCAL_QUARTER_TIMESPAN,
FISCAL_YEAR_ID,
FISCAL_YEAR_DSC,
FISCAL_YEAR_END_DATE,
FISCAL_YEAR_TIMESPAN
FROM
TIME_DIM
WHERE
MONTH_ID IN (SELECT DISTINCT MONTH_ID FROM SALES_FACT)

See Also

List of views


View: UNITS_CUBE_CUBEVIEW

Properties

Name: | UNITS_CUBE_CUBEVIEW
Status: | INVALID
Last modify: | 4/16/2007 12:27:12 PM
Created: | 4/16/2007 12:27:12 PM
Description: |

Columns

Name | Type | Length | Nchar Length | Precision | Scale | NULL | Default | Comment | Updatable | Deletable | Insertable
TIME_ID | UNDEFINED | 0 |  |  |  | Y |  |  | YES | YES | YES
CUSTOMER_ID | UNDEFINED | 0 |  |  |  | Y |  |  | YES | YES | YES
PRODUCT_ID | UNDEFINED | 0 |  |  |  | Y |  |  | YES | YES | YES
CHANNEL_ID | UNDEFINED | 0 |  |  |  | Y |  |  | YES | YES | YES
TIME_CALENDAR_YEA_PARENT | UNDEFINED | 0 |  |  |  | Y |  |  | YES | YES | YES
TIME_YEAR_ID | UNDEFINED | 0 |  |  |  | Y |  |  | YES | YES | YES
TIME_YEAR_DESC | UNDEFINED | 0 |  |  |  | Y |  |  | YES | YES | YES
TIME_QUARTER_ID | UNDEFINED | 0 |  |  |  | Y |  |  | YES | YES | YES
TIME_QUARTER_DESC | UNDEFINED | 0 |  |  |  | Y |  |  | YES | YES | YES
TIME_MONTH_ID | UNDEFINED | 0 |  |  |  | Y |  |  | YES | YES | YES
TIME_MONTH_DESC | UNDEFINED | 0 |  |  |  | Y |  |  | YES | YES | YES
TIME_ALL_YEARS_ID | UNDEFINED | 0 |  |  |  | Y |  |  | YES | YES | YES
TIME_ALL_YEARS_DESC | UNDEFINED | 0 |  |  |  | Y |  |  | YES | YES | YES
TIME_LEVEL | UNDEFINED | 0 |  |  |  | Y |  |  | YES | YES | YES
TIME_END_DATE | UNDEFINED | 0 |  |  |  | Y |  |  | YES | YES | YES
TIME_TIME_SPAN | UNDEFINED | 0 |  |  |  | Y |  |  | YES | YES | YES
TIME_LONG_DESCRIPTION | UNDEFINED | 0 |  |  |  | Y |  |  | YES | YES | YES
TIME_SHORT_DESCRIPTION | UNDEFINED | 0 |  |  |  | Y |  |  | YES | YES | YES
TIME_QUARTER | UNDEFINED | 0 |  |  |  | Y |  |  | YES | YES | YES
TIME_MONTH | UNDEFINED | 0 |  |  |  | Y |  |  | YES | YES | YES
TIME_TIME_DSO_1 | UNDEFINED | 0 |  |  |  | Y |  |  | YES | YES | YES
CUSTOMER_SHIPMENTS_PARENT | UNDEFINED | 0 |  |  |  | Y |  |  | YES | YES | YES
CUSTOMER_TOTAL_CUSTOMER_ID | UNDEFINED | 0 |  |  |  | Y |  |  | YES | YES | YES
CUSTOMER_TOTAL_CUSTOMER_DESC | UNDEFINED | 0 |  |  |  | Y |  |  | YES | YES | YES
CUSTOMER_REGION_ID | UNDEFINED | 0 |  |  |  | Y |  |  | YES | YES | YES
CUSTOMER_REGION_DESC | UNDEFINED | 0 |  |  |  | Y |  |  | YES | YES | YES
CUSTOMER_WAREHOUSE_ID | UNDEFINED | 0 |  |  |  | Y |  |  | YES | YES | YES
CUSTOMER_WAREHOUSE_DESC | UNDEFINED | 0 |  |  |  | Y |  |  | YES | YES | YES
CUSTOMER_SHIP_TO_ID | UNDEFINED | 0 |  |  |  | Y |  |  | YES | YES | YES
CUSTOMER_SHIP_TO_DESC | UNDEFINED | 0 |  |  |  | Y |  |  | YES | YES | YES
CUSTOMER_MARKET_SEGME_PARENT | UNDEFINED | 0 |  |  |  | Y |  |  | YES | YES | YES
CUSTOMER_TOTAL_MARKET_ID | UNDEFINED | 0 |  |  |  | Y |  |  | YES | YES | YES
CUSTOMER_TOTAL_MARKET_DESC | UNDEFINED | 0 |  |  |  | Y |  |  | YES | YES | YES
CUSTOMER_MARKET_SEGMENT_ID | UNDEFINED | 0 |  |  |  | Y |  |  | YES | YES | YES
CUSTOMER_MARKET_SEGMENT_DESC | UNDEFINED | 0 |  |  |  | Y |  |  | YES | YES | YES
CUSTOMER_ACCOUNT_ID | UNDEFINED | 0 |  |  |  | Y |  |  | YES | YES | YES
CUSTOMER_ACCOUNT_DESC | UNDEFINED | 0 |  |  |  | Y |  |  | YES | YES | YES
CUSTOMER_LEVEL | UNDEFINED | 0 |  |  |  | Y |  |  | YES | YES | YES
CUSTOMER_LONG_DESCRIPTION | UNDEFINED | 0 |  |  |  | Y |  |  | YES | YES | YES
CUSTOMER_SHORT_DESCRIPTION | UNDEFINED | 0 |  |  |  | Y |  |  | YES | YES | YES
PRODUCT_PRIMARY_PARENT | UNDEFINED | 0 |  |  |  | Y |  |  | YES | YES | YES
PRODUCT_TOTAL_PRODUCT_ID | UNDEFINED | 0 |  |  |  | Y |  |  | YES | YES | YES
PRODUCT_TOTAL_PRODUCT_DESC | UNDEFINED | 0 |  |  |  | Y |  |  | YES | YES | YES
PRODUCT_CLASS_ID | UNDEFINED | 0 |  |  |  | Y |  |  | YES | YES | YES
PRODUCT_CLASS_DESC | UNDEFINED | 0 |  |  |  | Y |  |  | YES | YES | YES
PRODUCT_FAMILY_ID | UNDEFINED | 0 |  |  |  | Y |  |  | YES | YES | YES
PRODUCT_FAMILY_DESC | UNDEFINED | 0 |  |  |  | Y |  |  | YES | YES | YES
PRODUCT_ITEM_ID | UNDEFINED | 0 |  |  |  | Y |  |  | YES | YES | YES
PRODUCT_ITEM_DESC | UNDEFINED | 0 |  |  |  | Y |  |  | YES | YES | YES
PRODUCT_LEVEL | UNDEFINED | 0 |  |  |  | Y |  |  | YES | YES | YES
PRODUCT_LONG_DESCRIPTION | UNDEFINED | 0 |  |  |  | Y |  |  | YES | YES | YES
PRODUCT_SHORT_DESCRIPTION | UNDEFINED | 0 |  |  |  | Y |  |  | YES | YES | YES
PRODUCT_ISVISIBLE | UNDEFINED | 0 |  |  |  | Y |  |  | YES | YES | YES
PRODUCT_PACKAGE | UNDEFINED | 0 |  |  |  | Y |  |  | YES | YES | YES
PRODUCT_BUYER | UNDEFINED | 0 |  |  |  | Y |  |  | YES | YES | YES
PRODUCT_MARKETING_MANAGER | UNDEFINED | 0 |  |  |  | Y |  |  | YES | YES | YES
CHANNEL_PRIMARY_PARENT | UNDEFINED | 0 |  |  |  | Y |  |  | YES | YES | YES
CHANNEL_TOTAL_CHANNEL_ID | UNDEFINED | 0 |  |  |  | Y |  |  | YES | YES | YES
CHANNEL_TOTAL_CHANNEL_DESC | UNDEFINED | 0 |  |  |  | Y |  |  | YES | YES | YES
CHANNEL_CHANNEL_ID | UNDEFINED | 0 |  |  |  | Y |  |  | YES | YES | YES
CHANNEL_CHANNEL_DESC | UNDEFINED | 0 |  |  |  | Y |  |  | YES | YES | YES
CHANNEL_LEVEL | UNDEFINED | 0 |  |  |  | Y |  |  | YES | YES | YES
CHANNEL_LONG_DESCRIPTION | UNDEFINED | 0 |  |  |  | Y |  |  | YES | YES | YES
CHANNEL_SHORT_DESCRIPTION | UNDEFINED | 0 |  |  |  | Y |  |  | YES | YES | YES
UNITS | UNDEFINED | 0 |  |  |  | Y |  |  | YES | YES | YES
SALES | UNDEFINED | 0 |  |  |  | Y |  |  | YES | YES | YES
COST | UNDEFINED | 0 |  |  |  | Y |  |  | YES | YES | YES
SALES_PP | UNDEFINED | 0 |  |  |  | Y |  |  | YES | YES | YES
SALES_CHG_PP | UNDEFINED | 0 |  |  |  | Y |  |  | YES | YES | YES
SALES_PCT_CHG_PP | UNDEFINED | 0 |  |  |  | Y |  |  | YES | YES | YES
SALES_PY | UNDEFINED | 0 |  |  |  | Y |  |  | YES | YES | YES
SALES_CHG_PY | UNDEFINED | 0 |  |  |  | Y |  |  | YES | YES | YES
SALES_PCT_CHG_PY | UNDEFINED | 0 |  |  |  | Y |  |  | YES | YES | YES
SALES_YTD | UNDEFINED | 0 |  |  |  | Y |  |  | YES | YES | YES
SALES_YTD_PY | UNDEFINED | 0 |  |  |  | Y |  |  | YES | YES | YES
SALES_YTD_CHG_PY | UNDEFINED | 0 |  |  |  | Y |  |  | YES | YES | YES
SALES_YTD_PCT_CHG_PY | UNDEFINED | 0 |  |  |  | Y |  |  | YES | YES | YES
SALES_PROD_PRNT_SHARE | UNDEFINED | 0 |  |  |  | Y |  |  | YES | YES | YES
SALES_PROD_TOT_SHARE | UNDEFINED | 0 |  |  |  | Y |  |  | YES | YES | YES
SALES_3_PER_MOVAVG | UNDEFINED | 0 |  |  |  | Y |  |  | YES | YES | YES
PROFIT | UNDEFINED | 0 |  |  |  | Y |  |  | YES | YES | YES
HOW_IS_MARGIN | UNDEFINED | 0 |  |  |  | Y |  |  | YES | YES | YES
PROFIT_PP | UNDEFINED | 0 |  |  |  | Y |  |  | YES | YES | YES
PROFIT_CHG_PP | UNDEFINED | 0 |  |  |  | Y |  |  | YES | YES | YES
PROFIT_PCT_CHG_PP | UNDEFINED | 0 |  |  |  | Y |  |  | YES | YES | YES
PROFIT_PY | UNDEFINED | 0 |  |  |  | Y |  |  | YES | YES | YES
PROFIT_CHG_PY | UNDEFINED | 0 |  |  |  | Y |  |  | YES | YES | YES
PROFIT_PCT_CHG_PY | UNDEFINED | 0 |  |  |  | Y |  |  | YES | YES | YES
PROFIT_YTD | UNDEFINED | 0 |  |  |  | Y |  |  | YES | YES | YES
PROFIT_YTD_PY | UNDEFINED | 0 |  |  |  | Y |  |  | YES | YES | YES
PROFIT_YTD_CHG_PY | UNDEFINED | 0 |  |  |  | Y |  |  | YES | YES | YES
PROFIT_YTD_PCT_CHG_PY | UNDEFINED | 0 |  |  |  | Y |  |  | YES | YES | YES
PROFIT_PROD_PRNT_SHARE | UNDEFINED | 0 |  |  |  | Y |  |  | YES | YES | YES
PROFIT_PROD_TOT_SHARE | UNDEFINED | 0 |  |  |  | Y |  |  | YES | YES | YES
PROFIT_3_PER_MOVAVG | UNDEFINED | 0 |  |  |  | Y |  |  | YES | YES | YES
OLAP_CALC | UNDEFINED | 0 |  |  |  | Y |  |  | YES | YES | YES
Total: 96 column(s)

Uses

Owner | Name | Type
PUBLIC | OLAP_TABLE | SYNONYM
Total: 1 use reference(s)

DDL

CREATE OR REPLACE FORCE VIEW "GLOBAL"."UNITS_CUBE_CUBEVIEW" ("TIME_ID", "CUSTOMER_ID", "PRODUCT_ID", "CHANNEL_ID", "TIME_CALENDAR_YEA_PARENT", "TIME_YEAR_ID", "TIME_YEAR_DESC", "TIME_QUARTER_ID", "TIME_QUARTER_DESC", "TIME_MONTH_ID", "TIME_MONTH_DESC", "TIME_ALL_YEARS_ID", "TIME_ALL_YEARS_DESC", "TIME_LEVEL", "TIME_END_DATE", "TIME_TIME_SPAN", "TIME_LONG_DESCRIPTION", "TIME_SHORT_DESCRIPTION", "TIME_QUARTER", "TIME_MONTH", "TIME_TIME_DSO_1", "CUSTOMER_SHIPMENTS_PARENT", "CUSTOMER_TOTAL_CUSTOMER_ID", "CUSTOMER_TOTAL_CUSTOMER_DESC", "CUSTOMER_REGION_ID", "CUSTOMER_REGION_DESC", "CUSTOMER_WAREHOUSE_ID", "CUSTOMER_WAREHOUSE_DESC", "CUSTOMER_SHIP_TO_ID", "CUSTOMER_SHIP_TO_DESC", "CUSTOMER_MARKET_SEGME_PARENT", "CUSTOMER_TOTAL_MARKET_ID", "CUSTOMER_TOTAL_MARKET_DESC", "CUSTOMER_MARKET_SEGMENT_ID", "CUSTOMER_MARKET_SEGMENT_DESC", "CUSTOMER_ACCOUNT_ID", "CUSTOMER_ACCOUNT_DESC", "CUSTOMER_LEVEL", "CUSTOMER_LONG_DESCRIPTION", "CUSTOMER_SHORT_DESCRIPTION", "PRODUCT_PRIMARY_PARENT", "PRODUCT_TOTAL_PRODUCT_ID", "PRODUCT_TOTAL_PRODUCT_DESC", "PRODUCT_CLASS_ID", "PRODUCT_CLASS_DESC", "PRODUCT_FAMILY_ID", "PRODUCT_FAMILY_DESC", "PRODUCT_ITEM_ID", "PRODUCT_ITEM_DESC", "PRODUCT_LEVEL", "PRODUCT_LONG_DESCRIPTION", "PRODUCT_SHORT_DESCRIPTION", "PRODUCT_ISVISIBLE", "PRODUCT_PACKAGE", "PRODUCT_BUYER", "PRODUCT_MARKETING_MANAGER", "CHANNEL_PRIMARY_PARENT", "CHANNEL_TOTAL_CHANNEL_ID", "CHANNEL_TOTAL_CHANNEL_DESC", "CHANNEL_CHANNEL_ID", "CHANNEL_CHANNEL_DESC", "CHANNEL_LEVEL", "CHANNEL_LONG_DESCRIPTION", "CHANNEL_SHORT_DESCRIPTION", "UNITS", "SALES", "COST", "SALES_PP", "SALES_CHG_PP", "SALES_PCT_CHG_PP", "SALES_PY", "SALES_CHG_PY", "SALES_PCT_CHG_PY", "SALES_YTD", "SALES_YTD_PY", "SALES_YTD_CHG_PY", "SALES_YTD_PCT_CHG_PY", "SALES_PROD_PRNT_SHARE", "SALES_PROD_TOT_SHARE", "SALES_3_PER_MOVAVG", "PROFIT", "HOW_IS_MARGIN", "PROFIT_PP", "PROFIT_CHG_PP", "PROFIT_PCT_CHG_PP", "PROFIT_PY", "PROFIT_CHG_PY", "PROFIT_PCT_CHG_PY", "PROFIT_YTD", "PROFIT_YTD_PY", "PROFIT_YTD_CHG_PY", "PROFIT_YTD_PCT_CHG_PY", "PROFIT_PROD_PRNT_SHARE", "PROFIT_PROD_TOT_SHARE", "PROFIT_3_PER_MOVAVG", "OLAP_CALC") AS
SELECT "TIME_ID","CUSTOMER_ID","PRODUCT_ID","CHANNEL_ID","TIME_CALENDAR_YEA_PARENT","TIME_YEAR_ID","TIME_YEAR_DESC","TIME_QUARTER_ID","TIME_QUARTER_DESC","TIME_MONTH_ID","TIME_MONTH_DESC","TIME_ALL_YEARS_ID","TIME_ALL_YEARS_DESC","TIME_LEVEL","TIME_END_DATE","TIME_TIME_SPAN","TIME_LONG_DESCRIPTION","TIME_SHORT_DESCRIPTION","TIME_QUARTER","TIME_MONTH","TIME_TIME_DSO_1","CUSTOMER_SHIPMENTS_PARENT","CUSTOMER_TOTAL_CUSTOMER_ID","CUSTOMER_TOTAL_CUSTOMER_DESC","CUSTOMER_REGION_ID","CUSTOMER_REGION_DESC","CUSTOMER_WAREHOUSE_ID","CUSTOMER_WAREHOUSE_DESC","CUSTOMER_SHIP_TO_ID","CUSTOMER_SHIP_TO_DESC","CUSTOMER_MARKET_SEGME_PARENT","CUSTOMER_TOTAL_MARKET_ID","CUSTOMER_TOTAL_MARKET_DESC","CUSTOMER_MARKET_SEGMENT_ID","CUSTOMER_MARKET_SEGMENT_DESC","CUSTOMER_ACCOUNT_ID","CUSTOMER_ACCOUNT_DESC","CUSTOMER_LEVEL","CUSTOMER_LONG_DESCRIPTION","CUSTOMER_SHORT_DESCRIPTION","PRODUCT_PRIMARY_PARENT","PRODUCT_TOTAL_PRODUCT_ID","PRODUCT_TOTAL_PRODUCT_DESC","PRODUCT_CLASS_ID","PRODUCT_CLASS_DESC","PRODUCT_FAMILY_ID","PRODUCT_FAMILY_DESC","PRODUCT_ITEM_ID","PRODUCT_ITEM_DESC","PRODUCT_LEVEL","PRODUCT_LONG_DESCRIPTION","PRODUCT_SHORT_DESCRIPTION","PRODUCT_ISVISIBLE","PRODUCT_PACKAGE","PRODUCT_BUYER","PRODUCT_MARKETING_MANAGER","CHANNEL_PRIMARY_PARENT","CHANNEL_TOTAL_CHANNEL_ID","CHANNEL_TOTAL_CHANNEL_DESC","CHANNEL_CHANNEL_ID","CHANNEL_CHANNEL_DESC","CHANNEL_LEVEL","CHANNEL_LONG_DESCRIPTION","CHANNEL_SHORT_DESCRIPTION","UNITS","SALES","COST","SALES_PP","SALES_CHG_PP","SALES_PCT_CHG_PP","SALES_PY","SALES_CHG_PY","SALES_PCT_CHG_PY","SALES_YTD","SALES_YTD_PY","SALES_YTD_CHG_PY","SALES_YTD_PCT_CHG_PY","SALES_PROD_PRNT_SHARE","SALES_PROD_TOT_SHARE","SALES_3_PER_MOVAVG","PROFIT","HOW_IS_MARGIN","PROFIT_PP","PROFIT_CHG_PP","PROFIT_PCT_CHG_PP","PROFIT_PY","PROFIT_CHG_PY","PROFIT_PCT_CHG_PY","PROFIT_YTD","PROFIT_YTD_PY","PROFIT_YTD_CHG_PY","PROFIT_YTD_PCT_CHG_PY","PROFIT_PROD_PRNT_SHARE","PROFIT_PROD_TOT_SHARE","PROFIT_3_PER_MOVAVG","OLAP_CALC"
FROM table(OLAP_TABLE('GLOBAL duration session',
'',
'',
'&(UNITS_CUBE_LIMITMAP)' ))
MODEL
DIMENSION BY(
time_id,
customer_id,
product_id,
channel_id
)
MEASURES(
time_calendar_yea_parent,
time_year_id,
time_year_desc,
time_quarter_id,
time_quarter_desc,
time_month_id,
time_month_desc,
time_all_years_id,
time_all_years_desc,
time_level,
time_end_date,
time_time_span,
time_long_description,
time_short_description,
time_quarter,
time_month,
time_time_dso_1,
customer_shipments_parent,
customer_total_customer_id,
customer_total_customer_desc,
customer_region_id,
customer_region_desc,
customer_warehouse_id,
customer_warehouse_desc,
customer_ship_to_id,
customer_ship_to_desc,
customer_market_segme_parent,
customer_total_market_id,
customer_total_market_desc,
customer_market_segment_id,
customer_market_segment_desc,
customer_account_id,
customer_account_desc,
customer_level,
customer_long_description,
customer_short_description,
product_primary_parent,
product_total_product_id,
product_total_product_desc,
product_class_id,
product_class_desc,
product_family_id,
product_family_desc,
product_item_id,
product_item_desc,
product_level,
product_long_description,
product_short_description,
product_isvisible,
product_package,
product_buyer,
product_marketing_manager,
channel_primary_parent,
channel_total_channel_id,
channel_total_channel_desc,
channel_channel_id,
channel_channel_desc,
channel_level,
channel_long_description,
channel_short_description,
units,
sales,
cost,
sales_pp,
sales_chg_pp,
sales_pct_chg_pp,
sales_py,
sales_chg_py,
sales_pct_chg_py,
sales_ytd,
sales_ytd_py,
sales_ytd_chg_py,
sales_ytd_pct_chg_py,
sales_prod_prnt_share,
sales_prod_tot_share,
sales_3_per_movavg,
profit,
how_is_margin,
profit_pp,
profit_chg_pp,
profit_pct_chg_pp,
profit_py,
profit_chg_py,
profit_pct_chg_py,
profit_ytd,
profit_ytd_py,
profit_ytd_chg_py,
profit_ytd_pct_chg_py,
profit_prod_prnt_share,
profit_prod_tot_share,
profit_3_per_movavg,
olap_calc
)
RULES UPDATE SEQUENTIAL ORDER()

See Also

List of views


List of analytical workspaces

Analytical workspaces

Name | Default Language
GLOBAL | AMERICAN
Total: 1 analytical workspace(s)

See Also

Schema overview


Workspace: GLOBAL

Properties

Name: | GLOBAL
Short Name: | GLOBAL.GLOBAL
Plural Name: | GLOBAL.GLOBAL
MetaData Format: | 10.2
Default Language: | AMERICAN
Languages: | AMERICAN

Dimensions

Name | Short Name | Time | Use Native Key
TIME | AMERICAN::Time |  |
CHANNEL | AMERICAN::Channel |  |
CUSTOMER | AMERICAN::Customer |  |
PRODUCT | AMERICAN::Product |  |
Total: 4 dimension(s)

Cubes

Name | ShortName | SparseType | DefaultDataType | UseGlobalIndex | AutoSolve
UNITS_CUBE | AMERICAN::Units Cube | STANDARD | DECIMAL |  |
Total: 1 cube(s)

Measure folders

Name | Short Name
TIME_CALCULATIONS | AMERICAN::Time Calculations
YTD_CALCULATIONS | AMERICAN::YTD Calculations
PRODUCT_SHARE | AMERICAN::Product Share
Total: 3 measure folder(s)

Calculation plans

Name | Short Name
CALCULATION_PLAN1 | AMERICAN::Calculation Plan1
CALCULATION_PLAN | AMERICAN::Calculation Plan short
Total: 2 measure folder(s)

See Also

List of workspaces


List of dimensions

Dimensions

Name | Short Name | Time
TIME | AMERICAN::Time |
CHANNEL | AMERICAN::Channel |
CUSTOMER | AMERICAN::Customer |
PRODUCT | AMERICAN::Product |
Total: 4 dimension(s)

See Also

Workspace [GLOBAL]


Dimension: TIME

Properties

ID: | TIME.DIMENSION
Name: | TIME
Long Name: | AMERICAN::Time
Short Name: | AMERICAN::Time
Plural Name: | AMERICAN::Time
Schema: | GLOBAL
Time: |
Use Native Key: |

Levels

Name | Short Name | Dimensioned
YEAR | AMERICAN::Year |
QUARTER | AMERICAN::Quarter |
MONTH | AMERICAN::Month |
ALL_YEARS | AMERICAN::All Years |
Total: 4 level(s)

Hierarchies

Name | Long Name | Default | Type
CALENDAR_YEAR | AMERICAN::Calendar Year |  | LEVEL
Total: 1 hierarchy(s)

Attributes

Name | Short Name | DataType
END_DATE | AMERICAN::END_DATE | DATE
TIME_SPAN | AMERICAN::TIME_SPAN | INTEGER
LONG_DESCRIPTION | AMERICAN::Long Description | TEXT
SHORT_DESCRIPTION | AMERICAN::Short Description | TEXT
QUARTER | AMERICAN::Quarter | TEXT
MONTH | AMERICAN::Month | TEXT
TIME_DSO_1 | AMERICAN::TIME_DSO_1 | INTEGER
Total: 7 attribute(s)

See Also

List of dimensions


List of levels

Levels

Name | Short Name | Dimensioned
YEAR | AMERICAN::Year |
QUARTER | AMERICAN::Quarter |
MONTH | AMERICAN::Month |
ALL_YEARS | AMERICAN::All Years |
Total: 4 level(s)

See Also

Dimension [TIME]


Level: YEAR in TIME

Properties

ID: | TIME.YEAR.LEVEL
Name: | YEAR
Long Name: | AMERICAN::Year
Short Name: | AMERICAN::Year
Plural Name: | AMERICAN::Year
Dimensioned: |

See Also

List of levels


Level: QUARTER in TIME

Properties

ID: | TIME.QUARTER.LEVEL
Name: | QUARTER
Long Name: | AMERICAN::Quarter
Short Name: | AMERICAN::Quarter
Plural Name: | AMERICAN::Quarter
Dimensioned: |

See Also

List of levels


Level: MONTH in TIME

Properties

ID: | TIME.MONTH.LEVEL
Name: | MONTH
Long Name: | AMERICAN::Month
Short Name: | AMERICAN::Month
Plural Name: | AMERICAN::Month
Dimensioned: |

See Also

List of levels


Level: ALL_YEARS in TIME

Properties

ID: | TIME.ALL_YEARS.LEVEL
Name: | ALL_YEARS
Long Name: | AMERICAN::All Years
Short Name: | AMERICAN::All Years
Plural Name: | AMERICAN::All Years
Dimensioned: |

See Also

List of levels


List of hierarchies

Hierarchies

Name | Long Name | Default | Type
CALENDAR_YEAR | AMERICAN::Calendar Year |  | LEVEL
Total: 1 hierarchy(s)

See Also

Dimension [TIME]


Hierarchy: CALENDAR_YEAR in TIME

Properties

ID: | TIME.CALENDAR_YEAR.HIERARCHY
Name: | CALENDAR_YEAR
LongName: | AMERICAN::Calendar Year
ShortName: | AMERICAN::Calendar Year
PluralName: | AMERICAN::Calendar Year
Default: |
Type: | LEVEL

Levels

Name | Short Name | SourceColumn | ParentColumn
ALL_YEARS | AMERICAN::HLA1 | GLOBAL.TIME_VIEW.ALL_YEARS |
YEAR | AMERICAN::HLA2 | GLOBAL.TIME_VIEW.YEAR_ID | GLOBAL.TIME_VIEW.ALL_YEARS
QUARTER | AMERICAN::HLA3 | GLOBAL.TIME_VIEW.QUARTER_ID | GLOBAL.TIME_VIEW.YEAR_ID
MONTH | AMERICAN::HLA4 | GLOBAL.TIME_VIEW.MONTH_ID | GLOBAL.TIME_VIEW.QUARTER_ID
Total: 4 level(s)

See Also

List of hierarchies


List of levels

Level

Name | Short Name | SourceColumn | ParentColumn
ALL_YEARS | AMERICAN::HLA1 | GLOBAL.TIME_VIEW.ALL_YEARS |
YEAR | AMERICAN::HLA2 | GLOBAL.TIME_VIEW.YEAR_ID | GLOBAL.TIME_VIEW.ALL_YEARS
QUARTER | AMERICAN::HLA3 | GLOBAL.TIME_VIEW.QUARTER_ID | GLOBAL.TIME_VIEW.YEAR_ID
MONTH | AMERICAN::HLA4 | GLOBAL.TIME_VIEW.MONTH_ID | GLOBAL.TIME_VIEW.QUARTER_ID
Total: 4 attribute(s)

See Also

Hierarchy [CALENDAR_YEAR]


Level: ALL_YEARS in CALENDAR_YEAR

Properties

Name: | ALL_YEARS
LongName: | AMERICAN::HLA1
Short Name: | AMERICAN::HLA1
Plural Name: | AMERICAN::HLA1
SourceColumn: | GLOBAL.TIME_VIEW.ALL_YEARS
ParentColumn: |

See Also

List of levels


Level: YEAR in CALENDAR_YEAR

Properties

Name: | YEAR
LongName: | AMERICAN::HLA2
Short Name: | AMERICAN::HLA2
Plural Name: | AMERICAN::HLA2
SourceColumn: | GLOBAL.TIME_VIEW.YEAR_ID
ParentColumn: | GLOBAL.TIME_VIEW.ALL_YEARS

See Also

List of levels


Level: QUARTER in CALENDAR_YEAR

Properties

Name: | QUARTER
LongName: | AMERICAN::HLA3
Short Name: | AMERICAN::HLA3
Plural Name: | AMERICAN::HLA3
SourceColumn: | GLOBAL.TIME_VIEW.QUARTER_ID
ParentColumn: | GLOBAL.TIME_VIEW.YEAR_ID

See Also

List of levels


Level: MONTH in CALENDAR_YEAR

Properties

Name: | MONTH
LongName: | AMERICAN::HLA4
Short Name: | AMERICAN::HLA4
Plural Name: | AMERICAN::HLA4
SourceColumn: | GLOBAL.TIME_VIEW.MONTH_ID
ParentColumn: | GLOBAL.TIME_VIEW.QUARTER_ID

See Also

List of levels


List of attributes

Attributes

Name | Short Name | DataType | MultiLingual
END_DATE | AMERICAN::END_DATE | DATE |
TIME_SPAN | AMERICAN::TIME_SPAN | INTEGER |
LONG_DESCRIPTION | AMERICAN::Long Description | TEXT |
SHORT_DESCRIPTION | AMERICAN::Short Description | TEXT |
QUARTER | AMERICAN::Quarter | TEXT |
MONTH | AMERICAN::Month | TEXT |
TIME_DSO_1 | AMERICAN::TIME_DSO_1 | INTEGER |
Total: 7 attribute(s)

See Also

Dimension [TIME]


Attribute: END_DATE in TIME

Properties

ID: | TIME.END_DATE.ATTRIBUTE
Name: | END_DATE
Long Name: | AMERICAN::END_DATE
Short Name: | AMERICAN::END_DATE
Plural Name: | AMERICAN::END_DATE
DataType: | DATE
Classification: | END_DATE
DefaultOrder: |
MultiLingual: |

Mappings

Language | Hierarchy | Level | Column
AMERICAN | CALENDAR_YEAR | YEAR | GLOBAL.TIME_VIEW.YEAR_END_DATE
AMERICAN | CALENDAR_YEAR | QUARTER | GLOBAL.TIME_VIEW.QUARTER_END_DATE
AMERICAN | CALENDAR_YEAR | MONTH | GLOBAL.TIME_VIEW.MONTH_END_DATE
Total: 3 mappings(s)

Applied to levels

Hierarchy | Level | DefaultOrder | Install As Relation
CALENDAR_YEAR | YEAR |  |
CALENDAR_YEAR | QUARTER |  |
CALENDAR_YEAR | MONTH |  |
Total: 3 levels(s)

See Also

List of dimension attributes


Attribute: TIME_SPAN in TIME

Properties

ID: | TIME.TIME_SPAN.ATTRIBUTE
Name: | TIME_SPAN
Long Name: | AMERICAN::TIME_SPAN
Short Name: | AMERICAN::TIME_SPAN
Plural Name: | AMERICAN::TIME_SPAN
DataType: | INTEGER
Classification: | TIME_SPAN
DefaultOrder: |
MultiLingual: |

Mappings

Language | Hierarchy | Level | Column
AMERICAN | CALENDAR_YEAR | YEAR | GLOBAL.TIME_VIEW.YEAR_TIMESPAN
AMERICAN | CALENDAR_YEAR | QUARTER | GLOBAL.TIME_VIEW.QUARTER_TIMESPAN
AMERICAN | CALENDAR_YEAR | MONTH | GLOBAL.TIME_VIEW.MONTH_TIMESPAN
Total: 3 mappings(s)

Applied to levels

Hierarchy | Level | DefaultOrder | Install As Relation
CALENDAR_YEAR | YEAR |  |
CALENDAR_YEAR | QUARTER |  |
CALENDAR_YEAR | MONTH |  |
Total: 3 levels(s)

See Also

List of dimension attributes


Attribute: LONG_DESCRIPTION in TIME

Properties

ID: | TIME.LONG_DESCRIPTION.ATTRIBUTE
Name: | LONG_DESCRIPTION
Long Name: | AMERICAN::Long Description
Short Name: | AMERICAN::Long Description
Plural Name: | AMERICAN::Long Descriptions
DataType: | TEXT
Classification: | MEMBER_LONG_DESCRIPTION
DefaultOrder: |
MultiLingual: |

Mappings

Language | Hierarchy | Level | Column
AMERICAN | CALENDAR_YEAR | YEAR | GLOBAL.TIME_VIEW.YEAR_DSC
AMERICAN | CALENDAR_YEAR | QUARTER | GLOBAL.TIME_VIEW.QUARTER_DSC
AMERICAN | CALENDAR_YEAR | MONTH | GLOBAL.TIME_VIEW.MONTH_DSC
Total: 3 mappings(s)

Applied to levels

Hierarchy | Level | DefaultOrder | Install As Relation
CALENDAR_YEAR | YEAR |  |
CALENDAR_YEAR | QUARTER |  |
CALENDAR_YEAR | MONTH |  |
Total: 3 levels(s)

See Also

List of dimension attributes


Attribute: SHORT_DESCRIPTION in TIME

Properties

ID: | TIME.SHORT_DESCRIPTION.ATTRIBUTE
Name: | SHORT_DESCRIPTION
Long Name: | AMERICAN::Short Description
Short Name: | AMERICAN::Short Description
Plural Name: | AMERICAN::Short Descriptions
DataType: | TEXT
Classification: | MEMBER_SHORT_DESCRIPTION
DefaultOrder: |
MultiLingual: |

Mappings

Language | Hierarchy | Level | Column
AMERICAN | CALENDAR_YEAR | YEAR | GLOBAL.TIME_VIEW.YEAR_DSC
AMERICAN | CALENDAR_YEAR | QUARTER | GLOBAL.TIME_VIEW.QUARTER_DSC
AMERICAN | CALENDAR_YEAR | MONTH | GLOBAL.TIME_VIEW.MONTH_DSC
Total: 3 mappings(s)

Applied to levels

Hierarchy | Level | DefaultOrder | Install As Relation
CALENDAR_YEAR | YEAR |  |
CALENDAR_YEAR | QUARTER |  |
CALENDAR_YEAR | MONTH |  |
Total: 3 levels(s)

See Also

List of dimension attributes


Attribute: QUARTER in TIME

Properties

ID: | TIME.QUARTER.ATTRIBUTE
Name: | QUARTER
Long Name: | AMERICAN::Quarter
Short Name: | AMERICAN::Quarter
Plural Name: | AMERICAN::Quarter
DataType: | TEXT
Classification: | USER
DefaultOrder: |
MultiLingual: |

Mappings

Language | Hierarchy | Level | Column
AMERICAN | CALENDAR_YEAR | QUARTER | GLOBAL.TIME_VIEW.QUARTER
Total: 1 mappings(s)

Applied to levels

Hierarchy | Level | DefaultOrder | Install As Relation
CALENDAR_YEAR | QUARTER |  |
Total: 1 levels(s)

See Also

List of dimension attributes


Attribute: MONTH in TIME

Properties

ID: | TIME.MONTH.ATTRIBUTE
Name: | MONTH
Long Name: | AMERICAN::Month
Short Name: | AMERICAN::Month
Plural Name: | AMERICAN::Month
DataType: | TEXT
Classification: | USER
DefaultOrder: |
MultiLingual: |

Mappings

Language | Hierarchy | Level | Column
AMERICAN | CALENDAR_YEAR | MONTH | GLOBAL.TIME_VIEW.MONTH
Total: 1 mappings(s)

Applied to levels

Hierarchy | Level | DefaultOrder | Install As Relation
CALENDAR_YEAR | MONTH |  |
Total: 1 levels(s)

See Also

List of dimension attributes


Attribute: TIME_DSO_1 in TIME

Properties

ID: | TIME.TIME_DSO_1.ATTRIBUTE
Name: | TIME_DSO_1
Long Name: | AMERICAN::TIME_DSO_1
Short Name: | AMERICAN::TIME_DSO_1
Plural Name: | AMERICAN::TIME_DSO_1
DataType: | INTEGER
Classification: | USER
DefaultOrder: |
MultiLingual: |

See Also

List of dimension attributes


Dimension: CHANNEL

Properties

ID: | CHANNEL.DIMENSION
Name: | CHANNEL
Long Name: | AMERICAN::Channel
Short Name: | AMERICAN::Channel
Plural Name: | AMERICAN::Channel
Schema: | GLOBAL
Time: |
Use Native Key: |

Levels

Name | Short Name | Dimensioned
TOTAL_CHANNEL | AMERICAN::Total Channel |
CHANNEL | AMERICAN::Channel |
Total: 2 level(s)

Hierarchies

Name | Long Name | Default | Type
PRIMARY | AMERICAN::Primary |  | LEVEL
Total: 1 hierarchy(s)

Attributes

Name | Short Name | DataType
LONG_DESCRIPTION | AMERICAN::Long Description | TEXT
SHORT_DESCRIPTION | AMERICAN::Short Description | TEXT
Total: 2 attribute(s)

See Also

List of dimensions


List of levels

Levels

Name | Short Name | Dimensioned
TOTAL_CHANNEL | AMERICAN::Total Channel |
CHANNEL | AMERICAN::Channel |
Total: 2 level(s)

See Also

Dimension [CHANNEL]


Level: TOTAL_CHANNEL in CHANNEL

Properties

ID: | CHANNEL.TOTAL_CHANNEL.LEVEL
Name: | TOTAL_CHANNEL
Long Name: | AMERICAN::Total Channel
Short Name: | AMERICAN::Total Channel
Plural Name: | AMERICAN::Total Channel
Dimensioned: |

See Also

List of levels


Level: CHANNEL in CHANNEL

Properties

ID: | CHANNEL.CHANNEL.LEVEL
Name: | CHANNEL
Long Name: | AMERICAN::Channel
Short Name: | AMERICAN::Channel
Plural Name: | AMERICAN::Channel
Dimensioned: |

See Also

List of levels


List of hierarchies

Hierarchies

Name | Long Name | Default | Type
PRIMARY | AMERICAN::Primary |  | LEVEL
Total: 1 hierarchy(s)

See Also

Dimension [CHANNEL]


Hierarchy: PRIMARY in CHANNEL

Properties

ID: | CHANNEL.PRIMARY.HIERARCHY
Name: | PRIMARY
LongName: | AMERICAN::Primary
ShortName: | AMERICAN::Primary
PluralName: | AMERICAN::Primary
Default: |
Type: | LEVEL

Levels

Name | Short Name | SourceColumn | ParentColumn
TOTAL_CHANNEL | AMERICAN::HLA1 | GLOBAL.CHANNEL_VIEW.TOTAL_CHANNEL_ID |
CHANNEL | AMERICAN::HLA2 | GLOBAL.CHANNEL_VIEW.CHANNEL_ID | GLOBAL.CHANNEL_VIEW.TOTAL_CHANNEL_ID
Total: 2 level(s)

See Also

List of hierarchies


List of levels

Level

Name | Short Name | SourceColumn | ParentColumn
TOTAL_CHANNEL | AMERICAN::HLA1 | GLOBAL.CHANNEL_VIEW.TOTAL_CHANNEL_ID |
CHANNEL | AMERICAN::HLA2 | GLOBAL.CHANNEL_VIEW.CHANNEL_ID | GLOBAL.CHANNEL_VIEW.TOTAL_CHANNEL_ID
Total: 2 attribute(s)

See Also

Hierarchy [PRIMARY]


Level: TOTAL_CHANNEL in PRIMARY

Properties

Name: | TOTAL_CHANNEL
LongName: | AMERICAN::HLA1
Short Name: | AMERICAN::HLA1
Plural Name: | AMERICAN::HLA1
SourceColumn: | GLOBAL.CHANNEL_VIEW.TOTAL_CHANNEL_ID
ParentColumn: |

See Also

List of levels


Level: CHANNEL in PRIMARY

Properties

Name: | CHANNEL
LongName: | AMERICAN::HLA2
Short Name: | AMERICAN::HLA2
Plural Name: | AMERICAN::HLA2
SourceColumn: | GLOBAL.CHANNEL_VIEW.CHANNEL_ID
ParentColumn: | GLOBAL.CHANNEL_VIEW.TOTAL_CHANNEL_ID

See Also

List of levels


List of attributes

Attributes

Name | Short Name | DataType | MultiLingual
LONG_DESCRIPTION | AMERICAN::Long Description | TEXT |
SHORT_DESCRIPTION | AMERICAN::Short Description | TEXT |
Total: 2 attribute(s)

See Also

Dimension [CHANNEL]


Attribute: LONG_DESCRIPTION in CHANNEL

Properties

ID: | CHANNEL.LONG_DESCRIPTION.ATTRIBUTE
Name: | LONG_DESCRIPTION
Long Name: | AMERICAN::Long Description
Short Name: | AMERICAN::Long Description
Plural Name: | AMERICAN::Long Descriptions
DataType: | TEXT
Classification: | MEMBER_LONG_DESCRIPTION
DefaultOrder: |
MultiLingual: |

Mappings

Language | Hierarchy | Level | Column
AMERICAN | PRIMARY | TOTAL_CHANNEL | GLOBAL.CHANNEL_VIEW.TOTAL_CHANNEL_DSC
AMERICAN | PRIMARY | CHANNEL | GLOBAL.CHANNEL_VIEW.CHANNEL_DSC
Total: 2 mappings(s)

Applied to levels

Hierarchy | Level | DefaultOrder | Install As Relation
PRIMARY | TOTAL_CHANNEL |  |
PRIMARY | CHANNEL |  |
Total: 2 levels(s)

See Also

List of dimension attributes


Attribute: SHORT_DESCRIPTION in CHANNEL

Properties

ID: | CHANNEL.SHORT_DESCRIPTION.ATTRIBUTE
Name: | SHORT_DESCRIPTION
Long Name: | AMERICAN::Short Description
Short Name: | AMERICAN::Short Description
Plural Name: | AMERICAN::Short Descriptions
DataType: | TEXT
Classification: | MEMBER_SHORT_DESCRIPTION
DefaultOrder: |
MultiLingual: |

Mappings

Language | Hierarchy | Level | Column
AMERICAN | PRIMARY | TOTAL_CHANNEL | GLOBAL.CHANNEL_VIEW.TOTAL_CHANNEL_DSC
AMERICAN | PRIMARY | CHANNEL | GLOBAL.CHANNEL_VIEW.CHANNEL_DSC
Total: 2 mappings(s)

Applied to levels

Hierarchy | Level | DefaultOrder | Install As Relation
PRIMARY | TOTAL_CHANNEL |  |
PRIMARY | CHANNEL |  |
Total: 2 levels(s)

See Also

List of dimension attributes


Dimension: CUSTOMER

Properties

ID: | CUSTOMER.DIMENSION
Name: | CUSTOMER
Long Name: | AMERICAN::Customer
Short Name: | AMERICAN::Customer
Plural Name: | AMERICAN::Customer
Schema: | GLOBAL
Time: |
Use Native Key: |

Levels

Name | Short Name | Dimensioned
TOTAL_CUSTOMER | AMERICAN::Total Customer |
REGION | AMERICAN::Region |
WAREHOUSE | AMERICAN::Warehouse |
TOTAL_MARKET | AMERICAN::Total Market |
MARKET_SEGMENT | AMERICAN::Market Segment |
ACCOUNT | AMERICAN::Account |
SHIP_TO | AMERICAN::Ship To |
Total: 7 level(s)

Hierarchies

Name | Long Name | Default | Type
SHIPMENTS | AMERICAN::Shipments |  | LEVEL
MARKET_SEGMENT | AMERICAN::Market Segment |  | LEVEL
Total: 2 hierarchy(s)

Attributes

Name | Short Name | DataType
LONG_DESCRIPTION | AMERICAN::Long Description | TEXT
SHORT_DESCRIPTION | AMERICAN::Short Description | TEXT
Total: 2 attribute(s)

See Also

List of dimensions


List of levels

Levels

Name | Short Name | Dimensioned
TOTAL_CUSTOMER | AMERICAN::Total Customer |
REGION | AMERICAN::Region |
WAREHOUSE | AMERICAN::Warehouse |
TOTAL_MARKET | AMERICAN::Total Market |
MARKET_SEGMENT | AMERICAN::Market Segment |
ACCOUNT | AMERICAN::Account |
SHIP_TO | AMERICAN::Ship To |
Total: 7 level(s)

See Also

Dimension [CUSTOMER]


Level: TOTAL_CUSTOMER in CUSTOMER

Properties

ID: | CUSTOMER.TOTAL_CUSTOMER.LEVEL
Name: | TOTAL_CUSTOMER
Long Name: | AMERICAN::Total Customer
Short Name: | AMERICAN::Total Customer
Plural Name: | AMERICAN::Total Customer
Dimensioned: |

See Also

List of levels


Level: REGION in CUSTOMER

Properties

ID: | CUSTOMER.REGION.LEVEL
Name: | REGION
Long Name: | AMERICAN::Region
Short Name: | AMERICAN::Region
Plural Name: | AMERICAN::Region
Dimensioned: |

See Also

List of levels


Level: WAREHOUSE in CUSTOMER

Properties

ID: | CUSTOMER.WAREHOUSE.LEVEL
Name: | WAREHOUSE
Long Name: | AMERICAN::Warehouse
Short Name: | AMERICAN::Warehouse
Plural Name: | AMERICAN::Warehouse
Dimensioned: |

See Also

List of levels


Level: TOTAL_MARKET in CUSTOMER

Properties

ID: | CUSTOMER.TOTAL_MARKET.LEVEL
Name: | TOTAL_MARKET
Long Name: | AMERICAN::Total Market
Short Name: | AMERICAN::Total Market
Plural Name: | AMERICAN::Total Market
Dimensioned: |

See Also

List of levels


Level: MARKET_SEGMENT in CUSTOMER

Properties

ID: | CUSTOMER.MARKET_SEGMENT.LEVEL
Name: | MARKET_SEGMENT
Long Name: | AMERICAN::Market Segment
Short Name: | AMERICAN::Market Segment
Plural Name: | AMERICAN::Market Segment
Dimensioned: |

See Also

List of levels


Level: ACCOUNT in CUSTOMER

Properties

ID: | CUSTOMER.ACCOUNT.LEVEL
Name: | ACCOUNT
Long Name: | AMERICAN::Account
Short Name: | AMERICAN::Account
Plural Name: | AMERICAN::Account
Dimensioned: |

See Also

List of levels


Level: SHIP_TO in CUSTOMER

Properties

ID: | CUSTOMER.SHIP_TO.LEVEL
Name: | SHIP_TO
Long Name: | AMERICAN::Ship To
Short Name: | AMERICAN::Ship To
Plural Name: | AMERICAN::Ship To
Dimensioned: |

See Also

List of levels


List of hierarchies

Hierarchies

Name | Long Name | Default | Type
SHIPMENTS | AMERICAN::Shipments |  | LEVEL
MARKET_SEGMENT | AMERICAN::Market Segment |  | LEVEL
Total: 2 hierarchy(s)

See Also

Dimension [CUSTOMER]


Hierarchy: SHIPMENTS in CUSTOMER

Properties

ID: | CUSTOMER.SHIPMENTS.HIERARCHY
Name: | SHIPMENTS
LongName: | AMERICAN::Shipments
ShortName: | AMERICAN::Shipments
PluralName: | AMERICAN::Shipments
Default: |
Type: | LEVEL

Levels

Name | Short Name | SourceColumn | ParentColumn
TOTAL_CUSTOMER | AMERICAN::HLA1 | GLOBAL.CUSTOMER_VIEW.TOTAL_CUSTOMER_ID |
REGION | AMERICAN::HLA2 | GLOBAL.CUSTOMER_VIEW.REGION_ID | GLOBAL.CUSTOMER_VIEW.TOTAL_CUSTOMER_ID
WAREHOUSE | AMERICAN::HLA3 | GLOBAL.CUSTOMER_VIEW.WAREHOUSE_ID | GLOBAL.CUSTOMER_VIEW.REGION_ID
SHIP_TO | AMERICAN::HLA4 | GLOBAL.CUSTOMER_VIEW.SHIP_TO_ID | GLOBAL.CUSTOMER_VIEW.WAREHOUSE_ID
Total: 4 level(s)

See Also

List of hierarchies


List of levels

Level

Name | Short Name | SourceColumn | ParentColumn
TOTAL_CUSTOMER | AMERICAN::HLA1 | GLOBAL.CUSTOMER_VIEW.TOTAL_CUSTOMER_ID |
REGION | AMERICAN::HLA2 | GLOBAL.CUSTOMER_VIEW.REGION_ID | GLOBAL.CUSTOMER_VIEW.TOTAL_CUSTOMER_ID
WAREHOUSE | AMERICAN::HLA3 | GLOBAL.CUSTOMER_VIEW.WAREHOUSE_ID | GLOBAL.CUSTOMER_VIEW.REGION_ID
SHIP_TO | AMERICAN::HLA4 | GLOBAL.CUSTOMER_VIEW.SHIP_TO_ID | GLOBAL.CUSTOMER_VIEW.WAREHOUSE_ID
Total: 4 attribute(s)

See Also

Hierarchy [SHIPMENTS]


Level: TOTAL_CUSTOMER in SHIPMENTS

Properties

Name: | TOTAL_CUSTOMER
LongName: | AMERICAN::HLA1
Short Name: | AMERICAN::HLA1
Plural Name: | AMERICAN::HLA1
SourceColumn: | GLOBAL.CUSTOMER_VIEW.TOTAL_CUSTOMER_ID
ParentColumn: |

See Also

List of levels


Level: REGION in SHIPMENTS

Properties

Name: | REGION
LongName: | AMERICAN::HLA2
Short Name: | AMERICAN::HLA2
Plural Name: | AMERICAN::HLA2
SourceColumn: | GLOBAL.CUSTOMER_VIEW.REGION_ID
ParentColumn: | GLOBAL.CUSTOMER_VIEW.TOTAL_CUSTOMER_ID

See Also

List of levels


Level: WAREHOUSE in SHIPMENTS

Properties

Name: | WAREHOUSE
LongName: | AMERICAN::HLA3
Short Name: | AMERICAN::HLA3
Plural Name: | AMERICAN::HLA3
SourceColumn: | GLOBAL.CUSTOMER_VIEW.WAREHOUSE_ID
ParentColumn: | GLOBAL.CUSTOMER_VIEW.REGION_ID

See Also

List of levels


Level: SHIP_TO in SHIPMENTS

Properties

Name: | SHIP_TO
LongName: | AMERICAN::HLA4
Short Name: | AMERICAN::HLA4
Plural Name: | AMERICAN::HLA4
SourceColumn: | GLOBAL.CUSTOMER_VIEW.SHIP_TO_ID
ParentColumn: | GLOBAL.CUSTOMER_VIEW.WAREHOUSE_ID

See Also

List of levels


Hierarchy: MARKET_SEGMENT in CUSTOMER

Properties

ID: | CUSTOMER.MARKET_SEGMENT.HIERARCHY
Name: | MARKET_SEGMENT
LongName: | AMERICAN::Market Segment
ShortName: | AMERICAN::Market Segment
PluralName: | AMERICAN::Market Segment
Default: |
Type: | LEVEL

Levels

Name | Short Name | SourceColumn | ParentColumn
TOTAL_MARKET | AMERICAN::HLA1 | GLOBAL.CUSTOMER_VIEW.TOTAL_MARKET_ID |
MARKET_SEGMENT | AMERICAN::HLA2 | GLOBAL.CUSTOMER_VIEW.MARKET_SEGMENT_ID | GLOBAL.CUSTOMER_VIEW.TOTAL_MARKET_ID
ACCOUNT | AMERICAN::HLA3 | GLOBAL.CUSTOMER_VIEW.ACCOUNT_ID | GLOBAL.CUSTOMER_VIEW.MARKET_SEGMENT_ID
SHIP_TO | AMERICAN::HLA4 | GLOBAL.CUSTOMER_VIEW.SHIP_TO_ID | GLOBAL.CUSTOMER_VIEW.ACCOUNT_ID
Total: 4 level(s)

See Also

List of hierarchies


List of levels

Level

Name | Short Name | SourceColumn | ParentColumn
TOTAL_MARKET | AMERICAN::HLA1 | GLOBAL.CUSTOMER_VIEW.TOTAL_MARKET_ID |
MARKET_SEGMENT | AMERICAN::HLA2 | GLOBAL.CUSTOMER_VIEW.MARKET_SEGMENT_ID | GLOBAL.CUSTOMER_VIEW.TOTAL_MARKET_ID
ACCOUNT | AMERICAN::HLA3 | GLOBAL.CUSTOMER_VIEW.ACCOUNT_ID | GLOBAL.CUSTOMER_VIEW.MARKET_SEGMENT_ID
SHIP_TO | AMERICAN::HLA4 | GLOBAL.CUSTOMER_VIEW.SHIP_TO_ID | GLOBAL.CUSTOMER_VIEW.ACCOUNT_ID
Total: 4 attribute(s)

See Also

Hierarchy [MARKET_SEGMENT]


Level: TOTAL_MARKET in MARKET_SEGMENT

Properties

Name: | TOTAL_MARKET
LongName: | AMERICAN::HLA1
Short Name: | AMERICAN::HLA1
Plural Name: | AMERICAN::HLA1
SourceColumn: | GLOBAL.CUSTOMER_VIEW.TOTAL_MARKET_ID
ParentColumn: |

See Also

List of levels


Level: MARKET_SEGMENT in MARKET_SEGMENT

Properties

Name: | MARKET_SEGMENT
LongName: | AMERICAN::HLA2
Short Name: | AMERICAN::HLA2
Plural Name: | AMERICAN::HLA2
SourceColumn: | GLOBAL.CUSTOMER_VIEW.MARKET_SEGMENT_ID
ParentColumn: | GLOBAL.CUSTOMER_VIEW.TOTAL_MARKET_ID

See Also

List of levels


Level: ACCOUNT in MARKET_SEGMENT

Properties

Name: | ACCOUNT
LongName: | AMERICAN::HLA3
Short Name: | AMERICAN::HLA3
Plural Name: | AMERICAN::HLA3
SourceColumn: | GLOBAL.CUSTOMER_VIEW.ACCOUNT_ID
ParentColumn: | GLOBAL.CUSTOMER_VIEW.MARKET_SEGMENT_ID

See Also

List of levels


Level: SHIP_TO in MARKET_SEGMENT

Properties

Name: | SHIP_TO
LongName: | AMERICAN::HLA4
Short Name: | AMERICAN::HLA4
Plural Name: | AMERICAN::HLA4
SourceColumn: | GLOBAL.CUSTOMER_VIEW.SHIP_TO_ID
ParentColumn: | GLOBAL.CUSTOMER_VIEW.ACCOUNT_ID

See Also

List of levels


List of attributes

Attributes

Name | Short Name | DataType | MultiLingual
LONG_DESCRIPTION | AMERICAN::Long Description | TEXT |
SHORT_DESCRIPTION | AMERICAN::Short Description | TEXT |
Total: 2 attribute(s)

See Also

Dimension [CUSTOMER]


Attribute: LONG_DESCRIPTION in CUSTOMER

Properties

ID: | CUSTOMER.LONG_DESCRIPTION.ATTRIBUTE
Name: | LONG_DESCRIPTION
Long Name: | AMERICAN::Long Description
Short Name: | AMERICAN::Long Description
Plural Name: | AMERICAN::Long Descriptions
DataType: | TEXT
Classification: | MEMBER_LONG_DESCRIPTION
DefaultOrder: |
MultiLingual: |

Mappings

Language | Hierarchy | Level | Column
AMERICAN | SHIPMENTS | TOTAL_CUSTOMER | GLOBAL.CUSTOMER_VIEW.TOTAL_CUSTOMER_DSC
AMERICAN | SHIPMENTS | REGION | GLOBAL.CUSTOMER_VIEW.REGION_DSC
AMERICAN | SHIPMENTS | WAREHOUSE | GLOBAL.CUSTOMER_VIEW.WAREHOUSE_DSC
AMERICAN | SHIPMENTS | SHIP_TO | GLOBAL.CUSTOMER_VIEW.SHIP_TO_DSC
AMERICAN | MARKET_SEGMENT | TOTAL_MARKET | GLOBAL.CUSTOMER_VIEW.TOTAL_MARKET_DSC
AMERICAN | MARKET_SEGMENT | MARKET_SEGMENT | GLOBAL.CUSTOMER_VIEW.MARKET_SEGMENT_DSC
AMERICAN | MARKET_SEGMENT | ACCOUNT | GLOBAL.CUSTOMER_VIEW.ACCOUNT_DSC
AMERICAN | MARKET_SEGMENT | SHIP_TO | GLOBAL.CUSTOMER_VIEW.SHIP_TO_DSC
Total: 8 mappings(s)

Applied to levels

Hierarchy | Level | DefaultOrder | Install As Relation
SHIPMENTS | TOTAL_CUSTOMER |  |
SHIPMENTS | REGION |  |
SHIPMENTS | WAREHOUSE |  |
SHIPMENTS | SHIP_TO |  |
MARKET_SEGMENT | TOTAL_MARKET |  |
MARKET_SEGMENT | MARKET_SEGMENT |  |
MARKET_SEGMENT | ACCOUNT |  |
MARKET_SEGMENT | SHIP_TO |  |
Total: 8 levels(s)

See Also

List of dimension attributes


Attribute: SHORT_DESCRIPTION in CUSTOMER

Properties

ID: | CUSTOMER.SHORT_DESCRIPTION.ATTRIBUTE
Name: | SHORT_DESCRIPTION
Long Name: | AMERICAN::Short Description
Short Name: | AMERICAN::Short Description
Plural Name: | AMERICAN::Short Descriptions
DataType: | TEXT
Classification: | MEMBER_SHORT_DESCRIPTION
DefaultOrder: |
MultiLingual: |

Mappings

Language | Hierarchy | Level | Column
AMERICAN | SHIPMENTS | TOTAL_CUSTOMER | GLOBAL.CUSTOMER_VIEW.TOTAL_CUSTOMER_DSC
AMERICAN | SHIPMENTS | REGION | GLOBAL.CUSTOMER_VIEW.REGION_DSC
AMERICAN | SHIPMENTS | WAREHOUSE | GLOBAL.CUSTOMER_VIEW.WAREHOUSE_DSC
AMERICAN | SHIPMENTS | SHIP_TO | GLOBAL.CUSTOMER_VIEW.SHIP_TO_DSC
AMERICAN | MARKET_SEGMENT | TOTAL_MARKET | GLOBAL.CUSTOMER_VIEW.TOTAL_MARKET_DSC
AMERICAN | MARKET_SEGMENT | MARKET_SEGMENT | GLOBAL.CUSTOMER_VIEW.MARKET_SEGMENT_DSC
AMERICAN | MARKET_SEGMENT | ACCOUNT | GLOBAL.CUSTOMER_VIEW.ACCOUNT_DSC
AMERICAN | MARKET_SEGMENT | SHIP_TO | GLOBAL.CUSTOMER_VIEW.SHIP_TO_DSC
Total: 8 mappings(s)

Applied to levels

Hierarchy | Level | DefaultOrder | Install As Relation
SHIPMENTS | TOTAL_CUSTOMER |  |
SHIPMENTS | REGION |  |
SHIPMENTS | WAREHOUSE |  |
SHIPMENTS | SHIP_TO |  |
MARKET_SEGMENT | TOTAL_MARKET |  |
MARKET_SEGMENT | MARKET_SEGMENT |  |
MARKET_SEGMENT | ACCOUNT |  |
MARKET_SEGMENT | SHIP_TO |  |
Total: 8 levels(s)

See Also

List of dimension attributes


Dimension: PRODUCT

Properties

ID: | PRODUCT.DIMENSION
Name: | PRODUCT
Long Name: | AMERICAN::Product
Short Name: | AMERICAN::Product
Plural Name: | AMERICAN::Product
Schema: | GLOBAL
Time: |
Use Native Key: |

Levels

Name | Short Name | Dimensioned
TOTAL_PRODUCT | AMERICAN::Total Product |
CLASS | AMERICAN::Class |
FAMILY | AMERICAN::Family |
ITEM | AMERICAN::Item |
Total: 4 level(s)

Hierarchies

Name | Long Name | Default | Type
PRIMARY | AMERICAN::Primary |  | LEVEL
Total: 1 hierarchy(s)

Attributes

Name | Short Name | DataType
LONG_DESCRIPTION | AMERICAN::Long Description | TEXT
SHORT_DESCRIPTION | AMERICAN::Short Description | TEXT
ISVISIBLE | AMERICAN::Isvisible | BOOLEAN
PACKAGE | AMERICAN::Package | TEXT
BUYER | AMERICAN::Buyer | TEXT
MARKETING_MANAGER | AMERICAN::Marketing Manager | TEXT
Total: 6 attribute(s)

See Also

List of dimensions


List of levels

Levels

Name | Short Name | Dimensioned
TOTAL_PRODUCT | AMERICAN::Total Product |
CLASS | AMERICAN::Class |
FAMILY | AMERICAN::Family |
ITEM | AMERICAN::Item |
Total: 4 level(s)

See Also

Dimension [PRODUCT]


Level: TOTAL_PRODUCT in PRODUCT

Properties

ID: | PRODUCT.TOTAL_PRODUCT.LEVEL
Name: | TOTAL_PRODUCT
Long Name: | AMERICAN::Total Product
Short Name: | AMERICAN::Total Product
Plural Name: | AMERICAN::Total Product
Dimensioned: |

See Also

List of levels


Level: CLASS in PRODUCT

Properties

ID: | PRODUCT.CLASS.LEVEL
Name: | CLASS
Long Name: | AMERICAN::Class
Short Name: | AMERICAN::Class
Plural Name: | AMERICAN::Class
Dimensioned: |

See Also

List of levels


Level: FAMILY in PRODUCT

Properties

ID: | PRODUCT.FAMILY.LEVEL
Name: | FAMILY
Long Name: | AMERICAN::Family
Short Name: | AMERICAN::Family
Plural Name: | AMERICAN::Family
Dimensioned: |

See Also

List of levels


Level: ITEM in PRODUCT

Properties

ID: | PRODUCT.ITEM.LEVEL
Name: | ITEM
Long Name: | AMERICAN::Item
Short Name: | AMERICAN::Item
Plural Name: | AMERICAN::Item
Dimensioned: |

See Also

List of levels


List of hierarchies

Hierarchies

Name | Long Name | Default | Type
PRIMARY | AMERICAN::Primary |  | LEVEL
Total: 1 hierarchy(s)

See Also

Dimension [PRODUCT]


Hierarchy: PRIMARY in PRODUCT

Properties

ID: | PRODUCT.PRIMARY.HIERARCHY
Name: | PRIMARY
LongName: | AMERICAN::Primary
ShortName: | AMERICAN::Primary
PluralName: | AMERICAN::Primary
Default: |
Type: | LEVEL

Levels

Name | Short Name | SourceColumn | ParentColumn
TOTAL_PRODUCT | AMERICAN::HLA1 | GLOBAL.PRODUCT_VIEW.TOTAL_PRODUCT_ID |
CLASS | AMERICAN::HLA2 | GLOBAL.PRODUCT_VIEW.CLASS_ID | GLOBAL.PRODUCT_VIEW.TOTAL_PRODUCT_ID
FAMILY | AMERICAN::HLA3 | GLOBAL.PRODUCT_VIEW.FAMILY_ID | GLOBAL.PRODUCT_VIEW.CLASS_ID
ITEM | AMERICAN::HLA4 | GLOBAL.PRODUCT_VIEW.ITEM_ID | GLOBAL.PRODUCT_VIEW.FAMILY_ID
Total: 4 level(s)

See Also

List of hierarchies


List of levels

Level

Name | Short Name | SourceColumn | ParentColumn
TOTAL_PRODUCT | AMERICAN::HLA1 | GLOBAL.PRODUCT_VIEW.TOTAL_PRODUCT_ID |
CLASS | AMERICAN::HLA2 | GLOBAL.PRODUCT_VIEW.CLASS_ID | GLOBAL.PRODUCT_VIEW.TOTAL_PRODUCT_ID
FAMILY | AMERICAN::HLA3 | GLOBAL.PRODUCT_VIEW.FAMILY_ID | GLOBAL.PRODUCT_VIEW.CLASS_ID
ITEM | AMERICAN::HLA4 | GLOBAL.PRODUCT_VIEW.ITEM_ID | GLOBAL.PRODUCT_VIEW.FAMILY_ID
Total: 4 attribute(s)

See Also

Hierarchy [PRIMARY]


Level: TOTAL_PRODUCT in PRIMARY

Properties

Name: | TOTAL_PRODUCT
LongName: | AMERICAN::HLA1
Short Name: | AMERICAN::HLA1
Plural Name: | AMERICAN::HLA1
SourceColumn: | GLOBAL.PRODUCT_VIEW.TOTAL_PRODUCT_ID
ParentColumn: |

See Also

List of levels


Level: CLASS in PRIMARY

Properties

Name: | CLASS
LongName: | AMERICAN::HLA2
Short Name: | AMERICAN::HLA2
Plural Name: | AMERICAN::HLA2
SourceColumn: | GLOBAL.PRODUCT_VIEW.CLASS_ID
ParentColumn: | GLOBAL.PRODUCT_VIEW.TOTAL_PRODUCT_ID

See Also

List of levels


Level: FAMILY in PRIMARY

Properties

Name: | FAMILY
LongName: | AMERICAN::HLA3
Short Name: | AMERICAN::HLA3
Plural Name: | AMERICAN::HLA3
SourceColumn: | GLOBAL.PRODUCT_VIEW.FAMILY_ID
ParentColumn: | GLOBAL.PRODUCT_VIEW.CLASS_ID

See Also

List of levels


Level: ITEM in PRIMARY

Properties

Name: | ITEM
LongName: | AMERICAN::HLA4
Short Name: | AMERICAN::HLA4
Plural Name: | AMERICAN::HLA4
SourceColumn: | GLOBAL.PRODUCT_VIEW.ITEM_ID
ParentColumn: | GLOBAL.PRODUCT_VIEW.FAMILY_ID

See Also

List of levels


List of attributes

Attributes

Name | Short Name | DataType | MultiLingual
LONG_DESCRIPTION | AMERICAN::Long Description | TEXT |
SHORT_DESCRIPTION | AMERICAN::Short Description | TEXT |
ISVISIBLE | AMERICAN::Isvisible | BOOLEAN |
PACKAGE | AMERICAN::Package | TEXT |
BUYER | AMERICAN::Buyer | TEXT |
MARKETING_MANAGER | AMERICAN::Marketing Manager | TEXT |
Total: 6 attribute(s)

See Also

Dimension [PRODUCT]


Attribute: LONG_DESCRIPTION in PRODUCT

Properties

ID: | PRODUCT.LONG_DESCRIPTION.ATTRIBUTE
Name: | LONG_DESCRIPTION
Long Name: | AMERICAN::Long Description
Short Name: | AMERICAN::Long Description
Plural Name: | AMERICAN::Long Descriptions
DataType: | TEXT
Classification: | MEMBER_LONG_DESCRIPTION
DefaultOrder: |
MultiLingual: |

Mappings

Language | Hierarchy | Level | Column
AMERICAN | PRIMARY | TOTAL_PRODUCT | GLOBAL.PRODUCT_VIEW.TOTAL_PRODUCT_DSC
AMERICAN | PRIMARY | CLASS | GLOBAL.PRODUCT_VIEW.CLASS_DSC
AMERICAN | PRIMARY | FAMILY | GLOBAL.PRODUCT_VIEW.FAMILY_DSC
AMERICAN | PRIMARY | ITEM | GLOBAL.PRODUCT_VIEW.ITEM_DSC
Total: 4 mappings(s)

Applied to levels

Hierarchy | Level | DefaultOrder | Install As Relation
PRIMARY | TOTAL_PRODUCT |  |
PRIMARY | CLASS |  |
PRIMARY | FAMILY |  |
PRIMARY | ITEM |  |
Total: 4 levels(s)

See Also

List of dimension attributes


Attribute: SHORT_DESCRIPTION in PRODUCT

Properties

ID: | PRODUCT.SHORT_DESCRIPTION.ATTRIBUTE
Name: | SHORT_DESCRIPTION
Long Name: | AMERICAN::Short Description
Short Name: | AMERICAN::Short Description
Plural Name: | AMERICAN::Short Descriptions
DataType: | TEXT
Classification: | MEMBER_SHORT_DESCRIPTION
DefaultOrder: |
MultiLingual: |

Mappings

Language | Hierarchy | Level | Column
AMERICAN | PRIMARY | TOTAL_PRODUCT | GLOBAL.PRODUCT_VIEW.TOTAL_PRODUCT_DSC
AMERICAN | PRIMARY | CLASS | GLOBAL.PRODUCT_VIEW.CLASS_DSC
AMERICAN | PRIMARY | FAMILY | GLOBAL.PRODUCT_VIEW.FAMILY_DSC
AMERICAN | PRIMARY | ITEM | GLOBAL.PRODUCT_VIEW.ITEM_DSC
Total: 4 mappings(s)

Applied to levels

Hierarchy | Level | DefaultOrder | Install As Relation
PRIMARY | TOTAL_PRODUCT |  |
PRIMARY | CLASS |  |
PRIMARY | FAMILY |  |
PRIMARY | ITEM |  |
Total: 4 levels(s)

See Also

List of dimension attributes


Attribute: ISVISIBLE in PRODUCT

Properties

ID: | PRODUCT.ISVISIBLE.ATTRIBUTE
Name: | ISVISIBLE
Long Name: | AMERICAN::Isvisible
Short Name: | AMERICAN::Isvisible
Plural Name: | AMERICAN::Isvisible
DataType: | BOOLEAN
Classification: | USER
DefaultOrder: |
MultiLingual: |

Applied to levels

Hierarchy | Level | DefaultOrder | Install As Relation
PRIMARY | TOTAL_PRODUCT |  |
PRIMARY | CLASS |  |
PRIMARY | FAMILY |  |
PRIMARY | ITEM |  |
Total: 4 levels(s)

See Also

List of dimension attributes


Attribute: PACKAGE in PRODUCT

Properties

ID: | PRODUCT.PACKAGE.ATTRIBUTE
Name: | PACKAGE
Long Name: | AMERICAN::Package
Short Name: | AMERICAN::Package
Plural Name: | AMERICAN::Package
DataType: | TEXT
Classification: | USER
DefaultOrder: |
MultiLingual: |

Mappings

Language | Hierarchy | Level | Column
AMERICAN | PRIMARY | ITEM | GLOBAL.PRODUCT_VIEW.ITEM_PACKAGE
Total: 1 mappings(s)

Applied to levels

Hierarchy | Level | DefaultOrder | Install As Relation
PRIMARY | ITEM |  |
Total: 1 levels(s)

See Also

List of dimension attributes


Attribute: BUYER in PRODUCT

Properties

ID: | PRODUCT.BUYER.ATTRIBUTE
Name: | BUYER
Long Name: | AMERICAN::Buyer
Short Name: | AMERICAN::Buyer
Plural Name: | AMERICAN::Buyer
DataType: | TEXT
Classification: | USER
DefaultOrder: |
MultiLingual: |

Mappings

Language | Hierarchy | Level | Column
AMERICAN | PRIMARY | ITEM | GLOBAL.PRODUCT_VIEW.ITEM_BUYER
Total: 1 mappings(s)

Applied to levels

Hierarchy | Level | DefaultOrder | Install As Relation
PRIMARY | ITEM |  |
Total: 1 levels(s)

See Also

List of dimension attributes


Attribute: MARKETING_MANAGER in PRODUCT

Properties

ID: | PRODUCT.MARKETING_MANAGER.ATTRIBUTE
Name: | MARKETING_MANAGER
Long Name: | AMERICAN::Marketing Manager
Short Name: | AMERICAN::Marketing Manager
Plural Name: | AMERICAN::Marketing Manager
DataType: | TEXT
Classification: | USER
DefaultOrder: |
MultiLingual: |

Mappings

Language | Hierarchy | Level | Column
AMERICAN | PRIMARY | ITEM | GLOBAL.PRODUCT_VIEW.ITEM_MARKETING_MANAGER
Total: 1 mappings(s)

Applied to levels

Hierarchy | Level | DefaultOrder | Install As Relation
PRIMARY | ITEM |  |
Total: 1 levels(s)

See Also

List of dimension attributes


List of cubes

Cubes

Name | ShortName | SparseType | DefaultDataType | UseGlobalIndex | AutoSolve
UNITS_CUBE | AMERICAN::Units Cube | STANDARD | DECIMAL |  |
Total: 1 cube(s)

See Also

Workspace [GLOBAL]


Cube: UNITS_CUBE

Properties

ID: | UNITS_CUBE.CUBE
Name: | UNITS_CUBE
LongName: | AMERICAN::Units Cube
ShortName: | AMERICAN::Units Cube
Schema: | GLOBAL
SparseType: | STANDARD
DefaultDataType: | DECIMAL
UseGlobalIndex: |
AutoSolve: |

Dimensions

Name
TIME
CUSTOMER
PRODUCT
CHANNEL
Total: 4 dimension(s)

Dimension mappings

Dimension | Level | Column
TIME | MONTH | GLOBAL.SALES_FACT.MONTH_ID
CHANNEL | CHANNEL | GLOBAL.SALES_FACT.CHANNEL_ID
CUSTOMER | SHIP_TO | GLOBAL.SALES_FACT.SHIP_TO_ID
PRODUCT | ITEM | GLOBAL.SALES_FACT.ITEM_ID
Total: 4 mappings(s)

Measures

Name | Short Name | SourceColumn | DataType | AutoSolve
UNITS | AMERICAN::Units | GLOBAL.SALES_FACT.UNITS | INTEGER | DEFAULT
SALES | AMERICAN::Sales | GLOBAL.SALES_FACT.SALES | DECIMAL | DEFAULT
COST | AMERICAN::Cost | GLOBAL.SALES_FACT.COST | DECIMAL | DEFAULT
Total: 3 measures(s)

Derived measures

Name | Short Name | DataType | AutoSolve
PROFIT | AMERICAN::Profit | Decimal | DEFAULT
HOW_IS_MARGIN | AMERICAN::How Is Margin | TEXT | DEFAULT
Total: 2 derived measures(s)

Olap measures

Name | Short Name | DataType | AutoSolve
SALES_PP | AMERICAN::Sales Prior Period | Decimal | DEFAULT
SALES_CHG_PP | AMERICAN::Sales Change Prior Period | Decimal | DEFAULT
SALES_PCT_CHG_PP | AMERICAN::Sales % Chg Prior Period | Decimal | DEFAULT
SALES_PY | AMERICAN::Sales Prior Year | Decimal | DEFAULT
SALES_CHG_PY | AMERICAN::Sales Change Prior Year | Decimal | DEFAULT
SALES_PCT_CHG_PY | AMERICAN::Sales % Chg Prior Year | Decimal | DEFAULT
SALES_YTD | AMERICAN::Sales YTD | Decimal | DEFAULT
SALES_YTD_PY | AMERICAN::Sales YTD Prior Year | Decimal | DEFAULT
SALES_YTD_CHG_PY | AMERICAN::Sales YTD Chg Prior Year | Decimal | DEFAULT
SALES_YTD_PCT_CHG_PY | AMERICAN::Sales YTD % Chg Prior Year | Decimal | DEFAULT
SALES_PROD_PRNT_SHARE | AMERICAN::Sales Share of Prod Parent | Decimal | DEFAULT
SALES_PROD_TOT_SHARE | AMERICAN::Sales Share of Total Product | Decimal | DEFAULT
SALES_3_PER_MOVAVG | AMERICAN::Sales 3 Period Moving Avg | Decimal | DEFAULT
PROFIT_PP | AMERICAN::Profit Prior Period | Decimal | DEFAULT
PROFIT_CHG_PP | AMERICAN::Profit Change Prior Period | Decimal | DEFAULT
PROFIT_PCT_CHG_PP | AMERICAN::Profit % Chg Prior Period | Decimal | DEFAULT
PROFIT_PY | AMERICAN::Profit Prior Year | Decimal | DEFAULT
PROFIT_CHG_PY | AMERICAN::Profit Change Prior Year | Decimal | DEFAULT
PROFIT_PCT_CHG_PY | AMERICAN::Profit % Chg Prior Year | Decimal | DEFAULT
PROFIT_YTD | AMERICAN::Profit YTD | Decimal | DEFAULT
PROFIT_YTD_PY | AMERICAN::Profit YTD Prior Year | Decimal | DEFAULT
PROFIT_YTD_CHG_PY | AMERICAN::Profit YTD Chg Prior Year | Decimal | DEFAULT
PROFIT_YTD_PCT_CHG_PY | AMERICAN::Profit YTD % Chg Prior Year | Decimal | DEFAULT
PROFIT_PROD_PRNT_SHARE | AMERICAN::Profit Share of Prod Parent | Decimal | DEFAULT
PROFIT_PROD_TOT_SHARE | AMERICAN::Profit Share of Total Product | Decimal | DEFAULT
PROFIT_3_PER_MOVAVG | AMERICAN::Profit 3 Period Moving Avg | Decimal | DEFAULT
Total: 26 olap measures(s)

Olap aggregations

Order | Dimension | Level | Type | Operator | Expression
1 | TIME | YEAR | INCLUDE | SUM |
1 | TIME | MONTH | INCLUDE | SUM |
2 | CUSTOMER | REGION | INCLUDE | SUM |
2 | CUSTOMER | MARKET_SEGMENT | INCLUDE | SUM |
2 | CUSTOMER | SHIP_TO | INCLUDE | SUM |
3 | PRODUCT | CLASS | INCLUDE | SUM |
3 | PRODUCT | ITEM | INCLUDE | SUM |
4 | CHANNEL | CHANNEL | INCLUDE | SUM |
Total: 8 aggreagtions(s)

See Also

List of cubes


List of measures

Measures

Name | Short Name | SourceColumn | DataType | AutoSolve
UNITS | AMERICAN::Units | GLOBAL.SALES_FACT.UNITS | INTEGER | DEFAULT
SALES | AMERICAN::Sales | GLOBAL.SALES_FACT.SALES | DECIMAL | DEFAULT
COST | AMERICAN::Cost | GLOBAL.SALES_FACT.COST | DECIMAL | DEFAULT
Total: 3 measure(s)

See Also

Cube [UNITS_CUBE]


Measure: UNITS

Properties

ID: | UNITS_CUBE.UNITS.MEASURE
Name: | UNITS
Long Name: | AMERICAN::Units
Short Name: | AMERICAN::Units
Plural Name: | AMERICAN::Units
DataType: | INTEGER
Internal: |
Force Calc: |
Force Order: |
Sparse Type: | STANDARD
Use Global Index: |
AutoSolve: | DEFAULT
SourceColumn: | GLOBAL.SALES_FACT.UNITS

See Also

List of measures


Measure: SALES

Properties

ID: | UNITS_CUBE.SALES.MEASURE
Name: | SALES
Long Name: | AMERICAN::Sales
Short Name: | AMERICAN::Sales
Plural Name: | AMERICAN::Sales
DataType: | DECIMAL
Internal: |
Force Calc: |
Force Order: |
Sparse Type: | STANDARD
Use Global Index: |
AutoSolve: | DEFAULT
SourceColumn: | GLOBAL.SALES_FACT.SALES

See Also

List of measures


Measure: COST

Properties

ID: | UNITS_CUBE.COST.MEASURE
Name: | COST
Long Name: | AMERICAN::Cost
Short Name: | AMERICAN::Cost
Plural Name: | AMERICAN::Cost
DataType: | DECIMAL
Internal: |
Force Calc: |
Force Order: |
Sparse Type: | STANDARD
Use Global Index: |
AutoSolve: | DEFAULT
SourceColumn: | GLOBAL.SALES_FACT.COST

See Also

List of measures


List of derived measures

Measures

Name | Short Name | DataType | AutoSolve
PROFIT | AMERICAN::Profit | Decimal | DEFAULT
HOW_IS_MARGIN | AMERICAN::How Is Margin | TEXT | DEFAULT
Total: 2 derived measure(s)

See Also

Cube [UNITS_CUBE]


Derived measure: PROFIT

Properties

ID: | UNITS_CUBE.PROFIT.MEASURE
Name: | PROFIT
Long Name: | AMERICAN::Profit
Short Name: | AMERICAN::Profit
Plural Name: | AMERICAN::PROFIT
DataType: | Decimal
Internal: |
Force Calc: |
Force Order: |
Sparse Type: | STANDARD
Use Global Index: |
AutoSolve: | DEFAULT
IsValid: |
ExpressionText: | UNITS_CUBE.SALES.MEASURE - UNITS_CUBE.COST.MEASURE

See Also

List of derived measures


Derived measure: HOW_IS_MARGIN

Properties

ID: | UNITS_CUBE.HOW_IS_MARGIN.MEASURE
Name: | HOW_IS_MARGIN
Long Name: | AMERICAN::How Is Margin
Short Name: | AMERICAN::How Is Margin
Plural Name: | AMERICAN::HOW_IS_MARGIN
DataType: | TEXT
Internal: |
Force Calc: |
Force Order: |
Sparse Type: | STANDARD
Use Global Index: |
AutoSolve: | DEFAULT
IsValid: |
ExpressionText: | if UNITS_CUBE.PROFIT.MEASURE/UNITS_CUBE.SALES.MEASURE gt .2 then 'GROOVY' else if UNITS_CUBE.PROFIT.MEASURE/UNITS_CUBE.SALES.MEASURE lt .1 then 'YIPES' else 'WHATEVER'

See Also

List of derived measures


List of derived measures

Measures

Name | Short Name | DataType | AutoSolve
SALES_PP | AMERICAN::Sales Prior Period | Decimal | DEFAULT
SALES_CHG_PP | AMERICAN::Sales Change Prior Period | Decimal | DEFAULT
SALES_PCT_CHG_PP | AMERICAN::Sales % Chg Prior Period | Decimal | DEFAULT
SALES_PY | AMERICAN::Sales Prior Year | Decimal | DEFAULT
SALES_CHG_PY | AMERICAN::Sales Change Prior Year | Decimal | DEFAULT
SALES_PCT_CHG_PY | AMERICAN::Sales % Chg Prior Year | Decimal | DEFAULT
SALES_YTD | AMERICAN::Sales YTD | Decimal | DEFAULT
SALES_YTD_PY | AMERICAN::Sales YTD Prior Year | Decimal | DEFAULT
SALES_YTD_CHG_PY | AMERICAN::Sales YTD Chg Prior Year | Decimal | DEFAULT
SALES_YTD_PCT_CHG_PY | AMERICAN::Sales YTD % Chg Prior Year | Decimal | DEFAULT
SALES_PROD_PRNT_SHARE | AMERICAN::Sales Share of Prod Parent | Decimal | DEFAULT
SALES_PROD_TOT_SHARE | AMERICAN::Sales Share of Total Product | Decimal | DEFAULT
SALES_3_PER_MOVAVG | AMERICAN::Sales 3 Period Moving Avg | Decimal | DEFAULT
PROFIT_PP | AMERICAN::Profit Prior Period | Decimal | DEFAULT
PROFIT_CHG_PP | AMERICAN::Profit Change Prior Period | Decimal | DEFAULT
PROFIT_PCT_CHG_PP | AMERICAN::Profit % Chg Prior Period | Decimal | DEFAULT
PROFIT_PY | AMERICAN::Profit Prior Year | Decimal | DEFAULT
PROFIT_CHG_PY | AMERICAN::Profit Change Prior Year | Decimal | DEFAULT
PROFIT_PCT_CHG_PY | AMERICAN::Profit % Chg Prior Year | Decimal | DEFAULT
PROFIT_YTD | AMERICAN::Profit YTD | Decimal | DEFAULT
PROFIT_YTD_PY | AMERICAN::Profit YTD Prior Year | Decimal | DEFAULT
PROFIT_YTD_CHG_PY | AMERICAN::Profit YTD Chg Prior Year | Decimal | DEFAULT
PROFIT_YTD_PCT_CHG_PY | AMERICAN::Profit YTD % Chg Prior Year | Decimal | DEFAULT
PROFIT_PROD_PRNT_SHARE | AMERICAN::Profit Share of Prod Parent | Decimal | DEFAULT
PROFIT_PROD_TOT_SHARE | AMERICAN::Profit Share of Total Product | Decimal | DEFAULT
PROFIT_3_PER_MOVAVG | AMERICAN::Profit 3 Period Moving Avg | Decimal | DEFAULT
Total: 26 olap measure(s)

See Also

Cube [UNITS_CUBE]


Olap measure: SALES_PP

Properties

ID: | UNITS_CUBE.SALES_PP.MEASURE
Name: | SALES_PP
Long Name: | AMERICAN::Sales Prior Period
Short Name: | AMERICAN::Sales Prior Period
Plural Name: | AMERICAN::SALES_PP
DataType: | Decimal
Internal: |
Force Calc: |
Force Order: |
Sparse Type: | STANDARD
Use Global Index: |
AutoSolve: | DEFAULT
IsValid: |
Operator: | PRIOR_PERIOD

Inputs

KeyWord | Object | ScalarValue
DIMENSION | TIME.DIMENSION |
MEASURE | UNITS_CUBE.SALES.MEASURE |
HIERARCHY | TIME.CALENDAR_YEAR.HIERARCHY |
OFFSET |  | 1
Total: 4 inputs(s)

See Also

List of olap measures


Olap measure: SALES_CHG_PP

Properties

ID: | UNITS_CUBE.SALES_CHG_PP.MEASURE
Name: | SALES_CHG_PP
Long Name: | AMERICAN::Sales Change Prior Period
Short Name: | AMERICAN::Sales Change Prior Period
Plural Name: | AMERICAN::SALES_CHG_PP
DataType: | Decimal
Internal: |
Force Calc: |
Force Order: |
Sparse Type: | STANDARD
Use Global Index: |
AutoSolve: | DEFAULT
IsValid: |
Operator: | PRIOR_PERIOD_VARIANCE

Inputs

KeyWord | Object | ScalarValue
DIMENSION | TIME.DIMENSION |
MEASURE | UNITS_CUBE.SALES.MEASURE |
HIERARCHY | TIME.CALENDAR_YEAR.HIERARCHY |
OFFSET |  | 1
Total: 4 inputs(s)

See Also

List of olap measures


Olap measure: SALES_PCT_CHG_PP

Properties

ID: | UNITS_CUBE.SALES_PCT_CHG_PP.MEASURE
Name: | SALES_PCT_CHG_PP
Long Name: | AMERICAN::Sales % Chg Prior Period
Short Name: | AMERICAN::Sales % Chg Prior Period
Plural Name: | AMERICAN::SALES_PCT_CHG_PP
DataType: | Decimal
Internal: |
Force Calc: |
Force Order: |
Sparse Type: | STANDARD
Use Global Index: |
AutoSolve: | DEFAULT
IsValid: |
Operator: | PRIOR_PERIOD_VARIANCE_PERCENT

Inputs

KeyWord | Object | ScalarValue
DIMENSION | TIME.DIMENSION |
MEASURE | UNITS_CUBE.SALES.MEASURE |
HIERARCHY | TIME.CALENDAR_YEAR.HIERARCHY |
OFFSET |  | 1
Total: 4 inputs(s)

See Also

List of olap measures


Olap measure: SALES_PY

Properties

ID: | UNITS_CUBE.SALES_PY.MEASURE
Name: | SALES_PY
Long Name: | AMERICAN::Sales Prior Year
Short Name: | AMERICAN::Sales Prior Year
Plural Name: | AMERICAN::SALES_PY
DataType: | Decimal
Internal: |
Force Calc: |
Force Order: |
Sparse Type: | STANDARD
Use Global Index: |
AutoSolve: | DEFAULT
IsValid: |
Operator: | SAME_PERIOD_ANCESTORS_AGO

Inputs

KeyWord | Object | ScalarValue
DIMENSION | TIME.DIMENSION |
MEASURE | UNITS_CUBE.SALES.MEASURE |
HIERARCHY | TIME.CALENDAR_YEAR.HIERARCHY |
LEVEL | TIME.YEAR.LEVEL |
OFFSET |  | 1
Total: 5 inputs(s)

See Also

List of olap measures


Olap measure: SALES_CHG_PY

Properties

ID: | UNITS_CUBE.SALES_CHG_PY.MEASURE
Name: | SALES_CHG_PY
Long Name: | AMERICAN::Sales Change Prior Year
Short Name: | AMERICAN::Sales Change Prior Year
Plural Name: | AMERICAN::SALES_CHG_PY
DataType: | Decimal
Internal: |
Force Calc: |
Force Order: |
Sparse Type: | STANDARD
Use Global Index: |
AutoSolve: | DEFAULT
IsValid: |
Operator: | SAME_PERIOD_ANCESTORS_AGO_VARIANCE

Inputs

KeyWord | Object | ScalarValue
DIMENSION | TIME.DIMENSION |
MEASURE | UNITS_CUBE.SALES.MEASURE |
HIERARCHY | TIME.CALENDAR_YEAR.HIERARCHY |
LEVEL | TIME.YEAR.LEVEL |
OFFSET |  | 1
Total: 5 inputs(s)

See Also

List of olap measures


Olap measure: SALES_PCT_CHG_PY

Properties

ID: | UNITS_CUBE.SALES_PCT_CHG_PY.MEASURE
Name: | SALES_PCT_CHG_PY
Long Name: | AMERICAN::Sales % Chg Prior Year
Short Name: | AMERICAN::Sales % Chg Prior Year
Plural Name: | AMERICAN::SALES_PCT_CHG_PY
DataType: | Decimal
Internal: |
Force Calc: |
Force Order: |
Sparse Type: | STANDARD
Use Global Index: |
AutoSolve: | DEFAULT
IsValid: |
Operator: | SAME_PERIOD_ANCESTORS_AGO_VARIANCE_PERCENT

Inputs

KeyWord | Object | ScalarValue
DIMENSION | TIME.DIMENSION |
MEASURE | UNITS_CUBE.SALES.MEASURE |
HIERARCHY | TIME.CALENDAR_YEAR.HIERARCHY |
LEVEL | TIME.YEAR.LEVEL |
OFFSET |  | 1
Total: 5 inputs(s)

See Also

List of olap measures


Olap measure: SALES_YTD

Properties

ID: | UNITS_CUBE.SALES_YTD.MEASURE
Name: | SALES_YTD
Long Name: | AMERICAN::Sales YTD
Short Name: | AMERICAN::Sales YTD
Plural Name: | AMERICAN::SALES_YTD
DataType: | Decimal
Internal: |
Force Calc: |
Force Order: |
Sparse Type: | STANDARD
Use Global Index: |
AutoSolve: | DEFAULT
IsValid: |
Operator: | YEAR_TO_DATE

Inputs

KeyWord | Object | ScalarValue
DIMENSION | TIME.DIMENSION |
MEASURE | UNITS_CUBE.SALES.MEASURE |
Total: 2 inputs(s)

See Also

List of olap measures


Olap measure: SALES_YTD_PY

Properties

ID: | UNITS_CUBE.SALES_YTD_PY.MEASURE
Name: | SALES_YTD_PY
Long Name: | AMERICAN::Sales YTD Prior Year
Short Name: | AMERICAN::Sales YTD Prior Year
Plural Name: | AMERICAN::SALES_YTD_PY
DataType: | Decimal
Internal: |
Force Calc: |
Force Order: |
Sparse Type: | STANDARD
Use Global Index: |
AutoSolve: | DEFAULT
IsValid: |
Operator: | SAME_PERIOD_ANCESTORS_AGO

Inputs

KeyWord | Object | ScalarValue
DIMENSION | TIME.DIMENSION |
MEASURE | UNITS_CUBE.SALES_YTD.MEASURE |
HIERARCHY | TIME.CALENDAR_YEAR.HIERARCHY |
LEVEL | TIME.YEAR.LEVEL |
OFFSET |  | 1
Total: 5 inputs(s)

See Also

List of olap measures


Olap measure: SALES_YTD_CHG_PY

Properties

ID: | UNITS_CUBE.SALES_YTD_CHG_PY.MEASURE
Name: | SALES_YTD_CHG_PY
Long Name: | AMERICAN::Sales YTD Chg Prior Year
Short Name: | AMERICAN::Sales YTD Chg Prior Year
Plural Name: | AMERICAN::SALES_YTD_CHG_PY
DataType: | Decimal
Internal: |
Force Calc: |
Force Order: |
Sparse Type: | STANDARD
Use Global Index: |
AutoSolve: | DEFAULT
IsValid: |
Operator: | SAME_PERIOD_ANCESTORS_AGO_VARIANCE

Inputs

KeyWord | Object | ScalarValue
DIMENSION | TIME.DIMENSION |
MEASURE | UNITS_CUBE.SALES_YTD.MEASURE |
HIERARCHY | TIME.CALENDAR_YEAR.HIERARCHY |
LEVEL | TIME.YEAR.LEVEL |
OFFSET |  | 1
Total: 5 inputs(s)

See Also

List of olap measures


Olap measure: SALES_YTD_PCT_CHG_PY

Properties

ID: | UNITS_CUBE.SALES_YTD_PCT_CHG_PY.MEASURE
Name: | SALES_YTD_PCT_CHG_PY
Long Name: | AMERICAN::Sales YTD % Chg Prior Year
Short Name: | AMERICAN::Sales YTD % Chg Prior Year
Plural Name: | AMERICAN::SALES_YTD_PCT_CHG_PY
DataType: | Decimal
Internal: |
Force Calc: |
Force Order: |
Sparse Type: | STANDARD
Use Global Index: |
AutoSolve: | DEFAULT
IsValid: |
Operator: | SAME_PERIOD_ANCESTORS_AGO_VARIANCE_PERCENT

Inputs

KeyWord | Object | ScalarValue
DIMENSION | TIME.DIMENSION |
MEASURE | UNITS_CUBE.SALES_YTD.MEASURE |
HIERARCHY | TIME.CALENDAR_YEAR.HIERARCHY |
LEVEL | TIME.YEAR.LEVEL |
OFFSET |  | 1
Total: 5 inputs(s)

See Also

List of olap measures


Olap measure: SALES_PROD_PRNT_SHARE

Properties

ID: | UNITS_CUBE.SALES_PROD_PRNT_SHARE.MEASURE
Name: | SALES_PROD_PRNT_SHARE
Long Name: | AMERICAN::Sales Share of Prod Parent
Short Name: | AMERICAN::Sales Share of Prod Parent
Plural Name: | AMERICAN::SALES_PROD_PRNT_SHARE
DataType: | Decimal
Internal: |
Force Calc: |
Force Order: |
Sparse Type: | STANDARD
Use Global Index: |
AutoSolve: | DEFAULT
IsValid: |
Operator: | SHARE_TO_PARENT

Inputs

KeyWord | Object | ScalarValue
DIMENSION | PRODUCT.DIMENSION |
MEASURE | UNITS_CUBE.SALES.MEASURE |
HIERARCHY | PRODUCT.PRIMARY.HIERARCHY |
Total: 3 inputs(s)

See Also

List of olap measures


Olap measure: SALES_PROD_TOT_SHARE

Properties

ID: | UNITS_CUBE.SALES_PROD_TOT_SHARE.MEASURE
Name: | SALES_PROD_TOT_SHARE
Long Name: | AMERICAN::Sales Share of Total Product
Short Name: | AMERICAN::Sales Share of Total Product
Plural Name: | AMERICAN::SALES_PROD_TOT_SHARE
DataType: | Decimal
Internal: |
Force Calc: |
Force Order: |
Sparse Type: | STANDARD
Use Global Index: |
AutoSolve: | DEFAULT
IsValid: |
Operator: | SHARE_TO_TOTAL

Inputs

KeyWord | Object | ScalarValue
DIMENSION | PRODUCT.DIMENSION |
MEASURE | UNITS_CUBE.SALES.MEASURE |
HIERARCHY | PRODUCT.PRIMARY.HIERARCHY |
Total: 3 inputs(s)

See Also

List of olap measures


Olap measure: SALES_3_PER_MOVAVG

Properties

ID: | UNITS_CUBE.SALES_3_PER_MOVAVG.MEASURE
Name: | SALES_3_PER_MOVAVG
Long Name: | AMERICAN::Sales 3 Period Moving Avg
Short Name: | AMERICAN::Sales 3 Period Moving Avg
Plural Name: | AMERICAN::SALES_3_PER_MOVAVG
DataType: | Decimal
Internal: |
Force Calc: |
Force Order: |
Sparse Type: | STANDARD
Use Global Index: |
AutoSolve: | DEFAULT
IsValid: |
Operator: | MOVINGAVERAGE

Inputs

KeyWord | Object | ScalarValue
DIMENSION | TIME.DIMENSION |
MEASURE | UNITS_CUBE.SALES.MEASURE |
START |  | -2
STOP |  | 0
STEP |  | 1
Total: 5 inputs(s)

See Also

List of olap measures


Olap measure: PROFIT_PP

Properties

ID: | UNITS_CUBE.PROFIT_PP.MEASURE
Name: | PROFIT_PP
Long Name: | AMERICAN::Profit Prior Period
Short Name: | AMERICAN::Profit Prior Period
Plural Name: | AMERICAN::PROFIT_PP
DataType: | Decimal
Internal: |
Force Calc: |
Force Order: |
Sparse Type: | STANDARD
Use Global Index: |
AutoSolve: | DEFAULT
IsValid: |
Operator: | PRIOR_PERIOD

Inputs

KeyWord | Object | ScalarValue
DIMENSION | TIME.DIMENSION |
MEASURE | UNITS_CUBE.PROFIT.MEASURE |
HIERARCHY | TIME.CALENDAR_YEAR.HIERARCHY |
OFFSET |  | 1
Total: 4 inputs(s)

See Also

List of olap measures


Olap measure: PROFIT_CHG_PP

Properties

ID: | UNITS_CUBE.PROFIT_CHG_PP.MEASURE
Name: | PROFIT_CHG_PP
Long Name: | AMERICAN::Profit Change Prior Period
Short Name: | AMERICAN::Profit Change Prior Period
Plural Name: | AMERICAN::PROFIT_CHG_PP
DataType: | Decimal
Internal: |
Force Calc: |
Force Order: |
Sparse Type: | STANDARD
Use Global Index: |
AutoSolve: | DEFAULT
IsValid: |
Operator: | PRIOR_PERIOD_VARIANCE

Inputs

KeyWord | Object | ScalarValue
DIMENSION | TIME.DIMENSION |
MEASURE | UNITS_CUBE.PROFIT.MEASURE |
HIERARCHY | TIME.CALENDAR_YEAR.HIERARCHY |
OFFSET |  | 1
Total: 4 inputs(s)

See Also

List of olap measures


Olap measure: PROFIT_PCT_CHG_PP

Properties

ID: | UNITS_CUBE.PROFIT_PCT_CHG_PP.MEASURE
Name: | PROFIT_PCT_CHG_PP
Long Name: | AMERICAN::Profit % Chg Prior Period
Short Name: | AMERICAN::Profit % Chg Prior Period
Plural Name: | AMERICAN::PROFIT_PCT_CHG_PP
DataType: | Decimal
Internal: |
Force Calc: |
Force Order: |
Sparse Type: | STANDARD
Use Global Index: |
AutoSolve: | DEFAULT
IsValid: |
Operator: | PRIOR_PERIOD_VARIANCE_PERCENT

Inputs

KeyWord | Object | ScalarValue
DIMENSION | TIME.DIMENSION |
MEASURE | UNITS_CUBE.PROFIT.MEASURE |
HIERARCHY | TIME.CALENDAR_YEAR.HIERARCHY |
OFFSET |  | 1
Total: 4 inputs(s)

See Also

List of olap measures


Olap measure: PROFIT_PY

Properties

ID: | UNITS_CUBE.PROFIT_PY.MEASURE
Name: | PROFIT_PY
Long Name: | AMERICAN::Profit Prior Year
Short Name: | AMERICAN::Profit Prior Year
Plural Name: | AMERICAN::PROFIT_PY
DataType: | Decimal
Internal: |
Force Calc: |
Force Order: |
Sparse Type: | STANDARD
Use Global Index: |
AutoSolve: | DEFAULT
IsValid: |
Operator: | SAME_PERIOD_ANCESTORS_AGO

Inputs

KeyWord | Object | ScalarValue
DIMENSION | TIME.DIMENSION |
MEASURE | UNITS_CUBE.PROFIT.MEASURE |
HIERARCHY | TIME.CALENDAR_YEAR.HIERARCHY |
LEVEL | TIME.YEAR.LEVEL |
OFFSET |  | 1
Total: 5 inputs(s)

See Also

List of olap measures


Olap measure: PROFIT_CHG_PY

Properties

ID: | UNITS_CUBE.PROFIT_CHG_PY.MEASURE
Name: | PROFIT_CHG_PY
Long Name: | AMERICAN::Profit Change Prior Year
Short Name: | AMERICAN::Profit Change Prior Year
Plural Name: | AMERICAN::PROFIT_CHG_PY
DataType: | Decimal
Internal: |
Force Calc: |
Force Order: |
Sparse Type: | STANDARD
Use Global Index: |
AutoSolve: | DEFAULT
IsValid: |
Operator: | SAME_PERIOD_ANCESTORS_AGO_VARIANCE

Inputs

KeyWord | Object | ScalarValue
DIMENSION | TIME.DIMENSION |
MEASURE | UNITS_CUBE.PROFIT.MEASURE |
HIERARCHY | TIME.CALENDAR_YEAR.HIERARCHY |
LEVEL | TIME.YEAR.LEVEL |
OFFSET |  | 1
Total: 5 inputs(s)

See Also

List of olap measures


Olap measure: PROFIT_PCT_CHG_PY

Properties

ID: | UNITS_CUBE.PROFIT_PCT_CHG_PY.MEASURE
Name: | PROFIT_PCT_CHG_PY
Long Name: | AMERICAN::Profit % Chg Prior Year
Short Name: | AMERICAN::Profit % Chg Prior Year
Plural Name: | AMERICAN::PROFIT_PCT_CHG_PY
DataType: | Decimal
Internal: |
Force Calc: |
Force Order: |
Sparse Type: | STANDARD
Use Global Index: |
AutoSolve: | DEFAULT
IsValid: |
Operator: | SAME_PERIOD_ANCESTORS_AGO_VARIANCE_PERCENT

Inputs

KeyWord | Object | ScalarValue
DIMENSION | TIME.DIMENSION |
MEASURE | UNITS_CUBE.PROFIT.MEASURE |
HIERARCHY | TIME.CALENDAR_YEAR.HIERARCHY |
LEVEL | TIME.YEAR.LEVEL |
OFFSET |  | 1
Total: 5 inputs(s)

See Also

List of olap measures


Olap measure: PROFIT_YTD

Properties

ID: | UNITS_CUBE.PROFIT_YTD.MEASURE
Name: | PROFIT_YTD
Long Name: | AMERICAN::Profit YTD
Short Name: | AMERICAN::Profit YTD
Plural Name: | AMERICAN::PROFIT_YTD
DataType: | Decimal
Internal: |
Force Calc: |
Force Order: |
Sparse Type: | STANDARD
Use Global Index: |
AutoSolve: | DEFAULT
IsValid: |
Operator: | YEAR_TO_DATE

Inputs

KeyWord | Object | ScalarValue
DIMENSION | TIME.DIMENSION |
MEASURE | UNITS_CUBE.PROFIT.MEASURE |
Total: 2 inputs(s)

See Also

List of olap measures


Olap measure: PROFIT_YTD_PY

Properties

ID: | UNITS_CUBE.PROFIT_YTD_PY.MEASURE
Name: | PROFIT_YTD_PY
Long Name: | AMERICAN::Profit YTD Prior Year
Short Name: | AMERICAN::Profit YTD Prior Year
Plural Name: | AMERICAN::PROFIT_YTD_PY
DataType: | Decimal
Internal: |
Force Calc: |
Force Order: |
Sparse Type: | STANDARD
Use Global Index: |
AutoSolve: | DEFAULT
IsValid: |
Operator: | SAME_PERIOD_ANCESTORS_AGO

Inputs

KeyWord | Object | ScalarValue
DIMENSION | TIME.DIMENSION |
MEASURE | UNITS_CUBE.PROFIT_YTD.MEASURE |
HIERARCHY | TIME.CALENDAR_YEAR.HIERARCHY |
LEVEL | TIME.YEAR.LEVEL |
OFFSET |  | 1
Total: 5 inputs(s)

See Also

List of olap measures


Olap measure: PROFIT_YTD_CHG_PY

Properties

ID: | UNITS_CUBE.PROFIT_YTD_CHG_PY.MEASURE
Name: | PROFIT_YTD_CHG_PY
Long Name: | AMERICAN::Profit YTD Chg Prior Year
Short Name: | AMERICAN::Profit YTD Chg Prior Year
Plural Name: | AMERICAN::PROFIT_YTD_CHG_PY
DataType: | Decimal
Internal: |
Force Calc: |
Force Order: |
Sparse Type: | STANDARD
Use Global Index: |
AutoSolve: | DEFAULT
IsValid: |
Operator: | SAME_PERIOD_ANCESTORS_AGO_VARIANCE

Inputs

KeyWord | Object | ScalarValue
DIMENSION | TIME.DIMENSION |
MEASURE | UNITS_CUBE.PROFIT_YTD.MEASURE |
HIERARCHY | TIME.CALENDAR_YEAR.HIERARCHY |
LEVEL | TIME.YEAR.LEVEL |
OFFSET |  | 1
Total: 5 inputs(s)

See Also

List of olap measures


Olap measure: PROFIT_YTD_PCT_CHG_PY

Properties

ID: | UNITS_CUBE.PROFIT_YTD_PCT_CHG_PY.MEASURE
Name: | PROFIT_YTD_PCT_CHG_PY
Long Name: | AMERICAN::Profit YTD % Chg Prior Year
Short Name: | AMERICAN::Profit YTD % Chg Prior Year
Plural Name: | AMERICAN::PROFIT_YTD_PCT_CHG_PY
DataType: | Decimal
Internal: |
Force Calc: |
Force Order: |
Sparse Type: | STANDARD
Use Global Index: |
AutoSolve: | DEFAULT
IsValid: |
Operator: | SAME_PERIOD_ANCESTORS_AGO_VARIANCE_PERCENT

Inputs

KeyWord | Object | ScalarValue
DIMENSION | TIME.DIMENSION |
MEASURE | UNITS_CUBE.PROFIT_YTD.MEASURE |
HIERARCHY | TIME.CALENDAR_YEAR.HIERARCHY |
LEVEL | TIME.YEAR.LEVEL |
OFFSET |  | 1
Total: 5 inputs(s)

See Also

List of olap measures


Olap measure: PROFIT_PROD_PRNT_SHARE

Properties

ID: | UNITS_CUBE.PROFIT_PROD_PRNT_SHARE.MEASURE
Name: | PROFIT_PROD_PRNT_SHARE
Long Name: | AMERICAN::Profit Share of Prod Parent
Short Name: | AMERICAN::Profit Share of Prod Parent
Plural Name: | AMERICAN::PROFIT_PROD_PRNT_SHARE
DataType: | Decimal
Internal: |
Force Calc: |
Force Order: |
Sparse Type: | STANDARD
Use Global Index: |
AutoSolve: | DEFAULT
IsValid: |
Operator: | SHARE_TO_PARENT

Inputs

KeyWord | Object | ScalarValue
DIMENSION | PRODUCT.DIMENSION |
MEASURE | UNITS_CUBE.PROFIT.MEASURE |
HIERARCHY | PRODUCT.PRIMARY.HIERARCHY |
Total: 3 inputs(s)

See Also

List of olap measures


Olap measure: PROFIT_PROD_TOT_SHARE

Properties

ID: | UNITS_CUBE.PROFIT_PROD_TOT_SHARE.MEASURE
Name: | PROFIT_PROD_TOT_SHARE
Long Name: | AMERICAN::Profit Share of Total Product
Short Name: | AMERICAN::Profit Share of Total Product
Plural Name: | AMERICAN::PROFIT_PROD_TOT_SHARE
DataType: | Decimal
Internal: |
Force Calc: |
Force Order: |
Sparse Type: | STANDARD
Use Global Index: |
AutoSolve: | DEFAULT
IsValid: |
Operator: | SHARE_TO_TOTAL

Inputs

KeyWord | Object | ScalarValue
DIMENSION | PRODUCT.DIMENSION |
MEASURE | UNITS_CUBE.PROFIT.MEASURE |
HIERARCHY | PRODUCT.PRIMARY.HIERARCHY |
Total: 3 inputs(s)

See Also

List of olap measures


Olap measure: PROFIT_3_PER_MOVAVG

Properties

ID: | UNITS_CUBE.PROFIT_3_PER_MOVAVG.MEASURE
Name: | PROFIT_3_PER_MOVAVG
Long Name: | AMERICAN::Profit 3 Period Moving Avg
Short Name: | AMERICAN::Profit 3 Period Moving Avg
Plural Name: | AMERICAN::PROFIT_3_PER_MOVAVG
DataType: | Decimal
Internal: |
Force Calc: |
Force Order: |
Sparse Type: | STANDARD
Use Global Index: |
AutoSolve: | DEFAULT
IsValid: |
Operator: | MOVINGAVERAGE

Inputs

KeyWord | Object | ScalarValue
DIMENSION | TIME.DIMENSION |
MEASURE | UNITS_CUBE.PROFIT.MEASURE |
START |  | -2
STOP |  | 0
STEP |  | 1
Total: 5 inputs(s)

See Also

List of olap measures


List of measure folders

Measure folders

Name | Short Name
TIME_CALCULATIONS | AMERICAN::Time Calculations
YTD_CALCULATIONS | AMERICAN::YTD Calculations
PRODUCT_SHARE | AMERICAN::Product Share
Total: 3 measure folder(s)

See Also

Workspace [GLOBAL]


Measure folder: TIME_CALCULATIONS

Properties

ID: | TIME_CALCULATIONS.MEASUREFOLDER
Name: | TIME_CALCULATIONS
Long Name: | AMERICAN::Time Calculations
Short Name: | AMERICAN::Time Calculations
Plurar Name: | AMERICAN::TIME_CALCULATIONS

Cube measures

Cube | Measure
UNITS_CUBE | PROFIT_3_PER_MOVAVG
UNITS_CUBE | PROFIT_CHG_PP
UNITS_CUBE | PROFIT_CHG_PY
UNITS_CUBE | PROFIT_PCT_CHG_PP
UNITS_CUBE | PROFIT_PCT_CHG_PY
UNITS_CUBE | PROFIT_PP
UNITS_CUBE | PROFIT_PY
UNITS_CUBE | SALES_3_PER_MOVAVG
UNITS_CUBE | SALES_CHG_PP
UNITS_CUBE | SALES_CHG_PY
UNITS_CUBE | SALES_PCT_CHG_PP
UNITS_CUBE | SALES_PCT_CHG_PY
UNITS_CUBE | SALES_PP
UNITS_CUBE | SALES_PY
Total: 14 cube measure(s)

See Also

List of measure folders


Measure folder: YTD_CALCULATIONS

Properties

ID: | YTD_CALCULATIONS.MEASUREFOLDER
Name: | YTD_CALCULATIONS
Long Name: | AMERICAN::YTD Calculations
Short Name: | AMERICAN::YTD Calculations
Plurar Name: | AMERICAN::YTD_CALCULATIONS

Cube measures

Cube | Measure
UNITS_CUBE | PROFIT_YTD
UNITS_CUBE | PROFIT_YTD_CHG_PY
UNITS_CUBE | PROFIT_YTD_PCT_CHG_PY
UNITS_CUBE | PROFIT_YTD_PY
UNITS_CUBE | SALES_YTD
UNITS_CUBE | SALES_YTD_CHG_PY
UNITS_CUBE | SALES_YTD_PCT_CHG_PY
UNITS_CUBE | SALES_YTD_PY
Total: 8 cube measure(s)

See Also

List of measure folders


Measure folder: PRODUCT_SHARE

Properties

ID: | PRODUCT_SHARE.MEASUREFOLDER
Name: | PRODUCT_SHARE
Long Name: | AMERICAN::Product Share
Short Name: | AMERICAN::Product Share
Plurar Name: | AMERICAN::PRODUCT_SHARE

Cube measures

Cube | Measure
UNITS_CUBE | PROFIT_PROD_PRNT_SHARE
UNITS_CUBE | PROFIT_PROD_TOT_SHARE
UNITS_CUBE | SALES_PROD_PRNT_SHARE
UNITS_CUBE | SALES_PROD_TOT_SHARE
Total: 4 cube measure(s)

See Also

List of measure folders


List of calculation plans

Calculation plans

Name | Short Name
CALCULATION_PLAN1 | AMERICAN::Calculation Plan1
CALCULATION_PLAN | AMERICAN::Calculation Plan short
Total: 2calculation plan(s)

See Also

Workspace [GLOBAL]


Calculation plan: CALCULATION_PLAN1

Properties

ID: | CALCULATION_PLAN1.SOLVEGROUP
Name: | CALCULATION_PLAN1
Long Name: | AMERICAN::Calculation Plan1
Short Name: | AMERICAN::Calculation Plan1
Plurar Name: | AMERICAN::Calculation Plan1

Steps

Name | Short Name
STEP1 | AMERICAN::Step1 short
STEP2 | AMERICAN::Step2 short
Total: 2 step(s)

See Also

List of calculation plans


List of calculation steps

Calculation steps

Name | Short Name
STEP1 | AMERICAN::Step1 short
STEP2 | AMERICAN::Step2 short
Total: 2calculation step(s)

See Also

Calculation plan [CALCULATION_PLAN1]


Calculation step: STEP1

Properties

ID: | CALCULATION_PLAN1.STEP1.AGGREGATIONSOLVE
Name: | STEP1
Long Name: | AMERICAN::Step1 long
Short Name: | AMERICAN::Step1 short
Plurar Name: | AMERICAN::Step1 Description
Schema: | AW$DEFAULT
SolveOrder: | 1

Measures

Cube | Measure
UNITS_CUBE | SALES
UNITS_CUBE | UNITS
Total: 2 measure(s)

Aggregations

Dimension | Level | Operator | Type | Expression
CUSTOMER | TOTAL_CUSTOMER | SUM | INCLUDE |
CUSTOMER | REGION | SUM | INCLUDE |
CUSTOMER | MARKET_SEGMENT | SUM | INCLUDE |
CUSTOMER | ACCOUNT | SUM | INCLUDE |
CUSTOMER | SHIP_TO | SUM | INCLUDE |
TIME | YEAR | SUM | INCLUDE |
TIME | QUARTER | SUM | INCLUDE |
TIME | MONTH | SUM | INCLUDE |
TIME | ALL_YEARS | SUM | INCLUDE |
CHANNEL | CHANNEL | SUM | INCLUDE |
PRODUCT | TOTAL_PRODUCT | SUM | INCLUDE |
PRODUCT | CLASS | SUM | INCLUDE |
PRODUCT | ITEM | SUM | INCLUDE |
Total: 13 aggregation(s)

See Also

List of calculation steps


Calculation step: STEP2

Properties

ID: | CALCULATION_PLAN1.STEP2.AGGREGATIONSOLVE
Name: | STEP2
Long Name: | AMERICAN::Step2 long
Short Name: | AMERICAN::Step2 short
Plurar Name: | AMERICAN::Step2 description
Schema: | AW$DEFAULT
SolveOrder: | 2

Measures

Cube | Measure
UNITS_CUBE | COST
Total: 1 measure(s)

Aggregations

Dimension | Level | Operator | Type | Expression
CUSTOMER | REGION | SUM | INCLUDE |
CUSTOMER | MARKET_SEGMENT | SUM | INCLUDE |
CUSTOMER | SHIP_TO | SUM | INCLUDE |
TIME |  | SUM | EXCLUDE | ALL
CHANNEL | TOTAL_CHANNEL | SUM | INCLUDE |
CHANNEL | CHANNEL | SUM | INCLUDE |
PRODUCT | TOTAL_PRODUCT | SUM | INCLUDE |
PRODUCT | CLASS | SUM | INCLUDE |
PRODUCT | FAMILY | SUM | INCLUDE |
PRODUCT | ITEM | SUM | INCLUDE |
Total: 10 aggregation(s)

See Also

List of calculation steps


Calculation plan: CALCULATION_PLAN

Properties

ID: | CALCULATION_PLAN.SOLVEGROUP
Name: | CALCULATION_PLAN
Long Name: | AMERICAN::Calculation Plan long
Short Name: | AMERICAN::Calculation Plan short
Plurar Name: | AMERICAN::Calculation Plan description

Steps

Name | Short Name
STEP | AMERICAN::Step short
Total: 1 step(s)

See Also

List of calculation plans


List of calculation steps

Calculation steps

Name | Short Name
STEP | AMERICAN::Step short
Total: 1calculation step(s)

See Also

Calculation plan [CALCULATION_PLAN]


Calculation step: STEP

Properties

ID: | CALCULATION_PLAN.STEP.AGGREGATIONSOLVE
Name: | STEP
Long Name: | AMERICAN::Step long
Short Name: | AMERICAN::Step short
Plurar Name: | AMERICAN::Step description
Schema: | AW$DEFAULT
SolveOrder: | 1

Measures

Cube | Measure
UNITS_CUBE | COST
UNITS_CUBE | SALES
UNITS_CUBE | UNITS
Total: 3 measure(s)

Aggregations

Dimension | Level | Operator | Type | Expression
TIME | YEAR | SUM | INCLUDE |
TIME | QUARTER | SUM | INCLUDE |
TIME | MONTH | SUM | INCLUDE |
TIME | ALL_YEARS | SUM | INCLUDE |
CUSTOMER | REGION | SUM | INCLUDE |
CUSTOMER | SHIP_TO | SUM | INCLUDE |
PRODUCT | CLASS | SUM | INCLUDE |
PRODUCT | ITEM | SUM | INCLUDE |
CHANNEL | CHANNEL | SUM | INCLUDE |
Total: 9 aggregation(s)

See Also

List of calculation steps


Server Info

Properties

Version: 10.2.0.1.0

Schemas

Schema
GLOBAL
Total: 1 schema(s)

Server Parameters

Name | Value | ISSYS_M | Default | SES_M | SYS_M | Description
O7_DICTIONARY_ACCESSIBILITY | FALSE |  |  |  |  | Version 7 Dictionary Accessibility Support
active_instance_count |  |  |  |  |  | number of active instances in the cluster database
aq_tm_processes | 0 |  |  |  |  | number of AQ Time Managers to start
archive_lag_target | 0 |  |  |  |  | Maximum number of seconds of redos the standby could lose
asm_diskgroups |  |  |  |  |  | disk groups to mount automatically
asm_diskstring |  |  |  |  |  | disk set locations for discovery
asm_power_limit | 1 |  |  |  |  | number of processes for disk rebalancing
audit_file_dest | C:\ORACLE\ADMIN\ORACLE10\ADUMP |  |  |  |  | Directory in which auditing files are to reside
audit_sys_operations | FALSE |  |  |  |  | enable sys auditing
audit_trail | NONE |  |  |  |  | enable system auditing
background_core_dump | partial |  |  |  |  | Core Size for Background Processes
background_dump_dest | C:\ORACLE\ADMIN\ORACLE10\BDUMP |  |  |  |  | Detached process dump directory
backup_tape_io_slaves | FALSE |  |  |  |  | BACKUP Tape I/O slaves
bitmap_merge_area_size | 1048576 |  |  |  |  | maximum memory allow for BITMAP MERGE
blank_trimming | FALSE |  |  |  |  | blank trimming semantics parameter
buffer_pool_keep |  |  |  |  |  | Number of database blocks/latches in keep buffer pool
buffer_pool_recycle |  |  |  |  |  | Number of database blocks/latches in recycle buffer pool
circuits |  |  |  |  |  | max number of circuits
cluster_database | FALSE |  |  |  |  | if TRUE startup in cluster database mode
cluster_database_instances | 1 |  |  |  |  | number of instances to use for sizing cluster db SGA structures
cluster_interconnects |  |  |  |  |  | interconnects for RAC use
commit_point_strength | 1 |  |  |  |  | Bias this node has toward not preparing in a two-phase commit
commit_write |  |  |  |  |  | transaction commit log write behaviour
compatible | 10.2.0.1.0 |  |  |  |  | Database will be completely compatible with this software version
control_file_record_keep_time | 7 |  |  |  |  | control file record keep time in days
control_files | C:\ORACLE\ORADATA\ORACLE10\CONTROL01.CTL, C:\ORACLE\ORADATA\ORACLE10\CONTROL02.CTL, C:\ORACLE\ORADATA\ORACLE10\CONTROL03.CTL |  |  |  |  | control file names list
core_dump_dest | C:\ORACLE\ADMIN\ORACLE10\CDUMP |  |  |  |  | Core dump directory
cpu_count | 1 |  |  |  |  | number of CPUs for this instance
create_bitmap_area_size | 8388608 |  |  |  |  | size of create bitmap buffer for bitmap index
create_stored_outlines |  |  |  |  |  | create stored outlines for DML statements
cursor_sharing | EXACT |  |  |  |  | cursor sharing mode
cursor_space_for_time | FALSE |  |  |  |  | use more memory in order to get faster execution
db_16k_cache_size | 0 |  |  |  |  | Size of cache for 16K buffers
db_2k_cache_size | 0 |  |  |  |  | Size of cache for 2K buffers
db_32k_cache_size | 0 |  |  |  |  | Size of cache for 32K buffers
db_4k_cache_size | 0 |  |  |  |  | Size of cache for 4K buffers
db_8k_cache_size | 0 |  |  |  |  | Size of cache for 8K buffers
db_block_buffers | 0 |  |  |  |  | Number of database blocks cached in memory
db_block_checking | FALSE |  |  |  |  | header checking and data and index block checking
db_block_checksum | TRUE |  |  |  |  | store checksum in db blocks and check during reads
db_block_size | 8192 |  |  |  |  | Size of database block in bytes
db_cache_advice | ON |  |  |  |  | Buffer cache sizing advisory
db_cache_size | 0 |  |  |  |  | Size of DEFAULT buffer pool for standard block size buffers
db_create_file_dest |  |  |  |  |  | default database location
db_create_online_log_dest_1 |  |  |  |  |  | online log/controlfile destination #1
db_create_online_log_dest_2 |  |  |  |  |  | online log/controlfile destination #2
db_create_online_log_dest_3 |  |  |  |  |  | online log/controlfile destination #3
db_create_online_log_dest_4 |  |  |  |  |  | online log/controlfile destination #4
db_create_online_log_dest_5 |  |  |  |  |  | online log/controlfile destination #5
db_domain |  |  |  |  |  | directory part of global database name stored with CREATE DATABASE
db_file_multiblock_read_count | 16 |  |  |  |  | db block to be read each IO
db_file_name_convert |  |  |  |  |  | datafile name convert patterns and strings for standby/clone db
db_files | 200 |  |  |  |  | max allowable # db files
db_flashback_retention_target | 1440 |  |  |  |  | Maximum Flashback Database log retention time in minutes.
db_keep_cache_size | 0 |  |  |  |  | Size of KEEP buffer pool for standard block size buffers
db_name | ORACLE10 |  |  |  |  | database name specified in CREATE DATABASE
db_recovery_file_dest | C:\oracle/flash_recovery_area |  |  |  |  | default database recovery file location
db_recovery_file_dest_size | 2147483648 |  |  |  |  | database recovery files size limit
db_recycle_cache_size | 0 |  |  |  |  | Size of RECYCLE buffer pool for standard block size buffers
db_unique_name | ORACLE10 |  |  |  |  | Database Unique Name
db_writer_processes | 1 |  |  |  |  | number of background database writer processes to start
dbwr_io_slaves | 0 |  |  |  |  | DBWR I/O slaves
ddl_wait_for_locks | FALSE |  |  |  |  | Disable NOWAIT DML lock acquisitions
dg_broker_config_file1 | D:\ORACLE\PRODUCT\10.2.0\DB_1\DATABASE\DR1ORACLE10.DAT |  |  |  |  | data guard broker configuration file #1
dg_broker_config_file2 | D:\ORACLE\PRODUCT\10.2.0\DB_1\DATABASE\DR2ORACLE10.DAT |  |  |  |  | data guard broker configuration file #2
dg_broker_start | FALSE |  |  |  |  | start Data Guard broker framework (DMON process)
disk_asynch_io | TRUE |  |  |  |  | Use asynch I/O for random access devices
dispatchers | (PROTOCOL=TCP) (SERVICE=ORACLE10XDB) |  |  |  |  | specifications of dispatchers
distributed_lock_timeout | 60 |  |  |  |  | number of seconds a distributed transaction waits for a lock
dml_locks | 748 |  |  |  |  | dml locks - one for each table modified in a transaction
drs_start | FALSE |  |  |  |  | start DG Broker monitor (DMON process)
event |  |  |  |  |  | debug event control - default null string
fal_client |  |  |  |  |  | FAL client
fal_server |  |  |  |  |  | FAL server list
fast_start_io_target | 0 |  |  |  |  | Upper bound on recovery reads
fast_start_mttr_target | 0 |  |  |  |  | MTTR target of forward crash recovery in seconds
fast_start_parallel_rollback | LOW |  |  |  |  | max number of parallel recovery slaves that may be used
file_mapping | FALSE |  |  |  |  | enable file mapping
fileio_network_adapters |  |  |  |  |  | Network Adapters for File I/O
filesystemio_options |  |  |  |  |  | IO operations on filesystem files
fixed_date |  |  |  |  |  | fixed SYSDATE value
gc_files_to_locks |  |  |  |  |  | mapping between file numbers and global cache locks
gcs_server_processes | 0 |  |  |  |  | number of background gcs server processes to start
global_context_pool_size |  |  |  |  |  | Global Application Context Pool Size in Bytes
global_names | FALSE |  |  |  |  | enforce that database links have same name as remote database
hash_area_size | 131072 |  |  |  |  | size of in-memory hash work area
hi_shared_memory_address | 0 |  |  |  |  | SGA starting address (high order 32-bits on 64-bit platforms)
hs_autoregister | TRUE |  |  |  |  | enable automatic server DD updates in HS agent self-registration
ifile |  |  |  |  |  | include file in init.ora
instance_groups |  |  |  |  |  | list of instance group names
instance_name | oracle10 |  |  |  |  | instance name supported by the instance
instance_number | 0 |  |  |  |  | instance number
instance_type | RDBMS |  |  |  |  | type of instance to be executed
java_max_sessionspace_size | 0 |  |  |  |  | max allowed size in bytes of a Java sessionspace
java_pool_size | 0 |  |  |  |  | size in bytes of java pool
java_soft_sessionspace_limit | 0 |  |  |  |  | warning limit on size in bytes of a Java sessionspace
job_queue_processes | 10 |  |  |  |  | number of job queue slave processes
large_pool_size | 0 |  |  |  |  | size in bytes of large pool
ldap_directory_access | NONE |  |  |  |  | RDBMS's LDAP access option
license_max_sessions | 0 |  |  |  |  | maximum number of non-system user sessions allowed
license_max_users | 0 |  |  |  |  | maximum number of named users that can be created in the database
license_sessions_warning | 0 |  |  |  |  | warning level for number of non-system user sessions
local_listener | LISTENER_ORACLE10 |  |  |  |  | local listener
lock_name_space |  |  |  |  |  | lock name space used for generating lock names for standby/clone database
lock_sga | FALSE |  |  |  |  | Lock entire SGA in physical memory
log_archive_config |  |  |  |  |  | log archive config parameter
log_archive_dest |  |  |  |  |  | archival destination text string
log_archive_dest_1 |  |  |  |  |  | archival destination #1 text string
log_archive_dest_10 |  |  |  |  |  | archival destination #10 text string
log_archive_dest_2 |  |  |  |  |  | archival destination #2 text string
log_archive_dest_3 |  |  |  |  |  | archival destination #3 text string
log_archive_dest_4 |  |  |  |  |  | archival destination #4 text string
log_archive_dest_5 |  |  |  |  |  | archival destination #5 text string
log_archive_dest_6 |  |  |  |  |  | archival destination #6 text string
log_archive_dest_7 |  |  |  |  |  | archival destination #7 text string
log_archive_dest_8 |  |  |  |  |  | archival destination #8 text string
log_archive_dest_9 |  |  |  |  |  | archival destination #9 text string
log_archive_dest_state_1 | enable |  |  |  |  | archival destination #1 state text string
log_archive_dest_state_10 | enable |  |  |  |  | archival destination #10 state text string
log_archive_dest_state_2 | enable |  |  |  |  | archival destination #2 state text string
log_archive_dest_state_3 | enable |  |  |  |  | archival destination #3 state text string
log_archive_dest_state_4 | enable |  |  |  |  | archival destination #4 state text string
log_archive_dest_state_5 | enable |  |  |  |  | archival destination #5 state text string
log_archive_dest_state_6 | enable |  |  |  |  | archival destination #6 state text string
log_archive_dest_state_7 | enable |  |  |  |  | archival destination #7 state text string
log_archive_dest_state_8 | enable |  |  |  |  | archival destination #8 state text string
log_archive_dest_state_9 | enable |  |  |  |  | archival destination #9 state text string
log_archive_duplex_dest |  |  |  |  |  | duplex archival destination text string
log_archive_format | ARC%S_%R.%T |  |  |  |  | archival destination format
log_archive_local_first | TRUE |  |  |  |  | Establish EXPEDITE attribute default value
log_archive_max_processes | 2 |  |  |  |  | maximum number of active ARCH processes
log_archive_min_succeed_dest | 1 |  |  |  |  | minimum number of archive destinations that must succeed
log_archive_start | FALSE |  |  |  |  | start archival process on SGA initialization
log_archive_trace | 0 |  |  |  |  | Establish archivelog operation tracing level
log_buffer | 2899456 |  |  |  |  | redo circular buffer size
log_checkpoint_interval | 0 |  |  |  |  | # redo blocks checkpoint threshold
log_checkpoint_timeout | 1800 |  |  |  |  | Maximum time interval between checkpoints in seconds
log_checkpoints_to_alert | FALSE |  |  |  |  | log checkpoint begin/end to alert file
log_file_name_convert |  |  |  |  |  | logfile name convert patterns and strings for standby/clone db
logmnr_max_persistent_sessions | 1 |  |  |  |  | maximum number of threads to mine
max_commit_propagation_delay | 0 |  |  |  |  | Max age of new snapshot in .01 seconds
max_dispatchers |  |  |  |  |  | max number of dispatchers
max_dump_file_size | UNLIMITED |  |  |  |  | Maximum size (blocks) of dump file
max_enabled_roles | 150 |  |  |  |  | max number of roles a user can have enabled
max_shared_servers |  |  |  |  |  | max number of shared servers
object_cache_max_size_percent | 10 |  |  |  |  | percentage of maximum size over optimal of the user session's object cache
object_cache_optimal_size | 102400 |  |  |  |  | optimal size of the user session's object cache in bytes
olap_page_pool_size | 0 |  |  |  |  | size of the olap page pool in bytes
open_cursors | 300 |  |  |  |  | max # cursors per session
open_links | 4 |  |  |  |  | max # open links per session
open_links_per_instance | 4 |  |  |  |  | max # open links per instance
optimizer_dynamic_sampling | 2 |  |  |  |  | optimizer dynamic sampling
optimizer_features_enable | 10.2.0.1 |  |  |  |  | optimizer plan compatibility parameter
optimizer_index_caching | 0 |  |  |  |  | optimizer percent index caching
optimizer_index_cost_adj | 100 |  |  |  |  | optimizer index cost adjustment
optimizer_mode | ALL_ROWS |  |  |  |  | optimizer mode
optimizer_secure_view_merging | TRUE |  |  |  |  | optimizer secure view merging and predicate pushdown/movearound
os_authent_prefix | OPS$ |  |  |  |  | prefix for auto-logon accounts
os_roles | FALSE |  |  |  |  | retrieve roles from the operating system
parallel_adaptive_multi_user | TRUE |  |  |  |  | enable adaptive setting of degree for multiple user streams
parallel_automatic_tuning | FALSE |  |  |  |  | enable intelligent defaults for parallel execution parameters
parallel_execution_message_size | 2148 |  |  |  |  | message buffer size for parallel execution
parallel_instance_group |  |  |  |  |  | instance group to use for all parallel operations
parallel_max_servers | 20 |  |  |  |  | maximum parallel query servers per instance
parallel_min_percent | 0 |  |  |  |  | minimum percent of threads required for parallel query
parallel_min_servers | 0 |  |  |  |  | minimum parallel query servers per instance
parallel_server | FALSE |  |  |  |  | if TRUE startup in parallel server mode
parallel_server_instances | 1 |  |  |  |  | number of instances to use for sizing OPS SGA structures
parallel_threads_per_cpu | 2 |  |  |  |  | number of parallel execution threads per CPU
pga_aggregate_target | 16777216 |  |  |  |  | Target size for the aggregate PGA memory consumed by the instance
plsql_ccflags |  |  |  |  |  | PL/SQL ccflags
plsql_code_type | INTERPRETED |  |  |  |  | PL/SQL code-type
plsql_compiler_flags | INTERPRETED, NON_DEBUG |  |  |  |  | PL/SQL compiler flags
plsql_debug | FALSE |  |  |  |  | PL/SQL debug
plsql_native_library_dir |  |  |  |  |  | plsql native library dir
plsql_native_library_subdir_count | 0 |  |  |  |  | plsql native library number of subdirectories
plsql_optimize_level | 2 |  |  |  |  | PL/SQL optimize level
plsql_v2_compatibility | FALSE |  |  |  |  | PL/SQL version 2.x compatibility flag
plsql_warnings | DISABLE:ALL |  |  |  |  | PL/SQL compiler warnings settings
pre_page_sga | FALSE |  |  |  |  | pre-page sga for process
processes | 150 |  |  |  |  | user processes
query_rewrite_enabled | TRUE |  |  |  |  | allow rewrite of queries using materialized views if enabled
query_rewrite_integrity | enforced |  |  |  |  | perform rewrite using materialized views with desired integrity
rdbms_server_dn |  |  |  |  |  | RDBMS's Distinguished Name
read_only_open_delayed | FALSE |  |  |  |  | if TRUE delay opening of read only files until first access
recovery_parallelism | 0 |  |  |  |  | number of server processes to use for parallel recovery
recyclebin | on |  |  |  |  | recyclebin processing
remote_archive_enable | true |  |  |  |  | remote archival enable setting
remote_dependencies_mode | TIMESTAMP |  |  |  |  | remote-procedure-call dependencies mode parameter
remote_listener |  |  |  |  |  | remote listener
remote_login_passwordfile | EXCLUSIVE |  |  |  |  | password file usage parameter
remote_os_authent | FALSE |  |  |  |  | allow non-secure remote clients to use auto-logon accounts
remote_os_roles | FALSE |  |  |  |  | allow non-secure remote clients to use os roles
replication_dependency_tracking | TRUE |  |  |  |  | tracking dependency for Replication parallel propagation
resource_limit | FALSE |  |  |  |  | master switch for resource limit
resource_manager_plan |  |  |  |  |  | resource mgr top plan
resumable_timeout | 0 |  |  |  |  | set resumable_timeout
rollback_segments |  |  |  |  |  | undo segment list
serial_reuse | disable |  |  |  |  | reuse the frame segments
service_names | ORACLE10 |  |  |  |  | service names supported by the instance
session_cached_cursors | 20 |  |  |  |  | Number of cursors to cache in a session.
session_max_open_files | 10 |  |  |  |  | maximum number of open files allowed per session
sessions | 170 |  |  |  |  | user and system sessions
sga_max_size | 167772160 |  |  |  |  | max total SGA size
sga_target | 167772160 |  |  |  |  | Target size of SGA
shadow_core_dump | partial |  |  |  |  | Core Size for Shadow Processes
shared_memory_address | 0 |  |  |  |  | SGA starting address (low order 32-bits on 64-bit platforms)
shared_pool_reserved_size | 4194304 |  |  |  |  | size in bytes of reserved area of shared pool
shared_pool_size | 0 |  |  |  |  | size in bytes of shared pool
shared_server_sessions |  |  |  |  |  | max number of shared server sessions
shared_servers | 1 |  |  |  |  | number of shared servers to start up
skip_unusable_indexes | TRUE |  |  |  |  | skip unusable indexes if set to TRUE
smtp_out_server |  |  |  |  |  | utl_smtp server and port configuration parameter
sort_area_retained_size | 0 |  |  |  |  | size of in-memory sort work area retained between fetch calls
sort_area_size | 65536 |  |  |  |  | size of in-memory sort work area
spfile | D:\ORACLE\PRODUCT\10.2.0\DB_1\DBS\SPFILEORACLE10.ORA |  |  |  |  | server parameter file
sql92_security | FALSE |  |  |  |  | require select privilege for searched update/delete
sql_trace | FALSE |  |  |  |  | enable SQL trace
sql_version | NATIVE |  |  |  |  | sql language version parameter for compatibility issues
sqltune_category | DEFAULT |  |  |  |  | Category qualifier for applying hintsets
standby_archive_dest | %ORACLE_HOME%\RDBMS |  |  |  |  | standby database archivelog destination text string
standby_file_management | MANUAL |  |  |  |  | if auto then files are created/dropped automatically on standby
star_transformation_enabled | FALSE |  |  |  |  | enable the use of star transformation
statistics_level | TYPICAL |  |  |  |  | statistics level
streams_pool_size | 0 |  |  |  |  | size in bytes of the streams pool
tape_asynch_io | TRUE |  |  |  |  | Use asynch I/O requests for tape devices
thread | 0 |  |  |  |  | Redo thread to mount
timed_os_statistics | 0 |  |  |  |  | internal os statistic gathering interval in seconds
timed_statistics | TRUE |  |  |  |  | maintain internal timing statistics
trace_enabled | TRUE |  |  |  |  | enable KST tracing
tracefile_identifier |  |  |  |  |  | trace file custom identifier
transactions | 187 |  |  |  |  | max. number of concurrent active transactions
transactions_per_rollback_segment | 5 |  |  |  |  | number of active transactions per rollback segment
undo_management | AUTO |  |  |  |  | instance runs in SMU mode if TRUE, else in RBU mode
undo_retention | 900 |  |  |  |  | undo retention in seconds
undo_tablespace | UNDOTBS1 |  |  |  |  | use/switch undo tablespace
use_indirect_data_buffers | FALSE |  |  |  |  | Enable indirect data buffers (very large SGA on 32-bit platforms)
user_dump_dest | C:\ORACLE\ADMIN\ORACLE10\UDUMP |  |  |  |  | User process dump directory
utl_file_dir |  |  |  |  |  | utl_file accessible directories list
workarea_size_policy | AUTO |  |  |  |  | policy used to size SQL working areas (MANUAL/AUTO)


About

Documentation details

Customer: |
Project: |
Created: | 4/18/2007