Schema: SH

Properties

Name: | SH
Created: | 03.15.2007

Tables

Name | Status | Tablespace | Logging | Partitioned | Cached | Description
CHANNELS | VALID | EXAMPLE | N |  | ENABLED | small dimension table
COSTS | VALID |  | N |  | ENABLED |
COUNTRIES | VALID | EXAMPLE | N |  | ENABLED | country dimension table (snowflake)
CUSTOMERS | VALID | EXAMPLE | N |  | ENABLED | dimension table
DR$SUP_TEXT_IDX$I | VALID | EXAMPLE | N |  | ENABLED |
DR$SUP_TEXT_IDX$K | VALID |  | N | IOT | ENABLED |
DR$SUP_TEXT_IDX$N | VALID |  | N | IOT | ENABLED |
DR$SUP_TEXT_IDX$R | VALID | EXAMPLE | N |  | ENABLED |
MVIEW$_EXCEPTIONS | VALID | EXAMPLE | N |  | ENABLED |
PRODUCTS | VALID | EXAMPLE | N |  | ENABLED | dimension table
PROMOTIONS | VALID | EXAMPLE | N |  | ENABLED | dimension table without a PK-FK relationship with the facts table, to show outer join functionality
SALES | VALID |  | N |  | ENABLED | facts table, without a primary key; all rows are uniquely identified by the combination of all foreign keys
SALES_TRANSACTIONS_EXT | VALID |  | N |  | ENABLED |
SUPPLEMENTARY_DEMOGRAPHICS | VALID | EXAMPLE | N |  | ENABLED |
TIMES | VALID | EXAMPLE | N |  | ENABLED | Time dimension table to support multiple hierarchies and materialized views
Total: 15 table(s)

Views

Name | Status | Last modify | Created | Description
PROFITS | VALID | 03.15.2007 | 03.15.2007 |
Total: 1 view(s)

Constraints

Name | Table
CHANNELS_PK | CHANNELS
COSTS_CHANNEL_FK | COSTS
COSTS_PRODUCT_FK | COSTS
COSTS_PROMO_FK | COSTS
COSTS_TIME_FK | COSTS
COUNTRIES_PK | COUNTRIES
CUSTOMERS_COUNTRY_FK | CUSTOMERS
CUSTOMERS_PK | CUSTOMERS
PRODUCTS_PK | PRODUCTS
PROMO_PK | PROMOTIONS
SALES_CHANNEL_FK | SALES
SALES_CUSTOMER_FK | SALES
SALES_PRODUCT_FK | SALES
SALES_PROMO_FK | SALES
SALES_TIME_FK | SALES
SUPP_DEMO_PK | SUPPLEMENTARY_DEMOGRAPHICS
SYS_C005209 | SALES
SYS_C005210 | SALES
SYS_C005211 | SALES
SYS_C005212 | SALES
SYS_C005213 | SALES
SYS_C005214 | SALES
SYS_C005215 | SALES
SYS_C005216 | COSTS
SYS_C005217 | COSTS
SYS_C005218 | COSTS
SYS_C005219 | COSTS
SYS_C005220 | COSTS
SYS_C005221 | COSTS
SYS_C005222 | TIMES
SYS_C005223 | TIMES
SYS_C005224 | TIMES
SYS_C005225 | TIMES
SYS_C005226 | TIMES
SYS_C005227 | TIMES
SYS_C005228 | TIMES
SYS_C005229 | TIMES
SYS_C005230 | TIMES
SYS_C005231 | TIMES
SYS_C005232 | TIMES
SYS_C005233 | TIMES
SYS_C005234 | TIMES
SYS_C005235 | TIMES
SYS_C005236 | TIMES
SYS_C005237 | TIMES
SYS_C005238 | TIMES
SYS_C005239 | TIMES
SYS_C005240 | TIMES
SYS_C005241 | TIMES
SYS_C005242 | TIMES
SYS_C005243 | TIMES
SYS_C005244 | TIMES
SYS_C005245 | TIMES
SYS_C005246 | TIMES
SYS_C005247 | TIMES
SYS_C005248 | TIMES
SYS_C005249 | TIMES
SYS_C005250 | TIMES
SYS_C005251 | TIMES
SYS_C005252 | TIMES
SYS_C005253 | TIMES
SYS_C005254 | TIMES
SYS_C005255 | TIMES
SYS_C005256 | TIMES
SYS_C005257 | TIMES
SYS_C005258 | TIMES
SYS_C005259 | TIMES
SYS_C005261 | PRODUCTS
SYS_C005262 | PRODUCTS
SYS_C005263 | PRODUCTS
SYS_C005264 | PRODUCTS
SYS_C005265 | PRODUCTS
SYS_C005266 | PRODUCTS
SYS_C005267 | PRODUCTS
SYS_C005268 | PRODUCTS
SYS_C005269 | PRODUCTS
SYS_C005270 | PRODUCTS
SYS_C005271 | PRODUCTS
SYS_C005272 | PRODUCTS
SYS_C005273 | PRODUCTS
SYS_C005274 | PRODUCTS
SYS_C005275 | PRODUCTS
SYS_C005276 | PRODUCTS
SYS_C005277 | PRODUCTS
SYS_C005279 | CHANNELS
SYS_C005280 | CHANNELS
SYS_C005281 | CHANNELS
SYS_C005282 | CHANNELS
SYS_C005283 | CHANNELS
SYS_C005284 | CHANNELS
SYS_C005286 | PROMOTIONS
SYS_C005287 | PROMOTIONS
SYS_C005288 | PROMOTIONS
SYS_C005289 | PROMOTIONS
SYS_C005290 | PROMOTIONS
SYS_C005291 | PROMOTIONS
SYS_C005292 | PROMOTIONS
SYS_C005293 | PROMOTIONS
SYS_C005294 | PROMOTIONS
SYS_C005295 | PROMOTIONS
SYS_C005296 | PROMOTIONS
SYS_C005298 | CUSTOMERS
SYS_C005299 | CUSTOMERS
SYS_C005300 | CUSTOMERS
SYS_C005301 | CUSTOMERS
SYS_C005302 | CUSTOMERS
SYS_C005303 | CUSTOMERS
SYS_C005304 | CUSTOMERS
SYS_C005305 | CUSTOMERS
SYS_C005306 | CUSTOMERS
SYS_C005307 | CUSTOMERS
SYS_C005308 | CUSTOMERS
SYS_C005309 | CUSTOMERS
SYS_C005310 | CUSTOMERS
SYS_C005311 | CUSTOMERS
SYS_C005312 | CUSTOMERS
SYS_C005314 | COUNTRIES
SYS_C005315 | COUNTRIES
SYS_C005316 | COUNTRIES
SYS_C005317 | COUNTRIES
SYS_C005318 | COUNTRIES
SYS_C005319 | COUNTRIES
SYS_C005320 | COUNTRIES
SYS_C005321 | COUNTRIES
SYS_C005322 | COUNTRIES
SYS_C005324 | SUPPLEMENTARY_DEMOGRAPHICS
SYS_C005326 | MVIEW$_EXCEPTIONS
SYS_C005327 | MVIEW$_EXCEPTIONS
SYS_C005328 | MVIEW$_EXCEPTIONS
SYS_C005329 | MVIEW$_EXCEPTIONS
SYS_C005330 | MVIEW$_EXCEPTIONS
SYS_C005331 | CAL_MONTH_SALES_MV
SYS_C005332 | FWEEK_PSCAT_SALES_MV
SYS_C005333 | FWEEK_PSCAT_SALES_MV
SYS_C005334 | FWEEK_PSCAT_SALES_MV
SYS_C005335 | FWEEK_PSCAT_SALES_MV
SYS_C005367 | DR$SUP_TEXT_IDX$I
SYS_C005368 | DR$SUP_TEXT_IDX$I
SYS_C005369 | DR$SUP_TEXT_IDX$I
SYS_C005370 | DR$SUP_TEXT_IDX$I
SYS_C005371 | DR$SUP_TEXT_IDX$I
SYS_C005373 | DR$SUP_TEXT_IDX$N
SYS_IOT_TOP_52330 | DR$SUP_TEXT_IDX$K
SYS_IOT_TOP_52335 | DR$SUP_TEXT_IDX$N
TIMES_PK | TIMES
Total: 145 constraints(s)

Snapshots

Name | Tablespace | Refresh Method | Type | Status | PREBUILT | REWRITE_ENABLED
CAL_MONTH_SALES_MV | EXAMPLE | AGGREGATE | FORCE | UNKNOWN | YES | Y
FWEEK_PSCAT_SALES_MV | EXAMPLE | AGGREGATE | FORCE | UNKNOWN | YES | Y
Total: 2 snapshot(s)

Measure folders

Name | Description | Parent | Catalog id
SH_CAT | Sample Schema: Sales History Business Area |  | 122
Total: 1 measure folder(s)

Dimensions

Name | Valid | Plurar name | Display name | Description | Default display hierarchy | Dimension type
CHANNELS_DIM |  | Channels | Channel | Channel Values | CHANNEL_ROLLUP | HIER
CUSTOMERS_DIM |  | Customers | Customer | Customer Dimension Values | GEOG_ROLLUP | HIER
PRODUCTS_DIM |  | Products | Product | Product Dimension Values | PROD_ROLLUP | HIER
PROMOTIONS_DIM |  | Promotions | Promotions | Promotion Values | PROMO_ROLLUP | HIER
TIMES_DIM |  | Times | Time | Time Dimension Values | CAL_ROLLUP | HIER
Total: 5 dimension(s)

Cubes

Name | Valid | Display name | Fact Table Owner | Fact Table | Description
COST_CUBE |  | Cost Analysis | SH | COSTS | Unit Cost, Unit Price < TIMES PRODUCTS CHANNELS PROMOTIONS>
SALES_CUBE |  | Sales Analysis | SH | SALES | Sales amount, Sales quantity <TIMES CHANNELS PRODUCTS CUSTOMERS PROMOTIONS >
Total: 2 cube(s)

See Also

Server overview


List of tables

Tables

Name | Status | Tablespace | Logging | Partitioned | Cached | Locking | Description
CHANNELS | VALID | EXAMPLE | N |  | ENABLED | 2000 | small dimension table
COSTS | VALID |  | N |  | ENABLED | 2000 |
COUNTRIES | VALID | EXAMPLE | N |  | ENABLED | 2000 | country dimension table (snowflake)
CUSTOMERS | VALID | EXAMPLE | N |  | ENABLED | 2000 | dimension table
DR$SUP_TEXT_IDX$I | VALID | EXAMPLE | N |  | ENABLED |  |
DR$SUP_TEXT_IDX$K | VALID |  | N | IOT | ENABLED |  |
DR$SUP_TEXT_IDX$N | VALID |  | N | IOT | ENABLED |  |
DR$SUP_TEXT_IDX$R | VALID | EXAMPLE | N |  | ENABLED |  |
MVIEW$_EXCEPTIONS | VALID | EXAMPLE | N |  | ENABLED | 0 |
PRODUCTS | VALID | EXAMPLE | N |  | ENABLED | 2000 | dimension table
PROMOTIONS | VALID | EXAMPLE | N |  | ENABLED | 2000 | dimension table without a PK-FK relationship with the facts table, to show outer join functionality
SALES | VALID |  | N |  | ENABLED | 2000 | facts table, without a primary key; all rows are uniquely identified by the combination of all foreign keys
SALES_TRANSACTIONS_EXT | VALID |  | N |  | ENABLED | 0 |
SUPPLEMENTARY_DEMOGRAPHICS | VALID | EXAMPLE | N |  | ENABLED | 2000 |
TIMES | VALID | EXAMPLE | N |  | ENABLED | 2000 | Time dimension table to support multiple hierarchies and materialized views
Total: 15 table(s)

See Also

Schema overview


Table: CHANNELS

Properties

Name: | CHANNELS
Status: | VALID
Tablespace: | EXAMPLE
Logging: | N
Partitioned: |
Cached: | ENABLED
Locking: | 2000
IOT type: |
Object type: |
Type owner: |
Type: | N
Temporary: | N
Secondary: | NO
Nested: | DEFAULT
Buffer pool: | DISABLED
Row movement: | YES
Index Only Table: |
Minimum % of free space: | 10
Minimum % of udes space: |
Initial transactions: | 1
Max transactions: | 65536
Initial extent size, bytes: |
Secondary extent size, bytes: | 1
Min extents: | 2147483645
Max extents: |
% increase in extent: |
Process free list: |
Process free list groups: | NO
Backee up: | 5
Rows: | 4
Used blocks: | 0
Empty blocks: | 0
Average free space: | 0
Chained rows: | 40
Average row length: | 0
Average freespace on a freelist: | 0
Blocks on a freelist: | 1
Threds per instance: | 1
Instances: | N
Sample size: | 03.15.2007
Last analysed: | NO
Global statistics: | YES
User statistics: | NO
Duration: |
Skip corrupt blocks: | DISABLED
Monitoring: | YES
Cluster owner: |
Dependencies: | DISABLED
SizeMB: | 0,06
Extents: | 1
SizeBytes: | 65536
Description: | small dimension table

Columns

Name | Type | Length | Nchar Length | Precision | Scale | NULL | Default | Description
CHANNEL_ID | NUMBER |  |  |  |  | N |  | primary key column
CHANNEL_DESC | VARCHAR2 | 20 | 20 |  |  | N |  | e.g. telesales, internet, catalog
CHANNEL_CLASS | VARCHAR2 | 20 | 20 |  |  | N |  | e.g. direct, indirect
CHANNEL_CLASS_ID | NUMBER |  |  |  |  | N |  |
CHANNEL_TOTAL | VARCHAR2 | 13 | 13 |  |  | N |  |
CHANNEL_TOTAL_ID | NUMBER |  |  |  |  | N |  |
Total: 6 column(s)

Indexes

Name | Type | Unique
CHANNELS_PK | NORMAL | UNIQUE
Total: 1 index(s)

Constraints

Name | Type | Status | Delete rule | Defferable | Deffered
CHANNELS_PK | Primary Key | Enabled |  | Not Deferrable | Immediate
SYS_C005279 | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005280 | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005281 | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005282 | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005283 | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005284 | Check | Enabled |  | Not Deferrable | Immediate
Total: 7 constraints

Grants

Privilage | Grantee | Grantable | Grantor
SELECT | BI | NO | SH
Total: 1 grants

Referenced tables

Name | Owner | Constraint | DELETE_RULE
COSTS | SH | COSTS_CHANNEL_FK | NO ACTION
SALES | SH | SALES_CHANNEL_FK | NO ACTION
Total: 2 referenced table(s)

Table used by

Owner | Name | Type
BI | CHANNELS | SYNONYM
SH | CHANNELS_DIM | DIMENSION
Total: 2 used by reference(s)

DDL

CREATE TABLE "SH"."CHANNELS"
( "CHANNEL_ID" NUMBER NOT NULL ENABLE,
"CHANNEL_DESC" VARCHAR2(20) NOT NULL ENABLE,
"CHANNEL_CLASS" VARCHAR2(20) NOT NULL ENABLE,
"CHANNEL_CLASS_ID" NUMBER NOT NULL ENABLE,
"CHANNEL_TOTAL" VARCHAR2(13) NOT NULL ENABLE,
"CHANNEL_TOTAL_ID" NUMBER NOT NULL ENABLE,
CONSTRAINT "CHANNELS_PK" PRIMARY KEY ("CHANNEL_ID")
USING INDEX PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING COMPUTE STATISTICS
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" ENABLE NOVALIDATE
) PCTFREE 10 PCTUSED 40 INITRANS 1 MAXTRANS 255 NOCOMPRESS NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE"

See Also

List of tables


List of indexes

Indexes

Name | Type | Unique
CHANNELS_PK | NORMAL | UNIQUE
Total: 1 index(s)

See Also

Table [CHANNELS]


Index: CHANNELS_PK on table CHANNELS

Properties

Name: | CHANNELS_PK
Type: | NORMAL
Unique: | UNIQUE
Tablespace: | EXAMPLE
Status: | VALID
Table owner: | SH
Table name: | CHANNELS
Temporary: | No
Join Index: | No
Initial extent size: | 65536
Secondary extent size: |
Min extents: | 1
Max extents: | 2147483645
Percent encrease: |
Distinct keys: | 5
Minimum free %: | 10

Index Columns

Name | Length | Descend
CHANNEL_ID | 22 | ASC
Total: 1 column(s)

DDL

CREATE UNIQUE INDEX "SH"."CHANNELS_PK" ON "SH"."CHANNELS" ("CHANNEL_ID")
PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING COMPUTE STATISTICS
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE"

See Also

List of indexes


List of constraints

Constraints

Name | Type | Status | Delete rule | Defferable | Deffered
CHANNELS_PK | Primary Key | Enabled |  | Not Deferrable | Immediate
SYS_C005279 | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005280 | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005281 | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005282 | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005283 | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005284 | Check | Enabled |  | Not Deferrable | Immediate
Total: 7 constraint(s)

See Also

Table [CHANNELS]


Constraint: CHANNELS_PK on table CHANNELS

Properties

Name: | CHANNELS_PK
Type: | Primary Key
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
CHANNEL_ID
Total: 1 column(s)

DDL

ALTER TABLE "SH"."CHANNELS" ADD CONSTRAINT "CHANNELS_PK" PRIMARY KEY ("CHANNEL_ID")
USING INDEX PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING COMPUTE STATISTICS
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" ENABLE NOVALIDATE

See Also

List of constraints
Table [CHANNELS]


Constraint: SYS_C005279 on table CHANNELS

Properties

Name: | SYS_C005279
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
CHANNEL_ID
Total: 1 column(s)

DDL

ALTER TABLE "SH"."CHANNELS" MODIFY ("CHANNEL_ID" NOT NULL ENABLE)

See Also

List of constraints
Table [CHANNELS]


Constraint: SYS_C005280 on table CHANNELS

Properties

Name: | SYS_C005280
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
CHANNEL_DESC
Total: 1 column(s)

DDL

ALTER TABLE "SH"."CHANNELS" MODIFY ("CHANNEL_DESC" NOT NULL ENABLE)

See Also

List of constraints
Table [CHANNELS]


Constraint: SYS_C005281 on table CHANNELS

Properties

Name: | SYS_C005281
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
CHANNEL_CLASS
Total: 1 column(s)

DDL

ALTER TABLE "SH"."CHANNELS" MODIFY ("CHANNEL_CLASS" NOT NULL ENABLE)

See Also

List of constraints
Table [CHANNELS]


Constraint: SYS_C005282 on table CHANNELS

Properties

Name: | SYS_C005282
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
CHANNEL_CLASS_ID
Total: 1 column(s)

DDL

ALTER TABLE "SH"."CHANNELS" MODIFY ("CHANNEL_CLASS_ID" NOT NULL ENABLE)

See Also

List of constraints
Table [CHANNELS]


Constraint: SYS_C005283 on table CHANNELS

Properties

Name: | SYS_C005283
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
CHANNEL_TOTAL
Total: 1 column(s)

DDL

ALTER TABLE "SH"."CHANNELS" MODIFY ("CHANNEL_TOTAL" NOT NULL ENABLE)

See Also

List of constraints
Table [CHANNELS]


Constraint: SYS_C005284 on table CHANNELS

Properties

Name: | SYS_C005284
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
CHANNEL_TOTAL_ID
Total: 1 column(s)

DDL

ALTER TABLE "SH"."CHANNELS" MODIFY ("CHANNEL_TOTAL_ID" NOT NULL ENABLE)

See Also

List of constraints
Table [CHANNELS]


Table: COSTS

Properties

Name: | COSTS
Status: | VALID
Tablespace: |
Logging: | N
Partitioned: |
Cached: | ENABLED
Locking: | 2000
IOT type: |
Object type: |
Type owner: |
Type: | N
Temporary: | N
Secondary: | NO
Nested: |
Buffer pool: | DISABLED
Row movement: | YES
Index Only Table: |
Minimum % of free space: |
Minimum % of udes space: |
Initial transactions: |
Max transactions: |
Initial extent size, bytes: |
Secondary extent size, bytes: |
Min extents: |
Max extents: |
% increase in extent: |
Process free list: |
Process free list groups: |
Backee up: | 82112
Rows: | 266
Used blocks: | 0
Empty blocks: | 0
Average free space: | 0
Chained rows: | 26
Average row length: | 0
Average freespace on a freelist: | 0
Blocks on a freelist: | 1
Threds per instance: | 1
Instances: | N
Sample size: | 03.15.2007
Last analysed: | YES
Global statistics: | YES
User statistics: | NO
Duration: |
Skip corrupt blocks: | DISABLED
Monitoring: | YES
Cluster owner: |
Dependencies: | DISABLED
SizeMB: | 3,13
Extents: | 50
SizeBytes: | 3276800
Description: |

Columns

Name | Type | Length | Nchar Length | Precision | Scale | NULL | Default | Description
PROD_ID | NUMBER |  |  |  |  | N |  |
TIME_ID | DATE | 7 |  |  |  | N |  |
PROMO_ID | NUMBER |  |  |  |  | N |  |
CHANNEL_ID | NUMBER |  |  |  |  | N |  |
UNIT_COST | NUMBER | 12 |  | 10 | 2 | N |  |
UNIT_PRICE | NUMBER | 12 |  | 10 | 2 | N |  |
Total: 6 column(s)

Indexes

Name | Type | Unique
COSTS_PROD_BIX | BITMAP | NONUNIQUE
COSTS_TIME_BIX | BITMAP | NONUNIQUE
Total: 2 index(s)

Constraints

Name | Type | Status | Delete rule | Defferable | Deffered
COSTS_CHANNEL_FK | Referential Integrity | Disabled | No Action | Not Deferrable | Immediate
COSTS_PRODUCT_FK | Referential Integrity | Enabled | No Action | Not Deferrable | Immediate
COSTS_PROMO_FK | Referential Integrity | Disabled | No Action | Not Deferrable | Immediate
COSTS_TIME_FK | Referential Integrity | Enabled | No Action | Not Deferrable | Immediate
SYS_C005216 | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005217 | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005218 | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005219 | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005220 | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005221 | Check | Enabled |  | Not Deferrable | Immediate
Total: 10 constraints

Grants

Privilage | Grantee | Grantable | Grantor
SELECT | BI | NO | SH
Total: 1 grants

Partitions

Name | HightValue | Hight Value Length | Tablespace
COSTS_1995 | TO_DATE(' 1996-01-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83 | EXAMPLE
COSTS_1996 | TO_DATE(' 1997-01-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83 | EXAMPLE
COSTS_H1_1997 | TO_DATE(' 1997-07-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83 | EXAMPLE
COSTS_H2_1997 | TO_DATE(' 1998-01-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83 | EXAMPLE
COSTS_Q1_1998 | TO_DATE(' 1998-04-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83 | EXAMPLE
COSTS_Q2_1998 | TO_DATE(' 1998-07-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83 | EXAMPLE
COSTS_Q3_1998 | TO_DATE(' 1998-10-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83 | EXAMPLE
COSTS_Q4_1998 | TO_DATE(' 1999-01-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83 | EXAMPLE
COSTS_Q1_1999 | TO_DATE(' 1999-04-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83 | EXAMPLE
COSTS_Q2_1999 | TO_DATE(' 1999-07-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83 | EXAMPLE
COSTS_Q3_1999 | TO_DATE(' 1999-10-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83 | EXAMPLE
COSTS_Q4_1999 | TO_DATE(' 2000-01-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83 | EXAMPLE
COSTS_Q1_2000 | TO_DATE(' 2000-04-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83 | EXAMPLE
COSTS_Q2_2000 | TO_DATE(' 2000-07-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83 | EXAMPLE
COSTS_Q3_2000 | TO_DATE(' 2000-10-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83 | EXAMPLE
COSTS_Q4_2000 | TO_DATE(' 2001-01-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83 | EXAMPLE
COSTS_Q1_2001 | TO_DATE(' 2001-04-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83 | EXAMPLE
COSTS_Q2_2001 | TO_DATE(' 2001-07-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83 | EXAMPLE
COSTS_Q3_2001 | TO_DATE(' 2001-10-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83 | EXAMPLE
COSTS_Q4_2001 | TO_DATE(' 2002-01-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83 | EXAMPLE
COSTS_Q1_2002 | TO_DATE(' 2002-04-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83 | EXAMPLE
COSTS_Q2_2002 | TO_DATE(' 2002-07-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83 | EXAMPLE
COSTS_Q3_2002 | TO_DATE(' 2002-10-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83 | EXAMPLE
COSTS_Q4_2002 | TO_DATE(' 2003-01-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83 | EXAMPLE
COSTS_Q1_2003 | TO_DATE(' 2003-04-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83 | EXAMPLE
COSTS_Q2_2003 | TO_DATE(' 2003-07-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83 | EXAMPLE
COSTS_Q3_2003 | TO_DATE(' 2003-10-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83 | EXAMPLE
COSTS_Q4_2003 | TO_DATE(' 2004-01-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83 | EXAMPLE
Total: 28 partition(s)

Partitioned columns

Name | Position
TIME_ID | 1
Total: 1 partitioned column(s)

Table References

Name | Owner | Constraint | DELETE_RULE
CHANNELS | SH | COSTS_CHANNEL_FK |
PRODUCTS | SH | COSTS_PRODUCT_FK |
PROMOTIONS | SH | COSTS_PROMO_FK |
TIMES | SH | COSTS_TIME_FK |
Total: 4 table reference(s)

Table used by

Owner | Name | Type
BI | COSTS | SYNONYM
SH | PROFITS | VIEW
Total: 2 used by reference(s)

DDL

CREATE TABLE "SH"."COSTS"
( "PROD_ID" NUMBER NOT NULL ENABLE,
"TIME_ID" DATE NOT NULL ENABLE,
"PROMO_ID" NUMBER NOT NULL ENABLE,
"CHANNEL_ID" NUMBER NOT NULL ENABLE,
"UNIT_COST" NUMBER(10,2) NOT NULL ENABLE,
"UNIT_PRICE" NUMBER(10,2) NOT NULL ENABLE,
CONSTRAINT "COSTS_CHANNEL_FK" FOREIGN KEY ("CHANNEL_ID")
REFERENCES "SH"."CHANNELS" ("CHANNEL_ID") DISABLE,
CONSTRAINT "COSTS_TIME_FK" FOREIGN KEY ("TIME_ID")
REFERENCES "SH"."TIMES" ("TIME_ID") ENABLE NOVALIDATE,
CONSTRAINT "COSTS_PRODUCT_FK" FOREIGN KEY ("PROD_ID")
REFERENCES "SH"."PRODUCTS" ("PROD_ID") ENABLE NOVALIDATE,
CONSTRAINT "COSTS_PROMO_FK" FOREIGN KEY ("PROMO_ID")
REFERENCES "SH"."PROMOTIONS" ("PROMO_ID") DISABLE
) PCTFREE 5 PCTUSED 40 INITRANS 1 MAXTRANS 255 NOCOMPRESS NOLOGGING
STORAGE(
BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE"
PARTITION BY RANGE ("TIME_ID")
(PARTITION "COSTS_1995" VALUES LESS THAN (TO_DATE(' 1996-01-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN'))
PCTFREE 0 PCTUSED 40 INITRANS 1 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" COMPRESS ,
PARTITION "COSTS_1996" VALUES LESS THAN (TO_DATE(' 1997-01-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN'))
PCTFREE 0 PCTUSED 40 INITRANS 1 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" COMPRESS ,
PARTITION "COSTS_H1_1997" VALUES LESS THAN (TO_DATE(' 1997-07-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN'))
PCTFREE 0 PCTUSED 40 INITRANS 1 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" COMPRESS ,
PARTITION "COSTS_H2_1997" VALUES LESS THAN (TO_DATE(' 1998-01-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN'))
PCTFREE 0 PCTUSED 40 INITRANS 1 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" COMPRESS ,
PARTITION "COSTS_Q1_1998" VALUES LESS THAN (TO_DATE(' 1998-04-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN'))
PCTFREE 0 PCTUSED 40 INITRANS 1 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" COMPRESS ,
PARTITION "COSTS_Q2_1998" VALUES LESS THAN (TO_DATE(' 1998-07-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN'))
PCTFREE 0 PCTUSED 40 INITRANS 1 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" COMPRESS ,
PARTITION "COSTS_Q3_1998" VALUES LESS THAN (TO_DATE(' 1998-10-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN'))
PCTFREE 0 PCTUSED 40 INITRANS 1 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" COMPRESS ,
PARTITION "COSTS_Q4_1998" VALUES LESS THAN (TO_DATE(' 1999-01-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN'))
PCTFREE 0 PCTUSED 40 INITRANS 1 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" COMPRESS ,
PARTITION "COSTS_Q1_1999" VALUES LESS THAN (TO_DATE(' 1999-04-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN'))
PCTFREE 0 PCTUSED 40 INITRANS 1 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" COMPRESS ,
PARTITION "COSTS_Q2_1999" VALUES LESS THAN (TO_DATE(' 1999-07-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN'))
PCTFREE 0 PCTUSED 40 INITRANS 1 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" COMPRESS ,
PARTITION "COSTS_Q3_1999" VALUES LESS THAN (TO_DATE(' 1999-10-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN'))
PCTFREE 0 PCTUSED 40 INITRANS 1 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" COMPRESS ,
PARTITION "COSTS_Q4_1999" VALUES LESS THAN (TO_DATE(' 2000-01-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN'))
PCTFREE 0 PCTUSED 40 INITRANS 1 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" COMPRESS ,
PARTITION "COSTS_Q1_2000" VALUES LESS THAN (TO_DATE(' 2000-04-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN'))
PCTFREE 0 PCTUSED 40 INITRANS 1 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" COMPRESS ,
PARTITION "COSTS_Q2_2000" VALUES LESS THAN (TO_DATE(' 2000-07-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN'))
PCTFREE 0 PCTUSED 40 INITRANS 1 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" COMPRESS ,
PARTITION "COSTS_Q3_2000" VALUES LESS THAN (TO_DATE(' 2000-10-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN'))
PCTFREE 0 PCTUSED 40 INITRANS 1 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" COMPRESS ,
PARTITION "COSTS_Q4_2000" VALUES LESS THAN (TO_DATE(' 2001-01-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN'))
PCTFREE 0 PCTUSED 40 INITRANS 1 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" COMPRESS ,
PARTITION "COSTS_Q1_2001" VALUES LESS THAN (TO_DATE(' 2001-04-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN'))
PCTFREE 0 PCTUSED 40 INITRANS 1 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" COMPRESS ,
PARTITION "COSTS_Q2_2001" VALUES LESS THAN (TO_DATE(' 2001-07-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN'))
PCTFREE 0 PCTUSED 40 INITRANS 1 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" COMPRESS ,
PARTITION "COSTS_Q3_2001" VALUES LESS THAN (TO_DATE(' 2001-10-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN'))
PCTFREE 0 PCTUSED 40 INITRANS 1 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" COMPRESS ,
PARTITION "COSTS_Q4_2001" VALUES LESS THAN (TO_DATE(' 2002-01-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN'))
PCTFREE 0 PCTUSED 40 INITRANS 1 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" COMPRESS ,
PARTITION "COSTS_Q1_2002" VALUES LESS THAN (TO_DATE(' 2002-04-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN'))
PCTFREE 0 PCTUSED 40 INITRANS 1 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" COMPRESS ,
PARTITION "COSTS_Q2_2002" VALUES LESS THAN (TO_DATE(' 2002-07-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN'))
PCTFREE 0 PCTUSED 40 INITRANS 1 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" COMPRESS ,
PARTITION "COSTS_Q3_2002" VALUES LESS THAN (TO_DATE(' 2002-10-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN'))
PCTFREE 0 PCTUSED 40 INITRANS 1 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" COMPRESS ,
PARTITION "COSTS_Q4_2002" VALUES LESS THAN (TO_DATE(' 2003-01-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN'))
PCTFREE 0 PCTUSED 40 INITRANS 1 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" COMPRESS ,
PARTITION "COSTS_Q1_2003" VALUES LESS THAN (TO_DATE(' 2003-04-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN'))
PCTFREE 0 PCTUSED 40 INITRANS 1 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" COMPRESS ,
PARTITION "COSTS_Q2_2003" VALUES LESS THAN (TO_DATE(' 2003-07-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN'))
PCTFREE 0 PCTUSED 40 INITRANS 1 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" COMPRESS ,
PARTITION "COSTS_Q3_2003" VALUES LESS THAN (TO_DATE(' 2003-10-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN'))
PCTFREE 0 PCTUSED 40 INITRANS 1 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" COMPRESS ,
PARTITION "COSTS_Q4_2003" VALUES LESS THAN (TO_DATE(' 2004-01-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN'))
PCTFREE 5 PCTUSED 40 INITRANS 1 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" NOCOMPRESS )

See Also

List of tables


List of indexes

Indexes

Name | Type | Unique
COSTS_PROD_BIX | BITMAP | NONUNIQUE
COSTS_TIME_BIX | BITMAP | NONUNIQUE
Total: 2 index(s)

See Also

Table [COSTS]


Index: COSTS_PROD_BIX on table COSTS

Properties

Name: | COSTS_PROD_BIX
Type: | BITMAP
Unique: | NONUNIQUE
Tablespace: |
Status: | N/A
Table owner: | SH
Table name: | COSTS
Temporary: | No
Join Index: | No
Initial extent size: |
Secondary extent size: |
Min extents: |
Max extents: |
Percent encrease: |
Distinct keys: | 72
Minimum free %: |

Index Columns

Name | Length | Descend
PROD_ID | 22 | ASC
Total: 1 column(s)

Partitions

Name | Tablespace | Hight Value | Hight Value Length
COSTS_1995 | EXAMPLE | TO_DATE(' 1996-01-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83
COSTS_1996 | EXAMPLE | TO_DATE(' 1997-01-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83
COSTS_H1_1997 | EXAMPLE | TO_DATE(' 1997-07-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83
COSTS_H2_1997 | EXAMPLE | TO_DATE(' 1998-01-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83
COSTS_Q1_1998 | EXAMPLE | TO_DATE(' 1998-04-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83
COSTS_Q2_1998 | EXAMPLE | TO_DATE(' 1998-07-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83
COSTS_Q3_1998 | EXAMPLE | TO_DATE(' 1998-10-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83
COSTS_Q4_1998 | EXAMPLE | TO_DATE(' 1999-01-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83
COSTS_Q1_1999 | EXAMPLE | TO_DATE(' 1999-04-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83
COSTS_Q2_1999 | EXAMPLE | TO_DATE(' 1999-07-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83
COSTS_Q3_1999 | EXAMPLE | TO_DATE(' 1999-10-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83
COSTS_Q4_1999 | EXAMPLE | TO_DATE(' 2000-01-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83
COSTS_Q1_2000 | EXAMPLE | TO_DATE(' 2000-04-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83
COSTS_Q2_2000 | EXAMPLE | TO_DATE(' 2000-07-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83
COSTS_Q3_2000 | EXAMPLE | TO_DATE(' 2000-10-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83
COSTS_Q4_2000 | EXAMPLE | TO_DATE(' 2001-01-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83
COSTS_Q1_2001 | EXAMPLE | TO_DATE(' 2001-04-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83
COSTS_Q2_2001 | EXAMPLE | TO_DATE(' 2001-07-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83
COSTS_Q3_2001 | EXAMPLE | TO_DATE(' 2001-10-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83
COSTS_Q4_2001 | EXAMPLE | TO_DATE(' 2002-01-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83
COSTS_Q1_2002 | EXAMPLE | TO_DATE(' 2002-04-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83
COSTS_Q2_2002 | EXAMPLE | TO_DATE(' 2002-07-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83
COSTS_Q3_2002 | EXAMPLE | TO_DATE(' 2002-10-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83
COSTS_Q4_2002 | EXAMPLE | TO_DATE(' 2003-01-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83
COSTS_Q1_2003 | EXAMPLE | TO_DATE(' 2003-04-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83
COSTS_Q2_2003 | EXAMPLE | TO_DATE(' 2003-07-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83
COSTS_Q3_2003 | EXAMPLE | TO_DATE(' 2003-10-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83
COSTS_Q4_2003 | EXAMPLE | TO_DATE(' 2004-01-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83
Total: 28 partition(s)

Partitioned columns

Name
TIME_ID
Total: 1 partitioned column(s)

DDL

CREATE BITMAP INDEX "SH"."COSTS_PROD_BIX" ON "SH"."COSTS" ("PROD_ID")
PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING
STORAGE(
BUFFER_POOL DEFAULT) LOCAL
(PARTITION "COSTS_1995"
PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" ,
PARTITION "COSTS_1996"
PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" ,
PARTITION "COSTS_H1_1997"
PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" ,
PARTITION "COSTS_H2_1997"
PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" ,
PARTITION "COSTS_Q1_1998"
PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" ,
PARTITION "COSTS_Q2_1998"
PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" ,
PARTITION "COSTS_Q3_1998"
PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" ,
PARTITION "COSTS_Q4_1998"
PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" ,
PARTITION "COSTS_Q1_1999"
PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" ,
PARTITION "COSTS_Q2_1999"
PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" ,
PARTITION "COSTS_Q3_1999"
PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" ,
PARTITION "COSTS_Q4_1999"
PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" ,
PARTITION "COSTS_Q1_2000"
PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" ,
PARTITION "COSTS_Q2_2000"
PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" ,
PARTITION "COSTS_Q3_2000"
PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" ,
PARTITION "COSTS_Q4_2000"
PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" ,
PARTITION "COSTS_Q1_2001"
PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" ,
PARTITION "COSTS_Q2_2001"
PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" ,
PARTITION "COSTS_Q3_2001"
PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" ,
PARTITION "COSTS_Q4_2001"
PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" ,
PARTITION "COSTS_Q1_2002"
PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" ,
PARTITION "COSTS_Q2_2002"
PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" ,
PARTITION "COSTS_Q3_2002"
PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" ,
PARTITION "COSTS_Q4_2002"
PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" ,
PARTITION "COSTS_Q1_2003"
PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" ,
PARTITION "COSTS_Q2_2003"
PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" ,
PARTITION "COSTS_Q3_2003"
PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" ,
PARTITION "COSTS_Q4_2003"
PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" )

See Also

List of indexes


Index: COSTS_TIME_BIX on table COSTS

Properties

Name: | COSTS_TIME_BIX
Type: | BITMAP
Unique: | NONUNIQUE
Tablespace: |
Status: | N/A
Table owner: | SH
Table name: | COSTS
Temporary: | No
Join Index: | No
Initial extent size: |
Secondary extent size: |
Min extents: |
Max extents: |
Percent encrease: |
Distinct keys: | 1460
Minimum free %: |

Index Columns

Name | Length | Descend
TIME_ID | 7 | ASC
Total: 1 column(s)

Partitions

Name | Tablespace | Hight Value | Hight Value Length
COSTS_1995 | EXAMPLE | TO_DATE(' 1996-01-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83
COSTS_1996 | EXAMPLE | TO_DATE(' 1997-01-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83
COSTS_H1_1997 | EXAMPLE | TO_DATE(' 1997-07-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83
COSTS_H2_1997 | EXAMPLE | TO_DATE(' 1998-01-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83
COSTS_Q1_1998 | EXAMPLE | TO_DATE(' 1998-04-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83
COSTS_Q2_1998 | EXAMPLE | TO_DATE(' 1998-07-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83
COSTS_Q3_1998 | EXAMPLE | TO_DATE(' 1998-10-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83
COSTS_Q4_1998 | EXAMPLE | TO_DATE(' 1999-01-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83
COSTS_Q1_1999 | EXAMPLE | TO_DATE(' 1999-04-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83
COSTS_Q2_1999 | EXAMPLE | TO_DATE(' 1999-07-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83
COSTS_Q3_1999 | EXAMPLE | TO_DATE(' 1999-10-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83
COSTS_Q4_1999 | EXAMPLE | TO_DATE(' 2000-01-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83
COSTS_Q1_2000 | EXAMPLE | TO_DATE(' 2000-04-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83
COSTS_Q2_2000 | EXAMPLE | TO_DATE(' 2000-07-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83
COSTS_Q3_2000 | EXAMPLE | TO_DATE(' 2000-10-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83
COSTS_Q4_2000 | EXAMPLE | TO_DATE(' 2001-01-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83
COSTS_Q1_2001 | EXAMPLE | TO_DATE(' 2001-04-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83
COSTS_Q2_2001 | EXAMPLE | TO_DATE(' 2001-07-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83
COSTS_Q3_2001 | EXAMPLE | TO_DATE(' 2001-10-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83
COSTS_Q4_2001 | EXAMPLE | TO_DATE(' 2002-01-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83
COSTS_Q1_2002 | EXAMPLE | TO_DATE(' 2002-04-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83
COSTS_Q2_2002 | EXAMPLE | TO_DATE(' 2002-07-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83
COSTS_Q3_2002 | EXAMPLE | TO_DATE(' 2002-10-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83
COSTS_Q4_2002 | EXAMPLE | TO_DATE(' 2003-01-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83
COSTS_Q1_2003 | EXAMPLE | TO_DATE(' 2003-04-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83
COSTS_Q2_2003 | EXAMPLE | TO_DATE(' 2003-07-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83
COSTS_Q3_2003 | EXAMPLE | TO_DATE(' 2003-10-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83
COSTS_Q4_2003 | EXAMPLE | TO_DATE(' 2004-01-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83
Total: 28 partition(s)

Partitioned columns

Name
TIME_ID
Total: 1 partitioned column(s)

DDL

CREATE BITMAP INDEX "SH"."COSTS_TIME_BIX" ON "SH"."COSTS" ("TIME_ID")
PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING
STORAGE(
BUFFER_POOL DEFAULT) LOCAL
(PARTITION "COSTS_1995"
PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" ,
PARTITION "COSTS_1996"
PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" ,
PARTITION "COSTS_H1_1997"
PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" ,
PARTITION "COSTS_H2_1997"
PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" ,
PARTITION "COSTS_Q1_1998"
PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" ,
PARTITION "COSTS_Q2_1998"
PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" ,
PARTITION "COSTS_Q3_1998"
PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" ,
PARTITION "COSTS_Q4_1998"
PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" ,
PARTITION "COSTS_Q1_1999"
PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" ,
PARTITION "COSTS_Q2_1999"
PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" ,
PARTITION "COSTS_Q3_1999"
PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" ,
PARTITION "COSTS_Q4_1999"
PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" ,
PARTITION "COSTS_Q1_2000"
PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" ,
PARTITION "COSTS_Q2_2000"
PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" ,
PARTITION "COSTS_Q3_2000"
PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" ,
PARTITION "COSTS_Q4_2000"
PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" ,
PARTITION "COSTS_Q1_2001"
PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" ,
PARTITION "COSTS_Q2_2001"
PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" ,
PARTITION "COSTS_Q3_2001"
PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" ,
PARTITION "COSTS_Q4_2001"
PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" ,
PARTITION "COSTS_Q1_2002"
PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" ,
PARTITION "COSTS_Q2_2002"
PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" ,
PARTITION "COSTS_Q3_2002"
PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" ,
PARTITION "COSTS_Q4_2002"
PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" ,
PARTITION "COSTS_Q1_2003"
PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" ,
PARTITION "COSTS_Q2_2003"
PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" ,
PARTITION "COSTS_Q3_2003"
PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" ,
PARTITION "COSTS_Q4_2003"
PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" )

See Also

List of indexes


List of constraints

Constraints

Name | Type | Status | Delete rule | Defferable | Deffered
COSTS_CHANNEL_FK | Referential Integrity | Disabled | No Action | Not Deferrable | Immediate
COSTS_PRODUCT_FK | Referential Integrity | Enabled | No Action | Not Deferrable | Immediate
COSTS_PROMO_FK | Referential Integrity | Disabled | No Action | Not Deferrable | Immediate
COSTS_TIME_FK | Referential Integrity | Enabled | No Action | Not Deferrable | Immediate
SYS_C005216 | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005217 | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005218 | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005219 | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005220 | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005221 | Check | Enabled |  | Not Deferrable | Immediate
Total: 10 constraint(s)

See Also

Table [COSTS]


Constraint: COSTS_CHANNEL_FK on table COSTS

Properties

Name: | COSTS_CHANNEL_FK
Type: | Referential Integrity
Status: | Disabled
Delete rule: | No Action
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: | SH
R Constraint: | CHANNELS_PK

Columns

Name
CHANNEL_ID
Total: 1 column(s)

Reference columns

Owner | Table | Column
SH | CHANNELS | CHANNEL_ID
Total: 1 reference column(s)

DDL

See Also

List of constraints
Table [COSTS]


Constraint: COSTS_PRODUCT_FK on table COSTS

Properties

Name: | COSTS_PRODUCT_FK
Type: | Referential Integrity
Status: | Enabled
Delete rule: | No Action
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: | SH
R Constraint: | PRODUCTS_PK

Columns

Name
PROD_ID
Total: 1 column(s)

Reference columns

Owner | Table | Column
SH | PRODUCTS | PROD_ID
Total: 1 reference column(s)

DDL

See Also

List of constraints
Table [COSTS]


Constraint: COSTS_PROMO_FK on table COSTS

Properties

Name: | COSTS_PROMO_FK
Type: | Referential Integrity
Status: | Disabled
Delete rule: | No Action
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: | SH
R Constraint: | PROMO_PK

Columns

Name
PROMO_ID
Total: 1 column(s)

Reference columns

Owner | Table | Column
SH | PROMOTIONS | PROMO_ID
Total: 1 reference column(s)

DDL

See Also

List of constraints
Table [COSTS]


Constraint: COSTS_TIME_FK on table COSTS

Properties

Name: | COSTS_TIME_FK
Type: | Referential Integrity
Status: | Enabled
Delete rule: | No Action
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: | SH
R Constraint: | TIMES_PK

Columns

Name
TIME_ID
Total: 1 column(s)

Reference columns

Owner | Table | Column
SH | TIMES | TIME_ID
Total: 1 reference column(s)

DDL

See Also

List of constraints
Table [COSTS]


Constraint: SYS_C005216 on table COSTS

Properties

Name: | SYS_C005216
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
PROD_ID
Total: 1 column(s)

DDL

ALTER TABLE "SH"."COSTS" MODIFY ("PROD_ID" NOT NULL ENABLE)

See Also

List of constraints
Table [COSTS]


Constraint: SYS_C005217 on table COSTS

Properties

Name: | SYS_C005217
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
TIME_ID
Total: 1 column(s)

DDL

ALTER TABLE "SH"."COSTS" MODIFY ("TIME_ID" NOT NULL ENABLE)

See Also

List of constraints
Table [COSTS]


Constraint: SYS_C005218 on table COSTS

Properties

Name: | SYS_C005218
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
PROMO_ID
Total: 1 column(s)

DDL

ALTER TABLE "SH"."COSTS" MODIFY ("PROMO_ID" NOT NULL ENABLE)

See Also

List of constraints
Table [COSTS]


Constraint: SYS_C005219 on table COSTS

Properties

Name: | SYS_C005219
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
CHANNEL_ID
Total: 1 column(s)

DDL

ALTER TABLE "SH"."COSTS" MODIFY ("CHANNEL_ID" NOT NULL ENABLE)

See Also

List of constraints
Table [COSTS]


Constraint: SYS_C005220 on table COSTS

Properties

Name: | SYS_C005220
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
UNIT_COST
Total: 1 column(s)

DDL

ALTER TABLE "SH"."COSTS" MODIFY ("UNIT_COST" NOT NULL ENABLE)

See Also

List of constraints
Table [COSTS]


Constraint: SYS_C005221 on table COSTS

Properties

Name: | SYS_C005221
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
UNIT_PRICE
Total: 1 column(s)

DDL

ALTER TABLE "SH"."COSTS" MODIFY ("UNIT_PRICE" NOT NULL ENABLE)

See Also

List of constraints
Table [COSTS]


List of partitions on [COSTS]

Partitions

Name | HightValue | Hight Value Length | Tablespace
COSTS_1995 | TO_DATE(' 1996-01-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83 | EXAMPLE
COSTS_1996 | TO_DATE(' 1997-01-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83 | EXAMPLE
COSTS_H1_1997 | TO_DATE(' 1997-07-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83 | EXAMPLE
COSTS_H2_1997 | TO_DATE(' 1998-01-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83 | EXAMPLE
COSTS_Q1_1998 | TO_DATE(' 1998-04-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83 | EXAMPLE
COSTS_Q2_1998 | TO_DATE(' 1998-07-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83 | EXAMPLE
COSTS_Q3_1998 | TO_DATE(' 1998-10-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83 | EXAMPLE
COSTS_Q4_1998 | TO_DATE(' 1999-01-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83 | EXAMPLE
COSTS_Q1_1999 | TO_DATE(' 1999-04-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83 | EXAMPLE
COSTS_Q2_1999 | TO_DATE(' 1999-07-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83 | EXAMPLE
COSTS_Q3_1999 | TO_DATE(' 1999-10-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83 | EXAMPLE
COSTS_Q4_1999 | TO_DATE(' 2000-01-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83 | EXAMPLE
COSTS_Q1_2000 | TO_DATE(' 2000-04-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83 | EXAMPLE
COSTS_Q2_2000 | TO_DATE(' 2000-07-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83 | EXAMPLE
COSTS_Q3_2000 | TO_DATE(' 2000-10-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83 | EXAMPLE
COSTS_Q4_2000 | TO_DATE(' 2001-01-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83 | EXAMPLE
COSTS_Q1_2001 | TO_DATE(' 2001-04-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83 | EXAMPLE
COSTS_Q2_2001 | TO_DATE(' 2001-07-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83 | EXAMPLE
COSTS_Q3_2001 | TO_DATE(' 2001-10-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83 | EXAMPLE
COSTS_Q4_2001 | TO_DATE(' 2002-01-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83 | EXAMPLE
COSTS_Q1_2002 | TO_DATE(' 2002-04-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83 | EXAMPLE
COSTS_Q2_2002 | TO_DATE(' 2002-07-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83 | EXAMPLE
COSTS_Q3_2002 | TO_DATE(' 2002-10-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83 | EXAMPLE
COSTS_Q4_2002 | TO_DATE(' 2003-01-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83 | EXAMPLE
COSTS_Q1_2003 | TO_DATE(' 2003-04-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83 | EXAMPLE
COSTS_Q2_2003 | TO_DATE(' 2003-07-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83 | EXAMPLE
COSTS_Q3_2003 | TO_DATE(' 2003-10-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83 | EXAMPLE
COSTS_Q4_2003 | TO_DATE(' 2004-01-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83 | EXAMPLE
Total: 28 partition(s)

See Also

Table [COSTS]


Partition: COSTS_1995 on table COSTS

Properties

Name: | COSTS_1995
Hight Value: | TO_DATE(' 1996-01-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN')
Hight Value Length: | 83
Tablespace: | EXAMPLE
Rows: | 0
Blocks: | 0
Empty Blocks: | 0
Average Space: | 0

See Also

List of partitions


Partition: COSTS_1996 on table COSTS

Properties

Name: | COSTS_1996
Hight Value: | TO_DATE(' 1997-01-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN')
Hight Value Length: | 83
Tablespace: | EXAMPLE
Rows: | 0
Blocks: | 0
Empty Blocks: | 0
Average Space: | 0

See Also

List of partitions


Partition: COSTS_H1_1997 on table COSTS

Properties

Name: | COSTS_H1_1997
Hight Value: | TO_DATE(' 1997-07-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN')
Hight Value Length: | 83
Tablespace: | EXAMPLE
Rows: | 0
Blocks: | 0
Empty Blocks: | 0
Average Space: | 0

See Also

List of partitions


Partition: COSTS_H2_1997 on table COSTS

Properties

Name: | COSTS_H2_1997
Hight Value: | TO_DATE(' 1998-01-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN')
Hight Value Length: | 83
Tablespace: | EXAMPLE
Rows: | 0
Blocks: | 0
Empty Blocks: | 0
Average Space: | 0

See Also

List of partitions


Partition: COSTS_Q1_1998 on table COSTS

Properties

Name: | COSTS_Q1_1998
Hight Value: | TO_DATE(' 1998-04-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN')
Hight Value Length: | 83
Tablespace: | EXAMPLE
Rows: | 4411
Blocks: | 14
Empty Blocks: | 0
Average Space: | 0

See Also

List of partitions


Partition: COSTS_Q2_1998 on table COSTS

Properties

Name: | COSTS_Q2_1998
Hight Value: | TO_DATE(' 1998-07-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN')
Hight Value Length: | 83
Tablespace: | EXAMPLE
Rows: | 2397
Blocks: | 9
Empty Blocks: | 0
Average Space: | 0

See Also

List of partitions


Partition: COSTS_Q3_1998 on table COSTS

Properties

Name: | COSTS_Q3_1998
Hight Value: | TO_DATE(' 1998-10-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN')
Hight Value Length: | 83
Tablespace: | EXAMPLE
Rows: | 4129
Blocks: | 14
Empty Blocks: | 0
Average Space: | 0

See Also

List of partitions


Partition: COSTS_Q4_1998 on table COSTS

Properties

Name: | COSTS_Q4_1998
Hight Value: | TO_DATE(' 1999-01-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN')
Hight Value Length: | 83
Tablespace: | EXAMPLE
Rows: | 4577
Blocks: | 15
Empty Blocks: | 0
Average Space: | 0

See Also

List of partitions


Partition: COSTS_Q1_1999 on table COSTS

Properties

Name: | COSTS_Q1_1999
Hight Value: | TO_DATE(' 1999-04-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN')
Hight Value Length: | 83
Tablespace: | EXAMPLE
Rows: | 5884
Blocks: | 19
Empty Blocks: | 0
Average Space: | 0

See Also

List of partitions


Partition: COSTS_Q2_1999 on table COSTS

Properties

Name: | COSTS_Q2_1999
Hight Value: | TO_DATE(' 1999-07-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN')
Hight Value Length: | 83
Tablespace: | EXAMPLE
Rows: | 4179
Blocks: | 14
Empty Blocks: | 0
Average Space: | 0

See Also

List of partitions


Partition: COSTS_Q3_1999 on table COSTS

Properties

Name: | COSTS_Q3_1999
Hight Value: | TO_DATE(' 1999-10-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN')
Hight Value Length: | 83
Tablespace: | EXAMPLE
Rows: | 4336
Blocks: | 14
Empty Blocks: | 0
Average Space: | 0

See Also

List of partitions


Partition: COSTS_Q4_1999 on table COSTS

Properties

Name: | COSTS_Q4_1999
Hight Value: | TO_DATE(' 2000-01-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN')
Hight Value Length: | 83
Tablespace: | EXAMPLE
Rows: | 5060
Blocks: | 16
Empty Blocks: | 0
Average Space: | 0

See Also

List of partitions


Partition: COSTS_Q1_2000 on table COSTS

Properties

Name: | COSTS_Q1_2000
Hight Value: | TO_DATE(' 2000-04-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN')
Hight Value Length: | 83
Tablespace: | EXAMPLE
Rows: | 3772
Blocks: | 13
Empty Blocks: | 0
Average Space: | 0

See Also

List of partitions


Partition: COSTS_Q2_2000 on table COSTS

Properties

Name: | COSTS_Q2_2000
Hight Value: | TO_DATE(' 2000-07-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN')
Hight Value Length: | 83
Tablespace: | EXAMPLE
Rows: | 3715
Blocks: | 12
Empty Blocks: | 0
Average Space: | 0

See Also

List of partitions


Partition: COSTS_Q3_2000 on table COSTS

Properties

Name: | COSTS_Q3_2000
Hight Value: | TO_DATE(' 2000-10-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN')
Hight Value Length: | 83
Tablespace: | EXAMPLE
Rows: | 4798
Blocks: | 16
Empty Blocks: | 0
Average Space: | 0

See Also

List of partitions


Partition: COSTS_Q4_2000 on table COSTS

Properties

Name: | COSTS_Q4_2000
Hight Value: | TO_DATE(' 2001-01-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN')
Hight Value Length: | 83
Tablespace: | EXAMPLE
Rows: | 5088
Blocks: | 16
Empty Blocks: | 0
Average Space: | 0

See Also

List of partitions


Partition: COSTS_Q1_2001 on table COSTS

Properties

Name: | COSTS_Q1_2001
Hight Value: | TO_DATE(' 2001-04-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN')
Hight Value Length: | 83
Tablespace: | EXAMPLE
Rows: | 7328
Blocks: | 23
Empty Blocks: | 0
Average Space: | 0

See Also

List of partitions


Partition: COSTS_Q2_2001 on table COSTS

Properties

Name: | COSTS_Q2_2001
Hight Value: | TO_DATE(' 2001-07-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN')
Hight Value Length: | 83
Tablespace: | EXAMPLE
Rows: | 5882
Blocks: | 20
Empty Blocks: | 0
Average Space: | 0

See Also

List of partitions


Partition: COSTS_Q3_2001 on table COSTS

Properties

Name: | COSTS_Q3_2001
Hight Value: | TO_DATE(' 2001-10-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN')
Hight Value Length: | 83
Tablespace: | EXAMPLE
Rows: | 7545
Blocks: | 24
Empty Blocks: | 0
Average Space: | 0

See Also

List of partitions


Partition: COSTS_Q4_2001 on table COSTS

Properties

Name: | COSTS_Q4_2001
Hight Value: | TO_DATE(' 2002-01-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN')
Hight Value Length: | 83
Tablespace: | EXAMPLE
Rows: | 9011
Blocks: | 27
Empty Blocks: | 0
Average Space: | 0

See Also

List of partitions


Partition: COSTS_Q1_2002 on table COSTS

Properties

Name: | COSTS_Q1_2002
Hight Value: | TO_DATE(' 2002-04-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN')
Hight Value Length: | 83
Tablespace: | EXAMPLE
Rows: | 0
Blocks: | 0
Empty Blocks: | 0
Average Space: | 0

See Also

List of partitions


Partition: COSTS_Q2_2002 on table COSTS

Properties

Name: | COSTS_Q2_2002
Hight Value: | TO_DATE(' 2002-07-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN')
Hight Value Length: | 83
Tablespace: | EXAMPLE
Rows: | 0
Blocks: | 0
Empty Blocks: | 0
Average Space: | 0

See Also

List of partitions


Partition: COSTS_Q3_2002 on table COSTS

Properties

Name: | COSTS_Q3_2002
Hight Value: | TO_DATE(' 2002-10-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN')
Hight Value Length: | 83
Tablespace: | EXAMPLE
Rows: | 0
Blocks: | 0
Empty Blocks: | 0
Average Space: | 0

See Also

List of partitions


Partition: COSTS_Q4_2002 on table COSTS

Properties

Name: | COSTS_Q4_2002
Hight Value: | TO_DATE(' 2003-01-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN')
Hight Value Length: | 83
Tablespace: | EXAMPLE
Rows: | 0
Blocks: | 0
Empty Blocks: | 0
Average Space: | 0

See Also

List of partitions


Partition: COSTS_Q1_2003 on table COSTS

Properties

Name: | COSTS_Q1_2003
Hight Value: | TO_DATE(' 2003-04-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN')
Hight Value Length: | 83
Tablespace: | EXAMPLE
Rows: | 0
Blocks: | 0
Empty Blocks: | 0
Average Space: | 0

See Also

List of partitions


Partition: COSTS_Q2_2003 on table COSTS

Properties

Name: | COSTS_Q2_2003
Hight Value: | TO_DATE(' 2003-07-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN')
Hight Value Length: | 83
Tablespace: | EXAMPLE
Rows: | 0
Blocks: | 0
Empty Blocks: | 0
Average Space: | 0

See Also

List of partitions


Partition: COSTS_Q3_2003 on table COSTS

Properties

Name: | COSTS_Q3_2003
Hight Value: | TO_DATE(' 2003-10-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN')
Hight Value Length: | 83
Tablespace: | EXAMPLE
Rows: | 0
Blocks: | 0
Empty Blocks: | 0
Average Space: | 0

See Also

List of partitions


Partition: COSTS_Q4_2003 on table COSTS

Properties

Name: | COSTS_Q4_2003
Hight Value: | TO_DATE(' 2004-01-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN')
Hight Value Length: | 83
Tablespace: | EXAMPLE
Rows: | 0
Blocks: | 0
Empty Blocks: | 0
Average Space: | 0

See Also

List of partitions


Table: COUNTRIES

Properties

Name: | COUNTRIES
Status: | VALID
Tablespace: | EXAMPLE
Logging: | N
Partitioned: |
Cached: | ENABLED
Locking: | 2000
IOT type: |
Object type: |
Type owner: |
Type: | N
Temporary: | N
Secondary: | NO
Nested: | DEFAULT
Buffer pool: | DISABLED
Row movement: | YES
Index Only Table: |
Minimum % of free space: | 10
Minimum % of udes space: |
Initial transactions: | 1
Max transactions: | 65536
Initial extent size, bytes: |
Secondary extent size, bytes: | 1
Min extents: | 2147483645
Max extents: |
% increase in extent: |
Process free list: |
Process free list groups: | NO
Backee up: | 23
Rows: | 4
Used blocks: | 0
Empty blocks: | 0
Average free space: | 0
Chained rows: | 64
Average row length: | 0
Average freespace on a freelist: | 0
Blocks on a freelist: | 1
Threds per instance: | 1
Instances: | N
Sample size: | 03.15.2007
Last analysed: | NO
Global statistics: | YES
User statistics: | NO
Duration: |
Skip corrupt blocks: | DISABLED
Monitoring: | YES
Cluster owner: |
Dependencies: | DISABLED
SizeMB: | 0,06
Extents: | 1
SizeBytes: | 65536
Description: | country dimension table (snowflake)

Columns

Name | Type | Length | Nchar Length | Precision | Scale | NULL | Default | Description
COUNTRY_ID | NUMBER |  |  |  |  | N |  | primary key
COUNTRY_ISO_CODE | CHAR | 2 | 2 |  |  | N |  |
COUNTRY_NAME | VARCHAR2 | 40 | 40 |  |  | N |  | country name
COUNTRY_SUBREGION | VARCHAR2 | 30 | 30 |  |  | N |  | e.g. Western Europe, to allow hierarchies
COUNTRY_SUBREGION_ID | NUMBER |  |  |  |  | N |  |
COUNTRY_REGION | VARCHAR2 | 20 | 20 |  |  | N |  | e.g. Europe, Asia
COUNTRY_REGION_ID | NUMBER |  |  |  |  | N |  |
COUNTRY_TOTAL | VARCHAR2 | 11 | 11 |  |  | N |  |
COUNTRY_TOTAL_ID | NUMBER |  |  |  |  | N |  |
COUNTRY_NAME_HIST | VARCHAR2 | 40 | 40 |  |  | Y |  |
Total: 10 column(s)

Indexes

Name | Type | Unique
COUNTRIES_PK | NORMAL | UNIQUE
Total: 1 index(s)

Constraints

Name | Type | Status | Delete rule | Defferable | Deffered
COUNTRIES_PK | Primary Key | Enabled |  | Not Deferrable | Immediate
SYS_C005314 | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005315 | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005316 | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005317 | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005318 | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005319 | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005320 | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005321 | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005322 | Check | Enabled |  | Not Deferrable | Immediate
Total: 10 constraints

Grants

Privilage | Grantee | Grantable | Grantor
SELECT | BI | NO | SH
Total: 1 grants

Referenced tables

Name | Owner | Constraint | DELETE_RULE
CUSTOMERS | SH | CUSTOMERS_COUNTRY_FK | NO ACTION
Total: 1 referenced table(s)

Table used by

Owner | Name | Type
BI | COUNTRIES | SYNONYM
SH | CUSTOMERS_DIM | DIMENSION
Total: 2 used by reference(s)

DDL

CREATE TABLE "SH"."COUNTRIES"
( "COUNTRY_ID" NUMBER NOT NULL ENABLE,
"COUNTRY_ISO_CODE" CHAR(2) NOT NULL ENABLE,
"COUNTRY_NAME" VARCHAR2(40) NOT NULL ENABLE,
"COUNTRY_SUBREGION" VARCHAR2(30) NOT NULL ENABLE,
"COUNTRY_SUBREGION_ID" NUMBER NOT NULL ENABLE,
"COUNTRY_REGION" VARCHAR2(20) NOT NULL ENABLE,
"COUNTRY_REGION_ID" NUMBER NOT NULL ENABLE,
"COUNTRY_TOTAL" VARCHAR2(11) NOT NULL ENABLE,
"COUNTRY_TOTAL_ID" NUMBER NOT NULL ENABLE,
"COUNTRY_NAME_HIST" VARCHAR2(40),
CONSTRAINT "COUNTRIES_PK" PRIMARY KEY ("COUNTRY_ID")
USING INDEX PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING COMPUTE STATISTICS
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" ENABLE NOVALIDATE
) PCTFREE 10 PCTUSED 40 INITRANS 1 MAXTRANS 255 NOCOMPRESS NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE"

See Also

List of tables


List of indexes

Indexes

Name | Type | Unique
COUNTRIES_PK | NORMAL | UNIQUE
Total: 1 index(s)

See Also

Table [COUNTRIES]


Index: COUNTRIES_PK on table COUNTRIES

Properties

Name: | COUNTRIES_PK
Type: | NORMAL
Unique: | UNIQUE
Tablespace: | EXAMPLE
Status: | VALID
Table owner: | SH
Table name: | COUNTRIES
Temporary: | No
Join Index: | No
Initial extent size: | 65536
Secondary extent size: |
Min extents: | 1
Max extents: | 2147483645
Percent encrease: |
Distinct keys: | 23
Minimum free %: | 10

Index Columns

Name | Length | Descend
COUNTRY_ID | 22 | ASC
Total: 1 column(s)

DDL

CREATE UNIQUE INDEX "SH"."COUNTRIES_PK" ON "SH"."COUNTRIES" ("COUNTRY_ID")
PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING COMPUTE STATISTICS
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE"

See Also

List of indexes


List of constraints

Constraints

Name | Type | Status | Delete rule | Defferable | Deffered
COUNTRIES_PK | Primary Key | Enabled |  | Not Deferrable | Immediate
SYS_C005314 | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005315 | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005316 | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005317 | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005318 | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005319 | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005320 | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005321 | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005322 | Check | Enabled |  | Not Deferrable | Immediate
Total: 10 constraint(s)

See Also

Table [COUNTRIES]


Constraint: COUNTRIES_PK on table COUNTRIES

Properties

Name: | COUNTRIES_PK
Type: | Primary Key
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
COUNTRY_ID
Total: 1 column(s)

DDL

ALTER TABLE "SH"."COUNTRIES" ADD CONSTRAINT "COUNTRIES_PK" PRIMARY KEY ("COUNTRY_ID")
USING INDEX PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING COMPUTE STATISTICS
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" ENABLE NOVALIDATE

See Also

List of constraints
Table [COUNTRIES]


Constraint: SYS_C005314 on table COUNTRIES

Properties

Name: | SYS_C005314
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
COUNTRY_ID
Total: 1 column(s)

DDL

ALTER TABLE "SH"."COUNTRIES" MODIFY ("COUNTRY_ID" NOT NULL ENABLE)

See Also

List of constraints
Table [COUNTRIES]


Constraint: SYS_C005315 on table COUNTRIES

Properties

Name: | SYS_C005315
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
COUNTRY_ISO_CODE
Total: 1 column(s)

DDL

ALTER TABLE "SH"."COUNTRIES" MODIFY ("COUNTRY_ISO_CODE" NOT NULL ENABLE)

See Also

List of constraints
Table [COUNTRIES]


Constraint: SYS_C005316 on table COUNTRIES

Properties

Name: | SYS_C005316
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
COUNTRY_NAME
Total: 1 column(s)

DDL

ALTER TABLE "SH"."COUNTRIES" MODIFY ("COUNTRY_NAME" NOT NULL ENABLE)

See Also

List of constraints
Table [COUNTRIES]


Constraint: SYS_C005317 on table COUNTRIES

Properties

Name: | SYS_C005317
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
COUNTRY_SUBREGION
Total: 1 column(s)

DDL

ALTER TABLE "SH"."COUNTRIES" MODIFY ("COUNTRY_SUBREGION" NOT NULL ENABLE)

See Also

List of constraints
Table [COUNTRIES]


Constraint: SYS_C005318 on table COUNTRIES

Properties

Name: | SYS_C005318
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
COUNTRY_SUBREGION_ID
Total: 1 column(s)

DDL

ALTER TABLE "SH"."COUNTRIES" MODIFY ("COUNTRY_SUBREGION_ID" NOT NULL ENABLE)

See Also

List of constraints
Table [COUNTRIES]


Constraint: SYS_C005319 on table COUNTRIES

Properties

Name: | SYS_C005319
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
COUNTRY_REGION
Total: 1 column(s)

DDL

ALTER TABLE "SH"."COUNTRIES" MODIFY ("COUNTRY_REGION" NOT NULL ENABLE)

See Also

List of constraints
Table [COUNTRIES]


Constraint: SYS_C005320 on table COUNTRIES

Properties

Name: | SYS_C005320
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
COUNTRY_REGION_ID
Total: 1 column(s)

DDL

ALTER TABLE "SH"."COUNTRIES" MODIFY ("COUNTRY_REGION_ID" NOT NULL ENABLE)

See Also

List of constraints
Table [COUNTRIES]


Constraint: SYS_C005321 on table COUNTRIES

Properties

Name: | SYS_C005321
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
COUNTRY_TOTAL
Total: 1 column(s)

DDL

ALTER TABLE "SH"."COUNTRIES" MODIFY ("COUNTRY_TOTAL" NOT NULL ENABLE)

See Also

List of constraints
Table [COUNTRIES]


Constraint: SYS_C005322 on table COUNTRIES

Properties

Name: | SYS_C005322
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
COUNTRY_TOTAL_ID
Total: 1 column(s)

DDL

ALTER TABLE "SH"."COUNTRIES" MODIFY ("COUNTRY_TOTAL_ID" NOT NULL ENABLE)

See Also

List of constraints
Table [COUNTRIES]


Table: CUSTOMERS

Properties

Name: | CUSTOMERS
Status: | VALID
Tablespace: | EXAMPLE
Logging: | N
Partitioned: |
Cached: | ENABLED
Locking: | 2000
IOT type: |
Object type: |
Type owner: |
Type: | N
Temporary: | N
Secondary: | NO
Nested: | DEFAULT
Buffer pool: | DISABLED
Row movement: | YES
Index Only Table: |
Minimum % of free space: | 10
Minimum % of udes space: |
Initial transactions: | 1
Max transactions: | 65536
Initial extent size, bytes: |
Secondary extent size, bytes: | 1
Min extents: | 2147483645
Max extents: |
% increase in extent: |
Process free list: |
Process free list groups: | NO
Backee up: | 55500
Rows: | 1486
Used blocks: | 0
Empty blocks: | 0
Average free space: | 0
Chained rows: | 180
Average row length: | 0
Average freespace on a freelist: | 0
Blocks on a freelist: | 1
Threds per instance: | 1
Instances: | N
Sample size: | 03.15.2007
Last analysed: | NO
Global statistics: | YES
User statistics: | NO
Duration: |
Skip corrupt blocks: | DISABLED
Monitoring: | YES
Cluster owner: |
Dependencies: | DISABLED
SizeMB: | 12
Extents: | 27
SizeBytes: | 12582912
Description: | dimension table

Columns

Name | Type | Length | Nchar Length | Precision | Scale | NULL | Default | Description
CUST_ID | NUMBER |  |  |  |  | N |  | primary key
CUST_FIRST_NAME | VARCHAR2 | 20 | 20 |  |  | N |  | first name of the customer
CUST_LAST_NAME | VARCHAR2 | 40 | 40 |  |  | N |  | last name of the customer
CUST_GENDER | CHAR | 1 | 1 |  |  | N |  | gender; low cardinality attribute
CUST_YEAR_OF_BIRTH | NUMBER | 4 |  | 4 | 0 | N |  | customer year of birth
CUST_MARITAL_STATUS | VARCHAR2 | 20 | 20 |  |  | Y |  | customer marital status; low cardinality attribute
CUST_STREET_ADDRESS | VARCHAR2 | 40 | 40 |  |  | N |  | customer street address
CUST_POSTAL_CODE | VARCHAR2 | 10 | 10 |  |  | N |  | postal code of the customer
CUST_CITY | VARCHAR2 | 30 | 30 |  |  | N |  | city where the customer lives
CUST_CITY_ID | NUMBER |  |  |  |  | N |  |
CUST_STATE_PROVINCE | VARCHAR2 | 40 | 40 |  |  | N |  | customer geography: state or province
CUST_STATE_PROVINCE_ID | NUMBER |  |  |  |  | N |  |
COUNTRY_ID | NUMBER |  |  |  |  | N |  | foreign key to the countries table (snowflake)
CUST_MAIN_PHONE_NUMBER | VARCHAR2 | 25 | 25 |  |  | N |  | customer main phone number
CUST_INCOME_LEVEL | VARCHAR2 | 30 | 30 |  |  | Y |  | customer income level
CUST_CREDIT_LIMIT | NUMBER |  |  |  |  | Y |  | customer credit limit
CUST_EMAIL | VARCHAR2 | 30 | 30 |  |  | Y |  | customer email id
CUST_TOTAL | VARCHAR2 | 14 | 14 |  |  | N |  |
CUST_TOTAL_ID | NUMBER |  |  |  |  | N |  |
CUST_SRC_ID | NUMBER |  |  |  |  | Y |  |
CUST_EFF_FROM | DATE | 7 |  |  |  | Y |  |
CUST_EFF_TO | DATE | 7 |  |  |  | Y |  |
CUST_VALID | VARCHAR2 | 1 | 1 |  |  | Y |  |
Total: 23 column(s)

Indexes

Name | Type | Unique
CUSTOMERS_GENDER_BIX | BITMAP | NONUNIQUE
CUSTOMERS_MARITAL_BIX | BITMAP | NONUNIQUE
CUSTOMERS_PK | NORMAL | UNIQUE
CUSTOMERS_YOB_BIX | BITMAP | NONUNIQUE
Total: 4 index(s)

Constraints

Name | Type | Status | Delete rule | Defferable | Deffered
CUSTOMERS_COUNTRY_FK | Referential Integrity | Enabled | No Action | Not Deferrable | Immediate
CUSTOMERS_PK | Primary Key | Enabled |  | Not Deferrable | Immediate
SYS_C005298 | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005299 | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005300 | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005301 | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005302 | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005303 | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005304 | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005305 | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005306 | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005307 | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005308 | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005309 | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005310 | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005311 | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005312 | Check | Enabled |  | Not Deferrable | Immediate
Total: 17 constraints

Grants

Privilage | Grantee | Grantable | Grantor
SELECT | BI | NO | SH
Total: 1 grants

Referenced tables

Name | Owner | Constraint | DELETE_RULE
SALES | SH | SALES_CUSTOMER_FK | NO ACTION
Total: 1 referenced table(s)

Table References

Name | Owner | Constraint | DELETE_RULE
COUNTRIES | SH | CUSTOMERS_COUNTRY_FK |
Total: 1 table reference(s)

Table used by

Owner | Name | Type
BI | CUSTOMERS | SYNONYM
SH | CUSTOMERS_DIM | DIMENSION
Total: 2 used by reference(s)

DDL

CREATE TABLE "SH"."CUSTOMERS"
( "CUST_ID" NUMBER NOT NULL ENABLE,
"CUST_FIRST_NAME" VARCHAR2(20) NOT NULL ENABLE,
"CUST_LAST_NAME" VARCHAR2(40) NOT NULL ENABLE,
"CUST_GENDER" CHAR(1) NOT NULL ENABLE,
"CUST_YEAR_OF_BIRTH" NUMBER(4,0) NOT NULL ENABLE,
"CUST_MARITAL_STATUS" VARCHAR2(20),
"CUST_STREET_ADDRESS" VARCHAR2(40) NOT NULL ENABLE,
"CUST_POSTAL_CODE" VARCHAR2(10) NOT NULL ENABLE,
"CUST_CITY" VARCHAR2(30) NOT NULL ENABLE,
"CUST_CITY_ID" NUMBER NOT NULL ENABLE,
"CUST_STATE_PROVINCE" VARCHAR2(40) NOT NULL ENABLE,
"CUST_STATE_PROVINCE_ID" NUMBER NOT NULL ENABLE,
"COUNTRY_ID" NUMBER NOT NULL ENABLE,
"CUST_MAIN_PHONE_NUMBER" VARCHAR2(25) NOT NULL ENABLE,
"CUST_INCOME_LEVEL" VARCHAR2(30),
"CUST_CREDIT_LIMIT" NUMBER,
"CUST_EMAIL" VARCHAR2(30),
"CUST_TOTAL" VARCHAR2(14) NOT NULL ENABLE,
"CUST_TOTAL_ID" NUMBER NOT NULL ENABLE,
"CUST_SRC_ID" NUMBER,
"CUST_EFF_FROM" DATE,
"CUST_EFF_TO" DATE,
"CUST_VALID" VARCHAR2(1),
CONSTRAINT "CUSTOMERS_PK" PRIMARY KEY ("CUST_ID")
USING INDEX PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING COMPUTE STATISTICS
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" ENABLE NOVALIDATE,
CONSTRAINT "CUSTOMERS_COUNTRY_FK" FOREIGN KEY ("COUNTRY_ID")
REFERENCES "SH"."COUNTRIES" ("COUNTRY_ID") ENABLE NOVALIDATE
) PCTFREE 10 PCTUSED 40 INITRANS 1 MAXTRANS 255 NOCOMPRESS NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE"

See Also

List of tables


List of indexes

Indexes

Name | Type | Unique
CUSTOMERS_GENDER_BIX | BITMAP | NONUNIQUE
CUSTOMERS_MARITAL_BIX | BITMAP | NONUNIQUE
CUSTOMERS_PK | NORMAL | UNIQUE
CUSTOMERS_YOB_BIX | BITMAP | NONUNIQUE
Total: 4 index(s)

See Also

Table [CUSTOMERS]


Index: CUSTOMERS_GENDER_BIX on table CUSTOMERS

Properties

Name: | CUSTOMERS_GENDER_BIX
Type: | BITMAP
Unique: | NONUNIQUE
Tablespace: | EXAMPLE
Status: | VALID
Table owner: | SH
Table name: | CUSTOMERS
Temporary: | No
Join Index: | No
Initial extent size: | 65536
Secondary extent size: |
Min extents: | 1
Max extents: | 2147483645
Percent encrease: |
Distinct keys: | 2
Minimum free %: | 10

Index Columns

Name | Length | Descend
CUST_GENDER | 1 | ASC
Total: 1 column(s)

DDL

CREATE BITMAP INDEX "SH"."CUSTOMERS_GENDER_BIX" ON "SH"."CUSTOMERS" ("CUST_GENDER")
PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING COMPUTE STATISTICS
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE"

See Also

List of indexes


Index: CUSTOMERS_MARITAL_BIX on table CUSTOMERS

Properties

Name: | CUSTOMERS_MARITAL_BIX
Type: | BITMAP
Unique: | NONUNIQUE
Tablespace: | EXAMPLE
Status: | VALID
Table owner: | SH
Table name: | CUSTOMERS
Temporary: | No
Join Index: | No
Initial extent size: | 65536
Secondary extent size: |
Min extents: | 1
Max extents: | 2147483645
Percent encrease: |
Distinct keys: | 11
Minimum free %: | 10

Index Columns

Name | Length | Descend
CUST_MARITAL_STATUS | 20 | ASC
Total: 1 column(s)

DDL

CREATE BITMAP INDEX "SH"."CUSTOMERS_MARITAL_BIX" ON "SH"."CUSTOMERS" ("CUST_MARITAL_STATUS")
PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING COMPUTE STATISTICS
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE"

See Also

List of indexes


Index: CUSTOMERS_PK on table CUSTOMERS

Properties

Name: | CUSTOMERS_PK
Type: | NORMAL
Unique: | UNIQUE
Tablespace: | EXAMPLE
Status: | VALID
Table owner: | SH
Table name: | CUSTOMERS
Temporary: | No
Join Index: | No
Initial extent size: | 65536
Secondary extent size: |
Min extents: | 1
Max extents: | 2147483645
Percent encrease: |
Distinct keys: | 55500
Minimum free %: | 10

Index Columns

Name | Length | Descend
CUST_ID | 22 | ASC
Total: 1 column(s)

DDL

CREATE UNIQUE INDEX "SH"."CUSTOMERS_PK" ON "SH"."CUSTOMERS" ("CUST_ID")
PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING COMPUTE STATISTICS
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE"

See Also

List of indexes


Index: CUSTOMERS_YOB_BIX on table CUSTOMERS

Properties

Name: | CUSTOMERS_YOB_BIX
Type: | BITMAP
Unique: | NONUNIQUE
Tablespace: | EXAMPLE
Status: | VALID
Table owner: | SH
Table name: | CUSTOMERS
Temporary: | No
Join Index: | No
Initial extent size: | 65536
Secondary extent size: |
Min extents: | 1
Max extents: | 2147483645
Percent encrease: |
Distinct keys: | 75
Minimum free %: | 10

Index Columns

Name | Length | Descend
CUST_YEAR_OF_BIRTH | 22 | ASC
Total: 1 column(s)

DDL

CREATE BITMAP INDEX "SH"."CUSTOMERS_YOB_BIX" ON "SH"."CUSTOMERS" ("CUST_YEAR_OF_BIRTH")
PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING COMPUTE STATISTICS
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE"

See Also

List of indexes


List of constraints

Constraints

Name | Type | Status | Delete rule | Defferable | Deffered
CUSTOMERS_COUNTRY_FK | Referential Integrity | Enabled | No Action | Not Deferrable | Immediate
CUSTOMERS_PK | Primary Key | Enabled |  | Not Deferrable | Immediate
SYS_C005298 | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005299 | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005300 | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005301 | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005302 | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005303 | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005304 | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005305 | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005306 | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005307 | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005308 | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005309 | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005310 | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005311 | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005312 | Check | Enabled |  | Not Deferrable | Immediate
Total: 17 constraint(s)

See Also

Table [CUSTOMERS]


Constraint: CUSTOMERS_COUNTRY_FK on table CUSTOMERS

Properties

Name: | CUSTOMERS_COUNTRY_FK
Type: | Referential Integrity
Status: | Enabled
Delete rule: | No Action
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: | SH
R Constraint: | COUNTRIES_PK

Columns

Name
COUNTRY_ID
Total: 1 column(s)

Reference columns

Owner | Table | Column
SH | COUNTRIES | COUNTRY_ID
Total: 1 reference column(s)

DDL

See Also

List of constraints
Table [CUSTOMERS]


Constraint: CUSTOMERS_PK on table CUSTOMERS

Properties

Name: | CUSTOMERS_PK
Type: | Primary Key
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
CUST_ID
Total: 1 column(s)

DDL

ALTER TABLE "SH"."CUSTOMERS" ADD CONSTRAINT "CUSTOMERS_PK" PRIMARY KEY ("CUST_ID")
USING INDEX PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING COMPUTE STATISTICS
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" ENABLE NOVALIDATE

See Also

List of constraints
Table [CUSTOMERS]


Constraint: SYS_C005298 on table CUSTOMERS

Properties

Name: | SYS_C005298
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
CUST_ID
Total: 1 column(s)

DDL

ALTER TABLE "SH"."CUSTOMERS" MODIFY ("CUST_ID" NOT NULL ENABLE)

See Also

List of constraints
Table [CUSTOMERS]


Constraint: SYS_C005299 on table CUSTOMERS

Properties

Name: | SYS_C005299
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
CUST_FIRST_NAME
Total: 1 column(s)

DDL

ALTER TABLE "SH"."CUSTOMERS" MODIFY ("CUST_FIRST_NAME" NOT NULL ENABLE)

See Also

List of constraints
Table [CUSTOMERS]


Constraint: SYS_C005300 on table CUSTOMERS

Properties

Name: | SYS_C005300
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
CUST_LAST_NAME
Total: 1 column(s)

DDL

ALTER TABLE "SH"."CUSTOMERS" MODIFY ("CUST_LAST_NAME" NOT NULL ENABLE)

See Also

List of constraints
Table [CUSTOMERS]


Constraint: SYS_C005301 on table CUSTOMERS

Properties

Name: | SYS_C005301
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
CUST_GENDER
Total: 1 column(s)

DDL

ALTER TABLE "SH"."CUSTOMERS" MODIFY ("CUST_GENDER" NOT NULL ENABLE)

See Also

List of constraints
Table [CUSTOMERS]


Constraint: SYS_C005302 on table CUSTOMERS

Properties

Name: | SYS_C005302
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
CUST_YEAR_OF_BIRTH
Total: 1 column(s)

DDL

ALTER TABLE "SH"."CUSTOMERS" MODIFY ("CUST_YEAR_OF_BIRTH" NOT NULL ENABLE)

See Also

List of constraints
Table [CUSTOMERS]


Constraint: SYS_C005303 on table CUSTOMERS

Properties

Name: | SYS_C005303
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
CUST_STREET_ADDRESS
Total: 1 column(s)

DDL

ALTER TABLE "SH"."CUSTOMERS" MODIFY ("CUST_STREET_ADDRESS" NOT NULL ENABLE)

See Also

List of constraints
Table [CUSTOMERS]


Constraint: SYS_C005304 on table CUSTOMERS

Properties

Name: | SYS_C005304
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
CUST_POSTAL_CODE
Total: 1 column(s)

DDL

ALTER TABLE "SH"."CUSTOMERS" MODIFY ("CUST_POSTAL_CODE" NOT NULL ENABLE)

See Also

List of constraints
Table [CUSTOMERS]


Constraint: SYS_C005305 on table CUSTOMERS

Properties

Name: | SYS_C005305
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
CUST_CITY
Total: 1 column(s)

DDL

ALTER TABLE "SH"."CUSTOMERS" MODIFY ("CUST_CITY" NOT NULL ENABLE)

See Also

List of constraints
Table [CUSTOMERS]


Constraint: SYS_C005306 on table CUSTOMERS

Properties

Name: | SYS_C005306
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
CUST_CITY_ID
Total: 1 column(s)

DDL

ALTER TABLE "SH"."CUSTOMERS" MODIFY ("CUST_CITY_ID" NOT NULL ENABLE)

See Also

List of constraints
Table [CUSTOMERS]


Constraint: SYS_C005307 on table CUSTOMERS

Properties

Name: | SYS_C005307
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
CUST_STATE_PROVINCE
Total: 1 column(s)

DDL

ALTER TABLE "SH"."CUSTOMERS" MODIFY ("CUST_STATE_PROVINCE" NOT NULL ENABLE)

See Also

List of constraints
Table [CUSTOMERS]


Constraint: SYS_C005308 on table CUSTOMERS

Properties

Name: | SYS_C005308
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
CUST_STATE_PROVINCE_ID
Total: 1 column(s)

DDL

ALTER TABLE "SH"."CUSTOMERS" MODIFY ("CUST_STATE_PROVINCE_ID" NOT NULL ENABLE)

See Also

List of constraints
Table [CUSTOMERS]


Constraint: SYS_C005309 on table CUSTOMERS

Properties

Name: | SYS_C005309
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
COUNTRY_ID
Total: 1 column(s)

DDL

ALTER TABLE "SH"."CUSTOMERS" MODIFY ("COUNTRY_ID" NOT NULL ENABLE)

See Also

List of constraints
Table [CUSTOMERS]


Constraint: SYS_C005310 on table CUSTOMERS

Properties

Name: | SYS_C005310
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
CUST_MAIN_PHONE_NUMBER
Total: 1 column(s)

DDL

ALTER TABLE "SH"."CUSTOMERS" MODIFY ("CUST_MAIN_PHONE_NUMBER" NOT NULL ENABLE)

See Also

List of constraints
Table [CUSTOMERS]


Constraint: SYS_C005311 on table CUSTOMERS

Properties

Name: | SYS_C005311
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
CUST_TOTAL
Total: 1 column(s)

DDL

ALTER TABLE "SH"."CUSTOMERS" MODIFY ("CUST_TOTAL" NOT NULL ENABLE)

See Also

List of constraints
Table [CUSTOMERS]


Constraint: SYS_C005312 on table CUSTOMERS

Properties

Name: | SYS_C005312
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
CUST_TOTAL_ID
Total: 1 column(s)

DDL

ALTER TABLE "SH"."CUSTOMERS" MODIFY ("CUST_TOTAL_ID" NOT NULL ENABLE)

See Also

List of constraints
Table [CUSTOMERS]


Table: DR$SUP_TEXT_IDX$I

Properties

Name: | DR$SUP_TEXT_IDX$I
Status: | VALID
Tablespace: | EXAMPLE
Logging: | N
Partitioned: |
Cached: | ENABLED
Locking: |
IOT type: |
Object type: |
Type owner: |
Type: | N
Temporary: | Y
Secondary: | NO
Nested: | DEFAULT
Buffer pool: | DISABLED
Row movement: | NO
Index Only Table: |
Minimum % of free space: | 10
Minimum % of udes space: |
Initial transactions: | 1
Max transactions: | 65536
Initial extent size, bytes: |
Secondary extent size, bytes: | 1
Min extents: | 2147483645
Max extents: |
% increase in extent: |
Process free list: |
Process free list groups: | NO
Backee up: |
Rows: |
Used blocks: |
Empty blocks: |
Average free space: |
Chained rows: |
Average row length: |
Average freespace on a freelist: |
Blocks on a freelist: | 1
Threds per instance: | 1
Instances: | N
Sample size: |
Last analysed: | NO
Global statistics: | NO
User statistics: | NO
Duration: |
Skip corrupt blocks: | DISABLED
Monitoring: | YES
Cluster owner: |
Dependencies: | DISABLED
SizeMB: | 0,06
Extents: | 1
SizeBytes: | 65536
Description: |

Columns

Name | Type | Length | Nchar Length | Precision | Scale | NULL | Default | Description
TOKEN_TEXT | VARCHAR2 | 64 | 64 |  |  | N |  |
TOKEN_TYPE | NUMBER | 3 |  | 3 | 0 | N |  |
TOKEN_FIRST | NUMBER | 10 |  | 10 | 0 | N |  |
TOKEN_LAST | NUMBER | 10 |  | 10 | 0 | N |  |
TOKEN_COUNT | NUMBER | 10 |  | 10 | 0 | N |  |
TOKEN_INFO | BLOB | 4000 |  |  |  | Y |  |
Total: 6 column(s)

Indexes

Name | Type | Unique
DR$SUP_TEXT_IDX$X | NORMAL | NONUNIQUE
SYS_IL0000052326C00006$$ | LOB | UNIQUE
Total: 2 index(s)

Constraints

Name | Type | Status | Delete rule | Defferable | Deffered
SYS_C005367 | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005368 | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005369 | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005370 | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005371 | Check | Enabled |  | Not Deferrable | Immediate
Total: 5 constraints

DDL

CREATE TABLE "SH"."DR$SUP_TEXT_IDX$I"
( "TOKEN_TEXT" VARCHAR2(64) NOT NULL ENABLE,
"TOKEN_TYPE" NUMBER(3,0) NOT NULL ENABLE,
"TOKEN_FIRST" NUMBER(10,0) NOT NULL ENABLE,
"TOKEN_LAST" NUMBER(10,0) NOT NULL ENABLE,
"TOKEN_COUNT" NUMBER(10,0) NOT NULL ENABLE,
"TOKEN_INFO" BLOB
) PCTFREE 10 PCTUSED 40 INITRANS 1 MAXTRANS 255 NOCOMPRESS NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE"
LOB ("TOKEN_INFO") STORE AS (
TABLESPACE "EXAMPLE" ENABLE STORAGE IN ROW CHUNK 8192 PCTVERSION 10
NOCACHE NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT))

See Also

List of tables


List of indexes

Indexes

Name | Type | Unique
DR$SUP_TEXT_IDX$X | NORMAL | NONUNIQUE
SYS_IL0000052326C00006$$ | LOB | UNIQUE
Total: 2 index(s)

See Also

Table [DR$SUP_TEXT_IDX$I]


Index: DR$SUP_TEXT_IDX$X on table DR$SUP_TEXT_IDX$I

Properties

Name: | DR$SUP_TEXT_IDX$X
Type: | NORMAL
Unique: | NONUNIQUE
Tablespace: | EXAMPLE
Status: | VALID
Table owner: | SH
Table name: | DR$SUP_TEXT_IDX$I
Temporary: | No
Join Index: | No
Initial extent size: | 65536
Secondary extent size: |
Min extents: | 1
Max extents: | 2147483645
Percent encrease: |
Distinct keys: |
Minimum free %: | 10

Index Columns

Name | Length | Descend
TOKEN_TEXT | 64 | ASC
TOKEN_TYPE | 22 | ASC
TOKEN_FIRST | 22 | ASC
TOKEN_LAST | 22 | ASC
TOKEN_COUNT | 22 | ASC
Total: 5 column(s)

DDL

CREATE INDEX "SH"."DR$SUP_TEXT_IDX$X" ON "SH"."DR$SUP_TEXT_IDX$I" ("TOKEN_TEXT", "TOKEN_TYPE", "TOKEN_FIRST", "TOKEN_LAST", "TOKEN_COUNT")
PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING COMPRESS 2
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE"

See Also

List of indexes


Index: SYS_IL0000052326C00006$$ on table DR$SUP_TEXT_IDX$I

Properties

Name: | SYS_IL0000052326C00006$$
Type: | LOB
Unique: | UNIQUE
Tablespace: | EXAMPLE
Status: | VALID
Table owner: | SH
Table name: | DR$SUP_TEXT_IDX$I
Temporary: | No
Join Index: | No
Initial extent size: | 65536
Secondary extent size: |
Min extents: | 1
Max extents: | 2147483645
Percent encrease: |
Distinct keys: |
Minimum free %: | 10

DDL

CREATE UNIQUE INDEX "SH"."SYS_IL0000052326C00006$$" ON "SH"."DR$SUP_TEXT_IDX$I" (
PCTFREE 10 INITRANS 2 MAXTRANS 255
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE"
PARALLEL (DEGREE 0 INSTANCES 0)

See Also

List of indexes


List of constraints

Constraints

Name | Type | Status | Delete rule | Defferable | Deffered
SYS_C005367 | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005368 | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005369 | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005370 | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005371 | Check | Enabled |  | Not Deferrable | Immediate
Total: 5 constraint(s)

See Also

Table [DR$SUP_TEXT_IDX$I]


Constraint: SYS_C005367 on table DR$SUP_TEXT_IDX$I

Properties

Name: | SYS_C005367
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
TOKEN_TEXT
Total: 1 column(s)

DDL

ALTER TABLE "SH"."DR$SUP_TEXT_IDX$I" MODIFY ("TOKEN_TEXT" NOT NULL ENABLE)

See Also

List of constraints
Table [DR$SUP_TEXT_IDX$I]


Constraint: SYS_C005368 on table DR$SUP_TEXT_IDX$I

Properties

Name: | SYS_C005368
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
TOKEN_TYPE
Total: 1 column(s)

DDL

ALTER TABLE "SH"."DR$SUP_TEXT_IDX$I" MODIFY ("TOKEN_TYPE" NOT NULL ENABLE)

See Also

List of constraints
Table [DR$SUP_TEXT_IDX$I]


Constraint: SYS_C005369 on table DR$SUP_TEXT_IDX$I

Properties

Name: | SYS_C005369
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
TOKEN_FIRST
Total: 1 column(s)

DDL

ALTER TABLE "SH"."DR$SUP_TEXT_IDX$I" MODIFY ("TOKEN_FIRST" NOT NULL ENABLE)

See Also

List of constraints
Table [DR$SUP_TEXT_IDX$I]


Constraint: SYS_C005370 on table DR$SUP_TEXT_IDX$I

Properties

Name: | SYS_C005370
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
TOKEN_LAST
Total: 1 column(s)

DDL

ALTER TABLE "SH"."DR$SUP_TEXT_IDX$I" MODIFY ("TOKEN_LAST" NOT NULL ENABLE)

See Also

List of constraints
Table [DR$SUP_TEXT_IDX$I]


Constraint: SYS_C005371 on table DR$SUP_TEXT_IDX$I

Properties

Name: | SYS_C005371
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
TOKEN_COUNT
Total: 1 column(s)

DDL

ALTER TABLE "SH"."DR$SUP_TEXT_IDX$I" MODIFY ("TOKEN_COUNT" NOT NULL ENABLE)

See Also

List of constraints
Table [DR$SUP_TEXT_IDX$I]


Table: DR$SUP_TEXT_IDX$K

Properties

Name: | DR$SUP_TEXT_IDX$K
Status: | VALID
Tablespace: |
Logging: | N
Partitioned: | IOT
Cached: | ENABLED
Locking: |
IOT type: |
Object type: |
Type owner: |
Type: | N
Temporary: | Y
Secondary: | NO
Nested: |
Buffer pool: | DISABLED
Row movement: | NO
Index Only Table: |
Minimum % of free space: | 0
Minimum % of udes space: | 0
Initial transactions: | 0
Max transactions: |
Initial extent size, bytes: |
Secondary extent size, bytes: |
Min extents: |
Max extents: |
% increase in extent: |
Process free list: |
Process free list groups: |
Backee up: |
Rows: |
Used blocks: |
Empty blocks: |
Average free space: |
Chained rows: |
Average row length: |
Average freespace on a freelist: |
Blocks on a freelist: | 1
Threds per instance: | 1
Instances: | N
Sample size: |
Last analysed: | NO
Global statistics: | NO
User statistics: | NO
Duration: |
Skip corrupt blocks: | DISABLED
Monitoring: | YES
Cluster owner: |
Dependencies: | DISABLED
SizeMB: |
Extents: |
SizeBytes: |
Description: |

Columns

Name | Type | Length | Nchar Length | Precision | Scale | NULL | Default | Description
DOCID | NUMBER | 38 |  | 38 | 0 | Y |  |
TEXTKEY | ROWID | 10 |  |  |  | N |  |
Total: 2 column(s)

Indexes

Name | Type | Unique
SYS_IOT_TOP_52330 | IOT - TOP | UNIQUE
Total: 1 index(s)

Constraints

Name | Type | Status | Delete rule | Defferable | Deffered
SYS_IOT_TOP_52330 | Primary Key | Enabled |  | Not Deferrable | Immediate
Total: 1 constraints

DDL

CREATE TABLE "SH"."DR$SUP_TEXT_IDX$K"
( "DOCID" NUMBER(38,0),
"TEXTKEY" ROWID,
PRIMARY KEY ("TEXTKEY") ENABLE
) ORGANIZATION INDEX NOCOMPRESS PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE"
PCTTHRESHOLD 50

See Also

List of tables


List of indexes

Indexes

Name | Type | Unique
SYS_IOT_TOP_52330 | IOT - TOP | UNIQUE
Total: 1 index(s)

See Also

Table [DR$SUP_TEXT_IDX$K]


Index: SYS_IOT_TOP_52330 on table DR$SUP_TEXT_IDX$K

Properties

Name: | SYS_IOT_TOP_52330
Type: | IOT - TOP
Unique: | UNIQUE
Tablespace: | EXAMPLE
Status: | VALID
Table owner: | SH
Table name: | DR$SUP_TEXT_IDX$K
Temporary: | No
Join Index: | No
Initial extent size: | 65536
Secondary extent size: |
Min extents: | 1
Max extents: | 2147483645
Percent encrease: |
Distinct keys: |
Minimum free %: | 10

Index Columns

Name | Length | Descend
TEXTKEY | 10 | ASC
Total: 1 column(s)

DDL

CREATE UNIQUE INDEX "SH"."SYS_IOT_TOP_52330" ON "SH"."DR$SUP_TEXT_IDX$K" ("TEXTKEY")
PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE"

See Also

List of indexes


List of constraints

Constraints

Name | Type | Status | Delete rule | Defferable | Deffered
SYS_IOT_TOP_52330 | Primary Key | Enabled |  | Not Deferrable | Immediate
Total: 1 constraint(s)

See Also

Table [DR$SUP_TEXT_IDX$K]


Constraint: SYS_IOT_TOP_52330 on table DR$SUP_TEXT_IDX$K

Properties

Name: | SYS_IOT_TOP_52330
Type: | Primary Key
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
TEXTKEY
Total: 1 column(s)

DDL

ALTER TABLE "SH"."DR$SUP_TEXT_IDX$K" ADD PRIMARY KEY ("TEXTKEY")
USING INDEX PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" ENABLE

See Also

List of constraints
Table [DR$SUP_TEXT_IDX$K]


Table: DR$SUP_TEXT_IDX$N

Properties

Name: | DR$SUP_TEXT_IDX$N
Status: | VALID
Tablespace: |
Logging: | N
Partitioned: | IOT
Cached: | ENABLED
Locking: |
IOT type: |
Object type: |
Type owner: |
Type: | N
Temporary: | Y
Secondary: | NO
Nested: |
Buffer pool: | DISABLED
Row movement: | NO
Index Only Table: |
Minimum % of free space: | 0
Minimum % of udes space: | 0
Initial transactions: | 0
Max transactions: |
Initial extent size, bytes: |
Secondary extent size, bytes: |
Min extents: |
Max extents: |
% increase in extent: |
Process free list: |
Process free list groups: |
Backee up: |
Rows: |
Used blocks: |
Empty blocks: |
Average free space: |
Chained rows: |
Average row length: |
Average freespace on a freelist: |
Blocks on a freelist: | 1
Threds per instance: | 1
Instances: | N
Sample size: |
Last analysed: | NO
Global statistics: | NO
User statistics: | NO
Duration: |
Skip corrupt blocks: | DISABLED
Monitoring: | YES
Cluster owner: |
Dependencies: | DISABLED
SizeMB: |
Extents: |
SizeBytes: |
Description: |

Columns

Name | Type | Length | Nchar Length | Precision | Scale | NULL | Default | Description
NLT_DOCID | NUMBER | 38 |  | 38 | 0 | N |  |
NLT_MARK | CHAR | 1 | 1 |  |  | N |  |
Total: 2 column(s)

Indexes

Name | Type | Unique
SYS_IOT_TOP_52335 | IOT - TOP | UNIQUE
Total: 1 index(s)

Constraints

Name | Type | Status | Delete rule | Defferable | Deffered
SYS_C005373 | Check | Enabled |  | Not Deferrable | Immediate
SYS_IOT_TOP_52335 | Primary Key | Enabled |  | Not Deferrable | Immediate
Total: 2 constraints

DDL

CREATE TABLE "SH"."DR$SUP_TEXT_IDX$N"
( "NLT_DOCID" NUMBER(38,0),
"NLT_MARK" CHAR(1) NOT NULL ENABLE,
PRIMARY KEY ("NLT_DOCID") ENABLE
) ORGANIZATION INDEX NOCOMPRESS PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE"
PCTTHRESHOLD 50

See Also

List of tables


List of indexes

Indexes

Name | Type | Unique
SYS_IOT_TOP_52335 | IOT - TOP | UNIQUE
Total: 1 index(s)

See Also

Table [DR$SUP_TEXT_IDX$N]


Index: SYS_IOT_TOP_52335 on table DR$SUP_TEXT_IDX$N

Properties

Name: | SYS_IOT_TOP_52335
Type: | IOT - TOP
Unique: | UNIQUE
Tablespace: | EXAMPLE
Status: | VALID
Table owner: | SH
Table name: | DR$SUP_TEXT_IDX$N
Temporary: | No
Join Index: | No
Initial extent size: | 65536
Secondary extent size: |
Min extents: | 1
Max extents: | 2147483645
Percent encrease: |
Distinct keys: |
Minimum free %: | 10

Index Columns

Name | Length | Descend
NLT_DOCID | 22 | ASC
Total: 1 column(s)

DDL

CREATE UNIQUE INDEX "SH"."SYS_IOT_TOP_52335" ON "SH"."DR$SUP_TEXT_IDX$N" ("NLT_DOCID")
PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE"

See Also

List of indexes


List of constraints

Constraints

Name | Type | Status | Delete rule | Defferable | Deffered
SYS_C005373 | Check | Enabled |  | Not Deferrable | Immediate
SYS_IOT_TOP_52335 | Primary Key | Enabled |  | Not Deferrable | Immediate
Total: 2 constraint(s)

See Also

Table [DR$SUP_TEXT_IDX$N]


Constraint: SYS_C005373 on table DR$SUP_TEXT_IDX$N

Properties

Name: | SYS_C005373
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
NLT_MARK
Total: 1 column(s)

DDL

ALTER TABLE "SH"."DR$SUP_TEXT_IDX$N" MODIFY ("NLT_MARK" NOT NULL ENABLE)

See Also

List of constraints
Table [DR$SUP_TEXT_IDX$N]


Constraint: SYS_IOT_TOP_52335 on table DR$SUP_TEXT_IDX$N

Properties

Name: | SYS_IOT_TOP_52335
Type: | Primary Key
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
NLT_DOCID
Total: 1 column(s)

DDL

ALTER TABLE "SH"."DR$SUP_TEXT_IDX$N" ADD PRIMARY KEY ("NLT_DOCID")
USING INDEX PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" ENABLE

See Also

List of constraints
Table [DR$SUP_TEXT_IDX$N]


Table: DR$SUP_TEXT_IDX$R

Properties

Name: | DR$SUP_TEXT_IDX$R
Status: | VALID
Tablespace: | EXAMPLE
Logging: | N
Partitioned: |
Cached: | ENABLED
Locking: |
IOT type: |
Object type: |
Type owner: |
Type: | N
Temporary: | Y
Secondary: | NO
Nested: | DEFAULT
Buffer pool: | DISABLED
Row movement: | NO
Index Only Table: |
Minimum % of free space: | 10
Minimum % of udes space: |
Initial transactions: | 1
Max transactions: | 65536
Initial extent size, bytes: |
Secondary extent size, bytes: | 1
Min extents: | 2147483645
Max extents: |
% increase in extent: |
Process free list: |
Process free list groups: | NO
Backee up: |
Rows: |
Used blocks: |
Empty blocks: |
Average free space: |
Chained rows: |
Average row length: |
Average freespace on a freelist: |
Blocks on a freelist: | 1
Threds per instance: | 1
Instances: | N
Sample size: |
Last analysed: | NO
Global statistics: | NO
User statistics: | NO
Duration: |
Skip corrupt blocks: | DISABLED
Monitoring: | YES
Cluster owner: |
Dependencies: | DISABLED
SizeMB: | 0,06
Extents: | 1
SizeBytes: | 65536
Description: |

Columns

Name | Type | Length | Nchar Length | Precision | Scale | NULL | Default | Description
ROW_NO | NUMBER | 3 |  | 3 | 0 | Y |  |
DATA | BLOB | 4000 |  |  |  | Y |  |
Total: 2 column(s)

Indexes

Name | Type | Unique
SYS_IL0000052332C00002$$ | LOB | UNIQUE
Total: 1 index(s)

DDL

CREATE TABLE "SH"."DR$SUP_TEXT_IDX$R"
( "ROW_NO" NUMBER(3,0),
"DATA" BLOB
) PCTFREE 10 PCTUSED 40 INITRANS 1 MAXTRANS 255 NOCOMPRESS NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE"
LOB ("DATA") STORE AS (
TABLESPACE "EXAMPLE" ENABLE STORAGE IN ROW CHUNK 8192 PCTVERSION 10
CACHE
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT))

See Also

List of tables


List of indexes

Indexes

Name | Type | Unique
SYS_IL0000052332C00002$$ | LOB | UNIQUE
Total: 1 index(s)

See Also

Table [DR$SUP_TEXT_IDX$R]


Index: SYS_IL0000052332C00002$$ on table DR$SUP_TEXT_IDX$R

Properties

Name: | SYS_IL0000052332C00002$$
Type: | LOB
Unique: | UNIQUE
Tablespace: | EXAMPLE
Status: | VALID
Table owner: | SH
Table name: | DR$SUP_TEXT_IDX$R
Temporary: | No
Join Index: | No
Initial extent size: | 65536
Secondary extent size: |
Min extents: | 1
Max extents: | 2147483645
Percent encrease: |
Distinct keys: |
Minimum free %: | 10

DDL

CREATE UNIQUE INDEX "SH"."SYS_IL0000052332C00002$$" ON "SH"."DR$SUP_TEXT_IDX$R" (
PCTFREE 10 INITRANS 2 MAXTRANS 255
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE"
PARALLEL (DEGREE 0 INSTANCES 0)

See Also

List of indexes


Table: MVIEW$_EXCEPTIONS

Properties

Name: | MVIEW$_EXCEPTIONS
Status: | VALID
Tablespace: | EXAMPLE
Logging: | N
Partitioned: |
Cached: | ENABLED
Locking: | 0
IOT type: |
Object type: |
Type owner: |
Type: | N
Temporary: | N
Secondary: | NO
Nested: | DEFAULT
Buffer pool: | DISABLED
Row movement: | YES
Index Only Table: |
Minimum % of free space: | 10
Minimum % of udes space: |
Initial transactions: | 1
Max transactions: | 65536
Initial extent size, bytes: |
Secondary extent size, bytes: | 1
Min extents: | 2147483645
Max extents: |
% increase in extent: |
Process free list: |
Process free list groups: | NO
Backee up: | 0
Rows: | 0
Used blocks: | 0
Empty blocks: | 0
Average free space: | 0
Chained rows: | 0
Average row length: | 0
Average freespace on a freelist: | 0
Blocks on a freelist: | 1
Threds per instance: | 1
Instances: | N
Sample size: | 03.15.2007
Last analysed: | NO
Global statistics: | YES
User statistics: | NO
Duration: |
Skip corrupt blocks: | DISABLED
Monitoring: | YES
Cluster owner: |
Dependencies: | DISABLED
SizeMB: | 0,06
Extents: | 1
SizeBytes: | 65536
Description: |

Columns

Name | Type | Length | Nchar Length | Precision | Scale | NULL | Default | Description
OWNER | VARCHAR2 | 30 | 30 |  |  | N |  |
TABLE_NAME | VARCHAR2 | 30 | 30 |  |  | N |  |
DIMENSION_NAME | VARCHAR2 | 30 | 30 |  |  | N |  |
RELATIONSHIP | VARCHAR2 | 11 | 11 |  |  | N |  |
BAD_ROWID | ROWID | 10 |  |  |  | N |  |
Total: 5 column(s)

Constraints

Name | Type | Status | Delete rule | Defferable | Deffered
SYS_C005326 | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005327 | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005328 | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005329 | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005330 | Check | Enabled |  | Not Deferrable | Immediate
Total: 5 constraints

DDL

CREATE TABLE "SH"."MVIEW$_EXCEPTIONS"
( "OWNER" VARCHAR2(30) NOT NULL ENABLE,
"TABLE_NAME" VARCHAR2(30) NOT NULL ENABLE,
"DIMENSION_NAME" VARCHAR2(30) NOT NULL ENABLE,
"RELATIONSHIP" VARCHAR2(11) NOT NULL ENABLE,
"BAD_ROWID" ROWID NOT NULL ENABLE
) PCTFREE 10 PCTUSED 40 INITRANS 1 MAXTRANS 255 NOCOMPRESS NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE"

See Also

List of tables


List of constraints

Constraints

Name | Type | Status | Delete rule | Defferable | Deffered
SYS_C005326 | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005327 | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005328 | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005329 | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005330 | Check | Enabled |  | Not Deferrable | Immediate
Total: 5 constraint(s)

See Also

Table [MVIEW$_EXCEPTIONS]


Constraint: SYS_C005326 on table MVIEW$_EXCEPTIONS

Properties

Name: | SYS_C005326
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
OWNER
Total: 1 column(s)

DDL

ALTER TABLE "SH"."MVIEW$_EXCEPTIONS" MODIFY ("OWNER" NOT NULL ENABLE)

See Also

List of constraints
Table [MVIEW$_EXCEPTIONS]


Constraint: SYS_C005327 on table MVIEW$_EXCEPTIONS

Properties

Name: | SYS_C005327
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
TABLE_NAME
Total: 1 column(s)

DDL

ALTER TABLE "SH"."MVIEW$_EXCEPTIONS" MODIFY ("TABLE_NAME" NOT NULL ENABLE)

See Also

List of constraints
Table [MVIEW$_EXCEPTIONS]


Constraint: SYS_C005328 on table MVIEW$_EXCEPTIONS

Properties

Name: | SYS_C005328
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
DIMENSION_NAME
Total: 1 column(s)

DDL

ALTER TABLE "SH"."MVIEW$_EXCEPTIONS" MODIFY ("DIMENSION_NAME" NOT NULL ENABLE)

See Also

List of constraints
Table [MVIEW$_EXCEPTIONS]


Constraint: SYS_C005329 on table MVIEW$_EXCEPTIONS

Properties

Name: | SYS_C005329
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
RELATIONSHIP
Total: 1 column(s)

DDL

ALTER TABLE "SH"."MVIEW$_EXCEPTIONS" MODIFY ("RELATIONSHIP" NOT NULL ENABLE)

See Also

List of constraints
Table [MVIEW$_EXCEPTIONS]


Constraint: SYS_C005330 on table MVIEW$_EXCEPTIONS

Properties

Name: | SYS_C005330
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
BAD_ROWID
Total: 1 column(s)

DDL

ALTER TABLE "SH"."MVIEW$_EXCEPTIONS" MODIFY ("BAD_ROWID" NOT NULL ENABLE)

See Also

List of constraints
Table [MVIEW$_EXCEPTIONS]


Table: PRODUCTS

Properties

Name: | PRODUCTS
Status: | VALID
Tablespace: | EXAMPLE
Logging: | N
Partitioned: |
Cached: | ENABLED
Locking: | 2000
IOT type: |
Object type: |
Type owner: |
Type: | N
Temporary: | N
Secondary: | NO
Nested: | DEFAULT
Buffer pool: | DISABLED
Row movement: | YES
Index Only Table: |
Minimum % of free space: | 10
Minimum % of udes space: |
Initial transactions: | 1
Max transactions: | 65536
Initial extent size, bytes: |
Secondary extent size, bytes: | 1
Min extents: | 2147483645
Max extents: |
% increase in extent: |
Process free list: |
Process free list groups: | NO
Backee up: | 72
Rows: | 5
Used blocks: | 0
Empty blocks: | 0
Average free space: | 0
Chained rows: | 170
Average row length: | 0
Average freespace on a freelist: | 0
Blocks on a freelist: | 1
Threds per instance: | 1
Instances: | N
Sample size: | 03.15.2007
Last analysed: | NO
Global statistics: | YES
User statistics: | NO
Duration: |
Skip corrupt blocks: | DISABLED
Monitoring: | YES
Cluster owner: |
Dependencies: | DISABLED
SizeMB: | 0,06
Extents: | 1
SizeBytes: | 65536
Description: | dimension table

Columns

Name | Type | Length | Nchar Length | Precision | Scale | NULL | Default | Description
PROD_ID | NUMBER | 6 |  | 6 | 0 | N |  | primary key
PROD_NAME | VARCHAR2 | 50 | 50 |  |  | N |  | product name
PROD_DESC | VARCHAR2 | 4000 | 4000 |  |  | N |  | product description
PROD_SUBCATEGORY | VARCHAR2 | 50 | 50 |  |  | N |  | product subcategory
PROD_SUBCATEGORY_ID | NUMBER |  |  |  |  | N |  |
PROD_SUBCATEGORY_DESC | VARCHAR2 | 2000 | 2000 |  |  | N |  | product subcategory description
PROD_CATEGORY | VARCHAR2 | 50 | 50 |  |  | N |  | product category
PROD_CATEGORY_ID | NUMBER |  |  |  |  | N |  |
PROD_CATEGORY_DESC | VARCHAR2 | 2000 | 2000 |  |  | N |  | product category description
PROD_WEIGHT_CLASS | NUMBER | 3 |  | 3 | 0 | N |  | product weight class
PROD_UNIT_OF_MEASURE | VARCHAR2 | 20 | 20 |  |  | Y |  | product unit of measure
PROD_PACK_SIZE | VARCHAR2 | 30 | 30 |  |  | N |  | product package size
SUPPLIER_ID | NUMBER | 6 |  | 6 | 0 | N |  | this column
PROD_STATUS | VARCHAR2 | 20 | 20 |  |  | N |  | product status
PROD_LIST_PRICE | NUMBER | 10 |  | 8 | 2 | N |  | product list price
PROD_MIN_PRICE | NUMBER | 10 |  | 8 | 2 | N |  | product minimum price
PROD_TOTAL | VARCHAR2 | 13 | 13 |  |  | N |  |
PROD_TOTAL_ID | NUMBER |  |  |  |  | N |  |
PROD_SRC_ID | NUMBER |  |  |  |  | Y |  |
PROD_EFF_FROM | DATE | 7 |  |  |  | Y |  |
PROD_EFF_TO | DATE | 7 |  |  |  | Y |  |
PROD_VALID | VARCHAR2 | 1 | 1 |  |  | Y |  |
Total: 22 column(s)

Indexes

Name | Type | Unique
PRODUCTS_PK | NORMAL | UNIQUE
PRODUCTS_PROD_CAT_IX | NORMAL | NONUNIQUE
PRODUCTS_PROD_STATUS_BIX | BITMAP | NONUNIQUE
PRODUCTS_PROD_SUBCAT_IX | NORMAL | NONUNIQUE
Total: 4 index(s)

Constraints

Name | Type | Status | Delete rule | Defferable | Deffered
PRODUCTS_PK | Primary Key | Enabled |  | Not Deferrable | Immediate
SYS_C005261 | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005262 | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005263 | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005264 | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005265 | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005266 | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005267 | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005268 | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005269 | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005270 | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005271 | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005272 | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005273 | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005274 | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005275 | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005276 | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005277 | Check | Enabled |  | Not Deferrable | Immediate
Total: 18 constraints

Grants

Privilage | Grantee | Grantable | Grantor
SELECT | BI | NO | SH
Total: 1 grants

Referenced tables

Name | Owner | Constraint | DELETE_RULE
COSTS | SH | COSTS_PRODUCT_FK | NO ACTION
SALES | SH | SALES_PRODUCT_FK | NO ACTION
Total: 2 referenced table(s)

Table used by

Owner | Name | Type
BI | PRODUCTS | SYNONYM
SH | PRODUCTS_DIM | DIMENSION
SH | FWEEK_PSCAT_SALES_MV | MATERIALIZED VIEW
Total: 3 used by reference(s)

DDL

CREATE TABLE "SH"."PRODUCTS"
( "PROD_ID" NUMBER(6,0) NOT NULL ENABLE,
"PROD_NAME" VARCHAR2(50) NOT NULL ENABLE,
"PROD_DESC" VARCHAR2(4000) NOT NULL ENABLE,
"PROD_SUBCATEGORY" VARCHAR2(50) NOT NULL ENABLE,
"PROD_SUBCATEGORY_ID" NUMBER NOT NULL ENABLE,
"PROD_SUBCATEGORY_DESC" VARCHAR2(2000) NOT NULL ENABLE,
"PROD_CATEGORY" VARCHAR2(50) NOT NULL ENABLE,
"PROD_CATEGORY_ID" NUMBER NOT NULL ENABLE,
"PROD_CATEGORY_DESC" VARCHAR2(2000) NOT NULL ENABLE,
"PROD_WEIGHT_CLASS" NUMBER(3,0) NOT NULL ENABLE,
"PROD_UNIT_OF_MEASURE" VARCHAR2(20),
"PROD_PACK_SIZE" VARCHAR2(30) NOT NULL ENABLE,
"SUPPLIER_ID" NUMBER(6,0) NOT NULL ENABLE,
"PROD_STATUS" VARCHAR2(20) NOT NULL ENABLE,
"PROD_LIST_PRICE" NUMBER(8,2) NOT NULL ENABLE,
"PROD_MIN_PRICE" NUMBER(8,2) NOT NULL ENABLE,
"PROD_TOTAL" VARCHAR2(13) NOT NULL ENABLE,
"PROD_TOTAL_ID" NUMBER NOT NULL ENABLE,
"PROD_SRC_ID" NUMBER,
"PROD_EFF_FROM" DATE,
"PROD_EFF_TO" DATE,
"PROD_VALID" VARCHAR2(1),
CONSTRAINT "PRODUCTS_PK" PRIMARY KEY ("PROD_ID")
USING INDEX PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING COMPUTE STATISTICS
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" ENABLE NOVALIDATE
) PCTFREE 10 PCTUSED 40 INITRANS 1 MAXTRANS 255 NOCOMPRESS NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE"

See Also

List of tables


List of indexes

Indexes

Name | Type | Unique
PRODUCTS_PK | NORMAL | UNIQUE
PRODUCTS_PROD_CAT_IX | NORMAL | NONUNIQUE
PRODUCTS_PROD_STATUS_BIX | BITMAP | NONUNIQUE
PRODUCTS_PROD_SUBCAT_IX | NORMAL | NONUNIQUE
Total: 4 index(s)

See Also

Table [PRODUCTS]


Index: PRODUCTS_PK on table PRODUCTS

Properties

Name: | PRODUCTS_PK
Type: | NORMAL
Unique: | UNIQUE
Tablespace: | EXAMPLE
Status: | VALID
Table owner: | SH
Table name: | PRODUCTS
Temporary: | No
Join Index: | No
Initial extent size: | 65536
Secondary extent size: |
Min extents: | 1
Max extents: | 2147483645
Percent encrease: |
Distinct keys: | 72
Minimum free %: | 10

Index Columns

Name | Length | Descend
PROD_ID | 22 | ASC
Total: 1 column(s)

DDL

CREATE UNIQUE INDEX "SH"."PRODUCTS_PK" ON "SH"."PRODUCTS" ("PROD_ID")
PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING COMPUTE STATISTICS
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE"

See Also

List of indexes


Index: PRODUCTS_PROD_CAT_IX on table PRODUCTS

Properties

Name: | PRODUCTS_PROD_CAT_IX
Type: | NORMAL
Unique: | NONUNIQUE
Tablespace: | EXAMPLE
Status: | VALID
Table owner: | SH
Table name: | PRODUCTS
Temporary: | No
Join Index: | No
Initial extent size: | 65536
Secondary extent size: |
Min extents: | 1
Max extents: | 2147483645
Percent encrease: |
Distinct keys: | 5
Minimum free %: | 10

Index Columns

Name | Length | Descend
PROD_CATEGORY | 50 | ASC
Total: 1 column(s)

DDL

CREATE INDEX "SH"."PRODUCTS_PROD_CAT_IX" ON "SH"."PRODUCTS" ("PROD_CATEGORY")
PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING COMPUTE STATISTICS
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE"

See Also

List of indexes


Index: PRODUCTS_PROD_STATUS_BIX on table PRODUCTS

Properties

Name: | PRODUCTS_PROD_STATUS_BIX
Type: | BITMAP
Unique: | NONUNIQUE
Tablespace: | EXAMPLE
Status: | VALID
Table owner: | SH
Table name: | PRODUCTS
Temporary: | No
Join Index: | No
Initial extent size: | 65536
Secondary extent size: |
Min extents: | 1
Max extents: | 2147483645
Percent encrease: |
Distinct keys: | 1
Minimum free %: | 10

Index Columns

Name | Length | Descend
PROD_STATUS | 20 | ASC
Total: 1 column(s)

DDL

CREATE BITMAP INDEX "SH"."PRODUCTS_PROD_STATUS_BIX" ON "SH"."PRODUCTS" ("PROD_STATUS")
PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING COMPUTE STATISTICS
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE"

See Also

List of indexes


Index: PRODUCTS_PROD_SUBCAT_IX on table PRODUCTS

Properties

Name: | PRODUCTS_PROD_SUBCAT_IX
Type: | NORMAL
Unique: | NONUNIQUE
Tablespace: | EXAMPLE
Status: | VALID
Table owner: | SH
Table name: | PRODUCTS
Temporary: | No
Join Index: | No
Initial extent size: | 65536
Secondary extent size: |
Min extents: | 1
Max extents: | 2147483645
Percent encrease: |
Distinct keys: | 21
Minimum free %: | 10

Index Columns

Name | Length | Descend
PROD_SUBCATEGORY | 50 | ASC
Total: 1 column(s)

DDL

CREATE INDEX "SH"."PRODUCTS_PROD_SUBCAT_IX" ON "SH"."PRODUCTS" ("PROD_SUBCATEGORY")
PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING COMPUTE STATISTICS
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE"

See Also

List of indexes


List of constraints

Constraints

Name | Type | Status | Delete rule | Defferable | Deffered
PRODUCTS_PK | Primary Key | Enabled |  | Not Deferrable | Immediate
SYS_C005261 | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005262 | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005263 | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005264 | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005265 | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005266 | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005267 | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005268 | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005269 | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005270 | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005271 | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005272 | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005273 | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005274 | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005275 | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005276 | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005277 | Check | Enabled |  | Not Deferrable | Immediate
Total: 18 constraint(s)

See Also

Table [PRODUCTS]


Constraint: PRODUCTS_PK on table PRODUCTS

Properties

Name: | PRODUCTS_PK
Type: | Primary Key
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
PROD_ID
Total: 1 column(s)

DDL

ALTER TABLE "SH"."PRODUCTS" ADD CONSTRAINT "PRODUCTS_PK" PRIMARY KEY ("PROD_ID")
USING INDEX PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING COMPUTE STATISTICS
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" ENABLE NOVALIDATE

See Also

List of constraints
Table [PRODUCTS]


Constraint: SYS_C005261 on table PRODUCTS

Properties

Name: | SYS_C005261
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
PROD_ID
Total: 1 column(s)

DDL

ALTER TABLE "SH"."PRODUCTS" MODIFY ("PROD_ID" NOT NULL ENABLE)

See Also

List of constraints
Table [PRODUCTS]


Constraint: SYS_C005262 on table PRODUCTS

Properties

Name: | SYS_C005262
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
PROD_NAME
Total: 1 column(s)

DDL

ALTER TABLE "SH"."PRODUCTS" MODIFY ("PROD_NAME" NOT NULL ENABLE)

See Also

List of constraints
Table [PRODUCTS]


Constraint: SYS_C005263 on table PRODUCTS

Properties

Name: | SYS_C005263
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
PROD_DESC
Total: 1 column(s)

DDL

ALTER TABLE "SH"."PRODUCTS" MODIFY ("PROD_DESC" NOT NULL ENABLE)

See Also

List of constraints
Table [PRODUCTS]


Constraint: SYS_C005264 on table PRODUCTS

Properties

Name: | SYS_C005264
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
PROD_SUBCATEGORY
Total: 1 column(s)

DDL

ALTER TABLE "SH"."PRODUCTS" MODIFY ("PROD_SUBCATEGORY" NOT NULL ENABLE)

See Also

List of constraints
Table [PRODUCTS]


Constraint: SYS_C005265 on table PRODUCTS

Properties

Name: | SYS_C005265
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
PROD_SUBCATEGORY_ID
Total: 1 column(s)

DDL

ALTER TABLE "SH"."PRODUCTS" MODIFY ("PROD_SUBCATEGORY_ID" NOT NULL ENABLE)

See Also

List of constraints
Table [PRODUCTS]


Constraint: SYS_C005266 on table PRODUCTS

Properties

Name: | SYS_C005266
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
PROD_SUBCATEGORY_DESC
Total: 1 column(s)

DDL

ALTER TABLE "SH"."PRODUCTS" MODIFY ("PROD_SUBCATEGORY_DESC" NOT NULL ENABLE)

See Also

List of constraints
Table [PRODUCTS]


Constraint: SYS_C005267 on table PRODUCTS

Properties

Name: | SYS_C005267
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
PROD_CATEGORY
Total: 1 column(s)

DDL

ALTER TABLE "SH"."PRODUCTS" MODIFY ("PROD_CATEGORY" NOT NULL ENABLE)

See Also

List of constraints
Table [PRODUCTS]


Constraint: SYS_C005268 on table PRODUCTS

Properties

Name: | SYS_C005268
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
PROD_CATEGORY_ID
Total: 1 column(s)

DDL

ALTER TABLE "SH"."PRODUCTS" MODIFY ("PROD_CATEGORY_ID" NOT NULL ENABLE)

See Also

List of constraints
Table [PRODUCTS]


Constraint: SYS_C005269 on table PRODUCTS

Properties

Name: | SYS_C005269
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
PROD_CATEGORY_DESC
Total: 1 column(s)

DDL

ALTER TABLE "SH"."PRODUCTS" MODIFY ("PROD_CATEGORY_DESC" NOT NULL ENABLE)

See Also

List of constraints
Table [PRODUCTS]


Constraint: SYS_C005270 on table PRODUCTS

Properties

Name: | SYS_C005270
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
PROD_WEIGHT_CLASS
Total: 1 column(s)

DDL

ALTER TABLE "SH"."PRODUCTS" MODIFY ("PROD_WEIGHT_CLASS" NOT NULL ENABLE)

See Also

List of constraints
Table [PRODUCTS]


Constraint: SYS_C005271 on table PRODUCTS

Properties

Name: | SYS_C005271
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
PROD_PACK_SIZE
Total: 1 column(s)

DDL

ALTER TABLE "SH"."PRODUCTS" MODIFY ("PROD_PACK_SIZE" NOT NULL ENABLE)

See Also

List of constraints
Table [PRODUCTS]


Constraint: SYS_C005272 on table PRODUCTS

Properties

Name: | SYS_C005272
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
SUPPLIER_ID
Total: 1 column(s)

DDL

ALTER TABLE "SH"."PRODUCTS" MODIFY ("SUPPLIER_ID" NOT NULL ENABLE)

See Also

List of constraints
Table [PRODUCTS]


Constraint: SYS_C005273 on table PRODUCTS

Properties

Name: | SYS_C005273
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
PROD_STATUS
Total: 1 column(s)

DDL

ALTER TABLE "SH"."PRODUCTS" MODIFY ("PROD_STATUS" NOT NULL ENABLE)

See Also

List of constraints
Table [PRODUCTS]


Constraint: SYS_C005274 on table PRODUCTS

Properties

Name: | SYS_C005274
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
PROD_LIST_PRICE
Total: 1 column(s)

DDL

ALTER TABLE "SH"."PRODUCTS" MODIFY ("PROD_LIST_PRICE" NOT NULL ENABLE)

See Also

List of constraints
Table [PRODUCTS]


Constraint: SYS_C005275 on table PRODUCTS

Properties

Name: | SYS_C005275
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
PROD_MIN_PRICE
Total: 1 column(s)

DDL

ALTER TABLE "SH"."PRODUCTS" MODIFY ("PROD_MIN_PRICE" NOT NULL ENABLE)

See Also

List of constraints
Table [PRODUCTS]


Constraint: SYS_C005276 on table PRODUCTS

Properties

Name: | SYS_C005276
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
PROD_TOTAL
Total: 1 column(s)

DDL

ALTER TABLE "SH"."PRODUCTS" MODIFY ("PROD_TOTAL" NOT NULL ENABLE)

See Also

List of constraints
Table [PRODUCTS]


Constraint: SYS_C005277 on table PRODUCTS

Properties

Name: | SYS_C005277
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
PROD_TOTAL_ID
Total: 1 column(s)

DDL

ALTER TABLE "SH"."PRODUCTS" MODIFY ("PROD_TOTAL_ID" NOT NULL ENABLE)

See Also

List of constraints
Table [PRODUCTS]


Table: PROMOTIONS

Properties

Name: | PROMOTIONS
Status: | VALID
Tablespace: | EXAMPLE
Logging: | N
Partitioned: |
Cached: | ENABLED
Locking: | 2000
IOT type: |
Object type: |
Type owner: |
Type: | N
Temporary: | N
Secondary: | NO
Nested: | DEFAULT
Buffer pool: | DISABLED
Row movement: | YES
Index Only Table: |
Minimum % of free space: | 10
Minimum % of udes space: |
Initial transactions: | 1
Max transactions: | 65536
Initial extent size, bytes: |
Secondary extent size, bytes: | 1
Min extents: | 2147483645
Max extents: |
% increase in extent: |
Process free list: |
Process free list groups: | NO
Backee up: | 503
Rows: | 57
Used blocks: | 0
Empty blocks: | 0
Average free space: | 0
Chained rows: | 97
Average row length: | 0
Average freespace on a freelist: | 0
Blocks on a freelist: | 1
Threds per instance: | 1
Instances: | N
Sample size: | 03.15.2007
Last analysed: | NO
Global statistics: | YES
User statistics: | NO
Duration: |
Skip corrupt blocks: | DISABLED
Monitoring: | YES
Cluster owner: |
Dependencies: | DISABLED
SizeMB: | 0,5
Extents: | 8
SizeBytes: | 524288
Description: | dimension table without a PK-FK relationship with the facts table, to show outer join functionality

Columns

Name | Type | Length | Nchar Length | Precision | Scale | NULL | Default | Description
PROMO_ID | NUMBER | 6 |  | 6 | 0 | N |  | primary key column
PROMO_NAME | VARCHAR2 | 30 | 30 |  |  | N |  | promotion description
PROMO_SUBCATEGORY | VARCHAR2 | 30 | 30 |  |  | N |  | enables to investigate promotion hierarchies
PROMO_SUBCATEGORY_ID | NUMBER |  |  |  |  | N |  |
PROMO_CATEGORY | VARCHAR2 | 30 | 30 |  |  | N |  | promotion category
PROMO_CATEGORY_ID | NUMBER |  |  |  |  | N |  |
PROMO_COST | NUMBER | 12 |  | 10 | 2 | N |  | promotion cost, to do promotion effect calculations
PROMO_BEGIN_DATE | DATE | 7 |  |  |  | N |  | promotion begin day
PROMO_END_DATE | DATE | 7 |  |  |  | N |  | promotion end day
PROMO_TOTAL | VARCHAR2 | 15 | 15 |  |  | N |  |
PROMO_TOTAL_ID | NUMBER |  |  |  |  | N |  |
Total: 11 column(s)

Indexes

Name | Type | Unique
PROMO_PK | NORMAL | UNIQUE
Total: 1 index(s)

Constraints

Name | Type | Status | Delete rule | Defferable | Deffered
PROMO_PK | Primary Key | Enabled |  | Not Deferrable | Immediate
SYS_C005286 | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005287 | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005288 | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005289 | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005290 | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005291 | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005292 | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005293 | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005294 | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005295 | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005296 | Check | Enabled |  | Not Deferrable | Immediate
Total: 12 constraints

Grants

Privilage | Grantee | Grantable | Grantor
SELECT | BI | NO | SH
Total: 1 grants

Referenced tables

Name | Owner | Constraint | DELETE_RULE
COSTS | SH | COSTS_PROMO_FK | NO ACTION
SALES | SH | SALES_PROMO_FK | NO ACTION
Total: 2 referenced table(s)

Table used by

Owner | Name | Type
SH | PROMOTIONS_DIM | DIMENSION
BI | PROMOTIONS | SYNONYM
Total: 2 used by reference(s)

DDL

CREATE TABLE "SH"."PROMOTIONS"
( "PROMO_ID" NUMBER(6,0) NOT NULL ENABLE,
"PROMO_NAME" VARCHAR2(30) NOT NULL ENABLE,
"PROMO_SUBCATEGORY" VARCHAR2(30) NOT NULL ENABLE,
"PROMO_SUBCATEGORY_ID" NUMBER NOT NULL ENABLE,
"PROMO_CATEGORY" VARCHAR2(30) NOT NULL ENABLE,
"PROMO_CATEGORY_ID" NUMBER NOT NULL ENABLE,
"PROMO_COST" NUMBER(10,2) NOT NULL ENABLE,
"PROMO_BEGIN_DATE" DATE NOT NULL ENABLE,
"PROMO_END_DATE" DATE NOT NULL ENABLE,
"PROMO_TOTAL" VARCHAR2(15) NOT NULL ENABLE,
"PROMO_TOTAL_ID" NUMBER NOT NULL ENABLE,
CONSTRAINT "PROMO_PK" PRIMARY KEY ("PROMO_ID")
USING INDEX PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING COMPUTE STATISTICS
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" ENABLE NOVALIDATE
) PCTFREE 10 PCTUSED 40 INITRANS 1 MAXTRANS 255 NOCOMPRESS NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE"

See Also

List of tables


List of indexes

Indexes

Name | Type | Unique
PROMO_PK | NORMAL | UNIQUE
Total: 1 index(s)

See Also

Table [PROMOTIONS]


Index: PROMO_PK on table PROMOTIONS

Properties

Name: | PROMO_PK
Type: | NORMAL
Unique: | UNIQUE
Tablespace: | EXAMPLE
Status: | VALID
Table owner: | SH
Table name: | PROMOTIONS
Temporary: | No
Join Index: | No
Initial extent size: | 65536
Secondary extent size: |
Min extents: | 1
Max extents: | 2147483645
Percent encrease: |
Distinct keys: | 503
Minimum free %: | 10

Index Columns

Name | Length | Descend
PROMO_ID | 22 | ASC
Total: 1 column(s)

DDL

CREATE UNIQUE INDEX "SH"."PROMO_PK" ON "SH"."PROMOTIONS" ("PROMO_ID")
PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING COMPUTE STATISTICS
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE"

See Also

List of indexes


List of constraints

Constraints

Name | Type | Status | Delete rule | Defferable | Deffered
PROMO_PK | Primary Key | Enabled |  | Not Deferrable | Immediate
SYS_C005286 | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005287 | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005288 | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005289 | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005290 | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005291 | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005292 | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005293 | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005294 | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005295 | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005296 | Check | Enabled |  | Not Deferrable | Immediate
Total: 12 constraint(s)

See Also

Table [PROMOTIONS]


Constraint: PROMO_PK on table PROMOTIONS

Properties

Name: | PROMO_PK
Type: | Primary Key
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
PROMO_ID
Total: 1 column(s)

DDL

ALTER TABLE "SH"."PROMOTIONS" ADD CONSTRAINT "PROMO_PK" PRIMARY KEY ("PROMO_ID")
USING INDEX PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING COMPUTE STATISTICS
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" ENABLE NOVALIDATE

See Also

List of constraints
Table [PROMOTIONS]


Constraint: SYS_C005286 on table PROMOTIONS

Properties

Name: | SYS_C005286
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
PROMO_ID
Total: 1 column(s)

DDL

ALTER TABLE "SH"."PROMOTIONS" MODIFY ("PROMO_ID" NOT NULL ENABLE)

See Also

List of constraints
Table [PROMOTIONS]


Constraint: SYS_C005287 on table PROMOTIONS

Properties

Name: | SYS_C005287
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
PROMO_NAME
Total: 1 column(s)

DDL

ALTER TABLE "SH"."PROMOTIONS" MODIFY ("PROMO_NAME" NOT NULL ENABLE)

See Also

List of constraints
Table [PROMOTIONS]


Constraint: SYS_C005288 on table PROMOTIONS

Properties

Name: | SYS_C005288
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
PROMO_SUBCATEGORY
Total: 1 column(s)

DDL

ALTER TABLE "SH"."PROMOTIONS" MODIFY ("PROMO_SUBCATEGORY" NOT NULL ENABLE)

See Also

List of constraints
Table [PROMOTIONS]


Constraint: SYS_C005289 on table PROMOTIONS

Properties

Name: | SYS_C005289
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
PROMO_SUBCATEGORY_ID
Total: 1 column(s)

DDL

ALTER TABLE "SH"."PROMOTIONS" MODIFY ("PROMO_SUBCATEGORY_ID" NOT NULL ENABLE)

See Also

List of constraints
Table [PROMOTIONS]


Constraint: SYS_C005290 on table PROMOTIONS

Properties

Name: | SYS_C005290
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
PROMO_CATEGORY
Total: 1 column(s)

DDL

ALTER TABLE "SH"."PROMOTIONS" MODIFY ("PROMO_CATEGORY" NOT NULL ENABLE)

See Also

List of constraints
Table [PROMOTIONS]


Constraint: SYS_C005291 on table PROMOTIONS

Properties

Name: | SYS_C005291
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
PROMO_CATEGORY_ID
Total: 1 column(s)

DDL

ALTER TABLE "SH"."PROMOTIONS" MODIFY ("PROMO_CATEGORY_ID" NOT NULL ENABLE)

See Also

List of constraints
Table [PROMOTIONS]


Constraint: SYS_C005292 on table PROMOTIONS

Properties

Name: | SYS_C005292
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
PROMO_COST
Total: 1 column(s)

DDL

ALTER TABLE "SH"."PROMOTIONS" MODIFY ("PROMO_COST" NOT NULL ENABLE)

See Also

List of constraints
Table [PROMOTIONS]


Constraint: SYS_C005293 on table PROMOTIONS

Properties

Name: | SYS_C005293
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
PROMO_BEGIN_DATE
Total: 1 column(s)

DDL

ALTER TABLE "SH"."PROMOTIONS" MODIFY ("PROMO_BEGIN_DATE" NOT NULL ENABLE)

See Also

List of constraints
Table [PROMOTIONS]


Constraint: SYS_C005294 on table PROMOTIONS

Properties

Name: | SYS_C005294
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
PROMO_END_DATE
Total: 1 column(s)

DDL

ALTER TABLE "SH"."PROMOTIONS" MODIFY ("PROMO_END_DATE" NOT NULL ENABLE)

See Also

List of constraints
Table [PROMOTIONS]


Constraint: SYS_C005295 on table PROMOTIONS

Properties

Name: | SYS_C005295
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
PROMO_TOTAL
Total: 1 column(s)

DDL

ALTER TABLE "SH"."PROMOTIONS" MODIFY ("PROMO_TOTAL" NOT NULL ENABLE)

See Also

List of constraints
Table [PROMOTIONS]


Constraint: SYS_C005296 on table PROMOTIONS

Properties

Name: | SYS_C005296
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
PROMO_TOTAL_ID
Total: 1 column(s)

DDL

ALTER TABLE "SH"."PROMOTIONS" MODIFY ("PROMO_TOTAL_ID" NOT NULL ENABLE)

See Also

List of constraints
Table [PROMOTIONS]


Table: SALES

Properties

Name: | SALES
Status: | VALID
Tablespace: |
Logging: | N
Partitioned: |
Cached: | ENABLED
Locking: | 2000
IOT type: |
Object type: |
Type owner: |
Type: | N
Temporary: | N
Secondary: | NO
Nested: |
Buffer pool: | DISABLED
Row movement: | YES
Index Only Table: |
Minimum % of free space: |
Minimum % of udes space: |
Initial transactions: |
Max transactions: |
Initial extent size, bytes: |
Secondary extent size, bytes: |
Min extents: |
Max extents: |
% increase in extent: |
Process free list: |
Process free list groups: |
Backee up: | 918843
Rows: | 1769
Used blocks: | 0
Empty blocks: | 0
Average free space: | 0
Chained rows: | 29
Average row length: | 0
Average freespace on a freelist: | 0
Blocks on a freelist: | 1
Threds per instance: | 1
Instances: | N
Sample size: | 03.15.2007
Last analysed: | YES
Global statistics: | YES
User statistics: | NO
Duration: |
Skip corrupt blocks: | DISABLED
Monitoring: | YES
Cluster owner: |
Dependencies: | DISABLED
SizeMB: | 15,88
Extents: | 239
SizeBytes: | 16646144
Description: | facts table, without a primary key; all rows are uniquely identified by the combination of all foreign keys

Columns

Name | Type | Length | Nchar Length | Precision | Scale | NULL | Default | Description
PROD_ID | NUMBER |  |  |  |  | N |  | FK to the products dimension table
CUST_ID | NUMBER |  |  |  |  | N |  | FK to the customers dimension table
TIME_ID | DATE | 7 |  |  |  | N |  | FK to the times dimension table
CHANNEL_ID | NUMBER |  |  |  |  | N |  | FK to the channels dimension table
PROMO_ID | NUMBER |  |  |  |  | N |  | promotion identifier, without FK constraint (intentionally) to show outer join optimization
QUANTITY_SOLD | NUMBER | 12 |  | 10 | 2 | N |  | product quantity sold with the transaction
AMOUNT_SOLD | NUMBER | 12 |  | 10 | 2 | N |  | invoiced amount to the customer
Total: 7 column(s)

Indexes

Name | Type | Unique
SALES_CHANNEL_BIX | BITMAP | NONUNIQUE
SALES_CUST_BIX | BITMAP | NONUNIQUE
SALES_PROD_BIX | BITMAP | NONUNIQUE
SALES_PROMO_BIX | BITMAP | NONUNIQUE
SALES_TIME_BIX | BITMAP | NONUNIQUE
Total: 5 index(s)

Constraints

Name | Type | Status | Delete rule | Defferable | Deffered
SALES_CHANNEL_FK | Referential Integrity | Enabled | No Action | Not Deferrable | Immediate
SALES_CUSTOMER_FK | Referential Integrity | Enabled | No Action | Not Deferrable | Immediate
SALES_PRODUCT_FK | Referential Integrity | Enabled | No Action | Not Deferrable | Immediate
SALES_PROMO_FK | Referential Integrity | Enabled | No Action | Not Deferrable | Immediate
SALES_TIME_FK | Referential Integrity | Enabled | No Action | Not Deferrable | Immediate
SYS_C005209 | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005210 | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005211 | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005212 | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005213 | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005214 | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005215 | Check | Enabled |  | Not Deferrable | Immediate
Total: 12 constraints

Grants

Privilage | Grantee | Grantable | Grantor
SELECT | BI | NO | SH
Total: 1 grants

Partitions

Name | HightValue | Hight Value Length | Tablespace
SALES_1995 | TO_DATE(' 1996-01-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83 | EXAMPLE
SALES_1996 | TO_DATE(' 1997-01-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83 | EXAMPLE
SALES_H1_1997 | TO_DATE(' 1997-07-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83 | EXAMPLE
SALES_H2_1997 | TO_DATE(' 1998-01-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83 | EXAMPLE
SALES_Q1_1998 | TO_DATE(' 1998-04-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83 | EXAMPLE
SALES_Q2_1998 | TO_DATE(' 1998-07-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83 | EXAMPLE
SALES_Q3_1998 | TO_DATE(' 1998-10-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83 | EXAMPLE
SALES_Q4_1998 | TO_DATE(' 1999-01-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83 | EXAMPLE
SALES_Q1_1999 | TO_DATE(' 1999-04-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83 | EXAMPLE
SALES_Q2_1999 | TO_DATE(' 1999-07-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83 | EXAMPLE
SALES_Q3_1999 | TO_DATE(' 1999-10-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83 | EXAMPLE
SALES_Q4_1999 | TO_DATE(' 2000-01-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83 | EXAMPLE
SALES_Q1_2000 | TO_DATE(' 2000-04-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83 | EXAMPLE
SALES_Q2_2000 | TO_DATE(' 2000-07-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83 | EXAMPLE
SALES_Q3_2000 | TO_DATE(' 2000-10-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83 | EXAMPLE
SALES_Q4_2000 | TO_DATE(' 2001-01-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83 | EXAMPLE
SALES_Q1_2001 | TO_DATE(' 2001-04-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83 | EXAMPLE
SALES_Q2_2001 | TO_DATE(' 2001-07-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83 | EXAMPLE
SALES_Q3_2001 | TO_DATE(' 2001-10-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83 | EXAMPLE
SALES_Q4_2001 | TO_DATE(' 2002-01-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83 | EXAMPLE
SALES_Q1_2002 | TO_DATE(' 2002-04-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83 | EXAMPLE
SALES_Q2_2002 | TO_DATE(' 2002-07-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83 | EXAMPLE
SALES_Q3_2002 | TO_DATE(' 2002-10-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83 | EXAMPLE
SALES_Q4_2002 | TO_DATE(' 2003-01-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83 | EXAMPLE
SALES_Q1_2003 | TO_DATE(' 2003-04-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83 | EXAMPLE
SALES_Q2_2003 | TO_DATE(' 2003-07-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83 | EXAMPLE
SALES_Q3_2003 | TO_DATE(' 2003-10-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83 | EXAMPLE
SALES_Q4_2003 | TO_DATE(' 2004-01-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83 | EXAMPLE
Total: 28 partition(s)

Partitioned columns

Name | Position
TIME_ID | 1
Total: 1 partitioned column(s)

Table References

Name | Owner | Constraint | DELETE_RULE
CHANNELS | SH | SALES_CHANNEL_FK |
CUSTOMERS | SH | SALES_CUSTOMER_FK |
PRODUCTS | SH | SALES_PRODUCT_FK |
PROMOTIONS | SH | SALES_PROMO_FK |
TIMES | SH | SALES_TIME_FK |
Total: 5 table reference(s)

Table used by

Owner | Name | Type
SH | PROFITS | VIEW
SH | CAL_MONTH_SALES_MV | MATERIALIZED VIEW
SH | FWEEK_PSCAT_SALES_MV | MATERIALIZED VIEW
BI | SALES | SYNONYM
Total: 4 used by reference(s)

DDL

CREATE TABLE "SH"."SALES"
( "PROD_ID" NUMBER NOT NULL ENABLE,
"CUST_ID" NUMBER NOT NULL ENABLE,
"TIME_ID" DATE NOT NULL ENABLE,
"CHANNEL_ID" NUMBER NOT NULL ENABLE,
"PROMO_ID" NUMBER NOT NULL ENABLE,
"QUANTITY_SOLD" NUMBER(10,2) NOT NULL ENABLE,
"AMOUNT_SOLD" NUMBER(10,2) NOT NULL ENABLE,
CONSTRAINT "SALES_CHANNEL_FK" FOREIGN KEY ("CHANNEL_ID")
REFERENCES "SH"."CHANNELS" ("CHANNEL_ID") ENABLE NOVALIDATE,
CONSTRAINT "SALES_TIME_FK" FOREIGN KEY ("TIME_ID")
REFERENCES "SH"."TIMES" ("TIME_ID") ENABLE NOVALIDATE,
CONSTRAINT "SALES_PRODUCT_FK" FOREIGN KEY ("PROD_ID")
REFERENCES "SH"."PRODUCTS" ("PROD_ID") ENABLE NOVALIDATE,
CONSTRAINT "SALES_CUSTOMER_FK" FOREIGN KEY ("CUST_ID")
REFERENCES "SH"."CUSTOMERS" ("CUST_ID") ENABLE NOVALIDATE,
CONSTRAINT "SALES_PROMO_FK" FOREIGN KEY ("PROMO_ID")
REFERENCES "SH"."PROMOTIONS" ("PROMO_ID") ENABLE NOVALIDATE
) PCTFREE 5 PCTUSED 40 INITRANS 1 MAXTRANS 255 NOCOMPRESS NOLOGGING
STORAGE(
BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE"
PARTITION BY RANGE ("TIME_ID")
(PARTITION "SALES_1995" VALUES LESS THAN (TO_DATE(' 1996-01-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN'))
PCTFREE 0 PCTUSED 40 INITRANS 1 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" COMPRESS ,
PARTITION "SALES_1996" VALUES LESS THAN (TO_DATE(' 1997-01-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN'))
PCTFREE 0 PCTUSED 40 INITRANS 1 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" COMPRESS ,
PARTITION "SALES_H1_1997" VALUES LESS THAN (TO_DATE(' 1997-07-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN'))
PCTFREE 0 PCTUSED 40 INITRANS 1 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" COMPRESS ,
PARTITION "SALES_H2_1997" VALUES LESS THAN (TO_DATE(' 1998-01-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN'))
PCTFREE 0 PCTUSED 40 INITRANS 1 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" COMPRESS ,
PARTITION "SALES_Q1_1998" VALUES LESS THAN (TO_DATE(' 1998-04-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN'))
PCTFREE 0 PCTUSED 40 INITRANS 1 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" COMPRESS ,
PARTITION "SALES_Q2_1998" VALUES LESS THAN (TO_DATE(' 1998-07-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN'))
PCTFREE 0 PCTUSED 40 INITRANS 1 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" COMPRESS ,
PARTITION "SALES_Q3_1998" VALUES LESS THAN (TO_DATE(' 1998-10-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN'))
PCTFREE 0 PCTUSED 40 INITRANS 1 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" COMPRESS ,
PARTITION "SALES_Q4_1998" VALUES LESS THAN (TO_DATE(' 1999-01-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN'))
PCTFREE 0 PCTUSED 40 INITRANS 1 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" COMPRESS ,
PARTITION "SALES_Q1_1999" VALUES LESS THAN (TO_DATE(' 1999-04-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN'))
PCTFREE 0 PCTUSED 40 INITRANS 1 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" COMPRESS ,
PARTITION "SALES_Q2_1999" VALUES LESS THAN (TO_DATE(' 1999-07-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN'))
PCTFREE 0 PCTUSED 40 INITRANS 1 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" COMPRESS ,
PARTITION "SALES_Q3_1999" VALUES LESS THAN (TO_DATE(' 1999-10-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN'))
PCTFREE 0 PCTUSED 40 INITRANS 1 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" COMPRESS ,
PARTITION "SALES_Q4_1999" VALUES LESS THAN (TO_DATE(' 2000-01-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN'))
PCTFREE 0 PCTUSED 40 INITRANS 1 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" COMPRESS ,
PARTITION "SALES_Q1_2000" VALUES LESS THAN (TO_DATE(' 2000-04-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN'))
PCTFREE 0 PCTUSED 40 INITRANS 1 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" COMPRESS ,
PARTITION "SALES_Q2_2000" VALUES LESS THAN (TO_DATE(' 2000-07-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN'))
PCTFREE 0 PCTUSED 40 INITRANS 1 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" COMPRESS ,
PARTITION "SALES_Q3_2000" VALUES LESS THAN (TO_DATE(' 2000-10-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN'))
PCTFREE 0 PCTUSED 40 INITRANS 1 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" COMPRESS ,
PARTITION "SALES_Q4_2000" VALUES LESS THAN (TO_DATE(' 2001-01-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN'))
PCTFREE 0 PCTUSED 40 INITRANS 1 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" COMPRESS ,
PARTITION "SALES_Q1_2001" VALUES LESS THAN (TO_DATE(' 2001-04-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN'))
PCTFREE 0 PCTUSED 40 INITRANS 1 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" COMPRESS ,
PARTITION "SALES_Q2_2001" VALUES LESS THAN (TO_DATE(' 2001-07-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN'))
PCTFREE 0 PCTUSED 40 INITRANS 1 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" COMPRESS ,
PARTITION "SALES_Q3_2001" VALUES LESS THAN (TO_DATE(' 2001-10-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN'))
PCTFREE 0 PCTUSED 40 INITRANS 1 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" COMPRESS ,
PARTITION "SALES_Q4_2001" VALUES LESS THAN (TO_DATE(' 2002-01-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN'))
PCTFREE 0 PCTUSED 40 INITRANS 1 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" COMPRESS ,
PARTITION "SALES_Q1_2002" VALUES LESS THAN (TO_DATE(' 2002-04-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN'))
PCTFREE 0 PCTUSED 40 INITRANS 1 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" COMPRESS ,
PARTITION "SALES_Q2_2002" VALUES LESS THAN (TO_DATE(' 2002-07-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN'))
PCTFREE 0 PCTUSED 40 INITRANS 1 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" COMPRESS ,
PARTITION "SALES_Q3_2002" VALUES LESS THAN (TO_DATE(' 2002-10-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN'))
PCTFREE 0 PCTUSED 40 INITRANS 1 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" COMPRESS ,
PARTITION "SALES_Q4_2002" VALUES LESS THAN (TO_DATE(' 2003-01-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN'))
PCTFREE 0 PCTUSED 40 INITRANS 1 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" COMPRESS ,
PARTITION "SALES_Q1_2003" VALUES LESS THAN (TO_DATE(' 2003-04-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN'))
PCTFREE 0 PCTUSED 40 INITRANS 1 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" COMPRESS ,
PARTITION "SALES_Q2_2003" VALUES LESS THAN (TO_DATE(' 2003-07-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN'))
PCTFREE 0 PCTUSED 40 INITRANS 1 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" COMPRESS ,
PARTITION "SALES_Q3_2003" VALUES LESS THAN (TO_DATE(' 2003-10-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN'))
PCTFREE 0 PCTUSED 40 INITRANS 1 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" COMPRESS ,
PARTITION "SALES_Q4_2003" VALUES LESS THAN (TO_DATE(' 2004-01-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN'))
PCTFREE 5 PCTUSED 40 INITRANS 1 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" NOCOMPRESS )

See Also

List of tables


List of indexes

Indexes

Name | Type | Unique
SALES_CHANNEL_BIX | BITMAP | NONUNIQUE
SALES_CUST_BIX | BITMAP | NONUNIQUE
SALES_PROD_BIX | BITMAP | NONUNIQUE
SALES_PROMO_BIX | BITMAP | NONUNIQUE
SALES_TIME_BIX | BITMAP | NONUNIQUE
Total: 5 index(s)

See Also

Table [SALES]


Index: SALES_CHANNEL_BIX on table SALES

Properties

Name: | SALES_CHANNEL_BIX
Type: | BITMAP
Unique: | NONUNIQUE
Tablespace: |
Status: | N/A
Table owner: | SH
Table name: | SALES
Temporary: | No
Join Index: | No
Initial extent size: |
Secondary extent size: |
Min extents: |
Max extents: |
Percent encrease: |
Distinct keys: | 4
Minimum free %: |

Index Columns

Name | Length | Descend
CHANNEL_ID | 22 | ASC
Total: 1 column(s)

Partitions

Name | Tablespace | Hight Value | Hight Value Length
SALES_1995 | EXAMPLE | TO_DATE(' 1996-01-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83
SALES_1996 | EXAMPLE | TO_DATE(' 1997-01-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83
SALES_H1_1997 | EXAMPLE | TO_DATE(' 1997-07-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83
SALES_H2_1997 | EXAMPLE | TO_DATE(' 1998-01-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83
SALES_Q1_1998 | EXAMPLE | TO_DATE(' 1998-04-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83
SALES_Q2_1998 | EXAMPLE | TO_DATE(' 1998-07-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83
SALES_Q3_1998 | EXAMPLE | TO_DATE(' 1998-10-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83
SALES_Q4_1998 | EXAMPLE | TO_DATE(' 1999-01-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83
SALES_Q1_1999 | EXAMPLE | TO_DATE(' 1999-04-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83
SALES_Q2_1999 | EXAMPLE | TO_DATE(' 1999-07-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83
SALES_Q3_1999 | EXAMPLE | TO_DATE(' 1999-10-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83
SALES_Q4_1999 | EXAMPLE | TO_DATE(' 2000-01-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83
SALES_Q1_2000 | EXAMPLE | TO_DATE(' 2000-04-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83
SALES_Q2_2000 | EXAMPLE | TO_DATE(' 2000-07-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83
SALES_Q3_2000 | EXAMPLE | TO_DATE(' 2000-10-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83
SALES_Q4_2000 | EXAMPLE | TO_DATE(' 2001-01-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83
SALES_Q1_2001 | EXAMPLE | TO_DATE(' 2001-04-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83
SALES_Q2_2001 | EXAMPLE | TO_DATE(' 2001-07-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83
SALES_Q3_2001 | EXAMPLE | TO_DATE(' 2001-10-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83
SALES_Q4_2001 | EXAMPLE | TO_DATE(' 2002-01-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83
SALES_Q1_2002 | EXAMPLE | TO_DATE(' 2002-04-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83
SALES_Q2_2002 | EXAMPLE | TO_DATE(' 2002-07-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83
SALES_Q3_2002 | EXAMPLE | TO_DATE(' 2002-10-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83
SALES_Q4_2002 | EXAMPLE | TO_DATE(' 2003-01-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83
SALES_Q1_2003 | EXAMPLE | TO_DATE(' 2003-04-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83
SALES_Q2_2003 | EXAMPLE | TO_DATE(' 2003-07-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83
SALES_Q3_2003 | EXAMPLE | TO_DATE(' 2003-10-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83
SALES_Q4_2003 | EXAMPLE | TO_DATE(' 2004-01-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83
Total: 28 partition(s)

Partitioned columns

Name
TIME_ID
Total: 1 partitioned column(s)

DDL

CREATE BITMAP INDEX "SH"."SALES_CHANNEL_BIX" ON "SH"."SALES" ("CHANNEL_ID")
PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING
STORAGE(
BUFFER_POOL DEFAULT) LOCAL
(PARTITION "SALES_1995"
PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" ,
PARTITION "SALES_1996"
PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" ,
PARTITION "SALES_H1_1997"
PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" ,
PARTITION "SALES_H2_1997"
PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" ,
PARTITION "SALES_Q1_1998"
PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" ,
PARTITION "SALES_Q2_1998"
PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" ,
PARTITION "SALES_Q3_1998"
PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" ,
PARTITION "SALES_Q4_1998"
PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" ,
PARTITION "SALES_Q1_1999"
PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" ,
PARTITION "SALES_Q2_1999"
PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" ,
PARTITION "SALES_Q3_1999"
PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" ,
PARTITION "SALES_Q4_1999"
PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" ,
PARTITION "SALES_Q1_2000"
PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" ,
PARTITION "SALES_Q2_2000"
PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" ,
PARTITION "SALES_Q3_2000"
PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" ,
PARTITION "SALES_Q4_2000"
PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" ,
PARTITION "SALES_Q1_2001"
PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" ,
PARTITION "SALES_Q2_2001"
PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" ,
PARTITION "SALES_Q3_2001"
PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" ,
PARTITION "SALES_Q4_2001"
PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" ,
PARTITION "SALES_Q1_2002"
PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" ,
PARTITION "SALES_Q2_2002"
PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" ,
PARTITION "SALES_Q3_2002"
PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" ,
PARTITION "SALES_Q4_2002"
PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" ,
PARTITION "SALES_Q1_2003"
PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" ,
PARTITION "SALES_Q2_2003"
PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" ,
PARTITION "SALES_Q3_2003"
PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" ,
PARTITION "SALES_Q4_2003"
PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" )

See Also

List of indexes


Index: SALES_CUST_BIX on table SALES

Properties

Name: | SALES_CUST_BIX
Type: | BITMAP
Unique: | NONUNIQUE
Tablespace: |
Status: | N/A
Table owner: | SH
Table name: | SALES
Temporary: | No
Join Index: | No
Initial extent size: |
Secondary extent size: |
Min extents: |
Max extents: |
Percent encrease: |
Distinct keys: | 7059
Minimum free %: |

Index Columns

Name | Length | Descend
CUST_ID | 22 | ASC
Total: 1 column(s)

Partitions

Name | Tablespace | Hight Value | Hight Value Length
SALES_1995 | EXAMPLE | TO_DATE(' 1996-01-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83
SALES_1996 | EXAMPLE | TO_DATE(' 1997-01-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83
SALES_H1_1997 | EXAMPLE | TO_DATE(' 1997-07-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83
SALES_H2_1997 | EXAMPLE | TO_DATE(' 1998-01-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83
SALES_Q1_1998 | EXAMPLE | TO_DATE(' 1998-04-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83
SALES_Q2_1998 | EXAMPLE | TO_DATE(' 1998-07-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83
SALES_Q3_1998 | EXAMPLE | TO_DATE(' 1998-10-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83
SALES_Q4_1998 | EXAMPLE | TO_DATE(' 1999-01-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83
SALES_Q1_1999 | EXAMPLE | TO_DATE(' 1999-04-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83
SALES_Q2_1999 | EXAMPLE | TO_DATE(' 1999-07-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83
SALES_Q3_1999 | EXAMPLE | TO_DATE(' 1999-10-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83
SALES_Q4_1999 | EXAMPLE | TO_DATE(' 2000-01-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83
SALES_Q1_2000 | EXAMPLE | TO_DATE(' 2000-04-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83
SALES_Q2_2000 | EXAMPLE | TO_DATE(' 2000-07-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83
SALES_Q3_2000 | EXAMPLE | TO_DATE(' 2000-10-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83
SALES_Q4_2000 | EXAMPLE | TO_DATE(' 2001-01-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83
SALES_Q1_2001 | EXAMPLE | TO_DATE(' 2001-04-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83
SALES_Q2_2001 | EXAMPLE | TO_DATE(' 2001-07-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83
SALES_Q3_2001 | EXAMPLE | TO_DATE(' 2001-10-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83
SALES_Q4_2001 | EXAMPLE | TO_DATE(' 2002-01-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83
SALES_Q1_2002 | EXAMPLE | TO_DATE(' 2002-04-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83
SALES_Q2_2002 | EXAMPLE | TO_DATE(' 2002-07-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83
SALES_Q3_2002 | EXAMPLE | TO_DATE(' 2002-10-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83
SALES_Q4_2002 | EXAMPLE | TO_DATE(' 2003-01-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83
SALES_Q1_2003 | EXAMPLE | TO_DATE(' 2003-04-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83
SALES_Q2_2003 | EXAMPLE | TO_DATE(' 2003-07-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83
SALES_Q3_2003 | EXAMPLE | TO_DATE(' 2003-10-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83
SALES_Q4_2003 | EXAMPLE | TO_DATE(' 2004-01-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83
Total: 28 partition(s)

Partitioned columns

Name
TIME_ID
Total: 1 partitioned column(s)

DDL

CREATE BITMAP INDEX "SH"."SALES_CUST_BIX" ON "SH"."SALES" ("CUST_ID")
PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING
STORAGE(
BUFFER_POOL DEFAULT) LOCAL
(PARTITION "SALES_1995"
PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" ,
PARTITION "SALES_1996"
PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" ,
PARTITION "SALES_H1_1997"
PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" ,
PARTITION "SALES_H2_1997"
PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" ,
PARTITION "SALES_Q1_1998"
PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" ,
PARTITION "SALES_Q2_1998"
PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" ,
PARTITION "SALES_Q3_1998"
PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" ,
PARTITION "SALES_Q4_1998"
PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" ,
PARTITION "SALES_Q1_1999"
PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" ,
PARTITION "SALES_Q2_1999"
PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" ,
PARTITION "SALES_Q3_1999"
PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" ,
PARTITION "SALES_Q4_1999"
PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" ,
PARTITION "SALES_Q1_2000"
PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" ,
PARTITION "SALES_Q2_2000"
PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" ,
PARTITION "SALES_Q3_2000"
PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" ,
PARTITION "SALES_Q4_2000"
PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" ,
PARTITION "SALES_Q1_2001"
PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" ,
PARTITION "SALES_Q2_2001"
PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" ,
PARTITION "SALES_Q3_2001"
PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" ,
PARTITION "SALES_Q4_2001"
PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" ,
PARTITION "SALES_Q1_2002"
PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" ,
PARTITION "SALES_Q2_2002"
PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" ,
PARTITION "SALES_Q3_2002"
PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" ,
PARTITION "SALES_Q4_2002"
PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" ,
PARTITION "SALES_Q1_2003"
PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" ,
PARTITION "SALES_Q2_2003"
PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" ,
PARTITION "SALES_Q3_2003"
PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" ,
PARTITION "SALES_Q4_2003"
PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" )

See Also

List of indexes


Index: SALES_PROD_BIX on table SALES

Properties

Name: | SALES_PROD_BIX
Type: | BITMAP
Unique: | NONUNIQUE
Tablespace: |
Status: | N/A
Table owner: | SH
Table name: | SALES
Temporary: | No
Join Index: | No
Initial extent size: |
Secondary extent size: |
Min extents: |
Max extents: |
Percent encrease: |
Distinct keys: | 72
Minimum free %: |

Index Columns

Name | Length | Descend
PROD_ID | 22 | ASC
Total: 1 column(s)

Partitions

Name | Tablespace | Hight Value | Hight Value Length
SALES_1995 | EXAMPLE | TO_DATE(' 1996-01-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83
SALES_1996 | EXAMPLE | TO_DATE(' 1997-01-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83
SALES_H1_1997 | EXAMPLE | TO_DATE(' 1997-07-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83
SALES_H2_1997 | EXAMPLE | TO_DATE(' 1998-01-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83
SALES_Q1_1998 | EXAMPLE | TO_DATE(' 1998-04-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83
SALES_Q2_1998 | EXAMPLE | TO_DATE(' 1998-07-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83
SALES_Q3_1998 | EXAMPLE | TO_DATE(' 1998-10-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83
SALES_Q4_1998 | EXAMPLE | TO_DATE(' 1999-01-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83
SALES_Q1_1999 | EXAMPLE | TO_DATE(' 1999-04-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83
SALES_Q2_1999 | EXAMPLE | TO_DATE(' 1999-07-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83
SALES_Q3_1999 | EXAMPLE | TO_DATE(' 1999-10-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83
SALES_Q4_1999 | EXAMPLE | TO_DATE(' 2000-01-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83
SALES_Q1_2000 | EXAMPLE | TO_DATE(' 2000-04-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83
SALES_Q2_2000 | EXAMPLE | TO_DATE(' 2000-07-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83
SALES_Q3_2000 | EXAMPLE | TO_DATE(' 2000-10-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83
SALES_Q4_2000 | EXAMPLE | TO_DATE(' 2001-01-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83
SALES_Q1_2001 | EXAMPLE | TO_DATE(' 2001-04-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83
SALES_Q2_2001 | EXAMPLE | TO_DATE(' 2001-07-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83
SALES_Q3_2001 | EXAMPLE | TO_DATE(' 2001-10-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83
SALES_Q4_2001 | EXAMPLE | TO_DATE(' 2002-01-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83
SALES_Q1_2002 | EXAMPLE | TO_DATE(' 2002-04-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83
SALES_Q2_2002 | EXAMPLE | TO_DATE(' 2002-07-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83
SALES_Q3_2002 | EXAMPLE | TO_DATE(' 2002-10-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83
SALES_Q4_2002 | EXAMPLE | TO_DATE(' 2003-01-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83
SALES_Q1_2003 | EXAMPLE | TO_DATE(' 2003-04-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83
SALES_Q2_2003 | EXAMPLE | TO_DATE(' 2003-07-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83
SALES_Q3_2003 | EXAMPLE | TO_DATE(' 2003-10-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83
SALES_Q4_2003 | EXAMPLE | TO_DATE(' 2004-01-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83
Total: 28 partition(s)

Partitioned columns

Name
TIME_ID
Total: 1 partitioned column(s)

DDL

CREATE BITMAP INDEX "SH"."SALES_PROD_BIX" ON "SH"."SALES" ("PROD_ID")
PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING
STORAGE(
BUFFER_POOL DEFAULT) LOCAL
(PARTITION "SALES_1995"
PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" ,
PARTITION "SALES_1996"
PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" ,
PARTITION "SALES_H1_1997"
PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" ,
PARTITION "SALES_H2_1997"
PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" ,
PARTITION "SALES_Q1_1998"
PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" ,
PARTITION "SALES_Q2_1998"
PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" ,
PARTITION "SALES_Q3_1998"
PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" ,
PARTITION "SALES_Q4_1998"
PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" ,
PARTITION "SALES_Q1_1999"
PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" ,
PARTITION "SALES_Q2_1999"
PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" ,
PARTITION "SALES_Q3_1999"
PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" ,
PARTITION "SALES_Q4_1999"
PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" ,
PARTITION "SALES_Q1_2000"
PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" ,
PARTITION "SALES_Q2_2000"
PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" ,
PARTITION "SALES_Q3_2000"
PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" ,
PARTITION "SALES_Q4_2000"
PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" ,
PARTITION "SALES_Q1_2001"
PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" ,
PARTITION "SALES_Q2_2001"
PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" ,
PARTITION "SALES_Q3_2001"
PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" ,
PARTITION "SALES_Q4_2001"
PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" ,
PARTITION "SALES_Q1_2002"
PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" ,
PARTITION "SALES_Q2_2002"
PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" ,
PARTITION "SALES_Q3_2002"
PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" ,
PARTITION "SALES_Q4_2002"
PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" ,
PARTITION "SALES_Q1_2003"
PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" ,
PARTITION "SALES_Q2_2003"
PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" ,
PARTITION "SALES_Q3_2003"
PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" ,
PARTITION "SALES_Q4_2003"
PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" )

See Also

List of indexes


Index: SALES_PROMO_BIX on table SALES

Properties

Name: | SALES_PROMO_BIX
Type: | BITMAP
Unique: | NONUNIQUE
Tablespace: |
Status: | N/A
Table owner: | SH
Table name: | SALES
Temporary: | No
Join Index: | No
Initial extent size: |
Secondary extent size: |
Min extents: |
Max extents: |
Percent encrease: |
Distinct keys: | 4
Minimum free %: |

Index Columns

Name | Length | Descend
PROMO_ID | 22 | ASC
Total: 1 column(s)

Partitions

Name | Tablespace | Hight Value | Hight Value Length
SALES_1995 | EXAMPLE | TO_DATE(' 1996-01-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83
SALES_1996 | EXAMPLE | TO_DATE(' 1997-01-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83
SALES_H1_1997 | EXAMPLE | TO_DATE(' 1997-07-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83
SALES_H2_1997 | EXAMPLE | TO_DATE(' 1998-01-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83
SALES_Q1_1998 | EXAMPLE | TO_DATE(' 1998-04-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83
SALES_Q2_1998 | EXAMPLE | TO_DATE(' 1998-07-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83
SALES_Q3_1998 | EXAMPLE | TO_DATE(' 1998-10-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83
SALES_Q4_1998 | EXAMPLE | TO_DATE(' 1999-01-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83
SALES_Q1_1999 | EXAMPLE | TO_DATE(' 1999-04-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83
SALES_Q2_1999 | EXAMPLE | TO_DATE(' 1999-07-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83
SALES_Q3_1999 | EXAMPLE | TO_DATE(' 1999-10-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83
SALES_Q4_1999 | EXAMPLE | TO_DATE(' 2000-01-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83
SALES_Q1_2000 | EXAMPLE | TO_DATE(' 2000-04-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83
SALES_Q2_2000 | EXAMPLE | TO_DATE(' 2000-07-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83
SALES_Q3_2000 | EXAMPLE | TO_DATE(' 2000-10-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83
SALES_Q4_2000 | EXAMPLE | TO_DATE(' 2001-01-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83
SALES_Q1_2001 | EXAMPLE | TO_DATE(' 2001-04-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83
SALES_Q2_2001 | EXAMPLE | TO_DATE(' 2001-07-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83
SALES_Q3_2001 | EXAMPLE | TO_DATE(' 2001-10-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83
SALES_Q4_2001 | EXAMPLE | TO_DATE(' 2002-01-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83
SALES_Q1_2002 | EXAMPLE | TO_DATE(' 2002-04-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83
SALES_Q2_2002 | EXAMPLE | TO_DATE(' 2002-07-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83
SALES_Q3_2002 | EXAMPLE | TO_DATE(' 2002-10-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83
SALES_Q4_2002 | EXAMPLE | TO_DATE(' 2003-01-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83
SALES_Q1_2003 | EXAMPLE | TO_DATE(' 2003-04-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83
SALES_Q2_2003 | EXAMPLE | TO_DATE(' 2003-07-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83
SALES_Q3_2003 | EXAMPLE | TO_DATE(' 2003-10-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83
SALES_Q4_2003 | EXAMPLE | TO_DATE(' 2004-01-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83
Total: 28 partition(s)

Partitioned columns

Name
TIME_ID
Total: 1 partitioned column(s)

DDL

CREATE BITMAP INDEX "SH"."SALES_PROMO_BIX" ON "SH"."SALES" ("PROMO_ID")
PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING
STORAGE(
BUFFER_POOL DEFAULT) LOCAL
(PARTITION "SALES_1995"
PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" ,
PARTITION "SALES_1996"
PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" ,
PARTITION "SALES_H1_1997"
PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" ,
PARTITION "SALES_H2_1997"
PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" ,
PARTITION "SALES_Q1_1998"
PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" ,
PARTITION "SALES_Q2_1998"
PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" ,
PARTITION "SALES_Q3_1998"
PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" ,
PARTITION "SALES_Q4_1998"
PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" ,
PARTITION "SALES_Q1_1999"
PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" ,
PARTITION "SALES_Q2_1999"
PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" ,
PARTITION "SALES_Q3_1999"
PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" ,
PARTITION "SALES_Q4_1999"
PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" ,
PARTITION "SALES_Q1_2000"
PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" ,
PARTITION "SALES_Q2_2000"
PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" ,
PARTITION "SALES_Q3_2000"
PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" ,
PARTITION "SALES_Q4_2000"
PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" ,
PARTITION "SALES_Q1_2001"
PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" ,
PARTITION "SALES_Q2_2001"
PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" ,
PARTITION "SALES_Q3_2001"
PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" ,
PARTITION "SALES_Q4_2001"
PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" ,
PARTITION "SALES_Q1_2002"
PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" ,
PARTITION "SALES_Q2_2002"
PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" ,
PARTITION "SALES_Q3_2002"
PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" ,
PARTITION "SALES_Q4_2002"
PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" ,
PARTITION "SALES_Q1_2003"
PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" ,
PARTITION "SALES_Q2_2003"
PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" ,
PARTITION "SALES_Q3_2003"
PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" ,
PARTITION "SALES_Q4_2003"
PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" )

See Also

List of indexes


Index: SALES_TIME_BIX on table SALES

Properties

Name: | SALES_TIME_BIX
Type: | BITMAP
Unique: | NONUNIQUE
Tablespace: |
Status: | N/A
Table owner: | SH
Table name: | SALES
Temporary: | No
Join Index: | No
Initial extent size: |
Secondary extent size: |
Min extents: |
Max extents: |
Percent encrease: |
Distinct keys: | 1460
Minimum free %: |

Index Columns

Name | Length | Descend
TIME_ID | 7 | ASC
Total: 1 column(s)

Partitions

Name | Tablespace | Hight Value | Hight Value Length
SALES_1995 | EXAMPLE | TO_DATE(' 1996-01-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83
SALES_1996 | EXAMPLE | TO_DATE(' 1997-01-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83
SALES_H1_1997 | EXAMPLE | TO_DATE(' 1997-07-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83
SALES_H2_1997 | EXAMPLE | TO_DATE(' 1998-01-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83
SALES_Q1_1998 | EXAMPLE | TO_DATE(' 1998-04-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83
SALES_Q2_1998 | EXAMPLE | TO_DATE(' 1998-07-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83
SALES_Q3_1998 | EXAMPLE | TO_DATE(' 1998-10-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83
SALES_Q4_1998 | EXAMPLE | TO_DATE(' 1999-01-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83
SALES_Q1_1999 | EXAMPLE | TO_DATE(' 1999-04-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83
SALES_Q2_1999 | EXAMPLE | TO_DATE(' 1999-07-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83
SALES_Q3_1999 | EXAMPLE | TO_DATE(' 1999-10-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83
SALES_Q4_1999 | EXAMPLE | TO_DATE(' 2000-01-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83
SALES_Q1_2000 | EXAMPLE | TO_DATE(' 2000-04-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83
SALES_Q2_2000 | EXAMPLE | TO_DATE(' 2000-07-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83
SALES_Q3_2000 | EXAMPLE | TO_DATE(' 2000-10-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83
SALES_Q4_2000 | EXAMPLE | TO_DATE(' 2001-01-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83
SALES_Q1_2001 | EXAMPLE | TO_DATE(' 2001-04-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83
SALES_Q2_2001 | EXAMPLE | TO_DATE(' 2001-07-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83
SALES_Q3_2001 | EXAMPLE | TO_DATE(' 2001-10-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83
SALES_Q4_2001 | EXAMPLE | TO_DATE(' 2002-01-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83
SALES_Q1_2002 | EXAMPLE | TO_DATE(' 2002-04-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83
SALES_Q2_2002 | EXAMPLE | TO_DATE(' 2002-07-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83
SALES_Q3_2002 | EXAMPLE | TO_DATE(' 2002-10-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83
SALES_Q4_2002 | EXAMPLE | TO_DATE(' 2003-01-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83
SALES_Q1_2003 | EXAMPLE | TO_DATE(' 2003-04-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83
SALES_Q2_2003 | EXAMPLE | TO_DATE(' 2003-07-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83
SALES_Q3_2003 | EXAMPLE | TO_DATE(' 2003-10-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83
SALES_Q4_2003 | EXAMPLE | TO_DATE(' 2004-01-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83
Total: 28 partition(s)

Partitioned columns

Name
TIME_ID
Total: 1 partitioned column(s)

DDL

CREATE BITMAP INDEX "SH"."SALES_TIME_BIX" ON "SH"."SALES" ("TIME_ID")
PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING
STORAGE(
BUFFER_POOL DEFAULT) LOCAL
(PARTITION "SALES_1995"
PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" ,
PARTITION "SALES_1996"
PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" ,
PARTITION "SALES_H1_1997"
PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" ,
PARTITION "SALES_H2_1997"
PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" ,
PARTITION "SALES_Q1_1998"
PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" ,
PARTITION "SALES_Q2_1998"
PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" ,
PARTITION "SALES_Q3_1998"
PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" ,
PARTITION "SALES_Q4_1998"
PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" ,
PARTITION "SALES_Q1_1999"
PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" ,
PARTITION "SALES_Q2_1999"
PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" ,
PARTITION "SALES_Q3_1999"
PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" ,
PARTITION "SALES_Q4_1999"
PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" ,
PARTITION "SALES_Q1_2000"
PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" ,
PARTITION "SALES_Q2_2000"
PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" ,
PARTITION "SALES_Q3_2000"
PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" ,
PARTITION "SALES_Q4_2000"
PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" ,
PARTITION "SALES_Q1_2001"
PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" ,
PARTITION "SALES_Q2_2001"
PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" ,
PARTITION "SALES_Q3_2001"
PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" ,
PARTITION "SALES_Q4_2001"
PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" ,
PARTITION "SALES_Q1_2002"
PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" ,
PARTITION "SALES_Q2_2002"
PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" ,
PARTITION "SALES_Q3_2002"
PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" ,
PARTITION "SALES_Q4_2002"
PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" ,
PARTITION "SALES_Q1_2003"
PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" ,
PARTITION "SALES_Q2_2003"
PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" ,
PARTITION "SALES_Q3_2003"
PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" ,
PARTITION "SALES_Q4_2003"
PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" )

See Also

List of indexes


List of constraints

Constraints

Name | Type | Status | Delete rule | Defferable | Deffered
SALES_CHANNEL_FK | Referential Integrity | Enabled | No Action | Not Deferrable | Immediate
SALES_CUSTOMER_FK | Referential Integrity | Enabled | No Action | Not Deferrable | Immediate
SALES_PRODUCT_FK | Referential Integrity | Enabled | No Action | Not Deferrable | Immediate
SALES_PROMO_FK | Referential Integrity | Enabled | No Action | Not Deferrable | Immediate
SALES_TIME_FK | Referential Integrity | Enabled | No Action | Not Deferrable | Immediate
SYS_C005209 | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005210 | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005211 | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005212 | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005213 | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005214 | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005215 | Check | Enabled |  | Not Deferrable | Immediate
Total: 12 constraint(s)

See Also

Table [SALES]


Constraint: SALES_CHANNEL_FK on table SALES

Properties

Name: | SALES_CHANNEL_FK
Type: | Referential Integrity
Status: | Enabled
Delete rule: | No Action
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: | SH
R Constraint: | CHANNELS_PK

Columns

Name
CHANNEL_ID
Total: 1 column(s)

Reference columns

Owner | Table | Column
SH | CHANNELS | CHANNEL_ID
Total: 1 reference column(s)

DDL

See Also

List of constraints
Table [SALES]


Constraint: SALES_CUSTOMER_FK on table SALES

Properties

Name: | SALES_CUSTOMER_FK
Type: | Referential Integrity
Status: | Enabled
Delete rule: | No Action
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: | SH
R Constraint: | CUSTOMERS_PK

Columns

Name
CUST_ID
Total: 1 column(s)

Reference columns

Owner | Table | Column
SH | CUSTOMERS | CUST_ID
Total: 1 reference column(s)

DDL

See Also

List of constraints
Table [SALES]


Constraint: SALES_PRODUCT_FK on table SALES

Properties

Name: | SALES_PRODUCT_FK
Type: | Referential Integrity
Status: | Enabled
Delete rule: | No Action
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: | SH
R Constraint: | PRODUCTS_PK

Columns

Name
PROD_ID
Total: 1 column(s)

Reference columns

Owner | Table | Column
SH | PRODUCTS | PROD_ID
Total: 1 reference column(s)

DDL

See Also

List of constraints
Table [SALES]


Constraint: SALES_PROMO_FK on table SALES

Properties

Name: | SALES_PROMO_FK
Type: | Referential Integrity
Status: | Enabled
Delete rule: | No Action
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: | SH
R Constraint: | PROMO_PK

Columns

Name
PROMO_ID
Total: 1 column(s)

Reference columns

Owner | Table | Column
SH | PROMOTIONS | PROMO_ID
Total: 1 reference column(s)

DDL

See Also

List of constraints
Table [SALES]


Constraint: SALES_TIME_FK on table SALES

Properties

Name: | SALES_TIME_FK
Type: | Referential Integrity
Status: | Enabled
Delete rule: | No Action
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: | SH
R Constraint: | TIMES_PK

Columns

Name
TIME_ID
Total: 1 column(s)

Reference columns

Owner | Table | Column
SH | TIMES | TIME_ID
Total: 1 reference column(s)

DDL

See Also

List of constraints
Table [SALES]


Constraint: SYS_C005209 on table SALES

Properties

Name: | SYS_C005209
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
PROD_ID
Total: 1 column(s)

DDL

ALTER TABLE "SH"."SALES" MODIFY ("PROD_ID" NOT NULL ENABLE)

See Also

List of constraints
Table [SALES]


Constraint: SYS_C005210 on table SALES

Properties

Name: | SYS_C005210
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
CUST_ID
Total: 1 column(s)

DDL

ALTER TABLE "SH"."SALES" MODIFY ("CUST_ID" NOT NULL ENABLE)

See Also

List of constraints
Table [SALES]


Constraint: SYS_C005211 on table SALES

Properties

Name: | SYS_C005211
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
TIME_ID
Total: 1 column(s)

DDL

ALTER TABLE "SH"."SALES" MODIFY ("TIME_ID" NOT NULL ENABLE)

See Also

List of constraints
Table [SALES]


Constraint: SYS_C005212 on table SALES

Properties

Name: | SYS_C005212
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
CHANNEL_ID
Total: 1 column(s)

DDL

ALTER TABLE "SH"."SALES" MODIFY ("CHANNEL_ID" NOT NULL ENABLE)

See Also

List of constraints
Table [SALES]


Constraint: SYS_C005213 on table SALES

Properties

Name: | SYS_C005213
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
PROMO_ID
Total: 1 column(s)

DDL

ALTER TABLE "SH"."SALES" MODIFY ("PROMO_ID" NOT NULL ENABLE)

See Also

List of constraints
Table [SALES]


Constraint: SYS_C005214 on table SALES

Properties

Name: | SYS_C005214
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
QUANTITY_SOLD
Total: 1 column(s)

DDL

ALTER TABLE "SH"."SALES" MODIFY ("QUANTITY_SOLD" NOT NULL ENABLE)

See Also

List of constraints
Table [SALES]


Constraint: SYS_C005215 on table SALES

Properties

Name: | SYS_C005215
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
AMOUNT_SOLD
Total: 1 column(s)

DDL

ALTER TABLE "SH"."SALES" MODIFY ("AMOUNT_SOLD" NOT NULL ENABLE)

See Also

List of constraints
Table [SALES]


List of partitions on [SALES]

Partitions

Name | HightValue | Hight Value Length | Tablespace
SALES_1995 | TO_DATE(' 1996-01-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83 | EXAMPLE
SALES_1996 | TO_DATE(' 1997-01-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83 | EXAMPLE
SALES_H1_1997 | TO_DATE(' 1997-07-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83 | EXAMPLE
SALES_H2_1997 | TO_DATE(' 1998-01-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83 | EXAMPLE
SALES_Q1_1998 | TO_DATE(' 1998-04-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83 | EXAMPLE
SALES_Q2_1998 | TO_DATE(' 1998-07-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83 | EXAMPLE
SALES_Q3_1998 | TO_DATE(' 1998-10-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83 | EXAMPLE
SALES_Q4_1998 | TO_DATE(' 1999-01-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83 | EXAMPLE
SALES_Q1_1999 | TO_DATE(' 1999-04-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83 | EXAMPLE
SALES_Q2_1999 | TO_DATE(' 1999-07-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83 | EXAMPLE
SALES_Q3_1999 | TO_DATE(' 1999-10-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83 | EXAMPLE
SALES_Q4_1999 | TO_DATE(' 2000-01-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83 | EXAMPLE
SALES_Q1_2000 | TO_DATE(' 2000-04-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83 | EXAMPLE
SALES_Q2_2000 | TO_DATE(' 2000-07-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83 | EXAMPLE
SALES_Q3_2000 | TO_DATE(' 2000-10-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83 | EXAMPLE
SALES_Q4_2000 | TO_DATE(' 2001-01-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83 | EXAMPLE
SALES_Q1_2001 | TO_DATE(' 2001-04-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83 | EXAMPLE
SALES_Q2_2001 | TO_DATE(' 2001-07-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83 | EXAMPLE
SALES_Q3_2001 | TO_DATE(' 2001-10-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83 | EXAMPLE
SALES_Q4_2001 | TO_DATE(' 2002-01-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83 | EXAMPLE
SALES_Q1_2002 | TO_DATE(' 2002-04-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83 | EXAMPLE
SALES_Q2_2002 | TO_DATE(' 2002-07-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83 | EXAMPLE
SALES_Q3_2002 | TO_DATE(' 2002-10-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83 | EXAMPLE
SALES_Q4_2002 | TO_DATE(' 2003-01-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83 | EXAMPLE
SALES_Q1_2003 | TO_DATE(' 2003-04-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83 | EXAMPLE
SALES_Q2_2003 | TO_DATE(' 2003-07-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83 | EXAMPLE
SALES_Q3_2003 | TO_DATE(' 2003-10-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83 | EXAMPLE
SALES_Q4_2003 | TO_DATE(' 2004-01-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN') | 83 | EXAMPLE
Total: 28 partition(s)

See Also

Table [SALES]


Partition: SALES_1995 on table SALES

Properties

Name: | SALES_1995
Hight Value: | TO_DATE(' 1996-01-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN')
Hight Value Length: | 83
Tablespace: | EXAMPLE
Rows: | 0
Blocks: | 0
Empty Blocks: | 0
Average Space: | 0

See Also

List of partitions


Partition: SALES_1996 on table SALES

Properties

Name: | SALES_1996
Hight Value: | TO_DATE(' 1997-01-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN')
Hight Value Length: | 83
Tablespace: | EXAMPLE
Rows: | 0
Blocks: | 0
Empty Blocks: | 0
Average Space: | 0

See Also

List of partitions


Partition: SALES_H1_1997 on table SALES

Properties

Name: | SALES_H1_1997
Hight Value: | TO_DATE(' 1997-07-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN')
Hight Value Length: | 83
Tablespace: | EXAMPLE
Rows: | 0
Blocks: | 0
Empty Blocks: | 0
Average Space: | 0

See Also

List of partitions


Partition: SALES_H2_1997 on table SALES

Properties

Name: | SALES_H2_1997
Hight Value: | TO_DATE(' 1998-01-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN')
Hight Value Length: | 83
Tablespace: | EXAMPLE
Rows: | 0
Blocks: | 0
Empty Blocks: | 0
Average Space: | 0

See Also

List of partitions


Partition: SALES_Q1_1998 on table SALES

Properties

Name: | SALES_Q1_1998
Hight Value: | TO_DATE(' 1998-04-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN')
Hight Value Length: | 83
Tablespace: | EXAMPLE
Rows: | 43687
Blocks: | 90
Empty Blocks: | 0
Average Space: | 0

See Also

List of partitions


Partition: SALES_Q2_1998 on table SALES

Properties

Name: | SALES_Q2_1998
Hight Value: | TO_DATE(' 1998-07-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN')
Hight Value Length: | 83
Tablespace: | EXAMPLE
Rows: | 35758
Blocks: | 76
Empty Blocks: | 0
Average Space: | 0

See Also

List of partitions


Partition: SALES_Q3_1998 on table SALES

Properties

Name: | SALES_Q3_1998
Hight Value: | TO_DATE(' 1998-10-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN')
Hight Value Length: | 83
Tablespace: | EXAMPLE
Rows: | 50515
Blocks: | 95
Empty Blocks: | 0
Average Space: | 0

See Also

List of partitions


Partition: SALES_Q4_1998 on table SALES

Properties

Name: | SALES_Q4_1998
Hight Value: | TO_DATE(' 1999-01-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN')
Hight Value Length: | 83
Tablespace: | EXAMPLE
Rows: | 48874
Blocks: | 108
Empty Blocks: | 0
Average Space: | 0

See Also

List of partitions


Partition: SALES_Q1_1999 on table SALES

Properties

Name: | SALES_Q1_1999
Hight Value: | TO_DATE(' 1999-04-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN')
Hight Value Length: | 83
Tablespace: | EXAMPLE
Rows: | 64186
Blocks: | 121
Empty Blocks: | 0
Average Space: | 0

See Also

List of partitions


Partition: SALES_Q2_1999 on table SALES

Properties

Name: | SALES_Q2_1999
Hight Value: | TO_DATE(' 1999-07-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN')
Hight Value Length: | 83
Tablespace: | EXAMPLE
Rows: | 54233
Blocks: | 103
Empty Blocks: | 0
Average Space: | 0

See Also

List of partitions


Partition: SALES_Q3_1999 on table SALES

Properties

Name: | SALES_Q3_1999
Hight Value: | TO_DATE(' 1999-10-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN')
Hight Value Length: | 83
Tablespace: | EXAMPLE
Rows: | 67138
Blocks: | 120
Empty Blocks: | 0
Average Space: | 0

See Also

List of partitions


Partition: SALES_Q4_1999 on table SALES

Properties

Name: | SALES_Q4_1999
Hight Value: | TO_DATE(' 2000-01-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN')
Hight Value Length: | 83
Tablespace: | EXAMPLE
Rows: | 62388
Blocks: | 114
Empty Blocks: | 0
Average Space: | 0

See Also

List of partitions


Partition: SALES_Q1_2000 on table SALES

Properties

Name: | SALES_Q1_2000
Hight Value: | TO_DATE(' 2000-04-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN')
Hight Value Length: | 83
Tablespace: | EXAMPLE
Rows: | 62197
Blocks: | 119
Empty Blocks: | 0
Average Space: | 0

See Also

List of partitions


Partition: SALES_Q2_2000 on table SALES

Properties

Name: | SALES_Q2_2000
Hight Value: | TO_DATE(' 2000-07-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN')
Hight Value Length: | 83
Tablespace: | EXAMPLE
Rows: | 55515
Blocks: | 109
Empty Blocks: | 0
Average Space: | 0

See Also

List of partitions


Partition: SALES_Q3_2000 on table SALES

Properties

Name: | SALES_Q3_2000
Hight Value: | TO_DATE(' 2000-10-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN')
Hight Value Length: | 83
Tablespace: | EXAMPLE
Rows: | 58950
Blocks: | 110
Empty Blocks: | 0
Average Space: | 0

See Also

List of partitions


Partition: SALES_Q4_2000 on table SALES

Properties

Name: | SALES_Q4_2000
Hight Value: | TO_DATE(' 2001-01-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN')
Hight Value Length: | 83
Tablespace: | EXAMPLE
Rows: | 55984
Blocks: | 106
Empty Blocks: | 0
Average Space: | 0

See Also

List of partitions


Partition: SALES_Q1_2001 on table SALES

Properties

Name: | SALES_Q1_2001
Hight Value: | TO_DATE(' 2001-04-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN')
Hight Value Length: | 83
Tablespace: | EXAMPLE
Rows: | 60608
Blocks: | 119
Empty Blocks: | 0
Average Space: | 0

See Also

List of partitions


Partition: SALES_Q2_2001 on table SALES

Properties

Name: | SALES_Q2_2001
Hight Value: | TO_DATE(' 2001-07-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN')
Hight Value Length: | 83
Tablespace: | EXAMPLE
Rows: | 63292
Blocks: | 119
Empty Blocks: | 0
Average Space: | 0

See Also

List of partitions


Partition: SALES_Q3_2001 on table SALES

Properties

Name: | SALES_Q3_2001
Hight Value: | TO_DATE(' 2001-10-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN')
Hight Value Length: | 83
Tablespace: | EXAMPLE
Rows: | 65769
Blocks: | 124
Empty Blocks: | 0
Average Space: | 0

See Also

List of partitions


Partition: SALES_Q4_2001 on table SALES

Properties

Name: | SALES_Q4_2001
Hight Value: | TO_DATE(' 2002-01-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN')
Hight Value Length: | 83
Tablespace: | EXAMPLE
Rows: | 69749
Blocks: | 136
Empty Blocks: | 0
Average Space: | 0

See Also

List of partitions


Partition: SALES_Q1_2002 on table SALES

Properties

Name: | SALES_Q1_2002
Hight Value: | TO_DATE(' 2002-04-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN')
Hight Value Length: | 83
Tablespace: | EXAMPLE
Rows: | 0
Blocks: | 0
Empty Blocks: | 0
Average Space: | 0

See Also

List of partitions


Partition: SALES_Q2_2002 on table SALES

Properties

Name: | SALES_Q2_2002
Hight Value: | TO_DATE(' 2002-07-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN')
Hight Value Length: | 83
Tablespace: | EXAMPLE
Rows: | 0
Blocks: | 0
Empty Blocks: | 0
Average Space: | 0

See Also

List of partitions


Partition: SALES_Q3_2002 on table SALES

Properties

Name: | SALES_Q3_2002
Hight Value: | TO_DATE(' 2002-10-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN')
Hight Value Length: | 83
Tablespace: | EXAMPLE
Rows: | 0
Blocks: | 0
Empty Blocks: | 0
Average Space: | 0

See Also

List of partitions


Partition: SALES_Q4_2002 on table SALES

Properties

Name: | SALES_Q4_2002
Hight Value: | TO_DATE(' 2003-01-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN')
Hight Value Length: | 83
Tablespace: | EXAMPLE
Rows: | 0
Blocks: | 0
Empty Blocks: | 0
Average Space: | 0

See Also

List of partitions


Partition: SALES_Q1_2003 on table SALES

Properties

Name: | SALES_Q1_2003
Hight Value: | TO_DATE(' 2003-04-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN')
Hight Value Length: | 83
Tablespace: | EXAMPLE
Rows: | 0
Blocks: | 0
Empty Blocks: | 0
Average Space: | 0

See Also

List of partitions


Partition: SALES_Q2_2003 on table SALES

Properties

Name: | SALES_Q2_2003
Hight Value: | TO_DATE(' 2003-07-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN')
Hight Value Length: | 83
Tablespace: | EXAMPLE
Rows: | 0
Blocks: | 0
Empty Blocks: | 0
Average Space: | 0

See Also

List of partitions


Partition: SALES_Q3_2003 on table SALES

Properties

Name: | SALES_Q3_2003
Hight Value: | TO_DATE(' 2003-10-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN')
Hight Value Length: | 83
Tablespace: | EXAMPLE
Rows: | 0
Blocks: | 0
Empty Blocks: | 0
Average Space: | 0

See Also

List of partitions


Partition: SALES_Q4_2003 on table SALES

Properties

Name: | SALES_Q4_2003
Hight Value: | TO_DATE(' 2004-01-01 00:00:00', 'SYYYY-MM-DD HH24:MI:SS', 'NLS_CALENDAR=GREGORIAN')
Hight Value Length: | 83
Tablespace: | EXAMPLE
Rows: | 0
Blocks: | 0
Empty Blocks: | 0
Average Space: | 0

See Also

List of partitions


Table: SALES_TRANSACTIONS_EXT

Properties

Name: | SALES_TRANSACTIONS_EXT
Status: | VALID
Tablespace: |
Logging: | N
Partitioned: |
Cached: | ENABLED
Locking: | 0
IOT type: |
Object type: |
Type owner: |
Type: | N
Temporary: | N
Secondary: | NO
Nested: |
Buffer pool: | DISABLED
Row movement: | YES
Index Only Table: |
Minimum % of free space: | 0
Minimum % of udes space: | 0
Initial transactions: | 0
Max transactions: |
Initial extent size, bytes: |
Secondary extent size, bytes: |
Min extents: |
Max extents: |
% increase in extent: |
Process free list: |
Process free list groups: | YES
Backee up: | 0
Rows: | 0
Used blocks: | 0
Empty blocks: | 0
Average free space: | 0
Chained rows: | 0
Average row length: | 0
Average freespace on a freelist: | 0
Blocks on a freelist: | 1
Threds per instance: | 1
Instances: | N
Sample size: | 03.15.2007
Last analysed: | NO
Global statistics: | YES
User statistics: | NO
Duration: |
Skip corrupt blocks: | DISABLED
Monitoring: | NO
Cluster owner: |
Dependencies: | DISABLED
SizeMB: |
Extents: |
SizeBytes: |
Description: |

Columns

Name | Type | Length | Nchar Length | Precision | Scale | NULL | Default | Description
PROD_ID | NUMBER |  |  |  |  | Y |  |
CUST_ID | NUMBER |  |  |  |  | Y |  |
TIME_ID | DATE | 7 |  |  |  | Y |  |
CHANNEL_ID | NUMBER |  |  |  |  | Y |  |
PROMO_ID | NUMBER |  |  |  |  | Y |  |
QUANTITY_SOLD | NUMBER |  |  |  |  | Y |  |
AMOUNT_SOLD | NUMBER | 12 |  | 10 | 2 | Y |  |
UNIT_COST | NUMBER | 12 |  | 10 | 2 | Y |  |
UNIT_PRICE | NUMBER | 12 |  | 10 | 2 | Y |  |
Total: 9 column(s)

DDL

CREATE TABLE "SH"."SALES_TRANSACTIONS_EXT"
( "PROD_ID" NUMBER,
"CUST_ID" NUMBER,
"TIME_ID" DATE,
"CHANNEL_ID" NUMBER,
"PROMO_ID" NUMBER,
"QUANTITY_SOLD" NUMBER,
"AMOUNT_SOLD" NUMBER(10,2),
"UNIT_COST" NUMBER(10,2),
"UNIT_PRICE" NUMBER(10,2)
)
ORGANIZATION EXTERNAL
( TYPE ORACLE_LOADER
DEFAULT DIRECTORY "DATA_FILE_DIR"
ACCESS PARAMETERS
( RECORDS DELIMITED BY NEWLINE CHARACTERSET US7ASCII
BADFILE log_file_dir:'ext_1v3.bad'
LOGFILE log_file_dir:'ext_1v3.log'
FIELDS TERMINATED BY "|" OPTIONALLY ENCLOSED BY '^' LDRTRIM
( PROD_ID ,
CUST_ID ,
TIME_ID DATE(10) "YYYY-MM-DD",
CHANNEL_ID ,
PROMO_ID ,
QUANTITY_SOLD ,
AMOUNT_SOLD ,
UNIT_COST ,
UNIT_PRICE
)
)
LOCATION
( 'sale1v3.dat'
)
)
REJECT LIMIT 100

See Also

List of tables


Table: SUPPLEMENTARY_DEMOGRAPHICS

Properties

Name: | SUPPLEMENTARY_DEMOGRAPHICS
Status: | VALID
Tablespace: | EXAMPLE
Logging: | N
Partitioned: |
Cached: | ENABLED
Locking: | 2000
IOT type: |
Object type: |
Type owner: |
Type: | N
Temporary: | N
Secondary: | NO
Nested: | DEFAULT
Buffer pool: | DISABLED
Row movement: | YES
Index Only Table: |
Minimum % of free space: | 10
Minimum % of udes space: |
Initial transactions: | 1
Max transactions: | 65536
Initial extent size, bytes: |
Secondary extent size, bytes: | 1
Min extents: | 2147483645
Max extents: |
% increase in extent: |
Process free list: |
Process free list groups: | NO
Backee up: | 4500
Rows: | 466
Used blocks: | 0
Empty blocks: | 0
Average free space: | 0
Chained rows: | 152
Average row length: | 0
Average freespace on a freelist: | 0
Blocks on a freelist: | 1
Threds per instance: | 1
Instances: | N
Sample size: | 03.15.2007
Last analysed: | NO
Global statistics: | YES
User statistics: | NO
Duration: |
Skip corrupt blocks: | DISABLED
Monitoring: | YES
Cluster owner: |
Dependencies: | DISABLED
SizeMB: | 4
Extents: | 19
SizeBytes: | 4194304
Description: |

Columns

Name | Type | Length | Nchar Length | Precision | Scale | NULL | Default | Description
CUST_ID | NUMBER |  |  |  |  | N |  |
EDUCATION | VARCHAR2 | 21 | 21 |  |  | Y |  |
OCCUPATION | VARCHAR2 | 21 | 21 |  |  | Y |  |
HOUSEHOLD_SIZE | VARCHAR2 | 21 | 21 |  |  | Y |  |
YRS_RESIDENCE | NUMBER |  |  |  |  | Y |  |
AFFINITY_CARD | NUMBER | 10 |  | 10 | 0 | Y |  |
BULK_PACK_DISKETTES | NUMBER | 10 |  | 10 | 0 | Y |  |
FLAT_PANEL_MONITOR | NUMBER | 10 |  | 10 | 0 | Y |  |
HOME_THEATER_PACKAGE | NUMBER | 10 |  | 10 | 0 | Y |  |
BOOKKEEPING_APPLICATION | NUMBER | 10 |  | 10 | 0 | Y |  |
PRINTER_SUPPLIES | NUMBER | 10 |  | 10 | 0 | Y |  |
Y_BOX_GAMES | NUMBER | 10 |  | 10 | 0 | Y |  |
OS_DOC_SET_KANJI | NUMBER | 10 |  | 10 | 0 | Y |  |
COMMENTS | VARCHAR2 | 4000 | 4000 |  |  | Y |  |
Total: 14 column(s)

Indexes

Name | Type | Unique
SUP_TEXT_IDX | DOMAIN | NONUNIQUE
Total: 1 index(s)

Constraints

Name | Type | Status | Delete rule | Defferable | Deffered
SUPP_DEMO_PK | Primary Key | Disabled |  | Not Deferrable | Immediate
SYS_C005324 | Check | Enabled |  | Not Deferrable | Immediate
Total: 2 constraints

DDL

CREATE TABLE "SH"."SUPPLEMENTARY_DEMOGRAPHICS"
( "CUST_ID" NUMBER NOT NULL ENABLE,
"EDUCATION" VARCHAR2(21),
"OCCUPATION" VARCHAR2(21),
"HOUSEHOLD_SIZE" VARCHAR2(21),
"YRS_RESIDENCE" NUMBER,
"AFFINITY_CARD" NUMBER(10,0),
"BULK_PACK_DISKETTES" NUMBER(10,0),
"FLAT_PANEL_MONITOR" NUMBER(10,0),
"HOME_THEATER_PACKAGE" NUMBER(10,0),
"BOOKKEEPING_APPLICATION" NUMBER(10,0),
"PRINTER_SUPPLIES" NUMBER(10,0),
"Y_BOX_GAMES" NUMBER(10,0),
"OS_DOC_SET_KANJI" NUMBER(10,0),
"COMMENTS" VARCHAR2(4000),
CONSTRAINT "SUPP_DEMO_PK" PRIMARY KEY ("CUST_ID") DISABLE
) PCTFREE 10 PCTUSED 40 INITRANS 1 MAXTRANS 255 NOCOMPRESS NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE"

See Also

List of tables


List of indexes

Indexes

Name | Type | Unique
SUP_TEXT_IDX | DOMAIN | NONUNIQUE
Total: 1 index(s)

See Also

Table [SUPPLEMENTARY_DEMOGRAPHICS]


Index: SUP_TEXT_IDX on table SUPPLEMENTARY_DEMOGRAPHICS

Properties

Name: | SUP_TEXT_IDX
Type: | DOMAIN
Unique: | NONUNIQUE
Tablespace: |
Status: | VALID
Table owner: | SH
Table name: | SUPPLEMENTARY_DEMOGRAPHICS
Temporary: | No
Join Index: | No
Initial extent size: |
Secondary extent size: |
Min extents: |
Max extents: |
Percent encrease: |
Distinct keys: |
Minimum free %: | 0

Index Columns

Name | Length | Descend
COMMENTS | 4000 | ASC
Total: 1 column(s)

DDL

CREATE INDEX "SH"."SUP_TEXT_IDX" ON "SH"."SUPPLEMENTARY_DEMOGRAPHICS" ("COMMENTS")
INDEXTYPE IS "CTXSYS"."CONTEXT" PARAMETERS ('nopopulate')

See Also

List of indexes


List of constraints

Constraints

Name | Type | Status | Delete rule | Defferable | Deffered
SUPP_DEMO_PK | Primary Key | Disabled |  | Not Deferrable | Immediate
SYS_C005324 | Check | Enabled |  | Not Deferrable | Immediate
Total: 2 constraint(s)

See Also

Table [SUPPLEMENTARY_DEMOGRAPHICS]


Constraint: SUPP_DEMO_PK on table SUPPLEMENTARY_DEMOGRAPHICS

Properties

Name: | SUPP_DEMO_PK
Type: | Primary Key
Status: | Disabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
CUST_ID
Total: 1 column(s)

DDL

ALTER TABLE "SH"."SUPPLEMENTARY_DEMOGRAPHICS" ADD CONSTRAINT "SUPP_DEMO_PK" PRIMARY KEY ("CUST_ID") DISABLE

See Also

List of constraints
Table [SUPPLEMENTARY_DEMOGRAPHICS]


Constraint: SYS_C005324 on table SUPPLEMENTARY_DEMOGRAPHICS

Properties

Name: | SYS_C005324
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
CUST_ID
Total: 1 column(s)

DDL

ALTER TABLE "SH"."SUPPLEMENTARY_DEMOGRAPHICS" MODIFY ("CUST_ID" NOT NULL ENABLE)

See Also

List of constraints
Table [SUPPLEMENTARY_DEMOGRAPHICS]


Table: TIMES

Properties

Name: | TIMES
Status: | VALID
Tablespace: | EXAMPLE
Logging: | N
Partitioned: |
Cached: | ENABLED
Locking: | 2000
IOT type: |
Object type: |
Type owner: |
Type: | N
Temporary: | N
Secondary: | NO
Nested: | DEFAULT
Buffer pool: | DISABLED
Row movement: | YES
Index Only Table: |
Minimum % of free space: | 10
Minimum % of udes space: |
Initial transactions: | 1
Max transactions: | 65536
Initial extent size, bytes: |
Secondary extent size, bytes: | 1
Min extents: | 2147483645
Max extents: |
% increase in extent: |
Process free list: |
Process free list groups: | NO
Backee up: | 1826
Rows: | 59
Used blocks: | 0
Empty blocks: | 0
Average free space: | 0
Chained rows: | 197
Average row length: | 0
Average freespace on a freelist: | 0
Blocks on a freelist: | 1
Threds per instance: | 1
Instances: | N
Sample size: | 03.15.2007
Last analysed: | NO
Global statistics: | YES
User statistics: | NO
Duration: |
Skip corrupt blocks: | DISABLED
Monitoring: | YES
Cluster owner: |
Dependencies: | DISABLED
SizeMB: | 0,5
Extents: | 8
SizeBytes: | 524288
Description: | Time dimension table to support multiple hierarchies and materialized views

Columns

Name | Type | Length | Nchar Length | Precision | Scale | NULL | Default | Description
TIME_ID | DATE | 7 |  |  |  | N |  | primary key; day date, finest granularity, CORRECT ORDER
DAY_NAME | VARCHAR2 | 9 | 9 |  |  | N |  | Monday to Sunday, repeating
DAY_NUMBER_IN_WEEK | NUMBER | 1 |  | 1 | 0 | N |  | 1 to 7, repeating
DAY_NUMBER_IN_MONTH | NUMBER | 2 |  | 2 | 0 | N |  | 1 to 31, repeating
CALENDAR_WEEK_NUMBER | NUMBER | 2 |  | 2 | 0 | N |  | 1 to 53, repeating
FISCAL_WEEK_NUMBER | NUMBER | 2 |  | 2 | 0 | N |  | 1 to 53, repeating
WEEK_ENDING_DAY | DATE | 7 |  |  |  | N |  | date of last day in week, CORRECT ORDER
WEEK_ENDING_DAY_ID | NUMBER |  |  |  |  | N |  |
CALENDAR_MONTH_NUMBER | NUMBER | 2 |  | 2 | 0 | N |  | 1 to 12, repeating
FISCAL_MONTH_NUMBER | NUMBER | 2 |  | 2 | 0 | N |  | 1 to 12, repeating
CALENDAR_MONTH_DESC | VARCHAR2 | 8 | 8 |  |  | N |  | e.g. 1998-01, CORRECT ORDER
CALENDAR_MONTH_ID | NUMBER |  |  |  |  | N |  |
FISCAL_MONTH_DESC | VARCHAR2 | 8 | 8 |  |  | N |  | e.g. 1998-01, CORRECT ORDER
FISCAL_MONTH_ID | NUMBER |  |  |  |  | N |  |
DAYS_IN_CAL_MONTH | NUMBER |  |  |  |  | N |  | e.g. 28,31, repeating
DAYS_IN_FIS_MONTH | NUMBER |  |  |  |  | N |  | e.g. 25,32, repeating
END_OF_CAL_MONTH | DATE | 7 |  |  |  | N |  | last day of calendar month
END_OF_FIS_MONTH | DATE | 7 |  |  |  | N |  | last day of fiscal month
CALENDAR_MONTH_NAME | VARCHAR2 | 9 | 9 |  |  | N |  | January to December, repeating
FISCAL_MONTH_NAME | VARCHAR2 | 9 | 9 |  |  | N |  | January to December, repeating
CALENDAR_QUARTER_DESC | CHAR | 7 | 7 |  |  | N |  | e.g. 1998-Q1, CORRECT ORDER
CALENDAR_QUARTER_ID | NUMBER |  |  |  |  | N |  |
FISCAL_QUARTER_DESC | CHAR | 7 | 7 |  |  | N |  | e.g. 1999-Q3, CORRECT ORDER
FISCAL_QUARTER_ID | NUMBER |  |  |  |  | N |  |
DAYS_IN_CAL_QUARTER | NUMBER |  |  |  |  | N |  | e.g. 88,90, repeating
DAYS_IN_FIS_QUARTER | NUMBER |  |  |  |  | N |  | e.g. 88,90, repeating
END_OF_CAL_QUARTER | DATE | 7 |  |  |  | N |  | last day of calendar quarter
END_OF_FIS_QUARTER | DATE | 7 |  |  |  | N |  | last day of fiscal quarter
CALENDAR_QUARTER_NUMBER | NUMBER | 1 |  | 1 | 0 | N |  | 1 to 4, repeating
FISCAL_QUARTER_NUMBER | NUMBER | 1 |  | 1 | 0 | N |  | 1 to 4, repeating
CALENDAR_YEAR | NUMBER | 4 |  | 4 | 0 | N |  | e.g. 1999, CORRECT ORDER
CALENDAR_YEAR_ID | NUMBER |  |  |  |  | N |  |
FISCAL_YEAR | NUMBER | 4 |  | 4 | 0 | N |  | e.g. 1999, CORRECT ORDER
FISCAL_YEAR_ID | NUMBER |  |  |  |  | N |  |
DAYS_IN_CAL_YEAR | NUMBER |  |  |  |  | N |  | 365,366 repeating
DAYS_IN_FIS_YEAR | NUMBER |  |  |  |  | N |  | e.g. 355,364, repeating
END_OF_CAL_YEAR | DATE | 7 |  |  |  | N |  | last day of cal year
END_OF_FIS_YEAR | DATE | 7 |  |  |  | N |  | last day of fiscal year
Total: 38 column(s)

Indexes

Name | Type | Unique
TIMES_PK | NORMAL | UNIQUE
Total: 1 index(s)

Constraints

Name | Type | Status | Delete rule | Defferable | Deffered
SYS_C005222 | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005223 | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005224 | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005225 | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005226 | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005227 | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005228 | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005229 | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005230 | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005231 | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005232 | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005233 | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005234 | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005235 | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005236 | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005237 | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005238 | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005239 | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005240 | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005241 | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005242 | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005243 | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005244 | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005245 | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005246 | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005247 | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005248 | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005249 | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005250 | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005251 | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005252 | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005253 | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005254 | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005255 | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005256 | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005257 | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005258 | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005259 | Check | Enabled |  | Not Deferrable | Immediate
TIMES_PK | Primary Key | Enabled |  | Not Deferrable | Immediate
Total: 39 constraints

Grants

Privilage | Grantee | Grantable | Grantor
SELECT | BI | NO | SH
Total: 1 grants

Referenced tables

Name | Owner | Constraint | DELETE_RULE
COSTS | SH | COSTS_TIME_FK | NO ACTION
SALES | SH | SALES_TIME_FK | NO ACTION
Total: 2 referenced table(s)

Table used by

Owner | Name | Type
SH | CAL_MONTH_SALES_MV | MATERIALIZED VIEW
BI | TIMES | SYNONYM
SH | TIMES_DIM | DIMENSION
SH | FWEEK_PSCAT_SALES_MV | MATERIALIZED VIEW
Total: 4 used by reference(s)

DDL

CREATE TABLE "SH"."TIMES"
( "TIME_ID" DATE NOT NULL ENABLE,
"DAY_NAME" VARCHAR2(9) NOT NULL ENABLE,
"DAY_NUMBER_IN_WEEK" NUMBER(1,0) NOT NULL ENABLE,
"DAY_NUMBER_IN_MONTH" NUMBER(2,0) NOT NULL ENABLE,
"CALENDAR_WEEK_NUMBER" NUMBER(2,0) NOT NULL ENABLE,
"FISCAL_WEEK_NUMBER" NUMBER(2,0) NOT NULL ENABLE,
"WEEK_ENDING_DAY" DATE NOT NULL ENABLE,
"WEEK_ENDING_DAY_ID" NUMBER NOT NULL ENABLE,
"CALENDAR_MONTH_NUMBER" NUMBER(2,0) NOT NULL ENABLE,
"FISCAL_MONTH_NUMBER" NUMBER(2,0) NOT NULL ENABLE,
"CALENDAR_MONTH_DESC" VARCHAR2(8) NOT NULL ENABLE,
"CALENDAR_MONTH_ID" NUMBER NOT NULL ENABLE,
"FISCAL_MONTH_DESC" VARCHAR2(8) NOT NULL ENABLE,
"FISCAL_MONTH_ID" NUMBER NOT NULL ENABLE,
"DAYS_IN_CAL_MONTH" NUMBER NOT NULL ENABLE,
"DAYS_IN_FIS_MONTH" NUMBER NOT NULL ENABLE,
"END_OF_CAL_MONTH" DATE NOT NULL ENABLE,
"END_OF_FIS_MONTH" DATE NOT NULL ENABLE,
"CALENDAR_MONTH_NAME" VARCHAR2(9) NOT NULL ENABLE,
"FISCAL_MONTH_NAME" VARCHAR2(9) NOT NULL ENABLE,
"CALENDAR_QUARTER_DESC" CHAR(7) NOT NULL ENABLE,
"CALENDAR_QUARTER_ID" NUMBER NOT NULL ENABLE,
"FISCAL_QUARTER_DESC" CHAR(7) NOT NULL ENABLE,
"FISCAL_QUARTER_ID" NUMBER NOT NULL ENABLE,
"DAYS_IN_CAL_QUARTER" NUMBER NOT NULL ENABLE,
"DAYS_IN_FIS_QUARTER" NUMBER NOT NULL ENABLE,
"END_OF_CAL_QUARTER" DATE NOT NULL ENABLE,
"END_OF_FIS_QUARTER" DATE NOT NULL ENABLE,
"CALENDAR_QUARTER_NUMBER" NUMBER(1,0) NOT NULL ENABLE,
"FISCAL_QUARTER_NUMBER" NUMBER(1,0) NOT NULL ENABLE,
"CALENDAR_YEAR" NUMBER(4,0) NOT NULL ENABLE,
"CALENDAR_YEAR_ID" NUMBER NOT NULL ENABLE,
"FISCAL_YEAR" NUMBER(4,0) NOT NULL ENABLE,
"FISCAL_YEAR_ID" NUMBER NOT NULL ENABLE,
"DAYS_IN_CAL_YEAR" NUMBER NOT NULL ENABLE,
"DAYS_IN_FIS_YEAR" NUMBER NOT NULL ENABLE,
"END_OF_CAL_YEAR" DATE NOT NULL ENABLE,
"END_OF_FIS_YEAR" DATE NOT NULL ENABLE,
CONSTRAINT "TIMES_PK" PRIMARY KEY ("TIME_ID")
USING INDEX PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING COMPUTE STATISTICS
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" ENABLE NOVALIDATE
) PCTFREE 10 PCTUSED 40 INITRANS 1 MAXTRANS 255 NOCOMPRESS NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE"

See Also

List of tables


List of indexes

Indexes

Name | Type | Unique
TIMES_PK | NORMAL | UNIQUE
Total: 1 index(s)

See Also

Table [TIMES]


Index: TIMES_PK on table TIMES

Properties

Name: | TIMES_PK
Type: | NORMAL
Unique: | UNIQUE
Tablespace: | EXAMPLE
Status: | VALID
Table owner: | SH
Table name: | TIMES
Temporary: | No
Join Index: | No
Initial extent size: | 65536
Secondary extent size: |
Min extents: | 1
Max extents: | 2147483645
Percent encrease: |
Distinct keys: | 1826
Minimum free %: | 10

Index Columns

Name | Length | Descend
TIME_ID | 7 | ASC
Total: 1 column(s)

DDL

CREATE UNIQUE INDEX "SH"."TIMES_PK" ON "SH"."TIMES" ("TIME_ID")
PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING COMPUTE STATISTICS
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE"

See Also

List of indexes


List of constraints

Constraints

Name | Type | Status | Delete rule | Defferable | Deffered
SYS_C005222 | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005223 | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005224 | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005225 | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005226 | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005227 | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005228 | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005229 | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005230 | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005231 | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005232 | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005233 | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005234 | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005235 | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005236 | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005237 | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005238 | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005239 | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005240 | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005241 | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005242 | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005243 | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005244 | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005245 | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005246 | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005247 | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005248 | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005249 | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005250 | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005251 | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005252 | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005253 | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005254 | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005255 | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005256 | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005257 | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005258 | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005259 | Check | Enabled |  | Not Deferrable | Immediate
TIMES_PK | Primary Key | Enabled |  | Not Deferrable | Immediate
Total: 39 constraint(s)

See Also

Table [TIMES]


Constraint: SYS_C005222 on table TIMES

Properties

Name: | SYS_C005222
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
TIME_ID
Total: 1 column(s)

DDL

ALTER TABLE "SH"."TIMES" MODIFY ("TIME_ID" NOT NULL ENABLE)

See Also

List of constraints
Table [TIMES]


Constraint: SYS_C005223 on table TIMES

Properties

Name: | SYS_C005223
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
DAY_NAME
Total: 1 column(s)

DDL

ALTER TABLE "SH"."TIMES" MODIFY ("DAY_NAME" NOT NULL ENABLE)

See Also

List of constraints
Table [TIMES]


Constraint: SYS_C005224 on table TIMES

Properties

Name: | SYS_C005224
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
DAY_NUMBER_IN_WEEK
Total: 1 column(s)

DDL

ALTER TABLE "SH"."TIMES" MODIFY ("DAY_NUMBER_IN_WEEK" NOT NULL ENABLE)

See Also

List of constraints
Table [TIMES]


Constraint: SYS_C005225 on table TIMES

Properties

Name: | SYS_C005225
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
DAY_NUMBER_IN_MONTH
Total: 1 column(s)

DDL

ALTER TABLE "SH"."TIMES" MODIFY ("DAY_NUMBER_IN_MONTH" NOT NULL ENABLE)

See Also

List of constraints
Table [TIMES]


Constraint: SYS_C005226 on table TIMES

Properties

Name: | SYS_C005226
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
CALENDAR_WEEK_NUMBER
Total: 1 column(s)

DDL

ALTER TABLE "SH"."TIMES" MODIFY ("CALENDAR_WEEK_NUMBER" NOT NULL ENABLE)

See Also

List of constraints
Table [TIMES]


Constraint: SYS_C005227 on table TIMES

Properties

Name: | SYS_C005227
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
FISCAL_WEEK_NUMBER
Total: 1 column(s)

DDL

ALTER TABLE "SH"."TIMES" MODIFY ("FISCAL_WEEK_NUMBER" NOT NULL ENABLE)

See Also

List of constraints
Table [TIMES]


Constraint: SYS_C005228 on table TIMES

Properties

Name: | SYS_C005228
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
WEEK_ENDING_DAY
Total: 1 column(s)

DDL

ALTER TABLE "SH"."TIMES" MODIFY ("WEEK_ENDING_DAY" NOT NULL ENABLE)

See Also

List of constraints
Table [TIMES]


Constraint: SYS_C005229 on table TIMES

Properties

Name: | SYS_C005229
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
WEEK_ENDING_DAY_ID
Total: 1 column(s)

DDL

ALTER TABLE "SH"."TIMES" MODIFY ("WEEK_ENDING_DAY_ID" NOT NULL ENABLE)

See Also

List of constraints
Table [TIMES]


Constraint: SYS_C005230 on table TIMES

Properties

Name: | SYS_C005230
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
CALENDAR_MONTH_NUMBER
Total: 1 column(s)

DDL

ALTER TABLE "SH"."TIMES" MODIFY ("CALENDAR_MONTH_NUMBER" NOT NULL ENABLE)

See Also

List of constraints
Table [TIMES]


Constraint: SYS_C005231 on table TIMES

Properties

Name: | SYS_C005231
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
FISCAL_MONTH_NUMBER
Total: 1 column(s)

DDL

ALTER TABLE "SH"."TIMES" MODIFY ("FISCAL_MONTH_NUMBER" NOT NULL ENABLE)

See Also

List of constraints
Table [TIMES]


Constraint: SYS_C005232 on table TIMES

Properties

Name: | SYS_C005232
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
CALENDAR_MONTH_DESC
Total: 1 column(s)

DDL

ALTER TABLE "SH"."TIMES" MODIFY ("CALENDAR_MONTH_DESC" NOT NULL ENABLE)

See Also

List of constraints
Table [TIMES]


Constraint: SYS_C005233 on table TIMES

Properties

Name: | SYS_C005233
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
CALENDAR_MONTH_ID
Total: 1 column(s)

DDL

ALTER TABLE "SH"."TIMES" MODIFY ("CALENDAR_MONTH_ID" NOT NULL ENABLE)

See Also

List of constraints
Table [TIMES]


Constraint: SYS_C005234 on table TIMES

Properties

Name: | SYS_C005234
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
FISCAL_MONTH_DESC
Total: 1 column(s)

DDL

ALTER TABLE "SH"."TIMES" MODIFY ("FISCAL_MONTH_DESC" NOT NULL ENABLE)

See Also

List of constraints
Table [TIMES]


Constraint: SYS_C005235 on table TIMES

Properties

Name: | SYS_C005235
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
FISCAL_MONTH_ID
Total: 1 column(s)

DDL

ALTER TABLE "SH"."TIMES" MODIFY ("FISCAL_MONTH_ID" NOT NULL ENABLE)

See Also

List of constraints
Table [TIMES]


Constraint: SYS_C005236 on table TIMES

Properties

Name: | SYS_C005236
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
DAYS_IN_CAL_MONTH
Total: 1 column(s)

DDL

ALTER TABLE "SH"."TIMES" MODIFY ("DAYS_IN_CAL_MONTH" NOT NULL ENABLE)

See Also

List of constraints
Table [TIMES]


Constraint: SYS_C005237 on table TIMES

Properties

Name: | SYS_C005237
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
DAYS_IN_FIS_MONTH
Total: 1 column(s)

DDL

ALTER TABLE "SH"."TIMES" MODIFY ("DAYS_IN_FIS_MONTH" NOT NULL ENABLE)

See Also

List of constraints
Table [TIMES]


Constraint: SYS_C005238 on table TIMES

Properties

Name: | SYS_C005238
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
END_OF_CAL_MONTH
Total: 1 column(s)

DDL

ALTER TABLE "SH"."TIMES" MODIFY ("END_OF_CAL_MONTH" NOT NULL ENABLE)

See Also

List of constraints
Table [TIMES]


Constraint: SYS_C005239 on table TIMES

Properties

Name: | SYS_C005239
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
END_OF_FIS_MONTH
Total: 1 column(s)

DDL

ALTER TABLE "SH"."TIMES" MODIFY ("END_OF_FIS_MONTH" NOT NULL ENABLE)

See Also

List of constraints
Table [TIMES]


Constraint: SYS_C005240 on table TIMES

Properties

Name: | SYS_C005240
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
CALENDAR_MONTH_NAME
Total: 1 column(s)

DDL

ALTER TABLE "SH"."TIMES" MODIFY ("CALENDAR_MONTH_NAME" NOT NULL ENABLE)

See Also

List of constraints
Table [TIMES]


Constraint: SYS_C005241 on table TIMES

Properties

Name: | SYS_C005241
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
FISCAL_MONTH_NAME
Total: 1 column(s)

DDL

ALTER TABLE "SH"."TIMES" MODIFY ("FISCAL_MONTH_NAME" NOT NULL ENABLE)

See Also

List of constraints
Table [TIMES]


Constraint: SYS_C005242 on table TIMES

Properties

Name: | SYS_C005242
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
CALENDAR_QUARTER_DESC
Total: 1 column(s)

DDL

ALTER TABLE "SH"."TIMES" MODIFY ("CALENDAR_QUARTER_DESC" NOT NULL ENABLE)

See Also

List of constraints
Table [TIMES]


Constraint: SYS_C005243 on table TIMES

Properties

Name: | SYS_C005243
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
CALENDAR_QUARTER_ID
Total: 1 column(s)

DDL

ALTER TABLE "SH"."TIMES" MODIFY ("CALENDAR_QUARTER_ID" NOT NULL ENABLE)

See Also

List of constraints
Table [TIMES]


Constraint: SYS_C005244 on table TIMES

Properties

Name: | SYS_C005244
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
FISCAL_QUARTER_DESC
Total: 1 column(s)

DDL

ALTER TABLE "SH"."TIMES" MODIFY ("FISCAL_QUARTER_DESC" NOT NULL ENABLE)

See Also

List of constraints
Table [TIMES]


Constraint: SYS_C005245 on table TIMES

Properties

Name: | SYS_C005245
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
FISCAL_QUARTER_ID
Total: 1 column(s)

DDL

ALTER TABLE "SH"."TIMES" MODIFY ("FISCAL_QUARTER_ID" NOT NULL ENABLE)

See Also

List of constraints
Table [TIMES]


Constraint: SYS_C005246 on table TIMES

Properties

Name: | SYS_C005246
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
DAYS_IN_CAL_QUARTER
Total: 1 column(s)

DDL

ALTER TABLE "SH"."TIMES" MODIFY ("DAYS_IN_CAL_QUARTER" NOT NULL ENABLE)

See Also

List of constraints
Table [TIMES]


Constraint: SYS_C005247 on table TIMES

Properties

Name: | SYS_C005247
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
DAYS_IN_FIS_QUARTER
Total: 1 column(s)

DDL

ALTER TABLE "SH"."TIMES" MODIFY ("DAYS_IN_FIS_QUARTER" NOT NULL ENABLE)

See Also

List of constraints
Table [TIMES]


Constraint: SYS_C005248 on table TIMES

Properties

Name: | SYS_C005248
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
END_OF_CAL_QUARTER
Total: 1 column(s)

DDL

ALTER TABLE "SH"."TIMES" MODIFY ("END_OF_CAL_QUARTER" NOT NULL ENABLE)

See Also

List of constraints
Table [TIMES]


Constraint: SYS_C005249 on table TIMES

Properties

Name: | SYS_C005249
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
END_OF_FIS_QUARTER
Total: 1 column(s)

DDL

ALTER TABLE "SH"."TIMES" MODIFY ("END_OF_FIS_QUARTER" NOT NULL ENABLE)

See Also

List of constraints
Table [TIMES]


Constraint: SYS_C005250 on table TIMES

Properties

Name: | SYS_C005250
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
CALENDAR_QUARTER_NUMBER
Total: 1 column(s)

DDL

ALTER TABLE "SH"."TIMES" MODIFY ("CALENDAR_QUARTER_NUMBER" NOT NULL ENABLE)

See Also

List of constraints
Table [TIMES]


Constraint: SYS_C005251 on table TIMES

Properties

Name: | SYS_C005251
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
FISCAL_QUARTER_NUMBER
Total: 1 column(s)

DDL

ALTER TABLE "SH"."TIMES" MODIFY ("FISCAL_QUARTER_NUMBER" NOT NULL ENABLE)

See Also

List of constraints
Table [TIMES]


Constraint: SYS_C005252 on table TIMES

Properties

Name: | SYS_C005252
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
CALENDAR_YEAR
Total: 1 column(s)

DDL

ALTER TABLE "SH"."TIMES" MODIFY ("CALENDAR_YEAR" NOT NULL ENABLE)

See Also

List of constraints
Table [TIMES]


Constraint: SYS_C005253 on table TIMES

Properties

Name: | SYS_C005253
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
CALENDAR_YEAR_ID
Total: 1 column(s)

DDL

ALTER TABLE "SH"."TIMES" MODIFY ("CALENDAR_YEAR_ID" NOT NULL ENABLE)

See Also

List of constraints
Table [TIMES]


Constraint: SYS_C005254 on table TIMES

Properties

Name: | SYS_C005254
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
FISCAL_YEAR
Total: 1 column(s)

DDL

ALTER TABLE "SH"."TIMES" MODIFY ("FISCAL_YEAR" NOT NULL ENABLE)

See Also

List of constraints
Table [TIMES]


Constraint: SYS_C005255 on table TIMES

Properties

Name: | SYS_C005255
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
FISCAL_YEAR_ID
Total: 1 column(s)

DDL

ALTER TABLE "SH"."TIMES" MODIFY ("FISCAL_YEAR_ID" NOT NULL ENABLE)

See Also

List of constraints
Table [TIMES]


Constraint: SYS_C005256 on table TIMES

Properties

Name: | SYS_C005256
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
DAYS_IN_CAL_YEAR
Total: 1 column(s)

DDL

ALTER TABLE "SH"."TIMES" MODIFY ("DAYS_IN_CAL_YEAR" NOT NULL ENABLE)

See Also

List of constraints
Table [TIMES]


Constraint: SYS_C005257 on table TIMES

Properties

Name: | SYS_C005257
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
DAYS_IN_FIS_YEAR
Total: 1 column(s)

DDL

ALTER TABLE "SH"."TIMES" MODIFY ("DAYS_IN_FIS_YEAR" NOT NULL ENABLE)

See Also

List of constraints
Table [TIMES]


Constraint: SYS_C005258 on table TIMES

Properties

Name: | SYS_C005258
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
END_OF_CAL_YEAR
Total: 1 column(s)

DDL

ALTER TABLE "SH"."TIMES" MODIFY ("END_OF_CAL_YEAR" NOT NULL ENABLE)

See Also

List of constraints
Table [TIMES]


Constraint: SYS_C005259 on table TIMES

Properties

Name: | SYS_C005259
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
END_OF_FIS_YEAR
Total: 1 column(s)

DDL

ALTER TABLE "SH"."TIMES" MODIFY ("END_OF_FIS_YEAR" NOT NULL ENABLE)

See Also

List of constraints
Table [TIMES]


Constraint: TIMES_PK on table TIMES

Properties

Name: | TIMES_PK
Type: | Primary Key
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
TIME_ID
Total: 1 column(s)

DDL

ALTER TABLE "SH"."TIMES" ADD CONSTRAINT "TIMES_PK" PRIMARY KEY ("TIME_ID")
USING INDEX PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING COMPUTE STATISTICS
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" ENABLE NOVALIDATE

See Also

List of constraints
Table [TIMES]


List of views

Views

Name | Status | Last modify | Created | Description
PROFITS | VALID | 03.15.2007 | 03.15.2007 |
Total: 1 view(s)

See Also

Schema overview


View: PROFITS

Properties

Name: | PROFITS
Status: | VALID
Last modify: | 03.15.2007
Created: | 03.15.2007
Description: |

Columns

Name | Type | Length | Nchar Length | Precision | Scale | NULL | Default | Comment | Updatable | Deletable | Insertable
CHANNEL_ID | NUMBER |  |  |  |  | N |  |  | NO | NO | NO
CUST_ID | NUMBER |  |  |  |  | N |  |  | NO | NO | NO
PROD_ID | NUMBER |  |  |  |  | N |  |  | NO | NO | NO
PROMO_ID | NUMBER |  |  |  |  | N |  |  | NO | NO | NO
TIME_ID | DATE | 7 |  |  |  | N |  |  | NO | NO | NO
UNIT_COST | NUMBER | 12 |  | 10 | 2 | N |  |  | NO | NO | NO
UNIT_PRICE | NUMBER | 12 |  | 10 | 2 | N |  |  | NO | NO | NO
AMOUNT_SOLD | NUMBER | 12 |  | 10 | 2 | N |  |  | NO | NO | NO
QUANTITY_SOLD | NUMBER | 12 |  | 10 | 2 | N |  |  | NO | NO | NO
TOTAL_COST | NUMBER |  |  |  |  | Y |  |  | NO | NO | NO
Total: 10 column(s)

Uses

Owner | Name | Type
SH | COSTS | TABLE
SH | SALES | TABLE
Total: 2 use reference(s)

DDL

CREATE OR REPLACE FORCE VIEW "SH"."PROFITS" ("CHANNEL_ID", "CUST_ID", "PROD_ID", "PROMO_ID", "TIME_ID", "UNIT_COST", "UNIT_PRICE", "AMOUNT_SOLD", "QUANTITY_SOLD", "TOTAL_COST") AS
SELECT
s.channel_id,
s.cust_id,
s.prod_id,
s.promo_id,
s.time_id,
c.unit_cost,
c.unit_price,
s.amount_sold,
s.quantity_sold,
c.unit_cost * s.quantity_sold TOTAL_COST
FROM costs c, sales s
WHERE c.prod_id = s.prod_id
AND c.time_id = s.time_id
AND c.channel_id = s.channel_id
AND c.promo_id = s.promo_id

See Also

List of views


List of constraints

Constraints

Name | Table | Type | Status | Delete rule | Defferable | Deffered
CHANNELS_PK | CHANNELS | Primary Key | Enabled |  | Not Deferrable | Immediate
COSTS_CHANNEL_FK | COSTS | Referential Integrity | Disabled | No Action | Not Deferrable | Immediate
COSTS_PRODUCT_FK | COSTS | Referential Integrity | Enabled | No Action | Not Deferrable | Immediate
COSTS_PROMO_FK | COSTS | Referential Integrity | Disabled | No Action | Not Deferrable | Immediate
COSTS_TIME_FK | COSTS | Referential Integrity | Enabled | No Action | Not Deferrable | Immediate
COUNTRIES_PK | COUNTRIES | Primary Key | Enabled |  | Not Deferrable | Immediate
CUSTOMERS_COUNTRY_FK | CUSTOMERS | Referential Integrity | Enabled | No Action | Not Deferrable | Immediate
CUSTOMERS_PK | CUSTOMERS | Primary Key | Enabled |  | Not Deferrable | Immediate
PRODUCTS_PK | PRODUCTS | Primary Key | Enabled |  | Not Deferrable | Immediate
PROMO_PK | PROMOTIONS | Primary Key | Enabled |  | Not Deferrable | Immediate
SALES_CHANNEL_FK | SALES | Referential Integrity | Enabled | No Action | Not Deferrable | Immediate
SALES_CUSTOMER_FK | SALES | Referential Integrity | Enabled | No Action | Not Deferrable | Immediate
SALES_PRODUCT_FK | SALES | Referential Integrity | Enabled | No Action | Not Deferrable | Immediate
SALES_PROMO_FK | SALES | Referential Integrity | Enabled | No Action | Not Deferrable | Immediate
SALES_TIME_FK | SALES | Referential Integrity | Enabled | No Action | Not Deferrable | Immediate
SUPP_DEMO_PK | SUPPLEMENTARY_DEMOGRAPHICS | Primary Key | Disabled |  | Not Deferrable | Immediate
SYS_C005209 | SALES | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005210 | SALES | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005211 | SALES | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005212 | SALES | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005213 | SALES | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005214 | SALES | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005215 | SALES | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005216 | COSTS | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005217 | COSTS | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005218 | COSTS | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005219 | COSTS | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005220 | COSTS | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005221 | COSTS | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005222 | TIMES | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005223 | TIMES | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005224 | TIMES | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005225 | TIMES | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005226 | TIMES | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005227 | TIMES | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005228 | TIMES | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005229 | TIMES | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005230 | TIMES | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005231 | TIMES | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005232 | TIMES | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005233 | TIMES | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005234 | TIMES | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005235 | TIMES | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005236 | TIMES | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005237 | TIMES | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005238 | TIMES | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005239 | TIMES | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005240 | TIMES | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005241 | TIMES | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005242 | TIMES | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005243 | TIMES | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005244 | TIMES | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005245 | TIMES | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005246 | TIMES | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005247 | TIMES | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005248 | TIMES | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005249 | TIMES | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005250 | TIMES | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005251 | TIMES | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005252 | TIMES | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005253 | TIMES | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005254 | TIMES | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005255 | TIMES | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005256 | TIMES | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005257 | TIMES | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005258 | TIMES | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005259 | TIMES | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005261 | PRODUCTS | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005262 | PRODUCTS | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005263 | PRODUCTS | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005264 | PRODUCTS | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005265 | PRODUCTS | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005266 | PRODUCTS | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005267 | PRODUCTS | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005268 | PRODUCTS | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005269 | PRODUCTS | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005270 | PRODUCTS | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005271 | PRODUCTS | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005272 | PRODUCTS | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005273 | PRODUCTS | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005274 | PRODUCTS | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005275 | PRODUCTS | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005276 | PRODUCTS | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005277 | PRODUCTS | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005279 | CHANNELS | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005280 | CHANNELS | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005281 | CHANNELS | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005282 | CHANNELS | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005283 | CHANNELS | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005284 | CHANNELS | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005286 | PROMOTIONS | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005287 | PROMOTIONS | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005288 | PROMOTIONS | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005289 | PROMOTIONS | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005290 | PROMOTIONS | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005291 | PROMOTIONS | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005292 | PROMOTIONS | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005293 | PROMOTIONS | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005294 | PROMOTIONS | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005295 | PROMOTIONS | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005296 | PROMOTIONS | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005298 | CUSTOMERS | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005299 | CUSTOMERS | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005300 | CUSTOMERS | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005301 | CUSTOMERS | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005302 | CUSTOMERS | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005303 | CUSTOMERS | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005304 | CUSTOMERS | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005305 | CUSTOMERS | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005306 | CUSTOMERS | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005307 | CUSTOMERS | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005308 | CUSTOMERS | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005309 | CUSTOMERS | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005310 | CUSTOMERS | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005311 | CUSTOMERS | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005312 | CUSTOMERS | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005314 | COUNTRIES | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005315 | COUNTRIES | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005316 | COUNTRIES | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005317 | COUNTRIES | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005318 | COUNTRIES | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005319 | COUNTRIES | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005320 | COUNTRIES | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005321 | COUNTRIES | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005322 | COUNTRIES | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005324 | SUPPLEMENTARY_DEMOGRAPHICS | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005326 | MVIEW$_EXCEPTIONS | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005327 | MVIEW$_EXCEPTIONS | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005328 | MVIEW$_EXCEPTIONS | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005329 | MVIEW$_EXCEPTIONS | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005330 | MVIEW$_EXCEPTIONS | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005331 | CAL_MONTH_SALES_MV | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005332 | FWEEK_PSCAT_SALES_MV | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005333 | FWEEK_PSCAT_SALES_MV | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005334 | FWEEK_PSCAT_SALES_MV | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005335 | FWEEK_PSCAT_SALES_MV | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005367 | DR$SUP_TEXT_IDX$I | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005368 | DR$SUP_TEXT_IDX$I | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005369 | DR$SUP_TEXT_IDX$I | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005370 | DR$SUP_TEXT_IDX$I | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005371 | DR$SUP_TEXT_IDX$I | Check | Enabled |  | Not Deferrable | Immediate
SYS_C005373 | DR$SUP_TEXT_IDX$N | Check | Enabled |  | Not Deferrable | Immediate
SYS_IOT_TOP_52330 | DR$SUP_TEXT_IDX$K | Primary Key | Enabled |  | Not Deferrable | Immediate
SYS_IOT_TOP_52335 | DR$SUP_TEXT_IDX$N | Primary Key | Enabled |  | Not Deferrable | Immediate
TIMES_PK | TIMES | Primary Key | Enabled |  | Not Deferrable | Immediate
Total: 145 constraints

See Also

Schema overview


Constraint: CHANNELS_PK on table CHANNELS

Properties

Name: | CHANNELS_PK
Table: | CHANNELS
Type: | Primary Key
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
CHANNEL_ID
Total: 1 column(s)

DDL

ALTER TABLE "SH"."CHANNELS" ADD CONSTRAINT "CHANNELS_PK" PRIMARY KEY ("CHANNEL_ID")
USING INDEX PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING COMPUTE STATISTICS
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" ENABLE NOVALIDATE

See Also

List of constraints
Table [CHANNELS]


Constraint: COSTS_CHANNEL_FK on table COSTS

Properties

Name: | COSTS_CHANNEL_FK
Table: | COSTS
Type: | Referential Integrity
Status: | Disabled
Delete rule: | No Action
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: | SH
R Constraint: | CHANNELS_PK

Columns

Name
CHANNEL_ID
Total: 1 column(s)

Reference columns

Owner | Table | Column
SH | CHANNELS | CHANNEL_ID
Total: 1 reference column(s)

DDL

See Also

List of constraints
Table [COSTS]


Constraint: COSTS_PRODUCT_FK on table COSTS

Properties

Name: | COSTS_PRODUCT_FK
Table: | COSTS
Type: | Referential Integrity
Status: | Enabled
Delete rule: | No Action
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: | SH
R Constraint: | PRODUCTS_PK

Columns

Name
PROD_ID
Total: 1 column(s)

Reference columns

Owner | Table | Column
SH | PRODUCTS | PROD_ID
Total: 1 reference column(s)

DDL

See Also

List of constraints
Table [COSTS]


Constraint: COSTS_PROMO_FK on table COSTS

Properties

Name: | COSTS_PROMO_FK
Table: | COSTS
Type: | Referential Integrity
Status: | Disabled
Delete rule: | No Action
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: | SH
R Constraint: | PROMO_PK

Columns

Name
PROMO_ID
Total: 1 column(s)

Reference columns

Owner | Table | Column
SH | PROMOTIONS | PROMO_ID
Total: 1 reference column(s)

DDL

See Also

List of constraints
Table [COSTS]


Constraint: COSTS_TIME_FK on table COSTS

Properties

Name: | COSTS_TIME_FK
Table: | COSTS
Type: | Referential Integrity
Status: | Enabled
Delete rule: | No Action
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: | SH
R Constraint: | TIMES_PK

Columns

Name
TIME_ID
Total: 1 column(s)

Reference columns

Owner | Table | Column
SH | TIMES | TIME_ID
Total: 1 reference column(s)

DDL

See Also

List of constraints
Table [COSTS]


Constraint: COUNTRIES_PK on table COUNTRIES

Properties

Name: | COUNTRIES_PK
Table: | COUNTRIES
Type: | Primary Key
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
COUNTRY_ID
Total: 1 column(s)

DDL

ALTER TABLE "SH"."COUNTRIES" ADD CONSTRAINT "COUNTRIES_PK" PRIMARY KEY ("COUNTRY_ID")
USING INDEX PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING COMPUTE STATISTICS
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" ENABLE NOVALIDATE

See Also

List of constraints
Table [COUNTRIES]


Constraint: CUSTOMERS_COUNTRY_FK on table CUSTOMERS

Properties

Name: | CUSTOMERS_COUNTRY_FK
Table: | CUSTOMERS
Type: | Referential Integrity
Status: | Enabled
Delete rule: | No Action
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: | SH
R Constraint: | COUNTRIES_PK

Columns

Name
COUNTRY_ID
Total: 1 column(s)

Reference columns

Owner | Table | Column
SH | COUNTRIES | COUNTRY_ID
Total: 1 reference column(s)

DDL

See Also

List of constraints
Table [CUSTOMERS]


Constraint: CUSTOMERS_PK on table CUSTOMERS

Properties

Name: | CUSTOMERS_PK
Table: | CUSTOMERS
Type: | Primary Key
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
CUST_ID
Total: 1 column(s)

DDL

ALTER TABLE "SH"."CUSTOMERS" ADD CONSTRAINT "CUSTOMERS_PK" PRIMARY KEY ("CUST_ID")
USING INDEX PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING COMPUTE STATISTICS
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" ENABLE NOVALIDATE

See Also

List of constraints
Table [CUSTOMERS]


Constraint: PRODUCTS_PK on table PRODUCTS

Properties

Name: | PRODUCTS_PK
Table: | PRODUCTS
Type: | Primary Key
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
PROD_ID
Total: 1 column(s)

DDL

ALTER TABLE "SH"."PRODUCTS" ADD CONSTRAINT "PRODUCTS_PK" PRIMARY KEY ("PROD_ID")
USING INDEX PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING COMPUTE STATISTICS
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" ENABLE NOVALIDATE

See Also

List of constraints
Table [PRODUCTS]


Constraint: PROMO_PK on table PROMOTIONS

Properties

Name: | PROMO_PK
Table: | PROMOTIONS
Type: | Primary Key
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
PROMO_ID
Total: 1 column(s)

DDL

ALTER TABLE "SH"."PROMOTIONS" ADD CONSTRAINT "PROMO_PK" PRIMARY KEY ("PROMO_ID")
USING INDEX PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING COMPUTE STATISTICS
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" ENABLE NOVALIDATE

See Also

List of constraints
Table [PROMOTIONS]


Constraint: SALES_CHANNEL_FK on table SALES

Properties

Name: | SALES_CHANNEL_FK
Table: | SALES
Type: | Referential Integrity
Status: | Enabled
Delete rule: | No Action
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: | SH
R Constraint: | CHANNELS_PK

Columns

Name
CHANNEL_ID
Total: 1 column(s)

Reference columns

Owner | Table | Column
SH | CHANNELS | CHANNEL_ID
Total: 1 reference column(s)

DDL

See Also

List of constraints
Table [SALES]


Constraint: SALES_CUSTOMER_FK on table SALES

Properties

Name: | SALES_CUSTOMER_FK
Table: | SALES
Type: | Referential Integrity
Status: | Enabled
Delete rule: | No Action
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: | SH
R Constraint: | CUSTOMERS_PK

Columns

Name
CUST_ID
Total: 1 column(s)

Reference columns

Owner | Table | Column
SH | CUSTOMERS | CUST_ID
Total: 1 reference column(s)

DDL

See Also

List of constraints
Table [SALES]


Constraint: SALES_PRODUCT_FK on table SALES

Properties

Name: | SALES_PRODUCT_FK
Table: | SALES
Type: | Referential Integrity
Status: | Enabled
Delete rule: | No Action
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: | SH
R Constraint: | PRODUCTS_PK

Columns

Name
PROD_ID
Total: 1 column(s)

Reference columns

Owner | Table | Column
SH | PRODUCTS | PROD_ID
Total: 1 reference column(s)

DDL

See Also

List of constraints
Table [SALES]


Constraint: SALES_PROMO_FK on table SALES

Properties

Name: | SALES_PROMO_FK
Table: | SALES
Type: | Referential Integrity
Status: | Enabled
Delete rule: | No Action
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: | SH
R Constraint: | PROMO_PK

Columns

Name
PROMO_ID
Total: 1 column(s)

Reference columns

Owner | Table | Column
SH | PROMOTIONS | PROMO_ID
Total: 1 reference column(s)

DDL

See Also

List of constraints
Table [SALES]


Constraint: SALES_TIME_FK on table SALES

Properties

Name: | SALES_TIME_FK
Table: | SALES
Type: | Referential Integrity
Status: | Enabled
Delete rule: | No Action
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: | SH
R Constraint: | TIMES_PK

Columns

Name
TIME_ID
Total: 1 column(s)

Reference columns

Owner | Table | Column
SH | TIMES | TIME_ID
Total: 1 reference column(s)

DDL

See Also

List of constraints
Table [SALES]


Constraint: SUPP_DEMO_PK on table SUPPLEMENTARY_DEMOGRAPHICS

Properties

Name: | SUPP_DEMO_PK
Table: | SUPPLEMENTARY_DEMOGRAPHICS
Type: | Primary Key
Status: | Disabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
CUST_ID
Total: 1 column(s)

DDL

ALTER TABLE "SH"."SUPPLEMENTARY_DEMOGRAPHICS" ADD CONSTRAINT "SUPP_DEMO_PK" PRIMARY KEY ("CUST_ID") DISABLE

See Also

List of constraints
Table [SUPPLEMENTARY_DEMOGRAPHICS]


Constraint: SYS_C005209 on table SALES

Properties

Name: | SYS_C005209
Table: | SALES
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
PROD_ID
Total: 1 column(s)

DDL

ALTER TABLE "SH"."SALES" MODIFY ("PROD_ID" NOT NULL ENABLE)

See Also

List of constraints
Table [SALES]


Constraint: SYS_C005210 on table SALES

Properties

Name: | SYS_C005210
Table: | SALES
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
CUST_ID
Total: 1 column(s)

DDL

ALTER TABLE "SH"."SALES" MODIFY ("CUST_ID" NOT NULL ENABLE)

See Also

List of constraints
Table [SALES]


Constraint: SYS_C005211 on table SALES

Properties

Name: | SYS_C005211
Table: | SALES
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
TIME_ID
Total: 1 column(s)

DDL

ALTER TABLE "SH"."SALES" MODIFY ("TIME_ID" NOT NULL ENABLE)

See Also

List of constraints
Table [SALES]


Constraint: SYS_C005212 on table SALES

Properties

Name: | SYS_C005212
Table: | SALES
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
CHANNEL_ID
Total: 1 column(s)

DDL

ALTER TABLE "SH"."SALES" MODIFY ("CHANNEL_ID" NOT NULL ENABLE)

See Also

List of constraints
Table [SALES]


Constraint: SYS_C005213 on table SALES

Properties

Name: | SYS_C005213
Table: | SALES
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
PROMO_ID
Total: 1 column(s)

DDL

ALTER TABLE "SH"."SALES" MODIFY ("PROMO_ID" NOT NULL ENABLE)

See Also

List of constraints
Table [SALES]


Constraint: SYS_C005214 on table SALES

Properties

Name: | SYS_C005214
Table: | SALES
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
QUANTITY_SOLD
Total: 1 column(s)

DDL

ALTER TABLE "SH"."SALES" MODIFY ("QUANTITY_SOLD" NOT NULL ENABLE)

See Also

List of constraints
Table [SALES]


Constraint: SYS_C005215 on table SALES

Properties

Name: | SYS_C005215
Table: | SALES
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
AMOUNT_SOLD
Total: 1 column(s)

DDL

ALTER TABLE "SH"."SALES" MODIFY ("AMOUNT_SOLD" NOT NULL ENABLE)

See Also

List of constraints
Table [SALES]


Constraint: SYS_C005216 on table COSTS

Properties

Name: | SYS_C005216
Table: | COSTS
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
PROD_ID
Total: 1 column(s)

DDL

ALTER TABLE "SH"."COSTS" MODIFY ("PROD_ID" NOT NULL ENABLE)

See Also

List of constraints
Table [COSTS]


Constraint: SYS_C005217 on table COSTS

Properties

Name: | SYS_C005217
Table: | COSTS
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
TIME_ID
Total: 1 column(s)

DDL

ALTER TABLE "SH"."COSTS" MODIFY ("TIME_ID" NOT NULL ENABLE)

See Also

List of constraints
Table [COSTS]


Constraint: SYS_C005218 on table COSTS

Properties

Name: | SYS_C005218
Table: | COSTS
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
PROMO_ID
Total: 1 column(s)

DDL

ALTER TABLE "SH"."COSTS" MODIFY ("PROMO_ID" NOT NULL ENABLE)

See Also

List of constraints
Table [COSTS]


Constraint: SYS_C005219 on table COSTS

Properties

Name: | SYS_C005219
Table: | COSTS
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
CHANNEL_ID
Total: 1 column(s)

DDL

ALTER TABLE "SH"."COSTS" MODIFY ("CHANNEL_ID" NOT NULL ENABLE)

See Also

List of constraints
Table [COSTS]


Constraint: SYS_C005220 on table COSTS

Properties

Name: | SYS_C005220
Table: | COSTS
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
UNIT_COST
Total: 1 column(s)

DDL

ALTER TABLE "SH"."COSTS" MODIFY ("UNIT_COST" NOT NULL ENABLE)

See Also

List of constraints
Table [COSTS]


Constraint: SYS_C005221 on table COSTS

Properties

Name: | SYS_C005221
Table: | COSTS
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
UNIT_PRICE
Total: 1 column(s)

DDL

ALTER TABLE "SH"."COSTS" MODIFY ("UNIT_PRICE" NOT NULL ENABLE)

See Also

List of constraints
Table [COSTS]


Constraint: SYS_C005222 on table TIMES

Properties

Name: | SYS_C005222
Table: | TIMES
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
TIME_ID
Total: 1 column(s)

DDL

ALTER TABLE "SH"."TIMES" MODIFY ("TIME_ID" NOT NULL ENABLE)

See Also

List of constraints
Table [TIMES]


Constraint: SYS_C005223 on table TIMES

Properties

Name: | SYS_C005223
Table: | TIMES
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
DAY_NAME
Total: 1 column(s)

DDL

ALTER TABLE "SH"."TIMES" MODIFY ("DAY_NAME" NOT NULL ENABLE)

See Also

List of constraints
Table [TIMES]


Constraint: SYS_C005224 on table TIMES

Properties

Name: | SYS_C005224
Table: | TIMES
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
DAY_NUMBER_IN_WEEK
Total: 1 column(s)

DDL

ALTER TABLE "SH"."TIMES" MODIFY ("DAY_NUMBER_IN_WEEK" NOT NULL ENABLE)

See Also

List of constraints
Table [TIMES]


Constraint: SYS_C005225 on table TIMES

Properties

Name: | SYS_C005225
Table: | TIMES
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
DAY_NUMBER_IN_MONTH
Total: 1 column(s)

DDL

ALTER TABLE "SH"."TIMES" MODIFY ("DAY_NUMBER_IN_MONTH" NOT NULL ENABLE)

See Also

List of constraints
Table [TIMES]


Constraint: SYS_C005226 on table TIMES

Properties

Name: | SYS_C005226
Table: | TIMES
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
CALENDAR_WEEK_NUMBER
Total: 1 column(s)

DDL

ALTER TABLE "SH"."TIMES" MODIFY ("CALENDAR_WEEK_NUMBER" NOT NULL ENABLE)

See Also

List of constraints
Table [TIMES]


Constraint: SYS_C005227 on table TIMES

Properties

Name: | SYS_C005227
Table: | TIMES
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
FISCAL_WEEK_NUMBER
Total: 1 column(s)

DDL

ALTER TABLE "SH"."TIMES" MODIFY ("FISCAL_WEEK_NUMBER" NOT NULL ENABLE)

See Also

List of constraints
Table [TIMES]


Constraint: SYS_C005228 on table TIMES

Properties

Name: | SYS_C005228
Table: | TIMES
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
WEEK_ENDING_DAY
Total: 1 column(s)

DDL

ALTER TABLE "SH"."TIMES" MODIFY ("WEEK_ENDING_DAY" NOT NULL ENABLE)

See Also

List of constraints
Table [TIMES]


Constraint: SYS_C005229 on table TIMES

Properties

Name: | SYS_C005229
Table: | TIMES
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
WEEK_ENDING_DAY_ID
Total: 1 column(s)

DDL

ALTER TABLE "SH"."TIMES" MODIFY ("WEEK_ENDING_DAY_ID" NOT NULL ENABLE)

See Also

List of constraints
Table [TIMES]


Constraint: SYS_C005230 on table TIMES

Properties

Name: | SYS_C005230
Table: | TIMES
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
CALENDAR_MONTH_NUMBER
Total: 1 column(s)

DDL

ALTER TABLE "SH"."TIMES" MODIFY ("CALENDAR_MONTH_NUMBER" NOT NULL ENABLE)

See Also

List of constraints
Table [TIMES]


Constraint: SYS_C005231 on table TIMES

Properties

Name: | SYS_C005231
Table: | TIMES
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
FISCAL_MONTH_NUMBER
Total: 1 column(s)

DDL

ALTER TABLE "SH"."TIMES" MODIFY ("FISCAL_MONTH_NUMBER" NOT NULL ENABLE)

See Also

List of constraints
Table [TIMES]


Constraint: SYS_C005232 on table TIMES

Properties

Name: | SYS_C005232
Table: | TIMES
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
CALENDAR_MONTH_DESC
Total: 1 column(s)

DDL

ALTER TABLE "SH"."TIMES" MODIFY ("CALENDAR_MONTH_DESC" NOT NULL ENABLE)

See Also

List of constraints
Table [TIMES]


Constraint: SYS_C005233 on table TIMES

Properties

Name: | SYS_C005233
Table: | TIMES
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
CALENDAR_MONTH_ID
Total: 1 column(s)

DDL

ALTER TABLE "SH"."TIMES" MODIFY ("CALENDAR_MONTH_ID" NOT NULL ENABLE)

See Also

List of constraints
Table [TIMES]


Constraint: SYS_C005234 on table TIMES

Properties

Name: | SYS_C005234
Table: | TIMES
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
FISCAL_MONTH_DESC
Total: 1 column(s)

DDL

ALTER TABLE "SH"."TIMES" MODIFY ("FISCAL_MONTH_DESC" NOT NULL ENABLE)

See Also

List of constraints
Table [TIMES]


Constraint: SYS_C005235 on table TIMES

Properties

Name: | SYS_C005235
Table: | TIMES
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
FISCAL_MONTH_ID
Total: 1 column(s)

DDL

ALTER TABLE "SH"."TIMES" MODIFY ("FISCAL_MONTH_ID" NOT NULL ENABLE)

See Also

List of constraints
Table [TIMES]


Constraint: SYS_C005236 on table TIMES

Properties

Name: | SYS_C005236
Table: | TIMES
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
DAYS_IN_CAL_MONTH
Total: 1 column(s)

DDL

ALTER TABLE "SH"."TIMES" MODIFY ("DAYS_IN_CAL_MONTH" NOT NULL ENABLE)

See Also

List of constraints
Table [TIMES]


Constraint: SYS_C005237 on table TIMES

Properties

Name: | SYS_C005237
Table: | TIMES
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
DAYS_IN_FIS_MONTH
Total: 1 column(s)

DDL

ALTER TABLE "SH"."TIMES" MODIFY ("DAYS_IN_FIS_MONTH" NOT NULL ENABLE)

See Also

List of constraints
Table [TIMES]


Constraint: SYS_C005238 on table TIMES

Properties

Name: | SYS_C005238
Table: | TIMES
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
END_OF_CAL_MONTH
Total: 1 column(s)

DDL

ALTER TABLE "SH"."TIMES" MODIFY ("END_OF_CAL_MONTH" NOT NULL ENABLE)

See Also

List of constraints
Table [TIMES]


Constraint: SYS_C005239 on table TIMES

Properties

Name: | SYS_C005239
Table: | TIMES
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
END_OF_FIS_MONTH
Total: 1 column(s)

DDL

ALTER TABLE "SH"."TIMES" MODIFY ("END_OF_FIS_MONTH" NOT NULL ENABLE)

See Also

List of constraints
Table [TIMES]


Constraint: SYS_C005240 on table TIMES

Properties

Name: | SYS_C005240
Table: | TIMES
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
CALENDAR_MONTH_NAME
Total: 1 column(s)

DDL

ALTER TABLE "SH"."TIMES" MODIFY ("CALENDAR_MONTH_NAME" NOT NULL ENABLE)

See Also

List of constraints
Table [TIMES]


Constraint: SYS_C005241 on table TIMES

Properties

Name: | SYS_C005241
Table: | TIMES
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
FISCAL_MONTH_NAME
Total: 1 column(s)

DDL

ALTER TABLE "SH"."TIMES" MODIFY ("FISCAL_MONTH_NAME" NOT NULL ENABLE)

See Also

List of constraints
Table [TIMES]


Constraint: SYS_C005242 on table TIMES

Properties

Name: | SYS_C005242
Table: | TIMES
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
CALENDAR_QUARTER_DESC
Total: 1 column(s)

DDL

ALTER TABLE "SH"."TIMES" MODIFY ("CALENDAR_QUARTER_DESC" NOT NULL ENABLE)

See Also

List of constraints
Table [TIMES]


Constraint: SYS_C005243 on table TIMES

Properties

Name: | SYS_C005243
Table: | TIMES
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
CALENDAR_QUARTER_ID
Total: 1 column(s)

DDL

ALTER TABLE "SH"."TIMES" MODIFY ("CALENDAR_QUARTER_ID" NOT NULL ENABLE)

See Also

List of constraints
Table [TIMES]


Constraint: SYS_C005244 on table TIMES

Properties

Name: | SYS_C005244
Table: | TIMES
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
FISCAL_QUARTER_DESC
Total: 1 column(s)

DDL

ALTER TABLE "SH"."TIMES" MODIFY ("FISCAL_QUARTER_DESC" NOT NULL ENABLE)

See Also

List of constraints
Table [TIMES]


Constraint: SYS_C005245 on table TIMES

Properties

Name: | SYS_C005245
Table: | TIMES
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
FISCAL_QUARTER_ID
Total: 1 column(s)

DDL

ALTER TABLE "SH"."TIMES" MODIFY ("FISCAL_QUARTER_ID" NOT NULL ENABLE)

See Also

List of constraints
Table [TIMES]


Constraint: SYS_C005246 on table TIMES

Properties

Name: | SYS_C005246
Table: | TIMES
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
DAYS_IN_CAL_QUARTER
Total: 1 column(s)

DDL

ALTER TABLE "SH"."TIMES" MODIFY ("DAYS_IN_CAL_QUARTER" NOT NULL ENABLE)

See Also

List of constraints
Table [TIMES]


Constraint: SYS_C005247 on table TIMES

Properties

Name: | SYS_C005247
Table: | TIMES
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
DAYS_IN_FIS_QUARTER
Total: 1 column(s)

DDL

ALTER TABLE "SH"."TIMES" MODIFY ("DAYS_IN_FIS_QUARTER" NOT NULL ENABLE)

See Also

List of constraints
Table [TIMES]


Constraint: SYS_C005248 on table TIMES

Properties

Name: | SYS_C005248
Table: | TIMES
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
END_OF_CAL_QUARTER
Total: 1 column(s)

DDL

ALTER TABLE "SH"."TIMES" MODIFY ("END_OF_CAL_QUARTER" NOT NULL ENABLE)

See Also

List of constraints
Table [TIMES]


Constraint: SYS_C005249 on table TIMES

Properties

Name: | SYS_C005249
Table: | TIMES
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
END_OF_FIS_QUARTER
Total: 1 column(s)

DDL

ALTER TABLE "SH"."TIMES" MODIFY ("END_OF_FIS_QUARTER" NOT NULL ENABLE)

See Also

List of constraints
Table [TIMES]


Constraint: SYS_C005250 on table TIMES

Properties

Name: | SYS_C005250
Table: | TIMES
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
CALENDAR_QUARTER_NUMBER
Total: 1 column(s)

DDL

ALTER TABLE "SH"."TIMES" MODIFY ("CALENDAR_QUARTER_NUMBER" NOT NULL ENABLE)

See Also

List of constraints
Table [TIMES]


Constraint: SYS_C005251 on table TIMES

Properties

Name: | SYS_C005251
Table: | TIMES
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
FISCAL_QUARTER_NUMBER
Total: 1 column(s)

DDL

ALTER TABLE "SH"."TIMES" MODIFY ("FISCAL_QUARTER_NUMBER" NOT NULL ENABLE)

See Also

List of constraints
Table [TIMES]


Constraint: SYS_C005252 on table TIMES

Properties

Name: | SYS_C005252
Table: | TIMES
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
CALENDAR_YEAR
Total: 1 column(s)

DDL

ALTER TABLE "SH"."TIMES" MODIFY ("CALENDAR_YEAR" NOT NULL ENABLE)

See Also

List of constraints
Table [TIMES]


Constraint: SYS_C005253 on table TIMES

Properties

Name: | SYS_C005253
Table: | TIMES
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
CALENDAR_YEAR_ID
Total: 1 column(s)

DDL

ALTER TABLE "SH"."TIMES" MODIFY ("CALENDAR_YEAR_ID" NOT NULL ENABLE)

See Also

List of constraints
Table [TIMES]


Constraint: SYS_C005254 on table TIMES

Properties

Name: | SYS_C005254
Table: | TIMES
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
FISCAL_YEAR
Total: 1 column(s)

DDL

ALTER TABLE "SH"."TIMES" MODIFY ("FISCAL_YEAR" NOT NULL ENABLE)

See Also

List of constraints
Table [TIMES]


Constraint: SYS_C005255 on table TIMES

Properties

Name: | SYS_C005255
Table: | TIMES
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
FISCAL_YEAR_ID
Total: 1 column(s)

DDL

ALTER TABLE "SH"."TIMES" MODIFY ("FISCAL_YEAR_ID" NOT NULL ENABLE)

See Also

List of constraints
Table [TIMES]


Constraint: SYS_C005256 on table TIMES

Properties

Name: | SYS_C005256
Table: | TIMES
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
DAYS_IN_CAL_YEAR
Total: 1 column(s)

DDL

ALTER TABLE "SH"."TIMES" MODIFY ("DAYS_IN_CAL_YEAR" NOT NULL ENABLE)

See Also

List of constraints
Table [TIMES]


Constraint: SYS_C005257 on table TIMES

Properties

Name: | SYS_C005257
Table: | TIMES
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
DAYS_IN_FIS_YEAR
Total: 1 column(s)

DDL

ALTER TABLE "SH"."TIMES" MODIFY ("DAYS_IN_FIS_YEAR" NOT NULL ENABLE)

See Also

List of constraints
Table [TIMES]


Constraint: SYS_C005258 on table TIMES

Properties

Name: | SYS_C005258
Table: | TIMES
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
END_OF_CAL_YEAR
Total: 1 column(s)

DDL

ALTER TABLE "SH"."TIMES" MODIFY ("END_OF_CAL_YEAR" NOT NULL ENABLE)

See Also

List of constraints
Table [TIMES]


Constraint: SYS_C005259 on table TIMES

Properties

Name: | SYS_C005259
Table: | TIMES
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
END_OF_FIS_YEAR
Total: 1 column(s)

DDL

ALTER TABLE "SH"."TIMES" MODIFY ("END_OF_FIS_YEAR" NOT NULL ENABLE)

See Also

List of constraints
Table [TIMES]


Constraint: SYS_C005261 on table PRODUCTS

Properties

Name: | SYS_C005261
Table: | PRODUCTS
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
PROD_ID
Total: 1 column(s)

DDL

ALTER TABLE "SH"."PRODUCTS" MODIFY ("PROD_ID" NOT NULL ENABLE)

See Also

List of constraints
Table [PRODUCTS]


Constraint: SYS_C005262 on table PRODUCTS

Properties

Name: | SYS_C005262
Table: | PRODUCTS
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
PROD_NAME
Total: 1 column(s)

DDL

ALTER TABLE "SH"."PRODUCTS" MODIFY ("PROD_NAME" NOT NULL ENABLE)

See Also

List of constraints
Table [PRODUCTS]


Constraint: SYS_C005263 on table PRODUCTS

Properties

Name: | SYS_C005263
Table: | PRODUCTS
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
PROD_DESC
Total: 1 column(s)

DDL

ALTER TABLE "SH"."PRODUCTS" MODIFY ("PROD_DESC" NOT NULL ENABLE)

See Also

List of constraints
Table [PRODUCTS]


Constraint: SYS_C005264 on table PRODUCTS

Properties

Name: | SYS_C005264
Table: | PRODUCTS
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
PROD_SUBCATEGORY
Total: 1 column(s)

DDL

ALTER TABLE "SH"."PRODUCTS" MODIFY ("PROD_SUBCATEGORY" NOT NULL ENABLE)

See Also

List of constraints
Table [PRODUCTS]


Constraint: SYS_C005265 on table PRODUCTS

Properties

Name: | SYS_C005265
Table: | PRODUCTS
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
PROD_SUBCATEGORY_ID
Total: 1 column(s)

DDL

ALTER TABLE "SH"."PRODUCTS" MODIFY ("PROD_SUBCATEGORY_ID" NOT NULL ENABLE)

See Also

List of constraints
Table [PRODUCTS]


Constraint: SYS_C005266 on table PRODUCTS

Properties

Name: | SYS_C005266
Table: | PRODUCTS
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
PROD_SUBCATEGORY_DESC
Total: 1 column(s)

DDL

ALTER TABLE "SH"."PRODUCTS" MODIFY ("PROD_SUBCATEGORY_DESC" NOT NULL ENABLE)

See Also

List of constraints
Table [PRODUCTS]


Constraint: SYS_C005267 on table PRODUCTS

Properties

Name: | SYS_C005267
Table: | PRODUCTS
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
PROD_CATEGORY
Total: 1 column(s)

DDL

ALTER TABLE "SH"."PRODUCTS" MODIFY ("PROD_CATEGORY" NOT NULL ENABLE)

See Also

List of constraints
Table [PRODUCTS]


Constraint: SYS_C005268 on table PRODUCTS

Properties

Name: | SYS_C005268
Table: | PRODUCTS
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
PROD_CATEGORY_ID
Total: 1 column(s)

DDL

ALTER TABLE "SH"."PRODUCTS" MODIFY ("PROD_CATEGORY_ID" NOT NULL ENABLE)

See Also

List of constraints
Table [PRODUCTS]


Constraint: SYS_C005269 on table PRODUCTS

Properties

Name: | SYS_C005269
Table: | PRODUCTS
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
PROD_CATEGORY_DESC
Total: 1 column(s)

DDL

ALTER TABLE "SH"."PRODUCTS" MODIFY ("PROD_CATEGORY_DESC" NOT NULL ENABLE)

See Also

List of constraints
Table [PRODUCTS]


Constraint: SYS_C005270 on table PRODUCTS

Properties

Name: | SYS_C005270
Table: | PRODUCTS
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
PROD_WEIGHT_CLASS
Total: 1 column(s)

DDL

ALTER TABLE "SH"."PRODUCTS" MODIFY ("PROD_WEIGHT_CLASS" NOT NULL ENABLE)

See Also

List of constraints
Table [PRODUCTS]


Constraint: SYS_C005271 on table PRODUCTS

Properties

Name: | SYS_C005271
Table: | PRODUCTS
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
PROD_PACK_SIZE
Total: 1 column(s)

DDL

ALTER TABLE "SH"."PRODUCTS" MODIFY ("PROD_PACK_SIZE" NOT NULL ENABLE)

See Also

List of constraints
Table [PRODUCTS]


Constraint: SYS_C005272 on table PRODUCTS

Properties

Name: | SYS_C005272
Table: | PRODUCTS
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
SUPPLIER_ID
Total: 1 column(s)

DDL

ALTER TABLE "SH"."PRODUCTS" MODIFY ("SUPPLIER_ID" NOT NULL ENABLE)

See Also

List of constraints
Table [PRODUCTS]


Constraint: SYS_C005273 on table PRODUCTS

Properties

Name: | SYS_C005273
Table: | PRODUCTS
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
PROD_STATUS
Total: 1 column(s)

DDL

ALTER TABLE "SH"."PRODUCTS" MODIFY ("PROD_STATUS" NOT NULL ENABLE)

See Also

List of constraints
Table [PRODUCTS]


Constraint: SYS_C005274 on table PRODUCTS

Properties

Name: | SYS_C005274
Table: | PRODUCTS
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
PROD_LIST_PRICE
Total: 1 column(s)

DDL

ALTER TABLE "SH"."PRODUCTS" MODIFY ("PROD_LIST_PRICE" NOT NULL ENABLE)

See Also

List of constraints
Table [PRODUCTS]


Constraint: SYS_C005275 on table PRODUCTS

Properties

Name: | SYS_C005275
Table: | PRODUCTS
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
PROD_MIN_PRICE
Total: 1 column(s)

DDL

ALTER TABLE "SH"."PRODUCTS" MODIFY ("PROD_MIN_PRICE" NOT NULL ENABLE)

See Also

List of constraints
Table [PRODUCTS]


Constraint: SYS_C005276 on table PRODUCTS

Properties

Name: | SYS_C005276
Table: | PRODUCTS
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
PROD_TOTAL
Total: 1 column(s)

DDL

ALTER TABLE "SH"."PRODUCTS" MODIFY ("PROD_TOTAL" NOT NULL ENABLE)

See Also

List of constraints
Table [PRODUCTS]


Constraint: SYS_C005277 on table PRODUCTS

Properties

Name: | SYS_C005277
Table: | PRODUCTS
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
PROD_TOTAL_ID
Total: 1 column(s)

DDL

ALTER TABLE "SH"."PRODUCTS" MODIFY ("PROD_TOTAL_ID" NOT NULL ENABLE)

See Also

List of constraints
Table [PRODUCTS]


Constraint: SYS_C005279 on table CHANNELS

Properties

Name: | SYS_C005279
Table: | CHANNELS
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
CHANNEL_ID
Total: 1 column(s)

DDL

ALTER TABLE "SH"."CHANNELS" MODIFY ("CHANNEL_ID" NOT NULL ENABLE)

See Also

List of constraints
Table [CHANNELS]


Constraint: SYS_C005280 on table CHANNELS

Properties

Name: | SYS_C005280
Table: | CHANNELS
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
CHANNEL_DESC
Total: 1 column(s)

DDL

ALTER TABLE "SH"."CHANNELS" MODIFY ("CHANNEL_DESC" NOT NULL ENABLE)

See Also

List of constraints
Table [CHANNELS]


Constraint: SYS_C005281 on table CHANNELS

Properties

Name: | SYS_C005281
Table: | CHANNELS
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
CHANNEL_CLASS
Total: 1 column(s)

DDL

ALTER TABLE "SH"."CHANNELS" MODIFY ("CHANNEL_CLASS" NOT NULL ENABLE)

See Also

List of constraints
Table [CHANNELS]


Constraint: SYS_C005282 on table CHANNELS

Properties

Name: | SYS_C005282
Table: | CHANNELS
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
CHANNEL_CLASS_ID
Total: 1 column(s)

DDL

ALTER TABLE "SH"."CHANNELS" MODIFY ("CHANNEL_CLASS_ID" NOT NULL ENABLE)

See Also

List of constraints
Table [CHANNELS]


Constraint: SYS_C005283 on table CHANNELS

Properties

Name: | SYS_C005283
Table: | CHANNELS
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
CHANNEL_TOTAL
Total: 1 column(s)

DDL

ALTER TABLE "SH"."CHANNELS" MODIFY ("CHANNEL_TOTAL" NOT NULL ENABLE)

See Also

List of constraints
Table [CHANNELS]


Constraint: SYS_C005284 on table CHANNELS

Properties

Name: | SYS_C005284
Table: | CHANNELS
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
CHANNEL_TOTAL_ID
Total: 1 column(s)

DDL

ALTER TABLE "SH"."CHANNELS" MODIFY ("CHANNEL_TOTAL_ID" NOT NULL ENABLE)

See Also

List of constraints
Table [CHANNELS]


Constraint: SYS_C005286 on table PROMOTIONS

Properties

Name: | SYS_C005286
Table: | PROMOTIONS
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
PROMO_ID
Total: 1 column(s)

DDL

ALTER TABLE "SH"."PROMOTIONS" MODIFY ("PROMO_ID" NOT NULL ENABLE)

See Also

List of constraints
Table [PROMOTIONS]


Constraint: SYS_C005287 on table PROMOTIONS

Properties

Name: | SYS_C005287
Table: | PROMOTIONS
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
PROMO_NAME
Total: 1 column(s)

DDL

ALTER TABLE "SH"."PROMOTIONS" MODIFY ("PROMO_NAME" NOT NULL ENABLE)

See Also

List of constraints
Table [PROMOTIONS]


Constraint: SYS_C005288 on table PROMOTIONS

Properties

Name: | SYS_C005288
Table: | PROMOTIONS
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
PROMO_SUBCATEGORY
Total: 1 column(s)

DDL

ALTER TABLE "SH"."PROMOTIONS" MODIFY ("PROMO_SUBCATEGORY" NOT NULL ENABLE)

See Also

List of constraints
Table [PROMOTIONS]


Constraint: SYS_C005289 on table PROMOTIONS

Properties

Name: | SYS_C005289
Table: | PROMOTIONS
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
PROMO_SUBCATEGORY_ID
Total: 1 column(s)

DDL

ALTER TABLE "SH"."PROMOTIONS" MODIFY ("PROMO_SUBCATEGORY_ID" NOT NULL ENABLE)

See Also

List of constraints
Table [PROMOTIONS]


Constraint: SYS_C005290 on table PROMOTIONS

Properties

Name: | SYS_C005290
Table: | PROMOTIONS
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
PROMO_CATEGORY
Total: 1 column(s)

DDL

ALTER TABLE "SH"."PROMOTIONS" MODIFY ("PROMO_CATEGORY" NOT NULL ENABLE)

See Also

List of constraints
Table [PROMOTIONS]


Constraint: SYS_C005291 on table PROMOTIONS

Properties

Name: | SYS_C005291
Table: | PROMOTIONS
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
PROMO_CATEGORY_ID
Total: 1 column(s)

DDL

ALTER TABLE "SH"."PROMOTIONS" MODIFY ("PROMO_CATEGORY_ID" NOT NULL ENABLE)

See Also

List of constraints
Table [PROMOTIONS]


Constraint: SYS_C005292 on table PROMOTIONS

Properties

Name: | SYS_C005292
Table: | PROMOTIONS
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
PROMO_COST
Total: 1 column(s)

DDL

ALTER TABLE "SH"."PROMOTIONS" MODIFY ("PROMO_COST" NOT NULL ENABLE)

See Also

List of constraints
Table [PROMOTIONS]


Constraint: SYS_C005293 on table PROMOTIONS

Properties

Name: | SYS_C005293
Table: | PROMOTIONS
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
PROMO_BEGIN_DATE
Total: 1 column(s)

DDL

ALTER TABLE "SH"."PROMOTIONS" MODIFY ("PROMO_BEGIN_DATE" NOT NULL ENABLE)

See Also

List of constraints
Table [PROMOTIONS]


Constraint: SYS_C005294 on table PROMOTIONS

Properties

Name: | SYS_C005294
Table: | PROMOTIONS
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
PROMO_END_DATE
Total: 1 column(s)

DDL

ALTER TABLE "SH"."PROMOTIONS" MODIFY ("PROMO_END_DATE" NOT NULL ENABLE)

See Also

List of constraints
Table [PROMOTIONS]


Constraint: SYS_C005295 on table PROMOTIONS

Properties

Name: | SYS_C005295
Table: | PROMOTIONS
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
PROMO_TOTAL
Total: 1 column(s)

DDL

ALTER TABLE "SH"."PROMOTIONS" MODIFY ("PROMO_TOTAL" NOT NULL ENABLE)

See Also

List of constraints
Table [PROMOTIONS]


Constraint: SYS_C005296 on table PROMOTIONS

Properties

Name: | SYS_C005296
Table: | PROMOTIONS
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
PROMO_TOTAL_ID
Total: 1 column(s)

DDL

ALTER TABLE "SH"."PROMOTIONS" MODIFY ("PROMO_TOTAL_ID" NOT NULL ENABLE)

See Also

List of constraints
Table [PROMOTIONS]


Constraint: SYS_C005298 on table CUSTOMERS

Properties

Name: | SYS_C005298
Table: | CUSTOMERS
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
CUST_ID
Total: 1 column(s)

DDL

ALTER TABLE "SH"."CUSTOMERS" MODIFY ("CUST_ID" NOT NULL ENABLE)

See Also

List of constraints
Table [CUSTOMERS]


Constraint: SYS_C005299 on table CUSTOMERS

Properties

Name: | SYS_C005299
Table: | CUSTOMERS
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
CUST_FIRST_NAME
Total: 1 column(s)

DDL

ALTER TABLE "SH"."CUSTOMERS" MODIFY ("CUST_FIRST_NAME" NOT NULL ENABLE)

See Also

List of constraints
Table [CUSTOMERS]


Constraint: SYS_C005300 on table CUSTOMERS

Properties

Name: | SYS_C005300
Table: | CUSTOMERS
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
CUST_LAST_NAME
Total: 1 column(s)

DDL

ALTER TABLE "SH"."CUSTOMERS" MODIFY ("CUST_LAST_NAME" NOT NULL ENABLE)

See Also

List of constraints
Table [CUSTOMERS]


Constraint: SYS_C005301 on table CUSTOMERS

Properties

Name: | SYS_C005301
Table: | CUSTOMERS
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
CUST_GENDER
Total: 1 column(s)

DDL

ALTER TABLE "SH"."CUSTOMERS" MODIFY ("CUST_GENDER" NOT NULL ENABLE)

See Also

List of constraints
Table [CUSTOMERS]


Constraint: SYS_C005302 on table CUSTOMERS

Properties

Name: | SYS_C005302
Table: | CUSTOMERS
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
CUST_YEAR_OF_BIRTH
Total: 1 column(s)

DDL

ALTER TABLE "SH"."CUSTOMERS" MODIFY ("CUST_YEAR_OF_BIRTH" NOT NULL ENABLE)

See Also

List of constraints
Table [CUSTOMERS]


Constraint: SYS_C005303 on table CUSTOMERS

Properties

Name: | SYS_C005303
Table: | CUSTOMERS
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
CUST_STREET_ADDRESS
Total: 1 column(s)

DDL

ALTER TABLE "SH"."CUSTOMERS" MODIFY ("CUST_STREET_ADDRESS" NOT NULL ENABLE)

See Also

List of constraints
Table [CUSTOMERS]


Constraint: SYS_C005304 on table CUSTOMERS

Properties

Name: | SYS_C005304
Table: | CUSTOMERS
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
CUST_POSTAL_CODE
Total: 1 column(s)

DDL

ALTER TABLE "SH"."CUSTOMERS" MODIFY ("CUST_POSTAL_CODE" NOT NULL ENABLE)

See Also

List of constraints
Table [CUSTOMERS]


Constraint: SYS_C005305 on table CUSTOMERS

Properties

Name: | SYS_C005305
Table: | CUSTOMERS
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
CUST_CITY
Total: 1 column(s)

DDL

ALTER TABLE "SH"."CUSTOMERS" MODIFY ("CUST_CITY" NOT NULL ENABLE)

See Also

List of constraints
Table [CUSTOMERS]


Constraint: SYS_C005306 on table CUSTOMERS

Properties

Name: | SYS_C005306
Table: | CUSTOMERS
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
CUST_CITY_ID
Total: 1 column(s)

DDL

ALTER TABLE "SH"."CUSTOMERS" MODIFY ("CUST_CITY_ID" NOT NULL ENABLE)

See Also

List of constraints
Table [CUSTOMERS]


Constraint: SYS_C005307 on table CUSTOMERS

Properties

Name: | SYS_C005307
Table: | CUSTOMERS
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
CUST_STATE_PROVINCE
Total: 1 column(s)

DDL

ALTER TABLE "SH"."CUSTOMERS" MODIFY ("CUST_STATE_PROVINCE" NOT NULL ENABLE)

See Also

List of constraints
Table [CUSTOMERS]


Constraint: SYS_C005308 on table CUSTOMERS

Properties

Name: | SYS_C005308
Table: | CUSTOMERS
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
CUST_STATE_PROVINCE_ID
Total: 1 column(s)

DDL

ALTER TABLE "SH"."CUSTOMERS" MODIFY ("CUST_STATE_PROVINCE_ID" NOT NULL ENABLE)

See Also

List of constraints
Table [CUSTOMERS]


Constraint: SYS_C005309 on table CUSTOMERS

Properties

Name: | SYS_C005309
Table: | CUSTOMERS
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
COUNTRY_ID
Total: 1 column(s)

DDL

ALTER TABLE "SH"."CUSTOMERS" MODIFY ("COUNTRY_ID" NOT NULL ENABLE)

See Also

List of constraints
Table [CUSTOMERS]


Constraint: SYS_C005310 on table CUSTOMERS

Properties

Name: | SYS_C005310
Table: | CUSTOMERS
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
CUST_MAIN_PHONE_NUMBER
Total: 1 column(s)

DDL

ALTER TABLE "SH"."CUSTOMERS" MODIFY ("CUST_MAIN_PHONE_NUMBER" NOT NULL ENABLE)

See Also

List of constraints
Table [CUSTOMERS]


Constraint: SYS_C005311 on table CUSTOMERS

Properties

Name: | SYS_C005311
Table: | CUSTOMERS
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
CUST_TOTAL
Total: 1 column(s)

DDL

ALTER TABLE "SH"."CUSTOMERS" MODIFY ("CUST_TOTAL" NOT NULL ENABLE)

See Also

List of constraints
Table [CUSTOMERS]


Constraint: SYS_C005312 on table CUSTOMERS

Properties

Name: | SYS_C005312
Table: | CUSTOMERS
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
CUST_TOTAL_ID
Total: 1 column(s)

DDL

ALTER TABLE "SH"."CUSTOMERS" MODIFY ("CUST_TOTAL_ID" NOT NULL ENABLE)

See Also

List of constraints
Table [CUSTOMERS]


Constraint: SYS_C005314 on table COUNTRIES

Properties

Name: | SYS_C005314
Table: | COUNTRIES
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
COUNTRY_ID
Total: 1 column(s)

DDL

ALTER TABLE "SH"."COUNTRIES" MODIFY ("COUNTRY_ID" NOT NULL ENABLE)

See Also

List of constraints
Table [COUNTRIES]


Constraint: SYS_C005315 on table COUNTRIES

Properties

Name: | SYS_C005315
Table: | COUNTRIES
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
COUNTRY_ISO_CODE
Total: 1 column(s)

DDL

ALTER TABLE "SH"."COUNTRIES" MODIFY ("COUNTRY_ISO_CODE" NOT NULL ENABLE)

See Also

List of constraints
Table [COUNTRIES]


Constraint: SYS_C005316 on table COUNTRIES

Properties

Name: | SYS_C005316
Table: | COUNTRIES
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
COUNTRY_NAME
Total: 1 column(s)

DDL

ALTER TABLE "SH"."COUNTRIES" MODIFY ("COUNTRY_NAME" NOT NULL ENABLE)

See Also

List of constraints
Table [COUNTRIES]


Constraint: SYS_C005317 on table COUNTRIES

Properties

Name: | SYS_C005317
Table: | COUNTRIES
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
COUNTRY_SUBREGION
Total: 1 column(s)

DDL

ALTER TABLE "SH"."COUNTRIES" MODIFY ("COUNTRY_SUBREGION" NOT NULL ENABLE)

See Also

List of constraints
Table [COUNTRIES]


Constraint: SYS_C005318 on table COUNTRIES

Properties

Name: | SYS_C005318
Table: | COUNTRIES
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
COUNTRY_SUBREGION_ID
Total: 1 column(s)

DDL

ALTER TABLE "SH"."COUNTRIES" MODIFY ("COUNTRY_SUBREGION_ID" NOT NULL ENABLE)

See Also

List of constraints
Table [COUNTRIES]


Constraint: SYS_C005319 on table COUNTRIES

Properties

Name: | SYS_C005319
Table: | COUNTRIES
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
COUNTRY_REGION
Total: 1 column(s)

DDL

ALTER TABLE "SH"."COUNTRIES" MODIFY ("COUNTRY_REGION" NOT NULL ENABLE)

See Also

List of constraints
Table [COUNTRIES]


Constraint: SYS_C005320 on table COUNTRIES

Properties

Name: | SYS_C005320
Table: | COUNTRIES
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
COUNTRY_REGION_ID
Total: 1 column(s)

DDL

ALTER TABLE "SH"."COUNTRIES" MODIFY ("COUNTRY_REGION_ID" NOT NULL ENABLE)

See Also

List of constraints
Table [COUNTRIES]


Constraint: SYS_C005321 on table COUNTRIES

Properties

Name: | SYS_C005321
Table: | COUNTRIES
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
COUNTRY_TOTAL
Total: 1 column(s)

DDL

ALTER TABLE "SH"."COUNTRIES" MODIFY ("COUNTRY_TOTAL" NOT NULL ENABLE)

See Also

List of constraints
Table [COUNTRIES]


Constraint: SYS_C005322 on table COUNTRIES

Properties

Name: | SYS_C005322
Table: | COUNTRIES
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
COUNTRY_TOTAL_ID
Total: 1 column(s)

DDL

ALTER TABLE "SH"."COUNTRIES" MODIFY ("COUNTRY_TOTAL_ID" NOT NULL ENABLE)

See Also

List of constraints
Table [COUNTRIES]


Constraint: SYS_C005324 on table SUPPLEMENTARY_DEMOGRAPHICS

Properties

Name: | SYS_C005324
Table: | SUPPLEMENTARY_DEMOGRAPHICS
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
CUST_ID
Total: 1 column(s)

DDL

ALTER TABLE "SH"."SUPPLEMENTARY_DEMOGRAPHICS" MODIFY ("CUST_ID" NOT NULL ENABLE)

See Also

List of constraints
Table [SUPPLEMENTARY_DEMOGRAPHICS]


Constraint: SYS_C005326 on table MVIEW$_EXCEPTIONS

Properties

Name: | SYS_C005326
Table: | MVIEW$_EXCEPTIONS
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
OWNER
Total: 1 column(s)

DDL

ALTER TABLE "SH"."MVIEW$_EXCEPTIONS" MODIFY ("OWNER" NOT NULL ENABLE)

See Also

List of constraints
Table [MVIEW$_EXCEPTIONS]


Constraint: SYS_C005327 on table MVIEW$_EXCEPTIONS

Properties

Name: | SYS_C005327
Table: | MVIEW$_EXCEPTIONS
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
TABLE_NAME
Total: 1 column(s)

DDL

ALTER TABLE "SH"."MVIEW$_EXCEPTIONS" MODIFY ("TABLE_NAME" NOT NULL ENABLE)

See Also

List of constraints
Table [MVIEW$_EXCEPTIONS]


Constraint: SYS_C005328 on table MVIEW$_EXCEPTIONS

Properties

Name: | SYS_C005328
Table: | MVIEW$_EXCEPTIONS
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
DIMENSION_NAME
Total: 1 column(s)

DDL

ALTER TABLE "SH"."MVIEW$_EXCEPTIONS" MODIFY ("DIMENSION_NAME" NOT NULL ENABLE)

See Also

List of constraints
Table [MVIEW$_EXCEPTIONS]


Constraint: SYS_C005329 on table MVIEW$_EXCEPTIONS

Properties

Name: | SYS_C005329
Table: | MVIEW$_EXCEPTIONS
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
RELATIONSHIP
Total: 1 column(s)

DDL

ALTER TABLE "SH"."MVIEW$_EXCEPTIONS" MODIFY ("RELATIONSHIP" NOT NULL ENABLE)

See Also

List of constraints
Table [MVIEW$_EXCEPTIONS]


Constraint: SYS_C005330 on table MVIEW$_EXCEPTIONS

Properties

Name: | SYS_C005330
Table: | MVIEW$_EXCEPTIONS
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
BAD_ROWID
Total: 1 column(s)

DDL

ALTER TABLE "SH"."MVIEW$_EXCEPTIONS" MODIFY ("BAD_ROWID" NOT NULL ENABLE)

See Also

List of constraints
Table [MVIEW$_EXCEPTIONS]


Constraint: SYS_C005331 on table CAL_MONTH_SALES_MV

Properties

Name: | SYS_C005331
Table: | CAL_MONTH_SALES_MV
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
CALENDAR_MONTH_DESC
Total: 1 column(s)

DDL

ALTER TABLE "SH"."CAL_MONTH_SALES_MV" MODIFY ("CALENDAR_MONTH_DESC" NOT NULL ENABLE)

See Also

List of constraints
Table [CAL_MONTH_SALES_MV]


Constraint: SYS_C005332 on table FWEEK_PSCAT_SALES_MV

Properties

Name: | SYS_C005332
Table: | FWEEK_PSCAT_SALES_MV
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
WEEK_ENDING_DAY
Total: 1 column(s)

DDL

ALTER TABLE "SH"."FWEEK_PSCAT_SALES_MV" MODIFY ("WEEK_ENDING_DAY" NOT NULL ENABLE)

See Also

List of constraints
Table [FWEEK_PSCAT_SALES_MV]


Constraint: SYS_C005333 on table FWEEK_PSCAT_SALES_MV

Properties

Name: | SYS_C005333
Table: | FWEEK_PSCAT_SALES_MV
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
PROD_SUBCATEGORY
Total: 1 column(s)

DDL

ALTER TABLE "SH"."FWEEK_PSCAT_SALES_MV" MODIFY ("PROD_SUBCATEGORY" NOT NULL ENABLE)

See Also

List of constraints
Table [FWEEK_PSCAT_SALES_MV]


Constraint: SYS_C005334 on table FWEEK_PSCAT_SALES_MV

Properties

Name: | SYS_C005334
Table: | FWEEK_PSCAT_SALES_MV
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
CHANNEL_ID
Total: 1 column(s)

DDL

ALTER TABLE "SH"."FWEEK_PSCAT_SALES_MV" MODIFY ("CHANNEL_ID" NOT NULL ENABLE)

See Also

List of constraints
Table [FWEEK_PSCAT_SALES_MV]


Constraint: SYS_C005335 on table FWEEK_PSCAT_SALES_MV

Properties

Name: | SYS_C005335
Table: | FWEEK_PSCAT_SALES_MV
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
PROMO_ID
Total: 1 column(s)

DDL

ALTER TABLE "SH"."FWEEK_PSCAT_SALES_MV" MODIFY ("PROMO_ID" NOT NULL ENABLE)

See Also

List of constraints
Table [FWEEK_PSCAT_SALES_MV]


Constraint: SYS_C005367 on table DR$SUP_TEXT_IDX$I

Properties

Name: | SYS_C005367
Table: | DR$SUP_TEXT_IDX$I
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
TOKEN_TEXT
Total: 1 column(s)

DDL

ALTER TABLE "SH"."DR$SUP_TEXT_IDX$I" MODIFY ("TOKEN_TEXT" NOT NULL ENABLE)

See Also

List of constraints
Table [DR$SUP_TEXT_IDX$I]


Constraint: SYS_C005368 on table DR$SUP_TEXT_IDX$I

Properties

Name: | SYS_C005368
Table: | DR$SUP_TEXT_IDX$I
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
TOKEN_TYPE
Total: 1 column(s)

DDL

ALTER TABLE "SH"."DR$SUP_TEXT_IDX$I" MODIFY ("TOKEN_TYPE" NOT NULL ENABLE)

See Also

List of constraints
Table [DR$SUP_TEXT_IDX$I]


Constraint: SYS_C005369 on table DR$SUP_TEXT_IDX$I

Properties

Name: | SYS_C005369
Table: | DR$SUP_TEXT_IDX$I
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
TOKEN_FIRST
Total: 1 column(s)

DDL

ALTER TABLE "SH"."DR$SUP_TEXT_IDX$I" MODIFY ("TOKEN_FIRST" NOT NULL ENABLE)

See Also

List of constraints
Table [DR$SUP_TEXT_IDX$I]


Constraint: SYS_C005370 on table DR$SUP_TEXT_IDX$I

Properties

Name: | SYS_C005370
Table: | DR$SUP_TEXT_IDX$I
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
TOKEN_LAST
Total: 1 column(s)

DDL

ALTER TABLE "SH"."DR$SUP_TEXT_IDX$I" MODIFY ("TOKEN_LAST" NOT NULL ENABLE)

See Also

List of constraints
Table [DR$SUP_TEXT_IDX$I]


Constraint: SYS_C005371 on table DR$SUP_TEXT_IDX$I

Properties

Name: | SYS_C005371
Table: | DR$SUP_TEXT_IDX$I
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
TOKEN_COUNT
Total: 1 column(s)

DDL

ALTER TABLE "SH"."DR$SUP_TEXT_IDX$I" MODIFY ("TOKEN_COUNT" NOT NULL ENABLE)

See Also

List of constraints
Table [DR$SUP_TEXT_IDX$I]


Constraint: SYS_C005373 on table DR$SUP_TEXT_IDX$N

Properties

Name: | SYS_C005373
Table: | DR$SUP_TEXT_IDX$N
Type: | Check
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
NLT_MARK
Total: 1 column(s)

DDL

ALTER TABLE "SH"."DR$SUP_TEXT_IDX$N" MODIFY ("NLT_MARK" NOT NULL ENABLE)

See Also

List of constraints
Table [DR$SUP_TEXT_IDX$N]


Constraint: SYS_IOT_TOP_52330 on table DR$SUP_TEXT_IDX$K

Properties

Name: | SYS_IOT_TOP_52330
Table: | DR$SUP_TEXT_IDX$K
Type: | Primary Key
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
TEXTKEY
Total: 1 column(s)

DDL

ALTER TABLE "SH"."DR$SUP_TEXT_IDX$K" ADD PRIMARY KEY ("TEXTKEY")
USING INDEX PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" ENABLE

See Also

List of constraints
Table [DR$SUP_TEXT_IDX$K]


Constraint: SYS_IOT_TOP_52335 on table DR$SUP_TEXT_IDX$N

Properties

Name: | SYS_IOT_TOP_52335
Table: | DR$SUP_TEXT_IDX$N
Type: | Primary Key
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
NLT_DOCID
Total: 1 column(s)

DDL

ALTER TABLE "SH"."DR$SUP_TEXT_IDX$N" ADD PRIMARY KEY ("NLT_DOCID")
USING INDEX PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" ENABLE

See Also

List of constraints
Table [DR$SUP_TEXT_IDX$N]


Constraint: TIMES_PK on table TIMES

Properties

Name: | TIMES_PK
Table: | TIMES
Type: | Primary Key
Status: | Enabled
Delete rule: |
Defferable: | Not Deferrable
Deffered: | Immediate
R Owner: |
R Constraint: |

Columns

Name
TIME_ID
Total: 1 column(s)

DDL

ALTER TABLE "SH"."TIMES" ADD CONSTRAINT "TIMES_PK" PRIMARY KEY ("TIME_ID")
USING INDEX PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING COMPUTE STATISTICS
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE" ENABLE NOVALIDATE

See Also

List of constraints
Table [TIMES]


List of snapshots

Snapshots

Name | Tablespace | Refresh Method | Type | Status | PREBUILT | REWRITE_ENABLED
CAL_MONTH_SALES_MV | EXAMPLE | AGGREGATE | FORCE | UNKNOWN | YES | Y
FWEEK_PSCAT_SALES_MV | EXAMPLE | AGGREGATE | FORCE | UNKNOWN | YES | Y
Total: 2 snapshot(s)

See Also

Schema overview


Snapshot: CAL_MONTH_SALES_MV

Properties

Name: | CAL_MONTH_SALES_MV
Status: |
Tablespace: | EXAMPLE
Logging: | N
Partitioned: |
Cached: | ENABLED
Locking: | 2000
IOT type: |
Object type: |
Type owner: |
Type: | N
Temporary: | N
Secondary: | NO
Nested: | DEFAULT
Buffer pool: | DISABLED
Row movement: | YES
Index Only snapshot: |
Minimum % of free space: | 10
Minimum % of udes space: |
Initial transactions: | 1
Max transactions: | 65536
Initial extent size, bytes: |
Secondary extent size, bytes: | 1
Min extents: | 2147483645
Max extents: |
% increase in extent: |
Process free list: |
Process free list groups: | NO
Backee up: | 48
Rows: | 4
Used blocks: | 0
Empty blocks: | 0
Average free space: | 0
Chained rows: | 14
Average row length: | 0
Average freespace on a freelist: | 0
Blocks on a freelist: | 1
Threads per instance: | 1
Instances: | N
Sample size: | 03.15.2007
Last analysed: | NO
Global statistics: | YES
User statistics: | NO
Duration: |
Skip corrupt blocks: | DISABLED
Monitoring: | YES
Cluster owner: |
Dependencies: | DISABLED
SizeMB: | 0,06
Extents: | 1
SizeBytes: | 65536
Rollback segment: |
Table name: | CAL_MONTH_SALES_MV
Master view: |
Master owner: | SH
Master: | TIMES
Master link: |
Can use log: | YES
Uodateable: | NO
Refresh method: | AGGREGATE
Error: | 0
Next: |
Refresh group: |
Update trigger: |
Update log: |
Master rollback segment: |
Status: | UNKNOWN
Refresh mode: | DEMAND
Rebuild: | YES
Rewrite enabled: | Y
Rewrite capability: | GENERAL
Build mode: | PREBUILT
Fast refreshable: | DIRLOAD_LIMITEDDML
Last refresh type: | NA
Staleness: | UNKNOWN
After fast refresh: | UNKNOWN
Compile state: | VALID
Last refresh: | 03.15.2007
Start with: |
Use no index: | N

Columns

Name | Type | Length | Nchar Length | Precision | Scale | NULL | Default | Description
CALENDAR_MONTH_DESC | VARCHAR2 | 8 | 8 |  |  | N |  |
DOLLARS | NUMBER |  |  |  |  | Y |  |
Total: 2 column(s)

Query

SELECT t.calendar_month_desc
, sum(s.amount_sold) AS dollars
FROM sales s
,

DDL

See Also

List of snapshots


Snapshot: FWEEK_PSCAT_SALES_MV

Properties

Name: | FWEEK_PSCAT_SALES_MV
Status: |
Tablespace: | EXAMPLE
Logging: | N
Partitioned: |
Cached: | ENABLED
Locking: | 2000
IOT type: |
Object type: |
Type owner: |
Type: | N
Temporary: | N
Secondary: | NO
Nested: | DEFAULT
Buffer pool: | DISABLED
Row movement: | YES
Index Only snapshot: |
Minimum % of free space: | 10
Minimum % of udes space: |
Initial transactions: | 1
Max transactions: | 65536
Initial extent size, bytes: |
Secondary extent size, bytes: | 1
Min extents: | 2147483645
Max extents: |
% increase in extent: |
Process free list: |
Process free list groups: | NO
Backee up: | 11266
Rows: | 68
Used blocks: | 0
Empty blocks: | 0
Average free space: | 0
Chained rows: | 33
Average row length: | 0
Average freespace on a freelist: | 0
Blocks on a freelist: | 1
Threads per instance: | 1
Instances: | N
Sample size: | 03.15.2007
Last analysed: | NO
Global statistics: | YES
User statistics: | NO
Duration: |
Skip corrupt blocks: | DISABLED
Monitoring: | YES
Cluster owner: |
Dependencies: | DISABLED
SizeMB: | 0,56
Extents: | 9
SizeBytes: | 589824
Rollback segment: |
Table name: | FWEEK_PSCAT_SALES_MV
Master view: |
Master owner: | SH
Master: | PRODUCTS
Master link: |
Can use log: | YES
Uodateable: | NO
Refresh method: | AGGREGATE
Error: | 0
Next: |
Refresh group: |
Update trigger: |
Update log: |
Master rollback segment: |
Status: | UNKNOWN
Refresh mode: | DEMAND
Rebuild: | YES
Rewrite enabled: | Y
Rewrite capability: | GENERAL
Build mode: | PREBUILT
Fast refreshable: | DIRLOAD_LIMITEDDML
Last refresh type: | NA
Staleness: | UNKNOWN
After fast refresh: | UNKNOWN
Compile state: | VALID
Last refresh: | 03.15.2007
Start with: |
Use no index: | N

Columns

Name | Type | Length | Nchar Length | Precision | Scale | NULL | Default | Description
WEEK_ENDING_DAY | DATE | 7 |  |  |  | N |  |
PROD_SUBCATEGORY | VARCHAR2 | 50 | 50 |  |  | N |  |
DOLLARS | NUMBER |  |  |  |  | Y |  |
CHANNEL_ID | NUMBER |  |  |  |  | N |  |
PROMO_ID | NUMBER |  |  |  |  | N |  |
Total: 5 column(s)

Indexes

Name | Type | Unique
FW_PSC_S_MV_CHAN_BIX | BITMAP | NONUNIQUE
FW_PSC_S_MV_PROMO_BIX | BITMAP | NONUNIQUE
FW_PSC_S_MV_SUBCAT_BIX | BITMAP | NONUNIQUE
FW_PSC_S_MV_WD_BIX | BITMAP | NONUNIQUE
Total: 4 indexes(s)

Query

SELECT t.week_ending_day
, p.prod_subcategory
, sum(s.amount_sold) AS dollars

DDL

See Also

List of snapshots


List of indexes

Indexes

Name | Type | Unique
FW_PSC_S_MV_CHAN_BIX | BITMAP | NONUNIQUE
FW_PSC_S_MV_PROMO_BIX | BITMAP | NONUNIQUE
FW_PSC_S_MV_SUBCAT_BIX | BITMAP | NONUNIQUE
FW_PSC_S_MV_WD_BIX | BITMAP | NONUNIQUE
Total: 4 index(s)

See Also

Snapshot [FWEEK_PSCAT_SALES_MV]


Index: FW_PSC_S_MV_CHAN_BIX on snapshot FWEEK_PSCAT_SALES_MV

Properties

Name: | FW_PSC_S_MV_CHAN_BIX
Type: | BITMAP
Unique: | NONUNIQUE
Tablespace: | EXAMPLE
Status: | VALID
Descend: |
Table owner: | SH
Table name: | FWEEK_PSCAT_SALES_MV
Temporary: | No
Join Index: | No
Initial extent size: | 65536
Secondary extent size: |
Min extents: | 1
Max extents: | 2147483645
Percent encrease: |
Distinct keys: | 4
Minimum free %: | 10

Index Columns

Name | Length | Descend
CHANNEL_ID | 22 | ASC
Total: 1 column(s)

DDL

CREATE BITMAP INDEX "SH"."FW_PSC_S_MV_CHAN_BIX" ON "SH"."FWEEK_PSCAT_SALES_MV" ("CHANNEL_ID")
PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING COMPUTE STATISTICS
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE"

See Also

List of indexes


Index: FW_PSC_S_MV_PROMO_BIX on snapshot FWEEK_PSCAT_SALES_MV

Properties

Name: | FW_PSC_S_MV_PROMO_BIX
Type: | BITMAP
Unique: | NONUNIQUE
Tablespace: | EXAMPLE
Status: | VALID
Descend: |
Table owner: | SH
Table name: | FWEEK_PSCAT_SALES_MV
Temporary: | No
Join Index: | No
Initial extent size: | 65536
Secondary extent size: |
Min extents: | 1
Max extents: | 2147483645
Percent encrease: |
Distinct keys: | 4
Minimum free %: | 10

Index Columns

Name | Length | Descend
PROMO_ID | 22 | ASC
Total: 1 column(s)

DDL

CREATE BITMAP INDEX "SH"."FW_PSC_S_MV_PROMO_BIX" ON "SH"."FWEEK_PSCAT_SALES_MV" ("PROMO_ID")
PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING COMPUTE STATISTICS
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE"

See Also

List of indexes


Index: FW_PSC_S_MV_SUBCAT_BIX on snapshot FWEEK_PSCAT_SALES_MV

Properties

Name: | FW_PSC_S_MV_SUBCAT_BIX
Type: | BITMAP
Unique: | NONUNIQUE
Tablespace: | EXAMPLE
Status: | VALID
Descend: |
Table owner: | SH
Table name: | FWEEK_PSCAT_SALES_MV
Temporary: | No
Join Index: | No
Initial extent size: | 65536
Secondary extent size: |
Min extents: | 1
Max extents: | 2147483645
Percent encrease: |
Distinct keys: | 21
Minimum free %: | 10

Index Columns

Name | Length | Descend
PROD_SUBCATEGORY | 50 | ASC
Total: 1 column(s)

DDL

CREATE BITMAP INDEX "SH"."FW_PSC_S_MV_SUBCAT_BIX" ON "SH"."FWEEK_PSCAT_SALES_MV" ("PROD_SUBCATEGORY")
PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING COMPUTE STATISTICS
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE"

See Also

List of indexes


Index: FW_PSC_S_MV_WD_BIX on snapshot FWEEK_PSCAT_SALES_MV

Properties

Name: | FW_PSC_S_MV_WD_BIX
Type: | BITMAP
Unique: | NONUNIQUE
Tablespace: | EXAMPLE
Status: | VALID
Descend: |
Table owner: | SH
Table name: | FWEEK_PSCAT_SALES_MV
Temporary: | No
Join Index: | No
Initial extent size: | 65536
Secondary extent size: |
Min extents: | 1
Max extents: | 2147483645
Percent encrease: |
Distinct keys: | 210
Minimum free %: | 10

Index Columns

Name | Length | Descend
WEEK_ENDING_DAY | 7 | ASC
Total: 1 column(s)

DDL

CREATE BITMAP INDEX "SH"."FW_PSC_S_MV_WD_BIX" ON "SH"."FWEEK_PSCAT_SALES_MV" ("WEEK_ENDING_DAY")
PCTFREE 10 INITRANS 2 MAXTRANS 255 NOLOGGING COMPUTE STATISTICS
STORAGE(INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645
PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT)
TABLESPACE "EXAMPLE"

See Also

List of indexes


List of measure folder

Measure folders

Name | Description | Parent | Catalog id
SH_CAT | Sample Schema: Sales History Business Area |  | 122
Total: 1 measure folder(s)

See Also

Schema overview


Measure folder: SH_CAT

Properties

Name: | SH_CAT
Description: | Sample Schema: Sales History Business Area
Parent: |
Catalog id: | 122

Cube measures

Owner | Name | Measure
SH | COST_CUBE | UNIT_PRICE
SH | SALES_CUBE | SALES_AMOUNT
SH | COST_CUBE | UNIT_COST
SH | SALES_CUBE | SALES_QUANTITY
Total: 4 cube measure(s)

See Also

List of measure folders


List of dimensions

Dimensions

Name | Valid | Plurar name | Display name | Description | Default display hierarchy | Dimension type
CHANNELS_DIM |  | Channels | Channel | Channel Values | CHANNEL_ROLLUP | HIER
CUSTOMERS_DIM |  | Customers | Customer | Customer Dimension Values | GEOG_ROLLUP | HIER
PRODUCTS_DIM |  | Products | Product | Product Dimension Values | PROD_ROLLUP | HIER
PROMOTIONS_DIM |  | Promotions | Promotions | Promotion Values | PROMO_ROLLUP | HIER
TIMES_DIM |  | Times | Time | Time Dimension Values | CAL_ROLLUP | HIER
Total: 5 dimension(s)

See Also

Schema overview


Dimension: CHANNELS_DIM

Properties

Name: | CHANNELS_DIM
Valid: |
Dimension type: | HIER
Plurar name: | Channels
Default display hierarchy: | CHANNEL_ROLLUP
Display name: | Channel
Description: | Channel Values

Levels

Name | Display name | Description | Owner | Table
CHANNEL | Channel | Channel level of the standard hierarchy | SH | CHANNELS
CHANNEL_CLASS | Channel Class | Channel Class level of the standard hierarchy | SH | CHANNELS
CHANNEL_TOTAL | Channel Total | Channel Total for the standard hierarchy | SH | CHANNELS
Total: 3 level(s)

Hierarchies

Name | Display name | Description | Solved code
CHANNEL_ROLLUP | Channels Hierarchy | Channels Hierarchy | UL
Total: 1 hierarchy(s)

Attributes

Name | Display name | Description
Long Description | Long Description of Channels | Long Description of Channels
Short Description | Short Description of Channels | Short Description of Channels
Total: 2 attribute(s)

DDL

CREATE DIMENSION "SH"."CHANNELS_DIM" LEVEL "CHANNEL" IS ("CHANNELS"."CHANNEL_ID") LEVEL "CHANNEL_CLASS" IS ("CHANNELS"."CHANNEL_CLASS_ID") LEVEL "CHANNEL_TOTAL" IS ("CHANNELS"."CHANNEL_TOTAL_ID") HIERARCHY "CHANNEL_ROLLUP" ("CHANNEL" CHILD OF "CHANNEL_CLASS" CHILD OF "CHANNEL_TOTAL") ATTRIBUTE "CHANNEL" LEVEL "CHANNEL" DETERMINES "CHANNELS"."CHANNEL_DESC" ATTRIBUTE "CHANNEL_CLASS" LEVEL "CHANNEL_CLASS" DETERMINES "CHANNELS"."CHANNEL_CLASS" ATTRIBUTE "CHANNEL_TOTAL" LEVEL "CHANNEL_TOTAL" DETERMINES "CHANNELS"."CHANNEL_TOTAL"

See Also

List of dimensions


List of attributes

Attributes

Long Description | Long Description of Channels | Long Description of Channels
Short Description | Short Description of Channels | Short Description of Channels
Total: 2 attribute(s)

See Also

Dimension [CHANNELS_DIM]


Attribute: Long Description in CHANNELS_DIM

Properties

Name: | Long Description
Display name: | Long Description of Channels
Description: | Long Description of Channels

Mappings

Hierarchy | Level | Attribute | Owner | Table | Column | Type
CHANNEL_ROLLUP | CHANNEL | CHANNEL_DESC | SH | CHANNELS | CHANNEL_DESC | VARCHAR2
Total: 1 mappings(s)

See Also

List of dimension attributes


Attribute: Short Description in CHANNELS_DIM

Properties

Name: | Short Description
Display name: | Short Description of Channels
Description: | Short Description of Channels

Mappings

Hierarchy | Level | Attribute | Owner | Table | Column | Type
CHANNEL_ROLLUP | CHANNEL | CHANNEL_DESC | SH | CHANNELS | CHANNEL_DESC | VARCHAR2
Total: 1 mappings(s)

See Also

List of dimension attributes


List of levels

Levels

Name | Display name | Description | Owner | Table
CHANNEL | Channel | Channel level of the standard hierarchy | SH | CHANNELS
CHANNEL_CLASS | Channel Class | Channel Class level of the standard hierarchy | SH | CHANNELS
CHANNEL_TOTAL | Channel Total | Channel Total for the standard hierarchy | SH | CHANNELS
Total: 3 level(s)

See Also

Dimension [CHANNELS_DIM]


Level: CHANNEL in CHANNELS_DIM

Properties

Name: | CHANNEL
Display name: | Channel
Table owner: | SH
Table name: | CHANNELS

Mappings

Hierarchy | Table owner | Table | Column
CHANNEL_ROLLUP | SH | CHANNELS | CHANNEL_ID
Total: 1 mappings(s)

Attributes

Name | Display name | Description
CHANNEL_DESC | Channel | Channel Description
Total: 1 attribute(s)

See Also

List of levels


List of attributes

Attribute

Name | Display name | Description
CHANNEL_DESC | Channel | Channel Description
Total: 1 attribute(s)

See Also

Level [CHANNEL]


Atribute: CHANNEL_DESC in CHANNEL

Properties

Name: | CHANNEL_DESC
Display name: | Channel
Description: | Channel Description

Mappings

Attribute | Hierarchy | Owner | Table | Column | Type
Long Description | CHANNEL_ROLLUP | SH | CHANNELS | CHANNEL_DESC | VARCHAR2
Short Description | CHANNEL_ROLLUP | SH | CHANNELS | CHANNEL_DESC | VARCHAR2
Total: 2 mappings(s)

See Also

List of attributes


Level: CHANNEL_CLASS in CHANNELS_DIM

Properties

Name: | CHANNEL_CLASS
Display name: | Channel Class
Table owner: | SH
Table name: | CHANNELS

Mappings

Hierarchy | Table owner | Table | Column
CHANNEL_ROLLUP | SH | CHANNELS | CHANNEL_CLASS_ID
Total: 1 mappings(s)

Attributes

Name | Display name | Description
CHANNEL_CLASS | Channel Class | Channel Class Identifier
Total: 1 attribute(s)

See Also

List of levels


List of attributes

Attribute

Name | Display name | Description
CHANNEL_CLASS | Channel Class | Channel Class Identifier
Total: 1 attribute(s)

See Also

Level [CHANNEL_CLASS]


Atribute: CHANNEL_CLASS in CHANNEL_CLASS

Properties

Name: | CHANNEL_CLASS
Display name: | Channel Class
Description: | Channel Class Identifier

See Also

List of attributes


Level: CHANNEL_TOTAL in CHANNELS_DIM

Properties

Name: | CHANNEL_TOTAL
Display name: | Channel Total
Table owner: | SH
Table name: | CHANNELS

Mappings

Hierarchy | Table owner | Table | Column
CHANNEL_ROLLUP | SH | CHANNELS | CHANNEL_TOTAL_ID
Total: 1 mappings(s)

Attributes

Name | Display name | Description
CHANNEL_TOTAL | Channel Total | Channel Total
Total: 1 attribute(s)

See Also

List of levels


List of attributes

Attribute

Name | Display name | Description
CHANNEL_TOTAL | Channel Total | Channel Total
Total: 1 attribute(s)

See Also

Level [CHANNEL_TOTAL]


Atribute: CHANNEL_TOTAL in CHANNEL_TOTAL

Properties

Name: | CHANNEL_TOTAL
Display name: | Channel Total
Description: | Channel Total

See Also

List of attributes


List of hierarchies

Hierarchies

Name | Display name | Description | Solved code
CHANNEL_ROLLUP | Channels Hierarchy | Channels Hierarchy | UL
Total: 1 hierarchy(s)

See Also

Dimension [CHANNELS_DIM]


Hierarchy: CHANNEL_ROLLUP in CHANNELS_DIM

Properties

Name: | CHANNEL_ROLLUP
Display name: | Channels Hierarchy
Description: | Channels Hierarchy
Solved code: | UL

Levels

Name | Column | Parent level | Parent column
CHANNEL | SH.CHANNELS.CHANNEL_ID | CHANNEL_CLASS | SH.CHANNELS.CHANNEL_CLASS_ID
CHANNEL_CLASS | SH.CHANNELS.CHANNEL_CLASS_ID | CHANNEL_TOTAL | SH.CHANNELS.CHANNEL_TOTAL_ID
CHANNEL_TOTAL | SH.CHANNELS.CHANNEL_TOTAL_ID |  |
Total: 3 level(s)

See Also

List of hierarchies


Dimension: CUSTOMERS_DIM

Properties

Name: | CUSTOMERS_DIM
Valid: |
Dimension type: | HIER
Plurar name: | Customers
Default display hierarchy: | GEOG_ROLLUP
Display name: | Customer
Description: | Customer Dimension Values

Levels

Name | Display name | Description | Owner | Table
CITY | City | City level of the standard CUSTOMER hierarchy | SH | CUSTOMERS
COUNTRY | Country | Country level of the standard CUSTOMER hierarchy | SH | COUNTRIES
CUSTOMER | Customer | Customer level of standard CUSTOMER hierarchy | SH | CUSTOMERS
CUST_TOTAL | Customer Total | Customer Total for the standard CUSTOMER hierarchy | SH | CUSTOMERS
GEOG_TOTAL | Geography Total | Geography Total for the standard CUSTOMER hierarchy | SH | COUNTRIES
REGION | Region | Region level of the standard CUSTOMER hierarchy | SH | COUNTRIES
STATE | State | State level of the standard CUSTOMER hierarchy | SH | CUSTOMERS
SUBREGION | Subregion | Subregion level of the standard CUSTOMER hierarchy | SH | COUNTRIES
Total: 8 level(s)

Hierarchies

Name | Display name | Description | Solved code
CUST_ROLLUP | CUSTOMER hierarchy | CUSTOMER hierarchy | UL
GEOG_ROLLUP | GEOGRAPHY hierarchy | GEOGRAPHY hierarchy | UL
Total: 2 hierarchy(s)

Attributes

Name | Display name | Description
Credit Limit | Credit Limit | Credit Limit
Email | Email | Email
First Name | First Name | First Name
Gender | Gender | Gender
Income Level | Income Level | Income Level
Last Name | Last Name | Last Name
Long Description | Customer Information | Long Description of Customer Information
Marital Status | Marital Status | Marital Status
Phone Number | Phone Number | Phone Number
Postal Code | Postal Code | Postal Code
Short Description | Customer Information | Short Description of Customer Information
Street Address | Street Address | Street Address
Year of Birth | Year of Birth | Year of Birth
Total: 13 attribute(s)

DDL

CREATE DIMENSION "SH"."CUSTOMERS_DIM" LEVEL "CUSTOMER" IS ("CUSTOMERS"."CUST_ID") LEVEL "CITY" IS ("CUSTOMERS"."CUST_CITY_ID") LEVEL "STATE" IS ("CUSTOMERS"."CUST_STATE_PROVINCE_ID") LEVEL "COUNTRY" IS ("COUNTRIES"."COUNTRY_ID") LEVEL "SUBREGION" IS ("COUNTRIES"."COUNTRY_SUBREGION_ID") LEVEL "REGION" IS ("COUNTRIES"."COUNTRY_REGION_ID") LEVEL "GEOG_TOTAL" IS ("COUNTRIES"."COUNTRY_TOTAL_ID") LEVEL "CUST_TOTAL" IS ("CUSTOMERS"."CUST_TOTAL_ID") HIERARCHY "CUST_ROLLUP" ("CUSTOMER" CHILD OF "CITY" CHILD OF "STATE" CHILD OF "CUST_TOTAL") HIERARCHY "GEOG_ROLLUP" ("CUSTOMER" CHILD OF "CITY" CHILD OF "STATE" CHILD OF "COUNTRY" CHILD OF "SUBREGION" CHILD OF "REGION" CHILD OF "GEOG_TOTAL" JOIN KEY ("CUSTOMERS"."COUNTRY_ID") REFERENCES "COUNTRY") ATTRIBUTE "CUSTOMER" LEVEL "CUSTOMER" DETERMINES "CUSTOMERS"."CUST_FIRST_NAME" ATTRIBUTE "CUSTOMER" LEVEL "CUSTOMER" DETERMINES "CUSTOMERS"."CUST_EMAIL" ATTRIBUTE "CUSTOMER" LEVEL "CUSTOMER" DETERMINES "CUSTOMERS"."CUST_MAIN_PHONE_NUMBER" ATTRIBUTE "CUSTOMER" LEVEL "CUSTOMER" DETERMINES "CUSTOMERS"."CUST_POSTAL_CODE" ATTRIBUTE "CUSTOMER" LEVEL "CUSTOMER" DETERMINES "CUSTOMERS"."CUST_STREET_ADDRESS" ATTRIBUTE "CUSTOMER" LEVEL "CUSTOMER" DETERMINES "CUSTOMERS"."CUST_CREDIT_LIMIT" ATTRIBUTE "CUSTOMER" LEVEL "CUSTOMER" DETERMINES "CUSTOMERS"."CUST_INCOME_LEVEL" ATTRIBUTE "CUSTOMER" LEVEL "CUSTOMER" DETERMINES "CUSTOMERS"."CUST_YEAR_OF_BIRTH" ATTRIBUTE "CUSTOMER" LEVEL "CUSTOMER" DETERMINES "CUSTOMERS"."CUST_MARITAL_STATUS" ATTRIBUTE "CUSTOMER" LEVEL "CUSTOMER" DETERMINES "CUSTOMERS"."CUST_GENDER" ATTRIBUTE "CUSTOMER" LEVEL "CUSTOMER" DETERMINES "CUSTOMERS"."CUST_LAST_NAME" ATTRIBUTE "CITY" LEVEL "CITY" DETERMINES "CUSTOMERS"."CUST_CITY" ATTRIBUTE "STATE" LEVEL "STATE" DETERMINES "CUSTOMERS"."CUST_STATE_PROVINCE" ATTRIBUTE "COUNTRY" LEVEL "COUNTRY" DETERMINES "COUNTRIES"."COUNTRY_NAME" ATTRIBUTE "COUNTRY" LEVEL "COUNTRY" DETERMINES "COUNTRIES"."COUNTRY_ISO_CODE" ATTRIBUTE "SUBREGION" LEVEL "SUBREGION" DETERMINES "COUNTRIES"."COUNTRY_SUBREGION" ATTRIBUTE "REGION" LEVEL "REGION" DETERMINES "COUNTRIES"."COUNTRY_REGION" ATTRIBUTE "GEOG_TOTAL" LEVEL "GEOG_TOTAL" DETERMINES "COUNTRIES"."COUNTRY_TOTAL" ATTRIBUTE "CUST_TOTAL" LEVEL "CUST_TOTAL" DETERMINES "CUSTOMERS"."CUST_TOTAL"

See Also

List of dimensions


List of attributes

Attributes

Credit Limit | Credit Limit | Credit Limit
Email | Email | Email
First Name | First Name | First Name
Gender | Gender | Gender
Income Level | Income Level | Income Level
Last Name | Last Name | Last Name
Long Description | Customer Information | Long Description of Customer Information
Marital Status | Marital Status | Marital Status
Phone Number | Phone Number | Phone Number
Postal Code | Postal Code | Postal Code
Short Description | Customer Information | Short Description of Customer Information
Street Address | Street Address | Street Address
Year of Birth | Year of Birth | Year of Birth
Total: 13 attribute(s)

See Also

Dimension [CUSTOMERS_DIM]


Attribute: Credit Limit in CUSTOMERS_DIM

Properties

Name: | Credit Limit
Display name: | Credit Limit
Description: | Credit Limit

Mappings

Hierarchy | Level | Attribute | Owner | Table | Column | Type
CUST_ROLLUP | CUSTOMER | CUST_CREDIT_LIMIT | SH | CUSTOMERS | CUST_CREDIT_LIMIT | NUMBER
GEOG_ROLLUP | CUSTOMER | CUST_CREDIT_LIMIT | SH | CUSTOMERS | CUST_CREDIT_LIMIT | NUMBER
Total: 2 mappings(s)

See Also

List of dimension attributes


Attribute: Email in CUSTOMERS_DIM

Properties

Name: | Email
Display name: | Email
Description: | Email

Mappings

Hierarchy | Level | Attribute | Owner | Table | Column | Type
CUST_ROLLUP | CUSTOMER | CUST_EMAIL | SH | CUSTOMERS | CUST_EMAIL | VARCHAR2
GEOG_ROLLUP | CUSTOMER | CUST_EMAIL | SH | CUSTOMERS | CUST_EMAIL | VARCHAR2
Total: 2 mappings(s)

See Also

List of dimension attributes


Attribute: First Name in CUSTOMERS_DIM

Properties

Name: | First Name
Display name: | First Name
Description: | First Name

Mappings

Hierarchy | Level | Attribute | Owner | Table | Column | Type
CUST_ROLLUP | CUSTOMER | CUST_FIRST_NAME | SH | CUSTOMERS | CUST_FIRST_NAME | VARCHAR2
GEOG_ROLLUP | CUSTOMER | CUST_FIRST_NAME | SH | CUSTOMERS | CUST_FIRST_NAME | VARCHAR2
Total: 2 mappings(s)

See Also

List of dimension attributes


Attribute: Gender in CUSTOMERS_DIM

Properties

Name: | Gender
Display name: | Gender
Description: | Gender

Mappings

Hierarchy | Level | Attribute | Owner | Table | Column | Type
CUST_ROLLUP | CUSTOMER | CUST_GENDER | SH | CUSTOMERS | CUST_GENDER | CHAR
GEOG_ROLLUP | CUSTOMER | CUST_GENDER | SH | CUSTOMERS | CUST_GENDER | CHAR
Total: 2 mappings(s)

See Also

List of dimension attributes


Attribute: Income Level in CUSTOMERS_DIM

Properties

Name: | Income Level
Display name: | Income Level
Description: | Income Level

Mappings

Hierarchy | Level | Attribute | Owner | Table | Column | Type
CUST_ROLLUP | CUSTOMER | CUST_INCOME_LEVEL | SH | CUSTOMERS | CUST_INCOME_LEVEL | VARCHAR2
GEOG_ROLLUP | CUSTOMER | CUST_INCOME_LEVEL | SH | CUSTOMERS | CUST_INCOME_LEVEL | VARCHAR2
Total: 2 mappings(s)

See Also

List of dimension attributes


Attribute: Last Name in CUSTOMERS_DIM

Properties

Name: | Last Name
Display name: | Last Name
Description: | Last Name

Mappings

Hierarchy | Level | Attribute | Owner | Table | Column | Type
CUST_ROLLUP | CUSTOMER | CUST_LAST_NAME | SH | CUSTOMERS | CUST_LAST_NAME | VARCHAR2
GEOG_ROLLUP | CUSTOMER | CUST_LAST_NAME | SH | CUSTOMERS | CUST_LAST_NAME | VARCHAR2
Total: 2 mappings(s)

See Also

List of dimension attributes


Attribute: Long Description in CUSTOMERS_DIM

Properties

Name: | Long Description
Display name: | Customer Information
Description: | Long Description of Customer Information

Mappings

Hierarchy | Level | Attribute | Owner | Table | Column | Type
CUST_ROLLUP | CITY | CUST_CITY | SH | CUSTOMERS | CUST_CITY | VARCHAR2
CUST_ROLLUP | CUSTOMER | CUST_LAST_NAME | SH | CUSTOMERS | CUST_LAST_NAME | VARCHAR2
CUST_ROLLUP | STATE | CUST_STATE_PROVINCE | SH | CUSTOMERS | CUST_STATE_PROVINCE | VARCHAR2
GEOG_ROLLUP | COUNTRY | COUNTRY_NAME | SH | COUNTRIES | COUNTRY_NAME | VARCHAR2
GEOG_ROLLUP | REGION | COUNTRY_REGION | SH | COUNTRIES | COUNTRY_REGION | VARCHAR2
GEOG_ROLLUP | SUBREGION | COUNTRY_SUBREGION | SH | COUNTRIES | COUNTRY_SUBREGION | VARCHAR2
GEOG_ROLLUP | CITY | CUST_CITY | SH | CUSTOMERS | CUST_CITY | VARCHAR2
GEOG_ROLLUP | CUSTOMER | CUST_LAST_NAME | SH | CUSTOMERS | CUST_LAST_NAME | VARCHAR2
GEOG_ROLLUP | STATE | CUST_STATE_PROVINCE | SH | CUSTOMERS | CUST_STATE_PROVINCE | VARCHAR2
Total: 9 mappings(s)

See Also

List of dimension attributes


Attribute: Marital Status in CUSTOMERS_DIM

Properties

Name: | Marital Status
Display name: | Marital Status
Description: | Marital Status

Mappings

Hierarchy | Level | Attribute | Owner | Table | Column | Type
CUST_ROLLUP | CUSTOMER | CUST_MARITAL_STATUS | SH | CUSTOMERS | CUST_MARITAL_STATUS | VARCHAR2
GEOG_ROLLUP | CUSTOMER | CUST_MARITAL_STATUS | SH | CUSTOMERS | CUST_MARITAL_STATUS | VARCHAR2
Total: 2 mappings(s)

See Also

List of dimension attributes


Attribute: Phone Number in CUSTOMERS_DIM

Properties

Name: | Phone Number
Display name: | Phone Number
Description: | Phone Number

Mappings

Hierarchy | Level | Attribute | Owner | Table | Column | Type
CUST_ROLLUP | CUSTOMER | CUST_MAIN_PHONE_NUMBER | SH | CUSTOMERS | CUST_MAIN_PHONE_NUMBER | VARCHAR2
GEOG_ROLLUP | CUSTOMER | CUST_MAIN_PHONE_NUMBER | SH | CUSTOMERS | CUST_MAIN_PHONE_NUMBER | VARCHAR2
Total: 2 mappings(s)

See Also

List of dimension attributes


Attribute: Postal Code in CUSTOMERS_DIM

Properties

Name: | Postal Code
Display name: | Postal Code
Description: | Postal Code

Mappings

Hierarchy | Level | Attribute | Owner | Table | Column | Type
CUST_ROLLUP | CUSTOMER | CUST_POSTAL_CODE | SH | CUSTOMERS | CUST_POSTAL_CODE | VARCHAR2
GEOG_ROLLUP | CUSTOMER | CUST_POSTAL_CODE | SH | CUSTOMERS | CUST_POSTAL_CODE | VARCHAR2
Total: 2 mappings(s)

See Also

List of dimension attributes


Attribute: Short Description in CUSTOMERS_DIM

Properties

Name: | Short Description
Display name: | Customer Information
Description: | Short Description of Customer Information

Mappings

Hierarchy | Level | Attribute | Owner | Table | Column | Type
CUST_ROLLUP | CITY | CUST_CITY | SH | CUSTOMERS | CUST_CITY | VARCHAR2
CUST_ROLLUP | CUSTOMER | CUST_LAST_NAME | SH | CUSTOMERS | CUST_LAST_NAME | VARCHAR2
CUST_ROLLUP | STATE | CUST_STATE_PROVINCE | SH | CUSTOMERS | CUST_STATE_PROVINCE | VARCHAR2
GEOG_ROLLUP | COUNTRY | COUNTRY_NAME | SH | COUNTRIES | COUNTRY_NAME | VARCHAR2
GEOG_ROLLUP | REGION | COUNTRY_REGION | SH | COUNTRIES | COUNTRY_REGION | VARCHAR2
GEOG_ROLLUP | SUBREGION | COUNTRY_SUBREGION | SH | COUNTRIES | COUNTRY_SUBREGION | VARCHAR2
GEOG_ROLLUP | CITY | CUST_CITY | SH | CUSTOMERS | CUST_CITY | VARCHAR2
GEOG_ROLLUP | CUSTOMER | CUST_LAST_NAME | SH | CUSTOMERS | CUST_LAST_NAME | VARCHAR2
GEOG_ROLLUP | STATE | CUST_STATE_PROVINCE | SH | CUSTOMERS | CUST_STATE_PROVINCE | VARCHAR2
Total: 9 mappings(s)

See Also

List of dimension attributes


Attribute: Street Address in CUSTOMERS_DIM

Properties

Name: | Street Address
Display name: | Street Address
Description: | Street Address

Mappings

Hierarchy | Level | Attribute | Owner | Table | Column | Type
CUST_ROLLUP | CUSTOMER | CUST_STREET_ADDRESS | SH | CUSTOMERS | CUST_STREET_ADDRESS | VARCHAR2
GEOG_ROLLUP | CUSTOMER | CUST_STREET_ADDRESS | SH | CUSTOMERS | CUST_STREET_ADDRESS | VARCHAR2
Total: 2 mappings(s)

See Also

List of dimension attributes


Attribute: Year of Birth in CUSTOMERS_DIM

Properties

Name: | Year of Birth
Display name: | Year of Birth
Description: | Year of Birth

Mappings

Hierarchy | Level | Attribute | Owner | Table | Column | Type
CUST_ROLLUP | CUSTOMER | CUST_YEAR_OF_BIRTH | SH | CUSTOMERS | CUST_YEAR_OF_BIRTH | NUMBER
GEOG_ROLLUP | CUSTOMER | CUST_YEAR_OF_BIRTH | SH | CUSTOMERS | CUST_YEAR_OF_BIRTH | NUMBER
Total: 2 mappings(s)

See Also

List of dimension attributes


List of levels

Levels

Name | Display name | Description | Owner | Table
CITY | City | City level of the standard CUSTOMER hierarchy | SH | CUSTOMERS
COUNTRY | Country | Country level of the standard CUSTOMER hierarchy | SH | COUNTRIES
CUSTOMER | Customer | Customer level of standard CUSTOMER hierarchy | SH | CUSTOMERS
CUST_TOTAL | Customer Total | Customer Total for the standard CUSTOMER hierarchy | SH | CUSTOMERS
GEOG_TOTAL | Geography Total | Geography Total for the standard CUSTOMER hierarchy | SH | COUNTRIES
REGION | Region | Region level of the standard CUSTOMER hierarchy | SH | COUNTRIES
STATE | State | State level of the standard CUSTOMER hierarchy | SH | CUSTOMERS
SUBREGION | Subregion | Subregion level of the standard CUSTOMER hierarchy | SH | COUNTRIES
Total: 8 level(s)

See Also

Dimension [CUSTOMERS_DIM]


Level: CITY in CUSTOMERS_DIM

Properties

Name: | CITY
Display name: | City
Table owner: | SH
Table name: | CUSTOMERS

Mappings

Hierarchy | Table owner | Table | Column
CUST_ROLLUP | SH | CUSTOMERS | CUST_CITY_ID
GEOG_ROLLUP | SH | CUSTOMERS | CUST_CITY_ID
Total: 2 mappings(s)

Attributes

Name | Display name | Description
CUST_CITY | City | City Name
Total: 1 attribute(s)

See Also

List of levels


List of attributes

Attribute

Name | Display name | Description
CUST_CITY | City | City Name
Total: 1 attribute(s)

See Also

Level [CITY]


Atribute: CUST_CITY in CITY

Properties

Name: | CUST_CITY
Display name: | City
Description: | City Name

Mappings

Attribute | Hierarchy | Owner | Table | Column | Type
Long Description | CUST_ROLLUP | SH | CUSTOMERS | CUST_CITY | VARCHAR2
Short Description | CUST_ROLLUP | SH | CUSTOMERS | CUST_CITY | VARCHAR2
Long Description | GEOG_ROLLUP | SH | CUSTOMERS | CUST_CITY | VARCHAR2
Short Description | GEOG_ROLLUP | SH | CUSTOMERS | CUST_CITY | VARCHAR2
Total: 4 mappings(s)

See Also

List of attributes


Level: COUNTRY in CUSTOMERS_DIM

Properties

Name: | COUNTRY
Display name: | Country
Table owner: | SH
Table name: | COUNTRIES

Mappings

Hierarchy | Table owner | Table | Column
GEOG_ROLLUP | SH | COUNTRIES | COUNTRY_ID
Total: 1 mappings(s)

Attributes

Name | Display name | Description
COUNTRY_NAME | Country Name | Country Name
Total: 1 attribute(s)

See Also

List of levels


List of attributes

Attribute

Name | Display name | Description
COUNTRY_NAME | Country Name | Country Name
Total: 1 attribute(s)

See Also

Level [COUNTRY]


Atribute: COUNTRY_NAME in COUNTRY

Properties

Name: | COUNTRY_NAME
Display name: | Country Name
Description: | Country Name

Mappings

Attribute | Hierarchy | Owner | Table | Column | Type
Long Description | GEOG_ROLLUP | SH | COUNTRIES | COUNTRY_NAME | VARCHAR2
Short Description | GEOG_ROLLUP | SH | COUNTRIES | COUNTRY_NAME | VARCHAR2
Total: 2 mappings(s)

See Also

List of attributes


Level: CUSTOMER in CUSTOMERS_DIM

Properties

Name: | CUSTOMER
Display name: | Customer
Table owner: | SH
Table name: | CUSTOMERS

Mappings

Hierarchy | Table owner | Table | Column
CUST_ROLLUP | SH | CUSTOMERS | CUST_ID
GEOG_ROLLUP | SH | CUSTOMERS | CUST_ID
Total: 2 mappings(s)

Attributes

Name | Display name | Description
CUST_CREDIT_LIMIT | Credit Limit | Customer Credit Limit
CUST_EMAIL | Email | Customer Email
CUST_FIRST_NAME | First Name | Customer First Name
CUST_GENDER | Gender | Customer Gender
CUST_INCOME_LEVEL | Income Level | Customer Income Level
CUST_LAST_NAME | Last Name | Customer Last Name
CUST_MAIN_PHONE_NUMBER | Main Phone Number | Customer Main Phone Number
CUST_MARITAL_STATUS | Marital Status | Customer Marital Status
CUST_POSTAL_CODE | Postal Code | Customer Postal Code
CUST_STREET_ADDRESS | Street Address | Customer Street Address
CUST_YEAR_OF_BIRTH | Year of Birth | Customer Year of Birth
Total: 11 attribute(s)

See Also

List of levels


List of attributes

Attribute

Name | Display name | Description
CUST_CREDIT_LIMIT | Credit Limit | Customer Credit Limit
CUST_EMAIL | Email | Customer Email
CUST_FIRST_NAME | First Name | Customer First Name
CUST_GENDER | Gender | Customer Gender
CUST_INCOME_LEVEL | Income Level | Customer Income Level
CUST_LAST_NAME | Last Name | Customer Last Name
CUST_MAIN_PHONE_NUMBER | Main Phone Number | Customer Main Phone Number
CUST_MARITAL_STATUS | Marital Status | Customer Marital Status
CUST_POSTAL_CODE | Postal Code | Customer Postal Code
CUST_STREET_ADDRESS | Street Address | Customer Street Address
CUST_YEAR_OF_BIRTH | Year of Birth | Customer Year of Birth
Total: 11 attribute(s)

See Also

Level [CUSTOMER]


Atribute: CUST_CREDIT_LIMIT in CUSTOMER

Properties

Name: | CUST_CREDIT_LIMIT
Display name: | Credit Limit
Description: | Customer Credit Limit

Mappings

Attribute | Hierarchy | Owner | Table | Column | Type
Credit Limit | CUST_ROLLUP | SH | CUSTOMERS | CUST_CREDIT_LIMIT | NUMBER
Credit Limit | GEOG_ROLLUP | SH | CUSTOMERS | CUST_CREDIT_LIMIT | NUMBER
Total: 2 mappings(s)

See Also

List of attributes


Atribute: CUST_EMAIL in CUSTOMER

Properties

Name: | CUST_EMAIL
Display name: | Email
Description: | Customer Email

Mappings

Attribute | Hierarchy | Owner | Table | Column | Type
Email | CUST_ROLLUP | SH | CUSTOMERS | CUST_EMAIL | VARCHAR2
Email | GEOG_ROLLUP | SH | CUSTOMERS | CUST_EMAIL | VARCHAR2
Total: 2 mappings(s)

See Also

List of attributes


Atribute: CUST_FIRST_NAME in CUSTOMER

Properties

Name: | CUST_FIRST_NAME
Display name: | First Name
Description: | Customer First Name

Mappings

Attribute | Hierarchy | Owner | Table | Column | Type
First Name | CUST_ROLLUP | SH | CUSTOMERS | CUST_FIRST_NAME | VARCHAR2
First Name | GEOG_ROLLUP | SH | CUSTOMERS | CUST_FIRST_NAME | VARCHAR2
Total: 2 mappings(s)

See Also

List of attributes


Atribute: CUST_GENDER in CUSTOMER

Properties

Name: | CUST_GENDER
Display name: | Gender
Description: | Customer Gender

Mappings

Attribute | Hierarchy | Owner | Table | Column | Type
Gender | CUST_ROLLUP | SH | CUSTOMERS | CUST_GENDER | CHAR
Gender | GEOG_ROLLUP | SH | CUSTOMERS | CUST_GENDER | CHAR
Total: 2 mappings(s)

See Also

List of attributes


Atribute: CUST_INCOME_LEVEL in CUSTOMER

Properties

Name: | CUST_INCOME_LEVEL
Display name: | Income Level
Description: | Customer Income Level

Mappings

Attribute | Hierarchy | Owner | Table | Column | Type
Income Level | CUST_ROLLUP | SH | CUSTOMERS | CUST_INCOME_LEVEL | VARCHAR2
Income Level | GEOG_ROLLUP | SH | CUSTOMERS | CUST_INCOME_LEVEL | VARCHAR2
Total: 2 mappings(s)

See Also

List of attributes


Atribute: CUST_LAST_NAME in CUSTOMER

Properties

Name: | CUST_LAST_NAME
Display name: | Last Name
Description: | Customer Last Name

Mappings

Attribute | Hierarchy | Owner | Table | Column | Type
Last Name | CUST_ROLLUP | SH | CUSTOMERS | CUST_LAST_NAME | VARCHAR2
Long Description | CUST_ROLLUP | SH | CUSTOMERS | CUST_LAST_NAME | VARCHAR2
Short Description | CUST_ROLLUP | SH | CUSTOMERS | CUST_LAST_NAME | VARCHAR2
Last Name | GEOG_ROLLUP | SH | CUSTOMERS | CUST_LAST_NAME | VARCHAR2
Long Description | GEOG_ROLLUP | SH | CUSTOMERS | CUST_LAST_NAME | VARCHAR2
Short Description | GEOG_ROLLUP | SH | CUSTOMERS | CUST_LAST_NAME | VARCHAR2
Total: 6 mappings(s)

See Also

List of attributes


Atribute: CUST_MAIN_PHONE_NUMBER in CUSTOMER

Properties

Name: | CUST_MAIN_PHONE_NUMBER
Display name: | Main Phone Number
Description: | Customer Main Phone Number

Mappings

Attribute | Hierarchy | Owner | Table | Column | Type
Phone Number | CUST_ROLLUP | SH | CUSTOMERS | CUST_MAIN_PHONE_NUMBER | VARCHAR2
Phone Number | GEOG_ROLLUP | SH | CUSTOMERS | CUST_MAIN_PHONE_NUMBER | VARCHAR2
Total: 2 mappings(s)

See Also

List of attributes


Atribute: CUST_MARITAL_STATUS in CUSTOMER

Properties

Name: | CUST_MARITAL_STATUS
Display name: | Marital Status
Description: | Customer Marital Status

Mappings

Attribute | Hierarchy | Owner | Table | Column | Type
Marital Status | CUST_ROLLUP | SH | CUSTOMERS | CUST_MARITAL_STATUS | VARCHAR2
Marital Status | GEOG_ROLLUP | SH | CUSTOMERS | CUST_MARITAL_STATUS | VARCHAR2
Total: 2 mappings(s)

See Also

List of attributes


Atribute: CUST_POSTAL_CODE in CUSTOMER

Properties

Name: | CUST_POSTAL_CODE
Display name: | Postal Code
Description: | Customer Postal Code

Mappings

Attribute | Hierarchy | Owner | Table | Column | Type
Postal Code | CUST_ROLLUP | SH | CUSTOMERS | CUST_POSTAL_CODE | VARCHAR2
Postal Code | GEOG_ROLLUP | SH | CUSTOMERS | CUST_POSTAL_CODE | VARCHAR2
Total: 2 mappings(s)

See Also

List of attributes


Atribute: CUST_STREET_ADDRESS in CUSTOMER

Properties

Name: | CUST_STREET_ADDRESS
Display name: | Street Address
Description: | Customer Street Address

Mappings

Attribute | Hierarchy | Owner | Table | Column | Type
Street Address | CUST_ROLLUP | SH | CUSTOMERS | CUST_STREET_ADDRESS | VARCHAR2
Street Address | GEOG_ROLLUP | SH | CUSTOMERS | CUST_STREET_ADDRESS | VARCHAR2
Total: 2 mappings(s)

See Also

List of attributes


Atribute: CUST_YEAR_OF_BIRTH in CUSTOMER

Properties

Name: | CUST_YEAR_OF_BIRTH
Display name: | Year of Birth
Description: | Customer Year of Birth

Mappings

Attribute | Hierarchy | Owner | Table | Column | Type
Year of Birth | CUST_ROLLUP | SH | CUSTOMERS | CUST_YEAR_OF_BIRTH | NUMBER
Year of Birth | GEOG_ROLLUP | SH | CUSTOMERS | CUST_YEAR_OF_BIRTH | NUMBER
Total: 2 mappings(s)

See Also

List of attributes


Level: CUST_TOTAL in CUSTOMERS_DIM

Properties

Name: | CUST_TOTAL
Display name: | Customer Total
Table owner: | SH
Table name: | CUSTOMERS

Mappings

Hierarchy | Table owner | Table | Column
CUST_ROLLUP | SH | CUSTOMERS | CUST_TOTAL_ID
Total: 1 mappings(s)

Attributes

Name | Display name | Description
CUST_TOTAL | Customer Total | Customer Total
Total: 1 attribute(s)

See Also

List of levels


List of attributes

Attribute

Name | Display name | Description
CUST_TOTAL | Customer Total | Customer Total
Total: 1 attribute(s)

See Also

Level [CUST_TOTAL]


Atribute: CUST_TOTAL in CUST_TOTAL

Properties

Name: | CUST_TOTAL
Display name: | Customer Total
Description: | Customer Total

See Also

List of attributes


Level: GEOG_TOTAL in CUSTOMERS_DIM

Properties

Name: | GEOG_TOTAL
Display name: | Geography Total
Table owner: | SH
Table name: | COUNTRIES

Mappings

Hierarchy | Table owner | Table | Column
GEOG_ROLLUP | SH | COUNTRIES | COUNTRY_TOTAL_ID
Total: 1 mappings(s)

Attributes

Name | Display name | Description
COUNTRY_TOTAL | Country Total | Country Total
Total: 1 attribute(s)

See Also

List of levels


List of attributes

Attribute

Name | Display name | Description
COUNTRY_TOTAL | Country Total | Country Total
Total: 1 attribute(s)

See Also

Level [GEOG_TOTAL]


Atribute: COUNTRY_TOTAL in GEOG_TOTAL

Properties

Name: | COUNTRY_TOTAL
Display name: | Country Total
Description: | Country Total

See Also

List of attributes


Level: REGION in CUSTOMERS_DIM

Properties

Name: | REGION
Display name: | Region
Table owner: | SH
Table name: | COUNTRIES

Mappings

Hierarchy | Table owner | Table | Column
GEOG_ROLLUP | SH | COUNTRIES | COUNTRY_REGION_ID
Total: 1 mappings(s)

Attributes

Name | Display name | Description
COUNTRY_REGION | Region | Region Name
Total: 1 attribute(s)

See Also

List of levels


List of attributes

Attribute

Name | Display name | Description
COUNTRY_REGION | Region | Region Name
Total: 1 attribute(s)

See Also

Level [REGION]


Atribute: COUNTRY_REGION in REGION

Properties

Name: | COUNTRY_REGION
Display name: | Region
Description: | Region Name

Mappings

Attribute | Hierarchy | Owner | Table | Column | Type
Long Description | GEOG_ROLLUP | SH | COUNTRIES | COUNTRY_REGION | VARCHAR2
Short Description | GEOG_ROLLUP | SH | COUNTRIES | COUNTRY_REGION | VARCHAR2
Total: 2 mappings(s)

See Also

List of attributes


Level: STATE in CUSTOMERS_DIM

Properties

Name: | STATE
Display name: | State
Table owner: | SH
Table name: | CUSTOMERS

Mappings

Hierarchy | Table owner | Table | Column
CUST_ROLLUP | SH | CUSTOMERS | CUST_STATE_PROVINCE_ID
GEOG_ROLLUP | SH | CUSTOMERS | CUST_STATE_PROVINCE_ID
Total: 2 mappings(s)

Attributes

Name | Display name | Description
CUST_STATE_PROVINCE | State/Province | State/Province Name
Total: 1 attribute(s)

See Also

List of levels


List of attributes

Attribute

Name | Display name | Description
CUST_STATE_PROVINCE | State/Province | State/Province Name
Total: 1 attribute(s)

See Also

Level [STATE]


Atribute: CUST_STATE_PROVINCE in STATE

Properties

Name: | CUST_STATE_PROVINCE
Display name: | State/Province
Description: | State/Province Name

Mappings

Attribute | Hierarchy | Owner | Table | Column | Type
Long Description | CUST_ROLLUP | SH | CUSTOMERS | CUST_STATE_PROVINCE | VARCHAR2
Short Description | CUST_ROLLUP | SH | CUSTOMERS | CUST_STATE_PROVINCE | VARCHAR2
Long Description | GEOG_ROLLUP | SH | CUSTOMERS | CUST_STATE_PROVINCE | VARCHAR2
Short Description | GEOG_ROLLUP | SH | CUSTOMERS | CUST_STATE_PROVINCE | VARCHAR2
Total: 4 mappings(s)

See Also

List of attributes


Level: SUBREGION in CUSTOMERS_DIM

Properties

Name: | SUBREGION
Display name: | Subregion
Table owner: | SH
Table name: | COUNTRIES

Mappings

Hierarchy | Table owner | Table | Column
GEOG_ROLLUP | SH | COUNTRIES | COUNTRY_SUBREGION_ID
Total: 1 mappings(s)

Attributes

Name | Display name | Description
COUNTRY_SUBREGION | Subregion | Subregion Name
Total: 1 attribute(s)

See Also

List of levels


List of attributes

Attribute

Name | Display name | Description
COUNTRY_SUBREGION | Subregion | Subregion Name
Total: 1 attribute(s)

See Also

Level [SUBREGION]


Atribute: COUNTRY_SUBREGION in SUBREGION

Properties

Name: | COUNTRY_SUBREGION
Display name: | Subregion
Description: | Subregion Name

Mappings

Attribute | Hierarchy | Owner | Table | Column | Type
Long Description | GEOG_ROLLUP | SH | COUNTRIES | COUNTRY_SUBREGION | VARCHAR2
Short Description | GEOG_ROLLUP | SH | COUNTRIES | COUNTRY_SUBREGION | VARCHAR2
Total: 2 mappings(s)

See Also

List of attributes


List of hierarchies

Hierarchies

Name | Display name | Description | Solved code
CUST_ROLLUP | CUSTOMER hierarchy | CUSTOMER hierarchy | UL
GEOG_ROLLUP | GEOGRAPHY hierarchy | GEOGRAPHY hierarchy | UL
Total: 2 hierarchy(s)

See Also

Dimension [CUSTOMERS_DIM]


Hierarchy: CUST_ROLLUP in CUSTOMERS_DIM

Properties

Name: | CUST_ROLLUP
Display name: | CUSTOMER hierarchy
Description: | CUSTOMER hierarchy
Solved code: | UL

Levels

Name | Column | Parent level | Parent column
CHANNEL | SH.CHANNELS.CHANNEL_ID | CHANNEL_CLASS | SH.CHANNELS.CHANNEL_CLASS_ID
CHANNEL_CLASS | SH.CHANNELS.CHANNEL_CLASS_ID | CHANNEL_TOTAL | SH.CHANNELS.CHANNEL_TOTAL_ID
CHANNEL_TOTAL | SH.CHANNELS.CHANNEL_TOTAL_ID |  |
Total: 3 level(s)

See Also

List of hierarchies


Hierarchy: GEOG_ROLLUP in CUSTOMERS_DIM

Properties

Name: | GEOG_ROLLUP
Display name: | GEOGRAPHY hierarchy
Description: | GEOGRAPHY hierarchy
Solved code: | UL

Levels

Name | Column | Parent level | Parent column
CHANNEL | SH.CHANNELS.CHANNEL_ID | CHANNEL_CLASS | SH.CHANNELS.CHANNEL_CLASS_ID
CHANNEL_CLASS | SH.CHANNELS.CHANNEL_CLASS_ID | CHANNEL_TOTAL | SH.CHANNELS.CHANNEL_TOTAL_ID
CHANNEL_TOTAL | SH.CHANNELS.CHANNEL_TOTAL_ID |  |
Total: 3 level(s)

See Also

List of hierarchies


Dimension: PRODUCTS_DIM

Properties

Name: | PRODUCTS_DIM
Valid: |
Dimension type: | HIER
Plurar name: | Products
Default display hierarchy: | PROD_ROLLUP
Display name: | Product
Description: | Product Dimension Values

Levels

Name | Display name | Description | Owner | Table
CATEGORY | Categories | Category level of standard PRODUCT hierarchy | SH | PRODUCTS
PROD_TOTAL | Product Total | Product Total for the standard PRODUCT hierarchy | SH | PRODUCTS
PRODUCT | Products | Product level of standard PRODUCT hierarchy | SH | PRODUCTS
SUBCATEGORY | Sub-categories | Sub-category level of standard PRODUCT hierarchy | SH | PRODUCTS
Total: 4 level(s)

Hierarchies

Name | Display name | Description | Solved code
PROD_ROLLUP | Standard | Standard Product hierarchy | UL
Total: 1 hierarchy(s)

Attributes

Name | Display name | Description
Long Description | Long Product Description | Full Description of Products
Short Description | Short Product Names | Short name of Products
Total: 2 attribute(s)

DDL

CREATE DIMENSION "SH"."PRODUCTS_DIM" LEVEL "PRODUCT" IS ("PRODUCTS"."PROD_ID") LEVEL "SUBCATEGORY" IS ("PRODUCTS"."PROD_SUBCATEGORY_ID") LEVEL "CATEGORY" IS ("PRODUCTS"."PROD_CATEGORY_ID") LEVEL "PROD_TOTAL" IS ("PRODUCTS"."PROD_TOTAL_ID") HIERARCHY "PROD_ROLLUP" ("PRODUCT" CHILD OF "SUBCATEGORY" CHILD OF "CATEGORY" CHILD OF "PROD_TOTAL") ATTRIBUTE "PRODUCT" LEVEL "PRODUCT" DETERMINES "PRODUCTS"."PROD_NAME" ATTRIBUTE "PRODUCT" LEVEL "PRODUCT" DETERMINES "PRODUCTS"."PROD_MIN_PRICE" ATTRIBUTE "PRODUCT" LEVEL "PRODUCT" DETERMINES "PRODUCTS"."PROD_LIST_PRICE" ATTRIBUTE "PRODUCT" LEVEL "PRODUCT" DETERMINES "PRODUCTS"."PROD_STATUS" ATTRIBUTE "PRODUCT" LEVEL "PRODUCT" DETERMINES "PRODUCTS"."PROD_PACK_SIZE" ATTRIBUTE "PRODUCT" LEVEL "PRODUCT" DETERMINES "PRODUCTS"."PROD_UNIT_OF_MEASURE" ATTRIBUTE "PRODUCT" LEVEL "PRODUCT" DETERMINES "PRODUCTS"."PROD_WEIGHT_CLASS" ATTRIBUTE "PRODUCT" LEVEL "PRODUCT" DETERMINES "PRODUCTS"."PROD_DESC" ATTRIBUTE "SUBCATEGORY" LEVEL "SUBCATEGORY" DETERMINES "PRODUCTS"."PROD_SUBCATEGORY" ATTRIBUTE "SUBCATEGORY" LEVEL "SUBCATEGORY" DETERMINES "PRODUCTS"."PROD_SUBCATEGORY_DESC" ATTRIBUTE "CATEGORY" LEVEL "CATEGORY" DETERMINES "PRODUCTS"."PROD_CATEGORY" ATTRIBUTE "CATEGORY" LEVEL "CATEGORY" DETERMINES "PRODUCTS"."PROD_CATEGORY_DESC" ATTRIBUTE "PROD_TOTAL" LEVEL "PROD_TOTAL" DETERMINES "PRODUCTS"."PROD_TOTAL"

See Also

List of dimensions


List of attributes

Attributes

Long Description | Long Product Description | Full Description of Products
Short Description | Short Product Names | Short name of Products
Total: 2 attribute(s)

See Also

Dimension [PRODUCTS_DIM]


Attribute: Long Description in PRODUCTS_DIM

Properties

Name: | Long Description
Display name: | Long Product Description
Description: | Full Description of Products

Mappings

Hierarchy | Level | Attribute | Owner | Table | Column | Type
PROD_ROLLUP | CATEGORY | PROD_CATEGORY_DESC | SH | PRODUCTS | PROD_CATEGORY_DESC | VARCHAR2
PROD_ROLLUP | PRODUCT | PROD_DESC | SH | PRODUCTS | PROD_DESC | VARCHAR2
PROD_ROLLUP | SUBCATEGORY | PROD_SUBCATEGORY_DESC | SH | PRODUCTS | PROD_SUBCATEGORY_DESC | VARCHAR2
Total: 3 mappings(s)

See Also

List of dimension attributes


Attribute: Short Description in PRODUCTS_DIM

Properties

Name: | Short Description
Display name: | Short Product Names
Description: | Short name of Products

Mappings

Hierarchy | Level | Attribute | Owner | Table | Column | Type
PROD_ROLLUP | CATEGORY | PROD_CATEGORY_DESC | SH | PRODUCTS | PROD_CATEGORY_DESC | VARCHAR2
PROD_ROLLUP | PRODUCT | PROD_NAME | SH | PRODUCTS | PROD_NAME | VARCHAR2
PROD_ROLLUP | SUBCATEGORY | PROD_SUBCATEGORY_DESC | SH | PRODUCTS | PROD_SUBCATEGORY_DESC | VARCHAR2
Total: 3 mappings(s)

See Also

List of dimension attributes


List of levels

Levels

Name | Display name | Description | Owner | Table
CATEGORY | Categories | Category level of standard PRODUCT hierarchy | SH | PRODUCTS
PROD_TOTAL | Product Total | Product Total for the standard PRODUCT hierarchy | SH | PRODUCTS
PRODUCT | Products | Product level of standard PRODUCT hierarchy | SH | PRODUCTS
SUBCATEGORY | Sub-categories | Sub-category level of standard PRODUCT hierarchy | SH | PRODUCTS
Total: 4 level(s)

See Also

Dimension [PRODUCTS_DIM]


Level: CATEGORY in PRODUCTS_DIM

Properties

Name: | CATEGORY
Display name: | Categories
Table owner: | SH
Table name: | PRODUCTS

Mappings

Hierarchy | Table owner | Table | Column
PROD_ROLLUP | SH | PRODUCTS | PROD_CATEGORY_ID
Total: 1 mappings(s)

Attributes

Name | Display name | Description
PROD_CATEGORY | Category | Product category
PROD_CATEGORY_DESC | Category Description | Product Category Description
Total: 2 attribute(s)

See Also

List of levels


List of attributes

Attribute

Name | Display name | Description
PROD_CATEGORY | Category | Product category
PROD_CATEGORY_DESC | Category Description | Product Category Description
Total: 2 attribute(s)

See Also

Level [CATEGORY]


Atribute: PROD_CATEGORY in CATEGORY

Properties

Name: | PROD_CATEGORY
Display name: | Category
Description: | Product category

See Also

List of attributes


Atribute: PROD_CATEGORY_DESC in CATEGORY

Properties

Name: | PROD_CATEGORY_DESC
Display name: | Category Description
Description: | Product Category Description

Mappings

Attribute | Hierarchy | Owner | Table | Column | Type
Long Description | PROD_ROLLUP | SH | PRODUCTS | PROD_CATEGORY_DESC | VARCHAR2
Short Description | PROD_ROLLUP | SH | PRODUCTS | PROD_CATEGORY_DESC | VARCHAR2
Total: 2 mappings(s)

See Also

List of attributes


Level: PROD_TOTAL in PRODUCTS_DIM

Properties

Name: | PROD_TOTAL
Display name: | Product Total
Table owner: | SH
Table name: | PRODUCTS

Mappings

Hierarchy | Table owner | Table | Column
PROD_ROLLUP | SH | PRODUCTS | PROD_TOTAL_ID
Total: 1 mappings(s)

Attributes

Name | Display name | Description
PROD_TOTAL | Product Total | Product Total
Total: 1 attribute(s)

See Also

List of levels


List of attributes

Attribute

Name | Display name | Description
PROD_TOTAL | Product Total | Product Total
Total: 1 attribute(s)

See Also

Level [PROD_TOTAL]


Atribute: PROD_TOTAL in PROD_TOTAL

Properties

Name: | PROD_TOTAL
Display name: | Product Total
Description: | Product Total

See Also

List of attributes


Level: PRODUCT in PRODUCTS_DIM

Properties

Name: | PRODUCT
Display name: | Products
Table owner: | SH
Table name: | PRODUCTS

Mappings

Hierarchy | Table owner | Table | Column
PROD_ROLLUP | SH | PRODUCTS | PROD_ID
Total: 1 mappings(s)

Attributes

Name | Display name | Description
PROD_DESC | Product Description | Product Description including characteristics of the product
PROD_NAME | Product Name(s) | Names for Product values of the Standard Product hierarchy
PROD_UNIT_OF_MEASURE | Unit of Measure | Product Unit of Measure
PROD_WEIGHT_CLASS | Weight Class | Product Weight Class
Total: 4 attribute(s)

See Also

List of levels


List of attributes

Attribute

Name | Display name | Description
PROD_DESC | Product Description | Product Description including characteristics of the product
PROD_NAME | Product Name(s) | Names for Product values of the Standard Product hierarchy
PROD_UNIT_OF_MEASURE | Unit of Measure | Product Unit of Measure
PROD_WEIGHT_CLASS | Weight Class | Product Weight Class
Total: 4 attribute(s)

See Also

Level [PRODUCT]


Atribute: PROD_DESC in PRODUCT

Properties

Name: | PROD_DESC
Display name: | Product Description
Description: | Product Description including characteristics of the product

Mappings

Attribute | Hierarchy | Owner | Table | Column | Type
Long Description | PROD_ROLLUP | SH | PRODUCTS | PROD_DESC | VARCHAR2
Total: 1 mappings(s)

See Also

List of attributes


Atribute: PROD_NAME in PRODUCT

Properties

Name: | PROD_NAME
Display name: | Product Name(s)
Description: | Names for Product values of the Standard Product hierarchy

Mappings

Attribute | Hierarchy | Owner | Table | Column | Type
Short Description | PROD_ROLLUP | SH | PRODUCTS | PROD_NAME | VARCHAR2
Total: 1 mappings(s)

See Also

List of attributes


Atribute: PROD_UNIT_OF_MEASURE in PRODUCT

Properties

Name: | PROD_UNIT_OF_MEASURE
Display name: | Unit of Measure
Description: | Product Unit of Measure

See Also

List of attributes


Atribute: PROD_WEIGHT_CLASS in PRODUCT

Properties

Name: | PROD_WEIGHT_CLASS
Display name: | Weight Class
Description: | Product Weight Class

See Also

List of attributes


Level: SUBCATEGORY in PRODUCTS_DIM

Properties

Name: | SUBCATEGORY
Display name: | Sub-categories
Table owner: | SH
Table name: | PRODUCTS

Mappings

Hierarchy | Table owner | Table | Column
PROD_ROLLUP | SH | PRODUCTS | PROD_SUBCATEGORY_ID
Total: 1 mappings(s)

Attributes

Name | Display name | Description
PROD_SUBCATEGORY | Sub-category | Product Sub-category
PROD_SUBCATEGORY_DESC | Sub-category Description | Product Sub-category Description
Total: 2 attribute(s)

See Also

List of levels


List of attributes

Attribute

Name | Display name | Description
PROD_SUBCATEGORY | Sub-category | Product Sub-category
PROD_SUBCATEGORY_DESC | Sub-category Description | Product Sub-category Description
Total: 2 attribute(s)

See Also

Level [SUBCATEGORY]


Atribute: PROD_SUBCATEGORY in SUBCATEGORY

Properties

Name: | PROD_SUBCATEGORY
Display name: | Sub-category
Description: | Product Sub-category

See Also

List of attributes


Atribute: PROD_SUBCATEGORY_DESC in SUBCATEGORY

Properties

Name: | PROD_SUBCATEGORY_DESC
Display name: | Sub-category Description
Description: | Product Sub-category Description

Mappings

Attribute | Hierarchy | Owner | Table | Column | Type
Long Description | PROD_ROLLUP | SH | PRODUCTS | PROD_SUBCATEGORY_DESC | VARCHAR2
Short Description | PROD_ROLLUP | SH | PRODUCTS | PROD_SUBCATEGORY_DESC | VARCHAR2
Total: 2 mappings(s)

See Also

List of attributes


List of hierarchies

Hierarchies

Name | Display name | Description | Solved code
PROD_ROLLUP | Standard | Standard Product hierarchy | UL
Total: 1 hierarchy(s)

See Also

Dimension [PRODUCTS_DIM]


Hierarchy: PROD_ROLLUP in PRODUCTS_DIM

Properties

Name: | PROD_ROLLUP
Display name: | Standard
Description: | Standard Product hierarchy
Solved code: | UL

Levels

Name | Column | Parent level | Parent column
CHANNEL | SH.CHANNELS.CHANNEL_ID | CHANNEL_CLASS | SH.CHANNELS.CHANNEL_CLASS_ID
CHANNEL_CLASS | SH.CHANNELS.CHANNEL_CLASS_ID | CHANNEL_TOTAL | SH.CHANNELS.CHANNEL_TOTAL_ID
CHANNEL_TOTAL | SH.CHANNELS.CHANNEL_TOTAL_ID |  |
Total: 3 level(s)

See Also

List of hierarchies


Dimension: PROMOTIONS_DIM

Properties

Name: | PROMOTIONS_DIM
Valid: |
Dimension type: | HIER
Plurar name: | Promotions
Default display hierarchy: | PROMO_ROLLUP
Display name: | Promotions
Description: | Promotion Values

Levels

Name | Display name | Description | Owner | Table
CATEGORY | Promotions Categories | Category level of the standard PROMOTION hierarchy | SH | PROMOTIONS
PROMO | Promotions | Promotion level of the standard PROMOTION hierarchy | SH | PROMOTIONS
PROMO_TOTAL | Promotions Total | Promotions Total for the standard PROMOTION hierarchy | SH | PROMOTIONS
SUBCATEGORY | Promotions Sub-categories | Sub-category level of the standard PROMOTION hierarchy | SH | PROMOTIONS
Total: 4 level(s)

Hierarchies

Name | Display name | Description | Solved code
PROMO_ROLLUP | Promotion Hierarchy | Promotion Hierarchy | UL
Total: 1 hierarchy(s)

Attributes

Name | Display name | Description
Long Description | Long Description of Promotions | Long Description of Promotions
Short Description | ShortDescription of Promotions | Short Description of Promotions
Total: 2 attribute(s)

DDL

CREATE DIMENSION "SH"."PROMOTIONS_DIM" LEVEL "PROMO" IS ("PROMOTIONS"."PROMO_ID") LEVEL "SUBCATEGORY" IS ("PROMOTIONS"."PROMO_SUBCATEGORY_ID") LEVEL "CATEGORY" IS ("PROMOTIONS"."PROMO_CATEGORY_ID") LEVEL "PROMO_TOTAL" IS ("PROMOTIONS"."PROMO_TOTAL_ID") HIERARCHY "PROMO_ROLLUP" ("PROMO" CHILD OF "SUBCATEGORY" CHILD OF "CATEGORY" CHILD OF "PROMO_TOTAL") ATTRIBUTE "PROMO" LEVEL "PROMO" DETERMINES "PROMOTIONS"."PROMO_NAME" ATTRIBUTE "PROMO" LEVEL "PROMO" DETERMINES "PROMOTIONS"."PROMO_END_DATE" ATTRIBUTE "PROMO" LEVEL "PROMO" DETERMINES "PROMOTIONS"."PROMO_BEGIN_DATE" ATTRIBUTE "PROMO" LEVEL "PROMO" DETERMINES "PROMOTIONS"."PROMO_COST" ATTRIBUTE "SUBCATEGORY" LEVEL "SUBCATEGORY" DETERMINES "PROMOTIONS"."PROMO_SUBCATEGORY" ATTRIBUTE "CATEGORY" LEVEL "CATEGORY" DETERMINES "PROMOTIONS"."PROMO_CATEGORY" ATTRIBUTE "PROMO_TOTAL" LEVEL "PROMO_TOTAL" DETERMINES "PROMOTIONS"."PROMO_TOTAL"

See Also

List of dimensions


List of attributes

Attributes

Long Description | Long Description of Promotions | Long Description of Promotions
Short Description | ShortDescription of Promotions | Short Description of Promotions
Total: 2 attribute(s)

See Also

Dimension [PROMOTIONS_DIM]


Attribute: Long Description in PROMOTIONS_DIM

Properties

Name: | Long Description
Display name: | Long Description of Promotions
Description: | Long Description of Promotions

Mappings

Hierarchy | Level | Attribute | Owner | Table | Column | Type
PROMO_ROLLUP | PROMO | PROMO_NAME | SH | PROMOTIONS | PROMO_NAME | VARCHAR2
Total: 1 mappings(s)

See Also

List of dimension attributes


Attribute: Short Description in PROMOTIONS_DIM

Properties

Name: | Short Description
Display name: | ShortDescription of Promotions
Description: | Short Description of Promotions

Mappings

Hierarchy | Level | Attribute | Owner | Table | Column | Type
PROMO_ROLLUP | PROMO | PROMO_NAME | SH | PROMOTIONS | PROMO_NAME | VARCHAR2
Total: 1 mappings(s)

See Also

List of dimension attributes


List of levels

Levels

Name | Display name | Description | Owner | Table
CATEGORY | Promotions Categories | Category level of the standard PROMOTION hierarchy | SH | PROMOTIONS
PROMO | Promotions | Promotion level of the standard PROMOTION hierarchy | SH | PROMOTIONS
PROMO_TOTAL | Promotions Total | Promotions Total for the standard PROMOTION hierarchy | SH | PROMOTIONS
SUBCATEGORY | Promotions Sub-categories | Sub-category level of the standard PROMOTION hierarchy | SH | PROMOTIONS
Total: 4 level(s)

See Also

Dimension [PROMOTIONS_DIM]


Level: CATEGORY in PROMOTIONS_DIM

Properties

Name: | CATEGORY
Display name: | Promotions Categories
Table owner: | SH
Table name: | PROMOTIONS

Mappings

Hierarchy | Table owner | Table | Column
PROMO_ROLLUP | SH | PROMOTIONS | PROMO_CATEGORY_ID
Total: 1 mappings(s)

Attributes

Name | Display name | Description
PROMO_CATEGORY | Category | Promotion Category
Total: 1 attribute(s)

See Also

List of levels


List of attributes

Attribute

Name | Display name | Description
PROMO_CATEGORY | Category | Promotion Category
Total: 1 attribute(s)

See Also

Level [CATEGORY]


Atribute: PROMO_CATEGORY in CATEGORY

Properties

Name: | PROMO_CATEGORY
Display name: | Category
Description: | Promotion Category

See Also

List of attributes


Level: PROMO in PROMOTIONS_DIM

Properties

Name: | PROMO
Display name: | Promotions
Table owner: | SH
Table name: | PROMOTIONS

Mappings

Hierarchy | Table owner | Table | Column
PROMO_ROLLUP | SH | PROMOTIONS | PROMO_ID
Total: 1 mappings(s)

Attributes

Name | Display name | Description
PROMO_BEGIN_DATE | Begin date | Promotion Begin Date
PROMO_COST | Promotion costs | Promotion costs
PROMO_END_DATE | End date | Promotion End Date
PROMO_NAME | Promotion Name(s) | Names for the Promotions in the Standard Promotions hierarchy
Total: 4 attribute(s)

See Also

List of levels


List of attributes

Attribute

Name | Display name | Description
PROMO_BEGIN_DATE | Begin date | Promotion Begin Date
PROMO_COST | Promotion costs | Promotion costs
PROMO_END_DATE | End date | Promotion End Date
PROMO_NAME | Promotion Name(s) | Names for the Promotions in the Standard Promotions hierarchy
Total: 4 attribute(s)

See Also

Level [PROMO]


Atribute: PROMO_BEGIN_DATE in PROMO

Properties

Name: | PROMO_BEGIN_DATE
Display name: | Begin date
Description: | Promotion Begin Date

See Also

List of attributes


Atribute: PROMO_COST in PROMO

Properties

Name: | PROMO_COST
Display name: | Promotion costs
Description: | Promotion costs

See Also

List of attributes


Atribute: PROMO_END_DATE in PROMO

Properties

Name: | PROMO_END_DATE
Display name: | End date
Description: | Promotion End Date

See Also

List of attributes


Atribute: PROMO_NAME in PROMO

Properties

Name: | PROMO_NAME
Display name: | Promotion Name(s)
Description: | Names for the Promotions in the Standard Promotions hierarchy

Mappings

Attribute | Hierarchy | Owner | Table | Column | Type
Long Description | PROMO_ROLLUP | SH | PROMOTIONS | PROMO_NAME | VARCHAR2
Short Description | PROMO_ROLLUP | SH | PROMOTIONS | PROMO_NAME | VARCHAR2
Total: 2 mappings(s)

See Also

List of attributes


Level: PROMO_TOTAL in PROMOTIONS_DIM

Properties

Name: | PROMO_TOTAL
Display name: | Promotions Total
Table owner: | SH
Table name: | PROMOTIONS

Mappings

Hierarchy | Table owner | Table | Column
PROMO_ROLLUP | SH | PROMOTIONS | PROMO_TOTAL_ID
Total: 1 mappings(s)

Attributes

Name | Display name | Description
PROMO_TOTAL | Promotions Total | Promotions Total
Total: 1 attribute(s)

See Also

List of levels


List of attributes

Attribute

Name | Display name | Description
PROMO_TOTAL | Promotions Total | Promotions Total
Total: 1 attribute(s)

See Also

Level [PROMO_TOTAL]


Atribute: PROMO_TOTAL in PROMO_TOTAL

Properties

Name: | PROMO_TOTAL
Display name: | Promotions Total
Description: | Promotions Total

See Also

List of attributes


Level: SUBCATEGORY in PROMOTIONS_DIM

Properties

Name: | SUBCATEGORY
Display name: | Promotions Sub-categories
Table owner: | SH
Table name: | PROMOTIONS

Mappings

Hierarchy | Table owner | Table | Column
PROMO_ROLLUP | SH | PROMOTIONS | PROMO_SUBCATEGORY_ID
Total: 1 mappings(s)

Attributes

Name | Display name | Description
PROMO_SUBCATEGORY | Sub-Category | Promotion Sub-Category
Total: 1 attribute(s)

See Also

List of levels


List of attributes

Attribute

Name | Display name | Description
PROMO_SUBCATEGORY | Sub-Category | Promotion Sub-Category
Total: 1 attribute(s)

See Also

Level [SUBCATEGORY]


Atribute: PROMO_SUBCATEGORY in SUBCATEGORY

Properties

Name: | PROMO_SUBCATEGORY
Display name: | Sub-Category
Description: | Promotion Sub-Category

See Also

List of attributes


List of hierarchies

Hierarchies

Name | Display name | Description | Solved code
PROMO_ROLLUP | Promotion Hierarchy | Promotion Hierarchy | UL
Total: 1 hierarchy(s)

See Also

Dimension [PROMOTIONS_DIM]


Hierarchy: PROMO_ROLLUP in PROMOTIONS_DIM

Properties

Name: | PROMO_ROLLUP
Display name: | Promotion Hierarchy
Description: | Promotion Hierarchy
Solved code: | UL

Levels

Name | Column | Parent level | Parent column
CHANNEL | SH.CHANNELS.CHANNEL_ID | CHANNEL_CLASS | SH.CHANNELS.CHANNEL_CLASS_ID
CHANNEL_CLASS | SH.CHANNELS.CHANNEL_CLASS_ID | CHANNEL_TOTAL | SH.CHANNELS.CHANNEL_TOTAL_ID
CHANNEL_TOTAL | SH.CHANNELS.CHANNEL_TOTAL_ID |  |
Total: 3 level(s)

See Also

List of hierarchies


Dimension: TIMES_DIM

Properties

Name: | TIMES_DIM
Valid: |
Dimension type: | HIER
Plurar name: | Times
Default display hierarchy: | CAL_ROLLUP
Display name: | Time
Description: | Time Dimension Values

Levels

Name | Display name | Description | Owner | Table
DAY | Day | Day level of the Calendar hierarchy | SH | TIMES
FIS_MONTH | Fiscal Month | Month level of the Fiscal hierarchy | SH | TIMES
FIS_QUARTER | Fiscal Quarter | Quarter level of the Fiscal hierarchy | SH | TIMES
FIS_WEEK | Fiscal Week | Week level of the Fiscal hierarchy | SH | TIMES
FIS_YEAR | Fiscal Year | Year level of the Fiscal hierarchy | SH | TIMES
MONTH | Month | Month level of the Calendar hierarchy | SH | TIMES
QUARTER | Quarter | Quarter level of the Calendar hierarchy | SH | TIMES
YEAR | Year | Year level of the Calendar hierarchy | SH | TIMES
Total: 8 level(s)

Hierarchies

Name | Display name | Description | Solved code
CAL_ROLLUP | Calendar Hierarchy | Calendar Hierarchy | UL
FIS_ROLLUP | Fiscal Hierarchy | Fiscal Hierarchy | UL
Total: 2 hierarchy(s)

Attributes

Name | Display name | Description
Long Description | Long Time Period Names | Full name of time periods
Period End Date | Period End Date | Last Day in Time Period
Period Number of Days | Period Number of Days | Number of Days in Time Period
Short Description | Short Time Period Names | Short name of time periods
Total: 4 attribute(s)

DDL

CREATE DIMENSION "SH"."TIMES_DIM" LEVEL "DAY" IS ("TIMES"."TIME_ID") LEVEL "MONTH" IS ("TIMES"."CALENDAR_MONTH_ID") LEVEL "QUARTER" IS ("TIMES"."CALENDAR_QUARTER_ID") LEVEL "YEAR" IS ("TIMES"."CALENDAR_YEAR_ID") LEVEL "FIS_WEEK" IS ("TIMES"."WEEK_ENDING_DAY_ID") LEVEL "FIS_MONTH" IS ("TIMES"."FISCAL_MONTH_ID") LEVEL "FIS_QUARTER" IS ("TIMES"."FISCAL_QUARTER_ID") LEVEL "FIS_YEAR" IS ("TIMES"."FISCAL_YEAR_ID") HIERARCHY "CAL_ROLLUP" ("DAY" CHILD OF "MONTH" CHILD OF "QUARTER" CHILD OF "YEAR") HIERARCHY "FIS_ROLLUP" ("DAY" CHILD OF "FIS_WEEK" CHILD OF "FIS_MONTH" CHILD OF "FIS_QUARTER" CHILD OF "FIS_YEAR") ATTRIBUTE "DAY" LEVEL "DAY" DETERMINES "TIMES"."DAY_NUMBER_IN_WEEK" ATTRIBUTE "DAY" LEVEL "DAY" DETERMINES "TIMES"."CALENDAR_WEEK_NUMBER" ATTRIBUTE "DAY" LEVEL "DAY" DETERMINES "TIMES"."DAY_NUMBER_IN_MONTH" ATTRIBUTE "DAY" LEVEL "DAY" DETERMINES "TIMES"."DAY_NAME" ATTRIBUTE "MONTH" LEVEL "MONTH" DETERMINES "TIMES"."CALENDAR_MONTH_DESC" ATTRIBUTE "MONTH" LEVEL "MONTH" DETERMINES "TIMES"."END_OF_CAL_MONTH" ATTRIBUTE "MONTH" LEVEL "MONTH" DETERMINES "TIMES"."DAYS_IN_CAL_MONTH" ATTRIBUTE "MONTH" LEVEL "MONTH" DETERMINES "TIMES"."CALENDAR_MONTH_NAME" ATTRIBUTE "MONTH" LEVEL "MONTH" DETERMINES "TIMES"."CALENDAR_MONTH_NUMBER" ATTRIBUTE "QUARTER" LEVEL "QUARTER" DETERMINES "TIMES"."CALENDAR_QUARTER_DESC" ATTRIBUTE "QUARTER" LEVEL "QUARTER" DETERMINES "TIMES"."END_OF_CAL_QUARTER" ATTRIBUTE "QUARTER" LEVEL "QUARTER" DETERMINES "TIMES"."DAYS_IN_CAL_QUARTER" ATTRIBUTE "QUARTER" LEVEL "QUARTER" DETERMINES "TIMES"."CALENDAR_QUARTER_NUMBER" ATTRIBUTE "YEAR" LEVEL "YEAR" DETERMINES "TIMES"."CALENDAR_YEAR" ATTRIBUTE "YEAR" LEVEL "YEAR" DETERMINES "TIMES"."END_OF_CAL_YEAR" ATTRIBUTE "YEAR" LEVEL "YEAR" DETERMINES "TIMES"."DAYS_IN_CAL_YEAR" ATTRIBUTE "FIS_WEEK" LEVEL "FIS_WEEK" DETERMINES "TIMES"."WEEK_ENDING_DAY" ATTRIBUTE "FIS_WEEK" LEVEL "FIS_WEEK" DETERMINES "TIMES"."FISCAL_WEEK_NUMBER" ATTRIBUTE "FIS_MONTH" LEVEL "FIS_MONTH" DETERMINES "TIMES"."FISCAL_MONTH_DESC" ATTRIBUTE "FIS_MONTH" LEVEL "FIS_MONTH" DETERMINES "TIMES"."END_OF_FIS_MONTH" ATTRIBUTE "FIS_MONTH" LEVEL "FIS_MONTH" DETERMINES "TIMES"."DAYS_IN_FIS_MONTH" ATTRIBUTE "FIS_MONTH" LEVEL "FIS_MONTH" DETERMINES "TIMES"."FISCAL_MONTH_NAME" ATTRIBUTE "FIS_MONTH" LEVEL "FIS_MONTH" DETERMINES "TIMES"."FISCAL_MONTH_NUMBER" ATTRIBUTE "FIS_QUARTER" LEVEL "FIS_QUARTER" DETERMINES "TIMES"."FISCAL_QUARTER_DESC" ATTRIBUTE "FIS_QUARTER" LEVEL "FIS_QUARTER" DETERMINES "TIMES"."END_OF_FIS_QUARTER" ATTRIBUTE "FIS_QUARTER" LEVEL "FIS_QUARTER" DETERMINES "TIMES"."DAYS_IN_FIS_QUARTER" ATTRIBUTE "FIS_QUARTER" LEVEL "FIS_QUARTER" DETERMINES "TIMES"."FISCAL_QUARTER_NUMBER" ATTRIBUTE "FIS_YEAR" LEVEL "FIS_YEAR" DETERMINES "TIMES"."FISCAL_YEAR" ATTRIBUTE "FIS_YEAR" LEVEL "FIS_YEAR" DETERMINES "TIMES"."END_OF_FIS_YEAR" ATTRIBUTE "FIS_YEAR" LEVEL "FIS_YEAR" DETERMINES "TIMES"."DAYS_IN_FIS_YEAR"

See Also

List of dimensions


List of attributes

Attributes

Long Description | Long Time Period Names | Full name of time periods
Period End Date | Period End Date | Last Day in Time Period
Period Number of Days | Period Number of Days | Number of Days in Time Period
Short Description | Short Time Period Names | Short name of time periods
Total: 4 attribute(s)

See Also

Dimension [TIMES_DIM]


Attribute: Long Description in TIMES_DIM

Properties

Name: | Long Description
Display name: | Long Time Period Names
Description: | Full name of time periods

Mappings

Hierarchy | Level | Attribute | Owner | Table | Column | Type
CAL_ROLLUP | MONTH | CALENDAR_MONTH_DESC | SH | TIMES | CALENDAR_MONTH_DESC | VARCHAR2
CAL_ROLLUP | QUARTER | CALENDAR_QUARTER_DESC | SH | TIMES | CALENDAR_QUARTER_DESC | CHAR
CAL_ROLLUP | DAY | DAY_NAME | SH | TIMES | DAY_NAME | VARCHAR2
FIS_ROLLUP | DAY | DAY_NAME | SH | TIMES | DAY_NAME | VARCHAR2
FIS_ROLLUP | FIS_MONTH | FISCAL_MONTH_DESC | SH | TIMES | FISCAL_MONTH_DESC | VARCHAR2
FIS_ROLLUP | FIS_QUARTER | FISCAL_QUARTER_DESC | SH | TIMES | FISCAL_QUARTER_DESC | CHAR
Total: 6 mappings(s)

See Also

List of dimension attributes


Attribute: Period End Date in TIMES_DIM

Properties

Name: | Period End Date
Display name: | Period End Date
Description: | Last Day in Time Period

Mappings

Hierarchy | Level | Attribute | Owner | Table | Column | Type
CAL_ROLLUP | MONTH | END_OF_CAL_MONTH | SH | TIMES | END_OF_CAL_MONTH | DATE
CAL_ROLLUP | QUARTER | END_OF_CAL_QUARTER | SH | TIMES | END_OF_CAL_QUARTER | DATE
CAL_ROLLUP | YEAR | END_OF_CAL_YEAR | SH | TIMES | END_OF_CAL_YEAR | DATE
FIS_ROLLUP | FIS_MONTH | END_OF_FIS_MONTH | SH | TIMES | END_OF_FIS_MONTH | DATE
FIS_ROLLUP | FIS_QUARTER | END_OF_FIS_QUARTER | SH | TIMES | END_OF_FIS_QUARTER | DATE
FIS_ROLLUP | FIS_YEAR | END_OF_FIS_YEAR | SH | TIMES | END_OF_FIS_YEAR | DATE
Total: 6 mappings(s)

See Also

List of dimension attributes


Attribute: Period Number of Days in TIMES_DIM

Properties

Name: | Period Number of Days
Display name: | Period Number of Days
Description: | Number of Days in Time Period

Mappings

Hierarchy | Level | Attribute | Owner | Table | Column | Type
CAL_ROLLUP | MONTH | DAYS_IN_CAL_MONTH | SH | TIMES | DAYS_IN_CAL_MONTH | NUMBER
CAL_ROLLUP | QUARTER | DAYS_IN_CAL_QUARTER | SH | TIMES | DAYS_IN_CAL_QUARTER | NUMBER
CAL_ROLLUP | YEAR | DAYS_IN_CAL_YEAR | SH | TIMES | DAYS_IN_CAL_YEAR | NUMBER
FIS_ROLLUP | FIS_MONTH | DAYS_IN_FIS_MONTH | SH | TIMES | DAYS_IN_FIS_MONTH | NUMBER
FIS_ROLLUP | FIS_QUARTER | DAYS_IN_FIS_QUARTER | SH | TIMES | DAYS_IN_FIS_QUARTER | NUMBER
FIS_ROLLUP | FIS_YEAR | DAYS_IN_FIS_YEAR | SH | TIMES | DAYS_IN_FIS_YEAR | NUMBER
Total: 6 mappings(s)

See Also

List of dimension attributes


Attribute: Short Description in TIMES_DIM

Properties

Name: | Short Description
Display name: | Short Time Period Names
Description: | Short name of time periods

Mappings

Hierarchy | Level | Attribute | Owner | Table | Column | Type
CAL_ROLLUP | MONTH | CALENDAR_MONTH_DESC | SH | TIMES | CALENDAR_MONTH_DESC | VARCHAR2
CAL_ROLLUP | QUARTER | CALENDAR_QUARTER_DESC | SH | TIMES | CALENDAR_QUARTER_DESC | CHAR
CAL_ROLLUP | DAY | DAY_NAME | SH | TIMES | DAY_NAME | VARCHAR2
FIS_ROLLUP | DAY | DAY_NAME | SH | TIMES | DAY_NAME | VARCHAR2
FIS_ROLLUP | FIS_MONTH | FISCAL_MONTH_DESC | SH | TIMES | FISCAL_MONTH_DESC | VARCHAR2
FIS_ROLLUP | FIS_QUARTER | FISCAL_QUARTER_DESC | SH | TIMES | FISCAL_QUARTER_DESC | CHAR
Total: 6 mappings(s)

See Also

List of dimension attributes


List of levels

Levels

Name | Display name | Description | Owner | Table
DAY | Day | Day level of the Calendar hierarchy | SH | TIMES
FIS_MONTH | Fiscal Month | Month level of the Fiscal hierarchy | SH | TIMES
FIS_QUARTER | Fiscal Quarter | Quarter level of the Fiscal hierarchy | SH | TIMES
FIS_WEEK | Fiscal Week | Week level of the Fiscal hierarchy | SH | TIMES
FIS_YEAR | Fiscal Year | Year level of the Fiscal hierarchy | SH | TIMES
MONTH | Month | Month level of the Calendar hierarchy | SH | TIMES
QUARTER | Quarter | Quarter level of the Calendar hierarchy | SH | TIMES
YEAR | Year | Year level of the Calendar hierarchy | SH | TIMES
Total: 8 level(s)

See Also

Dimension [TIMES_DIM]


Level: DAY in TIMES_DIM

Properties

Name: | DAY
Display name: | Day
Table owner: | SH
Table name: | TIMES

Mappings

Hierarchy | Table owner | Table | Column
CAL_ROLLUP | SH | TIMES | TIME_ID
FIS_ROLLUP | SH | TIMES | TIME_ID
Total: 2 mappings(s)

Attributes

Name | Display name | Description
CALENDAR_WEEK_NUMBER | Calendar Week Number | Calendar Week Number
DAY_NAME | Day Name | Name of the Day of the Week
DAY_NUMBER_IN_MONTH | Day Number in Month | Day number in month
DAY_NUMBER_IN_WEEK | Day Number in Week | Day Number in Week where Monday is day number 1
Total: 4 attribute(s)

See Also

List of levels


List of attributes

Attribute

Name | Display name | Description
CALENDAR_WEEK_NUMBER | Calendar Week Number | Calendar Week Number
DAY_NAME | Day Name | Name of the Day of the Week
DAY_NUMBER_IN_MONTH | Day Number in Month | Day number in month
DAY_NUMBER_IN_WEEK | Day Number in Week | Day Number in Week where Monday is day number 1
Total: 4 attribute(s)

See Also

Level [DAY]


Atribute: CALENDAR_WEEK_NUMBER in DAY

Properties

Name: | CALENDAR_WEEK_NUMBER
Display name: | Calendar Week Number
Description: | Calendar Week Number

See Also

List of attributes


Atribute: DAY_NAME in DAY

Properties

Name: | DAY_NAME
Display name: | Day Name
Description: | Name of the Day of the Week

Mappings

Attribute | Hierarchy | Owner | Table | Column | Type
Long Description | CAL_ROLLUP | SH | TIMES | DAY_NAME | VARCHAR2
Short Description | CAL_ROLLUP | SH | TIMES | DAY_NAME | VARCHAR2
Long Description | FIS_ROLLUP | SH | TIMES | DAY_NAME | VARCHAR2
Short Description | FIS_ROLLUP | SH | TIMES | DAY_NAME | VARCHAR2
Total: 4 mappings(s)

See Also

List of attributes


Atribute: DAY_NUMBER_IN_MONTH in DAY

Properties

Name: | DAY_NUMBER_IN_MONTH
Display name: | Day Number in Month
Description: | Day number in month

See Also

List of attributes


Atribute: DAY_NUMBER_IN_WEEK in DAY

Properties

Name: | DAY_NUMBER_IN_WEEK
Display name: | Day Number in Week
Description: | Day Number in Week where Monday is day number 1

See Also

List of attributes


Level: FIS_MONTH in TIMES_DIM

Properties

Name: | FIS_MONTH
Display name: | Fiscal Month
Table owner: | SH
Table name: | TIMES

Mappings

Hierarchy | Table owner | Table | Column
FIS_ROLLUP | SH | TIMES | FISCAL_MONTH_ID
Total: 1 mappings(s)

Attributes

Name | Display name | Description
DAYS_IN_FIS_MONTH | DAYS_IN_FIS_MONTH | Number of Days in Fiscal Month
END_OF_FIS_MONTH | End of Fiscal Month | Last Day of the Fiscal Month
FISCAL_MONTH_DESC | Fiscal Month | Fiscal Month Description
FISCAL_MONTH_NAME | Fiscal Month Name | Fiscal Month Name
FISCAL_MONTH_NUMBER | Fiscal Month Number | Fiscal Month Number
Total: 5 attribute(s)

See Also

List of levels


List of attributes

Attribute

Name | Display name | Description
DAYS_IN_FIS_MONTH | DAYS_IN_FIS_MONTH | Number of Days in Fiscal Month
END_OF_FIS_MONTH | End of Fiscal Month | Last Day of the Fiscal Month
FISCAL_MONTH_DESC | Fiscal Month | Fiscal Month Description
FISCAL_MONTH_NAME | Fiscal Month Name | Fiscal Month Name
FISCAL_MONTH_NUMBER | Fiscal Month Number | Fiscal Month Number
Total: 5 attribute(s)

See Also

Level [FIS_MONTH]


Atribute: DAYS_IN_FIS_MONTH in FIS_MONTH

Properties

Name: | DAYS_IN_FIS_MONTH
Display name: | DAYS_IN_FIS_MONTH
Description: | Number of Days in Fiscal Month

Mappings

Attribute | Hierarchy | Owner | Table | Column | Type
Period Number of Days | FIS_ROLLUP | SH | TIMES | DAYS_IN_FIS_MONTH | NUMBER
Total: 1 mappings(s)

See Also

List of attributes


Atribute: END_OF_FIS_MONTH in FIS_MONTH

Properties

Name: | END_OF_FIS_MONTH
Display name: | End of Fiscal Month
Description: | Last Day of the Fiscal Month

Mappings

Attribute | Hierarchy | Owner | Table | Column | Type
Period End Date | FIS_ROLLUP | SH | TIMES | END_OF_FIS_MONTH | DATE
Total: 1 mappings(s)

See Also

List of attributes


Atribute: FISCAL_MONTH_DESC in FIS_MONTH

Properties

Name: | FISCAL_MONTH_DESC
Display name: | Fiscal Month
Description: | Fiscal Month Description

Mappings

Attribute | Hierarchy | Owner | Table | Column | Type
Long Description | FIS_ROLLUP | SH | TIMES | FISCAL_MONTH_DESC | VARCHAR2
Short Description | FIS_ROLLUP | SH | TIMES | FISCAL_MONTH_DESC | VARCHAR2
Total: 2 mappings(s)

See Also

List of attributes


Atribute: FISCAL_MONTH_NAME in FIS_MONTH

Properties

Name: | FISCAL_MONTH_NAME
Display name: | Fiscal Month Name
Description: | Fiscal Month Name

See Also

List of attributes


Atribute: FISCAL_MONTH_NUMBER in FIS_MONTH

Properties

Name: | FISCAL_MONTH_NUMBER
Display name: | Fiscal Month Number
Description: | Fiscal Month Number

See Also

List of attributes


Level: FIS_QUARTER in TIMES_DIM

Properties

Name: | FIS_QUARTER
Display name: | Fiscal Quarter
Table owner: | SH
Table name: | TIMES

Mappings

Hierarchy | Table owner | Table | Column
FIS_ROLLUP | SH | TIMES | FISCAL_QUARTER_ID
Total: 1 mappings(s)

Attributes

Name | Display name | Description
DAYS_IN_FIS_QUARTER | Days in Fiscal Quarter | Number of Days in Fiscal Quarter
END_OF_FIS_QUARTER | End of Fiscal Quarter | Last Day of the Fiscal Quarter
FISCAL_QUARTER_DESC | Fiscal Quarter Description | Fiscal Quarter Description
FISCAL_QUARTER_NUMBER | Fiscal Quarter Number | Fiscal Quarter Number
Total: 4 attribute(s)

See Also

List of levels


List of attributes

Attribute

Name | Display name | Description
DAYS_IN_FIS_QUARTER | Days in Fiscal Quarter | Number of Days in Fiscal Quarter
END_OF_FIS_QUARTER | End of Fiscal Quarter | Last Day of the Fiscal Quarter
FISCAL_QUARTER_DESC | Fiscal Quarter Description | Fiscal Quarter Description
FISCAL_QUARTER_NUMBER | Fiscal Quarter Number | Fiscal Quarter Number
Total: 4 attribute(s)

See Also

Level [FIS_QUARTER]


Atribute: DAYS_IN_FIS_QUARTER in FIS_QUARTER

Properties

Name: | DAYS_IN_FIS_QUARTER
Display name: | Days in Fiscal Quarter
Description: | Number of Days in Fiscal Quarter

Mappings

Attribute | Hierarchy | Owner | Table | Column | Type
Period Number of Days | FIS_ROLLUP | SH | TIMES | DAYS_IN_FIS_QUARTER | NUMBER
Total: 1 mappings(s)

See Also

List of attributes


Atribute: END_OF_FIS_QUARTER in FIS_QUARTER

Properties

Name: | END_OF_FIS_QUARTER
Display name: | End of Fiscal Quarter
Description: | Last Day of the Fiscal Quarter

Mappings

Attribute | Hierarchy | Owner | Table | Column | Type
Period End Date | FIS_ROLLUP | SH | TIMES | END_OF_FIS_QUARTER | DATE
Total: 1 mappings(s)

See Also

List of attributes


Atribute: FISCAL_QUARTER_DESC in FIS_QUARTER

Properties

Name: | FISCAL_QUARTER_DESC
Display name: | Fiscal Quarter Description
Description: | Fiscal Quarter Description

Mappings

Attribute | Hierarchy | Owner | Table | Column | Type
Long Description | FIS_ROLLUP | SH | TIMES | FISCAL_QUARTER_DESC | CHAR
Short Description | FIS_ROLLUP | SH | TIMES | FISCAL_QUARTER_DESC | CHAR
Total: 2 mappings(s)

See Also

List of attributes


Atribute: FISCAL_QUARTER_NUMBER in FIS_QUARTER

Properties

Name: | FISCAL_QUARTER_NUMBER
Display name: | Fiscal Quarter Number
Description: | Fiscal Quarter Number

See Also

List of attributes


Level: FIS_WEEK in TIMES_DIM

Properties

Name: | FIS_WEEK
Display name: | Fiscal Week
Table owner: | SH
Table name: | TIMES

Mappings

Hierarchy | Table owner | Table | Column
FIS_ROLLUP | SH | TIMES | WEEK_ENDING_DAY_ID
Total: 1 mappings(s)

Attributes

Name | Display name | Description
FISCAL_WEEK_NUMBER | Fiscal Week Number | Fiscal Week Number
WEEK_ENDING_DAY | Fiscal Week Ending Day | Fiscal Week Ending Day
Total: 2 attribute(s)

See Also

List of levels


List of attributes

Attribute

Name | Display name | Description
FISCAL_WEEK_NUMBER | Fiscal Week Number | Fiscal Week Number
WEEK_ENDING_DAY | Fiscal Week Ending Day | Fiscal Week Ending Day
Total: 2 attribute(s)

See Also

Level [FIS_WEEK]


Atribute: FISCAL_WEEK_NUMBER in FIS_WEEK

Properties

Name: | FISCAL_WEEK_NUMBER
Display name: | Fiscal Week Number
Description: | Fiscal Week Number

See Also

List of attributes


Atribute: WEEK_ENDING_DAY in FIS_WEEK

Properties

Name: | WEEK_ENDING_DAY
Display name: | Fiscal Week Ending Day
Description: | Fiscal Week Ending Day

See Also

List of attributes


Level: FIS_YEAR in TIMES_DIM

Properties

Name: | FIS_YEAR
Display name: | Fiscal Year
Table owner: | SH
Table name: | TIMES

Mappings

Hierarchy | Table owner | Table | Column
FIS_ROLLUP | SH | TIMES | FISCAL_YEAR_ID
Total: 1 mappings(s)

Attributes

Name | Display name | Description
DAYS_IN_FIS_YEAR | Days in Fiscal Year | Number of Days in Fiscal Year
END_OF_FIS_YEAR | End of Fiscal Year | Last Day of the Fiscal Year
FISCAL_YEAR | Fiscal Year | Fiscal Year
Total: 3 attribute(s)

See Also

List of levels


List of attributes

Attribute

Name | Display name | Description
DAYS_IN_FIS_YEAR | Days in Fiscal Year | Number of Days in Fiscal Year
END_OF_FIS_YEAR | End of Fiscal Year | Last Day of the Fiscal Year
FISCAL_YEAR | Fiscal Year | Fiscal Year
Total: 3 attribute(s)

See Also

Level [FIS_YEAR]


Atribute: DAYS_IN_FIS_YEAR in FIS_YEAR

Properties

Name: | DAYS_IN_FIS_YEAR
Display name: | Days in Fiscal Year
Description: | Number of Days in Fiscal Year

Mappings

Attribute | Hierarchy | Owner | Table | Column | Type
Period Number of Days | FIS_ROLLUP | SH | TIMES | DAYS_IN_FIS_YEAR | NUMBER
Total: 1 mappings(s)

See Also

List of attributes


Atribute: END_OF_FIS_YEAR in FIS_YEAR

Properties

Name: | END_OF_FIS_YEAR
Display name: | End of Fiscal Year
Description: | Last Day of the Fiscal Year

Mappings

Attribute | Hierarchy | Owner | Table | Column | Type
Period End Date | FIS_ROLLUP | SH | TIMES | END_OF_FIS_YEAR | DATE
Total: 1 mappings(s)

See Also

List of attributes


Atribute: FISCAL_YEAR in FIS_YEAR

Properties

Name: | FISCAL_YEAR
Display name: | Fiscal Year
Description: | Fiscal Year

See Also

List of attributes


Level: MONTH in TIMES_DIM

Properties

Name: | MONTH
Display name: | Month
Table owner: | SH
Table name: | TIMES

Mappings

Hierarchy | Table owner | Table | Column
CAL_ROLLUP | SH | TIMES | CALENDAR_MONTH_ID
Total: 1 mappings(s)

Attributes

Name | Display name | Description
CALENDAR_MONTH_DESC | Calendar Month | Calendar Month Description
CALENDAR_MONTH_NAME | Calendar Month Name | Name of the Month
CALENDAR_MONTH_NUMBER | Calendar Month Number | Month Number in Calendar year where January is month number 1
DAYS_IN_CAL_MONTH | Days in Calendar Month | Number of Days in Calendar Month
END_OF_CAL_MONTH | End of Calendar Month | Last Day of the Calendar Month
Total: 5 attribute(s)

See Also

List of levels


List of attributes

Attribute

Name | Display name | Description
CALENDAR_MONTH_DESC | Calendar Month | Calendar Month Description
CALENDAR_MONTH_NAME | Calendar Month Name | Name of the Month
CALENDAR_MONTH_NUMBER | Calendar Month Number | Month Number in Calendar year where January is month number 1
DAYS_IN_CAL_MONTH | Days in Calendar Month | Number of Days in Calendar Month
END_OF_CAL_MONTH | End of Calendar Month | Last Day of the Calendar Month
Total: 5 attribute(s)

See Also

Level [MONTH]


Atribute: CALENDAR_MONTH_DESC in MONTH

Properties

Name: | CALENDAR_MONTH_DESC
Display name: | Calendar Month
Description: | Calendar Month Description

Mappings

Attribute | Hierarchy | Owner | Table | Column | Type
Long Description | CAL_ROLLUP | SH | TIMES | CALENDAR_MONTH_DESC | VARCHAR2
Short Description | CAL_ROLLUP | SH | TIMES | CALENDAR_MONTH_DESC | VARCHAR2
Total: 2 mappings(s)

See Also

List of attributes


Atribute: CALENDAR_MONTH_NAME in MONTH

Properties

Name: | CALENDAR_MONTH_NAME
Display name: | Calendar Month Name
Description: | Name of the Month

See Also

List of attributes


Atribute: CALENDAR_MONTH_NUMBER in MONTH

Properties

Name: | CALENDAR_MONTH_NUMBER
Display name: | Calendar Month Number
Description: | Month Number in Calendar year where January is month number 1

See Also

List of attributes


Atribute: DAYS_IN_CAL_MONTH in MONTH

Properties

Name: | DAYS_IN_CAL_MONTH
Display name: | Days in Calendar Month
Description: | Number of Days in Calendar Month

Mappings

Attribute | Hierarchy | Owner | Table | Column | Type
Period Number of Days | CAL_ROLLUP | SH | TIMES | DAYS_IN_CAL_MONTH | NUMBER
Total: 1 mappings(s)

See Also

List of attributes


Atribute: END_OF_CAL_MONTH in MONTH

Properties

Name: | END_OF_CAL_MONTH
Display name: | End of Calendar Month
Description: | Last Day of the Calendar Month

Mappings

Attribute | Hierarchy | Owner | Table | Column | Type
Period End Date | CAL_ROLLUP | SH | TIMES | END_OF_CAL_MONTH | DATE
Total: 1 mappings(s)

See Also

List of attributes


Level: QUARTER in TIMES_DIM

Properties

Name: | QUARTER
Display name: | Quarter
Table owner: | SH
Table name: | TIMES

Mappings

Hierarchy | Table owner | Table | Column
CAL_ROLLUP | SH | TIMES | CALENDAR_QUARTER_ID
Total: 1 mappings(s)

Attributes

Name | Display name | Description
CALENDAR_QUARTER_DESC | Calendar Quarter | Calendar Quarter Description
CALENDAR_QUARTER_NUMBER | Calendar Quarter Number | Calendar Quarter Number
DAYS_IN_CAL_QUARTER | Days in Calendar Quarter | Number of Days in Calendar Quarter
END_OF_CAL_QUARTER | End of Calendar Quarter | Last Day of the Calendar Quarter
Total: 4 attribute(s)

See Also

List of levels


List of attributes

Attribute

Name | Display name | Description
CALENDAR_QUARTER_DESC | Calendar Quarter | Calendar Quarter Description
CALENDAR_QUARTER_NUMBER | Calendar Quarter Number | Calendar Quarter Number
DAYS_IN_CAL_QUARTER | Days in Calendar Quarter | Number of Days in Calendar Quarter
END_OF_CAL_QUARTER | End of Calendar Quarter | Last Day of the Calendar Quarter
Total: 4 attribute(s)

See Also

Level [QUARTER]


Atribute: CALENDAR_QUARTER_DESC in QUARTER

Properties

Name: | CALENDAR_QUARTER_DESC
Display name: | Calendar Quarter
Description: | Calendar Quarter Description

Mappings

Attribute | Hierarchy | Owner | Table | Column | Type
Long Description | CAL_ROLLUP | SH | TIMES | CALENDAR_QUARTER_DESC | CHAR
Short Description | CAL_ROLLUP | SH | TIMES | CALENDAR_QUARTER_DESC | CHAR
Total: 2 mappings(s)

See Also

List of attributes


Atribute: CALENDAR_QUARTER_NUMBER in QUARTER

Properties

Name: | CALENDAR_QUARTER_NUMBER
Display name: | Calendar Quarter Number
Description: | Calendar Quarter Number

See Also

List of attributes


Atribute: DAYS_IN_CAL_QUARTER in QUARTER

Properties

Name: | DAYS_IN_CAL_QUARTER
Display name: | Days in Calendar Quarter
Description: | Number of Days in Calendar Quarter

Mappings

Attribute | Hierarchy | Owner | Table | Column | Type
Period Number of Days | CAL_ROLLUP | SH | TIMES | DAYS_IN_CAL_QUARTER | NUMBER
Total: 1 mappings(s)

See Also

List of attributes


Atribute: END_OF_CAL_QUARTER in QUARTER

Properties

Name: | END_OF_CAL_QUARTER
Display name: | End of Calendar Quarter
Description: | Last Day of the Calendar Quarter

Mappings

Attribute | Hierarchy | Owner | Table | Column | Type
Period End Date | CAL_ROLLUP | SH | TIMES | END_OF_CAL_QUARTER | DATE
Total: 1 mappings(s)

See Also

List of attributes


Level: YEAR in TIMES_DIM

Properties

Name: | YEAR
Display name: | Year
Table owner: | SH
Table name: | TIMES

Mappings

Hierarchy | Table owner | Table | Column
CAL_ROLLUP | SH | TIMES | CALENDAR_YEAR_ID
Total: 1 mappings(s)

Attributes

Name | Display name | Description
CALENDAR_YEAR | Calendar Year | Calendar Year
DAYS_IN_CAL_YEAR | Days in Calendar Year | Number of Days in Calendar Year
END_OF_CAL_YEAR | End of Calendar Year | Last Day of the Calendar Year
Total: 3 attribute(s)

See Also

List of levels


List of attributes

Attribute

Name | Display name | Description
CALENDAR_YEAR | Calendar Year | Calendar Year
DAYS_IN_CAL_YEAR | Days in Calendar Year | Number of Days in Calendar Year
END_OF_CAL_YEAR | End of Calendar Year | Last Day of the Calendar Year
Total: 3 attribute(s)

See Also

Level [YEAR]


Atribute: CALENDAR_YEAR in YEAR

Properties

Name: | CALENDAR_YEAR
Display name: | Calendar Year
Description: | Calendar Year

See Also

List of attributes


Atribute: DAYS_IN_CAL_YEAR in YEAR

Properties

Name: | DAYS_IN_CAL_YEAR
Display name: | Days in Calendar Year
Description: | Number of Days in Calendar Year

Mappings

Attribute | Hierarchy | Owner | Table | Column | Type
Period Number of Days | CAL_ROLLUP | SH | TIMES | DAYS_IN_CAL_YEAR | NUMBER
Total: 1 mappings(s)

See Also

List of attributes


Atribute: END_OF_CAL_YEAR in YEAR

Properties

Name: | END_OF_CAL_YEAR
Display name: | End of Calendar Year
Description: | Last Day of the Calendar Year

Mappings

Attribute | Hierarchy | Owner | Table | Column | Type
Period End Date | CAL_ROLLUP | SH | TIMES | END_OF_CAL_YEAR | DATE
Total: 1 mappings(s)

See Also

List of attributes


List of hierarchies

Hierarchies

Name | Display name | Description | Solved code
CAL_ROLLUP | Calendar Hierarchy | Calendar Hierarchy | UL
FIS_ROLLUP | Fiscal Hierarchy | Fiscal Hierarchy | UL
Total: 2 hierarchy(s)

See Also

Dimension [TIMES_DIM]


Hierarchy: CAL_ROLLUP in TIMES_DIM

Properties

Name: | CAL_ROLLUP
Display name: | Calendar Hierarchy
Description: | Calendar Hierarchy
Solved code: | UL

Levels

Name | Column | Parent level | Parent column
CHANNEL | SH.CHANNELS.CHANNEL_ID | CHANNEL_CLASS | SH.CHANNELS.CHANNEL_CLASS_ID
CHANNEL_CLASS | SH.CHANNELS.CHANNEL_CLASS_ID | CHANNEL_TOTAL | SH.CHANNELS.CHANNEL_TOTAL_ID
CHANNEL_TOTAL | SH.CHANNELS.CHANNEL_TOTAL_ID |  |
Total: 3 level(s)

See Also

List of hierarchies


Hierarchy: FIS_ROLLUP in TIMES_DIM

Properties

Name: | FIS_ROLLUP
Display name: | Fiscal Hierarchy
Description: | Fiscal Hierarchy
Solved code: | UL

Levels

Name | Column | Parent level | Parent column
CHANNEL | SH.CHANNELS.CHANNEL_ID | CHANNEL_CLASS | SH.CHANNELS.CHANNEL_CLASS_ID
CHANNEL_CLASS | SH.CHANNELS.CHANNEL_CLASS_ID | CHANNEL_TOTAL | SH.CHANNELS.CHANNEL_TOTAL_ID
CHANNEL_TOTAL | SH.CHANNELS.CHANNEL_TOTAL_ID |  |
Total: 3 level(s)

See Also

List of hierarchies


List of cubes

Cubes

Name | Valid | Display name | Fact Table Owner | Fact Table | Description
COST_CUBE |  | Cost Analysis | SH | COSTS | Unit Cost, Unit Price < TIMES PRODUCTS CHANNELS PROMOTIONS>
SALES_CUBE |  | Sales Analysis | SH | SALES | Sales amount, Sales quantity <TIMES CHANNELS PRODUCTS CUSTOMERS PROMOTIONS >
Total: 2 cube(s)

See Also

Schema overview


Cube: COST_CUBE

Properties

Name: | COST_CUBE
Valid: |
Display name: | Cost Analysis
Fact Table Owner: | SH
Fact Table: | COSTS
Description: | Unit Cost, Unit Price < TIMES PRODUCTS CHANNELS PROMOTIONS>
Summary code: | RU

Dimensions

Owner | Name | Alias | Default Hierarchy | Dipend on
SH | CHANNELS_DIM | CHANNELS_DIM |  |
SH | PRODUCTS_DIM | PRODUCTS_DIM | PROD_ROLLUP |
SH | PROMOTIONS_DIM | PROMOTIONS_DIM |  |
SH | TIMES_DIM | TIMES_DIM | CAL_ROLLUP |
Total: 4 dimension(s)

Measures

Name | Display name | Description | Fact table owner | Fact table name | Fact column
UNIT_COST | Cost | Unit Cost Amount | SH | COSTS | UNIT_COST
UNIT_PRICE | Price | Unit Price Amount | SH | COSTS | UNIT_PRICE
Total: 2 measures(s)

Join keys

Dimension | Hierarchy | Level | Owner | Table | Column | Foreign key | Keymap type
CHANNELS_DIM | CHANNEL_ROLLUP | CHANNEL | SH | COSTS | CHANNEL_ID | COSTS_CHANNEL_FK | LL
PRODUCTS_DIM | PROD_ROLLUP | PRODUCT | SH | COSTS | PROD_ID | COSTS_PRODUCT_FK | LL
PROMOTIONS_DIM | PROMO_ROLLUP | PROMO | SH | COSTS | PROMO_ID | COSTS_PROMO_FK | LL
TIMES_DIM | CAL_ROLLUP | DAY | SH | COSTS | TIME_ID | COSTS_TIME_FK | LL
TIMES_DIM | FIS_ROLLUP | DAY | SH | COSTS | TIME_ID | COSTS_TIME_FK | LL
Total: 5 join key(s)

See Also

List of cubes


List of measures

Measures

Name | Display name | Description | Fact table owner | Fact table name | Fact column
UNIT_COST | Cost | Unit Cost Amount | SH | COSTS | UNIT_COST
UNIT_PRICE | Price | Unit Price Amount | SH | COSTS | UNIT_PRICE
Total: 2 measure(s)

See Also

Cube [COST_CUBE]


Measure: UNIT_COST

Properties

Name: | UNIT_COST
Display name: | Cost
Description: | Unit Cost Amount
Fact table owner: | SH
Fact table name: | COSTS
Fact column: | UNIT_COST

Aggregation

Dimension | Operator
TIMES_DIM | SUM
Total: 1 aggregation(s)

See Also

List of measures


Measure: UNIT_PRICE

Properties

Name: | UNIT_PRICE
Display name: | Price
Description: | Unit Price Amount
Fact table owner: | SH
Fact table name: | COSTS
Fact column: | UNIT_PRICE

Aggregation

Dimension | Operator
TIMES_DIM | SUM
Total: 1 aggregation(s)

See Also

List of measures


Cube: SALES_CUBE

Properties

Name: | SALES_CUBE
Valid: |
Display name: | Sales Analysis
Fact Table Owner: | SH
Fact Table: | SALES
Description: | Sales amount, Sales quantity <TIMES CHANNELS PRODUCTS CUSTOMERS PROMOTIONS >
Summary code: | RU

Dimensions

Owner | Name | Alias | Default Hierarchy | Dipend on
SH | CHANNELS_DIM | CHANNELS_DIM | CHANNEL_ROLLUP |
SH | CUSTOMERS_DIM | CUSTOMERS_DIM | GEOG_ROLLUP |
SH | PRODUCTS_DIM | PRODUCTS_DIM | PROD_ROLLUP |
SH | PROMOTIONS_DIM | PROMOTIONS_DIM | PROMO_ROLLUP |
SH | TIMES_DIM | TIMES_DIM | CAL_ROLLUP |
Total: 5 dimension(s)

Measures

Name | Display name | Description | Fact table owner | Fact table name | Fact column
SALES_AMOUNT | Sales | Dollar Sales | SH | SALES | AMOUNT_SOLD
SALES_QUANTITY | Quantity | Quantity Sold | SH | SALES | QUANTITY_SOLD
Total: 2 measures(s)

Join keys

Dimension | Hierarchy | Level | Owner | Table | Column | Foreign key | Keymap type
CHANNELS_DIM | CHANNEL_ROLLUP | CHANNEL | SH | SALES | CHANNEL_ID | SALES_CHANNEL_FK | LL
CUSTOMERS_DIM | CUST_ROLLUP | CUSTOMER | SH | SALES | CUST_ID | SALES_CUSTOMER_FK | LL
CUSTOMERS_DIM | GEOG_ROLLUP | CUSTOMER | SH | SALES | CUST_ID | SALES_CUSTOMER_FK | LL
PRODUCTS_DIM | PROD_ROLLUP | PRODUCT | SH | SALES | PROD_ID | SALES_PRODUCT_FK | LL
PROMOTIONS_DIM | PROMO_ROLLUP | PROMO | SH | SALES | PROMO_ID | SALES_PROMO_FK | LL
TIMES_DIM | CAL_ROLLUP | DAY | SH | SALES | TIME_ID | SALES_TIME_FK | LL
TIMES_DIM | FIS_ROLLUP | DAY | SH | SALES | TIME_ID | SALES_TIME_FK | LL
Total: 7 join key(s)

See Also

List of cubes


List of measures

Measures

Name | Display name | Description | Fact table owner | Fact table name | Fact column
SALES_AMOUNT | Sales | Dollar Sales | SH | SALES | AMOUNT_SOLD
SALES_QUANTITY | Quantity | Quantity Sold | SH | SALES | QUANTITY_SOLD
Total: 2 measure(s)

See Also

Cube [SALES_CUBE]


Measure: SALES_AMOUNT

Properties

Name: | SALES_AMOUNT
Display name: | Sales
Description: | Dollar Sales
Fact table owner: | SH
Fact table name: | SALES
Fact column: | AMOUNT_SOLD

Aggregation

Dimension | Operator
TIMES_DIM | SUM
Total: 1 aggregation(s)

See Also

List of measures


Measure: SALES_QUANTITY

Properties

Name: | SALES_QUANTITY
Display name: | Quantity
Description: | Quantity Sold
Fact table owner: | SH
Fact table name: | SALES
Fact column: | QUANTITY_SOLD

Aggregation

Dimension | Operator
TIMES_DIM | SUM
Total: 1 aggregation(s)

See Also

List of measures


Server Info

Properties

Version: 10.2.0.1.0

Schemas

Schema
SH
Total: 1 schema(s)

Server Parameters

Name | Value | ISSYS_M | Default | SES_M | SYS_M | Description
active_instance_count |  |  |  |  |  | number of active instances in the cluster database
aq_tm_processes | 0 |  |  |  |  | number of AQ Time Managers to start
archive_lag_target | 0 |  |  |  |  | Maximum number of seconds of redos the standby could lose
asm_diskgroups |  |  |  |  |  | disk groups to mount automatically
asm_diskstring |  |  |  |  |  | disk set locations for discovery
asm_power_limit | 1 |  |  |  |  | number of processes for disk rebalancing
audit_file_dest | D:\ORACLE\PRODUCT\10.2.0\ADMIN\ORCL\ADUMP |  |  |  |  | Directory in which auditing files are to reside
audit_sys_operations | FALSE |  |  |  |  | enable sys auditing
audit_trail | NONE |  |  |  |  | enable system auditing
background_core_dump | partial |  |  |  |  | Core Size for Background Processes
background_dump_dest | D:\ORACLE\PRODUCT\10.2.0\ADMIN\ORCL\BDUMP |  |  |  |  | Detached process dump directory
backup_tape_io_slaves | FALSE |  |  |  |  | BACKUP Tape I/O slaves
bitmap_merge_area_size | 1048576 |  |  |  |  | maximum memory allow for BITMAP MERGE
blank_trimming | FALSE |  |  |  |  | blank trimming semantics parameter
buffer_pool_keep |  |  |  |  |  | Number of database blocks/latches in keep buffer pool
buffer_pool_recycle |  |  |  |  |  | Number of database blocks/latches in recycle buffer pool
circuits |  |  |  |  |  | max number of circuits
cluster_database | FALSE |  |  |  |  | if TRUE startup in cluster database mode
cluster_database_instances | 1 |  |  |  |  | number of instances to use for sizing cluster db SGA structures
cluster_interconnects |  |  |  |  |  | interconnects for RAC use
commit_point_strength | 1 |  |  |  |  | Bias this node has toward not preparing in a two-phase commit
commit_write |  |  |  |  |  | transaction commit log write behaviour
compatible | 10.2.0.1.0 |  |  |  |  | Database will be completely compatible with this software version
control_file_record_keep_time | 7 |  |  |  |  | control file record keep time in days
control_files | D:\ORACLE\PRODUCT\10.2.0\ORADATA\ORCL\CONTROL01.CTL, D:\ORACLE\PRODUCT\10.2.0\ORADATA\ORCL\CONTROL02.CTL, D:\ORACLE\PRODUCT\10.2.0\ORADATA\ORCL\CONTROL03.CTL |  |  |  |  | control file names list
core_dump_dest | D:\ORACLE\PRODUCT\10.2.0\ADMIN\ORCL\CDUMP |  |  |  |  | Core dump directory
cpu_count | 1 |  |  |  |  | number of CPUs for this instance
create_bitmap_area_size | 8388608 |  |  |  |  | size of create bitmap buffer for bitmap index
create_stored_outlines |  |  |  |  |  | create stored outlines for DML statements
cursor_sharing | EXACT |  |  |  |  | cursor sharing mode
cursor_space_for_time | FALSE |  |  |  |  | use more memory in order to get faster execution
db_block_buffers | 0 |  |  |  |  | Number of database blocks cached in memory
db_block_checking | FALSE |  |  |  |  | header checking and data and index block checking
db_block_checksum | TRUE |  |  |  |  | store checksum in db blocks and check during reads
db_block_size | 8192 |  |  |  |  | Size of database block in bytes
db_cache_advice | ON |  |  |  |  | Buffer cache sizing advisory
db_cache_size | 0 |  |  |  |  | Size of DEFAULT buffer pool for standard block size buffers
db_create_file_dest |  |  |  |  |  | default database location
db_create_online_log_dest_1 |  |  |  |  |  | online log/controlfile destination #1
db_create_online_log_dest_2 |  |  |  |  |  | online log/controlfile destination #2
db_create_online_log_dest_3 |  |  |  |  |  | online log/controlfile destination #3
db_create_online_log_dest_4 |  |  |  |  |  | online log/controlfile destination #4
db_create_online_log_dest_5 |  |  |  |  |  | online log/controlfile destination #5
db_domain |  |  |  |  |  | directory part of global database name stored with CREATE DATABASE
db_file_multiblock_read_count | 16 |  |  |  |  | db block to be read each IO
db_file_name_convert |  |  |  |  |  | datafile name convert patterns and strings for standby/clone db
db_files | 200 |  |  |  |  | max allowable # db files
db_flashback_retention_target | 1440 |  |  |  |  | Maximum Flashback Database log retention time in minutes.
db_keep_cache_size | 0 |  |  |  |  | Size of KEEP buffer pool for standard block size buffers
db_name | orcl |  |  |  |  | database name specified in CREATE DATABASE
db_recovery_file_dest | D:\oracle\product\10.2.0/flash_recovery_area |  |  |  |  | default database recovery file location
db_recovery_file_dest_size | 2147483648 |  |  |  |  | database recovery files size limit
db_recycle_cache_size | 0 |  |  |  |  | Size of RECYCLE buffer pool for standard block size buffers
db_unique_name | orcl |  |  |  |  | Database Unique Name
dbwr_io_slaves | 0 |  |  |  |  | DBWR I/O slaves
db_writer_processes | 1 |  |  |  |  | number of background database writer processes to start
db_16k_cache_size | 0 |  |  |  |  | Size of cache for 16K buffers
db_2k_cache_size | 0 |  |  |  |  | Size of cache for 2K buffers
db_32k_cache_size | 0 |  |  |  |  | Size of cache for 32K buffers
db_4k_cache_size | 0 |  |  |  |  | Size of cache for 4K buffers
db_8k_cache_size | 0 |  |  |  |  | Size of cache for 8K buffers
ddl_wait_for_locks | FALSE |  |  |  |  | Disable NOWAIT DML lock acquisitions
dg_broker_config_file1 | D:\ORACLE\PRODUCT\10.2.0\DB_1\DATABASE\DR1ORCL.DAT |  |  |  |  | data guard broker configuration file #1
dg_broker_config_file2 | D:\ORACLE\PRODUCT\10.2.0\DB_1\DATABASE\DR2ORCL.DAT |  |  |  |  | data guard broker configuration file #2
dg_broker_start | FALSE |  |  |  |  | start Data Guard broker framework (DMON process)
disk_asynch_io | TRUE |  |  |  |  | Use asynch I/O for random access devices
dispatchers | (PROTOCOL=TCP) (SERVICE=orclXDB) |  |  |  |  | specifications of dispatchers
distributed_lock_timeout | 60 |  |  |  |  | number of seconds a distributed transaction waits for a lock
dml_locks | 748 |  |  |  |  | dml locks - one for each table modified in a transaction
drs_start | FALSE |  |  |  |  | start DG Broker monitor (DMON process)
event |  |  |  |  |  | debug event control - default null string
fal_client |  |  |  |  |  | FAL client
fal_server |  |  |  |  |  | FAL server list
fast_start_io_target | 0 |  |  |  |  | Upper bound on recovery reads
fast_start_mttr_target | 0 |  |  |  |  | MTTR target of forward crash recovery in seconds
fast_start_parallel_rollback | LOW |  |  |  |  | max number of parallel recovery slaves that may be used
fileio_network_adapters |  |  |  |  |  | Network Adapters for File I/O
file_mapping | FALSE |  |  |  |  | enable file mapping
filesystemio_options |  |  |  |  |  | IO operations on filesystem files
fixed_date |  |  |  |  |  | fixed SYSDATE value
gc_files_to_locks |  |  |  |  |  | mapping between file numbers and global cache locks
gcs_server_processes | 0 |  |  |  |  | number of background gcs server processes to start
global_context_pool_size |  |  |  |  |  | Global Application Context Pool Size in Bytes
global_names | FALSE |  |  |  |  | enforce that database links have same name as remote database
hash_area_size | 131072 |  |  |  |  | size of in-memory hash work area
hi_shared_memory_address | 0 |  |  |  |  | SGA starting address (high order 32-bits on 64-bit platforms)
hs_autoregister | TRUE |  |  |  |  | enable automatic server DD updates in HS agent self-registration
ifile |  |  |  |  |  | include file in init.ora
instance_groups |  |  |  |  |  | list of instance group names
instance_name | orcl |  |  |  |  | instance name supported by the instance
instance_number | 0 |  |  |  |  | instance number
instance_type | RDBMS |  |  |  |  | type of instance to be executed
java_max_sessionspace_size | 0 |  |  |  |  | max allowed size in bytes of a Java sessionspace
java_pool_size | 0 |  |  |  |  | size in bytes of java pool
java_soft_sessionspace_limit | 0 |  |  |  |  | warning limit on size in bytes of a Java sessionspace
job_queue_processes | 10 |  |  |  |  | number of job queue slave processes
large_pool_size | 0 |  |  |  |  | size in bytes of large pool
ldap_directory_access | NONE |  |  |  |  | RDBMS's LDAP access option
license_max_sessions | 0 |  |  |  |  | maximum number of non-system user sessions allowed
license_max_users | 0 |  |  |  |  | maximum number of named users that can be created in the database
license_sessions_warning | 0 |  |  |  |  | warning level for number of non-system user sessions
local_listener |  |  |  |  |  | local listener
lock_name_space |  |  |  |  |  | lock name space used for generating lock names for standby/clone database
lock_sga | FALSE |  |  |  |  | Lock entire SGA in physical memory
log_archive_config |  |  |  |  |  | log archive config parameter
log_archive_dest |  |  |  |  |  | archival destination text string
log_archive_dest_state_1 | enable |  |  |  |  | archival destination #1 state text string
log_archive_dest_state_10 | enable |  |  |  |  | archival destination #10 state text string
log_archive_dest_state_2 | enable |  |  |  |  | archival destination #2 state text string
log_archive_dest_state_3 | enable |  |  |  |  | archival destination #3 state text string
log_archive_dest_state_4 | enable |  |  |  |  | archival destination #4 state text string
log_archive_dest_state_5 | enable |  |  |  |  | archival destination #5 state text string
log_archive_dest_state_6 | enable |  |  |  |  | archival destination #6 state text string
log_archive_dest_state_7 | enable |  |  |  |  | archival destination #7 state text string
log_archive_dest_state_8 | enable |  |  |  |  | archival destination #8 state text string
log_archive_dest_state_9 | enable |  |  |  |  | archival destination #9 state text string
log_archive_dest_1 |  |  |  |  |  | archival destination #1 text string
log_archive_dest_10 |  |  |  |  |  | archival destination #10 text string
log_archive_dest_2 |  |  |  |  |  | archival destination #2 text string
log_archive_dest_3 |  |  |  |  |  | archival destination #3 text string
log_archive_dest_4 |  |  |  |  |  | archival destination #4 text string
log_archive_dest_5 |  |  |  |  |  | archival destination #5 text string
log_archive_dest_6 |  |  |  |  |  | archival destination #6 text string
log_archive_dest_7 |  |  |  |  |  | archival destination #7 text string
log_archive_dest_8 |  |  |  |  |  | archival destination #8 text string
log_archive_dest_9 |  |  |  |  |  | archival destination #9 text string
log_archive_duplex_dest |  |  |  |  |  | duplex archival destination text string
log_archive_format | ARC%S_%R.%T |  |  |  |  | archival destination format
log_archive_local_first | TRUE |  |  |  |  | Establish EXPEDITE attribute default value
log_archive_max_processes | 2 |  |  |  |  | maximum number of active ARCH processes
log_archive_min_succeed_dest | 1 |  |  |  |  | minimum number of archive destinations that must succeed
log_archive_start | FALSE |  |  |  |  | start archival process on SGA initialization
log_archive_trace | 0 |  |  |  |  | Establish archivelog operation tracing level
log_buffer | 2899456 |  |  |  |  | redo circular buffer size
log_checkpoint_interval | 0 |  |  |  |  | # redo blocks checkpoint threshold
log_checkpoints_to_alert | FALSE |  |  |  |  | log checkpoint begin/end to alert file
log_checkpoint_timeout | 1800 |  |  |  |  | Maximum time interval between checkpoints in seconds
log_file_name_convert |  |  |  |  |  | logfile name convert patterns and strings for standby/clone db
logmnr_max_persistent_sessions | 1 |  |  |  |  | maximum number of threads to mine
max_commit_propagation_delay | 0 |  |  |  |  | Max age of new snapshot in .01 seconds
max_dispatchers |  |  |  |  |  | max number of dispatchers
max_dump_file_size | UNLIMITED |  |  |  |  | Maximum size (blocks) of dump file
max_enabled_roles | 150 |  |  |  |  | max number of roles a user can have enabled
max_shared_servers |  |  |  |  |  | max number of shared servers
object_cache_max_size_percent | 10 |  |  |  |  | percentage of maximum size over optimal of the user session's object cache
object_cache_optimal_size | 102400 |  |  |  |  | optimal size of the user session's object cache in bytes
olap_page_pool_size | 0 |  |  |  |  | size of the olap page pool in bytes
open_cursors | 300 |  |  |  |  | max # cursors per session
open_links | 4 |  |  |  |  | max # open links per session
open_links_per_instance | 4 |  |  |  |  | max # open links per instance
optimizer_dynamic_sampling | 2 |  |  |  |  | optimizer dynamic sampling
optimizer_features_enable | 10.2.0.1 |  |  |  |  | optimizer plan compatibility parameter
optimizer_index_caching | 0 |  |  |  |  | optimizer percent index caching
optimizer_index_cost_adj | 100 |  |  |  |  | optimizer index cost adjustment
optimizer_mode | ALL_ROWS |  |  |  |  | optimizer mode
optimizer_secure_view_merging | TRUE |  |  |  |  | optimizer secure view merging and predicate pushdown/movearound
os_authent_prefix | OPS$ |  |  |  |  | prefix for auto-logon accounts
os_roles | FALSE |  |  |  |  | retrieve roles from the operating system
O7_DICTIONARY_ACCESSIBILITY | FALSE |  |  |  |  | Version 7 Dictionary Accessibility Support
parallel_adaptive_multi_user | TRUE |  |  |  |  | enable adaptive setting of degree for multiple user streams
parallel_automatic_tuning | FALSE |  |  |  |  | enable intelligent defaults for parallel execution parameters
parallel_execution_message_size | 2148 |  |  |  |  | message buffer size for parallel execution
parallel_instance_group |  |  |  |  |  | instance group to use for all parallel operations
parallel_max_servers | 20 |  |  |  |  | maximum parallel query servers per instance
parallel_min_percent | 0 |  |  |  |  | minimum percent of threads required for parallel query
parallel_min_servers | 0 |  |  |  |  | minimum parallel query servers per instance
parallel_server | FALSE |  |  |  |  | if TRUE startup in parallel server mode
parallel_server_instances | 1 |  |  |  |  | number of instances to use for sizing OPS SGA structures
parallel_threads_per_cpu | 2 |  |  |  |  | number of parallel execution threads per CPU
pga_aggregate_target | 16777216 |  |  |  |  | Target size for the aggregate PGA memory consumed by the instance
plsql_ccflags |  |  |  |  |  | PL/SQL ccflags
plsql_code_type | INTERPRETED |  |  |  |  | PL/SQL code-type
plsql_compiler_flags | INTERPRETED, NON_DEBUG |  |  |  |  | PL/SQL compiler flags
plsql_debug | FALSE |  |  |  |  | PL/SQL debug
plsql_native_library_dir |  |  |  |  |  | plsql native library dir
plsql_native_library_subdir_count | 0 |  |  |  |  | plsql native library number of subdirectories
plsql_optimize_level | 2 |  |  |  |  | PL/SQL optimize level
plsql_v2_compatibility | FALSE |  |  |  |  | PL/SQL version 2.x compatibility flag
plsql_warnings | DISABLE:ALL |  |  |  |  | PL/SQL compiler warnings settings
pre_page_sga | FALSE |  |  |  |  | pre-page sga for process
processes | 150 |  |  |  |  | user processes
query_rewrite_enabled | TRUE |  |  |  |  | allow rewrite of queries using materialized views if enabled
query_rewrite_integrity | enforced |  |  |  |  | perform rewrite using materialized views with desired integrity
rdbms_server_dn |  |  |  |  |  | RDBMS's Distinguished Name
read_only_open_delayed | FALSE |  |  |  |  | if TRUE delay opening of read only files until first access
recovery_parallelism | 0 |  |  |  |  | number of server processes to use for parallel recovery
recyclebin | on |  |  |  |  | recyclebin processing
remote_archive_enable | true |  |  |  |  | remote archival enable setting
remote_dependencies_mode | TIMESTAMP |  |  |  |  | remote-procedure-call dependencies mode parameter
remote_listener |  |  |  |  |  | remote listener
remote_login_passwordfile | EXCLUSIVE |  |  |  |  | password file usage parameter
remote_os_authent | FALSE |  |  |  |  | allow non-secure remote clients to use auto-logon accounts
remote_os_roles | FALSE |  |  |  |  | allow non-secure remote clients to use os roles
replication_dependency_tracking | TRUE |  |  |  |  | tracking dependency for Replication parallel propagation
resource_limit | FALSE |  |  |  |  | master switch for resource limit
resource_manager_plan |  |  |  |  |  | resource mgr top plan
resumable_timeout | 0 |  |  |  |  | set resumable_timeout
rollback_segments |  |  |  |  |  | undo segment list
serial_reuse | disable |  |  |  |  | reuse the frame segments
service_names | orcl |  |  |  |  | service names supported by the instance
session_cached_cursors | 20 |  |  |  |  | Number of cursors to cache in a session.
session_max_open_files | 10 |  |  |  |  | maximum number of open files allowed per session
sessions | 170 |  |  |  |  | user and system sessions
sga_max_size | 167772160 |  |  |  |  | max total SGA size
sga_target | 167772160 |  |  |  |  | Target size of SGA
shadow_core_dump | partial |  |  |  |  | Core Size for Shadow Processes
shared_memory_address | 0 |  |  |  |  | SGA starting address (low order 32-bits on 64-bit platforms)
shared_pool_reserved_size | 3565158 |  |  |  |  | size in bytes of reserved area of shared pool
shared_pool_size | 0 |  |  |  |  | size in bytes of shared pool
shared_servers | 1 |  |  |  |  | number of shared servers to start up
shared_server_sessions |  |  |  |  |  | max number of shared server sessions
skip_unusable_indexes | TRUE |  |  |  |  | skip unusable indexes if set to TRUE
smtp_out_server |  |  |  |  |  | utl_smtp server and port configuration parameter
sort_area_retained_size | 0 |  |  |  |  | size of in-memory sort work area retained between fetch calls
sort_area_size | 65536 |  |  |  |  | size of in-memory sort work area
spfile | D:\ORACLE\PRODUCT\10.2.0\DB_1\DBS\SPFILEORCL.ORA |  |  |  |  | server parameter file
sql_trace | FALSE |  |  |  |  | enable SQL trace
sqltune_category | DEFAULT |  |  |  |  | Category qualifier for applying hintsets
sql_version | NATIVE |  |  |  |  | sql language version parameter for compatibility issues
sql92_security | FALSE |  |  |  |  | require select privilege for searched update/delete
standby_archive_dest | %ORACLE_HOME%\RDBMS |  |  |  |  | standby database archivelog destination text string
standby_file_management | MANUAL |  |  |  |  | if auto then files are created/dropped automatically on standby
star_transformation_enabled | FALSE |  |  |  |  | enable the use of star transformation
statistics_level | TYPICAL |  |  |  |  | statistics level
streams_pool_size | 0 |  |  |  |  | size in bytes of the streams pool
tape_asynch_io | TRUE |  |  |  |  | Use asynch I/O requests for tape devices
thread | 0 |  |  |  |  | Redo thread to mount
timed_os_statistics | 0 |  |  |  |  | internal os statistic gathering interval in seconds
timed_statistics | TRUE |  |  |  |  | maintain internal timing statistics
trace_enabled | TRUE |  |  |  |  | enable KST tracing
tracefile_identifier |  |  |  |  |  | trace file custom identifier
transactions | 187 |  |  |  |  | max. number of concurrent active transactions
transactions_per_rollback_segment | 5 |  |  |  |  | number of active transactions per rollback segment
undo_management | AUTO |  |  |  |  | instance runs in SMU mode if TRUE, else in RBU mode
undo_retention | 900 |  |  |  |  | undo retention in seconds
undo_tablespace | UNDOTBS1 |  |  |  |  | use/switch undo tablespace
use_indirect_data_buffers | FALSE |  |  |  |  | Enable indirect data buffers (very large SGA on 32-bit platforms)
user_dump_dest | D:\ORACLE\PRODUCT\10.2.0\ADMIN\ORCL\UDUMP |  |  |  |  | User process dump directory
utl_file_dir |  |  |  |  |  | utl_file accessible directories list
workarea_size_policy | AUTO |  |  |  |  | policy used to size SQL working areas (MANUAL/AUTO)


About

Documentation details

Customer: |
Project: |
Created: | 04.03.2007