Database: postgres

Properties

Name: | postgres
Owner: | postgres
Encoding: | SQL_ASCII
Template: |
Allows connections: |
Max connections: | unlimited
Tablespace: | pg_default
Session config: |
Default schema: |
Comment: | 1

Schemas

Name | Owner | System | Comment
pg_toast | postgres |  | Reserved schema for TOAST tables
public | postgres |  | Standard public schema
information_schema | postgres |  |
Total: 3 schema(s)

See Also

List of databases


List of schemas

Schemas

Name | Owner | System | Comment
pg_toast | postgres |  | Reserved schema for TOAST tables
public | postgres |  | Standard public schema
information_schema | postgres |  |
Total: 3 schema(s)

See Also

Database overview


Schema: pg_toast

Properties

Name: | pg_toast
Owner: | postgres
System: |
Comment: | Reserved schema for TOAST tables

Domains

Name | Comment
domain1 | test domain
rrr |
Total: 2 domain(s)

Tables

Name | Owner | Tablespace | Comment
pg_toast_10737 | postgres |  |
pg_toast_10742 | postgres |  |
pg_toast_10747 | postgres |  |
pg_toast_10752 | postgres |  |
pg_toast_10757 | postgres |  |
pg_toast_10762 | postgres |  |
pg_toast_10767 | postgres |  |
pg_toast_1255 | postgres |  |
pg_toast_1260 | postgres | pg_global |
pg_toast_1262 | postgres | pg_global |
pg_toast_2396 | postgres | pg_global |
pg_toast_2604 | postgres |  |
pg_toast_2606 | postgres |  |
pg_toast_2609 | postgres |  |
pg_toast_2618 | postgres |  |
pg_toast_2619 | postgres |  |
Total: 16 table(s)

Types

Name | Owner | Comment
pg_toast_10737 | postgres |
pg_toast_10742 | postgres |
pg_toast_10747 | postgres |
pg_toast_10752 | postgres |
pg_toast_10757 | postgres |
pg_toast_10762 | postgres |
pg_toast_10767 | postgres |
pg_toast_1255 | postgres |
pg_toast_1260 | postgres |
pg_toast_1262 | postgres |
pg_toast_2396 | postgres |
pg_toast_2604 | postgres |
pg_toast_2606 | postgres |
pg_toast_2609 | postgres |
pg_toast_2618 | postgres |
pg_toast_2619 | postgres |
Total: 16 type(s)

See Also

List of schemas


List of domains

domains

Name | Owner | Comment
domain1 | postgres | test domain
rrr | postgres |
Total: 2 domain(s)

See Also

Schema overview


Domain: domain1

Properties

Name: | domain1
OID: | 16449
Owner: | postgres
Base type: | bigint
Default: | 1
Check: |
Not Null: |
Comment: | test domain

SQL

See Also

List of domains


Domain: rrr

Properties

Name: | rrr
OID: | 16450
Owner: | postgres
Base type: | integer
Default: | 34
Check: | CHECK ((VALUE > 33))
Not Null: |
Comment: |

SQL

See Also

List of domains


List of tables

Tables

Name | Owner | Tablespace | Comment
pg_toast_10737 | postgres |  |
pg_toast_10742 | postgres |  |
pg_toast_10747 | postgres |  |
pg_toast_10752 | postgres |  |
pg_toast_10757 | postgres |  |
pg_toast_10762 | postgres |  |
pg_toast_10767 | postgres |  |
pg_toast_1255 | postgres |  |
pg_toast_1260 | postgres | pg_global |
pg_toast_1262 | postgres | pg_global |
pg_toast_2396 | postgres | pg_global |
pg_toast_2604 | postgres |  |
pg_toast_2606 | postgres |  |
pg_toast_2609 | postgres |  |
pg_toast_2618 | postgres |  |
pg_toast_2619 | postgres |  |
Total: 16 tables(s)

See Also

Schema overview


Table: pg_toast_10737

Properties

Name: | pg_toast_10737
Owner: | postgres
Tablespace: |
Has indexes: |
Has rules: |
Has triggers: |
Inherited Tables Count: | 0
Comment: |

Columns

Name | Type | Length | Default value | Comment
tableoid | oid | -1 |  |
cmax | cid | -1 |  |
xmax | xid | -1 |  |
cmin | cid | -1 |  |
xmin | xid | -1 |  |
ctid | tid | -1 |  |
chunk_id | oid | -1 |  |
chunk_seq | int4 | -1 |  |
chunk_data | bytea | -1 |  |
Total: 9 column(s)

Indexes

Name | Unique | Primary key | Clustered
pg_toast_10737_index |  |  |
Total: 1 index(es)

SQL

See Also

List of tables


List of indexes

Indexes

Name | Unique | Primary key | Clustered
pg_toast_10737_index |  |  |
Total: 1 index(es)

See Also

Table overview


Index: pg_toast_10737_index

Properties

Name: | pg_toast_10737_index
Unique: |
Primary key: |
Clustered: |
Internar expression tree: |
Internar predicate tree: |

Columns

Name
chunk_id
chunk_seq
Total: 2 index column(s)

SQL

See Also

List of indexes


Table: pg_toast_10742

Properties

Name: | pg_toast_10742
Owner: | postgres
Tablespace: |
Has indexes: |
Has rules: |
Has triggers: |
Inherited Tables Count: | 0
Comment: |

Columns

Name | Type | Length | Default value | Comment
tableoid | oid | -1 |  |
cmax | cid | -1 |  |
xmax | xid | -1 |  |
cmin | cid | -1 |  |
xmin | xid | -1 |  |
ctid | tid | -1 |  |
chunk_id | oid | -1 |  |
chunk_seq | int4 | -1 |  |
chunk_data | bytea | -1 |  |
Total: 9 column(s)

Indexes

Name | Unique | Primary key | Clustered
pg_toast_10742_index |  |  |
Total: 1 index(es)

SQL

See Also

List of tables


List of indexes

Indexes

Name | Unique | Primary key | Clustered
pg_toast_10742_index |  |  |
Total: 1 index(es)

See Also

Table overview


Index: pg_toast_10742_index

Properties

Name: | pg_toast_10742_index
Unique: |
Primary key: |
Clustered: |
Internar expression tree: |
Internar predicate tree: |

Columns

Name
chunk_id
chunk_seq
Total: 2 index column(s)

SQL

See Also

List of indexes


Table: pg_toast_10747

Properties

Name: | pg_toast_10747
Owner: | postgres
Tablespace: |
Has indexes: |
Has rules: |
Has triggers: |
Inherited Tables Count: | 0
Comment: |

Columns

Name | Type | Length | Default value | Comment
tableoid | oid | -1 |  |
cmax | cid | -1 |  |
xmax | xid | -1 |  |
cmin | cid | -1 |  |
xmin | xid | -1 |  |
ctid | tid | -1 |  |
chunk_id | oid | -1 |  |
chunk_seq | int4 | -1 |  |
chunk_data | bytea | -1 |  |
Total: 9 column(s)

Indexes

Name | Unique | Primary key | Clustered
pg_toast_10747_index |  |  |
Total: 1 index(es)

SQL

See Also

List of tables


List of indexes

Indexes

Name | Unique | Primary key | Clustered
pg_toast_10747_index |  |  |
Total: 1 index(es)

See Also

Table overview


Index: pg_toast_10747_index

Properties

Name: | pg_toast_10747_index
Unique: |
Primary key: |
Clustered: |
Internar expression tree: |
Internar predicate tree: |

Columns

Name
chunk_id
chunk_seq
Total: 2 index column(s)

SQL

See Also

List of indexes


Table: pg_toast_10752

Properties

Name: | pg_toast_10752
Owner: | postgres
Tablespace: |
Has indexes: |
Has rules: |
Has triggers: |
Inherited Tables Count: | 0
Comment: |

Columns

Name | Type | Length | Default value | Comment
tableoid | oid | -1 |  |
cmax | cid | -1 |  |
xmax | xid | -1 |  |
cmin | cid | -1 |  |
xmin | xid | -1 |  |
ctid | tid | -1 |  |
chunk_id | oid | -1 |  |
chunk_seq | int4 | -1 |  |
chunk_data | bytea | -1 |  |
Total: 9 column(s)

Indexes

Name | Unique | Primary key | Clustered
pg_toast_10752_index |  |  |
Total: 1 index(es)

SQL

See Also

List of tables


List of indexes

Indexes

Name | Unique | Primary key | Clustered
pg_toast_10752_index |  |  |
Total: 1 index(es)

See Also

Table overview


Index: pg_toast_10752_index

Properties

Name: | pg_toast_10752_index
Unique: |
Primary key: |
Clustered: |
Internar expression tree: |
Internar predicate tree: |

Columns

Name
chunk_id
chunk_seq
Total: 2 index column(s)

SQL

See Also

List of indexes


Table: pg_toast_10757

Properties

Name: | pg_toast_10757
Owner: | postgres
Tablespace: |
Has indexes: |
Has rules: |
Has triggers: |
Inherited Tables Count: | 0
Comment: |

Columns

Name | Type | Length | Default value | Comment
tableoid | oid | -1 |  |
cmax | cid | -1 |  |
xmax | xid | -1 |  |
cmin | cid | -1 |  |
xmin | xid | -1 |  |
ctid | tid | -1 |  |
chunk_id | oid | -1 |  |
chunk_seq | int4 | -1 |  |
chunk_data | bytea | -1 |  |
Total: 9 column(s)

Indexes

Name | Unique | Primary key | Clustered
pg_toast_10757_index |  |  |
Total: 1 index(es)

SQL

See Also

List of tables


List of indexes

Indexes

Name | Unique | Primary key | Clustered
pg_toast_10757_index |  |  |
Total: 1 index(es)

See Also

Table overview


Index: pg_toast_10757_index

Properties

Name: | pg_toast_10757_index
Unique: |
Primary key: |
Clustered: |
Internar expression tree: |
Internar predicate tree: |

Columns

Name
chunk_id
chunk_seq
Total: 2 index column(s)

SQL

See Also

List of indexes


Table: pg_toast_10762

Properties

Name: | pg_toast_10762
Owner: | postgres
Tablespace: |
Has indexes: |
Has rules: |
Has triggers: |
Inherited Tables Count: | 0
Comment: |

Columns

Name | Type | Length | Default value | Comment
tableoid | oid | -1 |  |
cmax | cid | -1 |  |
xmax | xid | -1 |  |
cmin | cid | -1 |  |
xmin | xid | -1 |  |
ctid | tid | -1 |  |
chunk_id | oid | -1 |  |
chunk_seq | int4 | -1 |  |
chunk_data | bytea | -1 |  |
Total: 9 column(s)

Indexes

Name | Unique | Primary key | Clustered
pg_toast_10762_index |  |  |
Total: 1 index(es)

SQL

See Also

List of tables


List of indexes

Indexes

Name | Unique | Primary key | Clustered
pg_toast_10762_index |  |  |
Total: 1 index(es)

See Also

Table overview


Index: pg_toast_10762_index

Properties

Name: | pg_toast_10762_index
Unique: |
Primary key: |
Clustered: |
Internar expression tree: |
Internar predicate tree: |

Columns

Name
chunk_id
chunk_seq
Total: 2 index column(s)

SQL

See Also

List of indexes


Table: pg_toast_10767

Properties

Name: | pg_toast_10767
Owner: | postgres
Tablespace: |
Has indexes: |
Has rules: |
Has triggers: |
Inherited Tables Count: | 0
Comment: |

Columns

Name | Type | Length | Default value | Comment
tableoid | oid | -1 |  |
cmax | cid | -1 |  |
xmax | xid | -1 |  |
cmin | cid | -1 |  |
xmin | xid | -1 |  |
ctid | tid | -1 |  |
chunk_id | oid | -1 |  |
chunk_seq | int4 | -1 |  |
chunk_data | bytea | -1 |  |
Total: 9 column(s)

Indexes

Name | Unique | Primary key | Clustered
pg_toast_10767_index |  |  |
Total: 1 index(es)

SQL

See Also

List of tables


List of indexes

Indexes

Name | Unique | Primary key | Clustered
pg_toast_10767_index |  |  |
Total: 1 index(es)

See Also

Table overview


Index: pg_toast_10767_index

Properties

Name: | pg_toast_10767_index
Unique: |
Primary key: |
Clustered: |
Internar expression tree: |
Internar predicate tree: |

Columns

Name
chunk_id
chunk_seq
Total: 2 index column(s)

SQL

See Also

List of indexes


Table: pg_toast_1255

Properties

Name: | pg_toast_1255
Owner: | postgres
Tablespace: |
Has indexes: |
Has rules: |
Has triggers: |
Inherited Tables Count: | 0
Comment: |

Columns

Name | Type | Length | Default value | Comment
tableoid | oid | -1 |  |
cmax | cid | -1 |  |
xmax | xid | -1 |  |
cmin | cid | -1 |  |
xmin | xid | -1 |  |
ctid | tid | -1 |  |
chunk_id | oid | -1 |  |
chunk_seq | int4 | -1 |  |
chunk_data | bytea | -1 |  |
Total: 9 column(s)

Indexes

Name | Unique | Primary key | Clustered
pg_toast_1255_index |  |  |
Total: 1 index(es)

SQL

See Also

List of tables


List of indexes

Indexes

Name | Unique | Primary key | Clustered
pg_toast_1255_index |  |  |
Total: 1 index(es)

See Also

Table overview


Index: pg_toast_1255_index

Properties

Name: | pg_toast_1255_index
Unique: |
Primary key: |
Clustered: |
Internar expression tree: |
Internar predicate tree: |

Columns

Name
chunk_id
chunk_seq
Total: 2 index column(s)

SQL

See Also

List of indexes


Table: pg_toast_1260

Properties

Name: | pg_toast_1260
Owner: | postgres
Tablespace: | pg_global
Has indexes: |
Has rules: |
Has triggers: |
Inherited Tables Count: | 0
Comment: |

Columns

Name | Type | Length | Default value | Comment
tableoid | oid | -1 |  |
cmax | cid | -1 |  |
xmax | xid | -1 |  |
cmin | cid | -1 |  |
xmin | xid | -1 |  |
ctid | tid | -1 |  |
chunk_id | oid | -1 |  |
chunk_seq | int4 | -1 |  |
chunk_data | bytea | -1 |  |
Total: 9 column(s)

Indexes

Name | Unique | Primary key | Clustered
pg_toast_1260_index |  |  |
Total: 1 index(es)

SQL

See Also

List of tables


List of indexes

Indexes

Name | Unique | Primary key | Clustered
pg_toast_1260_index |  |  |
Total: 1 index(es)

See Also

Table overview


Index: pg_toast_1260_index

Properties

Name: | pg_toast_1260_index
Unique: |
Primary key: |
Clustered: |
Internar expression tree: |
Internar predicate tree: |

Columns

Name
chunk_id
chunk_seq
Total: 2 index column(s)

SQL

See Also

List of indexes


Table: pg_toast_1262

Properties

Name: | pg_toast_1262
Owner: | postgres
Tablespace: | pg_global
Has indexes: |
Has rules: |
Has triggers: |
Inherited Tables Count: | 0
Comment: |

Columns

Name | Type | Length | Default value | Comment
tableoid | oid | -1 |  |
cmax | cid | -1 |  |
xmax | xid | -1 |  |
cmin | cid | -1 |  |
xmin | xid | -1 |  |
ctid | tid | -1 |  |
chunk_id | oid | -1 |  |
chunk_seq | int4 | -1 |  |
chunk_data | bytea | -1 |  |
Total: 9 column(s)

Indexes

Name | Unique | Primary key | Clustered
pg_toast_1262_index |  |  |
Total: 1 index(es)

SQL

See Also

List of tables


List of indexes

Indexes

Name | Unique | Primary key | Clustered
pg_toast_1262_index |  |  |
Total: 1 index(es)

See Also

Table overview


Index: pg_toast_1262_index

Properties

Name: | pg_toast_1262_index
Unique: |
Primary key: |
Clustered: |
Internar expression tree: |
Internar predicate tree: |

Columns

Name
chunk_id
chunk_seq
Total: 2 index column(s)

SQL

See Also

List of indexes


Table: pg_toast_2396

Properties

Name: | pg_toast_2396
Owner: | postgres
Tablespace: | pg_global
Has indexes: |
Has rules: |
Has triggers: |
Inherited Tables Count: | 0
Comment: |

Columns

Name | Type | Length | Default value | Comment
tableoid | oid | -1 |  |
cmax | cid | -1 |  |
xmax | xid | -1 |  |
cmin | cid | -1 |  |
xmin | xid | -1 |  |
ctid | tid | -1 |  |
chunk_id | oid | -1 |  |
chunk_seq | int4 | -1 |  |
chunk_data | bytea | -1 |  |
Total: 9 column(s)

Indexes

Name | Unique | Primary key | Clustered
pg_toast_2396_index |  |  |
Total: 1 index(es)

SQL

See Also

List of tables


List of indexes

Indexes

Name | Unique | Primary key | Clustered
pg_toast_2396_index |  |  |
Total: 1 index(es)

See Also

Table overview


Index: pg_toast_2396_index

Properties

Name: | pg_toast_2396_index
Unique: |
Primary key: |
Clustered: |
Internar expression tree: |
Internar predicate tree: |

Columns

Name
chunk_id
chunk_seq
Total: 2 index column(s)

SQL

See Also

List of indexes


Table: pg_toast_2604

Properties

Name: | pg_toast_2604
Owner: | postgres
Tablespace: |
Has indexes: |
Has rules: |
Has triggers: |
Inherited Tables Count: | 0
Comment: |

Columns

Name | Type | Length | Default value | Comment
tableoid | oid | -1 |  |
cmax | cid | -1 |  |
xmax | xid | -1 |  |
cmin | cid | -1 |  |
xmin | xid | -1 |  |
ctid | tid | -1 |  |
chunk_id | oid | -1 |  |
chunk_seq | int4 | -1 |  |
chunk_data | bytea | -1 |  |
Total: 9 column(s)

Indexes

Name | Unique | Primary key | Clustered
pg_toast_2604_index |  |  |
Total: 1 index(es)

SQL

See Also

List of tables


List of indexes

Indexes

Name | Unique | Primary key | Clustered
pg_toast_2604_index |  |  |
Total: 1 index(es)

See Also

Table overview


Index: pg_toast_2604_index

Properties

Name: | pg_toast_2604_index
Unique: |
Primary key: |
Clustered: |
Internar expression tree: |
Internar predicate tree: |

Columns

Name
chunk_id
chunk_seq
Total: 2 index column(s)

SQL

See Also

List of indexes


Table: pg_toast_2606

Properties

Name: | pg_toast_2606
Owner: | postgres
Tablespace: |
Has indexes: |
Has rules: |
Has triggers: |
Inherited Tables Count: | 0
Comment: |

Columns

Name | Type | Length | Default value | Comment
tableoid | oid | -1 |  |
cmax | cid | -1 |  |
xmax | xid | -1 |  |
cmin | cid | -1 |  |
xmin | xid | -1 |  |
ctid | tid | -1 |  |
chunk_id | oid | -1 |  |
chunk_seq | int4 | -1 |  |
chunk_data | bytea | -1 |  |
Total: 9 column(s)

Indexes

Name | Unique | Primary key | Clustered
pg_toast_2606_index |  |  |
Total: 1 index(es)

SQL

See Also

List of tables


List of indexes

Indexes

Name | Unique | Primary key | Clustered
pg_toast_2606_index |  |  |
Total: 1 index(es)

See Also

Table overview


Index: pg_toast_2606_index

Properties

Name: | pg_toast_2606_index
Unique: |
Primary key: |
Clustered: |
Internar expression tree: |
Internar predicate tree: |

Columns

Name
chunk_id
chunk_seq
Total: 2 index column(s)

SQL

See Also

List of indexes


Table: pg_toast_2609

Properties

Name: | pg_toast_2609
Owner: | postgres
Tablespace: |
Has indexes: |
Has rules: |
Has triggers: |
Inherited Tables Count: | 0
Comment: |

Columns

Name | Type | Length | Default value | Comment
tableoid | oid | -1 |  |
cmax | cid | -1 |  |
xmax | xid | -1 |  |
cmin | cid | -1 |  |
xmin | xid | -1 |  |
ctid | tid | -1 |  |
chunk_id | oid | -1 |  |
chunk_seq | int4 | -1 |  |
chunk_data | bytea | -1 |  |
Total: 9 column(s)

Indexes

Name | Unique | Primary key | Clustered
pg_toast_2609_index |  |  |
Total: 1 index(es)

SQL

See Also

List of tables


List of indexes

Indexes

Name | Unique | Primary key | Clustered
pg_toast_2609_index |  |  |
Total: 1 index(es)

See Also

Table overview


Index: pg_toast_2609_index

Properties

Name: | pg_toast_2609_index
Unique: |
Primary key: |
Clustered: |
Internar expression tree: |
Internar predicate tree: |

Columns

Name
chunk_id
chunk_seq
Total: 2 index column(s)

SQL

See Also

List of indexes


Table: pg_toast_2618

Properties

Name: | pg_toast_2618
Owner: | postgres
Tablespace: |
Has indexes: |
Has rules: |
Has triggers: |
Inherited Tables Count: | 0
Comment: |

Columns

Name | Type | Length | Default value | Comment
tableoid | oid | -1 |  |
cmax | cid | -1 |  |
xmax | xid | -1 |  |
cmin | cid | -1 |  |
xmin | xid | -1 |  |
ctid | tid | -1 |  |
chunk_id | oid | -1 |  |
chunk_seq | int4 | -1 |  |
chunk_data | bytea | -1 |  |
Total: 9 column(s)

Indexes

Name | Unique | Primary key | Clustered
pg_toast_2618_index |  |  |
Total: 1 index(es)

SQL

See Also

List of tables


List of indexes

Indexes

Name | Unique | Primary key | Clustered
pg_toast_2618_index |  |  |
Total: 1 index(es)

See Also

Table overview


Index: pg_toast_2618_index

Properties

Name: | pg_toast_2618_index
Unique: |
Primary key: |
Clustered: |
Internar expression tree: |
Internar predicate tree: |

Columns

Name
chunk_id
chunk_seq
Total: 2 index column(s)

SQL

See Also

List of indexes


Table: pg_toast_2619

Properties

Name: | pg_toast_2619
Owner: | postgres
Tablespace: |
Has indexes: |
Has rules: |
Has triggers: |
Inherited Tables Count: | 0
Comment: |

Columns

Name | Type | Length | Default value | Comment
tableoid | oid | -1 |  |
cmax | cid | -1 |  |
xmax | xid | -1 |  |
cmin | cid | -1 |  |
xmin | xid | -1 |  |
ctid | tid | -1 |  |
chunk_id | oid | -1 |  |
chunk_seq | int4 | -1 |  |
chunk_data | bytea | -1 |  |
Total: 9 column(s)

Indexes

Name | Unique | Primary key | Clustered
pg_toast_2619_index |  |  |
Total: 1 index(es)

SQL

See Also

List of tables


List of indexes

Indexes

Name | Unique | Primary key | Clustered
pg_toast_2619_index |  |  |
Total: 1 index(es)

See Also

Table overview


Index: pg_toast_2619_index

Properties

Name: | pg_toast_2619_index
Unique: |
Primary key: |
Clustered: |
Internar expression tree: |
Internar predicate tree: |

Columns

Name
chunk_id
chunk_seq
Total: 2 index column(s)

SQL

See Also

List of indexes


List of types

Types

Name | Owner | Comment
pg_toast_10737 | postgres |
pg_toast_10742 | postgres |
pg_toast_10747 | postgres |
pg_toast_10752 | postgres |
pg_toast_10757 | postgres |
pg_toast_10762 | postgres |
pg_toast_10767 | postgres |
pg_toast_1255 | postgres |
pg_toast_1260 | postgres |
pg_toast_1262 | postgres |
pg_toast_2396 | postgres |
pg_toast_2604 | postgres |
pg_toast_2606 | postgres |
pg_toast_2609 | postgres |
pg_toast_2618 | postgres |
pg_toast_2619 | postgres |
Total: 16 type(s)

See Also

Schema overview


Type: pg_toast_10737

Properties

Name: | pg_toast_10737
OID: | 10740
Owner: | postgres
Alias: | pg_toast.pg_toast_10737
Aligment: | double
Internal length: | -1
Default: |
Passed by value: |
Input function: | record_in
Output function: | record_out
Receive function: | record_recv
Send function: | record_send
Storage: | EXTENDED
Comment: |

SQL

See Also

List of types


Type: pg_toast_10742

Properties

Name: | pg_toast_10742
OID: | 10745
Owner: | postgres
Alias: | pg_toast.pg_toast_10742
Aligment: | double
Internal length: | -1
Default: |
Passed by value: |
Input function: | record_in
Output function: | record_out
Receive function: | record_recv
Send function: | record_send
Storage: | EXTENDED
Comment: |

SQL

See Also

List of types


Type: pg_toast_10747

Properties

Name: | pg_toast_10747
OID: | 10750
Owner: | postgres
Alias: | pg_toast.pg_toast_10747
Aligment: | double
Internal length: | -1
Default: |
Passed by value: |
Input function: | record_in
Output function: | record_out
Receive function: | record_recv
Send function: | record_send
Storage: | EXTENDED
Comment: |

SQL

See Also

List of types


Type: pg_toast_10752

Properties

Name: | pg_toast_10752
OID: | 10755
Owner: | postgres
Alias: | pg_toast.pg_toast_10752
Aligment: | double
Internal length: | -1
Default: |
Passed by value: |
Input function: | record_in
Output function: | record_out
Receive function: | record_recv
Send function: | record_send
Storage: | EXTENDED
Comment: |

SQL

See Also

List of types


Type: pg_toast_10757

Properties

Name: | pg_toast_10757
OID: | 10760
Owner: | postgres
Alias: | pg_toast.pg_toast_10757
Aligment: | double
Internal length: | -1
Default: |
Passed by value: |
Input function: | record_in
Output function: | record_out
Receive function: | record_recv
Send function: | record_send
Storage: | EXTENDED
Comment: |

SQL

See Also

List of types


Type: pg_toast_10762

Properties

Name: | pg_toast_10762
OID: | 10765
Owner: | postgres
Alias: | pg_toast.pg_toast_10762
Aligment: | double
Internal length: | -1
Default: |
Passed by value: |
Input function: | record_in
Output function: | record_out
Receive function: | record_recv
Send function: | record_send
Storage: | EXTENDED
Comment: |

SQL

See Also

List of types


Type: pg_toast_10767

Properties

Name: | pg_toast_10767
OID: | 10770
Owner: | postgres
Alias: | pg_toast.pg_toast_10767
Aligment: | double
Internal length: | -1
Default: |
Passed by value: |
Input function: | record_in
Output function: | record_out
Receive function: | record_recv
Send function: | record_send
Storage: | EXTENDED
Comment: |

SQL

See Also

List of types


Type: pg_toast_1255

Properties

Name: | pg_toast_1255
OID: | 10288
Owner: | postgres
Alias: | pg_toast.pg_toast_1255
Aligment: | double
Internal length: | -1
Default: |
Passed by value: |
Input function: | record_in
Output function: | record_out
Receive function: | record_recv
Send function: | record_send
Storage: | EXTENDED
Comment: |

SQL

See Also

List of types


Type: pg_toast_1260

Properties

Name: | pg_toast_1260
OID: | 10291
Owner: | postgres
Alias: | pg_toast.pg_toast_1260
Aligment: | double
Internal length: | -1
Default: |
Passed by value: |
Input function: | record_in
Output function: | record_out
Receive function: | record_recv
Send function: | record_send
Storage: | EXTENDED
Comment: |

SQL

See Also

List of types


Type: pg_toast_1262

Properties

Name: | pg_toast_1262
OID: | 10292
Owner: | postgres
Alias: | pg_toast.pg_toast_1262
Aligment: | double
Internal length: | -1
Default: |
Passed by value: |
Input function: | record_in
Output function: | record_out
Receive function: | record_recv
Send function: | record_send
Storage: | EXTENDED
Comment: |

SQL

See Also

List of types


Type: pg_toast_2396

Properties

Name: | pg_toast_2396
OID: | 10293
Owner: | postgres
Alias: | pg_toast.pg_toast_2396
Aligment: | double
Internal length: | -1
Default: |
Passed by value: |
Input function: | record_in
Output function: | record_out
Receive function: | record_recv
Send function: | record_send
Storage: | EXTENDED
Comment: |

SQL

See Also

List of types


Type: pg_toast_2604

Properties

Name: | pg_toast_2604
OID: | 10285
Owner: | postgres
Alias: | pg_toast.pg_toast_2604
Aligment: | double
Internal length: | -1
Default: |
Passed by value: |
Input function: | record_in
Output function: | record_out
Receive function: | record_recv
Send function: | record_send
Storage: | EXTENDED
Comment: |

SQL

See Also

List of types


Type: pg_toast_2606

Properties

Name: | pg_toast_2606
OID: | 10286
Owner: | postgres
Alias: | pg_toast.pg_toast_2606
Aligment: | double
Internal length: | -1
Default: |
Passed by value: |
Input function: | record_in
Output function: | record_out
Receive function: | record_recv
Send function: | record_send
Storage: | EXTENDED
Comment: |

SQL

See Also

List of types


Type: pg_toast_2609

Properties

Name: | pg_toast_2609
OID: | 10287
Owner: | postgres
Alias: | pg_toast.pg_toast_2609
Aligment: | double
Internal length: | -1
Default: |
Passed by value: |
Input function: | record_in
Output function: | record_out
Receive function: | record_recv
Send function: | record_send
Storage: | EXTENDED
Comment: |

SQL

See Also

List of types


Type: pg_toast_2618

Properties

Name: | pg_toast_2618
OID: | 10289
Owner: | postgres
Alias: | pg_toast.pg_toast_2618
Aligment: | double
Internal length: | -1
Default: |
Passed by value: |
Input function: | record_in
Output function: | record_out
Receive function: | record_recv
Send function: | record_send
Storage: | EXTENDED
Comment: |

SQL

See Also

List of types


Type: pg_toast_2619

Properties

Name: | pg_toast_2619
OID: | 10290
Owner: | postgres
Alias: | pg_toast.pg_toast_2619
Aligment: | double
Internal length: | -1
Default: |
Passed by value: |
Input function: | record_in
Output function: | record_out
Receive function: | record_recv
Send function: | record_send
Storage: | EXTENDED
Comment: |

SQL

See Also

List of types


Schema: public

Properties

Name: | public
Owner: | postgres
System: |
Comment: | Standard public schema

Aggregates

Name | Owner | Comment
avg1(interval) | postgres |
Total: 1 aggregate(s)

Conversions

Name | Owner | Comment
ascii_to_mic | postgres |
Total: 1 conversion(s)

Domains

Name | Comment
domain1 | test domain
rrr |
Total: 2 domain(s)

Functions

Name | Owner | Comment
abbrev(inet) | postgres |
Total: 1 function(s)

Trigger functions

Name | Owner | Comment
RI_FKey_cascade_del | postgres |
Total: 1 trigger function(s)

Procedures

Name | Owner | Comment
pg_stat_file(IN filename text, OUT size bigint, OUT access timestamp with time zone, OUT modification timestamp with time zone, OUT change timestamp with time zone, OUT creation timestamp with time zone, OUT isdir boolean) | postgres |
pg_timezone_abbrevs(OUT abbrev text, OUT utc_offset interval, OUT is_dst boolean) | postgres |
Total: 2 procedure(s)

Operators

Name | Owner | Comment
! (int8) | postgres |
Total: 1 operator(s)

Operator classses

Name | Owner | Comment
_char_ops1 | postgres |
Total: 1 opclass(s)

Sequences

Name | Owner | Comment
sq_1 | postgres |
sq_example | postgres | example sequence
ww | postgres | ddssdss
Total: 3 sequence(s)

Tables

Name | Owner | Tablespace | Comment
pg_amop | postgres |  |
pg_amop1 | postgres |  |
Total: 2 table(s)

Types

Name | Owner | Comment
PIPPO | postgres |
pg_amop | postgres |
pg_amop1 | postgres |
sq_1 | postgres |
sq_example | postgres |
view1 | postgres |
ww | postgres |
Total: 7 type(s)

Views

Name | Owner | Comment
view1 | postgres | example view
Total: 1 view(s)

See Also

List of schemas


List of aggregates

Aggregates

Name | Owner | Comment
avg1(interval) | postgres |
Total: 1 aggregate(s)

See Also

Schema overview


Aggregate: avg1(interval)

Properties

Name: | avg1(interval)
Input type: | interval
Owner: | postgres
State type: | interval[]
State function: | interval_avg
Final type: | interval
Final function: | interval_avg
Sort Operator: |
Initial condition: | {0 second,0 second}
System aggregate?: |
Comment: |

SQL

CREATE AGGREGATE avg1 (
BASETYPE = interval,
SFUNC = interval_accum,
STYPE = interval[],
INITCOND = '{0 second,0 second}',
FINALFUNC = interval_avg
);

ALTER AGGREGATE public.avg1(interval) OWNER TO postgres;

See Also

List of aggregates


List of conversations

Conversions

Name | Owner | Comment
ascii_to_mic | postgres |
Total: 1 conversation(s)

See Also

Schema overview


Conversion: ascii_to_mic

Properties

Name: | ascii_to_mic
Owner: | postgres
Schema: | public
From: | SQL_ASCII
To: | MULE_INTERNAL
Function: | ascii_to_mic
Default: |
System: |
Comment: |

SQL

CREATE DEFAULT CONVERSION ascii_to_mic FOR 'SQL_ASCII' TO 'MULE_INTERNAL' FROM ascii_to_mic;

ALTER CONVERSION public.ascii_to_mic OWNER TO postgres;

SET default_tablespace = '';

SET default_with_oids = false;

See Also

List of conversions


Domain: domain1

Properties

Name: | domain1
OID: | 16449
Owner: | postgres
Base type: | bigint
Default: | 1
Check: |
Not Null: |
Comment: | test domain

SQL

CREATE DOMAIN domain1 AS bigint NOT NULL DEFAULT 1;

ALTER DOMAIN public.domain1 OWNER TO postgres;

See Also

List of domains


Domain: rrr

Properties

Name: | rrr
OID: | 16450
Owner: | postgres
Base type: | integer
Default: | 34
Check: | CHECK ((VALUE > 33))
Not Null: |
Comment: |

SQL

CREATE DOMAIN rrr AS integer NOT NULL DEFAULT 34
CONSTRAINT rrr_check CHECK ((VALUE > 33));

ALTER DOMAIN public.rrr OWNER TO postgres;

See Also

List of domains


List of functions

Functions

Name | Owner | Comment
abbrev(inet) | postgres |
Total: 1 function(s)

See Also

Schema overview


Function: abbrev(inet)

Properties

Name: | abbrev
Specific name: | abbrev(inet)
Owner: | postgres
Argument count: | 1
Return type: | text
Language: | internal
Return a set: |
Source: | inet_abbrev
Volatility: |
Security of definer: |
Strict: |
Comment: |

SQL

CREATE FUNCTION abbrev(inet) RETURNS text
AS $$inet_abbrev$$
LANGUAGE internal IMMUTABLE STRICT;

ALTER FUNCTION public.abbrev(inet) OWNER TO postgres;

See Also

List of functions


List of trigger functions

Trigger functions

Name | Owner | Comment
RI_FKey_cascade_del | postgres |
Total: 1 trigger function(s)

See Also

Schema overview


Trigger function: RI_FKey_cascade_del

Properties

Name: | RI_FKey_cascade_del
Owner: | postgres
Argument count: | 0
Return type: | trigger
Language: | internal
Return a set: |
Source: | RI_FKey_cascade_del
Volatility: |
Security of definer: |
Strict: |
Comment: |

SQL

CREATE FUNCTION "RI_FKey_cascade_del"() RETURNS "trigger"
AS $$RI_FKey_cascade_del$$
LANGUAGE internal STRICT;

ALTER FUNCTION public."RI_FKey_cascade_del"() OWNER TO postgres;

See Also

List of trigger functions


List of procedures

Procedures

Name | Owner | Comment
pg_stat_file(IN filename text, OUT size bigint, OUT access timestamp with time zone, OUT modification timestamp with time zone, OUT change timestamp with time zone, OUT creation timestamp with time zone, OUT isdir boolean) | postgres |
pg_timezone_abbrevs(OUT abbrev text, OUT utc_offset interval, OUT is_dst boolean) | postgres |
Total: 2 procedure(s)

See Also

Schema overview


Procedure: pg_stat_file(IN filename text, OUT size bigint, OUT access timestamp with time zone, OUT modification timestamp with time zone, OUT change timestamp with time zone, OUT creation timestamp with time zone, OUT isdir boolean)

Properties

Name: | pg_stat_file
Specific name: | pg_stat_file(IN filename text, OUT size bigint, OUT access timestamp with time zone, OUT modification timestamp with time zone, OUT change timestamp with time zone, OUT creation timestamp with time zone, OUT isdir boolean)
Owner: | postgres
Argument count: | 1
Return type: | record
Language: | internal
Return a set: |
Source: | pg_stat_file
Volatility: |
Security of definer: |
Strict: |
Comment: |

SQL

CREATE FUNCTION pg_stat_file(filename text, OUT size bigint, OUT "access" timestamp with time zone, OUT modification timestamp with time zone, OUT change timestamp with time zone, OUT creation timestamp with time zone, OUT isdir boolean) RETURNS record
AS $$pg_stat_file$$
LANGUAGE internal STRICT;

ALTER FUNCTION public.pg_stat_file(filename text, OUT size bigint, OUT "access" timestamp with time zone, OUT modification timestamp with time zone, OUT change timestamp with time zone, OUT creation timestamp with time zone, OUT isdir boolean) OWNER TO postgres;

See Also

List of procedures


Procedure: pg_timezone_abbrevs(OUT abbrev text, OUT utc_offset interval, OUT is_dst boolean)

Properties

Name: | pg_timezone_abbrevs
Specific name: | pg_timezone_abbrevs(OUT abbrev text, OUT utc_offset interval, OUT is_dst boolean)
Owner: | postgres
Argument count: | 0
Return type: | record
Language: | internal
Return a set: |
Source: | pg_timezone_abbrevs
Volatility: |
Security of definer: |
Strict: |
Comment: |

SQL

CREATE FUNCTION pg_timezone_abbrevs(OUT abbrev text, OUT utc_offset interval, OUT is_dst boolean) RETURNS SETOF record
AS $$pg_timezone_abbrevs$$
LANGUAGE internal STABLE STRICT;

ALTER FUNCTION public.pg_timezone_abbrevs(OUT abbrev text, OUT utc_offset interval, OUT is_dst boolean) OWNER TO postgres;

See Also

List of procedures


List of operators

Operators

Name | Owner | Comment
! (int8) | postgres |
Total: 1 operator(s)

See Also

Schema overview


Operator: ! (int8)

Properties

Name: | !
OID: | 16480
Owner: | postgres
Kind: | POSTFIX
Left type: | int8
Right type: |
Result type: | numeric
Commutator: |
Negator: |
Join function: |
Restrict function: |
Left Sort operator: |
Right Sort operator: |
Less Than operator: |
Greater Than Operator: |
Supports hash: |
Comment: |

SQL

CREATE OPERATOR ! (
PROCEDURE = numeric_fac,
LEFTARG = bigint
);

ALTER OPERATOR public.! (bigint, NONE) OWNER TO postgres;

See Also

List of operators


List of operator classes

Operator classes

Name | Owner | Comment
_char_ops1 | postgres |
Total: 1 operator classe(s)

See Also

Schema overview


Operator class: _char_ops1

Properties

Name: | _char_ops1
OID: | 16476
Owner: | postgres
Default: |
For type: | _char
Access method: | gin
Storage: |
Comment: |
Operator: | 1 &&(anyarray,anyarray)
Operator: | 2 @>(anyarray,anyarray)
Operator: | 3 <@(anyarray,anyarray)
Operator: | 4 =(anyarray,anyarray)
Function: | btcharcmp("char", "char")
Function: | ginarrayextract(anyarray, internal)
Function: | ginarrayextract(anyarray, internal)
Function: | ginarrayconsistent(internal, smallint, internal)

SQL

CREATE OPERATOR CLASS _char_ops1
FOR TYPE "char"[] USING gin AS
OPERATOR 1 &&(anyarray,anyarray) ,
OPERATOR 2 @>(anyarray,anyarray) ,
OPERATOR 3 <@(anyarray,anyarray) RECHECK ,
OPERATOR 4 =(anyarray,anyarray) RECHECK ,
FUNCTION 1 btcharcmp("char","char") ,
FUNCTION 2 ginarrayextract(anyarray,internal) ,
FUNCTION 3 ginarrayextract(anyarray,internal) ,
FUNCTION 4 ginarrayconsistent(internal,smallint,internal);

ALTER OPERATOR CLASS public._char_ops1 USING gin OWNER TO postgres;

See Also

List of operator classes


List of sequences

Sequences

Name | Owner | Comment
sq_1 | postgres |
sq_example | postgres | example sequence
ww | postgres | ddssdss
Total: 3 sequence(s)

See Also

Schema overview


Sequence: sq_1

Properties

Name: | sq_1
OID: | 16445
Owner: | postgres
Current value: | 1
Minimum: | 1
Maximum: | 9223372036854775807
Increment: | 1
Cache: | 1
Cycled: |
Comment: |

SQL

CREATE SEQUENCE sq_1
START WITH 1
INCREMENT BY 1
NO MAXVALUE
NO MINVALUE
CACHE 1;

ALTER TABLE public.sq_1 OWNER TO postgres;

See Also

List of sequences


Sequence: sq_example

Properties

Name: | sq_example
OID: | 16443
Owner: | postgres
Current value: | 1
Minimum: | 1
Maximum: | 9223372036854775807
Increment: | 1
Cache: | 1
Cycled: |
Comment: | example sequence

SQL

CREATE SEQUENCE sq_example
START WITH 1
INCREMENT BY 1
NO MAXVALUE
NO MINVALUE
CACHE 1
CYCLE;

ALTER TABLE public.sq_example OWNER TO postgres;

See Also

List of sequences


Sequence: ww

Properties

Name: | ww
OID: | 16447
Owner: | postgres
Current value: | 1
Minimum: | 1
Maximum: | 12
Increment: | 1
Cache: | 1
Cycled: |
Comment: | ddssdss

SQL

CREATE SEQUENCE ww
START WITH 1
INCREMENT BY 1
MAXVALUE 12
NO MINVALUE
CACHE 1
CYCLE;

ALTER TABLE public.ww OWNER TO postgres;

See Also

List of sequences


List of tables

Tables

Name | Owner | Tablespace | Comment
pg_amop | postgres |  |
pg_amop1 | postgres |  |
Total: 2 tables(s)

See Also

Schema overview


Table: pg_amop

Properties

Name: | pg_amop
Owner: | postgres
Tablespace: |
Has indexes: |
Has rules: |
Has triggers: |
Inherited Tables Count: | 0
Comment: |

Columns

Name | Type | Length | Default value | Comment
tableoid | oid | -1 |  |
cmax | cid | -1 |  |
xmax | xid | -1 |  |
cmin | cid | -1 |  |
xmin | xid | -1 |  |
ctid | tid | -1 |  |
amopclaid | oid | -1 |  |
amopsubtype | oid | -1 |  |
amopstrategy | int2 | -1 |  |
amopreqcheck | bool | -1 |  |
amopopr | oid | -1 |  |
Total: 11 column(s)

Indexes

Name | Unique | Primary key | Clustered
pg_amop_opc_strat_index |  |  |
pg_amop_opr_opc_index |  |  |
Total: 2 index(es)

SQL

CREATE TABLE pg_amop (
amopclaid oid NOT NULL,
amopsubtype oid NOT NULL,
amopstrategy smallint NOT NULL,
amopreqcheck boolean NOT NULL,
amopopr oid NOT NULL
);

ALTER TABLE public.pg_amop OWNER TO postgres;

See Also

List of tables


List of indexes

Indexes

Name | Unique | Primary key | Clustered
pg_amop_opc_strat_index |  |  |
pg_amop_opr_opc_index |  |  |
Total: 2 index(es)

See Also

Table overview


Index: pg_amop_opc_strat_index

Properties

Name: | pg_amop_opc_strat_index
Unique: |
Primary key: |
Clustered: |
Internar expression tree: |
Internar predicate tree: |

Columns

Name
amopclaid
amopsubtype
amopstrategy
Total: 3 index column(s)

SQL

See Also

List of indexes


Index: pg_amop_opr_opc_index

Properties

Name: | pg_amop_opr_opc_index
Unique: |
Primary key: |
Clustered: |
Internar expression tree: |
Internar predicate tree: |

Columns

Name
amopclaid
amopopr
Total: 2 index column(s)

SQL

See Also

List of indexes


Table: pg_amop1

Properties

Name: | pg_amop1
Owner: | postgres
Tablespace: |
Has indexes: |
Has rules: |
Has triggers: |
Inherited Tables Count: | 0
Comment: |

Columns

Name | Type | Length | Default value | Comment
tableoid | oid | -1 |  |
cmax | cid | -1 |  |
xmax | xid | -1 |  |
cmin | cid | -1 |  |
xmin | xid | -1 |  |
ctid | tid | -1 |  |
amopclaid | oid | -1 |  |
amopsubtype | oid | -1 |  |
amopstrategy | int2 | -1 |  |
amopreqcheck | bool | -1 |  |
amopopr | oid | -1 |  |
Total: 11 column(s)

Constraints

Name | Type | Deffered
ddd | unique |
Total: 1 constraint(s)

Indexes

Name | Unique | Primary key | Clustered
index1 |  |  |
Total: 1 index(es)

Rules

Name | Type | Instead
ddd | DELETE |
Total: 1 rule(s)

Triggers

Name | Trigger function | Enabled | Deferrable | Initially deferred
tr_amo1 | flatfile_update_trigger |  |  |
Total: 1 trigger(s)

SQL

CREATE TABLE pg_amop1 (
amopclaid oid NOT NULL,
amopsubtype oid NOT NULL,
amopstrategy smallint NOT NULL,
amopreqcheck boolean NOT NULL,
amopopr oid NOT NULL
);

ALTER TABLE public.pg_amop1 OWNER TO postgres;

See Also

List of tables


List of indexes

Indexes

Name | Unique | Primary key | Clustered
index1 |  |  |
Total: 1 index(es)

See Also

Table overview


Index: index1

Properties

Name: | index1
Unique: |
Primary key: |
Clustered: |
Internar expression tree: |
Internar predicate tree: |

Columns

Name
amopclaid
Total: 1 index column(s)

SQL

CREATE UNIQUE INDEX index1 ON pg_amop1 USING btree (amopclaid);

ALTER TABLE pg_amop1 CLUSTER ON index1;

See Also

List of indexes


List of rules

Rules

Name | Type | Insteed
ddd | DELETE |
Total: 1 rule(s)

See Also

Table overview


Rule: ddd

Properties

Name: | ddd
Table: | pg_amop1
Type: | DELETE
Is instead: |

SQL

CREATE RULE ddd AS ON DELETE TO pg_amop1 WHERE (old.amopclaid > (1)::oid) DO NOTHING;

See Also

Table overview


List of triggers

Triggers

Name | Trigger function | Enabled | Deferrable | Initially deferred
tr_amo1 | flatfile_update_trigger |  |  |
Total: 1 trigger(s)

See Also

Table overview


Trigger: tr_amo1

Properties

Name: | tr_amo1
Fires: | ROW
Timing: | BEFORE
Insert: |
Delete: |
Update: |
Trigger function: | flatfile_update_trigger
Enabled: |
Deferrable: |
Initially deferred: |
Comment: | trigger

SQL

CREATE TRIGGER tr_amo1
BEFORE UPDATE ON pg_amop1
FOR EACH ROW
EXECUTE PROCEDURE flatfile_update_trigger();

See Also

List of triggers


List of constraints

constraints

Name | Type | Deffered
ddd | unique |
Total: 1 constraint(s)

See Also

Table overview


Constraint: ddd

Properties

Name: | ddd
Type: | unique
Deffered: |
Deffered by default: |
Reference table: |
FK update action code: |
FK deletion action code: |
FK match typa: |
CHECK expression: |
Comment: | dddd

SQL

ALTER TABLE ONLY pg_amop1
ADD CONSTRAINT ddd UNIQUE (amopclaid);

See Also

List of constraints


List of types

Types

Name | Owner | Comment
PIPPO | postgres |
pg_amop | postgres |
pg_amop1 | postgres |
sq_1 | postgres |
sq_example | postgres |
view1 | postgres |
ww | postgres |
Total: 7 type(s)

See Also

Schema overview


Type: PIPPO

Properties

Name: | PIPPO
OID: | 16469
Owner: | postgres
Alias: | "PIPPO"
Aligment: | double
Internal length: | -1
Default: |
Passed by value: |
Input function: | record_in
Output function: | record_out
Receive function: | record_recv
Send function: | record_send
Storage: | EXTENDED
Comment: |

SQL

CREATE TYPE "PIPPO" AS (
one money,
two numeric(10,10)
);

ALTER TYPE public."PIPPO" OWNER TO postgres;

See Also

List of types


Type: pg_amop

Properties

Name: | pg_amop
OID: | 16453
Owner: | postgres
Alias: | public.pg_amop
Aligment: | double
Internal length: | -1
Default: |
Passed by value: |
Input function: | record_in
Output function: | record_out
Receive function: | record_recv
Send function: | record_send
Storage: | EXTENDED
Comment: |

SQL

See Also

List of types


Type: pg_amop1

Properties

Name: | pg_amop1
OID: | 16455
Owner: | postgres
Alias: | pg_amop1
Aligment: | double
Internal length: | -1
Default: |
Passed by value: |
Input function: | record_in
Output function: | record_out
Receive function: | record_recv
Send function: | record_send
Storage: | EXTENDED
Comment: |

SQL

See Also

List of types


Type: sq_1

Properties

Name: | sq_1
OID: | 16446
Owner: | postgres
Alias: | sq_1
Aligment: | double
Internal length: | -1
Default: |
Passed by value: |
Input function: | record_in
Output function: | record_out
Receive function: | record_recv
Send function: | record_send
Storage: | EXTENDED
Comment: |

SQL

See Also

List of types


Type: sq_example

Properties

Name: | sq_example
OID: | 16444
Owner: | postgres
Alias: | sq_example
Aligment: | double
Internal length: | -1
Default: |
Passed by value: |
Input function: | record_in
Output function: | record_out
Receive function: | record_recv
Send function: | record_send
Storage: | EXTENDED
Comment: |

SQL

See Also

List of types


Type: view1

Properties

Name: | view1
OID: | 16472
Owner: | postgres
Alias: | view1
Aligment: | double
Internal length: | -1
Default: |
Passed by value: |
Input function: | record_in
Output function: | record_out
Receive function: | record_recv
Send function: | record_send
Storage: | EXTENDED
Comment: |

SQL

See Also

List of types


Type: ww

Properties

Name: | ww
OID: | 16448
Owner: | postgres
Alias: | ww
Aligment: | double
Internal length: | -1
Default: |
Passed by value: |
Input function: | record_in
Output function: | record_out
Receive function: | record_recv
Send function: | record_send
Storage: | EXTENDED
Comment: |

SQL

See Also

List of types


List of views

Views

Name | Owner | Comment
view1 | postgres | example view
Total: 1 view(s)

See Also

Schema overview


View: view1

Properties

Name: | view1
Owner: | postgres
Has rules: |
Has Triggers: |
Comment: | example view

Columns

Name | Type | Length
?column? | int4 | -1
Total: 1 column(s)

Rules

Name | Type | Instead
view1_ondelete | DELETE |
Total: 1 rule(s)

SQL

CREATE VIEW view1 AS
SELECT 1 FROM pg_index;

ALTER TABLE public.view1 OWNER TO postgres;

See Also

List of views


List of rules

Rules

Name | Type | Instead
view1_ondelete | DELETE |
Total: 1 rule(s)

See Also

Table overview


Rule: view1_ondelete

Properties

Name: | view1_ondelete
View: | view1
Type: | DELETE
Instead: |
Comment: |

SQL

CREATE RULE view1_ondelete AS ON DELETE TO view1 WHERE (1 > 1) DO NOTHING;

See Also

View overview


Schema: information_schema

Properties

Name: | information_schema
Owner: | postgres
System: |
Comment: |

Domains

Name | Comment
domain1 | test domain
rrr |
Total: 2 domain(s)

Functions

Name | Owner | Comment
_pg_char_max_length(oid, integer) | postgres |
_pg_char_octet_length(oid, integer) | postgres |
_pg_datetime_precision(oid, integer) | postgres |
_pg_index_position(oid, smallint) | postgres |
_pg_keyissubset() | postgres |
_pg_keysequal() | postgres |
_pg_numeric_precision(oid, integer) | postgres |
_pg_numeric_precision_radix(oid, integer) | postgres |
_pg_numeric_scale(oid, integer) | postgres |
_pg_truetypid(pg_attribute, pg_type) | postgres |
_pg_truetypmod(pg_attribute, pg_type) | postgres |
_pg_underlying_index(oid) | postgres |
Total: 12 function(s)

Procedures

Name | Owner | Comment
_pg_expandarray(IN anyarray, OUT x anyelement, OUT n integer) | postgres |
Total: 1 procedure(s)

Tables

Name | Owner | Tablespace | Comment
sql_features | postgres |  |
sql_implementation_info | postgres |  |
sql_languages | postgres |  |
sql_packages | postgres |  |
sql_parts | postgres |  |
sql_sizing | postgres |  |
sql_sizing_profiles | postgres |  |
Total: 7 table(s)

Types

Name | Owner | Comment
administrable_role_authorizations | postgres |
applicable_roles | postgres |
attributes | postgres |
check_constraint_routine_usage | postgres |
check_constraints | postgres |
column_domain_usage | postgres |
column_privileges | postgres |
column_udt_usage | postgres |
columns | postgres |
constraint_column_usage | postgres |
constraint_table_usage | postgres |
data_type_privileges | postgres |
domain_constraints | postgres |
domain_udt_usage | postgres |
domains | postgres |
element_types | postgres |
enabled_roles | postgres |
information_schema_catalog_name | postgres |
key_column_usage | postgres |
parameters | postgres |
referential_constraints | postgres |
role_column_grants | postgres |
role_routine_grants | postgres |
role_table_grants | postgres |
role_usage_grants | postgres |
routine_privileges | postgres |
routines | postgres |
schemata | postgres |
sequences | postgres |
sql_features | postgres |
sql_implementation_info | postgres |
sql_languages | postgres |
sql_packages | postgres |
sql_parts | postgres |
sql_sizing | postgres |
sql_sizing_profiles | postgres |
table_constraints | postgres |
table_privileges | postgres |
tables | postgres |
triggered_update_columns | postgres |
triggers | postgres |
usage_privileges | postgres |
view_column_usage | postgres |
view_routine_usage | postgres |
view_table_usage | postgres |
views | postgres |
Total: 46 type(s)

Views

Name | Owner | Comment
administrable_role_authorizations | postgres |
applicable_roles | postgres |
attributes | postgres |
check_constraint_routine_usage | postgres |
check_constraints | postgres |
column_domain_usage | postgres |
column_privileges | postgres |
column_udt_usage | postgres |
columns | postgres |
constraint_column_usage | postgres |
constraint_table_usage | postgres |
data_type_privileges | postgres |
domain_constraints | postgres |
domain_udt_usage | postgres |
domains | postgres |
element_types | postgres |
enabled_roles | postgres |
information_schema_catalog_name | postgres |
key_column_usage | postgres |
parameters | postgres |
referential_constraints | postgres |
role_column_grants | postgres |
role_routine_grants | postgres |
role_table_grants | postgres |
role_usage_grants | postgres |
routine_privileges | postgres |
routines | postgres |
schemata | postgres |
sequences | postgres |
table_constraints | postgres |
table_privileges | postgres |
tables | postgres |
triggered_update_columns | postgres |
triggers | postgres |
usage_privileges | postgres |
view_column_usage | postgres |
view_routine_usage | postgres |
view_table_usage | postgres |
views | postgres |
Total: 39 view(s)

See Also

List of schemas


List of functions

Functions

Name | Owner | Comment
_pg_char_max_length(oid, integer) | postgres |
_pg_char_octet_length(oid, integer) | postgres |
_pg_datetime_precision(oid, integer) | postgres |
_pg_index_position(oid, smallint) | postgres |
_pg_keyissubset() | postgres |
_pg_keysequal() | postgres |
_pg_numeric_precision(oid, integer) | postgres |
_pg_numeric_precision_radix(oid, integer) | postgres |
_pg_numeric_scale(oid, integer) | postgres |
_pg_truetypid(pg_attribute, pg_type) | postgres |
_pg_truetypmod(pg_attribute, pg_type) | postgres |
_pg_underlying_index(oid) | postgres |
Total: 12 function(s)

See Also

Schema overview


Function: _pg_char_max_length(oid, integer)

Properties

Name: | _pg_char_max_length
Specific name: | _pg_char_max_length(oid, integer)
Owner: | postgres
Argument count: | 2
Return type: | int4
Language: | sql
Return a set: |
Source: | SELECT CASE WHEN $2 = -1 /* default typmod */ THEN null WHEN $1 IN (1042, 1043) /* char, varchar */ THEN $2 - 4 WHEN $1 IN (1560, 1562) /* bit, varbit */ THEN $2 ELSE null END
Volatility: |
Security of definer: |
Strict: |
Comment: |

SQL

CREATE FUNCTION _pg_char_max_length(typid oid, typmod integer) RETURNS integer
AS $_$SELECT
CASE WHEN $2 = -1 /* default typmod */
THEN null
WHEN $1 IN (1042, 1043) /* char, varchar */
THEN $2 - 4
WHEN $1 IN (1560, 1562) /* bit, varbit */
THEN $2
ELSE null
END$_$
LANGUAGE sql IMMUTABLE STRICT;

ALTER FUNCTION information_schema._pg_char_max_length(typid oid, typmod integer) OWNER TO postgres;

See Also

List of functions


Function: _pg_char_octet_length(oid, integer)

Properties

Name: | _pg_char_octet_length
Specific name: | _pg_char_octet_length(oid, integer)
Owner: | postgres
Argument count: | 2
Return type: | int4
Language: | sql
Return a set: |
Source: | SELECT CASE WHEN $1 IN (25, 1042, 1043) /* text, char, varchar */ THEN CAST(2^30 AS integer) ELSE null END
Volatility: |
Security of definer: |
Strict: |
Comment: |

SQL

CREATE FUNCTION _pg_char_octet_length(typid oid, typmod integer) RETURNS integer
AS $_$SELECT
CASE WHEN $1 IN (25, 1042, 1043) /* text, char, varchar */
THEN CAST(2^30 AS integer)
ELSE null
END$_$
LANGUAGE sql IMMUTABLE STRICT;

ALTER FUNCTION information_schema._pg_char_octet_length(typid oid, typmod integer) OWNER TO postgres;

See Also

List of functions


Function: _pg_datetime_precision(oid, integer)

Properties

Name: | _pg_datetime_precision
Specific name: | _pg_datetime_precision(oid, integer)
Owner: | postgres
Argument count: | 2
Return type: | int4
Language: | sql
Return a set: |
Source: | SELECT CASE WHEN $2 = -1 /* default typmod */ THEN null WHEN $1 IN (1083, 1114, 1184, 1266) /* time, timestamp, same + tz */ THEN $2 WHEN $1 IN (1186) /* interval */ THEN $2 & 65535 ELSE null END
Volatility: |
Security of definer: |
Strict: |
Comment: |

SQL

CREATE FUNCTION _pg_datetime_precision(typid oid, typmod integer) RETURNS integer
AS $_$SELECT
CASE WHEN $2 = -1 /* default typmod */
THEN null
WHEN $1 IN (1083, 1114, 1184, 1266) /* time, timestamp, same + tz */
THEN $2
WHEN $1 IN (1186) /* interval */
THEN $2 & 65535
ELSE null
END$_$
LANGUAGE sql IMMUTABLE STRICT;

ALTER FUNCTION information_schema._pg_datetime_precision(typid oid, typmod integer) OWNER TO postgres;

See Also

List of functions


Function: _pg_index_position(oid, smallint)

Properties

Name: | _pg_index_position
Specific name: | _pg_index_position(oid, smallint)
Owner: | postgres
Argument count: | 2
Return type: | int4
Language: | sql
Return a set: |
Source: | SELECT (ss.a).n FROM (SELECT information_schema._pg_expandarray(indkey) AS a FROM pg_catalog.pg_index WHERE indexrelid = $1) ss WHERE (ss.a).x = $2;
Volatility: |
Security of definer: |
Strict: |
Comment: |

SQL

CREATE FUNCTION _pg_index_position(oid, smallint) RETURNS integer
AS $_$
SELECT (ss.a).n FROM
(SELECT information_schema._pg_expandarray(indkey) AS a
FROM pg_catalog.pg_index WHERE indexrelid = $1) ss
WHERE (ss.a).x = $2;
$_$
LANGUAGE sql STABLE STRICT;

ALTER FUNCTION information_schema._pg_index_position(oid, smallint) OWNER TO postgres;

See Also

List of functions


Function: _pg_keyissubset()

Properties

Name: | _pg_keyissubset
Specific name: | _pg_keyissubset()
Owner: | postgres
Argument count: | 2
Return type: | bool
Language: | sql
Return a set: |
Source: | select $1[1] is null or ($1[1] = any ($2) and coalesce(information_schema._pg_keyissubset($1[2:pg_catalog.array_upper($1,1)], $2), true))
Volatility: |
Security of definer: |
Strict: |
Comment: |

SQL

See Also

List of functions


Function: _pg_keysequal()

Properties

Name: | _pg_keysequal
Specific name: | _pg_keysequal()
Owner: | postgres
Argument count: | 2
Return type: | bool
Language: | sql
Return a set: |
Source: | select information_schema._pg_keyissubset($1, $2) and information_schema._pg_keyissubset($2, $1)
Volatility: |
Security of definer: |
Strict: |
Comment: |

SQL

See Also

List of functions


Function: _pg_numeric_precision(oid, integer)

Properties

Name: | _pg_numeric_precision
Specific name: | _pg_numeric_precision(oid, integer)
Owner: | postgres
Argument count: | 2
Return type: | int4
Language: | sql
Return a set: |
Source: | SELECT CASE $1 WHEN 21 /*int2*/ THEN 16 WHEN 23 /*int4*/ THEN 32 WHEN 20 /*int8*/ THEN 64 WHEN 1700 /*numeric*/ THEN CASE WHEN $2 = -1 THEN null ELSE (($2 - 4) >> 16) & 65535 END WHEN 700 /*float4*/ THEN 24 /*FLT_MANT_DIG*/ WHEN 701 /*float8*/ THEN 53 /*DBL_MANT_DIG*/ ELSE null END
Volatility: |
Security of definer: |
Strict: |
Comment: |

SQL

CREATE FUNCTION _pg_numeric_precision(typid oid, typmod integer) RETURNS integer
AS $_$SELECT
CASE $1
WHEN 21 /*int2*/ THEN 16
WHEN 23 /*int4*/ THEN 32
WHEN 20 /*int8*/ THEN 64
WHEN 1700 /*numeric*/ THEN
CASE WHEN $2 = -1
THEN null
ELSE (($2 - 4) >> 16) & 65535
END
WHEN 700 /*float4*/ THEN 24 /*FLT_MANT_DIG*/
WHEN 701 /*float8*/ THEN 53 /*DBL_MANT_DIG*/
ELSE null
END$_$
LANGUAGE sql IMMUTABLE STRICT;

ALTER FUNCTION information_schema._pg_numeric_precision(typid oid, typmod integer) OWNER TO postgres;

See Also

List of functions


Function: _pg_numeric_precision_radix(oid, integer)

Properties

Name: | _pg_numeric_precision_radix
Specific name: | _pg_numeric_precision_radix(oid, integer)
Owner: | postgres
Argument count: | 2
Return type: | int4
Language: | sql
Return a set: |
Source: | SELECT CASE WHEN $1 IN (21, 23, 20, 700, 701) THEN 2 WHEN $1 IN (1700) THEN 10 ELSE null END
Volatility: |
Security of definer: |
Strict: |
Comment: |

SQL

CREATE FUNCTION _pg_numeric_precision_radix(typid oid, typmod integer) RETURNS integer
AS $_$SELECT
CASE WHEN $1 IN (21, 23, 20, 700, 701) THEN 2
WHEN $1 IN (1700) THEN 10
ELSE null
END$_$
LANGUAGE sql IMMUTABLE STRICT;

ALTER FUNCTION information_schema._pg_numeric_precision_radix(typid oid, typmod integer) OWNER TO postgres;

See Also

List of functions


Function: _pg_numeric_scale(oid, integer)

Properties

Name: | _pg_numeric_scale
Specific name: | _pg_numeric_scale(oid, integer)
Owner: | postgres
Argument count: | 2
Return type: | int4
Language: | sql
Return a set: |
Source: | SELECT CASE WHEN $1 IN (21, 23, 20) THEN 0 WHEN $1 IN (1700) THEN CASE WHEN $2 = -1 THEN null ELSE ($2 - 4) & 65535 END ELSE null END
Volatility: |
Security of definer: |
Strict: |
Comment: |

SQL

CREATE FUNCTION _pg_numeric_scale(typid oid, typmod integer) RETURNS integer
AS $_$SELECT
CASE WHEN $1 IN (21, 23, 20) THEN 0
WHEN $1 IN (1700) THEN
CASE WHEN $2 = -1
THEN null
ELSE ($2 - 4) & 65535
END
ELSE null
END$_$
LANGUAGE sql IMMUTABLE STRICT;

ALTER FUNCTION information_schema._pg_numeric_scale(typid oid, typmod integer) OWNER TO postgres;

See Also

List of functions


Function: _pg_truetypid(pg_attribute, pg_type)

Properties

Name: | _pg_truetypid
Specific name: | _pg_truetypid(pg_attribute, pg_type)
Owner: | postgres
Argument count: | 2
Return type: | oid
Language: | sql
Return a set: |
Source: | SELECT CASE WHEN $2.typtype = 'd' THEN $2.typbasetype ELSE $1.atttypid END
Volatility: |
Security of definer: |
Strict: |
Comment: |

SQL

CREATE FUNCTION _pg_truetypid(pg_attribute, pg_type) RETURNS oid
AS $_$SELECT CASE WHEN $2.typtype = 'd' THEN $2.typbasetype ELSE $1.atttypid END$_$
LANGUAGE sql IMMUTABLE STRICT;

ALTER FUNCTION information_schema._pg_truetypid(pg_attribute, pg_type) OWNER TO postgres;

See Also

List of functions


Function: _pg_truetypmod(pg_attribute, pg_type)

Properties

Name: | _pg_truetypmod
Specific name: | _pg_truetypmod(pg_attribute, pg_type)
Owner: | postgres
Argument count: | 2
Return type: | int4
Language: | sql
Return a set: |
Source: | SELECT CASE WHEN $2.typtype = 'd' THEN $2.typtypmod ELSE $1.atttypmod END
Volatility: |
Security of definer: |
Strict: |
Comment: |

SQL

CREATE FUNCTION _pg_truetypmod(pg_attribute, pg_type) RETURNS integer
AS $_$SELECT CASE WHEN $2.typtype = 'd' THEN $2.typtypmod ELSE $1.atttypmod END$_$
LANGUAGE sql IMMUTABLE STRICT;

ALTER FUNCTION information_schema._pg_truetypmod(pg_attribute, pg_type) OWNER TO postgres;

See Also

List of functions


Function: _pg_underlying_index(oid)

Properties

Name: | _pg_underlying_index
Specific name: | _pg_underlying_index(oid)
Owner: | postgres
Argument count: | 1
Return type: | oid
Language: | sql
Return a set: |
Source: | SELECT refobjid FROM pg_catalog.pg_depend WHERE classid = 'pg_catalog.pg_constraint'::pg_catalog.regclass AND objid = $1 AND refclassid = 'pg_catalog.pg_class'::pg_catalog.regclass AND refobjsubid = 0 AND deptype = 'n'
Volatility: |
Security of definer: |
Strict: |
Comment: |

SQL

CREATE FUNCTION _pg_underlying_index(oid) RETURNS oid
AS $_$
SELECT refobjid FROM pg_catalog.pg_depend
WHERE classid = 'pg_catalog.pg_constraint'::pg_catalog.regclass AND
objid = $1 AND
refclassid = 'pg_catalog.pg_class'::pg_catalog.regclass AND
refobjsubid = 0 AND deptype = 'n'
$_$
LANGUAGE sql STABLE STRICT;

ALTER FUNCTION information_schema._pg_underlying_index(oid) OWNER TO postgres;

See Also

List of functions


List of procedures

Procedures

Name | Owner | Comment
_pg_expandarray(IN anyarray, OUT x anyelement, OUT n integer) | postgres |
Total: 1 procedure(s)

See Also

Schema overview


Procedure: _pg_expandarray(IN anyarray, OUT x anyelement, OUT n integer)

Properties

Name: | _pg_expandarray
Specific name: | _pg_expandarray(IN anyarray, OUT x anyelement, OUT n integer)
Owner: | postgres
Argument count: | 1
Return type: | record
Language: | sql
Return a set: |
Source: | select $1[s], s - pg_catalog.array_lower($1,1) + 1 from pg_catalog.generate_series(pg_catalog.array_lower($1,1), pg_catalog.array_upper($1,1), 1) as g(s)
Volatility: |
Security of definer: |
Strict: |
Comment: |

SQL

CREATE FUNCTION _pg_expandarray(anyarray, OUT x anyelement, OUT n integer) RETURNS SETOF record
AS $_$select $1[s], s - pg_catalog.array_lower($1,1) + 1
from pg_catalog.generate_series(pg_catalog.array_lower($1,1),
pg_catalog.array_upper($1,1),
1) as g(s)$_$
LANGUAGE sql IMMUTABLE STRICT;

ALTER FUNCTION information_schema._pg_expandarray(anyarray, OUT x anyelement, OUT n integer) OWNER TO postgres;

See Also

List of procedures


List of tables

Tables

Name | Owner | Tablespace | Comment
sql_features | postgres |  |
sql_implementation_info | postgres |  |
sql_languages | postgres |  |
sql_packages | postgres |  |
sql_parts | postgres |  |
sql_sizing | postgres |  |
sql_sizing_profiles | postgres |  |
Total: 7 tables(s)

See Also

Schema overview


Table: sql_features

Properties

Name: | sql_features
Owner: | postgres
Tablespace: |
Has indexes: |
Has rules: |
Has triggers: |
Inherited Tables Count: | 0
Comment: |

Columns

Name | Type | Length | Default value | Comment
tableoid | oid | -1 |  |
cmax | cid | -1 |  |
xmax | xid | -1 |  |
cmin | cid | -1 |  |
xmin | xid | -1 |  |
ctid | tid | -1 |  |
feature_id | character_data | -1 |  |
feature_name | character_data | -1 |  |
sub_feature_id | character_data | -1 |  |
sub_feature_name | character_data | -1 |  |
is_supported | character_data | -1 |  |
is_verified_by | character_data | -1 |  |
comments | character_data | -1 |  |
Total: 13 column(s)

SQL

CREATE TABLE sql_features (
feature_id character_data,
feature_name character_data,
sub_feature_id character_data,
sub_feature_name character_data,
is_supported character_data,
is_verified_by character_data,
comments character_data
);

ALTER TABLE information_schema.sql_features OWNER TO postgres;

See Also

List of tables


Table: sql_implementation_info

Properties

Name: | sql_implementation_info
Owner: | postgres
Tablespace: |
Has indexes: |
Has rules: |
Has triggers: |
Inherited Tables Count: | 0
Comment: |

Columns

Name | Type | Length | Default value | Comment
tableoid | oid | -1 |  |
cmax | cid | -1 |  |
xmax | xid | -1 |  |
cmin | cid | -1 |  |
xmin | xid | -1 |  |
ctid | tid | -1 |  |
implementation_info_id | character_data | -1 |  |
implementation_info_name | character_data | -1 |  |
integer_value | cardinal_number | -1 |  |
character_value | character_data | -1 |  |
comments | character_data | -1 |  |
Total: 11 column(s)

SQL

CREATE TABLE sql_implementation_info (
implementation_info_id character_data,
implementation_info_name character_data,
integer_value cardinal_number,
character_value character_data,
comments character_data
);

ALTER TABLE information_schema.sql_implementation_info OWNER TO postgres;

See Also

List of tables


Table: sql_languages

Properties

Name: | sql_languages
Owner: | postgres
Tablespace: |
Has indexes: |
Has rules: |
Has triggers: |
Inherited Tables Count: | 0
Comment: |

Columns

Name | Type | Length | Default value | Comment
tableoid | oid | -1 |  |
cmax | cid | -1 |  |
xmax | xid | -1 |  |
cmin | cid | -1 |  |
xmin | xid | -1 |  |
ctid | tid | -1 |  |
sql_language_source | character_data | -1 |  |
sql_language_year | character_data | -1 |  |
sql_language_conformance | character_data | -1 |  |
sql_language_integrity | character_data | -1 |  |
sql_language_implementation | character_data | -1 |  |
sql_language_binding_style | character_data | -1 |  |
sql_language_programming_language | character_data | -1 |  |
Total: 13 column(s)

SQL

CREATE TABLE sql_languages (
sql_language_source character_data,
sql_language_year character_data,
sql_language_conformance character_data,
sql_language_integrity character_data,
sql_language_implementation character_data,
sql_language_binding_style character_data,
sql_language_programming_language character_data
);

ALTER TABLE information_schema.sql_languages OWNER TO postgres;

See Also

List of tables


Table: sql_packages

Properties

Name: | sql_packages
Owner: | postgres
Tablespace: |
Has indexes: |
Has rules: |
Has triggers: |
Inherited Tables Count: | 0
Comment: |

Columns

Name | Type | Length | Default value | Comment
tableoid | oid | -1 |  |
cmax | cid | -1 |  |
xmax | xid | -1 |  |
cmin | cid | -1 |  |
xmin | xid | -1 |  |
ctid | tid | -1 |  |
feature_id | character_data | -1 |  |
feature_name | character_data | -1 |  |
is_supported | character_data | -1 |  |
is_verified_by | character_data | -1 |  |
comments | character_data | -1 |  |
Total: 11 column(s)

SQL

CREATE TABLE sql_packages (
feature_id character_data,
feature_name character_data,
is_supported character_data,
is_verified_by character_data,
comments character_data
);

ALTER TABLE information_schema.sql_packages OWNER TO postgres;

See Also

List of tables


Table: sql_parts

Properties

Name: | sql_parts
Owner: | postgres
Tablespace: |
Has indexes: |
Has rules: |
Has triggers: |
Inherited Tables Count: | 0
Comment: |

Columns

Name | Type | Length | Default value | Comment
tableoid | oid | -1 |  |
cmax | cid | -1 |  |
xmax | xid | -1 |  |
cmin | cid | -1 |  |
xmin | xid | -1 |  |
ctid | tid | -1 |  |
feature_id | character_data | -1 |  |
feature_name | character_data | -1 |  |
is_supported | character_data | -1 |  |
is_verified_by | character_data | -1 |  |
comments | character_data | -1 |  |
Total: 11 column(s)

SQL

CREATE TABLE sql_parts (
feature_id character_data,
feature_name character_data,
is_supported character_data,
is_verified_by character_data,
comments character_data
);

ALTER TABLE information_schema.sql_parts OWNER TO postgres;

See Also

List of tables


Table: sql_sizing

Properties

Name: | sql_sizing
Owner: | postgres
Tablespace: |
Has indexes: |
Has rules: |
Has triggers: |
Inherited Tables Count: | 0
Comment: |

Columns

Name | Type | Length | Default value | Comment
tableoid | oid | -1 |  |
cmax | cid | -1 |  |
xmax | xid | -1 |  |
cmin | cid | -1 |  |
xmin | xid | -1 |  |
ctid | tid | -1 |  |
sizing_id | cardinal_number | -1 |  |
sizing_name | character_data | -1 |  |
supported_value | cardinal_number | -1 |  |
comments | character_data | -1 |  |
Total: 10 column(s)

SQL

CREATE TABLE sql_sizing (
sizing_id cardinal_number,
sizing_name character_data,
supported_value cardinal_number,
comments character_data
);

ALTER TABLE information_schema.sql_sizing OWNER TO postgres;

See Also

List of tables


Table: sql_sizing_profiles

Properties

Name: | sql_sizing_profiles
Owner: | postgres
Tablespace: |
Has indexes: |
Has rules: |
Has triggers: |
Inherited Tables Count: | 0
Comment: |

Columns

Name | Type | Length | Default value | Comment
tableoid | oid | -1 |  |
cmax | cid | -1 |  |
xmax | xid | -1 |  |
cmin | cid | -1 |  |
xmin | xid | -1 |  |
ctid | tid | -1 |  |
sizing_id | cardinal_number | -1 |  |
sizing_name | character_data | -1 |  |
profile_id | character_data | -1 |  |
required_value | cardinal_number | -1 |  |
comments | character_data | -1 |  |
Total: 11 column(s)

SQL

CREATE TABLE sql_sizing_profiles (
sizing_id cardinal_number,
sizing_name character_data,
profile_id character_data,
required_value cardinal_number,
comments character_data
);

ALTER TABLE information_schema.sql_sizing_profiles OWNER TO postgres;

See Also

List of tables


List of types

Types

Name | Owner | Comment
administrable_role_authorizations | postgres |
applicable_roles | postgres |
attributes | postgres |
check_constraint_routine_usage | postgres |
check_constraints | postgres |
column_domain_usage | postgres |
column_privileges | postgres |
column_udt_usage | postgres |
columns | postgres |
constraint_column_usage | postgres |
constraint_table_usage | postgres |
data_type_privileges | postgres |
domain_constraints | postgres |
domain_udt_usage | postgres |
domains | postgres |
element_types | postgres |
enabled_roles | postgres |
information_schema_catalog_name | postgres |
key_column_usage | postgres |
parameters | postgres |
referential_constraints | postgres |
role_column_grants | postgres |
role_routine_grants | postgres |
role_table_grants | postgres |
role_usage_grants | postgres |
routine_privileges | postgres |
routines | postgres |
schemata | postgres |
sequences | postgres |
sql_features | postgres |
sql_implementation_info | postgres |
sql_languages | postgres |
sql_packages | postgres |
sql_parts | postgres |
sql_sizing | postgres |
sql_sizing_profiles | postgres |
table_constraints | postgres |
table_privileges | postgres |
tables | postgres |
triggered_update_columns | postgres |
triggers | postgres |
usage_privileges | postgres |
view_column_usage | postgres |
view_routine_usage | postgres |
view_table_usage | postgres |
views | postgres |
Total: 46 type(s)

See Also

Schema overview


Type: administrable_role_authorizations

Properties

Name: | administrable_role_authorizations
OID: | 10647
Owner: | postgres
Alias: | information_schema.administrable_role_authorizations
Aligment: | double
Internal length: | -1
Default: |
Passed by value: |
Input function: | record_in
Output function: | record_out
Receive function: | record_recv
Send function: | record_send
Storage: | EXTENDED
Comment: |

SQL

See Also

List of types


Type: applicable_roles

Properties

Name: | applicable_roles
OID: | 10644
Owner: | postgres
Alias: | information_schema.applicable_roles
Aligment: | double
Internal length: | -1
Default: |
Passed by value: |
Input function: | record_in
Output function: | record_out
Receive function: | record_recv
Send function: | record_send
Storage: | EXTENDED
Comment: |

SQL

See Also

List of types


Type: attributes

Properties

Name: | attributes
OID: | 10650
Owner: | postgres
Alias: | information_schema.attributes
Aligment: | double
Internal length: | -1
Default: |
Passed by value: |
Input function: | record_in
Output function: | record_out
Receive function: | record_recv
Send function: | record_send
Storage: | EXTENDED
Comment: |

SQL

See Also

List of types


Type: check_constraint_routine_usage

Properties

Name: | check_constraint_routine_usage
OID: | 10654
Owner: | postgres
Alias: | information_schema.check_constraint_routine_usage
Aligment: | double
Internal length: | -1
Default: |
Passed by value: |
Input function: | record_in
Output function: | record_out
Receive function: | record_recv
Send function: | record_send
Storage: | EXTENDED
Comment: |

SQL

See Also

List of types


Type: check_constraints

Properties

Name: | check_constraints
OID: | 10657
Owner: | postgres
Alias: | information_schema.check_constraints
Aligment: | double
Internal length: | -1
Default: |
Passed by value: |
Input function: | record_in
Output function: | record_out
Receive function: | record_recv
Send function: | record_send
Storage: | EXTENDED
Comment: |

SQL

See Also

List of types


Type: column_domain_usage

Properties

Name: | column_domain_usage
OID: | 10661
Owner: | postgres
Alias: | information_schema.column_domain_usage
Aligment: | double
Internal length: | -1
Default: |
Passed by value: |
Input function: | record_in
Output function: | record_out
Receive function: | record_recv
Send function: | record_send
Storage: | EXTENDED
Comment: |

SQL

See Also

List of types


Type: column_privileges

Properties

Name: | column_privileges
OID: | 10665
Owner: | postgres
Alias: | information_schema.column_privileges
Aligment: | double
Internal length: | -1
Default: |
Passed by value: |
Input function: | record_in
Output function: | record_out
Receive function: | record_recv
Send function: | record_send
Storage: | EXTENDED
Comment: |

SQL

See Also

List of types


Type: column_udt_usage

Properties

Name: | column_udt_usage
OID: | 10669
Owner: | postgres
Alias: | information_schema.column_udt_usage
Aligment: | double
Internal length: | -1
Default: |
Passed by value: |
Input function: | record_in
Output function: | record_out
Receive function: | record_recv
Send function: | record_send
Storage: | EXTENDED
Comment: |

SQL

See Also

List of types


Type: columns

Properties

Name: | columns
OID: | 10673
Owner: | postgres
Alias: | information_schema.columns
Aligment: | double
Internal length: | -1
Default: |
Passed by value: |
Input function: | record_in
Output function: | record_out
Receive function: | record_recv
Send function: | record_send
Storage: | EXTENDED
Comment: |

SQL

See Also

List of types


Type: constraint_column_usage

Properties

Name: | constraint_column_usage
OID: | 10677
Owner: | postgres
Alias: | information_schema.constraint_column_usage
Aligment: | double
Internal length: | -1
Default: |
Passed by value: |
Input function: | record_in
Output function: | record_out
Receive function: | record_recv
Send function: | record_send
Storage: | EXTENDED
Comment: |

SQL

See Also

List of types


Type: constraint_table_usage

Properties

Name: | constraint_table_usage
OID: | 10681
Owner: | postgres
Alias: | information_schema.constraint_table_usage
Aligment: | double
Internal length: | -1
Default: |
Passed by value: |
Input function: | record_in
Output function: | record_out
Receive function: | record_recv
Send function: | record_send
Storage: | EXTENDED
Comment: |

SQL

See Also

List of types


Type: data_type_privileges

Properties

Name: | data_type_privileges
OID: | 10811
Owner: | postgres
Alias: | information_schema.data_type_privileges
Aligment: | double
Internal length: | -1
Default: |
Passed by value: |
Input function: | record_in
Output function: | record_out
Receive function: | record_recv
Send function: | record_send
Storage: | EXTENDED
Comment: |

SQL

See Also

List of types


Type: domain_constraints

Properties

Name: | domain_constraints
OID: | 10684
Owner: | postgres
Alias: | information_schema.domain_constraints
Aligment: | double
Internal length: | -1
Default: |
Passed by value: |
Input function: | record_in
Output function: | record_out
Receive function: | record_recv
Send function: | record_send
Storage: | EXTENDED
Comment: |

SQL

See Also

List of types


Type: domain_udt_usage

Properties

Name: | domain_udt_usage
OID: | 10687
Owner: | postgres
Alias: | information_schema.domain_udt_usage
Aligment: | double
Internal length: | -1
Default: |
Passed by value: |
Input function: | record_in
Output function: | record_out
Receive function: | record_recv
Send function: | record_send
Storage: | EXTENDED
Comment: |

SQL

See Also

List of types


Type: domains

Properties

Name: | domains
OID: | 10690
Owner: | postgres
Alias: | information_schema.domains
Aligment: | double
Internal length: | -1
Default: |
Passed by value: |
Input function: | record_in
Output function: | record_out
Receive function: | record_recv
Send function: | record_send
Storage: | EXTENDED
Comment: |

SQL

See Also

List of types


Type: element_types

Properties

Name: | element_types
OID: | 10815
Owner: | postgres
Alias: | information_schema.element_types
Aligment: | double
Internal length: | -1
Default: |
Passed by value: |
Input function: | record_in
Output function: | record_out
Receive function: | record_recv
Send function: | record_send
Storage: | EXTENDED
Comment: |

SQL

See Also

List of types


Type: enabled_roles

Properties

Name: | enabled_roles
OID: | 10694
Owner: | postgres
Alias: | information_schema.enabled_roles
Aligment: | double
Internal length: | -1
Default: |
Passed by value: |
Input function: | record_in
Output function: | record_out
Receive function: | record_recv
Send function: | record_send
Storage: | EXTENDED
Comment: |

SQL

See Also

List of types


Type: information_schema_catalog_name

Properties

Name: | information_schema_catalog_name
OID: | 10640
Owner: | postgres
Alias: | information_schema.information_schema_catalog_name
Aligment: | double
Internal length: | -1
Default: |
Passed by value: |
Input function: | record_in
Output function: | record_out
Receive function: | record_recv
Send function: | record_send
Storage: | EXTENDED
Comment: |

SQL

See Also

List of types


Type: key_column_usage

Properties

Name: | key_column_usage
OID: | 10697
Owner: | postgres
Alias: | information_schema.key_column_usage
Aligment: | double
Internal length: | -1
Default: |
Passed by value: |
Input function: | record_in
Output function: | record_out
Receive function: | record_recv
Send function: | record_send
Storage: | EXTENDED
Comment: |

SQL

See Also

List of types


Type: parameters

Properties

Name: | parameters
OID: | 10701
Owner: | postgres
Alias: | information_schema.parameters
Aligment: | double
Internal length: | -1
Default: |
Passed by value: |
Input function: | record_in
Output function: | record_out
Receive function: | record_recv
Send function: | record_send
Storage: | EXTENDED
Comment: |

SQL

See Also

List of types


Type: referential_constraints

Properties

Name: | referential_constraints
OID: | 10705
Owner: | postgres
Alias: | information_schema.referential_constraints
Aligment: | double
Internal length: | -1
Default: |
Passed by value: |
Input function: | record_in
Output function: | record_out
Receive function: | record_recv
Send function: | record_send
Storage: | EXTENDED
Comment: |

SQL

See Also

List of types


Type: role_column_grants

Properties

Name: | role_column_grants
OID: | 10709
Owner: | postgres
Alias: | information_schema.role_column_grants
Aligment: | double
Internal length: | -1
Default: |
Passed by value: |
Input function: | record_in
Output function: | record_out
Receive function: | record_recv
Send function: | record_send
Storage: | EXTENDED
Comment: |

SQL

See Also

List of types


Type: role_routine_grants

Properties

Name: | role_routine_grants
OID: | 10713
Owner: | postgres
Alias: | information_schema.role_routine_grants
Aligment: | double
Internal length: | -1
Default: |
Passed by value: |
Input function: | record_in
Output function: | record_out
Receive function: | record_recv
Send function: | record_send
Storage: | EXTENDED
Comment: |

SQL

See Also

List of types


Type: role_table_grants

Properties

Name: | role_table_grants
OID: | 10717
Owner: | postgres
Alias: | information_schema.role_table_grants
Aligment: | double
Internal length: | -1
Default: |
Passed by value: |
Input function: | record_in
Output function: | record_out
Receive function: | record_recv
Send function: | record_send
Storage: | EXTENDED
Comment: |

SQL

See Also

List of types


Type: role_usage_grants

Properties

Name: | role_usage_grants
OID: | 10721
Owner: | postgres
Alias: | information_schema.role_usage_grants
Aligment: | double
Internal length: | -1
Default: |
Passed by value: |
Input function: | record_in
Output function: | record_out
Receive function: | record_recv
Send function: | record_send
Storage: | EXTENDED
Comment: |

SQL

See Also

List of types


Type: routine_privileges

Properties

Name: | routine_privileges
OID: | 10724
Owner: | postgres
Alias: | information_schema.routine_privileges
Aligment: | double
Internal length: | -1
Default: |
Passed by value: |
Input function: | record_in
Output function: | record_out
Receive function: | record_recv
Send function: | record_send
Storage: | EXTENDED
Comment: |

SQL

See Also

List of types


Type: routines

Properties

Name: | routines
OID: | 10728
Owner: | postgres
Alias: | information_schema.routines
Aligment: | double
Internal length: | -1
Default: |
Passed by value: |
Input function: | record_in
Output function: | record_out
Receive function: | record_recv
Send function: | record_send
Storage: | EXTENDED
Comment: |

SQL

See Also

List of types


Type: schemata

Properties

Name: | schemata
OID: | 10732
Owner: | postgres
Alias: | information_schema.schemata
Aligment: | double
Internal length: | -1
Default: |
Passed by value: |
Input function: | record_in
Output function: | record_out
Receive function: | record_recv
Send function: | record_send
Storage: | EXTENDED
Comment: |

SQL

See Also

List of types


Type: sequences

Properties

Name: | sequences
OID: | 10735
Owner: | postgres
Alias: | information_schema.sequences
Aligment: | double
Internal length: | -1
Default: |
Passed by value: |
Input function: | record_in
Output function: | record_out
Receive function: | record_recv
Send function: | record_send
Storage: | EXTENDED
Comment: |

SQL

See Also

List of types


Type: sql_features

Properties

Name: | sql_features
OID: | 10738
Owner: | postgres
Alias: | information_schema.sql_features
Aligment: | double
Internal length: | -1
Default: |
Passed by value: |
Input function: | record_in
Output function: | record_out
Receive function: | record_recv
Send function: | record_send
Storage: | EXTENDED
Comment: |

SQL

See Also

List of types


Type: sql_implementation_info

Properties

Name: | sql_implementation_info
OID: | 10743
Owner: | postgres
Alias: | information_schema.sql_implementation_info
Aligment: | double
Internal length: | -1
Default: |
Passed by value: |
Input function: | record_in
Output function: | record_out
Receive function: | record_recv
Send function: | record_send
Storage: | EXTENDED
Comment: |

SQL

See Also

List of types


Type: sql_languages

Properties

Name: | sql_languages
OID: | 10748
Owner: | postgres
Alias: | information_schema.sql_languages
Aligment: | double
Internal length: | -1
Default: |
Passed by value: |
Input function: | record_in
Output function: | record_out
Receive function: | record_recv
Send function: | record_send
Storage: | EXTENDED
Comment: |

SQL

See Also

List of types


Type: sql_packages

Properties

Name: | sql_packages
OID: | 10753
Owner: | postgres
Alias: | information_schema.sql_packages
Aligment: | double
Internal length: | -1
Default: |
Passed by value: |
Input function: | record_in
Output function: | record_out
Receive function: | record_recv
Send function: | record_send
Storage: | EXTENDED
Comment: |

SQL

See Also

List of types


Type: sql_parts

Properties

Name: | sql_parts
OID: | 10758
Owner: | postgres
Alias: | information_schema.sql_parts
Aligment: | double
Internal length: | -1
Default: |
Passed by value: |
Input function: | record_in
Output function: | record_out
Receive function: | record_recv
Send function: | record_send
Storage: | EXTENDED
Comment: |

SQL

See Also

List of types


Type: sql_sizing

Properties

Name: | sql_sizing
OID: | 10763
Owner: | postgres
Alias: | information_schema.sql_sizing
Aligment: | double
Internal length: | -1
Default: |
Passed by value: |
Input function: | record_in
Output function: | record_out
Receive function: | record_recv
Send function: | record_send
Storage: | EXTENDED
Comment: |

SQL

See Also

List of types


Type: sql_sizing_profiles

Properties

Name: | sql_sizing_profiles
OID: | 10768
Owner: | postgres
Alias: | information_schema.sql_sizing_profiles
Aligment: | double
Internal length: | -1
Default: |
Passed by value: |
Input function: | record_in
Output function: | record_out
Receive function: | record_recv
Send function: | record_send
Storage: | EXTENDED
Comment: |

SQL

See Also

List of types


Type: table_constraints

Properties

Name: | table_constraints
OID: | 10773
Owner: | postgres
Alias: | information_schema.table_constraints
Aligment: | double
Internal length: | -1
Default: |
Passed by value: |
Input function: | record_in
Output function: | record_out
Receive function: | record_recv
Send function: | record_send
Storage: | EXTENDED
Comment: |

SQL

See Also

List of types


Type: table_privileges

Properties

Name: | table_privileges
OID: | 10777
Owner: | postgres
Alias: | information_schema.table_privileges
Aligment: | double
Internal length: | -1
Default: |
Passed by value: |
Input function: | record_in
Output function: | record_out
Receive function: | record_recv
Send function: | record_send
Storage: | EXTENDED
Comment: |

SQL

See Also

List of types


Type: tables

Properties

Name: | tables
OID: | 10781
Owner: | postgres
Alias: | information_schema.tables
Aligment: | double
Internal length: | -1
Default: |
Passed by value: |
Input function: | record_in
Output function: | record_out
Receive function: | record_recv
Send function: | record_send
Storage: | EXTENDED
Comment: |

SQL

See Also

List of types


Type: triggered_update_columns

Properties

Name: | triggered_update_columns
OID: | 10785
Owner: | postgres
Alias: | information_schema.triggered_update_columns
Aligment: | double
Internal length: | -1
Default: |
Passed by value: |
Input function: | record_in
Output function: | record_out
Receive function: | record_recv
Send function: | record_send
Storage: | EXTENDED
Comment: |

SQL

See Also

List of types


Type: triggers

Properties

Name: | triggers
OID: | 10788
Owner: | postgres
Alias: | information_schema.triggers
Aligment: | double
Internal length: | -1
Default: |
Passed by value: |
Input function: | record_in
Output function: | record_out
Receive function: | record_recv
Send function: | record_send
Storage: | EXTENDED
Comment: |

SQL

See Also

List of types


Type: usage_privileges

Properties

Name: | usage_privileges
OID: | 10792
Owner: | postgres
Alias: | information_schema.usage_privileges
Aligment: | double
Internal length: | -1
Default: |
Passed by value: |
Input function: | record_in
Output function: | record_out
Receive function: | record_recv
Send function: | record_send
Storage: | EXTENDED
Comment: |

SQL

See Also

List of types


Type: view_column_usage

Properties

Name: | view_column_usage
OID: | 10795
Owner: | postgres
Alias: | information_schema.view_column_usage
Aligment: | double
Internal length: | -1
Default: |
Passed by value: |
Input function: | record_in
Output function: | record_out
Receive function: | record_recv
Send function: | record_send
Storage: | EXTENDED
Comment: |

SQL

See Also

List of types


Type: view_routine_usage

Properties

Name: | view_routine_usage
OID: | 10799
Owner: | postgres
Alias: | information_schema.view_routine_usage
Aligment: | double
Internal length: | -1
Default: |
Passed by value: |
Input function: | record_in
Output function: | record_out
Receive function: | record_recv
Send function: | record_send
Storage: | EXTENDED
Comment: |

SQL

See Also

List of types


Type: view_table_usage

Properties

Name: | view_table_usage
OID: | 10803
Owner: | postgres
Alias: | information_schema.view_table_usage
Aligment: | double
Internal length: | -1
Default: |
Passed by value: |
Input function: | record_in
Output function: | record_out
Receive function: | record_recv
Send function: | record_send
Storage: | EXTENDED
Comment: |

SQL

See Also

List of types


Type: views

Properties

Name: | views
OID: | 10807
Owner: | postgres
Alias: | information_schema.views
Aligment: | double
Internal length: | -1
Default: |
Passed by value: |
Input function: | record_in
Output function: | record_out
Receive function: | record_recv
Send function: | record_send
Storage: | EXTENDED
Comment: |

SQL

See Also

List of types


List of views

Views

Name | Owner | Comment
administrable_role_authorizations | postgres |
applicable_roles | postgres |
attributes | postgres |
check_constraint_routine_usage | postgres |
check_constraints | postgres |
column_domain_usage | postgres |
column_privileges | postgres |
column_udt_usage | postgres |
columns | postgres |
constraint_column_usage | postgres |
constraint_table_usage | postgres |
data_type_privileges | postgres |
domain_constraints | postgres |
domain_udt_usage | postgres |
domains | postgres |
element_types | postgres |
enabled_roles | postgres |
information_schema_catalog_name | postgres |
key_column_usage | postgres |
parameters | postgres |
referential_constraints | postgres |
role_column_grants | postgres |
role_routine_grants | postgres |
role_table_grants | postgres |
role_usage_grants | postgres |
routine_privileges | postgres |
routines | postgres |
schemata | postgres |
sequences | postgres |
table_constraints | postgres |
table_privileges | postgres |
tables | postgres |
triggered_update_columns | postgres |
triggers | postgres |
usage_privileges | postgres |
view_column_usage | postgres |
view_routine_usage | postgres |
view_table_usage | postgres |
views | postgres |
Total: 39 view(s)

See Also

Schema overview


View: administrable_role_authorizations

Properties

Name: | administrable_role_authorizations
Owner: | postgres
Has rules: |
Has Triggers: |
Comment: |

Columns

Name | Type | Length
grantee | sql_identifier | -1
role_name | sql_identifier | -1
is_grantable | character_data | -1
Total: 3 column(s)

SQL

CREATE VIEW administrable_role_authorizations AS
SELECT applicable_roles.grantee, applicable_roles.role_name, applicable_roles.is_grantable FROM applicable_roles WHERE ((applicable_roles.is_grantable)::text = 'YES'::text);

ALTER TABLE information_schema.administrable_role_authorizations OWNER TO postgres;

See Also

List of views


View: applicable_roles

Properties

Name: | applicable_roles
Owner: | postgres
Has rules: |
Has Triggers: |
Comment: |

Columns

Name | Type | Length
grantee | sql_identifier | -1
role_name | sql_identifier | -1
is_grantable | character_data | -1
Total: 3 column(s)

SQL

CREATE VIEW applicable_roles AS
SELECT (a.rolname)::sql_identifier AS grantee, (b.rolname)::sql_identifier AS role_name, (CASE WHEN m.admin_option THEN 'YES'::text ELSE 'NO'::text END)::character_data AS is_grantable FROM ((pg_auth_members m JOIN pg_authid a ON ((m.member = a.oid))) JOIN pg_authid b ON ((m.roleid = b.oid))) WHERE pg_has_role(a.oid, 'USAGE'::text);

ALTER TABLE information_schema.applicable_roles OWNER TO postgres;

See Also

List of views


View: attributes

Properties

Name: | attributes
Owner: | postgres
Has rules: |
Has Triggers: |
Comment: |

Columns

Name | Type | Length
udt_catalog | sql_identifier | -1
udt_schema | sql_identifier | -1
udt_name | sql_identifier | -1
attribute_name | sql_identifier | -1
ordinal_position | cardinal_number | -1
attribute_default | character_data | -1
is_nullable | character_data | -1
data_type | character_data | -1
character_maximum_length | cardinal_number | -1
character_octet_length | cardinal_number | -1
character_set_catalog | sql_identifier | -1
character_set_schema | sql_identifier | -1
character_set_name | sql_identifier | -1
collation_catalog | sql_identifier | -1
collation_schema | sql_identifier | -1
collation_name | sql_identifier | -1
numeric_precision | cardinal_number | -1
numeric_precision_radix | cardinal_number | -1
numeric_scale | cardinal_number | -1
datetime_precision | cardinal_number | -1
interval_type | character_data | -1
interval_precision | character_data | -1
attribute_udt_catalog | sql_identifier | -1
attribute_udt_schema | sql_identifier | -1
attribute_udt_name | sql_identifier | -1
scope_catalog | sql_identifier | -1
scope_schema | sql_identifier | -1
scope_name | sql_identifier | -1
maximum_cardinality | cardinal_number | -1
dtd_identifier | sql_identifier | -1
is_derived_reference_attribute | character_data | -1
Total: 31 column(s)

SQL

CREATE VIEW attributes AS
SELECT (current_database())::sql_identifier AS udt_catalog, (nc.nspname)::sql_identifier AS udt_schema, (c.relname)::sql_identifier AS udt_name, (a.attname)::sql_identifier AS attribute_name, (a.attnum)::cardinal_number AS ordinal_position, (pg_get_expr(ad.adbin, ad.adrelid))::character_data AS attribute_default, (CASE WHEN (a.attnotnull OR ((t.typtype = 'd'::"char") AND t.typnotnull)) THEN 'NO'::text ELSE 'YES'::text END)::character_data AS is_nullable, (CASE WHEN ((t.typelem <> (0)::oid) AND (t.typlen = -1)) THEN 'ARRAY'::text WHEN (nt.nspname = 'pg_catalog'::name) THEN format_type(a.atttypid, NULL::integer) ELSE 'USER-DEFINED'::text END)::character_data AS data_type, (_pg_char_max_length(_pg_truetypid(a.*, t.*), _pg_truetypmod(a.*, t.*)))::cardinal_number AS character_maximum_length, (_pg_char_octet_length(_pg_truetypid(a.*, t.*), _pg_truetypmod(a.*, t.*)))::cardinal_number AS character_octet_length, (NULL::character varying)::sql_identifier AS character_set_catalog, (NULL::character varying)::sql_identifier AS character_set_schema, (NULL::character varying)::sql_identifier AS character_set_name, (NULL::character varying)::sql_identifier AS collation_catalog, (NULL::character varying)::sql_identifier AS collation_schema, (NULL::character varying)::sql_identifier AS collation_name, (_pg_numeric_precision(_pg_truetypid(a.*, t.*), _pg_truetypmod(a.*, t.*)))::cardinal_number AS numeric_precision, (_pg_numeric_precision_radix(_pg_truetypid(a.*, t.*), _pg_truetypmod(a.*, t.*)))::cardinal_number AS numeric_precision_radix, (_pg_numeric_scale(_pg_truetypid(a.*, t.*), _pg_truetypmod(a.*, t.*)))::cardinal_number AS numeric_scale, (_pg_datetime_precision(_pg_truetypid(a.*, t.*), _pg_truetypmod(a.*, t.*)))::cardinal_number AS datetime_precision, (NULL::character varying)::character_data AS interval_type, (NULL::character varying)::character_data AS interval_precision, (current_database())::sql_identifier AS attribute_udt_catalog, (nt.nspname)::sql_identifier AS attribute_udt_schema, (t.typname)::sql_identifier AS attribute_udt_name, (NULL::character varying)::sql_identifier AS scope_catalog, (NULL::character varying)::sql_identifier AS scope_schema, (NULL::character varying)::sql_identifier AS scope_name, (NULL::integer)::cardinal_number AS maximum_cardinality, (a.attnum)::sql_identifier AS dtd_identifier, ('NO'::character varying)::character_data AS is_derived_reference_attribute FROM (pg_attribute a LEFT JOIN pg_attrdef ad ON (((a.attrelid = ad.adrelid) AND (a.attnum = ad.adnum)))), pg_class c, pg_namespace nc, (pg_type t JOIN pg_namespace nt ON ((t.typnamespace = nt.oid))) WHERE ((((((a.attrelid = c.oid) AND (a.atttypid = t.oid)) AND (nc.oid = c.relnamespace)) AND (a.attnum > 0)) AND (NOT a.attisdropped)) AND (c.relkind = 'c'::"char"));

ALTER TABLE information_schema.attributes OWNER TO postgres;

See Also

List of views


View: check_constraint_routine_usage

Properties

Name: | check_constraint_routine_usage
Owner: | postgres
Has rules: |
Has Triggers: |
Comment: |

Columns

Name | Type | Length
constraint_catalog | sql_identifier | -1
constraint_schema | sql_identifier | -1
constraint_name | sql_identifier | -1
specific_catalog | sql_identifier | -1
specific_schema | sql_identifier | -1
specific_name | sql_identifier | -1
Total: 6 column(s)

SQL

CREATE VIEW check_constraint_routine_usage AS
SELECT (current_database())::sql_identifier AS constraint_catalog, (nc.nspname)::sql_identifier AS constraint_schema, (c.conname)::sql_identifier AS constraint_name, (current_database())::sql_identifier AS specific_catalog, (np.nspname)::sql_identifier AS specific_schema, ((((p.proname)::text || '_'::text) || (p.oid)::text))::sql_identifier AS specific_name FROM pg_namespace nc, pg_constraint c, pg_depend d, pg_proc p, pg_namespace np WHERE ((((((((nc.oid = c.connamespace) AND (c.contype = 'c'::"char")) AND (c.oid = d.objid)) AND (d.classid = ('pg_constraint'::regclass)::oid)) AND (d.refobjid = p.oid)) AND (d.refclassid = ('pg_proc'::regclass)::oid)) AND (p.pronamespace = np.oid)) AND pg_has_role(p.proowner, 'USAGE'::text));

ALTER TABLE information_schema.check_constraint_routine_usage OWNER TO postgres;

See Also

List of views


View: check_constraints

Properties

Name: | check_constraints
Owner: | postgres
Has rules: |
Has Triggers: |
Comment: |

Columns

Name | Type | Length
constraint_catalog | varchar | -1
constraint_schema | varchar | -1
constraint_name | varchar | -1
check_clause | varchar | -1
Total: 4 column(s)

SQL

CREATE VIEW check_constraints AS
SELECT (current_database())::sql_identifier AS constraint_catalog, (rs.nspname)::sql_identifier AS constraint_schema, (con.conname)::sql_identifier AS constraint_name, ("substring"(pg_get_constraintdef(con.oid), 7))::character_data AS check_clause FROM (((pg_constraint con LEFT JOIN pg_namespace rs ON ((rs.oid = con.connamespace))) LEFT JOIN pg_class c ON ((c.oid = con.conrelid))) LEFT JOIN pg_type t ON ((t.oid = con.contypid))) WHERE (pg_has_role(COALESCE(c.relowner, t.typowner), 'USAGE'::text) AND (con.contype = 'c'::"char")) UNION SELECT (current_database())::sql_identifier AS constraint_catalog, (n.nspname)::sql_identifier AS constraint_schema, (((((((n.oid)::text || '_'::text) || (r.oid)::text) || '_'::text) || (a.attnum)::text) || '_not_null'::text))::sql_identifier AS constraint_name, (((a.attname)::text || ' IS NOT NULL'::text))::character_data AS check_clause FROM pg_namespace n, pg_class r, pg_attribute a WHERE (((((((n.oid = r.relnamespace) AND (r.oid = a.attrelid)) AND (a.attnum > 0)) AND (NOT a.attisdropped)) AND a.attnotnull) AND (r.relkind = 'r'::"char")) AND pg_has_role(r.relowner, 'USAGE'::text));

ALTER TABLE information_schema.check_constraints OWNER TO postgres;

See Also

List of views


View: column_domain_usage

Properties

Name: | column_domain_usage
Owner: | postgres
Has rules: |
Has Triggers: |
Comment: |

Columns

Name | Type | Length
domain_catalog | sql_identifier | -1
domain_schema | sql_identifier | -1
domain_name | sql_identifier | -1
table_catalog | sql_identifier | -1
table_schema | sql_identifier | -1
table_name | sql_identifier | -1
column_name | sql_identifier | -1
Total: 7 column(s)

SQL

CREATE VIEW column_domain_usage AS
SELECT (current_database())::sql_identifier AS domain_catalog, (nt.nspname)::sql_identifier AS domain_schema, (t.typname)::sql_identifier AS domain_name, (current_database())::sql_identifier AS table_catalog, (nc.nspname)::sql_identifier AS table_schema, (c.relname)::sql_identifier AS table_name, (a.attname)::sql_identifier AS column_name FROM pg_type t, pg_namespace nt, pg_class c, pg_namespace nc, pg_attribute a WHERE (((((((((t.typnamespace = nt.oid) AND (c.relnamespace = nc.oid)) AND (a.attrelid = c.oid)) AND (a.atttypid = t.oid)) AND (t.typtype = 'd'::"char")) AND (c.relkind = ANY (ARRAY['r'::"char", 'v'::"char"]))) AND (a.attnum > 0)) AND (NOT a.attisdropped)) AND pg_has_role(t.typowner, 'USAGE'::text));

ALTER TABLE information_schema.column_domain_usage OWNER TO postgres;

See Also

List of views


View: column_privileges

Properties

Name: | column_privileges
Owner: | postgres
Has rules: |
Has Triggers: |
Comment: |

Columns

Name | Type | Length
grantor | sql_identifier | -1
grantee | sql_identifier | -1
table_catalog | sql_identifier | -1
table_schema | sql_identifier | -1
table_name | sql_identifier | -1
column_name | sql_identifier | -1
privilege_type | character_data | -1
is_grantable | character_data | -1
Total: 8 column(s)

SQL

CREATE VIEW column_privileges AS
SELECT (u_grantor.rolname)::sql_identifier AS grantor, (grantee.rolname)::sql_identifier AS grantee, (current_database())::sql_identifier AS table_catalog, (nc.nspname)::sql_identifier AS table_schema, (c.relname)::sql_identifier AS table_name, (a.attname)::sql_identifier AS column_name, (pr."type")::character_data AS privilege_type, (CASE WHEN aclcontains(c.relacl, makeaclitem(grantee.oid, u_grantor.oid, pr."type", true)) THEN 'YES'::text ELSE 'NO'::text END)::character_data AS is_grantable FROM pg_attribute a, pg_class c, pg_namespace nc, pg_authid u_grantor, (SELECT pg_authid.oid, pg_authid.rolname FROM pg_authid UNION ALL SELECT (0)::oid AS oid, 'PUBLIC') grantee(oid, rolname), (((SELECT 'SELECT' UNION ALL SELECT 'INSERT') UNION ALL SELECT 'UPDATE') UNION ALL SELECT 'REFERENCES') pr("type") WHERE (((((((a.attrelid = c.oid) AND (c.relnamespace = nc.oid)) AND (a.attnum > 0)) AND (NOT a.attisdropped)) AND (c.relkind = ANY (ARRAY['r'::"char", 'v'::"char"]))) AND aclcontains(c.relacl, makeaclitem(grantee.oid, u_grantor.oid, pr."type", false))) AND ((pg_has_role(u_grantor.oid, 'USAGE'::text) OR pg_has_role(grantee.oid, 'USAGE'::text)) OR (grantee.rolname = 'PUBLIC'::name)));

ALTER TABLE information_schema.column_privileges OWNER TO postgres;

See Also

List of views


View: column_udt_usage

Properties

Name: | column_udt_usage
Owner: | postgres
Has rules: |
Has Triggers: |
Comment: |

Columns

Name | Type | Length
udt_catalog | sql_identifier | -1
udt_schema | sql_identifier | -1
udt_name | sql_identifier | -1
table_catalog | sql_identifier | -1
table_schema | sql_identifier | -1
table_name | sql_identifier | -1
column_name | sql_identifier | -1
Total: 7 column(s)

SQL

CREATE VIEW column_udt_usage AS
SELECT (current_database())::sql_identifier AS udt_catalog, (COALESCE(nbt.nspname, nt.nspname))::sql_identifier AS udt_schema, (COALESCE(bt.typname, t.typname))::sql_identifier AS udt_name, (current_database())::sql_identifier AS table_catalog, (nc.nspname)::sql_identifier AS table_schema, (c.relname)::sql_identifier AS table_name, (a.attname)::sql_identifier AS column_name FROM pg_attribute a, pg_class c, pg_namespace nc, ((pg_type t JOIN pg_namespace nt ON ((t.typnamespace = nt.oid))) LEFT JOIN (pg_type bt JOIN pg_namespace nbt ON ((bt.typnamespace = nbt.oid))) ON (((t.typtype = 'd'::"char") AND (t.typbasetype = bt.oid)))) WHERE (((((((a.attrelid = c.oid) AND (a.atttypid = t.oid)) AND (nc.oid = c.relnamespace)) AND (a.attnum > 0)) AND (NOT a.attisdropped)) AND (c.relkind = ANY (ARRAY['r'::"char", 'v'::"char"]))) AND pg_has_role(COALESCE(bt.typowner, t.typowner), 'USAGE'::text));

ALTER TABLE information_schema.column_udt_usage OWNER TO postgres;

See Also

List of views


View: columns

Properties

Name: | columns
Owner: | postgres
Has rules: |
Has Triggers: |
Comment: |

Columns

Name | Type | Length
table_catalog | sql_identifier | -1
table_schema | sql_identifier | -1
table_name | sql_identifier | -1
column_name | sql_identifier | -1
ordinal_position | cardinal_number | -1
column_default | character_data | -1
is_nullable | character_data | -1
data_type | character_data | -1
character_maximum_length | cardinal_number | -1
character_octet_length | cardinal_number | -1
numeric_precision | cardinal_number | -1
numeric_precision_radix | cardinal_number | -1
numeric_scale | cardinal_number | -1
datetime_precision | cardinal_number | -1
interval_type | character_data | -1
interval_precision | character_data | -1
character_set_catalog | sql_identifier | -1
character_set_schema | sql_identifier | -1
character_set_name | sql_identifier | -1
collation_catalog | sql_identifier | -1
collation_schema | sql_identifier | -1
collation_name | sql_identifier | -1
domain_catalog | sql_identifier | -1
domain_schema | sql_identifier | -1
domain_name | sql_identifier | -1
udt_catalog | sql_identifier | -1
udt_schema | sql_identifier | -1
udt_name | sql_identifier | -1
scope_catalog | sql_identifier | -1
scope_schema | sql_identifier | -1
scope_name | sql_identifier | -1
maximum_cardinality | cardinal_number | -1
dtd_identifier | sql_identifier | -1
is_self_referencing | character_data | -1
is_identity | character_data | -1
identity_generation | character_data | -1
identity_start | character_data | -1
identity_increment | character_data | -1
identity_maximum | character_data | -1
identity_minimum | character_data | -1
identity_cycle | character_data | -1
is_generated | character_data | -1
generation_expression | character_data | -1
is_updatable | character_data | -1
Total: 44 column(s)

SQL

CREATE VIEW columns AS
SELECT (current_database())::sql_identifier AS table_catalog, (nc.nspname)::sql_identifier AS table_schema, (c.relname)::sql_identifier AS table_name, (a.attname)::sql_identifier AS column_name, (a.attnum)::cardinal_number AS ordinal_position, (pg_get_expr(ad.adbin, ad.adrelid))::character_data AS column_default, (CASE WHEN (a.attnotnull OR ((t.typtype = 'd'::"char") AND t.typnotnull)) THEN 'NO'::text ELSE 'YES'::text END)::character_data AS is_nullable, (CASE WHEN (t.typtype = 'd'::"char") THEN CASE WHEN ((bt.typelem <> (0)::oid) AND (bt.typlen = -1)) THEN 'ARRAY'::text WHEN (nbt.nspname = 'pg_catalog'::name) THEN format_type(t.typbasetype, NULL::integer) ELSE 'USER-DEFINED'::text END ELSE CASE WHEN ((t.typelem <> (0)::oid) AND (t.typlen = -1)) THEN 'ARRAY'::text WHEN (nt.nspname = 'pg_catalog'::name) THEN format_type(a.atttypid, NULL::integer) ELSE 'USER-DEFINED'::text END END)::character_data AS data_type, (_pg_char_max_length(_pg_truetypid(a.*, t.*), _pg_truetypmod(a.*, t.*)))::cardinal_number AS character_maximum_length, (_pg_char_octet_length(_pg_truetypid(a.*, t.*), _pg_truetypmod(a.*, t.*)))::cardinal_number AS character_octet_length, (_pg_numeric_precision(_pg_truetypid(a.*, t.*), _pg_truetypmod(a.*, t.*)))::cardinal_number AS numeric_precision, (_pg_numeric_precision_radix(_pg_truetypid(a.*, t.*), _pg_truetypmod(a.*, t.*)))::cardinal_number AS numeric_precision_radix, (_pg_numeric_scale(_pg_truetypid(a.*, t.*), _pg_truetypmod(a.*, t.*)))::cardinal_number AS numeric_scale, (_pg_datetime_precision(_pg_truetypid(a.*, t.*), _pg_truetypmod(a.*, t.*)))::cardinal_number AS datetime_precision, (NULL::character varying)::character_data AS interval_type, (NULL::character varying)::character_data AS interval_precision, (NULL::character varying)::sql_identifier AS character_set_catalog, (NULL::character varying)::sql_identifier AS character_set_schema, (NULL::character varying)::sql_identifier AS character_set_name, (NULL::character varying)::sql_identifier AS collation_catalog, (NULL::character varying)::sql_identifier AS collation_schema, (NULL::character varying)::sql_identifier AS collation_name, (CASE WHEN (t.typtype = 'd'::"char") THEN current_database() ELSE NULL::name END)::sql_identifier AS domain_catalog, (CASE WHEN (t.typtype = 'd'::"char") THEN nt.nspname ELSE NULL::name END)::sql_identifier AS domain_schema, (CASE WHEN (t.typtype = 'd'::"char") THEN t.typname ELSE NULL::name END)::sql_identifier AS domain_name, (current_database())::sql_identifier AS udt_catalog, (COALESCE(nbt.nspname, nt.nspname))::sql_identifier AS udt_schema, (COALESCE(bt.typname, t.typname))::sql_identifier AS udt_name, (NULL::character varying)::sql_identifier AS scope_catalog, (NULL::character varying)::sql_identifier AS scope_schema, (NULL::character varying)::sql_identifier AS scope_name, (NULL::integer)::cardinal_number AS maximum_cardinality, (a.attnum)::sql_identifier AS dtd_identifier, ('NO'::character varying)::character_data AS is_self_referencing, ('NO'::character varying)::character_data AS is_identity, (NULL::character varying)::character_data AS identity_generation, (NULL::character varying)::character_data AS identity_start, (NULL::character varying)::character_data AS identity_increment, (NULL::character varying)::character_data AS identity_maximum, (NULL::character varying)::character_data AS identity_minimum, (NULL::character varying)::character_data AS identity_cycle, ('NEVER'::character varying)::character_data AS is_generated, (NULL::character varying)::character_data AS generation_expression, (CASE WHEN (c.relkind = 'r'::"char") THEN 'YES'::text ELSE 'NO'::text END)::character_data AS is_updatable FROM (pg_attribute a LEFT JOIN pg_attrdef ad ON (((a.attrelid = ad.adrelid) AND (a.attnum = ad.adnum)))), pg_class c, pg_namespace nc, ((pg_type t JOIN pg_namespace nt ON ((t.typnamespace = nt.oid))) LEFT JOIN (pg_type bt JOIN pg_namespace nbt ON ((bt.typnamespace = nbt.oid))) ON (((t.typtype = 'd'::"char") AND (t.typbasetype = bt.oid)))) WHERE ((((((((a.attrelid = c.oid) AND (a.atttypid = t.oid)) AND (nc.oid = c.relnamespace)) AND (NOT pg_is_other_temp_schema(nc.oid))) AND (a.attnum > 0)) AND (NOT a.attisdropped)) AND (c.relkind = ANY (ARRAY['r'::"char", 'v'::"char"]))) AND ((((pg_has_role(c.relowner, 'USAGE'::text) OR has_table_privilege(c.oid, 'SELECT'::text)) OR has_table_privilege(c.oid, 'INSERT'::text)) OR has_table_privilege(c.oid, 'UPDATE'::text)) OR has_table_privilege(c.oid, 'REFERENCES'::text)));

ALTER TABLE information_schema.columns OWNER TO postgres;

See Also

List of views


View: constraint_column_usage

Properties

Name: | constraint_column_usage
Owner: | postgres
Has rules: |
Has Triggers: |
Comment: |

Columns

Name | Type | Length
table_catalog | sql_identifier | -1
table_schema | sql_identifier | -1
table_name | sql_identifier | -1
column_name | sql_identifier | -1
constraint_catalog | sql_identifier | -1
constraint_schema | sql_identifier | -1
constraint_name | sql_identifier | -1
Total: 7 column(s)

SQL

CREATE VIEW constraint_column_usage AS
SELECT (current_database())::sql_identifier AS table_catalog, (x.tblschema)::sql_identifier AS table_schema, (x.tblname)::sql_identifier AS table_name, (x.colname)::sql_identifier AS column_name, (current_database())::sql_identifier AS constraint_catalog, (x.cstrschema)::sql_identifier AS constraint_schema, (x.cstrname)::sql_identifier AS constraint_name FROM ((SELECT DISTINCT nr.nspname, r.relname, r.relowner, a.attname, nc.nspname, c.conname FROM pg_namespace nr, pg_class r, pg_attribute a, pg_depend d, pg_namespace nc, pg_constraint c WHERE (((((((((((nr.oid = r.relnamespace) AND (r.oid = a.attrelid)) AND (d.refclassid = ('pg_class'::regclass)::oid)) AND (d.refobjid = r.oid)) AND (d.refobjsubid = a.attnum)) AND (d.classid = ('pg_constraint'::regclass)::oid)) AND (d.objid = c.oid)) AND (c.connamespace = nc.oid)) AND (c.contype = 'c'::"char")) AND (r.relkind = 'r'::"char")) AND (NOT a.attisdropped)) ORDER BY nr.nspname, r.relname, r.relowner, a.attname, nc.nspname, c.conname) UNION ALL SELECT nr.nspname, r.relname, r.relowner, a.attname, nc.nspname, c.conname FROM pg_namespace nr, pg_class r, pg_attribute a, pg_namespace nc, pg_constraint c WHERE (((((((nr.oid = r.relnamespace) AND (r.oid = a.attrelid)) AND (nc.oid = c.connamespace)) AND CASE WHEN (c.contype = 'f'::"char") THEN ((r.oid = c.confrelid) AND (a.attnum = ANY (c.confkey))) ELSE ((r.oid = c.conrelid) AND (a.attnum = ANY (c.conkey))) END) AND (NOT a.attisdropped)) AND (c.contype = ANY (ARRAY['p'::"char", 'u'::"char", 'f'::"char"]))) AND (r.relkind = 'r'::"char"))) x(tblschema, tblname, tblowner, colname, cstrschema, cstrname) WHERE pg_has_role(x.tblowner, 'USAGE'::text);

ALTER TABLE information_schema.constraint_column_usage OWNER TO postgres;

See Also

List of views


View: constraint_table_usage

Properties

Name: | constraint_table_usage
Owner: | postgres
Has rules: |
Has Triggers: |
Comment: |

Columns

Name | Type | Length
table_catalog | sql_identifier | -1
table_schema | sql_identifier | -1
table_name | sql_identifier | -1
constraint_catalog | sql_identifier | -1
constraint_schema | sql_identifier | -1
constraint_name | sql_identifier | -1
Total: 6 column(s)

SQL

CREATE VIEW constraint_table_usage AS
SELECT (current_database())::sql_identifier AS table_catalog, (nr.nspname)::sql_identifier AS table_schema, (r.relname)::sql_identifier AS table_name, (current_database())::sql_identifier AS constraint_catalog, (nc.nspname)::sql_identifier AS constraint_schema, (c.conname)::sql_identifier AS constraint_name FROM pg_constraint c, pg_namespace nc, pg_class r, pg_namespace nr WHERE (((((c.connamespace = nc.oid) AND (r.relnamespace = nr.oid)) AND (((c.contype = 'f'::"char") AND (c.confrelid = r.oid)) OR ((c.contype = ANY (ARRAY['p'::"char", 'u'::"char"])) AND (c.conrelid = r.oid)))) AND (r.relkind = 'r'::"char")) AND pg_has_role(r.relowner, 'USAGE'::text));

ALTER TABLE information_schema.constraint_table_usage OWNER TO postgres;

See Also

List of views


View: data_type_privileges

Properties

Name: | data_type_privileges
Owner: | postgres
Has rules: |
Has Triggers: |
Comment: |

Columns

Name | Type | Length
object_catalog | sql_identifier | -1
object_schema | sql_identifier | -1
object_name | sql_identifier | -1
object_type | character_data | -1
dtd_identifier | sql_identifier | -1
Total: 5 column(s)

SQL

CREATE VIEW data_type_privileges AS
SELECT (current_database())::sql_identifier AS object_catalog, (x.objschema)::sql_identifier AS object_schema, (x.objname)::sql_identifier AS object_name, (x.objtype)::character_data AS object_type, (x.objdtdid)::sql_identifier AS dtd_identifier FROM ((((SELECT attributes.udt_schema, attributes.udt_name, 'USER-DEFINED TYPE'::text AS text, attributes.dtd_identifier FROM attributes UNION ALL SELECT columns.table_schema, columns.table_name, 'TABLE'::text AS text, columns.dtd_identifier FROM columns) UNION ALL SELECT domains.domain_schema, domains.domain_name, 'DOMAIN'::text AS text, domains.dtd_identifier FROM domains) UNION ALL SELECT parameters.specific_schema, parameters.specific_name, 'ROUTINE'::text AS text, parameters.dtd_identifier FROM parameters) UNION ALL SELECT routines.specific_schema, routines.specific_name, 'ROUTINE'::text AS text, routines.dtd_identifier FROM routines) x(objschema, objname, objtype, objdtdid);

ALTER TABLE information_schema.data_type_privileges OWNER TO postgres;

See Also

List of views


View: domain_constraints

Properties

Name: | domain_constraints
Owner: | postgres
Has rules: |
Has Triggers: |
Comment: |

Columns

Name | Type | Length
constraint_catalog | sql_identifier | -1
constraint_schema | sql_identifier | -1
constraint_name | sql_identifier | -1
domain_catalog | sql_identifier | -1
domain_schema | sql_identifier | -1
domain_name | sql_identifier | -1
is_deferrable | character_data | -1
initially_deferred | character_data | -1
Total: 8 column(s)

SQL

CREATE VIEW domain_constraints AS
SELECT (current_database())::sql_identifier AS constraint_catalog, (rs.nspname)::sql_identifier AS constraint_schema, (con.conname)::sql_identifier AS constraint_name, (current_database())::sql_identifier AS domain_catalog, (n.nspname)::sql_identifier AS domain_schema, (t.typname)::sql_identifier AS domain_name, (CASE WHEN con.condeferrable THEN 'YES'::text ELSE 'NO'::text END)::character_data AS is_deferrable, (CASE WHEN con.condeferred THEN 'YES'::text ELSE 'NO'::text END)::character_data AS initially_deferred FROM pg_namespace rs, pg_namespace n, pg_constraint con, pg_type t WHERE (((rs.oid = con.connamespace) AND (n.oid = t.typnamespace)) AND (t.oid = con.contypid));

ALTER TABLE information_schema.domain_constraints OWNER TO postgres;

See Also

List of views


View: domain_udt_usage

Properties

Name: | domain_udt_usage
Owner: | postgres
Has rules: |
Has Triggers: |
Comment: |

Columns

Name | Type | Length
udt_catalog | sql_identifier | -1
udt_schema | sql_identifier | -1
udt_name | sql_identifier | -1
domain_catalog | sql_identifier | -1
domain_schema | sql_identifier | -1
domain_name | sql_identifier | -1
Total: 6 column(s)

SQL

CREATE VIEW domain_udt_usage AS
SELECT (current_database())::sql_identifier AS udt_catalog, (nbt.nspname)::sql_identifier AS udt_schema, (bt.typname)::sql_identifier AS udt_name, (current_database())::sql_identifier AS domain_catalog, (nt.nspname)::sql_identifier AS domain_schema, (t.typname)::sql_identifier AS domain_name FROM pg_type t, pg_namespace nt, pg_type bt, pg_namespace nbt WHERE (((((t.typnamespace = nt.oid) AND (t.typbasetype = bt.oid)) AND (bt.typnamespace = nbt.oid)) AND (t.typtype = 'd'::"char")) AND pg_has_role(bt.typowner, 'USAGE'::text));

ALTER TABLE information_schema.domain_udt_usage OWNER TO postgres;

See Also

List of views


View: domains

Properties

Name: | domains
Owner: | postgres
Has rules: |
Has Triggers: |
Comment: |

Columns

Name | Type | Length
domain_catalog | sql_identifier | -1
domain_schema | sql_identifier | -1
domain_name | sql_identifier | -1
data_type | character_data | -1
character_maximum_length | cardinal_number | -1
character_octet_length | cardinal_number | -1
character_set_catalog | sql_identifier | -1
character_set_schema | sql_identifier | -1
character_set_name | sql_identifier | -1
collation_catalog | sql_identifier | -1
collation_schema | sql_identifier | -1
collation_name | sql_identifier | -1
numeric_precision | cardinal_number | -1
numeric_precision_radix | cardinal_number | -1
numeric_scale | cardinal_number | -1
datetime_precision | cardinal_number | -1
interval_type | character_data | -1
interval_precision | character_data | -1
domain_default | character_data | -1
udt_catalog | sql_identifier | -1
udt_schema | sql_identifier | -1
udt_name | sql_identifier | -1
scope_catalog | sql_identifier | -1
scope_schema | sql_identifier | -1
scope_name | sql_identifier | -1
maximum_cardinality | cardinal_number | -1
dtd_identifier | sql_identifier | -1
Total: 27 column(s)

SQL

CREATE VIEW domains AS
SELECT (current_database())::sql_identifier AS domain_catalog, (nt.nspname)::sql_identifier AS domain_schema, (t.typname)::sql_identifier AS domain_name, (CASE WHEN ((t.typelem <> (0)::oid) AND (t.typlen = -1)) THEN 'ARRAY'::text WHEN (nbt.nspname = 'pg_catalog'::name) THEN format_type(t.typbasetype, NULL::integer) ELSE 'USER-DEFINED'::text END)::character_data AS data_type, (_pg_char_max_length(t.typbasetype, t.typtypmod))::cardinal_number AS character_maximum_length, (_pg_char_octet_length(t.typbasetype, t.typtypmod))::cardinal_number AS character_octet_length, (NULL::character varying)::sql_identifier AS character_set_catalog, (NULL::character varying)::sql_identifier AS character_set_schema, (NULL::character varying)::sql_identifier AS character_set_name, (NULL::character varying)::sql_identifier AS collation_catalog, (NULL::character varying)::sql_identifier AS collation_schema, (NULL::character varying)::sql_identifier AS collation_name, (_pg_numeric_precision(t.typbasetype, t.typtypmod))::cardinal_number AS numeric_precision, (_pg_numeric_precision_radix(t.typbasetype, t.typtypmod))::cardinal_number AS numeric_precision_radix, (_pg_numeric_scale(t.typbasetype, t.typtypmod))::cardinal_number AS numeric_scale, (_pg_datetime_precision(t.typbasetype, t.typtypmod))::cardinal_number AS datetime_precision, (NULL::character varying)::character_data AS interval_type, (NULL::character varying)::character_data AS interval_precision, (t.typdefault)::character_data AS domain_default, (current_database())::sql_identifier AS udt_catalog, (nbt.nspname)::sql_identifier AS udt_schema, (bt.typname)::sql_identifier AS udt_name, (NULL::character varying)::sql_identifier AS scope_catalog, (NULL::character varying)::sql_identifier AS scope_schema, (NULL::character varying)::sql_identifier AS scope_name, (NULL::integer)::cardinal_number AS maximum_cardinality, (1)::sql_identifier AS dtd_identifier FROM pg_type t, pg_namespace nt, pg_type bt, pg_namespace nbt WHERE ((((t.typnamespace = nt.oid) AND (t.typbasetype = bt.oid)) AND (bt.typnamespace = nbt.oid)) AND (t.typtype = 'd'::"char"));

ALTER TABLE information_schema.domains OWNER TO postgres;

See Also

List of views


View: element_types

Properties

Name: | element_types
Owner: | postgres
Has rules: |
Has Triggers: |
Comment: |

Columns

Name | Type | Length
object_catalog | sql_identifier | -1
object_schema | sql_identifier | -1
object_name | sql_identifier | -1
object_type | character_data | -1
collection_type_identifier | sql_identifier | -1
data_type | character_data | -1
character_maximum_length | cardinal_number | -1
character_octet_length | cardinal_number | -1
character_set_catalog | sql_identifier | -1
character_set_schema | sql_identifier | -1
character_set_name | sql_identifier | -1
collation_catalog | sql_identifier | -1
collation_schema | sql_identifier | -1
collation_name | sql_identifier | -1
numeric_precision | cardinal_number | -1
numeric_precision_radix | cardinal_number | -1
numeric_scale | cardinal_number | -1
datetime_precision | cardinal_number | -1
interval_type | character_data | -1
interval_precision | character_data | -1
domain_default | character_data | -1
udt_catalog | sql_identifier | -1
udt_schema | sql_identifier | -1
udt_name | sql_identifier | -1
scope_catalog | sql_identifier | -1
scope_schema | sql_identifier | -1
scope_name | sql_identifier | -1
maximum_cardinality | cardinal_number | -1
dtd_identifier | sql_identifier | -1
Total: 29 column(s)

SQL

CREATE VIEW element_types AS
SELECT (current_database())::sql_identifier AS object_catalog, (n.nspname)::sql_identifier AS object_schema, (x.objname)::sql_identifier AS object_name, (x.objtype)::character_data AS object_type, (x.objdtdid)::sql_identifier AS collection_type_identifier, (CASE WHEN (nbt.nspname = 'pg_catalog'::name) THEN format_type(bt.oid, NULL::integer) ELSE 'USER-DEFINED'::text END)::character_data AS data_type, (NULL::integer)::cardinal_number AS character_maximum_length, (NULL::integer)::cardinal_number AS character_octet_length, (NULL::character varying)::sql_identifier AS character_set_catalog, (NULL::character varying)::sql_identifier AS character_set_schema, (NULL::character varying)::sql_identifier AS character_set_name, (NULL::character varying)::sql_identifier AS collation_catalog, (NULL::character varying)::sql_identifier AS collation_schema, (NULL::character varying)::sql_identifier AS collation_name, (NULL::integer)::cardinal_number AS numeric_precision, (NULL::integer)::cardinal_number AS numeric_precision_radix, (NULL::integer)::cardinal_number AS numeric_scale, (NULL::integer)::cardinal_number AS datetime_precision, (NULL::character varying)::character_data AS interval_type, (NULL::character varying)::character_data AS interval_precision, (NULL::character varying)::character_data AS domain_default, (current_database())::sql_identifier AS udt_catalog, (nbt.nspname)::sql_identifier AS udt_schema, (bt.typname)::sql_identifier AS udt_name, (NULL::character varying)::sql_identifier AS scope_catalog, (NULL::character varying)::sql_identifier AS scope_schema, (NULL::character varying)::sql_identifier AS scope_name, (NULL::integer)::cardinal_number AS maximum_cardinality, (('a'::text || (x.objdtdid)::text))::sql_identifier AS dtd_identifier FROM pg_namespace n, pg_type "at", pg_namespace nbt, pg_type bt, (((SELECT c.relnamespace, (c.relname)::sql_identifier AS relname, 'TABLE'::text AS text, a.attnum, a.atttypid FROM pg_class c, pg_attribute a WHERE ((((c.oid = a.attrelid) AND (c.relkind = ANY (ARRAY['r'::"char", 'v'::"char"]))) AND (a.attnum > 0)) AND (NOT a.attisdropped)) UNION ALL SELECT t.typnamespace, (t.typname)::sql_identifier AS typname, 'DOMAIN'::text AS text, 1, t.typbasetype FROM pg_type t WHERE (t.typtype = 'd'::"char")) UNION ALL SELECT ss.pronamespace, ((((ss.proname)::text || '_'::text) || (ss.oid)::text))::sql_identifier AS sql_identifier, 'ROUTINE'::text AS text, (ss.x).n AS n, (ss.x).x AS x FROM (SELECT p.pronamespace, p.proname, p.oid, _pg_expandarray(COALESCE(p.proallargtypes, (p.proargtypes)::oid[])) AS x FROM pg_proc p) ss) UNION ALL SELECT p.pronamespace, ((((p.proname)::text || '_'::text) || (p.oid)::text))::sql_identifier AS sql_identifier, 'ROUTINE'::text AS text, 0, p.prorettype FROM pg_proc p) x(objschema, objname, objtype, objdtdid, objtypeid) WHERE ((((((n.oid = x.objschema) AND ("at".oid = x.objtypeid)) AND (("at".typelem <> (0)::oid) AND ("at".typlen = -1))) AND ("at".typelem = bt.oid)) AND (nbt.oid = bt.typnamespace)) AND ((n.nspname, (x.objname)::text, x.objtype, (x.objdtdid)::text) IN (SELECT data_type_privileges.object_schema, data_type_privileges.object_name, data_type_privileges.object_type, data_type_privileges.dtd_identifier FROM data_type_privileges)));

ALTER TABLE information_schema.element_types OWNER TO postgres;

See Also

List of views


View: enabled_roles

Properties

Name: | enabled_roles
Owner: | postgres
Has rules: |
Has Triggers: |
Comment: |

Columns

Name | Type | Length
role_name | sql_identifier | -1
Total: 1 column(s)

SQL

CREATE VIEW enabled_roles AS
SELECT (a.rolname)::sql_identifier AS role_name FROM pg_authid a WHERE pg_has_role(a.oid, 'USAGE'::text);

ALTER TABLE information_schema.enabled_roles OWNER TO postgres;

See Also

List of views


View: information_schema_catalog_name

Properties

Name: | information_schema_catalog_name
Owner: | postgres
Has rules: |
Has Triggers: |
Comment: |

Columns

Name | Type | Length
catalog_name | sql_identifier | -1
Total: 1 column(s)

SQL

CREATE VIEW information_schema_catalog_name AS
SELECT (current_database())::sql_identifier AS catalog_name;

ALTER TABLE information_schema.information_schema_catalog_name OWNER TO postgres;

See Also

List of views


View: key_column_usage

Properties

Name: | key_column_usage
Owner: | postgres
Has rules: |
Has Triggers: |
Comment: |

Columns

Name | Type | Length
constraint_catalog | sql_identifier | -1
constraint_schema | sql_identifier | -1
constraint_name | sql_identifier | -1
table_catalog | sql_identifier | -1
table_schema | sql_identifier | -1
table_name | sql_identifier | -1
column_name | sql_identifier | -1
ordinal_position | cardinal_number | -1
position_in_unique_constraint | cardinal_number | -1
Total: 9 column(s)

SQL

CREATE VIEW key_column_usage AS
SELECT (current_database())::sql_identifier AS constraint_catalog, (ss.nc_nspname)::sql_identifier AS constraint_schema, (ss.conname)::sql_identifier AS constraint_name, (current_database())::sql_identifier AS table_catalog, (ss.nr_nspname)::sql_identifier AS table_schema, (ss.relname)::sql_identifier AS table_name, (a.attname)::sql_identifier AS column_name, ((ss.x).n)::cardinal_number AS ordinal_position, (CASE WHEN (ss.contype = 'f'::"char") THEN _pg_index_position(_pg_underlying_index(ss.coid), ss.confkey[(ss.x).n]) ELSE NULL::integer END)::cardinal_number AS position_in_unique_constraint FROM pg_attribute a, (SELECT r.oid AS roid, r.relname, nc.nspname AS nc_nspname, nr.nspname AS nr_nspname, c.oid AS coid, c.conname, c.contype, c.confkey, c.confrelid, _pg_expandarray(c.conkey) AS x FROM pg_namespace nr, pg_class r, pg_namespace nc, pg_constraint c WHERE (((((((nr.oid = r.relnamespace) AND (r.oid = c.conrelid)) AND (nc.oid = c.connamespace)) AND (c.contype = ANY (ARRAY['p'::"char", 'u'::"char", 'f'::"char"]))) AND (r.relkind = 'r'::"char")) AND (NOT pg_is_other_temp_schema(nr.oid))) AND ((((pg_has_role(r.relowner, 'USAGE'::text) OR has_table_privilege(r.oid, 'SELECT'::text)) OR has_table_privilege(r.oid, 'INSERT'::text)) OR has_table_privilege(r.oid, 'UPDATE'::text)) OR has_table_privilege(r.oid, 'REFERENCES'::text)))) ss WHERE (((ss.roid = a.attrelid) AND (a.attnum = (ss.x).x)) AND (NOT a.attisdropped));

ALTER TABLE information_schema.key_column_usage OWNER TO postgres;

See Also

List of views


View: parameters

Properties

Name: | parameters
Owner: | postgres
Has rules: |
Has Triggers: |
Comment: |

Columns

Name | Type | Length
specific_catalog | sql_identifier | -1
specific_schema | sql_identifier | -1
specific_name | sql_identifier | -1
ordinal_position | cardinal_number | -1
parameter_mode | character_data | -1
is_result | character_data | -1
as_locator | character_data | -1
parameter_name | sql_identifier | -1
data_type | character_data | -1
character_maximum_length | cardinal_number | -1
character_octet_length | cardinal_number | -1
character_set_catalog | sql_identifier | -1
character_set_schema | sql_identifier | -1
character_set_name | sql_identifier | -1
collation_catalog | sql_identifier | -1
collation_schema | sql_identifier | -1
collation_name | sql_identifier | -1
numeric_precision | cardinal_number | -1
numeric_precision_radix | cardinal_number | -1
numeric_scale | cardinal_number | -1
datetime_precision | cardinal_number | -1
interval_type | character_data | -1
interval_precision | character_data | -1
udt_catalog | sql_identifier | -1
udt_schema | sql_identifier | -1
udt_name | sql_identifier | -1
scope_catalog | sql_identifier | -1
scope_schema | sql_identifier | -1
scope_name | sql_identifier | -1
maximum_cardinality | cardinal_number | -1
dtd_identifier | sql_identifier | -1
Total: 31 column(s)

SQL

CREATE VIEW parameters AS
SELECT (current_database())::sql_identifier AS specific_catalog, (ss.n_nspname)::sql_identifier AS specific_schema, ((((ss.proname)::text || '_'::text) || (ss.p_oid)::text))::sql_identifier AS specific_name, ((ss.x).n)::cardinal_number AS ordinal_position, (CASE WHEN (ss.proargmodes IS NULL) THEN 'IN'::text WHEN (ss.proargmodes[(ss.x).n] = 'i'::"char") THEN 'IN'::text WHEN (ss.proargmodes[(ss.x).n] = 'o'::"char") THEN 'OUT'::text WHEN (ss.proargmodes[(ss.x).n] = 'b'::"char") THEN 'INOUT'::text ELSE NULL::text END)::character_data AS parameter_mode, ('NO'::character varying)::character_data AS is_result, ('NO'::character varying)::character_data AS as_locator, (NULLIF(ss.proargnames[(ss.x).n], ''::text))::sql_identifier AS parameter_name, (CASE WHEN ((t.typelem <> (0)::oid) AND (t.typlen = -1)) THEN 'ARRAY'::text WHEN (nt.nspname = 'pg_catalog'::name) THEN format_type(t.oid, NULL::integer) ELSE 'USER-DEFINED'::text END)::character_data AS data_type, (NULL::integer)::cardinal_number AS character_maximum_length, (NULL::integer)::cardinal_number AS character_octet_length, (NULL::character varying)::sql_identifier AS character_set_catalog, (NULL::character varying)::sql_identifier AS character_set_schema, (NULL::character varying)::sql_identifier AS character_set_name, (NULL::character varying)::sql_identifier AS collation_catalog, (NULL::character varying)::sql_identifier AS collation_schema, (NULL::character varying)::sql_identifier AS collation_name, (NULL::integer)::cardinal_number AS numeric_precision, (NULL::integer)::cardinal_number AS numeric_precision_radix, (NULL::integer)::cardinal_number AS numeric_scale, (NULL::integer)::cardinal_number AS datetime_precision, (NULL::character varying)::character_data AS interval_type, (NULL::character varying)::character_data AS interval_precision, (current_database())::sql_identifier AS udt_catalog, (nt.nspname)::sql_identifier AS udt_schema, (t.typname)::sql_identifier AS udt_name, (NULL::character varying)::sql_identifier AS scope_catalog, (NULL::character varying)::sql_identifier AS scope_schema, (NULL::character varying)::sql_identifier AS scope_name, (NULL::integer)::cardinal_number AS maximum_cardinality, ((ss.x).n)::sql_identifier AS dtd_identifier FROM pg_type t, pg_namespace nt, (SELECT n.nspname AS n_nspname, p.proname, p.oid AS p_oid, p.proargnames, p.proargmodes, _pg_expandarray(COALESCE(p.proallargtypes, (p.proargtypes)::oid[])) AS x FROM pg_namespace n, pg_proc p WHERE ((n.oid = p.pronamespace) AND (pg_has_role(p.proowner, 'USAGE'::text) OR has_function_privilege(p.oid, 'EXECUTE'::text)))) ss WHERE ((t.oid = (ss.x).x) AND (t.typnamespace = nt.oid));

ALTER TABLE information_schema.parameters OWNER TO postgres;

See Also

List of views


View: referential_constraints

Properties

Name: | referential_constraints
Owner: | postgres
Has rules: |
Has Triggers: |
Comment: |

Columns

Name | Type | Length
constraint_catalog | sql_identifier | -1
constraint_schema | sql_identifier | -1
constraint_name | sql_identifier | -1
unique_constraint_catalog | sql_identifier | -1
unique_constraint_schema | sql_identifier | -1
unique_constraint_name | sql_identifier | -1
match_option | character_data | -1
update_rule | character_data | -1
delete_rule | character_data | -1
Total: 9 column(s)

SQL

CREATE VIEW referential_constraints AS
SELECT (current_database())::sql_identifier AS constraint_catalog, (ncon.nspname)::sql_identifier AS constraint_schema, (con.conname)::sql_identifier AS constraint_name, (CASE WHEN (npkc.nspname IS NULL) THEN NULL::name ELSE current_database() END)::sql_identifier AS unique_constraint_catalog, (npkc.nspname)::sql_identifier AS unique_constraint_schema, (pkc.conname)::sql_identifier AS unique_constraint_name, (CASE con.confmatchtype WHEN 'f'::"char" THEN 'FULL'::text WHEN 'p'::"char" THEN 'PARTIAL'::text WHEN 'u'::"char" THEN 'NONE'::text ELSE NULL::text END)::character_data AS match_option, (CASE con.confupdtype WHEN 'c'::"char" THEN 'CASCADE'::text WHEN 'n'::"char" THEN 'SET NULL'::text WHEN 'd'::"char" THEN 'SET DEFAULT'::text WHEN 'r'::"char" THEN 'RESTRICT'::text WHEN 'a'::"char" THEN 'NO ACTION'::text ELSE NULL::text END)::character_data AS update_rule, (CASE con.confdeltype WHEN 'c'::"char" THEN 'CASCADE'::text WHEN 'n'::"char" THEN 'SET NULL'::text WHEN 'd'::"char" THEN 'SET DEFAULT'::text WHEN 'r'::"char" THEN 'RESTRICT'::text WHEN 'a'::"char" THEN 'NO ACTION'::text ELSE NULL::text END)::character_data AS delete_rule FROM (((pg_namespace ncon JOIN pg_constraint con ON ((ncon.oid = con.connamespace))) JOIN pg_class c ON ((con.conrelid = c.oid))) LEFT JOIN (pg_constraint pkc JOIN pg_namespace npkc ON ((pkc.connamespace = npkc.oid))) ON (((con.confrelid = pkc.conrelid) AND _pg_keysequal(con.confkey, pkc.conkey)))) WHERE ((((c.relkind = 'r'::"char") AND (con.contype = 'f'::"char")) AND ((pkc.contype = ANY (ARRAY['p'::"char", 'u'::"char"])) OR (pkc.contype IS NULL))) AND pg_has_role(c.relowner, 'USAGE'::text));

ALTER TABLE information_schema.referential_constraints OWNER TO postgres;

See Also

List of views


View: role_column_grants

Properties

Name: | role_column_grants
Owner: | postgres
Has rules: |
Has Triggers: |
Comment: |

Columns

Name | Type | Length
grantor | sql_identifier | -1
grantee | sql_identifier | -1
table_catalog | sql_identifier | -1
table_schema | sql_identifier | -1
table_name | sql_identifier | -1
column_name | sql_identifier | -1
privilege_type | character_data | -1
is_grantable | character_data | -1
Total: 8 column(s)

SQL

CREATE VIEW role_column_grants AS
SELECT (u_grantor.rolname)::sql_identifier AS grantor, (g_grantee.rolname)::sql_identifier AS grantee, (current_database())::sql_identifier AS table_catalog, (nc.nspname)::sql_identifier AS table_schema, (c.relname)::sql_identifier AS table_name, (a.attname)::sql_identifier AS column_name, (pr."type")::character_data AS privilege_type, (CASE WHEN aclcontains(c.relacl, makeaclitem(g_grantee.oid, u_grantor.oid, pr."type", true)) THEN 'YES'::text ELSE 'NO'::text END)::character_data AS is_grantable FROM pg_attribute a, pg_class c, pg_namespace nc, pg_authid u_grantor, pg_authid g_grantee, (((SELECT 'SELECT' UNION ALL SELECT 'INSERT') UNION ALL SELECT 'UPDATE') UNION ALL SELECT 'REFERENCES') pr("type") WHERE (((((((a.attrelid = c.oid) AND (c.relnamespace = nc.oid)) AND (a.attnum > 0)) AND (NOT a.attisdropped)) AND (c.relkind = ANY (ARRAY['r'::"char", 'v'::"char"]))) AND aclcontains(c.relacl, makeaclitem(g_grantee.oid, u_grantor.oid, pr."type", false))) AND ((u_grantor.rolname IN (SELECT enabled_roles.role_name FROM enabled_roles)) OR (g_grantee.rolname IN (SELECT enabled_roles.role_name FROM enabled_roles))));

ALTER TABLE information_schema.role_column_grants OWNER TO postgres;

See Also

List of views


View: role_routine_grants

Properties

Name: | role_routine_grants
Owner: | postgres
Has rules: |
Has Triggers: |
Comment: |

Columns

Name | Type | Length
grantor | sql_identifier | -1
grantee | sql_identifier | -1
specific_catalog | sql_identifier | -1
specific_schema | sql_identifier | -1
specific_name | sql_identifier | -1
routine_catalog | sql_identifier | -1
routine_schema | sql_identifier | -1
routine_name | sql_identifier | -1
privilege_type | character_data | -1
is_grantable | character_data | -1
Total: 10 column(s)

SQL

CREATE VIEW role_routine_grants AS
SELECT (u_grantor.rolname)::sql_identifier AS grantor, (g_grantee.rolname)::sql_identifier AS grantee, (current_database())::sql_identifier AS specific_catalog, (n.nspname)::sql_identifier AS specific_schema, ((((p.proname)::text || '_'::text) || (p.oid)::text))::sql_identifier AS specific_name, (current_database())::sql_identifier AS routine_catalog, (n.nspname)::sql_identifier AS routine_schema, (p.proname)::sql_identifier AS routine_name, ('EXECUTE'::character varying)::character_data AS privilege_type, (CASE WHEN aclcontains(p.proacl, makeaclitem(g_grantee.oid, u_grantor.oid, 'EXECUTE'::text, true)) THEN 'YES'::text ELSE 'NO'::text END)::character_data AS is_grantable FROM pg_proc p, pg_namespace n, pg_authid u_grantor, pg_authid g_grantee WHERE (((p.pronamespace = n.oid) AND aclcontains(p.proacl, makeaclitem(g_grantee.oid, u_grantor.oid, 'EXECUTE'::text, false))) AND ((u_grantor.rolname IN (SELECT enabled_roles.role_name FROM enabled_roles)) OR (g_grantee.rolname IN (SELECT enabled_roles.role_name FROM enabled_roles))));

ALTER TABLE information_schema.role_routine_grants OWNER TO postgres;

See Also

List of views


View: role_table_grants

Properties

Name: | role_table_grants
Owner: | postgres
Has rules: |
Has Triggers: |
Comment: |

Columns

Name | Type | Length
grantor | sql_identifier | -1
grantee | sql_identifier | -1
table_catalog | sql_identifier | -1
table_schema | sql_identifier | -1
table_name | sql_identifier | -1
privilege_type | character_data | -1
is_grantable | character_data | -1
with_hierarchy | character_data | -1
Total: 8 column(s)

SQL

CREATE VIEW role_table_grants AS
SELECT (u_grantor.rolname)::sql_identifier AS grantor, (g_grantee.rolname)::sql_identifier AS grantee, (current_database())::sql_identifier AS table_catalog, (nc.nspname)::sql_identifier AS table_schema, (c.relname)::sql_identifier AS table_name, (pr."type")::character_data AS privilege_type, (CASE WHEN aclcontains(c.relacl, makeaclitem(g_grantee.oid, u_grantor.oid, pr."type", true)) THEN 'YES'::text ELSE 'NO'::text END)::character_data AS is_grantable, ('NO'::character varying)::character_data AS with_hierarchy FROM pg_class c, pg_namespace nc, pg_authid u_grantor, pg_authid g_grantee, (((((SELECT 'SELECT' UNION ALL SELECT 'DELETE') UNION ALL SELECT 'INSERT') UNION ALL SELECT 'UPDATE') UNION ALL SELECT 'REFERENCES') UNION ALL SELECT 'TRIGGER') pr("type") WHERE ((((c.relnamespace = nc.oid) AND (c.relkind = ANY (ARRAY['r'::"char", 'v'::"char"]))) AND aclcontains(c.relacl, makeaclitem(g_grantee.oid, u_grantor.oid, pr."type", false))) AND ((u_grantor.rolname IN (SELECT enabled_roles.role_name FROM enabled_roles)) OR (g_grantee.rolname IN (SELECT enabled_roles.role_name FROM enabled_roles))));

ALTER TABLE information_schema.role_table_grants OWNER TO postgres;

See Also

List of views


View: role_usage_grants

Properties

Name: | role_usage_grants
Owner: | postgres
Has rules: |
Has Triggers: |
Comment: |

Columns

Name | Type | Length
grantor | sql_identifier | -1
grantee | sql_identifier | -1
object_catalog | sql_identifier | -1
object_schema | sql_identifier | -1
object_name | sql_identifier | -1
object_type | character_data | -1
privilege_type | character_data | -1
is_grantable | character_data | -1
Total: 8 column(s)

SQL

CREATE VIEW role_usage_grants AS
SELECT (NULL::character varying)::sql_identifier AS grantor, (NULL::character varying)::sql_identifier AS grantee, (current_database())::sql_identifier AS object_catalog, (NULL::character varying)::sql_identifier AS object_schema, (NULL::character varying)::sql_identifier AS object_name, (NULL::character varying)::character_data AS object_type, ('USAGE'::character varying)::character_data AS privilege_type, (NULL::character varying)::character_data AS is_grantable WHERE false;

ALTER TABLE information_schema.role_usage_grants OWNER TO postgres;

See Also

List of views


View: routine_privileges

Properties

Name: | routine_privileges
Owner: | postgres
Has rules: |
Has Triggers: |
Comment: |

Columns

Name | Type | Length
grantor | sql_identifier | -1
grantee | sql_identifier | -1
specific_catalog | sql_identifier | -1
specific_schema | sql_identifier | -1
specific_name | sql_identifier | -1
routine_catalog | sql_identifier | -1
routine_schema | sql_identifier | -1
routine_name | sql_identifier | -1
privilege_type | character_data | -1
is_grantable | character_data | -1
Total: 10 column(s)

SQL

CREATE VIEW routine_privileges AS
SELECT (u_grantor.rolname)::sql_identifier AS grantor, (grantee.rolname)::sql_identifier AS grantee, (current_database())::sql_identifier AS specific_catalog, (n.nspname)::sql_identifier AS specific_schema, ((((p.proname)::text || '_'::text) || (p.oid)::text))::sql_identifier AS specific_name, (current_database())::sql_identifier AS routine_catalog, (n.nspname)::sql_identifier AS routine_schema, (p.proname)::sql_identifier AS routine_name, ('EXECUTE'::character varying)::character_data AS privilege_type, (CASE WHEN aclcontains(p.proacl, makeaclitem(grantee.oid, u_grantor.oid, 'EXECUTE'::text, true)) THEN 'YES'::text ELSE 'NO'::text END)::character_data AS is_grantable FROM pg_proc p, pg_namespace n, pg_authid u_grantor, (SELECT pg_authid.oid, pg_authid.rolname FROM pg_authid UNION ALL SELECT (0)::oid AS oid, 'PUBLIC') grantee(oid, rolname) WHERE (((p.pronamespace = n.oid) AND aclcontains(p.proacl, makeaclitem(grantee.oid, u_grantor.oid, 'EXECUTE'::text, false))) AND ((pg_has_role(u_grantor.oid, 'USAGE'::text) OR pg_has_role(grantee.oid, 'USAGE'::text)) OR (grantee.rolname = 'PUBLIC'::name)));

ALTER TABLE information_schema.routine_privileges OWNER TO postgres;

See Also

List of views


View: routines

Properties

Name: | routines
Owner: | postgres
Has rules: |
Has Triggers: |
Comment: |

Columns

Name | Type | Length
specific_catalog | sql_identifier | -1
specific_schema | sql_identifier | -1
specific_name | sql_identifier | -1
routine_catalog | sql_identifier | -1
routine_schema | sql_identifier | -1
routine_name | sql_identifier | -1
routine_type | character_data | -1
module_catalog | sql_identifier | -1
module_schema | sql_identifier | -1
module_name | sql_identifier | -1
udt_catalog | sql_identifier | -1
udt_schema | sql_identifier | -1
udt_name | sql_identifier | -1
data_type | character_data | -1
character_maximum_length | cardinal_number | -1
character_octet_length | cardinal_number | -1
character_set_catalog | sql_identifier | -1
character_set_schema | sql_identifier | -1
character_set_name | sql_identifier | -1
collation_catalog | sql_identifier | -1
collation_schema | sql_identifier | -1
collation_name | sql_identifier | -1
numeric_precision | cardinal_number | -1
numeric_precision_radix | cardinal_number | -1
numeric_scale | cardinal_number | -1
datetime_precision | cardinal_number | -1
interval_type | character_data | -1
interval_precision | character_data | -1
type_udt_catalog | sql_identifier | -1
type_udt_schema | sql_identifier | -1
type_udt_name | sql_identifier | -1
scope_catalog | sql_identifier | -1
scope_schema | sql_identifier | -1
scope_name | sql_identifier | -1
maximum_cardinality | cardinal_number | -1
dtd_identifier | sql_identifier | -1
routine_body | character_data | -1
routine_definition | character_data | -1
external_name | character_data | -1
external_language | character_data | -1
parameter_style | character_data | -1
is_deterministic | character_data | -1
sql_data_access | character_data | -1
is_null_call | character_data | -1
sql_path | character_data | -1
schema_level_routine | character_data | -1
max_dynamic_result_sets | cardinal_number | -1
is_user_defined_cast | character_data | -1
is_implicitly_invocable | character_data | -1
security_type | character_data | -1
to_sql_specific_catalog | sql_identifier | -1
to_sql_specific_schema | sql_identifier | -1
to_sql_specific_name | sql_identifier | -1
as_locator | character_data | -1
created | time_stamp | -1
last_altered | time_stamp | -1
new_savepoint_level | character_data | -1
is_udt_dependent | character_data | -1
result_cast_from_data_type | character_data | -1
result_cast_as_locator | character_data | -1
result_cast_char_max_length | cardinal_number | -1
result_cast_char_octet_length | cardinal_number | -1
result_cast_char_set_catalog | sql_identifier | -1
result_cast_char_set_schema | sql_identifier | -1
result_cast_character_set_name | sql_identifier | -1
result_cast_collation_catalog | sql_identifier | -1
result_cast_collation_schema | sql_identifier | -1
result_cast_collation_name | sql_identifier | -1
result_cast_numeric_precision | cardinal_number | -1
result_cast_numeric_precision_radix | cardinal_number | -1
result_cast_numeric_scale | cardinal_number | -1
result_cast_datetime_precision | cardinal_number | -1
result_cast_interval_type | character_data | -1
result_cast_interval_precision | character_data | -1
result_cast_type_udt_catalog | sql_identifier | -1
result_cast_type_udt_schema | sql_identifier | -1
result_cast_type_udt_name | sql_identifier | -1
result_cast_scope_catalog | sql_identifier | -1
result_cast_scope_schema | sql_identifier | -1
result_cast_scope_name | sql_identifier | -1
result_cast_maximum_cardinality | cardinal_number | -1
result_cast_dtd_identifier | sql_identifier | -1
Total: 82 column(s)

SQL

CREATE VIEW routines AS
SELECT (current_database())::sql_identifier AS specific_catalog, (n.nspname)::sql_identifier AS specific_schema, ((((p.proname)::text || '_'::text) || (p.oid)::text))::sql_identifier AS specific_name, (current_database())::sql_identifier AS routine_catalog, (n.nspname)::sql_identifier AS routine_schema, (p.proname)::sql_identifier AS routine_name, ('FUNCTION'::character varying)::character_data AS routine_type, (NULL::character varying)::sql_identifier AS module_catalog, (NULL::character varying)::sql_identifier AS module_schema, (NULL::character varying)::sql_identifier AS module_name, (NULL::character varying)::sql_identifier AS udt_catalog, (NULL::character varying)::sql_identifier AS udt_schema, (NULL::character varying)::sql_identifier AS udt_name, (CASE WHEN ((t.typelem <> (0)::oid) AND (t.typlen = -1)) THEN 'ARRAY'::text WHEN (nt.nspname = 'pg_catalog'::name) THEN format_type(t.oid, NULL::integer) ELSE 'USER-DEFINED'::text END)::character_data AS data_type, (NULL::integer)::cardinal_number AS character_maximum_length, (NULL::integer)::cardinal_number AS character_octet_length, (NULL::character varying)::sql_identifier AS character_set_catalog, (NULL::character varying)::sql_identifier AS character_set_schema, (NULL::character varying)::sql_identifier AS character_set_name, (NULL::character varying)::sql_identifier AS collation_catalog, (NULL::character varying)::sql_identifier AS collation_schema, (NULL::character varying)::sql_identifier AS collation_name, (NULL::integer)::cardinal_number AS numeric_precision, (NULL::integer)::cardinal_number AS numeric_precision_radix, (NULL::integer)::cardinal_number AS numeric_scale, (NULL::integer)::cardinal_number AS datetime_precision, (NULL::character varying)::character_data AS interval_type, (NULL::character varying)::character_data AS interval_precision, (current_database())::sql_identifier AS type_udt_catalog, (nt.nspname)::sql_identifier AS type_udt_schema, (t.typname)::sql_identifier AS type_udt_name, (NULL::character varying)::sql_identifier AS scope_catalog, (NULL::character varying)::sql_identifier AS scope_schema, (NULL::character varying)::sql_identifier AS scope_name, (NULL::integer)::cardinal_number AS maximum_cardinality, (0)::sql_identifier AS dtd_identifier, (CASE WHEN (l.lanname = 'sql'::name) THEN 'SQL'::text ELSE 'EXTERNAL'::text END)::character_data AS routine_body, (CASE WHEN pg_has_role(p.proowner, 'USAGE'::text) THEN p.prosrc ELSE NULL::text END)::character_data AS routine_definition, (CASE WHEN (l.lanname = 'c'::name) THEN p.prosrc ELSE NULL::text END)::character_data AS external_name, (upper((l.lanname)::text))::character_data AS external_language, ('GENERAL'::character varying)::character_data AS parameter_style, (CASE WHEN (p.provolatile = 'i'::"char") THEN 'YES'::text ELSE 'NO'::text END)::character_data AS is_deterministic, ('MODIFIES'::character varying)::character_data AS sql_data_access, (CASE WHEN p.proisstrict THEN 'YES'::text ELSE 'NO'::text END)::character_data AS is_null_call, (NULL::character varying)::character_data AS sql_path, ('YES'::character varying)::character_data AS schema_level_routine, (0)::cardinal_number AS max_dynamic_result_sets, (NULL::character varying)::character_data AS is_user_defined_cast, (NULL::character varying)::character_data AS is_implicitly_invocable, (CASE WHEN p.prosecdef THEN 'DEFINER'::text ELSE 'INVOKER'::text END)::character_data AS security_type, (NULL::character varying)::sql_identifier AS to_sql_specific_catalog, (NULL::character varying)::sql_identifier AS to_sql_specific_schema, (NULL::character varying)::sql_identifier AS to_sql_specific_name, ('NO'::character varying)::character_data AS as_locator, (NULL::timestamp with time zone)::time_stamp AS created, (NULL::timestamp with time zone)::time_stamp AS last_altered, (NULL::character varying)::character_data AS new_savepoint_level, ('YES'::character varying)::character_data AS is_udt_dependent, (NULL::character varying)::character_data AS result_cast_from_data_type, (NULL::character varying)::character_data AS result_cast_as_locator, (NULL::integer)::cardinal_number AS result_cast_char_max_length, (NULL::integer)::cardinal_number AS result_cast_char_octet_length, (NULL::character varying)::sql_identifier AS result_cast_char_set_catalog, (NULL::character varying)::sql_identifier AS result_cast_char_set_schema, (NULL::character varying)::sql_identifier AS result_cast_character_set_name, (NULL::character varying)::sql_identifier AS result_cast_collation_catalog, (NULL::character varying)::sql_identifier AS result_cast_collation_schema, (NULL::character varying)::sql_identifier AS result_cast_collation_name, (NULL::integer)::cardinal_number AS result_cast_numeric_precision, (NULL::integer)::cardinal_number AS result_cast_numeric_precision_radix, (NULL::integer)::cardinal_number AS result_cast_numeric_scale, (NULL::integer)::cardinal_number AS result_cast_datetime_precision, (NULL::character varying)::character_data AS result_cast_interval_type, (NULL::character varying)::character_data AS result_cast_interval_precision, (NULL::character varying)::sql_identifier AS result_cast_type_udt_catalog, (NULL::character varying)::sql_identifier AS result_cast_type_udt_schema, (NULL::character varying)::sql_identifier AS result_cast_type_udt_name, (NULL::character varying)::sql_identifier AS result_cast_scope_catalog, (NULL::character varying)::sql_identifier AS result_cast_scope_schema, (NULL::character varying)::sql_identifier AS result_cast_scope_name, (NULL::integer)::cardinal_number AS result_cast_maximum_cardinality, (NULL::character varying)::sql_identifier AS result_cast_dtd_identifier FROM pg_namespace n, pg_proc p, pg_language l, pg_type t, pg_namespace nt WHERE (((((n.oid = p.pronamespace) AND (p.prolang = l.oid)) AND (p.prorettype = t.oid)) AND (t.typnamespace = nt.oid)) AND (pg_has_role(p.proowner, 'USAGE'::text) OR has_function_privilege(p.oid, 'EXECUTE'::text)));

ALTER TABLE information_schema.routines OWNER TO postgres;

See Also

List of views


View: schemata

Properties

Name: | schemata
Owner: | postgres
Has rules: |
Has Triggers: |
Comment: |

Columns

Name | Type | Length
catalog_name | sql_identifier | -1
schema_name | sql_identifier | -1
schema_owner | sql_identifier | -1
default_character_set_catalog | sql_identifier | -1
default_character_set_schema | sql_identifier | -1
default_character_set_name | sql_identifier | -1
sql_path | character_data | -1
Total: 7 column(s)

SQL

CREATE VIEW schemata AS
SELECT (current_database())::sql_identifier AS catalog_name, (n.nspname)::sql_identifier AS schema_name, (u.rolname)::sql_identifier AS schema_owner, (NULL::character varying)::sql_identifier AS default_character_set_catalog, (NULL::character varying)::sql_identifier AS default_character_set_schema, (NULL::character varying)::sql_identifier AS default_character_set_name, (NULL::character varying)::character_data AS sql_path FROM pg_namespace n, pg_authid u WHERE ((n.nspowner = u.oid) AND pg_has_role(n.nspowner, 'USAGE'::text));

ALTER TABLE information_schema.schemata OWNER TO postgres;

See Also

List of views


View: sequences

Properties

Name: | sequences
Owner: | postgres
Has rules: |
Has Triggers: |
Comment: |

Columns

Name | Type | Length
sequence_catalog | sql_identifier | -1
sequence_schema | sql_identifier | -1
sequence_name | sql_identifier | -1
data_type | character_data | -1
numeric_precision | cardinal_number | -1
numeric_precision_radix | cardinal_number | -1
numeric_scale | cardinal_number | -1
maximum_value | cardinal_number | -1
minimum_value | cardinal_number | -1
increment | cardinal_number | -1
cycle_option | character_data | -1
Total: 11 column(s)

SQL

CREATE VIEW sequences AS
SELECT (current_database())::sql_identifier AS sequence_catalog, (nc.nspname)::sql_identifier AS sequence_schema, (c.relname)::sql_identifier AS sequence_name, ('bigint'::character varying)::character_data AS data_type, (64)::cardinal_number AS numeric_precision, (2)::cardinal_number AS numeric_precision_radix, (0)::cardinal_number AS numeric_scale, (NULL::integer)::cardinal_number AS maximum_value, (NULL::integer)::cardinal_number AS minimum_value, (NULL::integer)::cardinal_number AS "increment", (NULL::character varying)::character_data AS cycle_option FROM pg_namespace nc, pg_class c WHERE ((((c.relnamespace = nc.oid) AND (c.relkind = 'S'::"char")) AND (NOT pg_is_other_temp_schema(nc.oid))) AND ((pg_has_role(c.relowner, 'USAGE'::text) OR has_table_privilege(c.oid, 'SELECT'::text)) OR has_table_privilege(c.oid, 'UPDATE'::text)));

ALTER TABLE information_schema.sequences OWNER TO postgres;

SET default_tablespace = '';

SET default_with_oids = false;

See Also

List of views


View: table_constraints

Properties

Name: | table_constraints
Owner: | postgres
Has rules: |
Has Triggers: |
Comment: |

Columns

Name | Type | Length
constraint_catalog | varchar | -1
constraint_schema | varchar | -1
constraint_name | varchar | -1
table_catalog | varchar | -1
table_schema | varchar | -1
table_name | varchar | -1
constraint_type | varchar | -1
is_deferrable | varchar | -1
initially_deferred | varchar | -1
Total: 9 column(s)

SQL

CREATE VIEW table_constraints AS
SELECT (current_database())::sql_identifier AS constraint_catalog, (nc.nspname)::sql_identifier AS constraint_schema, (c.conname)::sql_identifier AS constraint_name, (current_database())::sql_identifier AS table_catalog, (nr.nspname)::sql_identifier AS table_schema, (r.relname)::sql_identifier AS table_name, (CASE c.contype WHEN 'c'::"char" THEN 'CHECK'::text WHEN 'f'::"char" THEN 'FOREIGN KEY'::text WHEN 'p'::"char" THEN 'PRIMARY KEY'::text WHEN 'u'::"char" THEN 'UNIQUE'::text ELSE NULL::text END)::character_data AS constraint_type, (CASE WHEN c.condeferrable THEN 'YES'::text ELSE 'NO'::text END)::character_data AS is_deferrable, (CASE WHEN c.condeferred THEN 'YES'::text ELSE 'NO'::text END)::character_data AS initially_deferred FROM pg_namespace nc, pg_namespace nr, pg_constraint c, pg_class r WHERE ((((((nc.oid = c.connamespace) AND (nr.oid = r.relnamespace)) AND (c.conrelid = r.oid)) AND (r.relkind = 'r'::"char")) AND (NOT pg_is_other_temp_schema(nr.oid))) AND (((((pg_has_role(r.relowner, 'USAGE'::text) OR has_table_privilege(r.oid, 'INSERT'::text)) OR has_table_privilege(r.oid, 'UPDATE'::text)) OR has_table_privilege(r.oid, 'DELETE'::text)) OR has_table_privilege(r.oid, 'REFERENCES'::text)) OR has_table_privilege(r.oid, 'TRIGGER'::text))) UNION SELECT (current_database())::sql_identifier AS constraint_catalog, (nr.nspname)::sql_identifier AS constraint_schema, (((((((nr.oid)::text || '_'::text) || (r.oid)::text) || '_'::text) || (a.attnum)::text) || '_not_null'::text))::sql_identifier AS constraint_name, (current_database())::sql_identifier AS table_catalog, (nr.nspname)::sql_identifier AS table_schema, (r.relname)::sql_identifier AS table_name, ('CHECK'::character varying)::character_data AS constraint_type, ('NO'::character varying)::character_data AS is_deferrable, ('NO'::character varying)::character_data AS initially_deferred FROM pg_namespace nr, pg_class r, pg_attribute a WHERE ((((((((nr.oid = r.relnamespace) AND (r.oid = a.attrelid)) AND a.attnotnull) AND (a.attnum > 0)) AND (NOT a.attisdropped)) AND (r.relkind = 'r'::"char")) AND (NOT pg_is_other_temp_schema(nr.oid))) AND ((((((pg_has_role(r.relowner, 'USAGE'::text) OR has_table_privilege(r.oid, 'SELECT'::text)) OR has_table_privilege(r.oid, 'INSERT'::text)) OR has_table_privilege(r.oid, 'UPDATE'::text)) OR has_table_privilege(r.oid, 'DELETE'::text)) OR has_table_privilege(r.oid, 'REFERENCES'::text)) OR has_table_privilege(r.oid, 'TRIGGER'::text)));

ALTER TABLE information_schema.table_constraints OWNER TO postgres;

See Also

List of views


View: table_privileges

Properties

Name: | table_privileges
Owner: | postgres
Has rules: |
Has Triggers: |
Comment: |

Columns

Name | Type | Length
grantor | sql_identifier | -1
grantee | sql_identifier | -1
table_catalog | sql_identifier | -1
table_schema | sql_identifier | -1
table_name | sql_identifier | -1
privilege_type | character_data | -1
is_grantable | character_data | -1
with_hierarchy | character_data | -1
Total: 8 column(s)

SQL

CREATE VIEW table_privileges AS
SELECT (u_grantor.rolname)::sql_identifier AS grantor, (grantee.rolname)::sql_identifier AS grantee, (current_database())::sql_identifier AS table_catalog, (nc.nspname)::sql_identifier AS table_schema, (c.relname)::sql_identifier AS table_name, (pr."type")::character_data AS privilege_type, (CASE WHEN aclcontains(c.relacl, makeaclitem(grantee.oid, u_grantor.oid, pr."type", true)) THEN 'YES'::text ELSE 'NO'::text END)::character_data AS is_grantable, ('NO'::character varying)::character_data AS with_hierarchy FROM pg_class c, pg_namespace nc, pg_authid u_grantor, (SELECT pg_authid.oid, pg_authid.rolname FROM pg_authid UNION ALL SELECT (0)::oid AS oid, 'PUBLIC') grantee(oid, rolname), (((((SELECT 'SELECT' UNION ALL SELECT 'DELETE') UNION ALL SELECT 'INSERT') UNION ALL SELECT 'UPDATE') UNION ALL SELECT 'REFERENCES') UNION ALL SELECT 'TRIGGER') pr("type") WHERE ((((c.relnamespace = nc.oid) AND (c.relkind = ANY (ARRAY['r'::"char", 'v'::"char"]))) AND aclcontains(c.relacl, makeaclitem(grantee.oid, u_grantor.oid, pr."type", false))) AND ((pg_has_role(u_grantor.oid, 'USAGE'::text) OR pg_has_role(grantee.oid, 'USAGE'::text)) OR (grantee.rolname = 'PUBLIC'::name)));

ALTER TABLE information_schema.table_privileges OWNER TO postgres;

See Also

List of views


View: tables

Properties

Name: | tables
Owner: | postgres
Has rules: |
Has Triggers: |
Comment: |

Columns

Name | Type | Length
table_catalog | sql_identifier | -1
table_schema | sql_identifier | -1
table_name | sql_identifier | -1
table_type | character_data | -1
self_referencing_column_name | sql_identifier | -1
reference_generation | character_data | -1
user_defined_type_catalog | sql_identifier | -1
user_defined_type_schema | sql_identifier | -1
user_defined_type_name | sql_identifier | -1
is_insertable_into | character_data | -1
is_typed | character_data | -1
commit_action | character_data | -1
Total: 12 column(s)

SQL

CREATE VIEW tables AS
SELECT (current_database())::sql_identifier AS table_catalog, (nc.nspname)::sql_identifier AS table_schema, (c.relname)::sql_identifier AS table_name, (CASE WHEN (nc.oid = pg_my_temp_schema()) THEN 'LOCAL TEMPORARY'::text WHEN (c.relkind = 'r'::"char") THEN 'BASE TABLE'::text WHEN (c.relkind = 'v'::"char") THEN 'VIEW'::text ELSE NULL::text END)::character_data AS table_type, (NULL::character varying)::sql_identifier AS self_referencing_column_name, (NULL::character varying)::character_data AS reference_generation, (NULL::character varying)::sql_identifier AS user_defined_type_catalog, (NULL::character varying)::sql_identifier AS user_defined_type_schema, (NULL::character varying)::sql_identifier AS user_defined_type_name, (CASE WHEN (c.relkind = 'r'::"char") THEN 'YES'::text ELSE 'NO'::text END)::character_data AS is_insertable_into, ('NO'::character varying)::character_data AS is_typed, (CASE WHEN (nc.oid = pg_my_temp_schema()) THEN 'PRESERVE'::text ELSE NULL::text END)::character_data AS commit_action FROM pg_namespace nc, pg_class c WHERE ((((c.relnamespace = nc.oid) AND (c.relkind = ANY (ARRAY['r'::"char", 'v'::"char"]))) AND (NOT pg_is_other_temp_schema(nc.oid))) AND ((((((pg_has_role(c.relowner, 'USAGE'::text) OR has_table_privilege(c.oid, 'SELECT'::text)) OR has_table_privilege(c.oid, 'INSERT'::text)) OR has_table_privilege(c.oid, 'UPDATE'::text)) OR has_table_privilege(c.oid, 'DELETE'::text)) OR has_table_privilege(c.oid, 'REFERENCES'::text)) OR has_table_privilege(c.oid, 'TRIGGER'::text)));

ALTER TABLE information_schema.tables OWNER TO postgres;

See Also

List of views


View: triggered_update_columns

Properties

Name: | triggered_update_columns
Owner: | postgres
Has rules: |
Has Triggers: |
Comment: |

Columns

Name | Type | Length
trigger_catalog | sql_identifier | -1
trigger_schema | sql_identifier | -1
trigger_name | sql_identifier | -1
event_object_catalog | sql_identifier | -1
event_object_schema | sql_identifier | -1
event_object_table | sql_identifier | -1
event_object_column | sql_identifier | -1
Total: 7 column(s)

SQL

CREATE VIEW triggered_update_columns AS
SELECT (current_database())::sql_identifier AS trigger_catalog, (NULL::character varying)::sql_identifier AS trigger_schema, (NULL::character varying)::sql_identifier AS trigger_name, (current_database())::sql_identifier AS event_object_catalog, (NULL::character varying)::sql_identifier AS event_object_schema, (NULL::character varying)::sql_identifier AS event_object_table, (NULL::character varying)::sql_identifier AS event_object_column WHERE false;

ALTER TABLE information_schema.triggered_update_columns OWNER TO postgres;

See Also

List of views


View: triggers

Properties

Name: | triggers
Owner: | postgres
Has rules: |
Has Triggers: |
Comment: |

Columns

Name | Type | Length
trigger_catalog | sql_identifier | -1
trigger_schema | sql_identifier | -1
trigger_name | sql_identifier | -1
event_manipulation | character_data | -1
event_object_catalog | sql_identifier | -1
event_object_schema | sql_identifier | -1
event_object_table | sql_identifier | -1
action_order | cardinal_number | -1
action_condition | character_data | -1
action_statement | character_data | -1
action_orientation | character_data | -1
condition_timing | character_data | -1
condition_reference_old_table | sql_identifier | -1
condition_reference_new_table | sql_identifier | -1
condition_reference_old_row | sql_identifier | -1
condition_reference_new_row | sql_identifier | -1
created | time_stamp | -1
Total: 17 column(s)

SQL

CREATE VIEW triggers AS
SELECT (current_database())::sql_identifier AS trigger_catalog, (n.nspname)::sql_identifier AS trigger_schema, (t.tgname)::sql_identifier AS trigger_name, (em.text)::character_data AS event_manipulation, (current_database())::sql_identifier AS event_object_catalog, (n.nspname)::sql_identifier AS event_object_schema, (c.relname)::sql_identifier AS event_object_table, (NULL::integer)::cardinal_number AS action_order, (NULL::character varying)::character_data AS action_condition, ("substring"(pg_get_triggerdef(t.oid), ("position"("substring"(pg_get_triggerdef(t.oid), 48), 'EXECUTE PROCEDURE'::text) + 47)))::character_data AS action_statement, (CASE WHEN (((t.tgtype)::integer & 1) = 1) THEN 'ROW'::text ELSE 'STATEMENT'::text END)::character_data AS action_orientation, (CASE WHEN (((t.tgtype)::integer & 2) = 2) THEN 'BEFORE'::text ELSE 'AFTER'::text END)::character_data AS condition_timing, (NULL::character varying)::sql_identifier AS condition_reference_old_table, (NULL::character varying)::sql_identifier AS condition_reference_new_table, (NULL::character varying)::sql_identifier AS condition_reference_old_row, (NULL::character varying)::sql_identifier AS condition_reference_new_row, (NULL::timestamp with time zone)::time_stamp AS created FROM pg_namespace n, pg_class c, pg_trigger t, ((SELECT 4, 'INSERT' UNION ALL SELECT 8, 'DELETE') UNION ALL SELECT 16, 'UPDATE') em(num, text) WHERE ((((((n.oid = c.relnamespace) AND (c.oid = t.tgrelid)) AND (((t.tgtype)::integer & em.num) <> 0)) AND (NOT t.tgisconstraint)) AND (NOT pg_is_other_temp_schema(n.oid))) AND (((((pg_has_role(c.relowner, 'USAGE'::text) OR has_table_privilege(c.oid, 'INSERT'::text)) OR has_table_privilege(c.oid, 'UPDATE'::text)) OR has_table_privilege(c.oid, 'DELETE'::text)) OR has_table_privilege(c.oid, 'REFERENCES'::text)) OR has_table_privilege(c.oid, 'TRIGGER'::text)));

ALTER TABLE information_schema.triggers OWNER TO postgres;

See Also

List of views


View: usage_privileges

Properties

Name: | usage_privileges
Owner: | postgres
Has rules: |
Has Triggers: |
Comment: |

Columns

Name | Type | Length
grantor | sql_identifier | -1
grantee | sql_identifier | -1
object_catalog | sql_identifier | -1
object_schema | sql_identifier | -1
object_name | sql_identifier | -1
object_type | character_data | -1
privilege_type | character_data | -1
is_grantable | character_data | -1
Total: 8 column(s)

SQL

CREATE VIEW usage_privileges AS
SELECT (u.rolname)::sql_identifier AS grantor, ('PUBLIC'::character varying)::sql_identifier AS grantee, (current_database())::sql_identifier AS object_catalog, (n.nspname)::sql_identifier AS object_schema, (t.typname)::sql_identifier AS object_name, ('DOMAIN'::character varying)::character_data AS object_type, ('USAGE'::character varying)::character_data AS privilege_type, ('NO'::character varying)::character_data AS is_grantable FROM pg_authid u, pg_namespace n, pg_type t WHERE (((u.oid = t.typowner) AND (t.typnamespace = n.oid)) AND (t.typtype = 'd'::"char"));

ALTER TABLE information_schema.usage_privileges OWNER TO postgres;

See Also

List of views


View: view_column_usage

Properties

Name: | view_column_usage
Owner: | postgres
Has rules: |
Has Triggers: |
Comment: |

Columns

Name | Type | Length
view_catalog | sql_identifier | -1
view_schema | sql_identifier | -1
view_name | sql_identifier | -1
table_catalog | sql_identifier | -1
table_schema | sql_identifier | -1
table_name | sql_identifier | -1
column_name | sql_identifier | -1
Total: 7 column(s)

SQL

CREATE VIEW view_column_usage AS
SELECT DISTINCT (current_database())::sql_identifier AS view_catalog, (nv.nspname)::sql_identifier AS view_schema, (v.relname)::sql_identifier AS view_name, (current_database())::sql_identifier AS table_catalog, (nt.nspname)::sql_identifier AS table_schema, (t.relname)::sql_identifier AS table_name, (a.attname)::sql_identifier AS column_name FROM pg_namespace nv, pg_class v, pg_depend dv, pg_depend dt, pg_class t, pg_namespace nt, pg_attribute a WHERE ((((((((((((((((nv.oid = v.relnamespace) AND (v.relkind = 'v'::"char")) AND (v.oid = dv.refobjid)) AND (dv.refclassid = ('pg_class'::regclass)::oid)) AND (dv.classid = ('pg_rewrite'::regclass)::oid)) AND (dv.deptype = 'i'::"char")) AND (dv.objid = dt.objid)) AND (dv.refobjid <> dt.refobjid)) AND (dt.classid = ('pg_rewrite'::regclass)::oid)) AND (dt.refclassid = ('pg_class'::regclass)::oid)) AND (dt.refobjid = t.oid)) AND (t.relnamespace = nt.oid)) AND (t.relkind = ANY (ARRAY['r'::"char", 'v'::"char"]))) AND (t.oid = a.attrelid)) AND (dt.refobjsubid = a.attnum)) AND pg_has_role(t.relowner, 'USAGE'::text)) ORDER BY (current_database())::sql_identifier, (nv.nspname)::sql_identifier, (v.relname)::sql_identifier, (current_database())::sql_identifier, (nt.nspname)::sql_identifier, (t.relname)::sql_identifier, (a.attname)::sql_identifier;

ALTER TABLE information_schema.view_column_usage OWNER TO postgres;

See Also

List of views


View: view_routine_usage

Properties

Name: | view_routine_usage
Owner: | postgres
Has rules: |
Has Triggers: |
Comment: |

Columns

Name | Type | Length
table_catalog | sql_identifier | -1
table_schema | sql_identifier | -1
table_name | sql_identifier | -1
specific_catalog | sql_identifier | -1
specific_schema | sql_identifier | -1
specific_name | sql_identifier | -1
Total: 6 column(s)

SQL

CREATE VIEW view_routine_usage AS
SELECT DISTINCT (current_database())::sql_identifier AS table_catalog, (nv.nspname)::sql_identifier AS table_schema, (v.relname)::sql_identifier AS table_name, (current_database())::sql_identifier AS specific_catalog, (np.nspname)::sql_identifier AS specific_schema, ((((p.proname)::text || '_'::text) || (p.oid)::text))::sql_identifier AS specific_name FROM pg_namespace nv, pg_class v, pg_depend dv, pg_depend dp, pg_proc p, pg_namespace np WHERE ((((((((((((nv.oid = v.relnamespace) AND (v.relkind = 'v'::"char")) AND (v.oid = dv.refobjid)) AND (dv.refclassid = ('pg_class'::regclass)::oid)) AND (dv.classid = ('pg_rewrite'::regclass)::oid)) AND (dv.deptype = 'i'::"char")) AND (dv.objid = dp.objid)) AND (dp.classid = ('pg_rewrite'::regclass)::oid)) AND (dp.refclassid = ('pg_proc'::regclass)::oid)) AND (dp.refobjid = p.oid)) AND (p.pronamespace = np.oid)) AND pg_has_role(p.proowner, 'USAGE'::text)) ORDER BY (current_database())::sql_identifier, (nv.nspname)::sql_identifier, (v.relname)::sql_identifier, (current_database())::sql_identifier, (np.nspname)::sql_identifier, ((((p.proname)::text || '_'::text) || (p.oid)::text))::sql_identifier;

ALTER TABLE information_schema.view_routine_usage OWNER TO postgres;

See Also

List of views


View: view_table_usage

Properties

Name: | view_table_usage
Owner: | postgres
Has rules: |
Has Triggers: |
Comment: |

Columns

Name | Type | Length
view_catalog | sql_identifier | -1
view_schema | sql_identifier | -1
view_name | sql_identifier | -1
table_catalog | sql_identifier | -1
table_schema | sql_identifier | -1
table_name | sql_identifier | -1
Total: 6 column(s)

SQL

CREATE VIEW view_table_usage AS
SELECT DISTINCT (current_database())::sql_identifier AS view_catalog, (nv.nspname)::sql_identifier AS view_schema, (v.relname)::sql_identifier AS view_name, (current_database())::sql_identifier AS table_catalog, (nt.nspname)::sql_identifier AS table_schema, (t.relname)::sql_identifier AS table_name FROM pg_namespace nv, pg_class v, pg_depend dv, pg_depend dt, pg_class t, pg_namespace nt WHERE ((((((((((((((nv.oid = v.relnamespace) AND (v.relkind = 'v'::"char")) AND (v.oid = dv.refobjid)) AND (dv.refclassid = ('pg_class'::regclass)::oid)) AND (dv.classid = ('pg_rewrite'::regclass)::oid)) AND (dv.deptype = 'i'::"char")) AND (dv.objid = dt.objid)) AND (dv.refobjid <> dt.refobjid)) AND (dt.classid = ('pg_rewrite'::regclass)::oid)) AND (dt.refclassid = ('pg_class'::regclass)::oid)) AND (dt.refobjid = t.oid)) AND (t.relnamespace = nt.oid)) AND (t.relkind = ANY (ARRAY['r'::"char", 'v'::"char"]))) AND pg_has_role(t.relowner, 'USAGE'::text)) ORDER BY (current_database())::sql_identifier, (nv.nspname)::sql_identifier, (v.relname)::sql_identifier, (current_database())::sql_identifier, (nt.nspname)::sql_identifier, (t.relname)::sql_identifier;

ALTER TABLE information_schema.view_table_usage OWNER TO postgres;

See Also

List of views


View: views

Properties

Name: | views
Owner: | postgres
Has rules: |
Has Triggers: |
Comment: |

Columns

Name | Type | Length
table_catalog | sql_identifier | -1
table_schema | sql_identifier | -1
table_name | sql_identifier | -1
view_definition | character_data | -1
check_option | character_data | -1
is_updatable | character_data | -1
is_insertable_into | character_data | -1
Total: 7 column(s)

SQL

CREATE VIEW views AS
SELECT (current_database())::sql_identifier AS table_catalog, (nc.nspname)::sql_identifier AS table_schema, (c.relname)::sql_identifier AS table_name, (CASE WHEN pg_has_role(c.relowner, 'USAGE'::text) THEN pg_get_viewdef(c.oid) ELSE NULL::text END)::character_data AS view_definition, ('NONE'::character varying)::character_data AS check_option, (CASE WHEN ((EXISTS (SELECT 1 FROM pg_rewrite WHERE (((pg_rewrite.ev_class = c.oid) AND ((pg_rewrite.ev_type)::text = (2)::text)) AND pg_rewrite.is_instead))) AND (EXISTS (SELECT 1 FROM pg_rewrite WHERE (((pg_rewrite.ev_class = c.oid) AND ((pg_rewrite.ev_type)::text = (4)::text)) AND pg_rewrite.is_instead)))) THEN 'YES'::text ELSE 'NO'::text END)::character_data AS is_updatable, (CASE WHEN (EXISTS (SELECT 1 FROM pg_rewrite WHERE (((pg_rewrite.ev_class = c.oid) AND ((pg_rewrite.ev_type)::text = (3)::text)) AND pg_rewrite.is_instead))) THEN 'YES'::text ELSE 'NO'::text END)::character_data AS is_insertable_into FROM pg_namespace nc, pg_class c WHERE ((((c.relnamespace = nc.oid) AND (c.relkind = 'v'::"char")) AND (NOT pg_is_other_temp_schema(nc.oid))) AND ((((((pg_has_role(c.relowner, 'USAGE'::text) OR has_table_privilege(c.oid, 'SELECT'::text)) OR has_table_privilege(c.oid, 'INSERT'::text)) OR has_table_privilege(c.oid, 'UPDATE'::text)) OR has_table_privilege(c.oid, 'DELETE'::text)) OR has_table_privilege(c.oid, 'REFERENCES'::text)) OR has_table_privilege(c.oid, 'TRIGGER'::text)));

ALTER TABLE information_schema.views OWNER TO postgres;

See Also

List of views


Server: Server

Properties

MachineName: | Server
version: | PostgreSQL 8.2.5 on i686-pc-mingw32, compiled by GCC gcc.exe (GCC) 3.4.2 (mingw-special)

Databases

Name | Owner | Encoding | Default schema | Comment
postgres | postgres | SQL_ASCII |  | 1
Total: 1 database(s)

Tablespaces

Name | Owner | Location
pg_default | postgres |
pg_global | postgres |
Total: 2 tablespace(s)

Logins

Name | Superuser
postgres |
Total: 1 login(s)

Features

Name | Subfeature Name | Supported | Verified by
ABS and MOD functions |  |  |
ALTER TABLE statement: DROP COLUMN clause |  |  |
ALTER domain |  |  |
AS subquery clause in table definition |  |  |
Additional translation documentation |  |  |
Advanced OLAP operations |  |  |
Advanced multiset support |  |  |
Alter transform statement |  |  |
Array constructors by query |  |  |
Array element assignment |  |  |
Array locators |  |  |
Array-returning external SQL-invoked functions |  |  |
Arrays of reference types |  |  |
Arrays of user-defined types |  |  |
Assertions |  |  |
BIGINT data type |  |  |
BOOLEAN data type |  |  |
Basic LOB data type support |  |  |
Basic LOB data type support 01 | BLOB data type |  |
Basic LOB data type support 02 | CLOB data type |  |
Basic LOB data type support 03 | POSITION, LENGTH, LOWER, TRIM, UPPER, and SUBSTRING functions for LOB data types |  |
Basic LOB data type support 04 | Concatenation of LOB data types |  |
Basic LOB data type support 05 | LOB locator: non-holdable |  |
Basic Privileges |  |  |
Basic Privileges 01 | SELECT privilege |  |
Basic Privileges 02 | DELETE privilege |  |
Basic Privileges 03 | INSERT privilege at the table level |  |
Basic Privileges 04 | UPDATE privilege at the table level |  |
Basic Privileges 05 | UPDATE privilege at the column level |  |
Basic Privileges 06 | REFERENCES privilege at the table level |  |
Basic Privileges 07 | REFERENCES privilege at the column level |  |
Basic Privileges 08 | WITH GRANT OPTION |  |
Basic Privileges 09 | USAGE privilege |  |
Basic Privileges 10 | EXECUTE privilege |  |
Basic SET TRANSACTION statement |  |  |
Basic SET TRANSACTION statement 01 | SET TRANSACTION statement: ISOLATION LEVEL SERIALIZABLE clause |  |
Basic SET TRANSACTION statement 02 | SET TRANSACTION statement: READ ONLY and READ WRITE clauses |  |
Basic SQL-invoked routines |  |  |
Basic SQL-invoked routines 01 | User-defined functions with no overloading |  |
Basic SQL-invoked routines 02 | User-defined stored procedures with no overloading |  |
Basic SQL-invoked routines 03 | Function invocation |  |
Basic SQL-invoked routines 04 | CALL statement |  |
Basic SQL-invoked routines 05 | RETURN statement |  |
Basic SQL-invoked routines 06 | ROUTINES view |  |
Basic SQL-invoked routines 07 | PARAMETERS view |  |
Basic array support |  |  |
Basic array support 01 | Arrays of built-in data types |  |
Basic array support 02 | Arrays of distinct types |  |
Basic array support 03 | Array expressions |  |
Basic cursor support |  |  |
Basic cursor support 01 | DECLARE CURSOR |  |
Basic cursor support 02 | ORDER BY columns need not be in select list |  |
Basic cursor support 03 | Value expressions in ORDER BY clause |  |
Basic cursor support 04 | OPEN statement |  |
Basic cursor support 06 | Positioned UPDATE statement |  |
Basic cursor support 07 | Positioned DELETE statement |  |
Basic cursor support 08 | CLOSE statement |  |
Basic cursor support 10 | FETCH statement implicit NEXT |  |
Basic cursor support 17 | WITH HOLD cursors |  |
Basic data manipulation |  |  |
Basic data manipulation 01 | INSERT statement |  |
Basic data manipulation 03 | Searched UPDATE statement |  |
Basic data manipulation 04 | Searched DELETE statement |  |
Basic date and time |  |  |
Basic date and time 01 | DATE data type (including support of DATE literal) |  |
Basic date and time 02 | TIME data type (including support of TIME literal) with fractional seconds precision of at least 0 |  |
Basic date and time 03 | TIMESTAMP data type (including support of TIMESTAMP literal) with fractional seconds precision of at least 0 and 6 |  |
Basic date and time 04 | Comparison predicate on DATE, TIME, and TIMESTAMP data types |  |
Basic date and time 05 | Explicit CAST between datetime types and character string types |  |
Basic date and time 06 | CURRENT_DATE |  |
Basic date and time 07 | LOCALTIME |  |
Basic date and time 08 | LOCALTIMESTAMP |  |
Basic diagnostics management |  |  |
Basic diagnostics management 01 | GET DIAGNOSTICS statement |  |
Basic diagnostics management 02 | SET TRANSACTION statement: DIAGNOSTICS SIZE clause |  |
Basic dynamic SQL |  |  |
Basic flagging |  |  |
Basic information schema |  |  |
Basic information schema 01 | COLUMNS view |  |
Basic information schema 02 | TABLES view |  |
Basic information schema 03 | VIEWS view |  |
Basic information schema 04 | TABLE_CONSTRAINTS view |  |
Basic information schema 05 | REFERENTIAL_CONSTRAINTS view |  |
Basic information schema 06 | CHECK_CONSTRAINTS view |  |
Basic integrity constraints |  |  |
Basic integrity constraints 01 | NOT NULL constraints |  |
Basic integrity constraints 02 | UNIQUE constraints of NOT NULL columns |  |
Basic integrity constraints 03 | PRIMARY KEY constraints |  |
Basic integrity constraints 04 | Basic FOREIGN KEY constraint with the NO ACTION default for both referential delete action and referential update action |  |
Basic integrity constraints 06 | CHECK constraints |  |
Basic integrity constraints 07 | Column defaults |  |
Basic integrity constraints 08 | NOT NULL inferred on PRIMARY KEY |  |
Basic integrity constraints 10 | Names in a foreign key can be specified in any order |  |
Basic joined table |  |  |
Basic joined table 01 | Inner join (but not necessarily the INNER keyword) |  |
Basic joined table 02 | INNER keyword |  |
Basic joined table 03 | LEFT OUTER JOIN |  |
Basic joined table 04 | RIGHT OUTER JOIN |  |
Basic joined table 05 | Outer joins can be nested |  |
Basic joined table 07 | The inner table in a left or right outer join can also be used in an inner join |  |
Basic joined table 08 | All comparison operators are supported (rather than just =) |  |
Basic multiset support |  |  |
Basic predicates and search conditions |  |  |
Basic predicates and search conditions 01 | Comparison predicate |  |
Basic predicates and search conditions 02 | BETWEEN predicate |  |
Basic predicates and search conditions 03 | IN predicate with list of values |  |
Basic predicates and search conditions 04 | LIKE predicate |  |
Basic predicates and search conditions 05 | LIKE predicate ESCAPE clause |  |
Basic predicates and search conditions 06 | NULL predicate |  |
Basic predicates and search conditions 07 | Quantified comparison predicate |  |
Basic predicates and search conditions 08 | EXISTS predicate |  |
Basic predicates and search conditions 09 | Subqueries in comparison predicate |  |
Basic predicates and search conditions 11 | Subqueries in IN predicate |  |
Basic predicates and search conditions 12 | Subqueries in quantified comparison predicate |  |
Basic predicates and search conditions 13 | Correlated subqueries |  |
Basic predicates and search conditions 14 | Search condition |  |
Basic query expressions |  |  |
Basic query expressions 01 | UNION DISTINCT table operator |  |
Basic query expressions 02 | UNION ALL table operator |  |
Basic query expressions 03 | EXCEPT DISTINCT table operator |  |
Basic query expressions 05 | Columns combined via table operators need not have exactly the same data type |  |
Basic query expressions 06 | Table operators in subqueries |  |
Basic query specification |  |  |
Basic query specification 01 | SELECT DISTINCT |  |
Basic query specification 02 | GROUP BY clause |  |
Basic query specification 04 | GROUP BY can contain columns not in <select list> |  |
Basic query specification 05 | Select list items can be renamed |  |
Basic query specification 06 | HAVING clause |  |
Basic query specification 07 | Qualified * in select list |  |
Basic query specification 08 | Correlation names in the FROM clause |  |
Basic query specification 09 | Rename columns in the FROM clause |  |
Basic reference types |  |  |
Basic roles |  |  |
Basic schema manipulation |  |  |
Basic schema manipulation 01 | CREATE TABLE statement to create persistent base tables |  |
Basic schema manipulation 02 | CREATE VIEW statement |  |
Basic schema manipulation 03 | GRANT statement |  |
Basic schema manipulation 04 | ALTER TABLE statement: ADD COLUMN clause |  |
Basic schema manipulation 13 | DROP TABLE statement: RESTRICT clause |  |
Basic schema manipulation 16 | DROP VIEW statement: RESTRICT clause |  |
Basic schema manipulation 19 | REVOKE statement: RESTRICT clause |  |
Basic structured types |  |  |
Basic trigger capability |  |  |
Basic trigger capability 01 | Triggers activated on UPDATE, INSERT, or DELETE of one base table |  |
Basic trigger capability 02 | BEFORE triggers |  |
Basic trigger capability 03 | AFTER triggers |  |
Basic trigger capability 04 | FOR EACH ROW triggers |  |
Basic trigger capability 05 | Ability to specify a search condition that must be true before the trigger is invoked |  |
Basic trigger capability 06 | Support for run-time rules for the interaction of triggers and constraints |  |
Basic trigger capability 07 | TRIGGER privilege |  |
Basic trigger capability 08 | Multiple triggers for the same event are executed in the order in which they were created in the catalog |  |
Bracketed SQL comments (/*...*/ comments) |  |  |
CASCADE drop behavior |  |  |
CASE expression |  |  |
CASE expression 01 | Simple CASE |  |
CASE expression 02 | Searched CASE |  |
CASE expression 03 | NULLIF |  |
CASE expression 04 | COALESCE |  |
CAST function |  |  |
CORRESPONDING in query expressions |  |  |
Call-Level Interface |  |  |
Catalog name qualifiers |  |  |
Chained transactions |  |  |
Character data types |  |  |
Character set definition |  |  |
Character string types 01 | CHARACTER data type |  |
Character string types 02 | CHARACTER VARYING data type |  |
Character string types 03 | Character literals |  |
Character string types 04 | CHARACTER_LENGTH function |  |
Character string types 05 | OCTET_LENGTH function |  |
Character string types 06 | SUBSTRING function |  |
Character string types 07 | Character concatenation |  |
Character string types 08 | UPPER and LOWER functions |  |
Character string types 09 | TRIM function |  |
Character string types 10 | Implicit casting among the character string types |  |
Character string types 11 | POSITION function |  |
Character string types 12 | Character comparison |  |
Collation and translation |  |  |
Comma-separated predicates in simple CASE expression |  |  |
Comparable data types for referential constraints |  |  |
Compound character literals |  |  |
Connection management |  |  |
Constraint management |  |  |
Create method by specific method name |  |  |
Create table of type |  |  |
Cyclically dependent routines |  |  |
DISTINCT predicate |  |  |
DISTINCT predicate with negation |  |  |
Deferrable constraints |  |  |
Derived tables |  |  |
Direct SQL |  |  |
Distinct data types |  |  |
Distinct data types 01 | USER_DEFINED_TYPES view |  |
Domain support |  |  |
Dynamic specification of cursor attributes |  |  |
EXCEPT ALL table operator |  |  |
Elementary OLAP operations |  |  |
Embedded Ada |  |  |
Embedded C |  |  |
Embedded COBOL |  |  |
Embedded Fortran |  |  |
Embedded MUMPS |  |  |
Embedded PL/I |  |  |
Embedded Pascal |  |  |
Enhanced EXISTS predicate |  |  |
Enhanced collation support |  |  |
Enhanced documentation tables |  |  |
Enhanced documentation tables 01 | SQL_SIZING_PROFILES view |  |
Enhanced documentation tables 02 | SQL_IMPLEMENTATION_INFO view |  |
Enhanced documentation tables 03 | SQL_PACKAGES view |  |
Enhanced execution rights |  |  |
Enhanced numeric functions |  |  |
Enhanced reference types |  |  |
Enhanced savepoint management |  |  |
Enhanced seconds precision |  |  |
Enhanced structured types |  |  |
Enhanced trigger capability |  |  |
Expanded NULL predicate |  |  |
Explicit aliases for all-fields reference |  |  |
Explicit defaults |  |  |
Explicit security for SQL routines |  |  |
Explicit security for external routines |  |  |
Extended CASE expression |  |  |
Extended LIKE clause in table definition |  |  |
Extended LOB data type support |  |  |
Extended REVOKE statement |  |  |
Extended REVOKE statement 01 | REVOKE statement performed by other than the owner of a schema object |  |
Extended REVOKE statement 02 | REVOKE statement: GRANT OPTION FOR clause |  |
Extended REVOKE statement 03 | REVOKE statement to revoke a privilege that the grantee has WITH GRANT OPTION |  |
Extended dynamic SQL |  |  |
Extended dynamic SQL 01 | <describe input statement> |  |
Extended flagging |  |  |
Extended flagging |  |  |
Extended grouping capabilities |  |  |
Extended joined table |  |  |
Extended joined table 01 | NATURAL JOIN |  |
Extended joined table 02 | FULL OUTER JOIN |  |
Extended joined table 04 | CROSS JOIN |  |
Extended roles |  |  |
Extended schema manipulation |  |  |
Extended schema manipulation 01 | ALTER TABLE statement: ALTER COLUMN clause |  |
Extended schema manipulation 02 | ALTER TABLE statement: ADD CONSTRAINT clause |  |
Extended schema manipulation 03 | ALTER TABLE statement: DROP CONSTRAINT clause |  |
Extended set function support |  |  |
Extensions to embedded SQL exception declarations |  |  |
Features and conformance views |  |  |
Features and conformance views 01 | SQL_FEATURES view |  |
Features and conformance views 02 | SQL_SIZING view |  |
Features and conformance views 03 | SQL_LANGUAGES view |  |
Final structured types |  |  |
Full cursor update |  |  |
Full cursor update 01 | Updatable scrollable cursors |  |
Full cursor update 02 | Updatable ordered cursors |  |
Full set function |  |  |
Full value expressions |  |  |
Functional dependencies |  |  |
GROUP BY DISTINCT |  |  |
Generated columns |  |  |
Grouped operations |  |  |
Grouped operations 01 | WHERE, GROUP BY, and HAVING clauses supported in queries with grouped views |  |
Grouped operations 02 | Multiple tables supported in queries with grouped views |  |
Grouped operations 03 | Set functions supported in queries with grouped views |  |
Grouped operations 04 | Subqueries with GROUP BY and HAVING clauses and grouped views |  |
Grouped operations 05 | Single row SELECT with GROUP BY and HAVING clauses and grouped views |  |
Holdable locators |  |  |
IN predicate with one list element |  |  |
INSERT column privileges |  |  |
INSERT into a cursor |  |  |
INSERT statement: DEFAULT VALUES clause |  |  |
INTERSECT table operator |  |  |
INTERSECT table operator 01 | INTERSECT DISTINCT table operator |  |
INTERSECT table operator 02 | INTERSECT ALL table operator |  |
Identifiers |  |  |
Identifiers 01 | Delimited identifiers |  |
Identifiers 02 | Lower case identifiers |  |
Identifiers 03 | Trailing underscore |  |
Identity columns |  |  |
Indicator data types |  |  |
Insensitive cursors |  |  |
Intervals and datetime arithmetic |  |  |
Isolation levels other than SERIALIZABLE |  |  |
Isolation levels other than SERIALIZABLE 01 | READ UNCOMMITTED isolation level |  |
Isolation levels other than SERIALIZABLE 02 | READ COMMITTED isolation level |  |
Isolation levels other than SERIALIZABLE 03 | REPEATABLE READ isolation level |  |
LATERAL derived table |  |  |
LIKE clause in table definition |  |  |
LIKE enhancements |  |  |
Local cursor references |  |  |
Local table references |  |  |
Long identifiers |  |  |
MAX and MIN for row types |  |  |
MERGE statement |  |  |
Mixed column references in set functions |  |  |
Module language |  |  |
Module language Ada |  |  |
Module language C |  |  |
Module language COBOL |  |  |
Module language Fortran |  |  |
Module language MUMPS |  |  |
Module language PL/I |  |  |
Module language Pascal |  |  |
Multiargument GROUPING function |  |  |
Multiple column assignment |  |  |
Multiple module support |  |  |
Multiple schemas per user |  |  |
Multiset locators |  |  |
Multiset-returning external SQL-invoked functions |  |  |
Multisets of reference types |  |  |
Multisets of user-defined types |  |  |
Named character sets |  |  |
Named column joins for LOBs, arrays, and multisets |  |  |
National character |  |  |
Nested and concatenated GROUPING SETS |  |  |
Nested collection types |  |  |
Null value support (nulls in lieu of values) |  |  |
Numeric data types |  |  |
Numeric data types 01 | INTEGER and SMALLINT data types |  |
Numeric data types 02 | REAL, DOUBLE PRECISION, and FLOAT data types |  |
Numeric data types 03 | DECIMAL and NUMERIC data types |  |
Numeric data types 04 | Arithmetic operators |  |
Numeric data types 05 | Numeric comparison |  |
Numeric data types 06 | Implicit casting among the numeric data types |  |
ONLY in query expressions |  |  |
OVERLAPS predicate |  |  |
OVERLAY function |  |  |
Optional array bounds |  |  |
Optional key words for default syntax |  |  |
Overloading of SQL-invoked functions and procedures |  |  |
Permutable UDT options list |  |  |
Privilege tables |  |  |
Privilege tables 01 | TABLE_PRIVILEGES view |  |
Privilege tables 02 | COLUMN_PRIVILEGES view |  |
Privilege tables 03 | USAGE_PRIVILEGES view |  |
Qualified SQL parameter references |  |  |
Read-only scrollable cursors |  |  |
Read-only scrollable cursors 01 | FETCH with explicit NEXT |  |
Read-only scrollable cursors 02 | FETCH FIRST |  |
Read-only scrollable cursors 03 | FETCH LAST |  |
Read-only scrollable cursors 04 | FETCH PRIOR |  |
Read-only scrollable cursors 05 | FETCH ABSOLUTE |  |
Read-only scrollable cursors 06 | FETCH RELATIVE |  |
Recursive query |  |  |
Recursive query in subquery |  |  |
Referential MATCH types |  |  |
Referential action RESTRICT |  |  |
Referential delete actions |  |  |
Referential update actions |  |  |
Regular expression substring function |  |  |
Result sets return value |  |  |
Retrospective check constraints |  |  |
Routine language Ada |  |  |
Routine language C |  |  |
Routine language COBOL |  |  |
Routine language Fortran |  |  |
Routine language MUMPS |  |  |
Routine language PL/I |  |  |
Routine language Pascal |  |  |
Routine language SQL |  |  |
Row and table constructors |  |  |
Row types |  |  |
SELECT privilege with column granularity |  |  |
SET TRANSACTION statement: LOCAL option |  |  |
SIMILAR predicate |  |  |
SQL comments using leading double minus |  |  |
SQL paths in function and type name resolution |  |  |
SQL-dynamic statements in SQL routines |  |  |
SQL-dynamic statements in external routines |  |  |
SQL-invoked routines on arrays |  |  |
SQL-invoked routines on arrays 01 | Array parameters |  |
SQL-invoked routines on arrays 02 | Array as result type of functions |  |
SQL-invoked routines on multisets |  |  |
SQL-schema statements in SQL routines |  |  |
SQL-schema statements in external routines |  |  |
SQL-session and client module collations |  |  |
SQLSTATE support |  |  |
START TRANSACTION statement |  |  |
Sampling |  |  |
Savepoints |  |  |
Scalar subquery values |  |  |
Schema definition statement |  |  |
Schema definition statement 01 | CREATE SCHEMA |  |
Schema definition statement 02 | CREATE TABLE for persistent base tables |  |
Schema definition statement 03 | CREATE VIEW |  |
Schema definition statement 04 | CREATE VIEW: WITH CHECK OPTION |  |
Schema definition statement 05 | GRANT statement |  |
Self-referencing operations |  |  |
Self-referencing structured types |  |  |
Sensitive cursors |  |  |
Sequence generator support |  |  |
Session management |  |  |
Set functions |  |  |
Set functions 01 | AVG |  |
Set functions 02 | COUNT |  |
Set functions 03 | MAX |  |
Set functions 04 | MIN |  |
Set functions 05 | SUM |  |
Set functions 06 | ALL quantifier |  |
Set functions 07 | DISTINCT quantifier |  |
Simple tables |  |  |
Single row SELECT statement |  |  |
Specific type method |  |  |
Structured type locators |  |  |
Subprogram support |  |  |
Subqueries in CHECK |  |  |
Subtables |  |  |
Subtype treatment |  |  |
Subtype treatment for references |  |  |
Symmetric BETWEEN predicate |  |  |
Table functions |  |  |
Temporary tables |  |  |
Time zone specification |  |  |
Timestamp in Information Schema |  |  |
Transaction counts |  |  |
Transaction support |  |  |
Transaction support 01 | COMMIT statement |  |
Transaction support 02 | ROLLBACK statement |  |
Transform functions |  |  |
Translation support |  |  |
Truth value tests |  |  |
Type predicate |  |  |
UCS support |  |  |
UNION and EXCEPT in views |  |  |
UNIQUE constraints of possibly null columns |  |  |
UNIQUE predicate |  |  |
UPDATE statement: SET ROW option |  |  |
Unicode escapes in identifiers |  |  |
Unicode escapes in literals |  |  |
Unique constraint on entire row |  |  |
Untyped SQL-invoked function arguments |  |  |
Updatable joins, unions, and columns |  |  |
Updatable queries with subqueries |  |  |
Updatable table references |  |  |
Usage tables |  |  |
User authorization |  |  |
User-defined cast functions |  |  |
User-defined orderings |  |  |
View CHECK enhancements |  |  |
WITH (excluding RECURSIVE) in query expression |  |  |
WITH (excluding RECURSIVE) in subquery |  |  |
Total: 439 feature(s)

Implementations

Name | Integer value | Character value | Comments
CATALOG NAME |  | Y |
COLLATING SEQUENCE |  |  | not supported
CURSOR COMMIT BEHAVIOR | 1 |  | close cursors and retain prepared statements
DATA SOURCE NAME |  |  |
DBMS NAME |  | PostgreSQL |
DEFAULT TRANSACTION ISOLATION | 2 |  | READ COMMITTED; user-settable
IDENTIFIER CASE | 3 |  | stored in mixed case - case sensitive
NULL COLLATION | 0 |  | nulls higher than non-nulls
SERVER NAME |  |  |
SPECIAL CHARACTERS |  |  | all non-ASCII characters allowed
TRANSACTION CAPABLE | 2 |  | both DML and DDL
DBMS VERSION |  | 08.02.0005 |
Total: 12 implementation(s)

Packages

Name | Supported | Verified by | Comment
Core |  |  |
Enhanced datetime facilities |  |  |
Enhanced integrity management |  |  |
OLAP facilities |  |  |
PSM |  |  | PL/pgSQL is similar.
CLI |  |  | ODBC is similar.
Basic object support |  |  |
Enhanced object support |  |  |
Active database |  |  |
OLAP |  |  | NO
Total: 10 package(s)

Language bindings

Name | Source | Year | Programming language
CORE_DIRECT | ISO 9075 | 1999 |
CORE_EMBEDDED_C | ISO 9075 | 1999 | C
CORE_DIRECT | ISO 9075 | 2003 |
CORE_EMBEDDED_C | ISO 9075 | 2003 | C
Total: 4 language binding(s)

Sizings

Name | Supported value | Comment
MAXIMUM COLUMNS IN GROUP BY | 0 |
MAXIMUM COLUMNS IN ORDER BY | 0 |
MAXIMUM COLUMNS IN SELECT | 1664 |
MAXIMUM COLUMNS IN TABLE | 1600 |
MAXIMUM CONCURRENT ACTIVITIES | 0 |
MAXIMUM DRIVER CONNECTIONS |  |
MAXIMUM STATEMENT OCTETS | 0 |
MAXIMUM STATEMENT OCTETS DATA | 0 |
MAXIMUM STATEMENT OCTETS SCHEMA | 0 |
MAXIMUM TABLES IN SELECT | 0 |
MAXIMUM CURRENT DEFAULT TRANSFORM GROUP LENGTH |  |
MAXIMUM CURRENT TRANSFORM GROUP LENGTH |  |
MAXIMUM CURRENT PATH LENGTH | 0 |
MAXIMUM CURRENT ROLE LENGTH |  |
MAXIMUM CATALOG NAME LENGTH | 63 | Might be less, depending on character set.
MAXIMUM COLUMN NAME LENGTH | 63 | Might be less, depending on character set.
MAXIMUM CURSOR NAME LENGTH | 63 | Might be less, depending on character set.
MAXIMUM IDENTIFIER LENGTH | 63 | Might be less, depending on character set.
MAXIMUM SCHEMA NAME LENGTH | 63 | Might be less, depending on character set.
MAXIMUM TABLE NAME LENGTH | 63 | Might be less, depending on character set.
MAXIMUM USER NAME LENGTH | 63 | Might be less, depending on character set.
MAXIMUM SESSION USER LENGTH | 63 | Might be less, depending on character set.
MAXIMUM SYSTEM USER LENGTH | 63 | Might be less, depending on character set.
Total: 23 sizing(s)

Server parameters

Name | Setting
add_missing_from | off
allow_system_table_mods | off
archive_command |
archive_timeout | 0
array_nulls | on
authentication_timeout | 60
autovacuum | on
autovacuum_analyze_scale_factor | 0.1
autovacuum_analyze_threshold | 250
autovacuum_freeze_max_age | 200000000
autovacuum_naptime | 60
autovacuum_vacuum_cost_delay | -1
autovacuum_vacuum_cost_limit | -1
autovacuum_vacuum_scale_factor | 0.2
autovacuum_vacuum_threshold | 500
backslash_quote | safe_encoding
bgwriter_all_maxpages | 5
bgwriter_all_percent | 0.333
bgwriter_delay | 200
bgwriter_lru_maxpages | 5
bgwriter_lru_percent | 1
block_size | 8192
bonjour_name |
check_function_bodies | on
checkpoint_segments | 3
checkpoint_timeout | 300
checkpoint_warning | 30
client_encoding | Unicode
client_min_messages | notice
commit_delay | 0
commit_siblings | 5
config_file | D:/Program Files/PostgreSQL/8.2/data/postgresql.conf
constraint_exclusion | off
cpu_index_tuple_cost | 0.005
cpu_operator_cost | 0.0025
cpu_tuple_cost | 0.01
custom_variable_classes |
data_directory | D:/Program Files/PostgreSQL/8.2/data
DateStyle | ISO, MDY
db_user_namespace | off
deadlock_timeout | 1000
debug_assertions | off
debug_pretty_print | off
debug_print_parse | off
debug_print_plan | off
debug_print_rewritten | off
default_statistics_target | 10
default_tablespace |
default_transaction_isolation | read committed
default_transaction_read_only | off
default_with_oids | off
dynamic_library_path | $libdir
effective_cache_size | 16384
enable_bitmapscan | on
enable_hashagg | on
enable_hashjoin | on
enable_indexscan | on
enable_mergejoin | on
enable_nestloop | on
enable_seqscan | on
enable_sort | on
enable_tidscan | on
escape_string_warning | on
explain_pretty_print | on
external_pid_file |
extra_float_digits | 0
from_collapse_limit | 8
fsync | on
full_page_writes | on
geqo | on
geqo_effort | 5
geqo_generations | 0
geqo_pool_size | 0
geqo_selection_bias | 2
geqo_threshold | 12
gin_fuzzy_search_limit | 0
hba_file | D:/Program Files/PostgreSQL/8.2/data/pg_hba.conf
ident_file | D:/Program Files/PostgreSQL/8.2/data/pg_ident.conf
ignore_system_indexes | off
integer_datetimes | off
join_collapse_limit | 8
krb_caseins_users | off
krb_server_hostname |
krb_server_keyfile | FILE:/usr/local/pgsql/etc/krb5.keytab
krb_srvname | postgres
lc_collate | C
lc_ctype | C
lc_messages | C
lc_monetary | C
lc_numeric | C
lc_time | C
listen_addresses | *
local_preload_libraries |
log_connections | off
log_destination | stderr
log_directory | pg_log
log_disconnections | off
log_duration | off
log_error_verbosity | default
log_executor_stats | off
log_filename | postgresql-%Y-%m-%d_%H%M%S.log
log_hostname | off
log_line_prefix | %t
log_min_duration_statement | -1
log_min_error_statement | error
log_min_messages | notice
log_parser_stats | off
log_planner_stats | off
log_rotation_age | 1440
log_rotation_size | 10240
log_statement | none
log_statement_stats | off
log_truncate_on_rotation | off
maintenance_work_mem | 16384
max_connections | 100
max_files_per_process | 1000
max_fsm_pages | 204800
max_fsm_relations | 1000
max_function_args | 100
max_identifier_length | 63
max_index_keys | 32
max_locks_per_transaction | 64
max_prepared_transactions | 5
max_stack_depth | 2048
password_encryption | on
port | 5432
post_auth_delay | 0
pre_auth_delay | 0
random_page_cost | 4
redirect_stderr | on
regex_flavor | advanced
search_path | "$user",public
seq_page_cost | 1
server_encoding | SQL_ASCII
server_version | 8.2.5
server_version_num | 80205
shared_buffers | 4096
shared_preload_libraries |
silent_mode | off
sql_inheritance | on
ssl | off
standard_conforming_strings | off
statement_timeout | 0
stats_block_level | off
stats_command_string | on
stats_reset_on_server_start | off
stats_row_level | on
stats_start_collector | on
superuser_reserved_connections | 3
tcp_keepalives_count | 0
tcp_keepalives_idle | 0
tcp_keepalives_interval | 0
temp_buffers | 1024
TimeZone | Europe/Helsinki
timezone_abbreviations | Default
trace_notify | off
trace_sort | off
transaction_isolation | read committed
transaction_read_only | off
transform_null_equals | off
unix_socket_directory |
unix_socket_group |
unix_socket_permissions | 511
update_process_title | on
vacuum_cost_delay | 0
vacuum_cost_limit | 200
vacuum_cost_page_dirty | 20
vacuum_cost_page_hit | 1
vacuum_cost_page_miss | 10
vacuum_freeze_min_age | 100000000
wal_buffers | 8
wal_sync_method | open_datasync
work_mem | 1024
zero_damaged_pages | off
Total: 174 server parameter(s)

See Also

Tablespaces
Groups
Logins


List of tablespaces

Tablespaces

Name | Owner | Location
pg_default | postgres |
pg_global | postgres |
Total: 2 tablespace(s)

See Also

Server overview


Tablespace: pg_default

Properties

Name: | pg_default
Owner: | postgres
Location: |

See Also

List of tablespaces


Tablespace: pg_global

Properties

Name: | pg_global
Owner: | postgres
Location: |

See Also

List of tablespaces


List of logins

Logins

Name | Superuser | Inherits
postgres |  |
Total: 1 login(s)

See Also

Server overview


Login: postgres

Properties

Name: | postgres
Superuser: |
Inherits: |
Createroles: |
Createdb: |
Update catalogs: |
Canlogin: |
Connections limit: | -1
Valid until: |
Config: |

See Also

List of logins


About

Documentation details

Customer: |
Project: |
Created: | 12/24/2007