List of databases

Databases

Database | Owner | System | Description
UIPState | sa |  |
UIPstore | sa |  |
Total: 2 database(s)

See Also

Server overview


Database: UIPState

Properties

Name: | UIPState
Owner: | sa
Create for Attach: | 02.11.2007
Compatibility Level: | 80
Status: | Database is available for query
Full Text Search Enabled: |
Primary File: | D:\Program Files\Microsoft SQL Server\MSSQL\Data\UIPState.mdf
Version: | 539
Database size, MB: | 1.37 MB
Allocated Space, KB: | 752 KB
Data Space in Use and Reserved for Use, KB: | 288 KB
Index Space Usage, KB: | 304 KB
Allocated and Unused Space, KB: | 160 KB
Description: |

Data Files

File Name | Location | File Group | Allocated Space, MB | Autogrows | Grows | Maximum File Size, MB
UIPState | D:\Program Files\Microsoft SQL Server\MSSQL\Data\UIPState.mdf | PRIMARY | 0 |  | 10 % | Unrestricted
Total: 1 data file(s)

Log Files

File Name | Location | Allocated Space, MB | Autogrows | Grows | Maximum File Size, MB
UIPState_log | D:\Program Files\Microsoft SQL Server\MSSQL\Data\UIPState_log.LDF | 0 |  | 10 % | Unrestricted
Total: 1 log file(s)

Tables

Name | Owner | Data Size KB | Index Size KB | Creation Date | Cols | Rows | Description
State | dbo | 8 | 16 | 02.14.2006 | 3 | 0 |
Total: 1 table(s)

Stored procedures

Name | Owner | Description
CLEANUP_RemoveStaleState | dbo |
DeleteState | dbo |
InsertState | dbo |
SelectState | dbo |
SerializeXML | dbo |
UpdateState | dbo |
Total: 6 stored procedure(s)

Database Options

Settings: Auto Close:
Settings: Auto Shrink:
Settings: Auto Create Statistics:
Settings: Auto Update Statistics:
Settings: Use Quoted Identifiers:
Settings: Torn Page Detection:
Settings: Recursive Triggers:
Settings: ANSI NULL default:
Access: Read Only:
Access: Single User:
Access: Members of db_owner, dbcreator or sysadmin:
Truncate Log On Checkpoint:
Select Into/Bulkcopy:
Cursor Close On Commit:
Cursors in a Batch are with Local Scope:

See Also

Server overview


List of tables

Tables

Name | Owner | Data Size KB | Index Size KB | Creation Date | Cols | Rows | Description
State | dbo | 8 | 16 | 02.14.2006 | 3 | 0 |
Total: 1 table(s)

See Also

Database overview


Table: State

Properties

Owner: | dbo
Creation Date: | 02.14.2006
ID: | 613577224
Located On: | PRIMARY
Rows: | 0
Data Size KB: | 16
Index Size KB: | 8
Description: |

Columns

Name | Data Type | Length | NULL | Default | IsGUID | Description
StateGuid | uniqueidentifier | 16 |  |  |  |
DateAdded | datetime | 8 |  |  |  |
StateData | image | 16 |  |  |  |
Total: 3 column(s)

Objects that depend on [dbo].[State]

Object Name | Owner | Object Type | Dep Level
CLEANUP_RemoveStaleState | dbo | Procedure | 1
DeleteState | dbo | Procedure | 1
InsertState | dbo | Procedure | 1
SelectState | dbo | Procedure | 1
UpdateState | dbo | Procedure | 1
Total: 5 objects

SQL

CREATE TABLE [State] (
[StateGuid] [uniqueidentifier] NOT NULL ,
[DateAdded] [datetime] NOT NULL CONSTRAINT [DF_State_DateAdded] DEFAULT (getdate()),
[StateData] [image] NOT NULL
) ON [PRIMARY] TEXTIMAGE_ON [PRIMARY]
GO

See Also

List of tables


List of stored procedures

Stored procedures

Name | Owner | Description
CLEANUP_RemoveStaleState | dbo |
DeleteState | dbo |
InsertState | dbo |
SelectState | dbo |
SerializeXML | dbo |
UpdateState | dbo |
Total: 6 stored procedure(s)

See Also

Database overview


Stored Procedure: CLEANUP_RemoveStaleState

Properties

Owner: | dbo
Encrypted: |
Creation Date: | 02.14.2006
Description: |

Creation options

QUOTED_IDENTIFIER:
ANSI_NULLS:

Objects that [dbo].[CLEANUP_RemoveStaleState] depends on

Object Name | Owner | Object Type | Dep Level
State | dbo | Table | 1
Total: 1 object(s)

SQL

SET QUOTED_IDENTIFIER ON
GO

/****** Object: Stored Procedure dbo.CLEANUP_RemoveStaleState Script Date: 3/27/2003 10:46:41 PM ******/
CREATE PROCEDURE CLEANUP_RemoveStaleState

AS

SET NOCOUNT ON

DELETE FROM
State
WHERE
DateAdded < (DateAdd(dd, -30, getdate()))

GO
SET QUOTED_IDENTIFIER OFF
GO

See Also

List of stored procedures


Stored Procedure: DeleteState

Properties

Owner: | dbo
Encrypted: |
Creation Date: | 02.14.2006
Description: |

Creation options

QUOTED_IDENTIFIER:
ANSI_NULLS:

Parameters

Name | Direction | DataType | Length
@StateGuid | INPUT | uniqueidentifier | 16
Total: 1 parameter(s)

Objects that [dbo].[DeleteState] depends on

Object Name | Owner | Object Type | Dep Level
State | dbo | Table | 1
Total: 1 object(s)

SQL

SET QUOTED_IDENTIFIER ON
GO
SET ANSI_NULLS ON
GO

/****** Object: Stored Procedure dbo.DeleteState Script Date: 3/27/2003 10:46:41 PM ******/

/****** Object: Stored Procedure dbo.DeleteState Script Date: 3/27/2003 10:29:51 PM ******/

CREATE PROCEDURE dbo.DeleteState
(
@StateGuid uniqueidentifier
)
AS
delete State
where StateGuid = @StateGuid;
RETURN

GO
SET QUOTED_IDENTIFIER OFF
GO

GO
SET ANSI_NULLS OFF
GO

See Also

List of stored procedures


Stored Procedure: InsertState

Properties

Owner: | dbo
Encrypted: |
Creation Date: | 02.14.2006
Description: |

Creation options

QUOTED_IDENTIFIER:
ANSI_NULLS:

Parameters

Name | Direction | DataType | Length
@StateGuid | INPUT | uniqueidentifier | 16
@XmlState | INPUT | image | 16
Total: 2 parameter(s)

Objects that [dbo].[InsertState] depends on

Object Name | Owner | Object Type | Dep Level
State | dbo | Table | 1
Total: 1 object(s)

SQL

SET QUOTED_IDENTIFIER ON
GO
SET ANSI_NULLS ON
GO

/****** Object: Stored Procedure dbo.InsertState Script Date: 3/27/2003 10:46:41 PM ******/

/****** Object: Stored Procedure dbo.InsertState Script Date: 3/27/2003 10:29:51 PM ******/

CREATE PROCEDURE dbo.InsertState
(
@StateGuid uniqueidentifier,
@XmlState image
)
AS
if exists( select * from State where stateguid = @StateGuid)
begin
update State
set StateData = @XmlState
where StateGuid = @StateGuid
end
else
begin
insert into State (StateGuid,StateData)
values (@StateGuid, @XmlState);
end
RETURN

GO
SET QUOTED_IDENTIFIER OFF
GO

GO
SET ANSI_NULLS OFF
GO

See Also

List of stored procedures


Stored Procedure: SelectState

Properties

Owner: | dbo
Encrypted: |
Creation Date: | 02.14.2006
Description: |

Creation options

QUOTED_IDENTIFIER:
ANSI_NULLS:

Parameters

Name | Direction | DataType | Length
@StateGuid | INPUT | uniqueidentifier | 16
Total: 1 parameter(s)

Objects that [dbo].[SelectState] depends on

Object Name | Owner | Object Type | Dep Level
State | dbo | Table | 1
Total: 1 object(s)

SQL

SET QUOTED_IDENTIFIER ON
GO
SET ANSI_NULLS ON
GO

/****** Object: Stored Procedure dbo.SelectState Script Date: 3/27/2003 10:46:41 PM ******/

/****** Object: Stored Procedure dbo.SelectState Script Date: 3/27/2003 10:29:51 PM ******/

CREATE PROCEDURE dbo.SelectState
(
@StateGuid uniqueidentifier
)
AS
select StateData from State
where StateGuid = @StateGuid;
RETURN

GO
SET QUOTED_IDENTIFIER OFF
GO

GO
SET ANSI_NULLS OFF
GO

See Also

List of stored procedures


Stored Procedure: SerializeXML

Properties

Owner: | dbo
Encrypted: |
Creation Date: | 02.14.2006
Description: |

Creation options

QUOTED_IDENTIFIER:
ANSI_NULLS:

Parameters

Name | Direction | DataType | Length
@XmlStream | INPUT | image | 16
Total: 1 parameter(s)

SQL

SET QUOTED_IDENTIFIER ON
GO
SET ANSI_NULLS ON
GO

/****** Object: Stored Procedure dbo.SerializeXML Script Date: 3/27/2003 10:46:41 PM ******/

/****** Object: Stored Procedure dbo.SerializeXML Script Date: 3/27/2003 10:29:51 PM ******/

CREATE PROCEDURE dbo.SerializeXML
(
@XmlStream image
)
AS
insert into xmlserial ( XmlStream )
values (@XmlStream);

RETURN

GO
SET QUOTED_IDENTIFIER OFF
GO

GO
SET ANSI_NULLS OFF
GO

See Also

List of stored procedures


Stored Procedure: UpdateState

Properties

Owner: | dbo
Encrypted: |
Creation Date: | 02.14.2006
Description: |

Creation options

QUOTED_IDENTIFIER:
ANSI_NULLS:

Parameters

Name | Direction | DataType | Length
@StateGuid | INPUT | uniqueidentifier | 16
@StateData | INPUT | varbinary | 1
Total: 2 parameter(s)

Objects that [dbo].[UpdateState] depends on

Object Name | Owner | Object Type | Dep Level
State | dbo | Table | 1
Total: 1 object(s)

SQL

SET QUOTED_IDENTIFIER ON
GO
SET ANSI_NULLS ON
GO

/****** Object: Stored Procedure dbo.UpdateState Script Date: 3/27/2003 10:46:41 PM ******/

/****** Object: Stored Procedure dbo.UpdateState Script Date: 3/27/2003 10:29:51 PM ******/

CREATE PROCEDURE dbo.UpdateState
(
@StateGuid uniqueidentifier,
@StateData varbinary
)
AS
update State
set StateData = @StateData
where StateGuid = @StateGuid;
RETURN

GO
SET QUOTED_IDENTIFIER OFF
GO

GO
SET ANSI_NULLS OFF
GO

See Also

List of stored procedures


List of users

Users

Name
dbo
guest
UIP
Total: 3 users(s)

See Also

Database overview


User: dbo

User Properties

Name: dbo

SQL

if not exists (select * from dbo.sysusers where name = N'dbo' and uid < 16382)
EXEC sp_grantdbaccess N'sa', N'dbo'
GO

See Also

List of users


User: guest

User Properties

Name: guest

SQL

Unknown property[SQL] in [dbuser] type

See Also

List of users


User: UIP

User Properties

Name: UIP

SQL

Unknown property[SQL] in [dbuser] type

See Also

List of users


List of roles

Roles

Name
public
db_owner
Total: 2 roles(s)

See Also

Database overview


Role: public

Properties

Fixed:

SQL

if not exists (select * from dbo.sysusers where name = N'public' and uid > 16399)
EXEC sp_addrole N'public'
GO

See Also

List of roles


Role: db_owner

Properties

Fixed:

Users

Name
dbo
UIP
Total: 2 user(s)

SQL

See Also

List of roles


Database: UIPstore

Properties

Name: | UIPstore
Owner: | sa
Create for Attach: | 02.11.2007
Compatibility Level: | 80
Status: | Database is available for query
Full Text Search Enabled: |
Primary File: | D:\Program Files\Microsoft SQL Server\MSSQL\Data\UIPstore.mdf
Version: | 539
Database size, MB: | 1.49 MB
Allocated Space, KB: | 912 KB
Data Space in Use and Reserved for Use, KB: | 232 KB
Index Space Usage, KB: | 576 KB
Allocated and Unused Space, KB: | 104 KB
Description: |

Data Files

File Name | Location | File Group | Allocated Space, MB | Autogrows | Grows | Maximum File Size, MB
UIPstore | D:\Program Files\Microsoft SQL Server\MSSQL\Data\UIPstore.mdf | PRIMARY | 1 |  | 10 % | Unrestricted
Total: 1 data file(s)

Log Files

File Name | Location | Allocated Space, MB | Autogrows | Grows | Maximum File Size, MB
UIPstore_log | D:\Program Files\Microsoft SQL Server\MSSQL\Data\UIPstore_log.LDF | 0 |  | 10 % | Unrestricted
Total: 1 log file(s)

Tables

Name | Owner | Data Size KB | Index Size KB | Creation Date | Cols | Rows | Description
CartTasks | dbo | 16 | 8 | 02.14.2006 | 2 | 1 |
Categories | dbo | 24 | 8 | 02.14.2006 | 2 | 7 |
Customers | dbo | 40 | 8 | 02.14.2006 | 4 | 2 |
Order_details | dbo | 48 | 8 | 02.14.2006 | 4 | 10 |
Orders | dbo | 40 | 8 | 02.14.2006 | 4 | 3 |
Products | dbo | 64 | 8 | 02.14.2006 | 7 | 13 |
Reviews | dbo | 0 | 0 | 02.14.2006 | 6 | 0 |
Total: 7 table(s)

Stored procedures

Name | Owner | Description
DeleteProduct | dbo |
InsertCartTask | dbo |
InsertOrder | dbo |
InsertOrder_Details | dbo |
InsertProduct | dbo |
SelectAllCategories | dbo |
SelectAllProducts | dbo |
SelectCartTask | dbo |
SelectCartTaskByCustomerId | dbo |
SelectCartTaskByTaskId | dbo |
SelectCustomerByEmail | dbo |
SelectCustomerById | dbo |
SelectProductById | dbo |
SelectProducts | dbo |
UpdateProduct | dbo |
Total: 15 stored procedure(s)

Database Options

Settings: Auto Close:
Settings: Auto Shrink:
Settings: Auto Create Statistics:
Settings: Auto Update Statistics:
Settings: Use Quoted Identifiers:
Settings: Torn Page Detection:
Settings: Recursive Triggers:
Settings: ANSI NULL default:
Access: Read Only:
Access: Single User:
Access: Members of db_owner, dbcreator or sysadmin:
Truncate Log On Checkpoint:
Select Into/Bulkcopy:
Cursor Close On Commit:
Cursors in a Batch are with Local Scope:

See Also

Server overview


List of tables

Tables

Name | Owner | Data Size KB | Index Size KB | Creation Date | Cols | Rows | Description
CartTasks | dbo | 16 | 8 | 02.14.2006 | 2 | 1 |
Categories | dbo | 24 | 8 | 02.14.2006 | 2 | 7 |
Customers | dbo | 40 | 8 | 02.14.2006 | 4 | 2 |
Order_details | dbo | 48 | 8 | 02.14.2006 | 4 | 10 |
Orders | dbo | 40 | 8 | 02.14.2006 | 4 | 3 |
Products | dbo | 64 | 8 | 02.14.2006 | 7 | 13 |
Reviews | dbo | 0 | 0 | 02.14.2006 | 6 | 0 |
Total: 7 table(s)

See Also

Database overview


Table: CartTasks

Properties

Owner: | dbo
Creation Date: | 02.14.2006
ID: | 1977058079
Located On: | PRIMARY
Rows: | 1
Data Size KB: | 8
Index Size KB: | 16
Description: |

Columns

Name | Data Type | Length | NULL | Default | IsGUID | Description
CustomerID | int | 4 |  |  |  |
TaskID | uniqueidentifier | 16 |  |  |  |
Total: 2 column(s)

Indexes

Index | Primary | Unique
PK_CartTasks |  |
Total: 1 indexes(s)

Referenced Tables

Table | Foreign Key | Primary Key or Unique Constraint
Customers | FK_CartTasks_Customers | PK_Customers

Objects that [dbo].[CartTasks] depends on

Object Name | Owner | Object Type | Dep Level
Customers | dbo | Table | 1
Total: 1 objects

Objects that depend on [dbo].[CartTasks]

Object Name | Owner | Object Type | Dep Level
InsertCartTask | dbo | Procedure | 1
SelectCartTask | dbo | Procedure | 1
SelectCartTaskByCustomerId | dbo | Procedure | 1
SelectCartTaskByTaskId | dbo | Procedure | 1
Total: 4 objects

SQL

CREATE TABLE [CartTasks] (
[CustomerID] [int] NOT NULL ,
[TaskID] [uniqueidentifier] NOT NULL ,
CONSTRAINT [PK_CartTasks] PRIMARY KEY CLUSTERED
(
[CustomerID],
[TaskID]
) ON [PRIMARY] ,
CONSTRAINT [FK_CartTasks_Customers] FOREIGN KEY
(
[CustomerID]
) REFERENCES [Customers] (
[CustomerID]
)
) ON [PRIMARY]
GO

See Also

List of tables


List of indexes on [CartTasks]

Indexes

Index | Primary | Unique
PK_CartTasks |  |
Total: 1 index(s)

See Also

Table [CartTasks]


Index: PK_CartTasks on table dbo.CartTasks

Properties

Size KB: | 16
Fill Factor: | 0
Don't Recompute Statistics: |
Pad Index: |
Unique Index: |
Primary Key Index: |
Clustered Index: |
Is computed column in index: |
Ignore Duplicates: |
Located On: | PRIMARY
Disabled: |

Index Columns

Name | Descending
CustomerID | 0
TaskID | 0
Total: 2 column(s)

Statistics

Updated:
Average key length:
Density:
Rows in the table:
Rows sampled for statistics data:
Distribution steps:

SQL

CREATE UNIQUE CLUSTERED INDEX [PK_CartTasks] ON [dbo].[CartTasks]([CustomerID], [TaskID]) ON [PRIMARY]
GO

See Also

List of indexes


List of relationships on [CartTasks]

Relationships

Table | Foreign Key | Primary Key or Unique Constraint
Customers | FK_CartTasks_Customers | PK_Customers
Total: 1 relationship(s)

See Also

Table [CartTasks]


Relationship: [FK_CartTasks_Customers] on [CartTasks]

Properties

Primary Table Owner: | dbo
Primary Table: | Customers
Primary Key or Unique Constraint: | PK_Customers
Delete Cascade: |
Update Cascade: |

Relationship Columns

Column | Reference Column | Type
CustomerID | CustomerID | int
Total: 1 trigger(s)

SQL

ALTER TABLE [dbo].[CartTasks] ADD CONSTRAINT [FK_CartTasks_Customers] FOREIGN KEY
(
[CustomerID]
) REFERENCES [Customers] (
[CustomerID]
)
GO

See Also

Table [Customers]
Table [CartTasks]


Table: Categories

Properties

Owner: | dbo
Creation Date: | 02.14.2006
ID: | 1993058136
Located On: | PRIMARY
Rows: | 7
Data Size KB: | 8
Index Size KB: | 24
Description: |

Columns

Name | Data Type | Length | NULL | Default | IsGUID | Description
CategoryID | int | 4 |  |  |  |
CategoryName | varchar | 50 |  |  |  |
Total: 2 column(s)

Indexes

Index | Primary | Unique
PK_Categories |  |
Total: 1 indexes(s)

Identity column

Total: 1 identity columns

Referencing Tables

Table | Foreign Key | Primary Key or Unique Constraint
Products | FK_Products_Categories | PK_Categories

Objects that depend on [dbo].[Categories]

Object Name | Owner | Object Type | Dep Level
Products | dbo | Table | 1
SelectAllCategories | dbo | Procedure | 1
Reviews | dbo | Table | 2
DeleteProduct | dbo | Procedure | 2
InsertProduct | dbo | Procedure | 2
SelectAllProducts | dbo | Procedure | 2
SelectProductById | dbo | Procedure | 2
SelectProducts | dbo | Procedure | 2
UpdateProduct | dbo | Procedure | 2
Total: 9 objects

SQL

CREATE TABLE [Categories] (
[CategoryID] [int] IDENTITY (1, 1) NOT NULL ,
[CategoryName] [varchar] (50) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
CONSTRAINT [PK_Categories] PRIMARY KEY NONCLUSTERED
(
[CategoryID]
) WITH FILLFACTOR = 90 ON [PRIMARY]
) ON [PRIMARY]
GO

See Also

List of tables


List of indexes on [Categories]

Indexes

Index | Primary | Unique
PK_Categories |  |
Total: 1 index(s)

See Also

Table [Categories]


Index: PK_Categories on table dbo.Categories

Properties

Size KB: | 16
Fill Factor: | 90
Don't Recompute Statistics: |
Pad Index: |
Unique Index: |
Primary Key Index: |
Clustered Index: |
Is computed column in index: |
Ignore Duplicates: |
Located On: | PRIMARY
Disabled: |

Index Columns

Name | Descending
CategoryID | 0
Total: 1 column(s)

Statistics

Updated:
Average key length:
Density:
Rows in the table:
Rows sampled for statistics data:
Distribution steps:

SQL

CREATE UNIQUE INDEX [PK_Categories] ON [dbo].[Categories]([CategoryID]) WITH FILLFACTOR = 90 ON [PRIMARY]
GO

See Also

List of indexes


Table: Customers

Properties

Owner: | dbo
Creation Date: | 02.14.2006
ID: | 2009058193
Located On: | PRIMARY
Rows: | 2
Data Size KB: | 8
Index Size KB: | 40
Description: |

Columns

Name | Data Type | Length | NULL | Default | IsGUID | Description
CustomerID | int | 4 |  |  |  |
FullName | varchar | 50 |  |  |  |
EmailAddress | varchar | 50 |  |  |  |
Password | varchar | 20 |  |  |  |
Total: 4 column(s)

Indexes

Index | Primary | Unique
IX_Customers |  |
PK_Customers |  |
Total: 2 indexes(s)

Identity column

Total: 1 identity columns

Referencing Tables

Table | Foreign Key | Primary Key or Unique Constraint
CartTasks | FK_CartTasks_Customers | PK_Customers
Orders | FK_Orders_Customers | PK_Customers

Objects that depend on [dbo].[Customers]

Object Name | Owner | Object Type | Dep Level
CartTasks | dbo | Table | 1
Orders | dbo | Table | 1
SelectCustomerByEmail | dbo | Procedure | 1
SelectCustomerById | dbo | Procedure | 1
Order_details | dbo | Table | 2
InsertCartTask | dbo | Procedure | 2
InsertOrder | dbo | Procedure | 2
SelectCartTask | dbo | Procedure | 2
SelectCartTaskByCustomerId | dbo | Procedure | 2
SelectCartTaskByTaskId | dbo | Procedure | 2
InsertOrder_Details | dbo | Procedure | 3
Total: 11 objects

SQL

CREATE TABLE [Customers] (
[CustomerID] [int] IDENTITY (1, 1) NOT NULL ,
[FullName] [varchar] (50) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
[EmailAddress] [varchar] (50) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
[Password] [varchar] (20) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
CONSTRAINT [PK_Customers] PRIMARY KEY NONCLUSTERED
(
[CustomerID]
) WITH FILLFACTOR = 90 ON [PRIMARY] ,
CONSTRAINT [IX_Customers] UNIQUE NONCLUSTERED
(
[EmailAddress]
) ON [PRIMARY]
) ON [PRIMARY]
GO

See Also

List of tables


List of indexes on [Customers]

Indexes

Index | Primary | Unique
IX_Customers |  |
PK_Customers |  |
Total: 2 index(s)

See Also

Table [Customers]


Index: IX_Customers on table dbo.Customers

Properties

Size KB: | 16
Fill Factor: | 0
Don't Recompute Statistics: |
Pad Index: |
Unique Index: |
Primary Key Index: |
Clustered Index: |
Is computed column in index: |
Ignore Duplicates: |
Located On: | PRIMARY
Disabled: |

Index Columns

Name | Descending
EmailAddress | 0
Total: 1 column(s)

Statistics

Updated:
Average key length:
Density:
Rows in the table:
Rows sampled for statistics data:
Distribution steps:

SQL

CREATE UNIQUE INDEX [IX_Customers] ON [dbo].[Customers]([EmailAddress]) ON [PRIMARY]
GO

See Also

List of indexes


Index: PK_Customers on table dbo.Customers

Properties

Size KB: | 16
Fill Factor: | 90
Don't Recompute Statistics: |
Pad Index: |
Unique Index: |
Primary Key Index: |
Clustered Index: |
Is computed column in index: |
Ignore Duplicates: |
Located On: | PRIMARY
Disabled: |

Index Columns

Name | Descending
CustomerID | 0
Total: 1 column(s)

Statistics

Updated:
Average key length:
Density:
Rows in the table:
Rows sampled for statistics data:
Distribution steps:

SQL

CREATE UNIQUE INDEX [PK_Customers] ON [dbo].[Customers]([CustomerID]) WITH FILLFACTOR = 90 ON [PRIMARY]
GO

See Also

List of indexes


Table: Order_details

Properties

Owner: | dbo
Creation Date: | 02.14.2006
ID: | 2025058250
Located On: | PRIMARY
Rows: | 10
Data Size KB: | 8
Index Size KB: | 48
Description: |

Columns

Name | Data Type | Length | NULL | Default | IsGUID | Description
OrderID | int | 4 |  |  |  |
ProductID | int | 4 |  |  |  |
Quantity | int | 4 |  |  |  |
UnitCost | money | 8 |  |  |  |
Total: 4 column(s)

Indexes

Index | Primary | Unique
CI_order_details_orderid_prodid |  |
PK_OrderDetails |  |
IX_order_details_prodid |  |
Total: 3 indexes(s)

Referenced Tables

Table | Foreign Key | Primary Key or Unique Constraint
Orders | FK_OrderDetails_Orders | PK_Orders

Objects that [dbo].[Order_details] depends on

Object Name | Owner | Object Type | Dep Level
Customers | dbo | Table | 1
Orders | dbo | Table | 2
Total: 2 objects

Objects that depend on [dbo].[Order_details]

Object Name | Owner | Object Type | Dep Level
InsertOrder_Details | dbo | Procedure | 1
Total: 1 objects

SQL

CREATE TABLE [Order_details] (
[OrderID] [int] NOT NULL ,
[ProductID] [int] NOT NULL ,
[Quantity] [int] NOT NULL ,
[UnitCost] [money] NOT NULL ,
CONSTRAINT [PK_OrderDetails] PRIMARY KEY NONCLUSTERED
(
[OrderID],
[ProductID]
) WITH FILLFACTOR = 90 ON [PRIMARY] ,
CONSTRAINT [FK_OrderDetails_Orders] FOREIGN KEY
(
[OrderID]
) REFERENCES [Orders] (
[OrderID]
) ON DELETE CASCADE ON UPDATE CASCADE NOT FOR REPLICATION
) ON [PRIMARY]
GO

See Also

List of tables


List of indexes on [Order_details]

Indexes

Index | Primary | Unique
CI_order_details_orderid_prodid |  |
PK_OrderDetails |  |
IX_order_details_prodid |  |
Total: 3 index(s)

See Also

Table [Order_details]


Index: CI_order_details_orderid_prodid on table dbo.Order_details

Properties

Size KB: | 48
Fill Factor: | 90
Don't Recompute Statistics: |
Pad Index: |
Unique Index: |
Primary Key Index: |
Clustered Index: |
Is computed column in index: |
Ignore Duplicates: |
Located On: | PRIMARY
Disabled: |

Index Columns

Name | Descending
OrderID | 0
ProductID | 0
Total: 2 column(s)

Statistics

Updated:
Average key length:
Density:
Rows in the table:
Rows sampled for statistics data:
Distribution steps:

SQL

CREATE CLUSTERED INDEX [CI_order_details_orderid_prodid] ON [dbo].[Order_details]([OrderID], [ProductID]) WITH FILLFACTOR = 90 ON [PRIMARY]
GO

See Also

List of indexes


Index: PK_OrderDetails on table dbo.Order_details

Properties

Size KB: | 16
Fill Factor: | 90
Don't Recompute Statistics: |
Pad Index: |
Unique Index: |
Primary Key Index: |
Clustered Index: |
Is computed column in index: |
Ignore Duplicates: |
Located On: | PRIMARY
Disabled: |

Index Columns

Name | Descending
OrderID | 0
ProductID | 0
Total: 2 column(s)

Statistics

Updated:
Average key length:
Density:
Rows in the table:
Rows sampled for statistics data:
Distribution steps:

SQL

CREATE UNIQUE INDEX [PK_OrderDetails] ON [dbo].[Order_details]([OrderID], [ProductID]) WITH FILLFACTOR = 90 ON [PRIMARY]
GO

See Also

List of indexes


Index: IX_order_details_prodid on table dbo.Order_details

Properties

Size KB: | 16
Fill Factor: | 90
Don't Recompute Statistics: |
Pad Index: |
Unique Index: |
Primary Key Index: |
Clustered Index: |
Is computed column in index: |
Ignore Duplicates: |
Located On: | PRIMARY
Disabled: |

Index Columns

Name | Descending
ProductID | 0
Total: 1 column(s)

Statistics

Updated:
Average key length:
Density:
Rows in the table:
Rows sampled for statistics data:
Distribution steps:

SQL

CREATE INDEX [IX_order_details_prodid] ON [dbo].[Order_details]([ProductID]) WITH FILLFACTOR = 90 ON [PRIMARY]
GO

See Also

List of indexes


List of relationships on [Order_details]

Relationships

Table | Foreign Key | Primary Key or Unique Constraint
Orders | FK_OrderDetails_Orders | PK_Orders
Total: 1 relationship(s)

See Also

Table [Order_details]


Relationship: [FK_OrderDetails_Orders] on [Order_details]

Properties

Primary Table Owner: | dbo
Primary Table: | Orders
Primary Key or Unique Constraint: | PK_Orders
Delete Cascade: |
Update Cascade: |

Relationship Columns

Column | Reference Column | Type
OrderID | OrderID | int
Total: 1 trigger(s)

SQL

ALTER TABLE [dbo].[Order_details] ADD CONSTRAINT [FK_OrderDetails_Orders] FOREIGN KEY
(
[OrderID]
) REFERENCES [Orders] (
[OrderID]
) ON DELETE CASCADE ON UPDATE CASCADE NOT FOR REPLICATION
GO

See Also

Table [Orders]
Table [Order_details]


Table: Orders

Properties

Owner: | dbo
Creation Date: | 02.14.2006
ID: | 2041058307
Located On: | PRIMARY
Rows: | 3
Data Size KB: | 8
Index Size KB: | 40
Description: |

Columns

Name | Data Type | Length | NULL | Default | IsGUID | Description
OrderID | int | 4 |  |  |  |
CustomerID | int | 4 |  |  |  |
OrderDate | datetime | 8 |  |  |  |
ShipDate | datetime | 8 |  |  |  |
Total: 4 column(s)

Indexes

Index | Primary | Unique
PK_Orders |  |
IX_Orders_custid |  |
Total: 2 indexes(s)

Identity column

Total: 1 identity columns

Referencing Tables

Table | Foreign Key | Primary Key or Unique Constraint
Order_details | FK_OrderDetails_Orders | PK_Orders

Referenced Tables

Table | Foreign Key | Primary Key or Unique Constraint
Customers | FK_Orders_Customers | PK_Customers

Objects that [dbo].[Orders] depends on

Object Name | Owner | Object Type | Dep Level
Customers | dbo | Table | 1
Total: 1 objects

Objects that depend on [dbo].[Orders]

Object Name | Owner | Object Type | Dep Level
Order_details | dbo | Table | 1
InsertOrder | dbo | Procedure | 1
InsertOrder_Details | dbo | Procedure | 2
Total: 3 objects

SQL

CREATE TABLE [Orders] (
[OrderID] [int] IDENTITY (1, 1) NOT NULL ,
[CustomerID] [int] NOT NULL ,
[OrderDate] [datetime] NOT NULL CONSTRAINT [DF_Orders_OrderDate] DEFAULT (getdate()),
[ShipDate] [datetime] NOT NULL CONSTRAINT [DF_Orders_ShipDate] DEFAULT (getdate()),
CONSTRAINT [PK_Orders] PRIMARY KEY NONCLUSTERED
(
[OrderID]
) WITH FILLFACTOR = 90 ON [PRIMARY] ,
CONSTRAINT [FK_Orders_Customers] FOREIGN KEY
(
[CustomerID]
) REFERENCES [Customers] (
[CustomerID]
) ON DELETE CASCADE ON UPDATE CASCADE NOT FOR REPLICATION
) ON [PRIMARY]
GO

See Also

List of tables


List of indexes on [Orders]

Indexes

Index | Primary | Unique
PK_Orders |  |
IX_Orders_custid |  |
Total: 2 index(s)

See Also

Table [Orders]


Index: PK_Orders on table dbo.Orders

Properties

Size KB: | 16
Fill Factor: | 90
Don't Recompute Statistics: |
Pad Index: |
Unique Index: |
Primary Key Index: |
Clustered Index: |
Is computed column in index: |
Ignore Duplicates: |
Located On: | PRIMARY
Disabled: |

Index Columns

Name | Descending
OrderID | 0
Total: 1 column(s)

Statistics

Updated:
Average key length:
Density:
Rows in the table:
Rows sampled for statistics data:
Distribution steps:

SQL

CREATE UNIQUE INDEX [PK_Orders] ON [dbo].[Orders]([OrderID]) WITH FILLFACTOR = 90 ON [PRIMARY]
GO

See Also

List of indexes


Index: IX_Orders_custid on table dbo.Orders

Properties

Size KB: | 16
Fill Factor: | 90
Don't Recompute Statistics: |
Pad Index: |
Unique Index: |
Primary Key Index: |
Clustered Index: |
Is computed column in index: |
Ignore Duplicates: |
Located On: | PRIMARY
Disabled: |

Index Columns

Name | Descending
CustomerID | 0
Total: 1 column(s)

Statistics

Updated:
Average key length:
Density:
Rows in the table:
Rows sampled for statistics data:
Distribution steps:

SQL

CREATE INDEX [IX_Orders_custid] ON [dbo].[Orders]([CustomerID]) WITH FILLFACTOR = 90 ON [PRIMARY]
GO

See Also

List of indexes


List of relationships on [Orders]

Relationships

Table | Foreign Key | Primary Key or Unique Constraint
Customers | FK_Orders_Customers | PK_Customers
Total: 1 relationship(s)

See Also

Table [Orders]


Relationship: [FK_Orders_Customers] on [Orders]

Properties

Primary Table Owner: | dbo
Primary Table: | Customers
Primary Key or Unique Constraint: | PK_Customers
Delete Cascade: |
Update Cascade: |

Relationship Columns

Column | Reference Column | Type
CustomerID | CustomerID | int
Total: 1 trigger(s)

SQL

ALTER TABLE [dbo].[Orders] ADD CONSTRAINT [FK_Orders_Customers] FOREIGN KEY
(
[CustomerID]
) REFERENCES [Customers] (
[CustomerID]
) ON DELETE CASCADE ON UPDATE CASCADE NOT FOR REPLICATION
GO

See Also

Table [Customers]
Table [Orders]


Table: Products

Properties

Owner: | dbo
Creation Date: | 02.14.2006
ID: | 2057058364
Located On: | PRIMARY
Rows: | 13
Data Size KB: | 8
Index Size KB: | 64
Description: |

Columns

Name | Data Type | Length | NULL | Default | IsGUID | Description
ProductID | int | 4 |  |  |  |
CategoryID | int | 4 |  |  |  |
ModelNumber | varchar | 50 |  |  |  |
ModelName | varchar | 50 |  |  |  |
ProductImage | varchar | 50 |  |  |  |
UnitCost | money | 8 |  |  |  |
Description | varchar | 8000 |  |  |  |
Total: 7 column(s)

Indexes

Index | Primary | Unique
CI_Products_catid_prodid |  |
PK_Products |  |
IX_Products_catid |  |
IX_Products_prodid |  |
Total: 4 indexes(s)

Identity column

Total: 1 identity columns

Referencing Tables

Table | Foreign Key | Primary Key or Unique Constraint
Reviews | FK_Reviews_Products | PK_Products

Referenced Tables

Table | Foreign Key | Primary Key or Unique Constraint
Categories | FK_Products_Categories | PK_Categories

Objects that [dbo].[Products] depends on

Object Name | Owner | Object Type | Dep Level
Categories | dbo | Table | 1
Total: 1 objects

Objects that depend on [dbo].[Products]

Object Name | Owner | Object Type | Dep Level
Reviews | dbo | Table | 1
DeleteProduct | dbo | Procedure | 1
InsertProduct | dbo | Procedure | 1
SelectAllProducts | dbo | Procedure | 1
SelectProductById | dbo | Procedure | 1
SelectProducts | dbo | Procedure | 1
UpdateProduct | dbo | Procedure | 1
Total: 7 objects

SQL

CREATE TABLE [Products] (
[ProductID] [int] IDENTITY (1, 1) NOT NULL ,
[CategoryID] [int] NOT NULL ,
[ModelNumber] [varchar] (50) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
[ModelName] [varchar] (50) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
[ProductImage] [varchar] (50) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
[UnitCost] [money] NOT NULL ,
[Description] [varchar] (8000) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
CONSTRAINT [PK_Products] PRIMARY KEY NONCLUSTERED
(
[ProductID]
) WITH FILLFACTOR = 90 ON [PRIMARY] ,
CONSTRAINT [FK_Products_Categories] FOREIGN KEY
(
[CategoryID]
) REFERENCES [Categories] (
[CategoryID]
)
) ON [PRIMARY]
GO

See Also

List of tables


List of indexes on [Products]

Indexes

Index | Primary | Unique
CI_Products_catid_prodid |  |
PK_Products |  |
IX_Products_catid |  |
IX_Products_prodid |  |
Total: 4 index(s)

See Also

Table [Products]


Index: CI_Products_catid_prodid on table dbo.Products

Properties

Size KB: | 64
Fill Factor: | 90
Don't Recompute Statistics: |
Pad Index: |
Unique Index: |
Primary Key Index: |
Clustered Index: |
Is computed column in index: |
Ignore Duplicates: |
Located On: | PRIMARY
Disabled: |

Index Columns

Name | Descending
ProductID | 0
CategoryID | 0
Total: 2 column(s)

Statistics

Updated:
Average key length:
Density:
Rows in the table:
Rows sampled for statistics data:
Distribution steps:

SQL

CREATE CLUSTERED INDEX [CI_Products_catid_prodid] ON [dbo].[Products]([ProductID], [CategoryID]) WITH FILLFACTOR = 90 ON [PRIMARY]
GO

See Also

List of indexes


Index: PK_Products on table dbo.Products

Properties

Size KB: | 16
Fill Factor: | 90
Don't Recompute Statistics: |
Pad Index: |
Unique Index: |
Primary Key Index: |
Clustered Index: |
Is computed column in index: |
Ignore Duplicates: |
Located On: | PRIMARY
Disabled: |

Index Columns

Name | Descending
ProductID | 0
Total: 1 column(s)

Statistics

Updated:
Average key length:
Density:
Rows in the table:
Rows sampled for statistics data:
Distribution steps:

SQL

CREATE UNIQUE INDEX [PK_Products] ON [dbo].[Products]([ProductID]) WITH FILLFACTOR = 90 ON [PRIMARY]
GO

See Also

List of indexes


Index: IX_Products_catid on table dbo.Products

Properties

Size KB: | 16
Fill Factor: | 90
Don't Recompute Statistics: |
Pad Index: |
Unique Index: |
Primary Key Index: |
Clustered Index: |
Is computed column in index: |
Ignore Duplicates: |
Located On: | PRIMARY
Disabled: |

Index Columns

Name | Descending
CategoryID | 0
Total: 1 column(s)

Statistics

Updated:
Average key length:
Density:
Rows in the table:
Rows sampled for statistics data:
Distribution steps:

SQL

CREATE INDEX [IX_Products_catid] ON [dbo].[Products]([CategoryID]) WITH FILLFACTOR = 90 ON [PRIMARY]
GO

See Also

List of indexes


Index: IX_Products_prodid on table dbo.Products

Properties

Size KB: | 16
Fill Factor: | 90
Don't Recompute Statistics: |
Pad Index: |
Unique Index: |
Primary Key Index: |
Clustered Index: |
Is computed column in index: |
Ignore Duplicates: |
Located On: | PRIMARY
Disabled: |

Index Columns

Name | Descending
ProductID | 0
Total: 1 column(s)

Statistics

Updated:
Average key length:
Density:
Rows in the table:
Rows sampled for statistics data:
Distribution steps:

SQL

CREATE INDEX [IX_Products_prodid] ON [dbo].[Products]([ProductID]) WITH FILLFACTOR = 90 ON [PRIMARY]
GO

See Also

List of indexes


List of relationships on [Products]

Relationships

Table | Foreign Key | Primary Key or Unique Constraint
Categories | FK_Products_Categories | PK_Categories
Total: 1 relationship(s)

See Also

Table [Products]


Relationship: [FK_Products_Categories] on [Products]

Properties

Primary Table Owner: | dbo
Primary Table: | Categories
Primary Key or Unique Constraint: | PK_Categories
Delete Cascade: |
Update Cascade: |

Relationship Columns

Column | Reference Column | Type
CategoryID | CategoryID | int
Total: 1 trigger(s)

SQL

ALTER TABLE [dbo].[Products] ADD CONSTRAINT [FK_Products_Categories] FOREIGN KEY
(
[CategoryID]
) REFERENCES [Categories] (
[CategoryID]
)
GO

See Also

Table [Categories]
Table [Products]


Table: Reviews

Properties

Owner: | dbo
Creation Date: | 02.14.2006
ID: | 2073058421
Located On: | PRIMARY
Rows: | 0
Data Size KB: | 0
Index Size KB: | 0
Description: |

Columns

Name | Data Type | Length | NULL | Default | IsGUID | Description
ReviewID | int | 4 |  |  |  |
ProductID | int | 4 |  |  |  |
CustomerName | varchar | 50 |  |  |  |
CustomerEmail | varchar | 50 |  |  |  |
Rating | int | 4 |  |  |  |
Comments | varchar | 8000 |  |  |  |
Total: 6 column(s)

Identity column

Total: 1 identity columns

Referenced Tables

Table | Foreign Key | Primary Key or Unique Constraint
Products | FK_Reviews_Products | PK_Products

Objects that [dbo].[Reviews] depends on

Object Name | Owner | Object Type | Dep Level
Categories | dbo | Table | 1
Products | dbo | Table | 2
Total: 2 objects

SQL

CREATE TABLE [Reviews] (
[ReviewID] [int] IDENTITY (1, 1) NOT NULL ,
[ProductID] [int] NOT NULL ,
[CustomerName] [varchar] (50) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
[CustomerEmail] [varchar] (50) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
[Rating] [int] NOT NULL ,
[Comments] [varchar] (8000) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL ,
CONSTRAINT [FK_Reviews_Products] FOREIGN KEY
(
[ProductID]
) REFERENCES [Products] (
[ProductID]
) NOT FOR REPLICATION
) ON [PRIMARY]
GO

See Also

List of tables


List of relationships on [Reviews]

Relationships

Table | Foreign Key | Primary Key or Unique Constraint
Products | FK_Reviews_Products | PK_Products
Total: 1 relationship(s)

See Also

Table [Reviews]


Relationship: [FK_Reviews_Products] on [Reviews]

Properties

Primary Table Owner: | dbo
Primary Table: | Products
Primary Key or Unique Constraint: | PK_Products
Delete Cascade: |
Update Cascade: |

Relationship Columns

Column | Reference Column | Type
ProductID | ProductID | int
Total: 1 trigger(s)

SQL

ALTER TABLE [dbo].[Reviews] ADD CONSTRAINT [FK_Reviews_Products] FOREIGN KEY
(
[ProductID]
) REFERENCES [Products] (
[ProductID]
) NOT FOR REPLICATION
GO

See Also

Table [Products]
Table [Reviews]


List of stored procedures

Stored procedures

Name | Owner | Description
DeleteProduct | dbo |
InsertCartTask | dbo |
InsertOrder | dbo |
InsertOrder_Details | dbo |
InsertProduct | dbo |
SelectAllCategories | dbo |
SelectAllProducts | dbo |
SelectCartTask | dbo |
SelectCartTaskByCustomerId | dbo |
SelectCartTaskByTaskId | dbo |
SelectCustomerByEmail | dbo |
SelectCustomerById | dbo |
SelectProductById | dbo |
SelectProducts | dbo |
UpdateProduct | dbo |
Total: 15 stored procedure(s)

See Also

Database overview


Stored Procedure: DeleteProduct

Properties

Owner: | dbo
Encrypted: |
Creation Date: | 02.14.2006
Description: |

Creation options

QUOTED_IDENTIFIER:
ANSI_NULLS:

Parameters

Name | Direction | DataType | Length
@ProductID | INPUT | int | 4
Total: 1 parameter(s)

Objects that [dbo].[DeleteProduct] depends on

Object Name | Owner | Object Type | Dep Level
Categories | dbo | Table | 1
Products | dbo | Table | 2
Total: 2 object(s)

SQL

CREATE PROCEDURE DeleteProduct
@ProductID int

AS

Delete
Products
Where
ProductID = @ProductID

See Also

List of stored procedures


Stored Procedure: InsertCartTask

Properties

Owner: | dbo
Encrypted: |
Creation Date: | 02.14.2006
Description: |

Creation options

QUOTED_IDENTIFIER:
ANSI_NULLS:

Parameters

Name | Direction | DataType | Length
@CustomerID | INPUT | int | 4
@TaskID | INPUT | uniqueidentifier | 16
Total: 2 parameter(s)

Objects that [dbo].[InsertCartTask] depends on

Object Name | Owner | Object Type | Dep Level
Customers | dbo | Table | 1
CartTasks | dbo | Table | 2
Total: 2 object(s)

SQL

SET QUOTED_IDENTIFIER ON
GO

CREATE PROCEDURE InsertCartTask
@CustomerID int,
@TaskID uniqueidentifier

AS

Insert into CartTasks( CustomerID, TaskID ) values ( @CustomerID, @TaskID )

GO
SET QUOTED_IDENTIFIER OFF
GO

See Also

List of stored procedures


Stored Procedure: InsertOrder

Properties

Owner: | dbo
Encrypted: |
Creation Date: | 02.14.2006
Description: |

Creation options

QUOTED_IDENTIFIER:
ANSI_NULLS:

Parameters

Name | Direction | DataType | Length
@CustomerID | INPUT | int | 4
@OrderDate | INPUT | datetime | 8
@ShipDate | INPUT | datetime | 8
Total: 3 parameter(s)

Objects that [dbo].[InsertOrder] depends on

Object Name | Owner | Object Type | Dep Level
Customers | dbo | Table | 1
Orders | dbo | Table | 2
Total: 2 object(s)

SQL

CREATE PROCEDURE InsertOrder
@CustomerID int,
@OrderDate datetime,
@ShipDate datetime

AS

Insert into Orders ( CustomerID, OrderDate, ShipDate ) Values ( @CustomerID, @OrderDate, @ShipDate )
return SCOPE_IDENTITY()

See Also

List of stored procedures


Stored Procedure: InsertOrder_Details

Properties

Owner: | dbo
Encrypted: |
Creation Date: | 02.14.2006
Description: |

Creation options

QUOTED_IDENTIFIER:
ANSI_NULLS:

Parameters

Name | Direction | DataType | Length
@OrderID | INPUT | int | 4
@ProductID | INPUT | int | 4
@Quantity | INPUT | int | 4
@UnitCost | INPUT | money | 8
Total: 4 parameter(s)

Objects that [dbo].[InsertOrder_Details] depends on

Object Name | Owner | Object Type | Dep Level
Customers | dbo | Table | 1
Orders | dbo | Table | 2
Order_details | dbo | Table | 3
Total: 3 object(s)

SQL

CREATE PROCEDURE InsertOrder_Details
@OrderID int,
@ProductID int,
@Quantity int,
@UnitCost money

AS

Insert into Order_Details( OrderID, ProductID, Quantity, UnitCost ) Values ( @OrderID, @ProductID, @Quantity, @UnitCost )

See Also

List of stored procedures


Stored Procedure: InsertProduct

Properties

Owner: | dbo
Encrypted: |
Creation Date: | 02.14.2006
Description: |

Creation options

QUOTED_IDENTIFIER:
ANSI_NULLS:

Parameters

Name | Direction | DataType | Length
@CategoryID | INPUT | int | 4
@ModelNumber | INPUT | varchar | 50
@ModelName | INPUT | varchar | 50
@ProductImage | INPUT | varchar | 50
@UnitCost | INPUT | money | 8
@Description | INPUT | varchar | 8000
Total: 6 parameter(s)

Objects that [dbo].[InsertProduct] depends on

Object Name | Owner | Object Type | Dep Level
Categories | dbo | Table | 1
Products | dbo | Table | 2
Total: 2 object(s)

SQL

CREATE PROCEDURE InsertProduct
@CategoryID int,
@ModelNumber varchar(50),
@ModelName varchar(50),
@ProductImage varchar(50),
@UnitCost money,
@Description varchar(8000)

AS

Insert into Products ( CategoryID, ModelNumber, ModelName, ProductImage, UnitCost, [Description] )
Values ( @CategoryID, @ModelNumber, @ModelName, @ProductImage, @UnitCost, @Description )

See Also

List of stored procedures


Stored Procedure: SelectAllCategories

Properties

Owner: | dbo
Encrypted: |
Creation Date: | 02.14.2006
Description: |

Creation options

QUOTED_IDENTIFIER:
ANSI_NULLS:

Objects that [dbo].[SelectAllCategories] depends on

Object Name | Owner | Object Type | Dep Level
Categories | dbo | Table | 1
Total: 1 object(s)

SQL

CREATE PROCEDURE SelectAllCategories
AS

Select *
From categories

See Also

List of stored procedures


Stored Procedure: SelectAllProducts

Properties

Owner: | dbo
Encrypted: |
Creation Date: | 02.14.2006
Description: |

Creation options

QUOTED_IDENTIFIER:
ANSI_NULLS:

Objects that [dbo].[SelectAllProducts] depends on

Object Name | Owner | Object Type | Dep Level
Categories | dbo | Table | 1
Products | dbo | Table | 2
Total: 2 object(s)

SQL

CREATE PROCEDURE SelectAllProducts
AS

Select *
From products

See Also

List of stored procedures


Stored Procedure: SelectCartTask

Properties

Owner: | dbo
Encrypted: |
Creation Date: | 02.14.2006
Description: |

Creation options

QUOTED_IDENTIFIER:
ANSI_NULLS:

Parameters

Name | Direction | DataType | Length
@CustomerID | INPUT | int | 4
Total: 1 parameter(s)

Objects that [dbo].[SelectCartTask] depends on

Object Name | Owner | Object Type | Dep Level
Customers | dbo | Table | 1
CartTasks | dbo | Table | 2
Total: 2 object(s)

SQL

SET QUOTED_IDENTIFIER ON
GO

CREATE PROCEDURE SelectCartTask
@CustomerID int

AS

Select
TaskID
From
CartTasks
Where
CustomerID = @CustomerID

GO
SET QUOTED_IDENTIFIER OFF
GO

See Also

List of stored procedures


Stored Procedure: SelectCartTaskByCustomerId

Properties

Owner: | dbo
Encrypted: |
Creation Date: | 02.14.2006
Description: |

Creation options

QUOTED_IDENTIFIER:
ANSI_NULLS:

Parameters

Name | Direction | DataType | Length
@CustomerID | INPUT | int | 4
Total: 1 parameter(s)

Objects that [dbo].[SelectCartTaskByCustomerId] depends on

Object Name | Owner | Object Type | Dep Level
Customers | dbo | Table | 1
CartTasks | dbo | Table | 2
Total: 2 object(s)

SQL

SET QUOTED_IDENTIFIER ON
GO

CREATE PROCEDURE SelectCartTaskByCustomerId
@CustomerID int

AS

Select
TaskID
From
CartTasks
Where
CustomerID = @CustomerID

GO
SET QUOTED_IDENTIFIER OFF
GO

See Also

List of stored procedures


Stored Procedure: SelectCartTaskByTaskId

Properties

Owner: | dbo
Encrypted: |
Creation Date: | 02.14.2006
Description: |

Creation options

QUOTED_IDENTIFIER:
ANSI_NULLS:

Parameters

Name | Direction | DataType | Length
@TaskID | INPUT | uniqueidentifier | 16
Total: 1 parameter(s)

Objects that [dbo].[SelectCartTaskByTaskId] depends on

Object Name | Owner | Object Type | Dep Level
Customers | dbo | Table | 1
CartTasks | dbo | Table | 2
Total: 2 object(s)

SQL

CREATE PROCEDURE SelectCartTaskByTaskId
@TaskID uniqueidentifier

AS

Select
CustomerID
From
CartTasks
Where
TaskID = @TaskID

See Also

List of stored procedures


Stored Procedure: SelectCustomerByEmail

Properties

Owner: | dbo
Encrypted: |
Creation Date: | 02.14.2006
Description: |

Creation options

QUOTED_IDENTIFIER:
ANSI_NULLS:

Parameters

Name | Direction | DataType | Length
@EmailAddress | INPUT | varchar | 100
Total: 1 parameter(s)

Objects that [dbo].[SelectCustomerByEmail] depends on

Object Name | Owner | Object Type | Dep Level
Customers | dbo | Table | 1
Total: 1 object(s)

SQL

SET QUOTED_IDENTIFIER ON
GO

CREATE PROCEDURE SelectCustomerByEmail
@EmailAddress varchar(100)

AS

Select *
From Customers
Where EmailAddress = @EmailAddress

GO
SET QUOTED_IDENTIFIER OFF
GO

See Also

List of stored procedures


Stored Procedure: SelectCustomerById

Properties

Owner: | dbo
Encrypted: |
Creation Date: | 02.14.2006
Description: |

Creation options

QUOTED_IDENTIFIER:
ANSI_NULLS:

Parameters

Name | Direction | DataType | Length
@CustomerID | INPUT | int | 4
Total: 1 parameter(s)

Objects that [dbo].[SelectCustomerById] depends on

Object Name | Owner | Object Type | Dep Level
Customers | dbo | Table | 1
Total: 1 object(s)

SQL

SET QUOTED_IDENTIFIER ON
GO

CREATE PROCEDURE SelectCustomerById
@CustomerID int

AS

Select *
From Customers
Where CustomerID = @CustomerID

GO
SET QUOTED_IDENTIFIER OFF
GO

See Also

List of stored procedures


Stored Procedure: SelectProductById

Properties

Owner: | dbo
Encrypted: |
Creation Date: | 02.14.2006
Description: |

Creation options

QUOTED_IDENTIFIER:
ANSI_NULLS:

Parameters

Name | Direction | DataType | Length
@ProductID | INPUT | int | 4
Total: 1 parameter(s)

Objects that [dbo].[SelectProductById] depends on

Object Name | Owner | Object Type | Dep Level
Categories | dbo | Table | 1
Products | dbo | Table | 2
Total: 2 object(s)

SQL

CREATE PROCEDURE SelectProductById
@ProductID int
AS

Select *
From products
Where ProductID = @ProductID

See Also

List of stored procedures


Stored Procedure: SelectProducts

Properties

Owner: | dbo
Encrypted: |
Creation Date: | 02.14.2006
Description: |

Creation options

QUOTED_IDENTIFIER:
ANSI_NULLS:

Parameters

Name | Direction | DataType | Length
@product_id | INPUT | int | 4
Total: 1 parameter(s)

Objects that [dbo].[SelectProducts] depends on

Object Name | Owner | Object Type | Dep Level
Categories | dbo | Table | 1
Products | dbo | Table | 2
Total: 2 object(s)

SQL

CREATE PROCEDURE SelectProducts
@product_id integer
AS
SET NOCOUNT ON
select ProductID,
CategoryID,
ModelNumber,
ModelName,
ProductImage,
UnitCost,
[Description]
from products
where
ProductID = @product_id

See Also

List of stored procedures


Stored Procedure: UpdateProduct

Properties

Owner: | dbo
Encrypted: |
Creation Date: | 02.14.2006
Description: |

Creation options

QUOTED_IDENTIFIER:
ANSI_NULLS:

Parameters

Name | Direction | DataType | Length
@ProductID | INPUT | int | 4
@CategoryID | INPUT | int | 4
@ModelNumber | INPUT | varchar | 50
@ModelName | INPUT | varchar | 50
@ProductImage | INPUT | varchar | 50
@UnitCost | INPUT | money | 8
@Description | INPUT | varchar | 8000
Total: 7 parameter(s)

Objects that [dbo].[UpdateProduct] depends on

Object Name | Owner | Object Type | Dep Level
Categories | dbo | Table | 1
Products | dbo | Table | 2
Total: 2 object(s)

SQL

CREATE PROCEDURE UpdateProduct
@ProductID int,
@CategoryID int,
@ModelNumber varchar(50),
@ModelName varchar(50),
@ProductImage varchar(50),
@UnitCost money,
@Description varchar(8000)

AS

Update
Products
Set
CategoryID = @CategoryID,
ModelNumber = @ModelNumber,
ModelName = @ModelName,
ProductImage = @ProductImage,
UnitCost = @UnitCost,
[Description] = @Description
Where
ProductID = @ProductID

See Also

List of stored procedures


Server Info

Properties

Network Name: | PDCN
Language: | Cyrillic_General_CI_AS

Version

Microsoft SQL Server 2000 - 8.00.2039 (Intel X86)
May 3 2005 23:18:38
Copyright (c) 1988-2003 Microsoft Corporation
Enterprise Edition on Windows NT 5.0 (Build 2195: Service Pack 4)

Databases

Database | Owner | System
UIPState | sa |
UIPstore | sa |
Total: 2 database(s)

Server Configuration

Name | Value
Maximum recovery interval in minutes | 0
Allow updates to system tables | 0
Number of user connections allowed | 0
Number of locks for all users | 0
Number of open database objects | 0
Default fill factor percentage | 0
Allow triggers to be invoked within triggers | 1
Allow remote access | 1
default language | 0
Cross DB Ownership Chaining | 0
Maximum worker threads | 255
Network packet size | 4096
show advanced options | 1
Create DTC transaction for remote procedures | 0
c2 audit mode | 0
default full-text language | 1033
two digit year cutoff | 2049
Memory for index create sorts (kBytes) | 0
Priority boost | 0
remote login timeout | 20
remote query timeout | 600
cursor threshold | -1
set working set size | 0
user options | 0
affinity mask | 0
Maximum size of a text field in replication. | 65536
Tape retention period in days | 0
cost threshold for parallelism | 5
maximum degree of parallelism | 0
minimum memory per query (kBytes) | 1024
maximum time to wait for query memory (s) | -1
Minimum size of server memory (MB) | 0
Maximum size of server memory (MB) | 2147483647
Maximum estimated cost allowed by query governor | 0
User mode scheduler uses lightweight pooling | 0
scan for startup stored procedures | 0
AWE enabled in the server | 0
affinity64 mask | 0


List of logins

Logins

Name | Login Type | Default Database
sa | SQL Server standard | master
BUILTIN\Administrators | Windows security group | master
Total: 2 login(s)

See Also

Server overview


Login: sa

Properties

Name: | sa
Friendly Name: | English
System: |
Default Database: | master
Deny Windows Security Authenticated Connections: |
Type: | SQL Server standard
Permissions to Access the Server: |

Users with this login

Database | User
master | dbo
tempdb | dbo
model | dbo
msdb | dbo
pubs | dbo
Northwind | dbo
aanf | dbo
almirante | dbo
antinucciIT | dbo
aspnetstore | dbo
B_INDA | dbo
BIC | dbo
cast | dbo
ciak | dbo
CompulsionAsset | dbo
distmodel | dbo
farmacia | dbo
immobiliare | dbo
isvema | dbo
ivd | dbo
juli | dbo
lportal | dbo
mb_pg | dbo
metamedica | dbo
mGiove | dbo
MTC | dbo
ofbiz_ap | dbo
ofbiz | dbo
ofbiz_mnet | dbo
ofbiz2 | dbo
OLAP_REPOSOTORY_SPAIN | dbo
privacy | dbo
QM | dbo
regina | dbo
RIO_WEB | dbo
romesweethome | dbo
SICVE_TEST | dbo
student | dbo
sun_marte | dbo
sun_terra | dbo
sun_terra_door | dbo
sun_terra_terminal | dbo
sun_venus | dbo
sun2_marte | dbo
sun2_marte2 | dbo
sun2_terra | dbo
SUSDB | dbo
Terra | dbo
Terra_copy | dbo
TERRA_DOOR | dbo
terra_v2 | dbo
Test | dbo
UIPState | dbo
UIPstore | dbo
uVersion | dbo
WH_TEST | dbo

Roles with this Login

Role
sysadmin

SQL

if not exists (select * from master.dbo.syslogins where loginname = N'sa')
BEGIN
declare @logindb nvarchar(132), @loginlang nvarchar(132) select @logindb = N'master', @loginlang = N'us_english'
if @logindb is null or not exists (select * from master.dbo.sysdatabases where name = @logindb)
select @logindb = N'master'
if @loginlang is null or (not exists (select * from master.dbo.syslanguages where name = @loginlang) and @loginlang <> N'us_english')
select @loginlang = @@language
exec sp_addlogin N'sa', null, @logindb, @loginlang
END
GO

See Also

Server overview
Logins list


Login: BUILTIN\Administrators

Properties

Name: | BUILTIN\Administrators
Friendly Name: | English
System: |
Default Database: | master
Deny Windows Security Authenticated Connections: |
Type: | Windows security group
Permissions to Access the Server: |

Roles with this Login

Role
sysadmin

SQL

if not exists (select * from master.dbo.syslogins where loginname = N'BUILTIN\Administrators')
exec sp_grantlogin N'BUILTIN\Administrators'
exec sp_defaultdb N'BUILTIN\Administrators', N'master'
exec sp_defaultlanguage N'BUILTIN\Administrators', N'us_english'
GO

See Also

Server overview
Logins list


About

Documentation details

Customer: |
Project: |
Created: | 02.19.2007